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HDL Synthesis Design with LeonardoSpectrum: CPLD Flow

This tutorial shows you how to use LeonardoSpectrum from within ispLEVER® to
synthesize a Verilog design and generate an EDIF file for a Lattice CPLD device.

Note: If you want to learn how to use LeonardoSpectrum in standalone mode or understand more about
its advanced features, please see the third-party manuals online by choosing Help > ispLEVER
Documentation Library from the ispLEVER Project Navigator.

Learning Objectives
When you have completed this tutorial, you should be able to do the following:
o Create a new EDIF project in the ispLEVER system and target a device.

o Start LeonardoSpectrum from within the Project Navigator, synthesize your Verilog
design, and generate an EDIF netlist file.

o Import the EDIF file into the ispLEVER system, fit the design, generate a JEDEC
file, and view the Fitter report.

o Perform static timing analysis using the Performance Analyst and view the results.

Time to Complete This Tutorial
The time to complete this tutorial is about 20 minutes.

System Requirements

One of the following software configurations is required to complete the tutorial:

« ISpLEVER Starter

e iSpLEVER Base

e iSpLEVER Advanced

e iSpLEVER Advanced System with active Mentor Graphics LeonardoSpectrum
license

Accessing Online Help

You can find online help information on any tool included in the tutorial at any time by

pressing the F1 key.

About the Tutorial Design

The tutorial design consists of a simple set of equal-to, greater-than, and less-than data
comparators, as shown in the following figure:
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This tutorial first directs you to create an EDIF project in the Project Navigator, then
select the target device in which the design will be implemented. The tutorial assumes
that functional simulation has already been performed. Next, you start
LeonardoSpectrum and open a new LeonardoSpectrum project. After you import the
VHDL source files and set the implementation options, the tool synthesizes the design
into the target device and generates an EDIF netlist.You then import the EDIF netlist
into the Project Navigator project and perform mapping, placing, and routing. Finally,
you perform a static timing analysis and examine the results.

About the Tutorial Data Flow

The following figure illustrates the design flow that the tutorial takes.You may find it
helpful to refer to this diagram as you move through the tutorial tasks.
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Task 1: Create a New Project

To begin a new project, you must create a project directory. Then you must give the
project file a name (. syn) and declare the project type (EDIF).

The ispLEVER software saves an initial design file with the .syn file extension in the
directory that you specify. All project files are copied to or created in this directory. The
project type specifies that all design sources will be of this type.

To create a new project:
1. Start the ispLEVER system, if it is not already running.

2. Inthe Project Navigator, choose File > New Project to open the Create New Project
dialog box.

3. Inthe dialog box, do the following:
e In the Project Name box, type mux.

« Inthe Location box, change to the following directory:
<install paths>\examples\tutorial\tutors3.

Note: If you want to preserve the original tutorial design files, save the tutor3 directory to
another location on your computer before proceeding.

e Inthe Design Entry Type box, choose EDIF.
e In the Synthesis Tools box, choose LeonardoSpectrum.
e Click Next to open the Project Wizard — Select Device dialog box.

© 2004 Lattice Semiconductor 5
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Task 2: Target a Device

In the Project Navigator Sources in Project window, the device icon %2 appears next to
the target device for the project. The Project Navigator enables you target a design to a
specific Lattice device at any time during the design process. The default device is
ispLSI5256VE-165LF256. For this project, you will target a different device.

To view the list of available devices and to change the target device:
1. Inthe Project Wizard — Select Device dialog box, do the following:
e Inthe Family box, select ispMACH4000.
« In the Device box, choose LC4256V.
o Accept the default settings for the rest of the boxes.
e Click Next to open the Project Wizard — Add Source dialog box.

x
— Select Device: — Device Infarmatian:

Eamily: Device: ;
Statuz: Froduction

izpkACH 4000 L C42REY _

spLSISOOVE ] [LCdzmecsien e || oo 10000
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izphdACH 443 LC4256W 160 120 cells: B4
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ispMacH 50008 x| [LC42562C =1 || 140 pins: B4
Dedicated input; &

Speed grade: [nz) Fackage type:
Dutput enahble:

[10 =] [1ooTaFR |t

. - loc: 12 md,

Operating conditions:

IIndustriaI j

Part Marne:

|LCa256v-10T 100 =]
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2. In the Project Wizard — Add Source dialog box, click Next, then click Finish.
Your Project Navigator should look like this:
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ispLEVER Tutorials
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Task 3: Start LeonardoSpectrum from ispLEVER

For HDL designs, the ispLEVER software provides two synthesis tools that are
integrated into the Project Navigator environment: LeonardoSpectrum and Synplify.
You can synthesize your Verilog or VHDL design as a standalone process by choosing
the synthesis tool from the Lattice Semiconductor program group in your Start menu, or
you can synthesize automatically and seamlessly within the Project Navigator.

LeonardoSpectrum for Lattice is a logic synthesis tool that starts with a high-level
design written in the Verilog or VHDL hardware description language (HDL). Then it
converts the HDL description into small, high-performance design netlists that are
optimized for Lattice devices.

When you start LeonardoSpectrum for the first time, the main window is maximized
and displays the Tip of the Day and an information screen.

To start LeonardoSpectrum:

1. In the Project Navigator, choose Tools > LeonardoSpectrum Synthesis to open the
LeonardoSpectrum synthesis tool. It may take a few moments to activate the tool.

2. Click OK to close the Tip of the Day.

There are three ways to synthesize your design: Quick Setup, Advanced Flow Tabs,
and Synthesis Wizard. In this tutorial, you will use the Quick Setup method.

3. Make sure the Quick Setup tab is selected on the toolbar.

Your screen should look similar to the following. If not, choose Tools > Quick
Setup.

© 2004 Lattice Semiconductor 9
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Task 4: Use Quick Setup to Synthesize the Design

Quick Setup is a push-button flow that you can use to achieve good first-pass synthesis
results. You specify the target technology, open your input design files, optionally set
the target clock frequency, and verify the name of the output netlist. When you click
Run Flow, the entire synthesis flow is executed from start to finish, including synthesis,
applying global constraints, optimization, and writing the netlist. The output is an EDIF
netlist that can be read by ispLEVER. Attributes that are placed on design objects by the
HDL source code and LeonardoSpectrum are converted to properties in the EDIF
netlist.

To synthesize the design:

1. On the Quick Setup tab under Technology, click the plus sign (+) in front of Lattice
to expand the tree view, and then select the ispmach4000V device family.

- ispGO -

- jgpG D2
- izpL51-1 IIIEIEIHEDEIEI;’EIJ

- izpL 515000

- izpL515000E
- izpL515000WE_old
- izpL 513000

- jgprnachd 1008
- igprnachd 000C
izprnachd Q00

- igprachB0006 il
1| i B

2. Inthe Input field, click the Open files icon to open the Set Input File(s) dialog box.

LeonardoSpectrum does not read pre-compiled HDL designs from disk. Instead, the
source files are read directly into memory where LeonardoSpectrum builds an
EDIF-like in-memory database.

3. Make sure that you are in the tutorial\tutor3 directory.

4. Select multiple.v and click Open.
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Laoak jr: Ia tutor3 j da EF T

mulkiple, w

File name: — |rutiple. v Open I
Files of type: [ Input Files [+ VERL* H VER.* YHD.* HC ¥ Carcel |
i~

LeonardoSpectrum automatically points the output file to the project directory and
places the file name in the Input box.

= |hput
mLltiple. v

Open files:
. . =
“whorking Directony: El

5. Directly below the Open Files icon, click the Working Directory icon to open the
Set Working Directory dialog box.

The working directory is where LeonardoSpectrum places all generated output files.
These files include the output files from the synthesis process. For ispLEVER
projects, you should make the working directory the same as your project directory.

6. Make sure the path is pointing to <instal I_path>\examples\tutorial\tutor3,
then click Set to close the dialog box.
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Note: Only a few files will be generated in this tutorial. Because many generated files can be
created in a real project, it is a good practice to separate your design source files and batch scripts
into a separate subdirectory. For example, the input source files could be kept in a subdirectory
named src. Then, if your first synthesis run generates the "fastest” possible circuit, you may want to
do one or more optional runs to evaluate the tradeoffs between speed and area. You can simply copy
the src subdirectory into a new working directory named "smallest,”” for example, and the new
generated files for the next run will be placed there.

7. At the bottom of the Quick Setup tab, click Run Flow.

LeonardoSpectrum reads the opened input files and creates an in-memory EDIF
style database called the RTL database. The design is composed of generic gates
and non-mapped (black box) modules such as operators, counters, and inferred
RAMs. Next, the in-memory design is mapped to the specified technology, globally
optimized, and the results for each module are saved. If a timing constraint is not
met at this point, additional critical-path optimizations are run to try to meet the
constraints. The results are kept in a second in-memory technology-mapped design
database. The output EDIF netlist and support files are then automatically generated
and written to the working directory.

The Critical Path Report appears in the right pane.

Note: The Run Flow button is not active until you have selected your Input File(s) and target
technology. When the synthesis process is complete, the Information window on the right says that
the run successfully ended.
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8. Choose File > Exit to exit LeonardoSpectrum. Click Yes in the confirmation box.
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Task 5: Import the EDIF File into Your Project

You can import EDIF 2 0 0 netlists from third-party synthesis tools, such as Synplify or
LeonardoSpectrum, into ispLEVER.

To import an EDIF netlist into your project:

9. Inthe ispLEVER Project Navigator, choose Source > Import to open the Import
File dialog box.

10. Select multiple_0.edf, and then click Open.

20 x|
Lok in: I'a bukor3 j = I.:._:.F En-

rultiple_0.edf

File name: — |ruitiple_0.edf Open |
Files of tupe: I Sources [t ed®: aby;) j Cancel |
s

The software adds the selected EDIF file (multiple_o0.edf) to the project sources.
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Note: After you import an EDIF file into the ispLEVER project, it is always linked to the Project
Navigator. Therefore, if you make changes and recompile your HDL file to create a new EDIF file,
your project is automatically updated as well.
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Task 6: Fit the Design and View the Report

The ispLEVER software has a single user interface with all options preset to deliver the
highest possible push-button performance for most devices. When you double-click a
process, all the processes prior to that process run automatically. Therefore, all you have
to do is double-click the final process. However, here you will run one process at a time
and view the results as you go.

At the end of a successful fitter run, the iSpLEVER software generates a JEDEC file, as

well as a fitter report, so that you can see how the ispLEVER software has utilized and
routed the part.

To run the Fitter and view the report:

1. With the target device selected in the Sources window, double-click Fit Design in
the Processes for Current Source window to run the Fitter.

The ispLEVER software successfully fits the design in the specified device and
generates a JEDEC file.

Optional: If you like, you can right-click on the JEDEC File process and select View to create and
look at the contents of the JEDEC file. Close the file when you are through.

B ispLE¥ER Project Navigator - [C:AISPTOOLSS _04%EXAMPLES' TUTORIAL TUTOR3 Y mux.s¥n i ] B
File Wiew 3Source Process Options Tools window Help
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[EIErE T ]
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& Constraink Editor
'3 Fit Desian
[E] Pre-Fit Equations
C? Signal Cross Reference
W Fitter Report
@[] HTML Fitter Repart
Past-Fit Pinouts
&, Fost-Fit Re-Compile
o” I8 JEDECFile
i 15C-1532 File
& Timing Analysis
Timing Report
¥} Generate Timing Simulation Files
@ Report File
¥ Generate Board-level Stamp Model
@ Stamp Madel File
fgl Stamp Model Data File

=[toa - Timing Driven Analyze ;I
Alver. 1.0, supported by Lattice Semiconductor
i=plEVER 5.00 Copyright 1992-2005 Lattice Semiconductor. All Rights Reserved.

Done: completed successfully.

Starting: 'C:»1spTOOLSS_0-ispcpld-~bin“svnsvi eze —-sxze "C:~ispTOOLS5_0%ispvnsystenispufw"

—prj I
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v
SI5T\ Automake Log /Tla| | il
Ready I_WI_ v
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2. Double-click the HTML Fitter Report process to open the report in your browser.

3. View the contents and then close the report.

. File Edit Wiew o Bookmarks Tools window Help
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=l =]

SN

{ FWeather  »

¥
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Project Summary
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FPostFit Equations Tools-»Fitter Report File Format...

Project Summary

Project Name D mux
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Project Fitted on : Thu Mar 10 15:00:47 zZ005
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Package H 100

GLE Input Mux Size : 33

Available Blocks : 16

Speed : -10

Part Number : LC4z256V-10T100I

Jource Format : EDIF
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Copyright(C), 1992-2005, Lattice Semiconductor Corporaticn
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Task 7: Perform Static Timing Analysis

HDL Synthesis Design with LeonardoSpectrum: CPLD Flow

Static timing analysis is the process of verifying circuit timing by totaling the
propagation delays along paths between clocked or combinational elements in a circuit.
The analysis can determine and report timing data such as the critical path, setup and

hold-time requirements, and the maximum frequency.

The Performance Analyst traces each logical path in the design and calculates the path
delays using the device’s timing model and worst-case AC specifications supplied in the

device data sheet.

The timing analysis results are displayed in a graphical spreadsheet with source signals
displayed on the vertical axis and destination signals displayed on the horizontal axis.
The worst-case delay value is displayed in a spreadsheet cell if there is at least one
delay path between the source and destination. To more easily identify performance
bottlenecks, you can double-click a cell to view the path delay details.

To perform timing analysis:

1. In the Project Navigator Sources in Project window, select the target device.

2. Inthe Processes for Current Source window, double-click the Timing Analysis
process to open the Performance Analyst.

=10l |
File iew Met Control Preferences Window Help
=d sl?
=10l x|
I Rt 11 DELAY TABLE
[Commercia <1 SOURCE Ll | DESTINATI. | DELAY (ns) | DELAY (MH...| Delay Cons... | Slack Ci

Speed grade:

— Analyziz
= [Max O 1Co
©osUAH 0 HDE
D " WCOE

CORCY O 2P

o |

r— Path Control
# of
Paths

 Dizplay paths langer than

ot
Bl:tﬂ:er af IU—

Set

For Help, press F1

[ um 14:59:09 4

The Performance Analyst performs seven distinct analysis types: fMAX, tSU/tH,
tPD, tCO, tOE, tCOE, and tP2P. The first type, fMAX, is an internal register-to-
register delay analysis. fMAX measures the maximum clock operating frequency,
limited by worst-case register-to-register delay. The tP2P type is the path between
any two user-specified pins. The remaining five types are external pin-to-pin delay
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analysis. Timing threshold filters, source and destination filters, and path filters can
be used to independently fine-tune each analysis.

3. Under Analysis, select tCO and then click Run.

The tCO path trace analysis reports clock-to-out delay starting from the primary
input, going through the clock of flip-flops or gate of latches, and ending at the
primary output. In this case, it is 12.95 ns.

Note: Your timing results may differ slightly.

EPerfurmance Analyst - Untitled - mux

File Wiew Preferences Window Help

=10l x|
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" PD " ICOE
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Run
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£pply | |D-D
Mumber of |4
delays

al

Longest delay
[T

Data Sheet
WVersion 3.2

SOURC..

lll Lintitled - mux

DEZTIN...

DELAY TABLE
_|LOGICL..

reg_data...

req_data...

reg_data...

=N RN

req_data...

Double click to expand path

Delay path = req_data_3_.C:z: 12,95

[ om 1zEmin g

Remember from Task 4 that the data arrival time was 7.0. This number was the
simulated estimate. Now, using the Performance Analyst, you can see the actual
delay of 9.64 ns.

4. Click the highlighted cell (12.95) in the spreadsheet window to open the Expanded
Path dialog box.

This dialog box enables you to analyze the individual timing components used to
calculate the timing path. It shows a source pin (From) and a destination pin (To). It
also shows the delay type, the delay of that path (value ns), and the cumulative
delay of all the signals.

© 2004 Lattice Semiconductor

20




ispLEVER Tutorials HDL Synthesis Design with LeonardoSpectrum: CPLD Flow

Expanded Path

Sourcesreg_data_3_.C Destination:z

’Tl Fraom Loc |Tao Loc | Delay Type [Yalue (ns) | Total {ns)
Bt delay path  |[Id pa9 |req_data_3_| M7 tGCLE_IN+IC[ 328 3.28
4| reg_data_3_| M7 reg_data_S_.Clh? 1C0i 117 445
Help | reg_data_3_| M7 |z A7 |[TFBRHROUT| 521 966
e | z A7z A7 |tPDI 1.74 11.40
z A7 |z pd1  [tORP+BUF+| 155

Equations

5. Click Equations to open the Equations dialog box, which shows the functional
relationship between the selected source and the destination.

| iEquations ~=lol |

source: req_data_3_C Destination: z

reg_data_3_C= Id: ({1 pterm. 1 signal)

z= select_1_&Izelect_0_ & reg_data_z_.00
#lselect_1_4& select_0_ & reg_data_1_0
#lselect_1_ & Iselect_0_ & reg_data_0_.0
#select_1_& select_0_ & req_data_3_0; (4 pterms, b signals)

Help |

6. Close the Performance Analyst without saving.
7. Close LeonardoSpectrum, then close ispLEVER without saving.
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Summary

You have completed the HDL Synthesis Design with LeonardoSpectrum tutorial. In this
tutorial you have learned how to do the following:

o Create a new EDIF project in the ispLEVER system and target a device.

e Launch LeonardoSpectrum from within ispLEVER and generate an EDIF netlist file
using the Quick Setup tab flow.

o Import the EDIF file into the ispLEVER system, fit the design, generate a JEDEC
file, and view the Fitter report.

e Run static timing analysis using the Performance Analyst and view the results.
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Glossary

Following are the the terms and concepts that you should understand to use this tutorial
effectively.

EDIF. EDIF (Electronic Design Interchange Format) is a format used to exchange design data between
different electronic computer-aided design systems. It is designed to be written and read by computer
programs that are constituent parts of EDA systems or tools. Its syntax has been designed for easy machine
parsing and is similar to LISP. The ispLEVER software supports EDIF Version 2 0 0.

HDL. An HDL is a hardware description language, which describes the structure and function of integrated
circuits.

static timing analysis. Static timing analysis is the process of verifying circuit timing by totaling the
propagation delays along paths between clocked or combinational elements in a circuit. The analysis can
determine and report timing data such as the critical path, setup and hold-time requirements, and the
maximum frequency

synthesis. Synthesis is the process of translating a high-level design (RTL) description consisting of state
machines, truth tables, and/or Boolean equations into a process-specific gate-level logic implementation.

VHDL. VHDL (or VHSIC (Very High-Speed Integrated Circuits) Hardware Description Language) is a
language for describing the structure and function of integrated circuits.

Verilog. Verilog is a language for describing the structure and function of integrated circuits.
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Recommended Reference Materials

You can find additional information on the subjects covered by this tutorial from the
following recommended sources:

e LeonardoSpectrum for Lattice User’s Manual
e LeonardoSpectrum for Lattice HDL Synthesis Manual
o Lattice ispLEVER online help:

e How To guides

e Process Flows > ispXPGA Flows

o Data sheets, technical notes, and other information on ispXPGAs on the Lattice
Web site at http://www.latticesemi.com/search/literature.cfm. Click on FPGA >

iISpXPGA.

© 2004 Lattice Semiconductor 24



