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Using the ispXPGA Floorplanner 
This tutorial shows you how to use the Floorplanner to make adjustments to your 
ispXPGA design. 

Learning Objectives 

When you have completed this tutorial, you should be able to: 

• Open a Floorplanner design file 

• Tour the graphical user interface 

• Customize the Floorplanner display 

• Locate an element using the Design Browser 

• Change pin assignments 

• Reassign PFU block locations 

• Set a placement region 

• Use the Query Widget to find instances and nets 

• Locate timing delay paths with the Timing Widget 

• Group instances with the Design Browser 

• Locate a group with the Group Widget 
 

Time to Complete This Tutorial 

The time to complete this tutorial is about 40 minutes. 
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Task 1: Open the Design 
After starting the Project Navigator you can open the tutorial design file. 

1. Choose File > Open Example to open the dialog box. 

2. Navigate to the tutorial\tutor7 directory. 

Note: If you want to preserve the original tutorial design files, save the tutor7 directory to 
another location on your computer before proceeding. 

3. Select traffic.syn. 

4. Click Open. 

  

Note: You can toggle Revision Control on/off by right clicking in the Revision Control window and 
selecting either Turn On or Turn Off from the popup menu. For this tutorial, it doesn’t matter. 
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Task 2: Open a Floorplanner Design File 
After an initial Lattice internal database is generated, the Pack & Place Design process 
packs the design instances, or cells, into Programmable Functional Units (PFUs) and 
places them on the ispXPGA device. The output of this process is the post-place design 
database and a Pack/Place Report. 

When you run the Post-Place Design Floorplan process, the project design 
automatically loads into the Floorplanner. 

To open a post-place design floorplan file: 

• In the Project Navigator Processes window, double-click the Post-Place Design 
Floorplan process to open the Floorplanner with the current design. Your view will 
look similar to this one. 
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Task 3: Tour the Graphical User Interface - The Design Browser 
The Floorplanner main window contains three windows: the Design Browser, the 
Package View, and the Floorplan View. 

The Design Browser is located on the left side of the main window and gives you a 
logical perspective of your design. You can use the Design Browser to locate an 
instance or net in the Floorplan View window, or locate an external signal in either the 
Package View or Floorplan View windows. Additionally, you can unplace an instance, 
group nets and instances, and set regions in the top-level design using the Design 
Browser. 

 

 

The Design Browser divides your design into three sections: External Signals, 
Instances, and Nets. Each section can be expanded to show the logic elements used in 
the design. The Design Browser comprises various symbols.  

NOTE: For more information about using the Design Browser, see the Floorplanner Help – ispXPGA: 
Procedures  > Design Browser. 
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Task 4: Tour the Graphical User Interface - The Package View 
The Package View window provides a physical view of the design. The Package View 
shows the actual pin assignments. The system (non-user) pins are highlighted in gray. 
Any reserved pins are light gray. Assigned input pins are in blue. Output pins are in 
yellow. Bi-directional pins are in magenta. Unused pins are blank. These are the default 
colors, and they be changed using the Color Legend, as you will learn in Task 6. 

Note: You can toggle between the Package View and Floorplan View windows by choosing View > 
Package View or Floorplan View or by using the Windows shortcut Ctrl+F6. Choosing one of these 
commands brings the corresponding window to the front. 

 

 

For easy pin assignments, you can drag signals from the Design Browser to the Package 
View, or drag and drop signals inside the Package View. 

Right-click pop-up menus offer commands for controlling the view. For example, to 
view IO banking, click an empty space in Package View, right-click, and select Show 
Bank IO from the pop-up. To view pin attributes, click a pin, right-click, and select Pin 
Property.  

Note: For more information about using Package View, see the Floorplanner Help – ispXPGA: 
Procedures > Package View. 
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Task 5: Tour the Graphical User Interface - The Floorplan View 
The Floorplan View window displays the physical placement of the design logic and 
displays how device resources are utilized. You can use this window to debug and edit 
device utilization to achieve better performance. 

To change the Floorplan View display: 

1. On the toolbar, click the Fanin and Fanout buttons. 

Note: Fanin displays the signals coming into a component, and Fanout displays the signals leaving 
a component. 

 

2. Select the bottom PFU. Notice that the routing lines are displayed.  

 

Some of the procedures that you can perform in the Floorplan View include: 

• Moving PFUs, EBRs, and PIOs by selecting the blocks and dragging and 
dropping in the Floorplan View. 

• Setting group assignments using the Retain Packing command. By setting group 
assignments, you retain the logic packing and location of one or more PFU, PIO, 
and/or EBR. The group assignments are written to the Lattice Constraint File 
(.lct). 

• Creating regions (post-place, and post-route) to reserve resources in your design. 
You can also select instances within the region and move them as a group. 
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• Selecting instances and nets and grouping them with the Group command. 

• Displaying an amplified (enlarged) view of blocks, such as PFUs and PIOs. This 
allows you to see a detailed view of the blocks without the need to zoom in on 
each individual block in the Floorplan View.  You can click on pins in the 
amplified view and see their routing from a global perspective. 

• Performing custom pin-to-pin routing using the Pin Routing dialog box. 

• Viewing properties of an EBR, PFU, and PIOs. 

3. Click the Fanin and Fanout buttons again to turn off routing display. 

 

Note: For more information about using Floorplan View, see the Floorplanner Help – ispXPGA: 
Procedures > Floorplan View. 
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Task 6: Customizing the Floorplanner Display 
You can customize display colors of elements within the Floorplan View, Package 
View, and Design Browser windows. In this step, change the display color of used 
PFUs in the Floorplan View window. 

To customize display colors in the Floorplanner: 

1. Make the Floorplan View window active and use the View > Zoom commands (or 
the toolbar icons) so that your view is similar to this one. 
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2. Choose Tools > Color Legend to open the Color Legend dialog box. 

 

3. Use the scroll arrows and view the tabs to become familiar with what you can do 
using the dialog box. When you are through, return to the Floorplan View tab. 

4. Click the Used PFU color box (blue) to open the Color dialog box. 
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5. Select the color red and click OK to close the Color dialog box.  

 

 

6. Click OK to close the Color Legend dialog box. Notice the Used PFU color in the 
Floorplan View has changed from blue to red. 
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Task 7: Locate an Element with the Design Browser 
You can locate an instance or net in the Floorplan View using the Design Brower, and 
you can locate an external signal in either the Package View or Floorplan View. 

To locate an external signal (Device Pin) in the Package View: 

1. Double-click the Package View window title bar to expand the window. Choose 
View > Zoom In and adjust the view so that you are able to read the pin names.  

NOTE: Don’t worry about matching your view t this one. The important thing is to make sure you 
can read the pin numbers. 

 

 

© 2004 Lattice Semiconductor    13 



ispLEVER Tutorials  Using the ispXPGA Floorplanner 

2. In the Design Browser, expand the tree until you can see External Signals > clock 
@ R3. 

 

 

3.  In the Design Browser, right-click clock @ R3 and choose Locate > Device Pin. 
The view jumps to the R3 pin in the Package View. 

 

  © 2004 Lattice Semiconductor 14 



ispLEVER Tutorials  Using the ispXPGA Floorplanner 

4. Choose View > Floorplan View to make the Floorplan View window active. 
Choose View > Zoom to Fit so that you can see the entire floorplan. 
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5. In the Design Browser, right-click clock @ R3 and choose Locate > PIO. The view 
jumps to the R3 PIO in the Floorplan View. This lets you see the association 
between the pin, signal, and the PIO. 
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Task 8: Change Pin Assignments 
This reentrant design flow procedure lets you set or modify pin assignments using the 
Package View window. You can assign pins by dragging signals from the Design 
Browser to a pin in the Package View. Also, you can change pin assignments by 
dragging and dropping signals inside the Package View. 

To change a pin assignment: 

1. Make the Package View active by choosing View > Package View and adjust the 
window so that you can easily see the pin names. Then scroll all the way to the 
upper-right so that your view is similar to the one below. 
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2. In the previous task, you were using the Design Browser to locate pins in the 
Package View. Now you will do the reverse. In Package View, right-click E3 and 
select Locate > Design Signal. The signal sensor1 @ E3 is selected in the Design 
Browser. 
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3. In Package View, click E3, drag down three pins to H3 and drop it. Notice that the 
pin assignment also changed in the Design Browser. 

 

4. Select the C5 pin in package view, right-click and choose Unlock to delete the pin 
assignment. The color code is cleared from the pin in the Package View, and the L 
is cleared from the signal in the Design Browser. 

5. Now save the new pin changes to the constraint file. Choose File > Save 
Constraints to open the dialog box. Accept the current file name. At the bottom of 
the dialog box, select Pin Assignments, and then click Save.  

6. A message warns you that the file already exists. Click Yes to replace it.  

7. Choose File > Exit to exit the Floorplanner. A message asking, "Do you want to 
save the design changes you made?" appears. Click No. 

8. Return to the Project Navigator. Notice that the green check marks that indicated 
the Pack & Place Design process had completed are now gone. This is because the 
previous packed and placed design database is no longer accurate after you changed 
the pin assignment. 
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9. In the Project Navigator, double-click the Constraints Editor process to open the 
Constraint Editor. On the Pin Attributes tab, find the signal sensor1 and notice that 
it is assigned to pin H3. 

 

Note: If you wanted to, you could also change the pin assignment using the Constraint Editor 
Location Assignment dialog box (Pin Attribute > Location Assignment). 

10. Choose File > Exit to exit the Constraint Editor. 

11. In the Project Navigator, double-click the Post-Place Design Floorplan to open the 
design in the Floorplanner again. 

12. In Package View, verify in the Design Browser that the new pin assignment (H3) 
was saved as a design constraint and used during the reentrant Pack & Place 
process. 
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Task 9: Reassign PFU Block Locations 
This reentrant design flow procedure lets you move Blocks (PFUs, EBRs, and PIOs) by 
dragging and dropping in Floorplan View. 

To reassign block locations in Floorplan View: 

1. Choose View > Floorplan View to display Floorplan View. 

2. Choose View > Zoom In to enlarge the view of the upper-left corner. 

3. Select the PFU in row 2, column 1 (PFU2@PFU(2,1)) and hold down left mouse 
button.  

Note: Your layout might show different PFU placements. If so, select any PFU on the layout. 
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4. Drag the selected PFU down and to the row beneath it (row 3, column 1) and release 
the mouse button. 

 

 

5. Select the moved PFU (left-click), and then right-click and select Retain Packing. 
If a check mark is next to the Retain Packing command, the block packing is already 
retained. 

 

 

6. Save the new PFU location to the constraint file. Choose File > Save Constraints to 
open the dialog box. Accept the current file name. At the bottom of the dialog box, 
select PFU packing/placement, and then click Save.  

7. A message warns you that the file already exists. Click Yes to replace it.  
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Task 10: Set a Placement Region 
You can use the Design Browser to set a region in the top-level design that designates 
PFU placement within the Floorplan View.  

To set a PFU placement region: 

1. In the Design Browser, right-click the top-level hierarchical list (traffic) and 
select Set Region. 

Note: Make sure you select traffic first, and then right-click. If you do not see the region drawn 
as shown in step 2, try this step again. 
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2. In the Floorplan View, drag an area in which you want the PFUs to be placed. This 
region must be large enough to include all the PFUs in your design. 

 

3. Choose File > Save Constraints to open the dialog box. Select Region and then 
click Save. 

4. A message warns you that the file already exists. Click Yes to replace it.  

5. Choose File > Exit to exit the Floorplanner. A message asking, "Do you want to 
save the design changes you made?" appears. Click No. 

6. Return to the Project Navigator and double-click the Constraint Editor process to 
open the Constraint Editor. 
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7. Click the Group/Region Assignments tab. Notice the region defined in the 
constraints file. 

 

Row 1 shows the constraint of moving the PFU up one row. Row 2 shows the 
region you just created. 

8. Choose File > Exit to exit the Constraint Editor. 

9. Return to the Project Navigator and double-click the Post-Place Design Floorplan 
process. Notice the difference in the Floorplan View placement. 
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Task 11: Use the Query Widget to Find Instances and Nets 
You can use the Query Widget to find instances and nets in Floorplan View.  

To find instances with the Query Widget: 

1. Choose Tools > Query Widget to open the Query Widget.  

2. Click the Instance tab. 

 

3. There are 6 different queries you can run. In the dialog box, do the following 
(defaults): 

• For Placement, select Placed. 

• Under Scope, select Both and Whole Design. 

• Under Sort by Name, select Ascending. 

4. In the Enter Query box, enter the number 1, for the Query (Placement). 

5. Click Query. The query result is displayed in the Result box.  
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6. Select PFU0@PFU(1,1). 

 

 

7. Click Locate. The selected PFU instance (PFU0@PFU(1,1)) is highlighted in the 
Floorplan View. 
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8. Right-click on the instance and select Locate. The instance is also located and 
highlighted in the Design Browser. 

 

 

9. Click Close to close the Query Widget.  

10. Choose File > Exit to exit the Floorplanner.  

11. Click No to not save the constraint changes you made. 
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Task 12: Locate Timing Delay Paths with the Timing Widget 
You can use the Timing Widget to locate routed and unrouted signals. You can also 
locate timing delay paths for routed and unrouted signals. For this, you will have to run 
the Post-Route Design Floorplan process. 

To locate timing delay paths with the Timing Widget: 

1. In the Project Navigator, double-click the Post-Route Design Floorplan process. 

2. In the Floorplanner, choose Tools > Timing Widget to open the Timing Widget. 

3. Click Submit Query. The results are displayed in the All Returned Paths box. 

 

 

4. In the All Returned Paths box: 

• Select the first signal on the list (PFU2:CLK) 

• Under Type, make sure fMAX is selected 

• Click Locate.  
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The longest delay path is highlighted in the Floorplan View window. 

 

 

5. Click Close to close the Timing Widget. 
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Task 13: Group Instances with the Design Browser 
You can use the Design Browser to group instances or nets. Grouping instances or nets 
allows you to visually identify a group of certain design elements; for example, all 
instances that perform a function. Then, using the Group Widget you can easily locate 
them. This can be particularly useful in a complex design. A group can contain all 
instances or all nets, but not in combination. 

To group instances: 

1. In the Design Browser, expand the tree until you can see all the instances that you 
want to group. 

2. While holding down the CTRL key, click the green1 and green2 instance names to 
select them. 

 

 

3. Right-click on the selected Instances and choose Locate from the popup menu. (You 
must do this before you create the group.) 

4. Choose Edit > Group to open the New Group dialog box. 

5. In the dialog box, do the following: 
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• In the Group Name box, type myGreenGroup. 

• In the Comment box, type a descriptive note (Green Group). 

• In the Color box, click to open the Color dialog box. Select the color green for 
all the group elements. 

• Under Member Type, leave it set to Instance. 

 

 

6. Click OK to close the dialog and create the new group. 
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7. Repeating the above steps, select the two red instances and create another group 
called myRedGroup. 

 

 

8. Click OK to close the dialog and create the new group. 
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Task 14: Locate a Group with the Group Widget 
You can locate a group with the Group Widget. 

To locate a group with the Group Widget: 

1. Choose Modes > Group Display. This command allows you to toggle the display, 
in the Floorplan View, of any groups you have created.  The groups will display in 
whatever color you have selected in the Group Widget. 

2. Choose Tools > Group Widget to display the Group Widget. 

3. In the Group List, select myGreenGroup. 

 

 

4. Click Locate. The group is highlighted in the Floorplan View. 
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5. Click in the field to unselect the group. Now you can see the group displayed in 
green. 
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Congratulations 
You have completed the Debugging Designs with the Floorplanner tutorial. In this 
tutorial you have learned how to: 

• Open a Floorplanner design file 

• Tour the graphical user interface 

• Customizing the Floorplanner display 

• Locate an element using the Design Browser 

• Change pin assignments 

• Reassign PFU block locations 

• Set a placement region 

• Use the Query Widget to find instances and nets 

• Locate timing delay paths with the Timing Widget 

• Group instances with the Design Browser 

• Locate a group with the Group Widget 
 

For More Information 

You will find much more information about using the Floorplanner and ispXPGA 
devices in the online Help. For Floorplanner concepts, procedures, and user interface 
information, see Floorplanner Help – ispXPGA. For information about ispXPGA 
designs, see ispLEVER Help > Process Flows > ispXPGA Flow. 
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