
Lattice Radiant Power Calculator 
Tutorial

June 26, 2025



Lattice Radiant Power Calculator Tutorial 2

Copyright
Copyright © 2025 Lattice Semiconductor Corporation. All rights reserved. This 
document may not, in whole or part, be reproduced, modified, distributed, or publicly 
displayed without prior written consent from Lattice Semiconductor Corporation 
(“Lattice”).

Trademarks
All Lattice trademarks are as listed at www.latticesemi.com/legal. Synopsys and 
Synplify Pro are trademarks of Synopsys, Inc. Aldec and Active-HDL are trademarks 
of Aldec, Inc. Modelsim and Questa are trademarks or registered trademarks of 
Siemens Industry Software Inc. or its subsidiaries in the United States or other 
countries. All other trademarks are the property of their respective owners.

Disclaimers
NO WARRANTIES: THE INFORMATION PROVIDED IN THIS DOCUMENT IS “AS IS” 
WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING 
WARRANTIES OF ACCURACY, COMPLETENESS, MERCHANTABILITY, 
NONINFRINGEMENT OF INTELLECTUAL PROPERTY, OR FITNESS FOR ANY 
PARTICULAR PURPOSE. IN NO EVENT WILL LATTICE OR ITS SUPPLIERS BE 
LIABLE FOR ANY DAMAGES WHATSOEVER (WHETHER DIRECT, INDIRECT, 
SPECIAL, INCIDENTAL, OR CONSEQUENTIAL, INCLUDING, WITHOUT 
LIMITATION, DAMAGES FOR LOSS OF PROFITS, BUSINESS INTERRUPTION, OR 
LOSS OF INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO USE 
THE INFORMATION PROVIDED IN THIS DOCUMENT, EVEN IF LATTICE HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME 
JURISDICTIONS PROHIBIT THE EXCLUSION OR LIMITATION OF CERTAIN 
LIABILITY, SOME OF THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU.

Lattice may make changes to these materials, specifications, or information, or to the 
products described herein, at any time without notice. Lattice makes no commitment to 
update this documentation. Lattice reserves the right to discontinue any product or 
service without notice and assumes no obligation to correct any errors contained 
herein or to advise any user of this document of any correction if such be made. Lattice 
recommends its customers obtain the latest version of the relevant information to 
establish that the information being relied upon is current and before ordering any 
products.

http://www.latticesemi.com/legal


Lattice Radiant Power Calculator Tutorial 3

Type Conventions Used in This Document
Convention Meaning or Use

Bold Items in the user interface that you select or click. Text that you type 
into the user interface.

<Italic> Variables in commands, code syntax, and path names.

Ctrl+L Press the two keys at the same time.

Courier Code examples. Messages, reports, and prompts from the software.

... Omitted material in a line of code.

.

.

.

Omitted lines in code and report examples.

[ ] Optional items in syntax descriptions. In bus specifications, the 
brackets are required.

( ) Grouped items in syntax descriptions.

{ } Repeatable items in syntax descriptions.

| A choice between items in syntax descriptions.
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Lattice Radiant Power 
Calculator Tutorial

Power Calculator is a tool that helps you to estimate and analyze power 
consumption during the various stages of your design. Whether you are new 
to FPGA or a longtime designer, you will be able to make better design 
decisions every step of the way using this tool. As a result,   you will have 
better understanding of the power characteristics of your design, which will 
enable you to make better decisions every step of the way.

About the Tutorial
This tutorial shows you how to use Power Calculator to acquire accurate and 
comprehensive power usage data. 

In this tutorial, you will:

 Review the basics of power consumption in FPGA design

 Go over the key elements of the Power Calculator interface

 Choose design options and analyze impact on power consumption

 Learn to use specific features to speed up your process

 Compare Power Calculator results in Estimation mode and in Calculation 
mode.

Time to Complete

About 45 minutes.

System Requirements

 The Lattice Radiant software is required to complete the tutorial.
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Power Basics
Before you begin, it would be helpful to go over some basic information about 
power consumption.

What impacts power consumption?
 Temperature – Power consumption increases exponentially with 

temperature. 

 Activity factor –The more frequently the transistors switch, the higher the 
power consumption. 

 Design utilization – The amount and type of resources used in the FPGA 
design, such as logic blocks, memory, and I/O pins, affect power 
consumption. Higher utilization leads to higher power consumption, 
depending on the resources used in a design.

 Architecture – Different FPGA architectures have varying power 
efficiencies. Some architectures are optimized for low power 
consumption, while others may prioritize performance or flexibility.

 Operating frequency and voltage – Higher operating frequencies and 
voltages increase power consumption.

What is total chip power?
Total chip power in an FPGA is the overall power consumed by the device 
during operation. This includes both static and dynamic power components. 

What is static power and dynamic power?
Static power is the power consumed by an FPGA even when it is not actively 
switching. This is largely due to leakage currents in transistors.

Dynamic power, is the power consumed when the FPGA is actively switching 
states and performing operations. This includes power used during logic 
transitions and signal propagation

See also “Computing Static Power and Dynamic Power” on page 34.

What is Ambient Temperature?
Ambient temperature is the expected operating temperature of the air 
surrounding the FPGA. This is measured in °C.
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What is Effective Theta JA?
Effective Theta JA is the sum of all the package and board thermal resistance. 
It represents how effectively certain devices transfer heat to their surrounding 
environment.

Power Calculator estimates effective Theta based on the board, package, 
heat sink, and air flow among others. 

What is junction temperature?
The junction temperature of an FPGA is the temperature at which the silicon 
die can operate without any issue. It is directly affected by the ambient 
temperature and power dissipation.

For example, in Power Calculator, if you change the ambient temperature 
(TA), the junction temperature (TJ) is affected based on the following equation:

TJ = TA + θJA_EFFECTIVE * P

θJA_EFFECTIVE is the effective thermal impedance between the die and its 
environment and P is the power.

For the different values of Theta, see the online Help.
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Overview of Power Calculator 
Power Calculator is included in the Radiant software. You can open Power 
Calculator from within Radiant or as a stand-alone tool from the Windows 
Start menu. A stand-alone Power Estimator is also available, which allows 
you to estimate power consumption separately from Radiant.

Power Calculator provides two modes for reporting power consumption: 
estimation mode, which can be used before completing the design; and 
calculation mode, which is based on the physical netlist file after placement 
and routing. At the upper right corner of the main window is the Software 
Mode, which indicates either Estimation or Calculation, depending on the 
stage of your design. 

Power Calculator Main Interface
The main window shows the Power Summary page by default. 

In the Device section, you can select the device, package, part name, 
performance grade, and operating conditions. 

The Device Power Parameters section provides information pertaining to the 
device process conditions. Typical reflects the average or expected 
conditions under which the device normally operates while Worst considers 
the most extreme or demanding conditions the may be encountered by the 
device. This usually leads to the highest power consumption. The Power File 
Revision is the status of the power analysis file or model. 

The Environment section shows the operating temperature data of the 
device. Select User Entered TJ to directly specify Junction Temperature. 
Select Computed TJ to directly specify Ambient Temperature or enable 
Thermal Profile. For more information, see “Using Thermal Profile” on 
page 21.

You can view the other pages by clicking the tabs at the bottom of the main 
window. Except for Graph and Report, each of these pages allows you to 
view, edit, and add elements. The number and types of pages that are 
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available depends on the selected device. These pages are discussed in 
greater detail in “Working in Estimation Mode” on page 10.

Color Codes 
Meaning of table cell color:

 White – Editable. Changing values will not change Software Mode.

 Green – Read-only or contains output from the software.

 Light Yellow – Data is extracted from a design file (such as .udb)

 Red – The calculated value in the Junction Temperature box is either 
higher than 125 °C or higher than the maximum junction temperature 
allowed for a particular device and operating conditions. The Junction 
Temperature box is the only cell that can display red text.

Meaning of font colors:

 Blue – Default values.

 Gray – Values cannot be edited on the I/O page. Since the I/O page has 
columns for inputs, outputs, and bidirectionals, red font prevents you from 
altering an I/O that is not valid. For example, if the I/O type belongs only to 
an I/O input, the cell in the # of Inputs column would display a value in 
black font, indicating that it is editable. The cells in the # of Outputs and 
the # of Bidi columns, however, would display values in gray font to 
indicate that they cannot be edited.

 Black – All other texts.

Power Calculator Modes
Estimation Mode – used for a what-if analysis of power usage before you 
even start a design or at different stages of your existing design before it is 
completed. Power Calculator can switch between Calculation Mode and 
Estimation Mode. For example, while working in Calculation Mode, changing 
the I/O type automatically switches to Estimation Mode since the results are 
no longer based on the netlist. This allows you test various things in your 
design.

Calculation Mode – When you open Power Calculator from with Radiant, 
Power Calculator computes power consumption based on the post-PAR 
netlist of the design. When you have already routed used when you have 
already routed your design, the tool calculates power consumption on the 
basis of device resources taken from the design’s .udb file, or from an 
external file such as a .vcd file. Here, you get a more accurate computation of 
power consumption, because it is based on the actual device utilization and 
uses input files generated during simulation or synthesis.



Working in Estimation Mode

Lattice Radiant Power Calculator Tutorial 10

Reverting to Estimation Mode
Power Calculator automatically reverts to Estimation Mode from Calculation 
Mode when:

 You change the data in any cell other than AF (%), Freq., V., Dynamic 
Power Multiplier, Ambient Temperature, Performance Grade, Operating 
Condition, or Process Type.

 You rerun a process before Place & Route and you are working with an 
unsaved “untitled” temporary power calculator file. 

If you are working with a saved .pcf file, the software mode will not change 
when you rerun a process.

Generating a CSV Report 
Clicking the Generate CSV Report button creates a consolidated report of 
data in all the Power Calculator pages in .csv format. 

Working in Estimation Mode 
Estimation mode is primarily used for a what-if analysis of power usage 
before you complete or even start your design. Here, you can get a rough 
idea of your power consumption.

In Estimation mode, you may have an idea of the amount of resources that 
you will be using such as the number of LUTs, block RAMS, clocks, I/Os, and 
so on. You then enter all these information into Power Calculator. You do not 
even need an HDL code to get started. You can estimate resource utilization, 
clock frequency, and activity factor for your planned design. Since the inputs 
are mostly user defined, this mode is considered the least accurate.

Let us open a Radiant design example and explore the Estimation mode 
environment. Remember that this project has not been compiled.

1. In the Lattice Radiant Start Page, click Open Example.

2. In the Open Example dialog box, choose LIFCL_example.

3. For this tutorial, create a folder “Estimation Mode” and indicate this as the 
location for your project.

4. Click OK.

5. The Radiant main interface opens. Do not compile the project.

Note
For this tutorial, we are using an example design that comes with the Radiant 
software. This is to minimize compile time and to make sure that most users can easily 
run the design without error. The differences in power usage values may be small and 
at times negligible. To better appreciate the reported power usage data, you may opt to 
use your own more complicated design.
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6. Click Tools > Power Calculator or the Power Calculator button . 

The Power Calculator Power Summary page opens in Estimation mode.

7. Test how package type, speed grade, and device characteristics affect 
your power usage. Test how environmental conditions such as ambient 
temperature, heat sinks, airflow, and board size affect your design. 

You may perform the procedures in“How Heat Affects Power” on page 23.

You can provide information based on your own logic (if already available) 
and from other resources such as the device data sheet and technical 
notes that can be downloaded from the Lattice website. If you have a 
block that is a Lattice IP, specific IP user guides can likewise be 
downloaded from the Lattice website.

You will notice that some fields in the Power Calculator pages (such as 
Logic Block, Clocks, and I/O) are already filled out. Note that DDRPHY, 
DDRDLL, and DLLDEL tabs are also automatically filled out. These green 
cells are read-only and the values are output from the software. For more 
information, see the User Guides > Analyzing Power Consumption > 
Power Calculator Window Features > Power Calculator Pages section in 
the Radiant Help.

The following steps will walk you through some of the Power Calculator 
pages. 

8. Click the Power Matrix tab. 

The Power Matrix page shows each component’s power consumption 
from different sources. It features tabs for Block Current Power Supply (A) 
and Block Power by Power Supply (W), displaying current usage in 
amperes and power usage in watts for each component.

You can select the Generate CSV Report at the top-right corner to create 
a .csv file of the matrix that can be opened in a spreadsheet application.

9. Click the Logic Block tab.

The Logic Block page shows the estimated power usage of the design’s 
logic and the factors affecting it. Power calculation requires the frequency, 
activity factor per clock domain, and the number and enable factor of 
LUTs, distributed RAMs, ripple-carry logic circuits, and registers.
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It also features a Utilization table that displays resource usage 
percentages. When you modify the # Logic LUTs, # Registers, # Ripple, 
and # RAM columns for example, the Utilization table updates after 
recalculating power.

Note that Total Dynamic Power (W) is 0.00.

To add a row in the Logic table and in other tables in the Power Calculator 
pages, move the cursor over the table and right-click on it. Select the Add 
Row option. To remove a row, select and right-click on the row you want 
to delete. Select the Remove Row option.

Add three rows under Logic. Right-click under and choose Add Row. In 
the first two rows, type 200 in Freq. (MHz), 10000 in # Logic LUTs, 1000 in 
# Registers, and 150 in # Ripple.

You will observe that Total Dynamic Power (W) increased to 0.064.

10. Click the Clocks tab.

The Clocks page shows the estimated power usage of the design’s 
clocks, based on their frequency. Dynamic power calculation is based on 
the frequency of each clock. 



Working in Estimation Mode

Lattice Radiant Power Calculator Tutorial 13

The Clocks page only reports clocks in the clock tree, such as Primary, 
Secondary, and Edge Clocks.

11. Click the I/O tab.

The I/O page displays the estimated power consumption of the design’s I/
Os and the factors influencing it. Calculations need the frequency, activity 
factor, and number of inputs or outputs per clock domain. If a .udb file is 
used, Power Calculator extracts the information directly; otherwise, 
default values are assigned based on the design’s family.

You can add and remove rows in the following tables:

 Input Output WRIO

 Input Output HPIO

 Bidi WRIO

 Bidi HPIO

 SIOLOGIC

 IOLOGICA

 IOLOGICB

For example: 

a. Right-click under Bidi IOS33 below Clock Input Name and select Add 
Row.

b. Under Bi Type, you will see the low-voltage CMOS technology that is 
used. In this example, it is LVCMOS12-2-OFF-OFF, which means that 
the I/O is running at 1.2 V. The 2 stands for the output drive, which is 2 
Milliamps (mA).

c. Double-click this field and select from other options. Selecting a 
stronger drive output can draw more power.
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Add I/Os automatically. Perform the steps in “Adding I/Os” on page 28.

12. Click the I/O Term tab.

The I/O Term page shows details about external terminations for the I/Os. 
The power-consumption calculation is based on the power used by the 
external termination you provide. 

I/O Term does not draw significant amount of power and you do not enter 
values manually.

Note
Some I/O banks have more Bi Type options. These I/O banks offer greater 
capabilities but occupy more silicon area. Therefore, it is not ideal to make 
every I/O highly programmable, as they consume more transistors.
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13. Click the DSP tab.

The DSP block handles complex mathematical operations like addition 
and multiplication. It is designed for signal processing tasks, including 
filtering, Fourier transforms, and other high-speed arithmetic algorithms.

To add a DSP block:

a. Right-click under MULT9 below Clock Name and select Add Row.

b. Double-click under Type and click the pull-down arrow, you will see 
the different functions you can do with DSP.

As an example, select MULT9_REG_X2. Under Freq. (MHz), type 
200.

c. Hover over the DSP field to see the maximum allowable value. Type 
any value within range.

The Dyn. Pwr (W) value changes.

14. Click the PLL tab.

The PLL page shows the estimated power consumption of the phase-
locked loops in the design and other contributing factors.

To add a PLL block, right-click under PLL below Input Clock Name and 
select Add Row. Type 200 in Input Freq. (MHz).

Note
An error message is displayed if you type a value that is more than the maximum 
allowed.
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15. Click the Block RAM tab.

The Block RAM page shows the power consumption of the embedded 
block RAM (EBR) in the design and the factors that affect it. Calculations 
require the frequency and activity factor per clock domain.

You can add and remove rows in the following tables:

 SP RAM

 DP RAM

 DP RAM True

 FIFO

For example: 

a. Right-click under SP RAM below Clock Name and select Add Row.

b. Type 200 in Input Freq. (MHz).

c. Type 17 in EBR.

The Dyn. Pwr (W) value changes.
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16. Save your Power Calculator file. Click File > Save Untitled as. 

In the Save Power Calculator File dialog box, type PWC_tutorial in File 
name and click Save.

The file is added under Analysis Files in File List view.

17. Click File > Save Project and close it.
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Working in Calculation Mode
To work in Calculation mode, your design must have already completed 
synthesis, MAP, and Place & Route. In this case, Power Calculator computes 
power consumption on the basis of device resources taken from the design’s 
.udb file. Here, you get a more accurate computation of power consumption 
because it is based on the actual implementation results and uses input files 
generated during simulation or synthesis

Let us calculate power consumption in Calculation mode:

1. In the Lattice Radiant Start Page, click Open Example.

2. In the Open Example dialog box, choose LIFCL_example.

3. Indicate a new folder location for your project.

4. Click OK.

5. The Radiant main interface opens. Run Synthesis, Map. and Place & 
Route.

6. Click Tools > Power Calculator or the Power Calculator button . 

The Power Calculator Power Summary page opens in Calculation 
mode.

Your HDL code is synthesized, mapped, and place & routed and a UDB 
file is created. After you run Place & Route, you will have an updated UDB 
file. This UDB is the accurate representation of your design. Power 
Calculator will use this UDB to calculate power usage.

7. Click the Logic Block tab. 

Note that the tool already added logic data.

Note
While in Calculation mode, you can revert to Estimation mode. See “Reverting to 
Estimation Mode” on page 10.
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8. Click the Clocks tab.

Similar to the Logic Block page, the tool already added initial data.

9. Click the I/O tab.

Similar to the Logic Block page, the tool already added initial data.

You will note that in Calculation mode, the tool processes the design and 
provides more accurate results compared to Estimation Mode. 

Using VCD File in Power Calculator
There is an advanced process In Calculation mode wherein Power Calculator 
acquires input data from a VCD or Value Change Dump file. This is an ASCII-
based file where you record the signal transition values in your design during 
simulation. The format is defined by the IEEE Standard 1364-1995 for the 
Verilog Hardware Description Language. To use a VCD file in Power 
Calculator, you must run a post-route simulation. 

A VCD file consists of three main sections:

 Header – Metadata such as the date, simulator version, and timescale.
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 Variable Definitions – Signals and their hierarchical scope within the 
design.

 Value Changes – Changes in signal values over time during the 
simulation.

To generate a VCD file:

1. Run simulation in Radiant using the Simulation Wizard. 

2. Restart simulation (restart –f).

3. Create a VCD file (vcd file file_name>.vcd).

4. Add signals to dump in VCD file (vcd add <path_to_instance>/*).

5. Run simulation (run<time>).

6. Stop simulation to write to the VCD file (quit –sim).

For example:

restart –f
vcd file myvcdfile.vcd
vcd add /testbench/uut/*
run 1000 ns
quit -sim

If you input a post-routed simulation .vcd file to Power Calculator, the tool 
compares the clock signals in the .vcd file to each clock in the Power 
Calculator pages. If the clock names match, Power Calculator takes the 
frequency data from the .vcd file and populates the frequency columns, the 
activity factor (AF(%)) columns, or all, in the pages that contain these 
columns. 

To calculate power consumption using VCD:

1. In the Radiant software, choose File > Open Project.

2. Browse to your Radiant project and Click Open.

3. Click the Run All button.

4. Open Power Calculator and import the VCD file to Power Calculator:

5. Click Edit > Open Simulation File.

6. Indicate the VCD file and the module name. 

7. Click OK. 

Power Calculator will calculate the AF based on the simulation information.

If you take note of power usage data and compare it with Estimation mode 
results, you can conclude that using Calculation Mode with .vcd provides 
more accurate results.

Note
Power Calculator only supports VCD files. The SAIF file, which contains 
summary data extracted from VCD, is not supported. 
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Best Practices and other Recommendations

To complete the procedures in this section:

1. In the Lattice Radiant Start Page, click Open Example.

2. In the Open Example dialog box, choose LIFCL_example.

3. Indicate a folder location for your project.

4. Click OK.

5. The Radiant main interface opens. 

6. Click Tools > Power Calculator or the Power Calculator button . 

The Power Calculator Power Summary page opens in Estimation mode.

Using Thermal Profile
Thermal Profile in Power Calculator estimates the value of the Effective Theta 
JA (°C/W) based on the size of the board, the available heatsink, and airflow. 
The default thermal impedance value is based on a medium size board (6" x 
6", 6 layers), with no heat sink and 200 LFM (Linear Feet per Minute) air 
velocity.

In the Environment panel of the Power Summary page, you can open 
Thermal Profile by selecting Computed TJ and clicking the Thermal Profile 
button. Select Use Thermal Models to choose board, heat sink, and airflow 
options.

If you already made your own simulations and calculations, select Use 
Defined Effective Theta-JA and indicate the value in the Effective Theta JA 
(°C/W) box.
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Note

Selecting Custom Profile Heat Sink enables Theta-SA for Custom Heat 
Sink. This value is the maximum thermal resistance of the heat sink.
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How Heat Affects Power

Board Area
In the example, you have an Effective Theta JA value of 13.81. When you 
select Computed TJ and click Thermal Profile, you will find that Board 
Selection is Medium Board.

Change Board Selection to Large Board and the Effective Theta JA value 
goes down from 13.81 to 11.92 The larger the board, the lower the Effective 
Theta JA value. This is because you increased the area where the heat can 
spread out.
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Heat Sink and Air Flow
Change the Heat Sink Selection from No Heat Sink to High Profile Heat 
Sink and Airflow Selection, measured in Linear Feet per Minute or LFM, from 
250 LFM to 500 LFM. Note that Effective Theta JA value went further down 
from 11.92 to 7.73.

Ambient Temperature and Static Power
Static power affects power consumption significantly. Under Power by Power 
Supply, the Static (W) value is 0.230.

The main contributors to static power are:

 Leakage Currents – These are the small amounts of electric currents that 
flow through transistors when they are off. If you have millions of 
transistors, even small leaks add up and may result to a significant 
increase in power consumption.

 Standby Power – Power consumed by the FPGA when it is powered on 
but not actively performing any tasks. Standby power may include leakage 
currents and power used by always-on components, such as biasing 
circuits.

 Clock Network – Power consumed by the clock distribution network, even 
when the clock is not switching.



Best Practices and other Recommendations

Lattice Radiant Power Calculator Tutorial 25

If you increase Ambient Temperature (°C) from the default 25 to 70, the Static 
(W) value rises from 0.016 to 0.034 

This shows that heat affects static power. Note that there is no change in 
Dynamic (W).
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Directly Changing the Junction Temperature
You can directly change Junction Temperature value. Check the valid junction 
temperature range as specified in Operating Conditions in your device data 
sheet.

To change the junction temperature:

1. In the Environment section of the Power Summary page, select User 
Entered TJ.

2. Enter a value, in °C in the Junction Temperature (°C) box and press Enter 
or click anywhere outside the cell.

The value entered must be with the valid range in °C. The default value is 25 
°C for all devices. If you enter a value that is beyond the commercial, 
industrial, or automotive device limits, you will receive an error message that 
displays the range of valid values.
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Assigning a Global Setting for 
Frequency
When working in Estimation mode and you have numerous cases similar to 
this, you do not have to manually add the correct Freq. (MHz) values one cell 
at a time. You can click Edit > Frequency Settings to open the Frequency 
Settings dialog box. 

Type the correct value (200 in our example) in the Frequency Default field and 
click OK. This automatically changes all the Freq. (MHz) values in your 
design to 200.

Radiant compiles the design and finds a register, it can trace back the clock 
from the timing constraints. For example, when a clock is constrained to 200 
MHz. However, with regards to other logic LUTs that are doing logic functions, 
the tool cannot trace back at which frequency these are running. 

Dynamic power is calculated using the formula C·V2·f

where:

( C ) is the load capacitance,

( V ) is the supply voltage, and

( f ) is the clock frequency.

This formula shows that dynamic power consumption is directly proportional 
to the capacitance, the square of the supply voltage, and the clock frequency. 

So it is important to go through all the blocks and make sure you have no 
instance of 0 Freq. (MHz) to avoid any inaccuracy when using this tool.

Note
In Calculation mode, it is recommended to manually assign the actual 
frequency value.
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Importing Frequencies from Timing Report
You can also change global frequency value by selecting Use Frequency 
TWR and choosing options to import frequencies from the timing report. Make 
sure that the timing report contains the names of the clocks in the pages for 
which you want default frequency values.

 Minimum of Constraint and Timing –The default frequency in the 
Frequency (MHz) column of the Power Calculator pages will be taken 
from the lesser of the constrained frequency or the actual frequency in the 
timing report. 

 Always Use Constraint – The default frequency in the Frequency (MHz) 
column of the Power Calculator pages will be taken from the constrained 
frequency in the timing report. 

 Always Use Timing – The default frequency in the Frequency (MHz) 
column of the Power Calculator pages will be taken from the actual 
frequency in the timing report. 

If the clock frequency cannot be imported using this option, you have to 
specify a value. 

Adding I/Os
When you create a new Power Calculator file and you click the I/O tab, you 
will find numerous blank I/O tables that you have to populate with data. It 
would be difficult to add these I/Os manually especially if you are dealing with 
hundreds of them. 

To speed up the process of estimating routing resources, click Edit > 
Resource Settings. The Resource Settings dialog box opens. 
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Select Large to fill out 85% of your design. Power Calculator displays 85% of 
Logic, I/O, EBR, and others. It is better to fill out a large part of your design 
and reduce later as you please than start out with a small percentage and add 
these data manually later on. Click OK. 

You will be prompted to save your changes, choose No for now.

The tables are populated with routing data. However, you will note that all the 
Freq. (MHz) values are at 0. Change these by clicking Edit > Frequency 
Settings.

Change Frequency Default to 200 in the Frequency Settings dialog box and 
click OK.
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All the Freq. (MHz) values change to 200.
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Computing Activity Factor
Activity Factor % (AF%) is the average number of signal transition per 
second. You must provide this value under the AF% column in Power 
Calculator. 

Potentially high AF would be Adder, Arithmetic Logic, XOR gates, FEC 
(Forward Error Correction). Potentially low AF would be Control Logic and 
Power sequencing.

Synchronous Logic Activity Factor
Synchronous Logic AF is how often an output changes relative to a clock. 
This is measured from 0% to 100%.

Below is an example of a 3-bit counter.

So if you compute the average of these AF numbers, the 3-bit counter has an 
AF of 58%.

Combinatorial Logic Activity Factor
It is hard to predict the AF using combinatorial logic. It is better to avoid any 
combinatorial logic in the design because it is not predictable and could 
create glitches.

Figure 1: 3-bit Counter Example
Bit 2 Bit 1 Bit 0

0 0 0

0 0 1

0 1 0

0 1 1

1 0 0

1 0 1

1 1 0

1 1 1

25% AF- the output 
changes every 4 clock 

cycles

50% AF- the output 
changes every other 

clock cycle

100% AF- the output 
changes every clock 

cycle
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Changing AF 
The default Activity Factor or AF (%) setting is 10 but it is common to make 
this 12.5. This means that each clock changes on the average every eight 
clock cycle.

To change Activity Factor, click Edit > Activity Factor Settings and change 
Activity Factor Default to 12.5. Click OK.

The AF (%) setting is changed to 12.5.
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Advisory in Using Estimation Mode 
Settings
When you click Edit > Estimation Mode Settings, the Estimation Mode 
Settings dialog box opens.

This allows you to estimate the amount of routing resources that your design 
will use for power analysis.

Unless you have full knowledge and expertise on the use of this feature, it is 
recommended to keep the Routing Resource Utilization at its default value of 
Medium. 

For more information on estimating routing resource, see the User Guides > 
Analyzing Power Consumption > Estimating Routing Resource Usage section 
of the Radiant online Help.
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Computing Static Power and Dynamic 
Power
To calculate static power:

1. Click the Logic Block tab.

2. Subtract Total Dynamic Power (W) from Total Power (W) and you have 
your Static Power.

Using Calculate Immediately
In Power Calculator, you can immediately process every change that you 
make. To do this, click Edit and make sure that Calculate Immediately is 
checked.

When you make a change, you will observe that Power Calculator 
immediately processes the change. 

On the other hand, you can also choose to apply your changes only after 
clicking the Calculate button. To display this button, click Edit and disable 
Calculate Immediately. 

When you make a change, Power Calculator prompts you to manually click 
the Calculate button to process the change. As such, you can make several 
changes before allowing the tool to batch process them.
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Viewing and Printing Results
Power Calculator provides graphs of power consumption and enables you to 
print information from the pages and generate a consolidated report of data in 
a comma-separate value (.csv) file format. 

To generate a Power Calculator report in CSV format:

1. Click the Generate CSV Report button at the upper right-hand corner of 
the Power Calculator window.

2. In the Generate CSV Report dialog box, browse to the target directory for 
the report.

3. Type a name in the File name box and click Save.

You can further analyze the results in an external spreadsheet application that 
supports CSV.

Summary of Accomplishments
You have completed the Lattice Radiant Power Calculator Tutorial. In this 
tutorial, you have learned:

 the basics of power consumption in FPGA design

 the key elements of the Power Calculator interface

 design options to choose and analyze their impact on power consumption

 use specific features to speed up your process

 compare Power Calculator results in Estimation mode and in Calculation 
mode.

Recommended References
You can find additional information on the subjects covered by this tutorial in 
the Radiant Help:

 User Guides > Analyzing Power Consumption
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Revision History

The following table gives the revision history for this document.

Date Version Description

06/26/2025 2025.1 Updated to reflect changes in Radiant 2025.1.

12/20/2024 2024.2 Initial release.
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