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Acronyms in This Document

A listofacronyms used in this document.

Acronym Definition

BSP Board Support Package, the layer of software containing hardware -specific drivers and libraries to function
in a particular hardware environment.

DUT Design Under Test.

SDK Embedded System Designand DevelopKit. Aset of software development tools that allows the creation of
applications for software package on the Lattice embedded platform.

IDE Integrated Development Environment.

OEM Original Equipment Manufacturer.

Works pace The (?Ii rectorywh.ere storesyourwork, itis usedas the default contentarea foryour projects as well as for
holdinganyrequired metadata.

Workbench Refers to the desktop development environment in Eclipse IDE platform.

Programmer A tool canprogram Lattice FPGA SRAM and external SPI Flash through various interfaces, such as JTAG, SPI,

and I2C.

Perspective

A group of views and editors inthe Workbench window.

A free and openinstruction set architecture (ISA) enablinga new era of processorinnovation through open

RISCV standard collaboration.

RISC-V MC Lattice RISC-V for Micro-Controller Soft IP

SoC System on Chip. An integrated circuit thatintegratesall components of a computer or other electronic
systems.

SRAM Static Random Access Memory.

UFM UserFlash Memory.
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1. Introduction

Lattice Propel™ is a complete set of graphical and command-linetools to create, analyze, compile,and debug both
FPGA-based hardwareand software processor systems.

1.1. Purpose
Embedded system solutions play animportantrolein FPGA system design allowingyou to develop software for a

processorinan FPGA device. It provides flexibility for you to control various peripheralsfroma system bus.

To develop anembedded system on an FPGA, you need to design the System-on-Chip (SoC) with an embedded
processor and develop system software on the processor. Lattice Propel helps you develop your system with a RISC-V
processor, peripheral IP,and a set of tools.

The purpose of this document is to introduce Lattice Propel SDK tool and flow to help you quickly get started to build a
small demo system. You can find recommended flows of using Lattice Propel SDK in this document as well.

1.2. Audience

The intended audiencefor this document includes embedded system designers and embedded software developers
using Lattice FPGA devices. The complete list of supported devices can be found at Lattice Propel Release Notes. The
technical guidelines assumereaders haveexpertise in the embedded system area and FPGA technologies.

www. latticesemi.com/legal
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2. Lattice Propel Development Suite

Lattice Propel development suiteincludes:
e anintegrated development environment (IDE), whichis the framework of Propel;
e lattice Propel Builder, whichis for SoC design;

e lattice Propel SDK, whichis for system software development.

2.1. Eclipse IDE
EclipseIDE provides the Propel development suitea platform to manage the SoC project and the Embedded C/C++
Project inthe same workspace.

The SoC project, which extends from the Propel Builder project, provides easyinteraction with other Lattice design
tools, such as Lattice Diamond® within Propel.

The Embedded C/C++ Project provides a platform for developing or debugging application code within Eclipse IDE. The
project can be created directly from the SoC project with a pre-set Board Support Package (BSP) and applications by
using Propel development suite.

2.2. Lattice Propel Builder

Lattice Propel Builder allows you to assemblethe larger functional blocks of the design hierarchy. Propel Builder
enables you to instantiate modules and IP from the IP Catalogina schematic view, and caneasily connectthe modules.
Propel Builder also helps you customize address spaces within modules,such as a processor.In Propel development
suite, Propel Builderis usedto create a microprocessor integrated platformfor both hardwareand software
development.

Refer to Lattice Propel 2.0 Builder User Guide (FPGA-UG-02126) for more detailed information.

2.3. Lattice Propel SDK

Lattice Propel SDK is based on Eclipse Embedded CDT (C/C++ Development Tools). It allows you to create, build,and
debug software application projects thatdrive the platform within the Eclipseframework.

The main features are:
e Create, build, debug, or manage embedded applications for Lattice RISC-V CPU/SoC solution.
e Provideextra build steps to generate the binary and memory files required for deployment.

e Buildusingthelatestindustry standard open sourcecomponents and tools for RISC-V firmware development and
debugging.

e Support Newlib and nano for RISC-V, and provide lightweight standard library implementation.

e Providefully-configurabletoolchain definitions.

www. latticesemi.com/legal
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3. Lattice Propel Tool Flows

The Propel tool flows including SoC projectdesign flow, C/C++ project design flow, system simulation flow, and
programming and On-Chip-Debugging (OCD) debugging flow, are discussed in detail in the followingsections.

3.1. Propel Environment

3.1.1. Running Lattice Propel

After installing Lattice Propel, you can launch Propel from the desktop shortcuticon or from the Windows Start menu.
When Propel is invoked, a dialog (Figure3.1) pops up. You can browse to select where to locatethe workspace. For
normal needs, justclick Launch to pickthe defaultlocationand continuerunning Propel.

Q Lattice Propel Launcher ¥

Select a directory as workspace

Lattice Propel uses the workspace directory to store its preferences and development artifacts.

Workspace: | w Browse...

[[J Use this as the default and do not ask again

» Recent Workspaces

Figure 3.1. Select Workspace Dialog

After the workspacelocationis chosen, a single workbench window is displayed using defaultPropel SDK perspective.
The default Propel SDK perspective contains following five functional areas (Figure 3.2).

1. Menu barand Toolbar.

2. ProjectExplorerview: displays projects intheworkspace.

3. Editorview: provides capability of editing sourcefiles.

4, Outlineview: displays anoutlineofa filethatis currently open inthe editor area.
5

Log area includes theseviews: Problem view, Tasks view, Consoleview, Properties view, and Terminal view.

www. latticesemi.com/legal
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| £t workspace - Lattice Propel - O *

File Edit 5Scurce Refactor MNavigate Search Project Run  LatticeTools Window Help

H-BR - Q- @ -8 -E-@-%-0"Q -0 §-H[ ﬂEJei@'%* DiP-H-oe-o-|m

Project Explorer &2

BESYT &

There are no projects in your workspace.
To add a project:

There is no active editor that
provides an outline.

Create a new Lattice 5oC Design
Project
Q Create a new Lattice C/C++ Project
rﬁ Create a project...
Ex3 lmport projects...

[T Properties | & Terminal

Mo consoles to display at this time.

Figure 3.2. Propel Workbench Window

3.1.2. Importing General Projects

In Propel SDK, you can use the importing projectwizardto import existing projects into workspace except for Lattice
SoC design created by Lattice Propel Builder.

Note: You canonly import projects which arecreated or managed by Propel SDK by choosing General > Existing Project
into Workspace in Propel SDK.

1. Inlattice Propel (SDK), chooseFile > Import....
The Select wizard opens (Figure 3.3).

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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£ Import O >

Select

Create new projects from an archive file or directory. Iﬁ

Select an import wizard:

| type filter text |

w = General ~
& Archive File
1= Existing Projects into Workspace
[ File System
[T Preferences
[ Projects from Folder or Archive
» [= CfC++ v

@ < Back Einish Cancel

Figure 3.3. Import Projects Wizard — General

2. Select General > Existing Project into Workspace. Click Next.

The Import wizard switches to Import Projects wizard (Figure 3.4).

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.
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Q Import

Import Projects

Select a directory to search for existing Eclipse projects.

(®) Select root directory: | (B

~ | Browse...

() Select archive file:

Projects:

Browse...

test (D:\test)

Select All

Dezelect All

Refresh

Options
[]5earch for nested projects
Copy projects into workspace I
[]Close newly imported projects upon completion

[ Hide projects that already exist in the workspace
Working sets

[] Add project to working sets

@ < Back Next >

Mew...

Select...

Figure 3.4. Import Existing Projects Wizard

3. Choose either Select root directory or Select archive file, clickingtheassociated Browse button to locatethe
directory or filecontainingthe project.

Select the project or projects you want to import inthe Projects area.

Be sureto check the Copy projects into workspace option sothat your original projects do notget updated.
Click Finish to startthe importing process.

3.1.3. Importing Lattice SoC Design Projects

In Propel SDK, you can use the Import Wizard toimport Lattice SoC design projects into workspace. Existing SoC design

projects created by either Propel SDK or Propel Builder can also be imported into Workspace by choosing Lattice
Propel > Lattice SoC Design Projects.

1. From Lattice Propel SDK, chooseFile > Import....

The Select wizard opens (Figure 3.5).

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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2 Import O X
Import Lattice SoC Design projects into the workspace. H
Select an import wizard:
| type filter text |
= General ~
= C/C++
= Git
= Install
~ (= Lattice Propel
o Lattice SoC Design Projects into Worksapce
= Oomph
= Run/Debug v
® < Back Finish Cancel
Figure 3.5. Import Projects Wizard — Lattice Propel
2. Select Lattice Propel > Lattice SoC Design Projects into Worksapce. Click Next.

The Select wizard switches to Import Lattice SoC Design Projects wizard page (Figure3.6).

7% Import O d

Import Lattice SoC Design Projects
Select a directory to search for existing Eclipse projects.

Select root directory | D ~ Browse...
Projects:
SoC_dema (D:N\SoC_demo) Select All
Deselect All
Refresh

® < Back MNext = Cancel

Figure 3.6. Import Lattice SoC Design Projects Wizard

Locate the directory containing the projects by clicking the Browse button.
In Projects area, select the SoC design projector projects you want to import.

Click Finish to startthe importingprocess.

12
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3.2. SoC Project Design Flow

A new SoC design projectincludinga Propel Builder design can be started from the Lattice Propel sets. Followthe steps

below to create a new SoC design project.

3.2.1. Creating a SoC Design Project

To starta Lattice SoC Design Project from Propel:

1. InLlattice Propel,choose File > New > *r Lattice SoC Design Project. The Create SoC project wizard opens

(Figure 3.7).
7% SoC Project O
Create SoC project —
Create SoC project of selected template
Project name: ExampleSoC|
Use default location
C\lscchpropelh2.0vworkspace\ExampleSoC Browse...
default
Template selection
Processor: | RISC-V MC ~ | Family: MachX03D
Device: LCMXO3D-9400HC ~ | Performance: | 5
Package: |CABGA236 ~ | Board: MachXO3D Breakout
Template Design
Empty Project Hello World Project. Cemponents included:
Hello World Project a) Processor - RISC-V MC wy/ PIC/TIMER
b) GPIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port

Figure 3.7. Create SoC Project Wizard

2. Enter a projectname.

Note: Do not include periods, colons, or spaces inthe project name.

3. (Optional) To change the defaultlocation, clear the Use default location option, then browse to another location.

Choose a filesystem.

Select a desired platform template design. In particular, selectempty project for building systemfrom scratch.

Click Finish.

The SoC design projectis created in workbench, and its designis opened and displayedin Propel Builder

(Figure 3.10).
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3.2.2. Open a SoCDesign in Propel Builder
Within a SoC project, there is a Propel builder design.
To open Propel Builder for a SoC project:

1. Inthe Project Explorer view, select an SoC project.

2. Open the SoC project in one of the following three ways from Propel:

e Choose LatticeTools > q'h OpenDesign in Propel Builder (Figure 3.8).

LatticeTools = Window Help

4, Open Design in Propel Builder

#  Generate and Open Diamond Progjct
Generate and Open Radiant Progjct
Lattice Sentry Tools for MachXO3D >
Lattice Sentry Tools for Mach-NX >

Figure 3.8. LatticeTools Menu

e  Clickthe Propel Builder icon q"" on the toolbar.

e Right-clicktheSoC projectfrom Project Explorer. Choose Open Design In > IH'l" Propel Builder from the popup
menu (Figure 3.9).

Restore from Local History...

Open Design In * 4. Propel Builder
Team »  »  Diamond
Compare With » Radiant

Figure 3.9. Project Explorer Popup Menu

3. SoC Design is opened and displayedin Propel Builder (Figure 3.10).

. Propel Builder [C\lscc\propel\2.0hworkspace\ExampleSoC\ExampleSoC/ExampleSoC.sbx] Device: LCMX03D-8400HC-5BG256C - [m] *
File Edit View Design Window Help

o= I | £
= o B8 N ¢
Design View (m]
~ 1} ExampleSoC
» @ Instances
3 2 Ports
, rE Nets atii2agtd st
+AHEL
v Components et 4 AR ] o st
@ cpul:1.0.0 | =
[ gpic0:1.2.0
@ sysmem0:1.0.0

H =l ¢

Schematic Address Start Page

g st

[—C> qia_ii{7:0]

LaR]

Properties

Name:

Type: Instance i
Path: ExampleSoC
VLNV: lattice:systembuilder:Examp

4 3

IP Catal... DesignVi.. =

Tel Console
%

Figure 3.10. Propel Builder Window
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4., (Optional) Modify the designin Propel Builder as desired. Most of the templates include a functional-ready SoC
design.
Note: You canonly create an SoC design using Empty Project template insidethe Propel Builder. Refer to
Lattice Propel Builder 2.0 User Guide (FPGA-UG-02126) for more details on how to create an SoC design using
Empty Projecttemplate.

3.2.3. Open Design in Lattice FPGA Design Software

Withinan SoC project, you cancreate a Lattice FPGA design projectincluding a Propel Builder design, and then open
the FPGA design projectinappropriatesoftware. There are two FPGA Design Software available, Lattice Diamond and
Lattice Radiant™. Depends on the device family usedinthe SoC project, only one of the FPGA Design software can be
selected from the userinterface, the other is grayed out. If MachXO3D or LFMNX device familyis used, the Lattice
Diamond related menu items areactive from Propel Ul. If LIFCL or LFD2NX device familyis used, the Lattice Radiant
related menu items are activefrom Propel Ul.

To open FPGA Design Software for an SoC project from Propel:

1. (Optional)Set Lattice FPGA design software installation location from Propel. By default, Propel can find the proper
Lattice FPGA design software installation location, usually thelatestversioninstalled onthe PC. You canoverwrite
it following steps below.

Choose Windows > Preferences. The Preferences dialogopens (Figure3.11).

Select Propel Setting from the left pane. Click the Browse button to pick up the installation location of Diamond or
Radiant. Or, leave the Radiant Location area and Diamond Location area blank, as default. Propel can find the
location atomically.

{71 Preferences O >

type filter text | Propel Setting L=l ~ §

General A
C/C++ Radiant Location
Help |
Install/Update
LiClipse

MCU Diamand Location
Mylyn |

| Browse...

Oomph | Browse...

Propel Setting
Remote Development

Run/Debug
SVEditor
Team
Terminal

Validation - Restore Defaults Apply

'/?3' I\_‘_ =i (@' 'C;' Apply and Close Cancel

Figure 3.11. Propel Preferences Dialog

2. Inthe Project Explorer view from the Propel main GUI, select an SoC project.

3. Open the SoC projectin one of the followingways:

&
e Choose LatticeTools > Generate and open a Diamond project; Or, choose LatticeTools > Generate and
open a Radiantproject.

e Clickthe Diamond icon ” or the Radiant icon from the toolbar.
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e  Right-clickanSoC projectfrom the Project Explorer. Choose Open Design In >

Design In >

Radiant from the right-click menu.

Diamond. Or, choose Open

4. Diamond/RadiantprojectforSoC is generated atbackground and islaunched (Figure3.12/Figure3.13).

* Lattice Diamond - Start Page

- X
File Edit View Project Design Process Tools Window Help
PrE-Hed g paih GEBRRa QS o
& 25 pd ™ P [r— —
PECHECHSCEHEGA=USSSVMBY BENEHE G
File List 8 % ([} start Page [ Reports [ 8 x
v @ ExampleSoC
LCMX03D-8400HC-5BG256C N
o — Strateai Project: Release Notes FPGA Design Guide ~
rategies i R X X
@9 AS @ODEH--- Lattice Diamend Software 3.12 Release Notes Design Planning
27 Area
1/0 Assistant E MNew... User Guides HOL Ceding Guidelines
F&’ Quick [ Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
Timing Recent Projects: Lattice Diamond 3.12 User Guide Other Tool Guides
Strategyl 8 Examplesor Lattice Synthesis Engine for Diamond User ModelSim Users Manual
pit ] soc2 Guu.ja . . ModelSim GUI Reference Manual
Input Files Lattice Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
SoC/] @soc Guide
¥ Examle ExampleSoC_ ModelSim Tutorial
M ExampleSoC/ExampleSoCy 8 hello Clarity Designer User Guide i y
Synthesis Constraint Files Lattice Diamond 3.12 Programming Tools User SYNPIify Pro User Guide
v LPF Constraint Files Guid Synplify Pro Reference Manual
[ ExampleSoClpf Software Update Center Reveal User Guide Synplify Pro Language Support Reference
Debug Files Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manual
Script Files 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for TelfTk
Analysis Files No updates available Windows Lattice on the Web
Programming Files Last check time: Thu Mar 13 13:46:33 2021 Lattice Diamond 3.12 Installation Guide for | attice Semiconductor
inux
< > Answer Datahase ¥
File List Process Hierarchy
ITd Console g X

>

» source "C:/lscc/propel/2.0/workspace/ExampleSol/diamond setup_template.tcl”

Td Console Cutput Error Warning®

Ready Mem Usage: 127,628 K
Figure 3.12. Diamond Project
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Lattice Radiant Software - Reports

File Edit View Project Tools

R ocC
’ u Synthesize Design

ev S,

+ [2] ExampleSoC B 2 Start Page — Reports A
8 LFCL-40-9BG400! E
< Strategies
[i=] Area Reports ExampleSoC Project Summary
i=lihinng Implementation Name: impl_1 Performance Grade
? Strategy1
- 3B impl_1 (Synplify Pro) Strategy Name: Strategy 1 Operating Conditior
v B3 Input Files ] Part Number: LIFCL-40-9E.G400I Synthesis:
.| BampleSoC/ExampleSoC.v * |=] Synthesis Reports
- Pre-Synthesis Constraint Files Family LIFCL Timing Errors
Lattice LSE b (7] Map Reports Device: LIFCL-40 Project Created
Synplify Pro
v Post-Synthesis Constraint Files Package CABGA400 Project Updated:
3
BampleSoCpdc RECEISIROIIEREROS Project File C/Iscoipropel/2 0fworkspace/ExampleSoC/ExampleSoC n
Debug Files
Script Files Implementation Location: Cuilscoipropeli2. 0fworkspace/ExampleSoCimpl 1
+ |=1 Export Reports
Analysis Files

Programming Files

1 F vartO{uartd_inst) - uartd.y

D sysmemO(sysmem0_inst) - sysme..,
1 F osch(osc_inst) - oscliv

El gpic0(gpiol_inst) - gpiol.w

El3 cpul({cpul_inst) - cpulav

1} apb0(apb0_inst) - apb0.v

El3 ahbl2apbl({ahbl2apbl_inst]) - ahbl2...

~ 1} ExampleSoC - ExampleSoC.v x®
»
»
»
»
»
»
»
»

I} ahbl0(ahbl0_inst) - ahblO.v

O AleList [ Source Template 2] 1P Catalog

u Map Design

Window Help

QQaQa@
u Place & Route Design

b |1 Misc Reports

4

> source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant_setup_template.tcl”

Starting: parse design source files

(VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae_library/synthesis/verilog/lifcl.v'

>

Td Console

= output

E’ Message

A

n Export Files 4

Resource Usage
LUT4

PFU Register:

10 Buffers

EBR:

Tu
X

Figure 3.13. Radiant Project

5. (Optional) Fromthe File List view of the Diamond/Radiantsoftware:

e modify the top-level RTL file (<proj_name>_Top.v) to match the SoC design, presupposition of whichis that
there is a top-level RTL fileinyour SoC design; or

e create atop-level RTL file (<proj_name>_Top.v) to match the SoC design,if the SoC designis created from an
Empty Projecttemplate andthere is notop-level RTL filein your SoC design.

6. (Optional) Modify constraintfile (<proj_name>.lpf/<proj_name>.pdc) to match the SoC design, if you have
modified the SoC design.

Note: This step is a mustto the SoC design thatis created from Empty Projecttemplate.
7. Processthe designin Lattice Diamond/Radiant.

In Diamond software, switch to Process view of the project (Figure3.14). Make sure at leastone file, IBIS Model,
Verilog Simulation File, VHDL Simulation File, Bitstream File, or JEDEC file, is checked in the Export Files section for

programming. Choose Process > = Run.
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# Lattice Diamond - Start Page - O s
File Edit View Project Design Process Tools Window Help
A-g-rHa8ra b @ERRIQAQ Y = =1
PECEESE S CEEGRARUSNSoMBY FEEEN:@
& x ([ start Page [ Reports [ & x
3 Synthesize Design
& Synplify P -
- yaplify e Project: Release Notes FPGA Design Guide "
+ Translate Design @O
v ™ Map Design H Open... Lattice Diamand Software 3.12 Release Notes Design Planning
e i Mew... User Guides HDL Coding Guidelines

[1 & Map Trace
[ & Verilog Simulation File
[ & VHDL Simulation File

[ Import ispLEVER Project...

v & Place & Route Design Reég::;:ﬂ:z:::s'
[0 & Place & Route Trace
[ 2 10 Timing Analysis [ soc2
[0 2 Thermal Analysis [ soc

v 2 Export Files 8 helo

[0 & 1BIS Model

Lattice Diamand 3.12 Release Notes Timing Closure
Lattice Diamond 3.12 User Guide

Lattice Synthesis Engine for Diamond User

Other Tool Guides
ModelSim Users Manual

Guide . . ModelSim GUI Reference Manual
I(_;autlt‘\j:: Diamond 3.12 Platform Designer User ModelSim Command Reference Manual

Clarity Designer User Guide ModelSim Tuterial
Lattice Diamend 3.12 Programming Tools User Synplify Pro User Guide

oz Verilog Simulation File Guid Synplify Pro Reference Manual
[ & VHDL Simulation File Software Update Center Reveal User Guide Synplify Pro Language Support Reference
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manual
2 JEDEC File 3.12.0.290.2 Lattice Diamond 3.12 Installation Guide for 19/ 1K
Mo updates available Windows Lattice on the Web
Last check time: Thu Mar 18 13:46:39 2021 Il:iantl:\;e Diamend 3.12 Installation Guide for Lattice Semiconductor
Answer Datahass b
File List Process Hierarchy
Cutput & x
synpwrap —msg -prj "ExampleSoC_impll synplify.tcl” -log "ExampleSoC_impll.sri” ~
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserwved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v

Td Console Qutput Error Warning Info=

Start: Synplify Pro

Mem Usage: 313,848 K

Figure 3.14. Generate Programming File in Lattice Diamond

In Radiantsoftware, from the Process Toolbar, click Export Files (Figure 3.15).

Lattice Radiant Software - Reports

> prj_run Synthesis —impl impl 1

Td Console = OQutput

O File st [E source Template Elr Catalog

File Edit View Project Tools Window Help
= =
o 3 H QQQa@ ARE »
ynthesize Design Map Design Place & Route Design Export Files B
o g u p Desig n g Xpor
+ [ EcampleSoC % 12 Start Page | Reports ° A
I8 LIFCL-40-9BG4001 : -
v [ Strategies L\ Synthesize Design
= Argea R rts L\ Synplify Pro
r:—\ Tirmin epo = Post-Synthesis Timing Analysis
r:? St a‘g 1 Post-Synthesis Simulation File Performance Grade
5 rategy .
v % impl_1 (Synplify Pro) Map Design ] ] Operating Conditior
* [ Input Files ] Map Timing Analysis
%) ExampleSoC/ExampleSoC.y » [] Synthesis Reports Place & Route Design oo SIS
+ [ Pre-Synthesis Constraint Files = Place & Route Timing Analysis Timing Errors:
£ Lattice LSE 1/0 Timing Analysis
& S;n:\:"y . *» 5l Map Reports Export Files Project Created:
Bitst Fil .
< EI Post-Synthesis Constraint Files = ! II::I:!I ':I Project Updated:
» odel
B bh":'lp'es o-pde AEESRINEHIE B - Gate Level Simulation File 212, Dfworkspace/ExampleSoC/ExampleSoC. i
ebug Files i
[ Script Files » [ Export Reports 212 0fworkspace/ExampleSoCimpl 1
EI Analysis Files
1 Programming Files
. " » 2l Misc Reports
LUT4: 0 10 Buffers
PFU Register: 0 EBR:
1 = 3
> source "C:/lscc/propel/2.0/workspace/ExampleSoC/radiant setup template.tcl” [Ea x "

Starting: parse design source files
(VERI-1482) Analyzing Verilog file 'C:/lscc/radiant/3.0/cae_library/synthesis/verilog/lifcl.v'

&=l Message

Figure 3.15. Generate Programming File in Lattice Radiant

The Programming fileis generated. The generated programming filecanbe used inthe Programmer.
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3.2.4. Generating System Environment by Building Project

System environment package includingthe system environment fileand the BSP package is required for the embedded
C/C++ project.

To generate system environment package from Propel:

1. Inthe Project Explorer view, select an SoC project.

2. Choose Project > Build Project.

3. Check the buildingresultinthe Console view (Figure3.16).

{2 Problems |4 Tasks | B Console 2 1 Properties | @@ Terminal = B8

X% &EREE -0
<terminated> sge [SDP Builder] C\lscc\propel\d.0hvtools\python38_embed\python.exe

Warning - Unconnectien: cpu® inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 3.16. Build Result of SoC Project

3.2.5. About SoC Design Project

The SoC project creating starts with a functional-ready SoC design and a default simulation environment. In the Project
Explorer view, open an SoC project folder and all its sub-folders. The project contains the following files but not limited
to the followingfiles (Figure3.17),some of which may vary upon your opening the SoC design project in Diamond or
Radiantsoftware:

e <proj name>: Folder contains a Propel Builder designincluding the .sbx file.

e <proj_name>/application: Folder contains functional-ready embedded application source codes.
e impll:Folder contains the implementation of Diamond/Radiant project.

e sge: Folder contains generated packagenecessary for creating C/C++ project.

e verification: Folder contains theSoC verification project.

e verification/sim:Folder contains thesimulation environment.

e <proj name>.ldf: Diamond projectfile.

e <proj_name>.Ipf: Diamond projectlogical preferencefile.

e <proj_name>.rdf: Radiantprojectfile.

e <proj name>.pdc: Radiantprojectpost-synthesis constraints.

e <proj_name>.txt: Description filefromthe template.
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f|ﬁ.'1"‘_‘| Project Explorer 2
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|
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=]

w = ExampleSoC
v [= ExampleSoC
» [ application
» = lib
ExampleSoC_tmply
Vh ExampleSeC_tmplvhd
ExampleSeC_Top.v
ExampleSoC.sbhx
ExampleSoC.v
» = impll
v [= sge
» [= application
» = bsp
% = soc_svd
fu) cpul.yaml
S sys_env.xml
w = verification
» [= lib
¥ = sim
jsen ExampleSoC_v.json
ExampleSoC_v.shx
diamond_setup_temnplate.tel
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ExampleSoC.lpf
ExampleSoC.bet
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Figure 3.17. Contents of SoC Project
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3.3. C/C++ Project Design Flow

3.3.1. Creating a Lattice C/C++ Project

To starta Lattice C/C++ Project from Propel:

1. Choose File > New > @ Lattice C/C++ Project.

The C/C++ Projectwizard opens with the Load system and bsp page (Figure 3.18).

01 C/C++ Project O

Load system and bsp —

Correct system envirenment file and get toolchain parameter

Select system environment file and bsp package

System env: | Chlscch\propeh2.0hworkspace\ExampleSoChsgelsys_envaxml ~ Browse...

Select processor core to create C/C++ Project

Core selected: | cpul_inst
Project type:  |C
Systemn information

Device Family CPU Mame Instance Mame

MachXO3D riscy_mc cpul_inst

@' < Back Finish Cancel

Figure 3.18. Load System and BSP Dialog

2. Browse to the SoC project folder and select the system environment filesys_env.xml.

All system environment files availablein the current workspacecan be selected from the System env: drop-down

menu.

Ifthe platformhas more than one processor,choose one core.

Choose the project type, C or C++.

5. Click Next.
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The C/C++ Project dialogopens (Figure3.19).

S C/C++ Project

C/C++ Project
Create C/C++ project of selected type

Project name: | Example

Use default location
Location: | CAlscc\propeh2.0hworkspace\Example

Choose file systern: |default

Project type: Toolchains:

Browse...

= GNU Autotools
v = Executable
& Empty Project
® Lattice C/C++ Project
& Hello World RISC-V C Project
& Hello World AMSI C Project
(z= Shared Library
(7= Static Library
= Makefile project

RISC-V Cross GCC

Show project types and teolchains only if they are supported on the platform

< Back

@

Finish

Cancel

Figure 3.19. Create C/C++ Project Dialog

Enter a projectname. Suggest not using periods, colons, or spaces inyour projectname. Though spaces are

allowed, they may causecertainissue with some tools.

By default, the Use defaultlocation option is checked. The default filesystem is selected automatically. Suggest

usingthe defaultlocation, unless you have special need to a special location.

Select a project type. Select a toolchain. Normal choiceis Lattice C/C++ Project and RISC-V Cross GCC.

Click Next.

22
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The Lattice toolchain setting dialogopens (Figure 3.20).

{73 C/C++ Project O *

Lattice toolchain setting

Configuration: | Debug ~

Lib Setting  C/C++ Compiler C/C++ Linker
() Mo default libraries(-nodefaultlibs)

() Newlib
(® Newlib-nano

'::?j' < Back Mext = Cancel

Figure 3.20. Lattice Toolchain Setting Dialog

10. By default, two toolchain configuration modes, Debug and Release, can be chosen from the Configuration
drop-down menu.

e Debug configuration creates executables containing additional debuginformation thatlets the debugger make
directassociations between the sourcecode and the binaryfiles generated from the original source.

e Release configuration provides thetools with options setting to create an application with the best
performance.

You can modify frequently-used library, compiler,and linker options for each configuration. For a complete

toolchain setting, go to project properties after creatingthe project. Refer to the Advanced Tool Chain Setting

section.

e InLib Setting tab, standard Clibrary can bereconfigured. The nano version of library (Newlib-nano)isselected
by defaultfor small embedded usage.

e |InC/C++ Compiler tab, optimization level and debug level can be reconfigured for each toolchain
configuration.

e |InC/C++ Linker tab, Remove unused code (--gc-sections) is checked by default for garbage collection of unused
code.

11. Click Finish.

The Lattice C/C++ projectis created andis displayed usingthe Propel SDK perspective. A perspective is a collection
of tool views for a particular purpose. The Propel SDK perspective is for creating Lattice C/C++ programs.

3.3.2. Updating a Lattice C/C++ Project

When you make changes to an SoC project, sometimes you want to synchronizethe changes to anexisting Lattice
C/C++ projectinstead of creatinga new Lattice C/C++ project. Inthis case,you can usethe update C/C++ project
feature.

Note: This feature overwrites the correspondingfiles or settings of your existing C/C++ project. Be sure to back up your
C/C++ projectbefore usingthis feature.
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To update a Lattice C/C++ Project from Propel:

1. Generate the latestsystem environment packageaccordingto the Generating System Environment by Building
Projectsection.

Inthe Project Explorer view, select a C/C++ project.
3. Choose Project > Update Lattice C/C++ Project....
The C/C++ Projectwizard opens for updating system and bsp (Figure 3.21).

73 C/C++ Project — O x

Update system and bsp

Select system environment file and bsp package

Systern env: | IC:/lscc/propel/2.0/workspace/ExampleSeC/sge/sys_env.xml Browse...

] Re-generate toclchain parameters and linker script

[]Update bsp package

Update Cancel

Figure 3.21. Update System and BSP Dialog

4. Browse to the SoC project folder and select the system environment filesys_env.xml.
5. Select the checkbox for what you can update:

e Re-generate toolchain parameters and linker script: check this option if you want to modify CPU or memory in
the system.

e Update bsp package: check this optionifyou want to add additional IP components into the system.

6. Click Update to make changes for the selected C/C++ project.

3.3.3. Building a Lattice C/C++ Project
To build a Lattice C/C++ project in Propel:
1. Inthe Project Explorer view, select a C/C++ project.

2. Followsteps below ifyou want to change the active build configuration:

Choose Project > Build Configurations > Manage.... Or, click the Configuration icon ® onthe toolbar.

b. The Manage Configurations dialogopens (Figure 3.22) for choosingactive configuration. By default, a Debug
configuration creates executables containing additional debuginformation that lets the debugger make direct
associations between the source code and the binary files generated from the original source. ARelease
configuration provides the tools with options setting to create an application with the best performance.
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Q Exarnple: Manage Configurations X

Configuration Description Status

Debug Active

Release

Set Active Mew... Delete Rename...

Figure 3.22. Manage Configurations Dialog
3. Choose Project > Build Project. Or, click the Build icon % on the toolbar.
4. The results of the build command aredisplayed inthe Console view (Figure 3.23).
[2] Problems | ] Tasks | & Console 2 . [ Properties| & Terminal 4L q4p <_E|>| =i i =M | L= Il B R
CDT Build Conscle [Example]
A
Invoking: GNU RISC-V Cross Print Size
riscv-none-embed-size --format=berkeley "Example.elf”
text data bss dec hex filename
1262 =] 2723 3996 f96 Example.elf
Finished building: Example.siz
Invoking: Lattice Create Memory Deployment
riscv-none-embed-cbjcopy -0 binary --gap-fill @ "Example.elf” "Example.bin"; srec_cat "Example.bin”
-Binary -byte-swap 4 -DISable Header -Output “Example.mem" -MEM 32
Finished building: Example.mem
15:58:18 Build Finished. @ erreors, 8 warnings. (took 5s5.21ms)
v

Figure 3.23. Build Result of C/C++ Project

3.3.4. About Lattice C/C++ Project

The Lattice C/C++ project starts with source code. In the Project Explorer view, open a C/C++ project folder and all its
sub-folders. The project contains:

e src/bsp/driver: Folder contains driver codes fromthe IP in the platform.

e src/bsp/sys_platform.h: Header filethat defines DEVICE_FAMILY (the Lattice FPGA), address mapping,andany IP
parameters that can be used by the drivers.

e src/main.c:Sourcefilecontains the main routine, whichis the entry-point of a C/C++ program.

e src/cpu0.svd: System view description fileused for peripherals registers view at debug perspective.

e src/cpu0.yaml:Processor description fileused at debugging time.

e src/linker.ld: Linker scriptfile.

e src/sys_env.xml:System environment filedescribing aspects of the platform,such as memory spaces.

After buildingthe project, the build output can be found in each build configuration folder, the Debug folder or the
Release folder (Figure 3.24). The Debug or Release folder contains:

e <proj name>.elf: Executable fileused inon-chip debugging.

e <proj_name>.bin: Binaryfileusedindeployingthe applicationtoflash memory.
e <proj name>.lst: Extended listingfilegenerated by tool objdump.

e <proj name>map: Linker map file.

e <proj_name>mem: Lattice system memory initialization fileusedin System_Memory IP.
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Note: Some of the files listedin Figure 3.24 areintermediate files thatyou do not need to take careof.

5 Project Explorer &3 = O
BS Y 8
v (== Example
d:;? Binaries
i Includes
w [ sre
v (= bsp
[= driver

[h| sys_platform.h

[ main.c
[ utils.c

[H utils.h

[ cpub.svd
cpulyaml
el linker.ld

Fi
i% sys_envxml

w = Debug

[= src
%5 Example.elf - [none/le]

|=| Examplebin
Examplelst

Example.map
Example.mern

| & makefile

| @ objects.mk

| @ sources.mk
=% ExampleSoC

Figure 3.24. Contents of C/C++ Project

3.3.5. Writing Code

Lattice Propel is based on EclipseIDE. You can write application code followingthe process and usage of the same tools
asanyinEclipselDE. You can get more detailed information regarding Eclipse IDE from the Propel onlinehelp.

For writing code, Lattice Propel SDK provides two extra aids:
e lattice System Platform: An overview of the processor platform canbe displayed (Figure3.25).

e Linker Editor: An overview of the memory regions of linker scriptcan bedisplayed.You can modify key linker
parameters via the graphical interface (Figure 3.26).
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DeviceFamily: | MachX03D

i Lattice Platform 53 = 8
General
Vendor: | attice |
Library: | Propel |
Name: | ExampleSoC |
Version: [20 |
|
|

Bsplocation: | bsp

component ipnarme version  vendor basefAddress  range irg
cpull_inst riscV_mc 1.0.0 latticesemi.com D FEFFODD0 200
sysmem0_inst  system_memory  1.0.0 latticesemi.com  OxD 03000

gpiod_inst gpic 120 latticesemi.com  Dx3000 400 IRQ_S1
uart(_inst uart 1.0.1 latticesemi.com D 8400 400 IRQ_50

Owverview | sys_envaxml |

Figure 3.25. Lattice System Platform

% Lattice Platform rﬁ Linker 2 = g

Linker Script: linker.ld

Available Memory Regions
MNarme Attributes  Base Address Size
sysmermn{_inst rwx Ox0 03000

STACK and HEAP Size

HEAP_SIZE: | 0xD |
STACK_SIZE: | 0xA0D |

Section to Memory Region Mapping

Section Mame Memaory Region 2
sysmermn{_inst
«ctors sysmem{_inst
dtors sysmermn{_inst
rodata sysmem{_inst
data sysmermn{_inst
bss sysmem{_inst W

Overview | linker.d |

Figure 3.26. Linker Editor
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3.3.6. Advanced Tool Chain Setting

Followthe process below to modify the tool chainsettings of a C/C++ project.

To change tool chainsettingin Project Properties in Propel:

1.
2.
3.

Inthe Project Explorer view of Propel,select a C/C++ project.

Choose Project > Properties. The Properties for current projectopens (Figure 3.27).

Select Settings of C/C++ Build category from the left pane. Select the Tool Settings tab.

Q Properties for Example

type filter text

Resource
Builders
w /C++ Build
Build Variables
Environment
Legging
Settings
Tool Chain Editor
C/C++ General
MCU
Project Matures
Project References
Run/Debug Settings
SystemVerilog Project Properties
Task Repository
Task Tags
Validation

Settings

Configuration: |Debug [ Active ]

%) Tool Settings I3 Toolchains M Devices . Build Steps

@ Target Processor
(# Optimization
@ Warnings
@ Debugging
~ 133 GNURISC-V Cross Assembler
(#2 Preprocessor
@ Includes
(2 Warnings
(#5 Miscellaneous
w 3 GMU RISC-V Cross C Compiler
(2 Preprocessor
(22 Includes
@ Optimization
(2 Warnings
(# Miscellaneous
w 83 GMU RISC-V Cross C Linker
(2 General
(22 Libraries
@ Miscellaneous
~ I35 GNU RISC-V Cross Create Listing
(#2 General
w 83 GMU RISC-V Cross Print Size
@ General
~ I3 Lattice Create Memery Deployment
@ General

&

~ | | Manage Configurations...

Architecture

Build Artifact Binary Parsers @

4

RV32| (-march=rv321%) w
[J Multiply extension (RVIM)
] Atomic extension (RVA)
Floating point None ~
Compressed extension (RVC)
Integer ABI ILP32 (-mabi=ilp32*) ~
Floating point ABl | None ~
Tuning Teolchain default ~
Code model Teolchain default ~
Small data limit | 8
Align Toolchain default (-mtune) ~

[[]Small prologue/epilogue (-msave-restore)

Force string eperations to call library functions (-mmemcpy)

Other target flags |

Restore Defaults

Apply and Close

Apply

Cancel

00

L3

Customize the tools and tool options. All your customization can be resulted in the build configuration in the Tool

Figure 3.27. Properties of C/C++ Project

Settings properties tab. The build configurationisused duringyour C/C++ projectbuilding.

Note: Setting for each configuration, Debug or Release, is independent.

Click Apply and Close to savethe change.

Note: You may need to clean the project to make the new setting take effect for the whole project.

28
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3.4. System Simulation Flow

The SoC Project created from template has a default simulation environment for you to setup andstartfunctional

simulation.Itis generated automatically along with the SoC project creation.You canuseitas a startpointand

customize accordingly.

The default simulation environmentis with the followingfeatures:

e Provides similar user experienceas real board-level debugging, such as for Hello World SoC, key components
including RISC-V MC, System memory, and UART.

e Simulates user-modified template SoC with extended HDL designs.

e Simulates the whole system usingreal C/C++ projects as stimulus with the necessary modification and with all the

details for debugging.

e  Supports user extension with a friendly and flexibleapproach.

3.4.1. Launch Simulation

To launch simulation:

1. InPropel Builder,update the SoC designto enable simulation features.

e Enable the checkbox for Simulation Mode, and disablethe checkbox for Debug Enable for RISC-V MC |P
module in the General area (Figure 3.28).

., Module/IP Block Wizard

Diagram cpul

Configure Component from IP riscv_mc Version 1.2.0
Set the following parameters to configure this component.

Configure IP

cpul

[HIRQ_SOAHBL_MO_INSTR=H
[IRQ_S1 AHBL_M1_DATAH

—{dk_i TIMER_IRQ_MOH
—rst_n_i system_resetn_o
riscv_mc

| Property
~ General
Simulation Mode
Debug Enable
Compressed Instruction Extension
PIC Enable
Tirer Enable
PIC and Timer Base Address (32'h00000000 ~ 32'hFFFFFFFF)
Mumber of Interrupt Requests [2 - 8]

Mo DRC issues are found.

Value

3

Fa

'hFFFFOD0D

Generate

Cancel

Figure 3.28. Configure Module RISC-V MC

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

FPGA-UG-02127-1.0

29


http://www.latticesemi.com/legal

Lattice Propel 2.0 SDK
User Guide

mLATTICE

Enable the checkbox for Initialize Memory for system_memory |P module from the Initialization area of the

General tab, and set Initialization File generated from the corresponding C/C++ project (Figure 3.29).

“. Module/IP Block Wizard

Configure Component from Module system_memory Version 1.0.2
Set the following parameters to configure this component.

Diagram sysmem0

.

sysmem0O
.
AHBL_SO
AHBL_S1
— ahbl_hclk_i
—ahbl_hresetn_i
iy

system_memory

Configure IP
General Port 50 Settings Port 51 Settings
Property Value

Memory Address Depth [1 - 32768] | 8192

Data Bus Width(bits) 32
Memory Type EER
Port Count [1-2] 2
Enable Arbiter

Enable FIFO Streamer

Initialize Memory

Initialization File Format

Initialization File

Example/Debug/Example.mem

Mo DR.C issues are found.

Generate Cancel

Figure 3.29. Configure Module System Memory

2. Clickthe Switch icon on the toolbar to switch between SoC design and SoC verification project (Figure 3.30).

3.

==

After the SoC designis switchedto an SoC verification project, click the Generate iconl-’EiJ to generate the

simulation environmentfor OEM ModelSim. Click the Launch Simulation icon .' (Figure 3.30).

30
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%, Propel Builder [Ci/lscc/propel/2.0/workspace/ExampleSoC/verification/ExampleSoC_v.shx] Device: LCMXO3D-8400HC-5BG256C - O *
File Edit View Design Window Help
i—TH [FY =] Y
3 e « TMmENSOHEHB @QQ@Q
Design View = schematic Address Start Page
- ﬂ ExampleSoC_v "
3 ﬂjF Instances
sclk_rst_genl_inst uart_modell_inst
v i Nets Res B o
+ [ Components b th_ck_o uart_rx_data_debugje=
[ sysclk_rst_gen1:1.0.0 1'b0 dut_clk_dut_rst_o uart_tx_data_debugp=
[ vart_ model1:1.0.0 1'60 dut_rst_dut_ck_o k uart_rx_break_debug—
th_rst_o rstn uart_rx_valid_debugp—
uart_rxd uart_tx_busy_debugj—
Properties T uart_ix_en_debug—
MName: uart_txd
Type: Instance
Path: ExampleSoC_v
VLNV: |attice:svstembuilder:Exame »
a4 »
1P Catal.. Design Vi... r i
Tcl Console m|
Finished: "sbp design close" b
% sbp_design open -name ExampleSoC_v -path {C:/lscc/propel/2.0/workspace/ExampleSoC/verification/ExampleSoC_v.sbx}
3 -

Figure 3.30. SoC Verification Project

4. ModelSimislaunched runningsimulation for the SoC verification project. The corresponding waveform of the SoC
verification projectfor the Hello World projectis shown (Figure 3.31). Check the waveform.

M ModelSim DE 20203

- o x
file Edit View Compile Simulste Add Wave Tools Layout Bookmarks Window Help
|8-s@=8 J.,Gan,g'_n‘;,.ugumb h]@"? ”ﬂﬁ| G (5 oo EEEBAG Ennm“!:‘! L@ 8 || tevout simlace !|
[ Comrtoro fonzacss Al a-a-2@-2| [0 wm e[ & oleu ] L& el i £ € o Yy
|eaeassa|| L a/mimi
B om -vefadt ——:—— # d x] e .
R .
=l viest .
+ GSR_INST
;:nu(:ns( 2 [vtestidut_instjrstn

- B sysck_rst_pen1_inst Pl
- 8 vart_model1_inst
@ =ASSIGN=82

-l st
| #vem_capacity=

4 fvtestjdut_inst/bed_o
£ vtestjuart_model1_inst/ck
£ [vtestiuart_model1_instrstn

4 jetestjuart_model1_instjuart_red

. vtestjuart_model1_insthuart_ted
fvtestjuart_model1_inst/uar _debug
testjuart_model1_inst/uart_rx_valid_debug

Figure 3.31. Waveform of Hello World Project

3.4.2. Simulation Details

The default simulation environmentis located atthe generated simfolder insidethe SoC verification projectin Propel.
It contains:

[sim] -- generated simulation environment
[hdl_header]
soc_regs.v -- register definitions of all thecomponents in DUT/SOC
sys_platform.v  -- baseaddress, user settings of all the components in DUT/SOC
[misc]
* ok -- all the mem, hex, txt files will becopied here
flist.f --filelistfor HDLs
msim.do --do scriptfor simulator,itcanbe gsimfor Questasim
wave.do --do scriptforaddingsignalsin waveformwindow
<project_name>.sv -- top testbench, SystemVerilog based

You can extend more verification features in the top testbench.
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About Hello World Project

The Hello World Projectis designed to printsome strings using a top-level UART port. The testbench instantiates a
UART model to receive these data. Each byte (refer to uart_rx_data shown in Figure 3.31) can be checked using ASCII
format. Meanwhile, this UART model alsosupports sendingthe data to Design Under Test (DUT). The dataisstoredina
text fileand enabled by STIMULUS_GEN parameter.

3.5. Programming and On-Chip-Debugging Flow

This section describes the process of testing and debugging application codeon the actual hardwareincludingthe
Lattice FPGA with the hardwaredesign installed. Debugging with Propel SDK follows the same process and uses of the

same tools of any of those in EclipseIDE.

Before debugging, download the hardware design created from Diamond/Radiant Programmer. Refer to the User
Guide of the specific evaluation board for more details on the evaluation board.

3.5.1. Creating a Debug Launch Configuration

To debug a program, a debug launch configuration mustbe created. Most of the settings for a debug launch
configuration can beautomatically entered. Only a few settings need to be manually configured.

To create a debug launch configuration:
1. Inthe Project Explorer view of Propel,select a C/C++ project.

2. Buildthe projectand ensure the executable fileis available. Refer to the Buildinga Lattice C/C++ Projectsection for
details on the process.

3. Choose Run > Debug Configurations...
The Debug Configurations dialogopens (Figure 3.32).

7t Debug Configurations O *

Create, manage, and run configurations

[ § = *| B Y- Name:|ExampIeDebug |

|t}"pEfi|tEI'tl':5<t | [£] Main . [Z| CableConn| %3 Debugger| = Startup| & Source| [C] Commen| &, SVD Path
[©] C/C++ Application

Project:
[©] C/C++ Attach to Application g
[©] C/C++ Postmortem Debugger | Example | Browse...
[€] C/C++ Remote Application CfC++ Application:

Cif C/C++ Unit
[t ] GDB Hardware Debugging
w [t | GDB Open0CD Debugging Variables... Search Project... Browse...
¢ | Example Debug
[c| GDB QEMU Debugging

L Launch Group Build Cenfiguration: | Select Automatically ~
@ Launch Group (Deprecated)

| DebughExample.elf

Build (if required) before launching

(") Enable auto build () Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Apply

Filter matched 11 of 11 items

Figure 3.32. Debug Configurations Page
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4., Double-click GDB OpenOCD Debugging to create a new launch configuration.

A multi-tab pageis displayed. The Maintabshould already be filled in with the projectname, application filename,
and location.

5. Select the CableConn tab (Figure 3.33). This tab enables you to select a specific deviceon a specific cableport.

Click the Detect Cable button. Select the specific cable portfrom the Port drop-down list. By default, the first
availablecableport: FTUSB-0 is selected.

Click Scan Device button. Select the specific device from Device drop-down list. By default, the firstavailable
device on selected cableportis selected.

Keep the cablespeed sothatyou canuse the default clock divider.

7 Debug Configurations O >

Create, manage, and run configurations

CE 5| X | = Name: | Example Debug |
|t:.-'pr:fi|tr:rtr:><t | [E] Main | [5 CableConn . %5 Debugger| = Startup| & Source| [] Common| &, SVD Path
[E] C/C++ Application Cable Settings

[E] C/C++ Attach to Application

Port: FTUSE-0,USB2,Dual R5232-HS B Location 0000 w Detect Cable
[E] C/C++ Postmortern Debugger
[E] C/C++ Remote Application Device Settings
Cif C/C++ Unit

Device: | LCMXO3D-9400HC:0x212E3043 e Scan Device

[£] GDBE Hardware Debugging
GDE OpenOCD Deb i
vE pen coHaang Speed Settings
[t ] Example Debug o
[£] GDB QEMU Debugging (®) Use Default Clock Divider
i Launch Group () Use Customn Cleck Divider

@ Launch Group (Deprecated) 1 =

. . Revert Apply
Filter matched 11 of 11 items

@ Close

Figure 3.33 CableConn Tab of Debug Configurations

6. Select the Debugger tab (Figure 3.34). Itis critical thatthe Config options field contains the correctcommand line
options to be passedto OpenOCD.

—c "set port S{PORT}" is required for the selection connected to Lattice cable.The valueof variable
“S{PORT}’comes from the cablesettings of CableConntab.

—c "set target S{DEVICE}" is required for the selection specific device on the Lattice cable. The valueof variable
“S{DEVICE}’comes from the device settings of CableConntab.

—c "set tck S{TCKDIV}" is required for setting clock divider of the Lattice cable.
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i} Debug Configurations O X

Create, manage, and run configurations

CFeEBX| B Y-~ Name: | Example Debug

| type filter text | Main ( CableConn rﬁti“r Debugger - [ Startu;ﬂ 7 Source] =] Commonw T svD Pathw
[E] C/C++ Application OpenQCD Setup ~
[E] C/C++ Attach to Application Start OpenOCD locally

[E] C/C++ Postmortern Debugger
[E] C/C++ Remote Application

Cif C/C++ Unit Actual executable: | Chlscc\propel2 Dhsdk\eclipse\/../openocd/bin/openocd.exe |

[E] GDB Hardware DEbqulhg (to change it use the global or workspace preferences pages or the project properties page)
w [ | GDB Open0QCD Debugging

[£] Example Debug GDE port: 3333

Executable path: | S{epenccd_path}/${openocd_executable} | | Browse... | |Variab|5... |

[c] GDB QEMU Debugging Telnet port:
& Launch Group
= Launch Group (Deprecated) flelpoit 6666

Config options: || _¢ "set target ${DEVICE}" -c "set tck S{TCKDIV}" -¢ "set port ${PORT}" -f
interface/lattice-cable.cfg -c "set RISCV_SMALL_YAML
{8{ProjDirPath}/sre/cpulyaml}” -f target/riscv-small.cfg

Allocate console for OpenQCD Allocate console for the telnet connection v

Revert Appl
Filter matched 11 of 11 items LI

@ Debug | | Close

Figure 3.34 Debugger Tab of Debug Configurations

7. (Optional)Select the Common tab (Figure3.35). The Save as > Local file option is selected by default. This causes
the debug launch configuration to be saved into the workspace.

Change setting the Save as field to Shared file to let the debug launch configuration saved into the project that
aids the project portability.
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Q Debug Configurations

Create, manage, and run configurations

CEHeRExX | =R MName: | Example Debug
| type filter text | Main ( CableConn ﬁi?- Debugger (Eb Startup (E/ Source ﬂ-—=| Common .72, SVD Path
[E] C/C++ Application Save as -
[E] C/C++ Attach to Application ) Lecal file
[t] C/C++ Postmortem Debugger .
[E] C/C++ Remote Application Qe Te | \Bxample | e
Coo .
i C/Ce+ Unit . Display in favorites menu Encoding
[t ] GDB Hardware Debugging . .
« [€] GDB OpenOCD Debugging O #Debug (®) Default - inherited (UTF-8)
721 Example Debug O @ Run (O Other | 150-8850-1
[t] GDE QEMU Debugging
L Launch Group
= Launch Group (Deprecated)
Standard Input and Output
Allocate console (necessary for input) "
Revert Appl
Filter matched 11 of 11 items Ry

@

Figure 3.35 Common Tab of Debug Configurations
Remain settings as default. Do not change the settings unless necessary, or unless you understand what effect
these changes may have.

9. Click Apply to keep the current settings.
10. Click Close.

3.5.2. Starting a Debug Session
Before startinga debug session, be surethat:
e latticecableis connected to the computer.

e The target deviceis power ON.

e The hardwaredesign has a debug enabled processor module and already programminginto the target device.

With the above steps completed properly, followthe steps below to startthe debug session from Propel.
1. Choose Run > Debug Configurations...

2. Ifnecessary, expand the GDB OpenOCD Debugging group.
3. Select the newly-defined configuration.
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Click the Debug button (Figure 3.35).

Alternatively, for later sessions, usethe Debugicon jﬁ'f’-‘ on the toolbar. Do not click the Debug icon directly.
Instead, click the down arrow beside the Debug icon. Select the desired debug configuration from the drop-down

menu (Figure 3.36).

$ 0" Q- OE 5~

[c| 1Example Debug

Debug As
Debug Configurations..,

Organize Favorites..,

Figure 3.36. Debug Icon on Toolbar

5. Waitfor a few seconds for switching to debug perspective, startingthe server, connecting to the target device,
startingthe gdb client, downloadingthe application and starting the debugging session.
6. The Propel Window displaysas shownin Figure3.37.The execution stops rightat the beginning of the main()
function.
3 waorkspace - Example/src/main.c - Lattice Propel - [m] x
File  Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help
:[mi] @ |EBiiw o ® &3 @ 0l SR SNIH-0 - - -FH-C0 -0
Q BB
45 Debug 22 {4 Project Explorer = B || [ mainc £ = B ||w=v 22 % B|&LE|E P| = 8
g g 35/ A ARRANT OR REPRESENT THAT THIS FILE, ITS COI 5 : o= 8
= | 1ﬁ> 8 36 J// USE THE F ES N INFRINGE ON THIRD PARTIES' INTELLECTUAL & E| tIe s
v [£] Example Debug [GDB OpenOCD Debugging] 37 // RIGHTS, INCLUDING ANY PATENT. IT IS THE USER'S RESPONSIBILIT Name Type
VE Example.elf 38 // THE USER SOFTWARE DESIGN FOR CONSISTENCY AND FUNCTIOMNALITY Tt 9= idx uints t
v @ Thread #1 (Suspended : Signal : 0:Signal 0) || 39 // - VALIDATION METHODS. -
= main() at main.c:46 Oxddc TS /7
wel openocd.exe 42 #include “utils.h”|
g fiscv-none-embed-gdb
=int main(void) {
static uintd t idx = @;
DEBUG_PRINTF("Hello RISC-V world!\r\n");
LED_SET(ALL_OFF);
while (true) {
LED_SET(LED_ON(idx)}; P =
if (++idx == LED COUNT) { Name : idx o
idx = @; Details:e '\@'
H Default:e "\a@'
Decimal:@
if (RTL_SIM Hex: @x@
* <4ﬁ1?..w2«{\:. v Rinaru: v
< >
& Console | 111} Registers | 4 Terminal [21 Problems | (3 Executables [ Debugger Console &3 0 Memory B~-=08
Example Debug [GDE OpenQCD Debugging] ${cross_prefix}gdbS{cross_suffix} (177)
~
P t d.
e e v
Writable Smart Insert 42:19: 2503 165M of 334M @'

Figure 3.37. Debug Perspective

3.5.3. Peripherals Registers View

Peripherals registers view provides an easy-to-useinterface for examining or modifyingthe valu
registers during a debug session.

To useperipheral registers view in Propel (Figure 3.38):

es of peripheral

1. Make sureanactive debug sessionisrunandshowninthe debug perspective.
2. Findthe Peripherals view which is inthe same window with the Variables and Breakpoints views. For anyreason,
if not found, re-open from Window > Show View > Peripherals.
The Peripherals view lists all peripherals availablein the system view description svd file within the C/C++ Project.
© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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3. Selecting a peripheral in the Peripherals view can open a Memory Monitor that is mapped to the corresponding
peripheral memory area.

4. You canexamine and modify the value of the peripherals register in the memory view.

% workspace - Example/src/main.c - Lattice Propel - [m] *
File Edit Source Refactor Mavigate Search Project Run  LatticeTools Window Help
A il & IRiIBiv|prENIRRBPIHE(|SOC RS H-0- A" B F-idpi~fl-0orD-
4 Debu 2 N 5 Proja} = 8 || [ mainc 2 = 8
=l | i 8 ii S mmm e e A
v [&] Example Debug [GDB OpenQCD 22 #include "utils.h" Peripheral Address Description
v (¥ Example.elf 43 M F, cpullinst OxFFFFOD00
~ o Thread #1 (Suspended : Sig = int main(veid) { 'R, gpiol_inst 0x0D002000
= main() at main.c:46 Oxd static uintd_t idx = @; = -
& openocd.are DEBUG_PRINTF{"Hello RISC-V world!\r\n"}; O, sysmem0_inst  0x00000000
A ) LED_SET(ALL_OFF); V1'%, uartd_inst 0x00008400
s riscu-none-embed-gdb
while (true)
LED_SET(LED_ON{idx));
< >
if (++idx == LED_COUNTY {
idx = @;
}
v
< >
2 cConsole ﬂ'\’é? Registers (@ Terminal ﬂ_f_ Problems (O Executables (E Debugger Corf ole i} Memary i ) = 8
@ G B8l S &% - &
Monitors o5 38 B (7 gpiolinst 0x3000 T . o5 Mew Randering;.]
@ cpul_inst Register Address Value G
@ gpiolinst v 2, gpiol_inst 0x00D0S000
@ uvartd_inst v 100 RD_DATA REG 0x00008000 0x00008000
o rd_data [7:0] 00
1010 WR_DATA_REG 0x00008004 0x00008004
> Wl SET_DATA_REG 0x00008008 0x00008008
4 1m0 CLEAR_DATA REG 0x0000800C 0x0000800C
i DIRECTION_REG 0x00008010 0x00008010
< > 110 IMT TVDE RFG vDNNNRNTA vDNNNRNTA v
iemorzam [

Figure 3.38 Peripherals View in Debug Perspective

3.5.4. Serial Terminal Tool

Serial portcommunicationis frequently used duringthe microcontroller debugging. Propel SDK provides a built-in
terminal tool includingserial support for debugging.

To launch a serial terminal:

1. Findthe Terminal view nested to the Console view. If not found, re-open from Window > Show View > Terminal.

2. Inthe Terminal view, clickthe Open a Terminal iconE . The Launch Terminal dialogopens (Figure3.39).

3. Choose the Serial Terminal and configurethe Serial port with Baud rate.
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Q Launch Terminal O 4
Choose terminal: |Selia| Terminal V|
Settings
Serial port: | COmM1 v|
Baud rate: | 115200 ~|
Datasize: 8 ~|
Parity: |None v|
Stop bits: |1 ~|
Encoding: |Defau|t (150-8859-1) v|
@ [ ok ]| cance |

Figure 3.39. Launch Terminal Dialog

4. Click OK. A connection opens.
5. (Optional)Clickthe Toggle Command Input iconthat adds anedit box to enter text (Figure 3.40).

E Plohlemswo Euecutahls} 2 it E =x EE| H_ @ @ = g

Figure 3.40. Terminal View
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4. Propel Tutorial — Hello World

This “Hello World” projectcan be found from the template. The “Hello World” project provides a template of using
hardwareand software design with the minimal resourcerequired.

Followingthis tutorial, you can easily createa hardwareand software project. After that, you canrun the project on
your evaluation board.

The tutorial uses a MachXO3D breakout board as demonstration. It uses RS232 UART function.To enable RS232 UART
function on the MachX03D breakout board, the followingreworks on the boards arerequired.

1. Hardware reworks on MachXO3D breakout board.

Short R14 and R15 using0 Q resistors,as shownin Figure4.1.

D)
@ 176
:— -

® @ remR2s

—

MachX03D Breakout Baard

REV A P/N:LCMX03D-9400HC-B-EVN o000
SNLATTICE qeee

| SN SEMICONDUCTORy
000

ez () g Y
oo o RZ4RGS = £ :
. | g. o000
LATTICE ~o000
LCMXO3D-9400HC >0 ®®
5BG256CAS - - *e O ¢
29107H12 Y Y X X )

L NN

'YX X

vidi@
£ld1 @
s1d1®
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——
(=
e

[ B

aNe

9141 @

@0 @ 0wy /==
SR39
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104 F3 D3 G3 C2|D1 EI F1 GI GND[HI H3 J2 J1 GND[L1 M1 NI H6 103jm 40
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Figure 4.1. MachXO3D Breakout Board
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2. Configure the FTDI device with FT_Prog software to enable UART function.
Connect the MachX03D breakout boardto host PC and power ON.
Open FT_Prog software. Select DEVICES > Program.
Make surePort B is configured as RS232 UART in Hardwareand Virtual COM Portin Driver. See Figure 4.2.

Select DEVICES > Program from the FT_Prog software again. From the opened Program Devices dialog, click
Program.

Device Tree Property Value

=%z Device: 0 [Loc ID:0x0] RS232 UART P
Baﬁciipnzzws 245 FIFO
F1=» USB Device Descriptor CPUFIFO v
'=> USB Config Descriptor OPTO Isolate o
=5 USB String Descriptors
=/=p Hardware Specific

-=p Suspend DBUST
-=p TPRDRY

= Port A

El=» Port B

-+ [

[=p Driver

E

H=p 10 Pins

Device Tree

Property

Value

=& Device: 0 [Loc ID:0x0]

D2XX Direct

B:Ib FT E.EPROM Vitual COM Port @
#=> Chip Details )
i=p USB Device Descriptor
i#=p USB Config Descriptor
i=p USB String Descriptors
=/=p Hardware Specific

-=p Suspend DBUST

-=p TPRDRY

=y Port A

E= Port B

'=> Hardware

EhgDriver]

+H=p 10 Pins

Figure 4.2 Configure the FTDI Device

3. All the reworks for the MachX03D breakout boardis completed.

© 2021 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
All other brand or product names are trademarks or registered trademarks of their respective holders. The specifications and information herein are subject to change without notice.

40 FPGA-UG-02127-1.0


http://www.latticesemi.com/legal

s LATTICE

Lattice Propel 2.0 SDK
User Guide

4.1. Creating SoC Design Project and Preparing Hardware Design

To startan SoC Design Projectfrom Propel:

Choose File > New > n Lattice SoC Design Project.

2. The Create SoC Project wizard opens (Figure 4.3). Enter a project name, such as HelloWorldSoC. Select the Hello

World Project template.
3. ClickFinish. An SoC project is created.

i S0C Project O
Create SoC project —
Create SoC project of selected template
I Project name: | HelleWorldSoC
Use default location
Location: | Chlscc\propeh2.0\workspace\HelloWorldSoC Browse...
Choose file systerm: [default
Template selection
Processor: | RISC-V MC ~ | Farnily: Machx 03D ~
Device: LEMXO3D-S400HC ~ | Performance: |5 ~
Package: |CABGAZ56 ~ | Board: MachX¥03D Breakout ~
Template Design
ot Project Helle World Project. Components included:
|Hello World Project a) Processor - RISC-V MC w/ PIC/TIMER
b) GPIO
c) ASRAM - Asynchronous SRAM
d) UART - Serial port
®

Figure 4.3. Create SoC Project Wizard

4. The created SoC project can be found in the workbench. Its designis opened and displayedin Propel Builder for

review (Figure4.4).
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4, Propel Builder [Chlscc\propel\2.0hwo
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3 gC' Ports
3 ,rE Mets
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@ cpu:1.0.0
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Figure 4.4. Propel Builder Window

4.2. Launching Lattice Diamond

Launch Lattice Diamond from the created SoC project. To do that:

1.

2.

Click the Diamondicon
Diamond.

In Propel Project Explorer view, select the SoC project HelloWorldSoC.

on the toolbar. A Diamond projectis created and thus opened automaticallyin Lattice

completed process.

Switch to Process view of the Diamond project and make sure Bitstream File or JEDEC File is checked in the Export

Choose Process > = Run. Waitfor generating programming filesuccessfully. You cansee a green checkmark
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* Lattice Diamond - Start Page O *
File Edit View Project Design Process Tools Window Help
B-E-HiE vayd b eERA’ A/ BEE @
o = B M @m s 3 m— oy nn
YPECHESEGCCEEGA=LUY SV Y FEEEE®
Process & X Q-E‘ Start Page [[J Reports [ o) x
£ v 2 Synthesize Design
o = Synplify Pro -
N - T'- Ttpéy B Project: Release Notes FPGA Design Guide -
ranslate Design
v :: Map Desi 9 [ open... Lattice Diamond Software 3.12 Release Notes Design Planning
+ Map Design N N X
[ & Map Trace EEvew... user Guides HDL Ceding Guidelines
= Verilog Simulation File {3 Import ispLEVER Project... Lattice Diamond 3.12 Release Notes Timing Closure
- g
O : WYHDL Simulation File Recent Proj . Lattice Diamond 3.12 User Guide Other Tool Guides
v & Place 8 Route Design 7 ExampleSaC Lattice Synthesis Engine for Diamond User ModelSim Users Manual
-
O - Place & Route Trace @] soc2 Guide ModelSim GUI Reference Manual
E : 1/0 Timing Analysis EEISDE Iéautréc: Diamond 3.12 Platform Designer User ModelSim Command Reference Manual
¥ Thermal Analysis =
v 2 Export Files 8 hello Clarity Designer User Guide ModelSim Tutorial
O : IBIS Model Latt‘ijc:e Diamond 3.12 Programming Tools User Synplify Pro User Guide
[1 & Verilog Simulation File Gui Synplify Pro Reference Manual
] 2 VHDL Simulation File Software Update Center Reveal User Guide Synplif‘y Pro Language Support Reference
2 Bitstream File Currently running Lattice Diamond software version: Reveal Troubleshooting Guide Manua
= JEDEC File 3.12.0.240.2 Lattice Diamond 3.12 Installation Guide for Tel/The
No updates available Windows Lattice on the Web
Last check time: Thu Mar 18 13:46:39 2021 Il:_attlce Diamond 3.12 Installation Guide for Lattice Semicenductor
inux
Answer Datahase hd
File List Process Hierarchy
Output a8 x
synpwrap -msg -prj "ExampleSoC_impll synplify.tcl™ -log "ExampleSol_impll.srf"
Copyright (C) 1992-2020 Lattice Semiconductor Corporation. All rights reserved.
Lattice Diamond Version 3.12.0.240.2
INFO - Synplify synthesis engine is launched. v
Td Comsole  Output | Error  Wamning  Info®
Start: Synplify Pro Mem Usage: 313,948 K

Figure 4.5. Generate Programming File

4.3. Programming the Target Device

Once the programming fileis exported successfullyinlastsection,itis readyto program the target device. Make sure

the evaluation boardis powered ON and connect correctly to host PC before performing the following procedure.

1.
2.

3.

Clickthe Programmericon %' on the toolbar of the Lattice Diamond Project Explorer.

The Programmer: Getting Started dialog pops up (Figure4.6). Click OK.

Review the Device Family, Device, Operation, and File Name inthe Programmer window (as shown below).

i} Programmer: Getting Started

Select an Action

@ Create a new project from a JTAG scan

Cable: |HW-USBN-2B (FTDI)

¥ | Port: |FTUSB-O -

TCK Divider Setting (0-30x):

() Create a new blank project

O Open an existing programmer project

Import file to current implementation

Detect Cable

C: flscefpropelf2.0/workspace ExampleSaC fimpl 1 fimpl 1. xcf

Cancel

Figure 4.6. Programmer Getting Started Dialog
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BBP @S
Enable Status Device Family Device Operation File Mame
1 & MachX03D LCMXO3ID-5400HC ESRM-'I Fast Configuration & HelloWordSaC/impll/HelleWerldSaC _impll
FE

4. Clickthe Program icon ““*" to download the programming data fileto the device.

4.4. Creating Hello World C Project

Creating C projectrequires a system environment from SoC project as input.
1. InPropel Project Explorer view, select the SoC project HelloWorldSoC.
2. Choose Project > Build Project.

System environment of the selectSoC projectis generated under the SoC project folder. Check the resultfrom the

Consoleview (Figure 4.7).

|:_ Problems Fé', Tasks (E Console &3 = Properties} = Terminaq

= 8

<terminated> sge [SDP Builder] C\lscc\propel\2.0htoels\python38_embed\python.exe

XK EEREE D8

Warning - Unconnection: cpu@ inst TIMER_IRQ M@ remains unconnected
INFO - Finished: sge generated

Figure 4.7 Build Result of HelloWorld SoC Project

"
3. ChooseFile > New > % Lattice C/C++ Project.
The C/C++ Projectwizard opens with Load system and bsp page (Figure 4.8.).

S C/C++ Project

Load system and bsp

Correct system envirenment file and get toclchain parameter

Select system environment file and bsp package

System enwv: | Chlscc\propel 2. 0workspace\ExampleSoChsgelsys_envaem I| w |

Browse...

Select processor core to create C/C++ Project

Core selected: | cpul_inst
Project type:  |C
Systemn information

Device Family CPU Marne Instance Marme

MachXO3D riscy_mc cpul_inst

@ < Back Finish

Cancel

Figure 4.8. Load System and BSP Page
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4. Select the systemenvironment filejustgenerated (Figure4.8.). Click Next.
5. Enter projectname “HelloWorld” (Figure4.9). Click Next. Then click Finish.
The C projectis created and displayed in workbench.
{03 C/C++ Project O *
C/C++ Project —_—
Create C/C++ project of selected type |
Project name: | HelloWorld |
Use default location
Location: | Chlscc\propel2.00workspace\HelloWorld Browse...
Choose file systern: [default
Project type: Teolchains:
» = GMNU Autctocls ~ RISC-V Cross GCC
v [= Executable
& Empty Project
@ Lattice C/C++ Project
& Helle World RISC-V C Project
& Helln Warld AMNSIC Proiect ~
Show project types and toolchains only if they are supported on the platform
@ < Back Finish Cancel
Figure 4.9. Create C Project Page
6. Inthe ProjectExplorerview, select the C project “HelloWorld”.
7. Choose Project > Build Project.
8. Check the build resultfromthe Consoleview (Figure 4.10).
[*] Problems (E‘ Tasks (E Console 3 = Properties]@Terminaq JL4p <|‘='=:>| '—,E Q.'—E — .;Ekl mE-Sy= O
COT Build Console [HelloWarld]
e e LT L
text data bss dec hex filename ~
1262 a 2728 3998 96 Hellokorld.elf

Finished building: HelloWorld.siz

Inveking: Lattice Create Memory Deployment

riscv-none-embed-objcopy -0 binary --gap-fill @ "HelloWorld.elf™ "HelloWorld.bin™; srec_cat "HelloWorld.bin™
-Binary -byte-swap 4 -DISable Header -Output "HelloWorld.mem™ -MEM 32

Finished building: Hellokorld.mem

16:56:57 Build Finished. @ errors, @ warnings. (tecck 4s.81ems)

Figure 4.10. Build Result of HelloWorld C Project
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4.5. Running Demo on MachX0O3D Breakout Board — Hello world

1. Findthe Terminal view nest to the Console view. If not found, re-open from Window > Show View > Terminal.
2. Inthe Terminal view, clickthe Open a Terminal iconE .
3. Choose the Serial Terminal and configurethe Serial port with Baud rate 115200 (Figure 4.11).
Note: Serial portnumber depends on specific PC.
7% Launch Terminal O X
Choose terminal: | Serial Terminal w
Settings
Serial port: | COM1 o
Baud rate: | 115200 e
Data size: | & e
Parity: MNone ~
Stop bits: |1 ~
Encoding: | Default (150-8359-1) e
Figure 4.11. Launch Terminal Dialog
4. Click OK. Aserial connection communicatewith UART is ready.
5. Inthe Project Explorer view, select C project “HelloWorld”.
6. Choose Run > Debug Configurations...
7. Double-click GDB OpenOCD Debugging to create a new launch configuration (Figure4.12).
8. Clickthe Debug button.
Waitfor a few seconds for switchingto debug perspective, to start the server, andto allowitto connect to the
target device, startthe gdb client,download the application, and then start the debugging session.
Note: This demo uses default debug configuration options.
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% Debug Configurations O *

Create, manage, and run configurations

O @B xl V- MName: | HelloWerld Debug |
| type filter text | Main CableConrﬂ *5 Debugger\l B Startup\l B Sourcew = Commorﬂ 5 svD Path\l
] C/C++ Application o P
[c] C/C++ Attach to Application
[£] C/C++ Postrnortern Debugger | HelloWorld | | s |
[©] C/C++ Remote Application C/C++ Application:

Cif C/C++ Unit
[t ] GDB Hardware Debugging
w [t | GDB Open0CD Debugging | Variables... | |Search Ploject...| | Browse... |
[€] HelloWorld Debug
[t ] GDB QEMU Debugging
L Launch Group Build Cenfiguration: | Select Automatically V|
= Launch Group (Deprecated)

| Debug\HelloWorld.elf |

Build (if required) before launching

(C) Enable auto build (") Disable auto build
(®) Use workspace settings Configure Workspace Settings...
Revert Appl
Filter matched 11 of 11 items o .

@ Debug | | Close

Figure 4.12. Debug Configurations Page

9. Clickthe Resume icon "% on the toolbar.The serial terminal outputs “Hello RISC-V world!” (Figure 4.13).

7% warkspace - HelloWarld/src/main.c - Lattice Propel - O X
File Edit Source Refactor MNavigate Search Project Run  LatticeToocls Window Help
DR i ®y e @RSl S0Relitg-0-W-ido 94y
i{}'{‘r'*\b@":‘/'“‘j O\H':{”Sﬁ
5 De 22 Ea) Prw = 8 |@ main.c (@ crt.S (@ main.c &3 ] ox0 1 = 0 |[[x=v (.. Br (H E [E=% B &3 = PT = O
R 4L "
yg| i B8 #include "utils.h" ~ |Enter|ocatlon here v|| & B Sl
v [£] HelloWorld Debug [GDB O . . . ot
v HelloWorld.elf ‘int main(veid) { y -
Thread 21 [Running: static uintd_t idx = @;
#® Threa (Running DEBUG_PRINTF("Helle RISC-V world!\rin"); 8
5 openocd.exe LED_SET(ALL_OFF); Baa004T0: sw s3,12(sp) -
5 riscv-none-embed-gdb aeapa4fa: sw s4,8(sp)
while (true) { aeeea4fs: sw ra,28(sp)
LED_SET(LED_ON(idx)); Beaeasfc: jal ra,@x554 <uartPL
- - a7 LED_SET(ALL_OFF);
if (++idx == LED_COUNT) { 28008500 : lL:I:i. a5,8x3
idx = @ 00ERASE4:  1i a4,255
1 BRBOASHE : sw ad,4(as) # exsee )
hd AT B . 14 . 1TaAL
£ > < >
& Console | 4 Registers | & Terminal 2 IE: Problems o Executables Debugger Console n Memeo = O
9 99 Ly

B com4 52
Hello RISC-V world!

Figure 4.13. Run Result of Hello World Project
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Appendix A. Linker Script and System Memory Deployment
Duringthe Lattice C/C++ Project creation, Propel SDK generates a linker scriptfile, linker.ld, within the project. This

linker scriptfilecontainsa memory region listparsing fromthe corresponding SoC design.

Note: Illegal memory regions are not imported to linker script. Amemory region is consideredillegal,ifithas any of the
following conditions:

e No connectionto CPU

e Address spaceconflict

Each memory region has a listof attributes to specify whether or not use a particularmemory region for aninput
section (Figure A. 1).

e r:Read-only section.

e w: Read/Write section indicating the memory region is connected to the data port of CPU.

e x:Executable sectionindicating the memory region is connected to the instruction portof CPU.

Linker Script: linker.ld

Available Memory Regions

MName Attributes || Base Address Size
sysmemi_inst % 0:400000000 (0400008000
sysmermnl_inst w 0:400010000 0:400008000

Figure A. 1.Memory Regions in Linker Script

The generated linker scriptcontains a mappingtableof section pointingto memory region (Figure A. 2). Depending on
the attributes of each memory region, code section and data section can point to the same or different memory

regions.

Section to Memory Region Mapping

CODE: |sysmem0_inst -
DATA: |sysmeml_inst -

Section Mame Memory Region i
text sysmermn(_inst 2
.ctors sysmem(_inst

Jdtors sysmermn(_inst 1

Overview | linker.ld

Figure A. 2. Section to Memory Region Mapping

Duringthe Lattice C/C++ Project building, Propel SDK generates Lattice system memory initialization files. Depending
on the number of the memory regions used, it generates single memory initialization file or multiple memory
initialization files. The following picture (Figure A. 3) shows an example of multiple memory files being generated,
separatefor code and data segments.
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> 3
A= ;r:bug Section to Memory Region Mapping

- 2= src
. 5 Example.elf - [nonefle]

Example_Code.rnem CODE:
Exarnple_Data.mern DATA:

wllF ['|||' ['|||'

= Example.bin
=] Bamplelst Section Mame Memory Region
=] Example.ma E
=l p_ P text sysmem(_inst |l|
| @ makefile i

. .ctors sysmermn(_inst
| @ objects.mk i

Jdtors sysmem(_inst

| @ sources.mk o o -

=| tmp

Overview | linker.ld

Figure A. 3. Linker Script and Generated Memory Files

If you modify the linker script manually after the Lattice C/C++ project creation, especially changethe number of the

used memory regions,the number of memory files generated during projectbuildingcannotbe changed automatically.
You canre-configurethe generation of memory files in Propel by:

1. Inthe Project Explorer view of Propel, selecta C/C++ project.
2. Choose Project > Properties. The Properties dialogopens showingthe properties of the currentproject.
3. Select Settings of C/C++ Build category from the left pane. Select the Toolchains tab (FigureA. 4).

Check Create memoryfile, if you point code and data segments to same memory region. Or, check Create multiple
memory files, if you pointcode and data segments to separate memory regions.

4. Click Apply.
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% Properties for HelloWorld O x

| type filter text Settings Sy v 8
» Resource
Builders

s CfC++ Build Configuration: | Debug [ Active ] ~ | | Manage Configurations...

Build Variables
Envircnment

Logging B3 Tool Settings i Toolchains ‘M Devices # Build Steps Build Artifact Binary Parsers | * | *
Settings
Tool Chain Editor Mame: | GMNU MCU RISC-V GCC (riscv-nene-embed-gcc) e
» CfC++ General )
. MCU Architecture: | RISC-V V|
Project Matures Prefix: | riscv-none-embed- |
Project F‘.eferenc.es Suffix: | |
Run/Debug Settings
SystemVerilog Project Properties C compiler: | gcc |
Task Repository C++ compiler: | g++ |
Task Tags
> Validation Archiver: ar
Hex/Bin converter: | objcopy |
Listing generator: | objdump |
Size command: | size |
Build command: | make |

Remove command: | rm

Toolchain path: | §{eclipse_home}/../riscv-none-embed-gec/bin

(to change it use the global or workspace preferences pages or the project properties page
Build tools path: | §{eclipse_homel/../build_tools/bin

(to change it use the global or werkspace preferences pages or the project properties page

[] Create memory file

Create multiple memory files
Create extended listing
Print size

Restore Defaults Apply

@ Apply and Close Cancel

Figure A. 4. Toolchains Tab of C/C++ Build Settings

5. Go back to the Tool Settings tab. The relevant Lattice memory deployment tools can be found (Figure A. 5).
Customize the tool options as needed.

6. Click Apply and Close to savethe change.
Note: Setting for each configuration, Debug or Release, is independent.
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B9 Tool Settings i) Toolchains M Devices . Build Steps Build Artifact Binary Parsers II‘Z‘

(2 Target Processor LIFill gaps in the data
(22 Optimization Diata Walue 0

@ Warnings
@ Debugging

w 83 GNU RISC-V Cross Assembler
@ Preprocessor
@ Includes
@ Warnings
@ Miscellaneocus

w B85 GNU RISC-V Cross C Compiler
@ Preprocessor
@ Includes
@ Optimization
@ Warnings
@ Miscellaneocus

w 83 GNU RISC-V Cross C Linker
@ General
@ Libraries
@ Miscellaneocus

w 83 GNU RISC-V Cross Create Listing
@ General

w 83 GNU RISC-V Cross Print Size
@ General

Address Range | (x8000

w 83 Lattice Create Memory Deployment
@ General

w 83 Lattice Multi Memory Deployment (CODE SEGMENT)
(2 General

~ B3 Lattice Multi Memary Deployment (DATA SEGMENT)
(& General

| Restore DefauHs| | Apply |

Figure A. 5. Tool Settings Tab of C/C++ Build Settings
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Technical Support Assistance

Submit a technical support casethrough www.latticesemi.com/techsupport.
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Revision History

Revision 1.0, April 2021
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