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1. Introduction

In electronics, slew rate is defined as the change of voltage or current, or any other electrical quantity, per unit of time.

Electronic circuits may specify minimum or maximum limits on the slew rates for their inputs or outputs, with these
limits only valid under some set of given conditions, for example, output loading.

The Lattice Semiconductor MachXO3D™ devices feature single-ended output buffer for each device 1/0 pin with
programmable output slew rate control that can be configured for either low noise, SLEWRATE=SLOW, or high speed,
SLEWRATE=FAST, performance. Each I/O pin has an individual slew rate control. This slew rate control affects both
rising edge and falling edge. The rise and fall ramp rates for each /O standard can be found in the device IBIS file for a
given 1/O configuration. This demo shows how to enable slew rate control features through Lattice Diamond® software.

1.1. Demo Overview

This demo project outputs clocks in the same frequency but with different slew rate settings to two test points for
comparison.

This demo covers the following operations:
e Configuring different slew rates in the design
e  Programming the board with the design

e Validating the slew rate with hardware test

1.2. MachXO3D Development Board and Resources

Figure 1.1 shows the top side of the MachXO3D Development Board and resources used for this demo.
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Figure 1.1. MachXO3D Development Board

e TP105: Test point for Ball Site M22 to output clock
e TP106: Test point for Ball Site B21 to output clock
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1.3. Slew Rate Control Demo Circuits on the Board

MachX03D Development Board reserves circuits to simulate the customer application board with different board sizes
or routing trace lengths, with 4-, 8-, or 16-inch configuration, as shown in Figure 1.2. For example, to simulate 16-inch
length, you need to populate R280 or R281, and depopulate R279 or R290, then test waveform on TP109. In this demo,
the default 4-inch setting is used to show the slew rate control feature. TP105 and TP106 are used.

4 inch trace Bank1_TO R279 0 N TP105
R280‘/\N\DNI W O

| 4 inch trace 3290 DNI TPi07 I C116
R281MDNI W 1 O T _topF
| 8 inch trace OTF’109 118 =

10pF
120
| 10pF TP111 TP112 TP113
Banko_T1 - i | |
(4] Bank0_T1 > = = = =
4 inch trace Bank0_T1 BZSZMD - O TP106
RQBSNV\DNI
| 4 inch trace B291NV\DN| OTF’108 17
| 8 inch trace OTF’HO 119 =
121
1ODF TP114 TP115

iii

Figure 1.2. Slew Rate Control Demo Circuits
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2. Demo Package

2.1. Hardware Requirements

To run the demo, the following hardware are required:

e  PCrunning Windows 7 Operating System

e MachX03D Development Kit including Mini-USB cable

e  Oscilloscope, >200 MHz bandwidth preferred, with at least two probe channels

2.2. Software Requirements

To run the demo, the following software are required:
e MachX03D Slew Rate Control Demo package

e Lattice Diamond 3.11 or later

Note: The software programs are available at www.latticesemi.com/en/Products/DesignSoftwareAndIP.
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3. Demo Package Directory Structure

Figure 3.1 shows the demo package directory structure.

= MachXO2D_Slew_Rate_Control_Demo

= docs
FPGA-UG-02067-1-0-MachX03D-5lew-Rate-Control-Demo.pdf

=+ project
slew_rateldf
Slew_rate.lpf
slew_ratexcl

! spurce

slew_rate_top.wv

Figure 3.1. Demo Package Directory Structure
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4. Running the Slew Rate Control Demo

4.1. Opening the Slew Rate Control Demo Design
To open the slew rate control demo design:
1. Open Lattice Diamond software.

2. Select File > Open > Project.... Browse to find and open slew_rate.ldf from the downloaded demo package folder.
The Slew Rate Control Demo design is opened as shown in Figure 4.1.

file Edit View Project Design Process Jools Window Help
AvB-HgBradmh ERQAQAQBEE EREEBE G
ECRESESCEEG A BoBHY BER &)
Fie List & x | [ Reports @ | alx
4 ([} Slew_rate Sew_rate &
I LCMXO03D-9400HC-5BG484C
<} Stategies Design Summary
[ Area 4 B9 Project
[ 10 Assistant B Project Summary Module Name: Slew_rate Synthesis: Lattice LSE
B Quick 4 =0 Process Reports
Timing ) Lattice LSE Implementation Name: Slew_rate Strategy Name: Strategyl
-] Strategyl B Map Last Process: JEDEC File State: Passed
+ [H Slew_rate ) Place & Route Target Device: LCMXO3D-3400HC-58G484C Device Family: MachX03D (3
4 ) Input Files P Signal/Pad 2
¥ /source/slew_rate_top.v “B) Bitstream/JEDEC Device Type: LCMXO3D-9400HC Package Type: CABGAdE4
Synthesis Constraint Files 4 T Analysis Reports Performance grade: 5 Operating conditions: com
4 i LPF Constraint Files B) LSE Timing Report Logic preference file: Slew_rate.lps
[ Slew_ratepf [ Map Trace
Debug Files [3) Place & Route Trace Physical Preference file: Slew_rate/Slew_rate Slew_rate.prf
Script Files [ Thermal Analysis Broduct Version: 3.11.0.208.0 Patch Version:
Analysis Files _ B VO Timing Analysis Updated: 2018/09/27 14:38:51
4 |, Programming Files 4 T Tool Reports - -
B Slew_ratexct [ 10 S5O Analysis Implementation Location: F:/Sentry/Slew_rate_demo/project/Slew_rate
@ Hierarchy Parsing Report Project File: F:/Sentry/Slew_rate_demo/project/Slew_rate.ldsf
== [ P10 DRC
FleLst | Process | Hierarchy | & 8B ICL Cammandlan as

Figure 4.1. Open the Slew Rate Control Demo Project

3. Double-click slew_rate_top.v under File List. slew_rate_top.v is opened as shown in Figure 4.2. Check the default
output clock frequency setting for OSCJ_inst. NOM_FREQ is 33.25 MHz for the MachXO3D internal Oscillator OSCJ.

Fle Edit View Project Design Process Jools Window Help

A-Br-Hag B g m A A/ EH 3 @ [
YECREsE S CEEG AU BEEERE @
erst 8 x Reports 2 slew_rate_top.v [ ==
* [ Stew.rate — assign (non-process) operations —/ x
I LCMX03D-9400HC-5BG4BAC /
4 ) Strategies
[ Area assign rst = ~rstn:
[ V0 Assistant assign :uz_ciii = osc_clk;:
¥ Quick sosign out_olX
[ Timing A
[ strategy1
4 [H Slew_rate
4 . InputFiles

¥ ssource/slew_rate_top.v
Synthesis Constraint Files
4 ). LPF Constraint Files

[y Slew_rate.lpf
Debug Files
Script Files
Analysis Files .STDBY (rst) , O=Enabled, l=Disabled
4 |, Programming Files .0SC(osc_clk),
[1) Slew_rate.xcf .SEDSTDBY () E
):
endmodule >
FleList | Process | Herarchy | <l 5 >

Figure 4.2. Open the Slew Rate Control Demo Project

4. From the Process tab, as shown in Figure 4.3, double-click Export Files, or right-click Export Files and choose Rerun
All (&) to re-run all the previous processes to generate the JEDEC file.
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2 Lattice Synthesis Engine
Map Design
2 Map Trace
2 Verilog Simulation File
2 VHDL Simulation File
Place & Route Design
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7] & Thermal Analysis
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IBIS Model
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Slew_rate project summary

Module Name: Slew_rate Synthesis: Lattice LSE
Implementation Name: Slew_rate Strategy Name: Strategyl
Last Process: State:

Target Device: LCMXO3D-9400HC-5BG484C Device Family: MachX03D

Device Type:

LCMXO3D-9400HC

Package Type:

CABGA4E4

Performance grade:

5

Operating conditions:

coM

Logic preference file:

Slew_rate.lpf

Physical Preference file:

Slew_rate/Slew_rate_Slew rate.prf

Product Version:

3.11.0.208.0

Patch Version:

Updated:

2018/09/27 09:23:43

Implementation Location:

F:/Sentry/Slew_rate_demo/project/Slew_rate

Project File:

F:/Sentry/Slew_rate_demo/project/Slew_rate.ldf

User Guide
File Edit View Project Design Process Jools Window Help
A-B-HIP B e ¥Mm CERKRQQL] EA 2 8
PEORECHSQEEG AR Y FEEFEE O
Process Reports [ | = e
4 3 Synthesize Design Slew_rate —

T

Figure 4.3. Process of Slew Rate Control Demo Project

5. Select Tools > Spreadsheet View from the Diamond main interface. Open the Spreadsheet View to review the Port
Assignments for slew rate control demo project, as shown in Figure 4.4. By default, the SLEWRATE setting for the
output pin is SLOW.

Reports || | 1/ Spreadsheet View [£J ‘ (&l
] Name Group By Pin BANK BANK_VCC I0_TYPE PULLMODE DRIVE SLEWRATE CLAMP OPENDRAIN DIFFRESISTOR

1 4 2 AlPorts NIA NA [N/A NIA NIA N/A
11 4 @ Input NIA NA | N/A N/A NIA /A NIA /A NIA NIA NIA

me 222 » rstn N/A D3 5 Auto LVCMOS33  UP NA NA ON OFF OFF

(1.2 4 Output N/A N/A N/A i N/A N/A NIA N/A N/A N/A N/A

7, (121 out_clk0 N/A B21 0 LVCMOS33 DOWN 8 SLow OFF OFF OFF

= [122 out_clk1 /A M2 1 Aut LVCMOS33  DOWN 8 sLow OFF OFF OFF

k

'Y

3

9

n

(e m ] )

| port [P | ClockResource | Route Priority | CellMapping | Global Preferences | Timing Preferences | Group | MiscPreferences |

Figure 4.4. Spreadsheet View of Slew Rate Control Demo Project

4.2. Programming Default Image to MachXO3D Devices
To program the default image to MachXO3D devices:

1. Connect the PC to the MachXO3D Development Board using the Mini-USB cable. The board is powered ON.
In the Diamond main interface, from the File List tab (Figure 4.1), double-click Slew_rate.xcf. This XCF file for

2.

programming CFGO is opened in the embedded Programmer, as shown in Figure 4.5.

© 2018-2020 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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Cable and 1/0 Settings |

TCK Divider

1/O Settings

T 3

©) Use default Clock Divider

") Use custom Clock Divider

) Use default 1/0 settings

Use custom I/O settings

Reports i} Programmer - Slew_ratexcf * [[J ‘ &%
] i | 2
Enable Status Device Family Device Operation File Name File Date/Time Checks} 2
| | Cable Settings
1|Vl MachX03D LCMXO03D-9400HC  FLASH Erase,Program,Verify  ..e/Slew_rate_Slew_rate_a.jed ..7/18 09:57:53 0)@793“
| Detect Cable

Cable: HW-USBN-28 (FTDI) v
Port: FTUSB-0 =z |5
Custom port:
Programming Speed Settings

Figure 4.5. Embedded Programmer in the Demo Project

3. Select to highlight the only file information row (Figure 4.5). You can now see file information clearly. Double-click
Slew_rate_Slew_rate_a.jed from the File Name column (Figure 4.5). The Device Properties dialog box is opened
as shown in Figure 4.6.

i MachX03D - LCMXO3D-9400HC - Device Properties ?

General Device Information

Device Operation

Access mode: Flash Programming Mode
Port Interface: JTAG Interface
Operation: FLASH Erase,Program, Verify

CFGO Programming Options

Programming file: law_F'.abe_Control_DEmo,ﬂ:lrojectISIEw_ratefslew_rabe_slew_rate_a.jed

|:| CFG1 Programming Options

Programming file:

Cancel

Figure 4.6. Set Device Properties for Programing CFGO

4. Note that at this phase you may not be able to operate the *.jed file because of the different demo package
installation directory. To make the *.jed file work, in CFGO Programming Options (Figure 4.6), click the ... button to
re-appoint to Slew_rate_Slew_rate_a.jed.

5. Click OK (Figure 4.6), and return to embedded Programmer Slew_rate.xcf interface as shown in

Figure 4.5.

6. Click the Program button (**) from the toolbar (Figure 4.5) to download bitstream to CFGO with embedded

Programmer.

7. After the programming is successfully completed, you can use oscilloscope to probe TP105 and TP106. There are
duplicated clock waveforms, as shown in Figure 4.7.

© 2018-2020 Lattice Semiconductor Corp. All Lattice trademarks, registered trademarks, patents, and disclaimers are as listed at www.latticesemi.com/legal.
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Figure 4.7. Output Clocks with Slow Slew Rate (Frequency Setting is 33.25 MHz)

4.3. Changing the Slew Rate Settings for a Single Output

To change the slew rate for a single output:

1.

In the Spreadsheet View, change slew rate setting to FAST for out_clk1, as shown in Figure 4.8. out_clk1 from pin
M22 connects to TP105.

Spreadsheet View [£J

& x

3 4
11
w222

121
122

2 BEeT K

«

Port Assignments

Name
All Ports
Input
rstn
Output
out_clk0
out_clk1

Group By

Pin BANK
D3

B21
M22

n

10_TYPE

LVCMOS33

LVCMOS33
LVCMOS33

PULLMODE

upP

DOWN
DOWN

DRIVE

SLEWRATE

NA ON

sLow OFF
SLOW (Def) > | OFF
| SLOW (Def)

Pin Assignments | ClockResource | Route Priority | CellMapping | Global Preferences | Timing Preferences | Group | MiscPreferences

CLAMP

DIFFRESISTOR

OPENDRAIN

OFF OFF
OFF OFF
OFF OFF

Figure 4.8. Change Slew Rate Setting in the Spreadsheet View

Save all the design changes by choosing File > Save All, or click the Save All button (&') in the Diamond main

interface.

In the Process view of the Diamond main interface, as shown in Figure 4.9, double-click Export Files, or right-click
Export Files and choose Rerun All (&) to re-run all the previous processes to generate JEDEC files for the new

design.
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4 % Synthesize Design
“L Lattice Synthesis Engine
Map Design

o Map Trace

t

+ Verilog Simulation File

¥ VHDL Simulation File
Place & Route Design

= Place & Route Trace

= 1/0 Timing Analysis

18

= Thermal Analysis
a g Export Files
< IBIS Model
« Verilog Simulation File
= VHDL Simulation File
= Bitstream File
< JEDEC File

FileL... Process Hierarchy-—Post Synthesis Resourc...

Figure 4.9. Process View of the Diamond Main Interface

4. Inthe embedded Programmer interface of Slew_rate.xcf (Figure 4.5), click the Program button (** ) to download
new generated bitstream file to CFGO.

5. After the programming is successfully completed, you can use oscilloscope to probe TP105 and TP106 again.
Different clock waveforms are shown as Figure 4.10. With the same frequency, TP105 outputs clock signal with
faster ramp speed on both rising edge and falling edge.

(30 Sep
09:21:35

Figure 4.10. Output clocks with Different Slew Rate (Frequency Setting is 33.25 MHz)
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4.4. Changing Clock Speed to Show the Difference of Slew Rate Impact
To change Clock Speed and show the difference of Slew Rate impact:

1. Inthe Diamond main interface, edit slew_rate_top.v by changing the output frequency to 133 MHz. To do this, set
defparam OSCJ_inst. NOM_FREQ = "133.0" (Figure 4.2).

2. Save all the design changes by choosing File > Save All or click the Save All button (&) in the Diamond main
interface.

3. In Process view of the Diamond main interface, as shown in Figure 4.9, double-click Export Files, or right-click
Export Files and choose Rerun All (&) to re-run all the previous processes to generate JEDEC files for the new
design.

4. Inthe embedded Programmer interface of Slew_rate.xcf (Figure 4.5), click the Program button (**) to download
new generated bitstream file to CFGO.

5. After the programming is successfully completed, you can use oscilloscope to probe TP105 and TP106 again.
Different clock waveforms are shown as Figure 4.11. With high output clock frequency, TP105 shows good clock
waveform with FAST Slew Rate. TP106, however, is not good with SLOW Slew Rate setting.

2iTP106

NN

Figure 4.11. Output Clocks with Different Slew Rate (Frequency Setting is 133.0 MHz)
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Technical Support

For assistance, submit a technical support case at www.latticesemi.com/techsupport.
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