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Type Conventions Used in This Document

Convention Meaning or Use

Bold

<Italic>
Ctrl+L

Courier

Items in the user interface that you select or click. Text that you type
into the user interface.

Variables in commands, code syntax, and path names.

Press the two keys at the same time.

Code examples. Messages, reports, and prompts from the software.
Omitted material in a line of code.

Omitted lines in code and report examples.

Optional items in syntax descriptions. In bus specifications, the
brackets are required.

Grouped items in syntax descriptions.
Repeatable items in syntax descriptions.

A choice between items in syntax descriptions.
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Chapter

Help for Lattice Diamond

Lattice Diamond™ is the complete design environment for Lattice

1

Semiconductor FPGAs. The software includes a comprehensive set of tools
for all design tasks, including project management, design entry, simulation,

synthesis, place and route, in-system logic analysis and more.

To start learning about Diamond, see the Lattice Diamond User Guide To
quickly get some hands-on experience, try the Lattice Diamond Tutorial .

To help you experiment further, example projects are available. These
examples are designed to illustrate different aspects of designing with
Diamond. To see the examples, choose File > Open > Design Example.
Then open an example folder and open the example’s .Idf file. (An .Idf file
defines a design project for Diamond.)

The rest of the Help system provides complete instructions for the different
stages of the Diamond design flow and extensive reference material.
See Also

“Getting Help” on page 13

Lattice Diamond User Guide

Lattice Diamond Tutorial

Lattice Synthesis Engine Tutorial

Active-HDL On-line Documentation (Windows only)

Synplify and Synplify Pro for Lattice User Guide

Synplify and Synplify Pro for Lattice Reference Manual

Incremental Design Flow User Guide

Reveal User Guide

Reveal Troubleshooting Guide
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HELP FOR LATTICE DIAMOND : Getting Help

Getting Help

Tcl/Tk Documentation

FPGA Design Guide
Design Planning
HDL Coding Guidelines

Timing Closure

Lattice on the Web
Lattice Semiconductor
Answer Database
Lattice Solutions

Intellectual Property

For almost all questions, the place to start is this Help. It describes the FPGA
design flow using Diamond, the libraries of logic design elements, and the
details of the Diamond design tools. The Help also provides easy access to
many other information sources.

To make the most effective use of the Help, please review this section.

Opening the Help
The Help can be opened in several ways:

In Windows, choose Start > Programs > Lattice Diamond >
Accessories > Diamond Help.

In the main window, choose Help > Lattice Diamond Help.

To go directly to the Help for the tool that you're using do one of the
following:

If the tool is attached to the main window, choose Help > <Tool
Name> Help.

If the tool is detached, choose Help > £} Help.

To go directly to the Help for the view of the tool that you're using, press
F1.

For a description of how to use a dialog box, click Help (if available).

For a description of a feature in a dialog box, right-click on the feature. If a
box appears saying “What's This?,” click it. Or click on the feature and
then press Shift-F1. In Windows, you can also click the question mark &
button in the title bar and then hover over the feature. If the cursor turns
into an arrow with a question mark %’? click on the feature.

Lattice Diamond 3.6 Help
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HELP FOR LATTICE DIAMOND : Getting Help

Note: Not all dialog box features have pop-up descriptions.

To learn more about a property in the Strategies dialog box, select the
property and press F1.

To get more information related to a message, right-click the message. If a
menu appears with a Help command available, choose it.

JavaScript must be enabled in your default browser. If you are have trouble
opening the Help, see “Troubleshooting the Help” on page 15.

Using the Help

The Help has several features to help you find information.

Hide ar show  Enter search Goto Search Print the topic without
the contents. terms. results page. contents or toolbar.
/f'

-
e

- T,
Goto previous topic. G0 to next topic.

Contents The contents organizes the information in the Help. Look here to
see what subjects are covered or to begin in-depth study of a subject.

Click the =] (Contents) button to hide or show the contents pane.

Search The search locates all topics that contain specific text. This can be
the fastest way to find information once you are familiar with the contents of
the Help.

Enter one or more words and click the (Search) button. The Search page
opens with a list of topics containing all of the words (an AND function).
Some tips:

Enter phrases between a pair of double-quote marks. For example: "block
module”.

Use an asterisk * as a wildcard to also find plurals and different verb
tenses, or to search on word parts. For example, search* finds search,
searches, searching, and searched. Searching on *annotate finds
annotate and backannotate.

Capitalization does not matter.

Leave out punctuation except for hyphens in hyphenated words.

Lattice Diamond 3.6 Help
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Search results are ordered by the number and types of hits found. The first
few topics are most likely to have substantial information on the search terms.
Topics at the end of the list may have just a casual mention of the terms.

Search Navigation Tip

Your browser’s forward and back buttons may not work the way you expect with the
Search page. To go to the Search page, always click the (Search) button. If you're
on the Search page and want to go back to the topic you were looking at, click the E
(Contents) button.

Glossary The “Glossary” on page 2458 has definitions of hundreds of
technical terms and abbreviations. The Glossary is in the contents under
“Reference Guides.”

Design Tool Reference “Design Tool Reference” on page 2523 is an index
of all the tools in the Diamond tool set. This can be an easy way to find
information about a tool. Design Tool Reference is in the contents under
“Reference Guides.”

Type Conventions Used in This
Document

Convention Meaning or Use

Bold Items in the user interface that you select or click. Text that you type
into the user interface.

<Italic> Variables in commands, code syntax, and path names.

Ctrl+L Press the two keys at the same time.

Courier Code examples. Messages, reports, and prompts from the software.
Omitted material in a line of code.

Omitted lines in code and report examples.

[ ] Optional items in syntax descriptions. In bus specifications, the
brackets are required.

() Grouped items in syntax descriptions.
{} Repeatable items in syntax descriptions.

| A choice between items in syntax descriptions.

Troubleshooting the Help

If you are have trouble opening the Help, check for the following situations:

Lattice Diamond 3.6 Help

15



HELP FOR LATTICE DIAMOND : Getting Help

Active Content or Scripts Are Blocked Opening the online Help may be
interrupted by one of the following messages on the Internet Explorer
Information Bar:

“To help protect your security, Internet Explorer has restricted this file from
showing active content that could access your computer. Click here for
options...”

“To help protect your security, Internet Explorer has restricted this file from
running scripts or ActiveX controls that could access your computer. Click
here for options...”

To see the Help, click on the Information Bar and choose Allow Blocked
Content. A dialog box with an expanded warning opens. Click Yes.

To avoid these warnings, either use a different browser or turn off the warning
for active content in Internet Explorer.

Note

Doing either of these means that when you open any Web page that is resident on
your computer—not just Diamond Help—the page will automatically run any active
content that it has. While active content is common and can be very useful, malicious
content can damage your files. Be sure you trust the software on your computer.

To turn off the warning:
1. InInternet Explorer, choose Tools > Internet Options.
2. Click the Advanced tab.

3. Under Security, select Allow active content to run in files on My
Computer.

4. Click OK.

Back and Forward Buttons Do Not Work with the Search Page Your
browser’s back and forward buttons may not work the way you expect with
the Search page. Instead of returning to the Search page, you go to the
previous or next topic. Instead of returning from the Search page to the
previous or next topic, you stay on the Search page. The Search page is not
in the stack of visited pages.

To go to the Search page, always click the (Search) button. If you're on the
Search page and want to go back to the topic you were looking at, click the
= (Contents) button.

Contacting Technical Support

FAQs The first place to look. The Answer Database provides solutions to
guestions that many of our customers have already asked. Lattice
Applications Engineers are continuously adding to the Database.

Telephone Support Hotline Receive direct technical support for all Lattice
products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

Lattice Diamond 3.6 Help
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HELP FOR LATTICE DIAMOND : Updating Diamond from the Web

For USA & Canada: 1-800-LATTICE (528-8423)
For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time
(CST), +0800 UTC. Chinese and English language only.

For Asia: +86 21 52989090
E-mail Support »techsupport@latticesemi.com

For Local Support Contact your nearest Lattice Sales Office.

Updating Diamond from the Web

You can update Diamond from the Lattice Web site with UPDATE. The
UPDATE program can be set to automatically check for service patches and
alert you when one is available. You can also use UPDATE to manually check
for service patches. When you find a patch you can download it and install it
at your convenience. Or, in Windows, you can have the patch automatically
installed after downloading it.

Start by setting the UPDATE options. See “Setting Options for Updates” on
page 17.
See Also

“Getting a Service Patch” on page 18

“Installing a Downloaded Service Patch” on page 20

Setting Options for Updates

To get service patches, you must specify the Internet settings and if you want
the software to check for service patches. These options can be set in the
Diamond main window or in the UPDATE program. The following instructions
are for the Diamond main window. In UPDATE, start by choosing Settings >
% Update Settings.

To set update options:
1. In Diamond’s main window, choose Tools > Options.
The Options dialog box opens.

2. Inthe hierarchy tree of the Options dialog box, choose Environment/
Startup.

3. If you want the software to automatically check for patches, select
Automatic check for software update when Lattice Diamond
launches, and then select the desired interval.

Clear this option to disable automatic checking. If you disable this option,
you should occasionally run a manual check as described in “Getting a
Service Patch” on page 18.

Lattice Diamond 3.6 Help
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HELP FOR LATTICE DIAMOND : Updating Diamond from the Web

4. In the hierarchy tree of the Options dialog box, choose Environment/
Network Settings.

You need to set up an Internet connection to download patches regardless
of whether you selected automatic checking.

5. If you use a proxy server to reach the Internet, select Use a Proxy
Server. Then fill in the rest of the form.

Ask your system administrator for the host address, port assignment, and
proxy type. You may also find the proxy information in the options or
preferences of your browser. Check for Advanced or Connections options.

6. Click OK.

Getting a Service Patch

There are two ways to get service patches: checking manually with the
UPDATE program or, more conveniently, through the Start Page of Diamond’s
main window. If you enabled automatic checking in the UPDATE options,
Diamond notifies you whenever a new service patch becomes available.

In Windows, if a service patch is available, you have a choice between
installing the patch immediately or downloading it now and installing it later, at
a convenient time.

In Linux, you download the service patch and install it manually at your
convenience.

Whether you are installing immediately or just downloading the service patch,
getting it may take several minutes. Depending on the size of the patch,
installing it may take a few more minutes.

To get a service patch from the Start Page:

1. If you do not have automatic checking enabled, choose Help > Iﬁl Check
for Updates.

2. Check the lower-left corner of the Start Page. If there is a service patch
available, the frame is titled “Software Upgrade Recommended” and
shows a list of patches as shown below.

3. Forinformation about a patch, click the patch version number.

Your default browser opens with an update notice. This notice includes
information about installing the patch and links to the Lattice Web site for
more information.

4. After reading the update notice, do one of the following:
(Windows only) Click the Install icon that is next to the version

number to immediately install the service patch. Close all Diamond
tools and then restart Diamond.

Click the Download ‘&, icon that is next to the version number to save
the service patch to a directory and install it later. In the Save File

Lattice Diamond 3.6 Help
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Figure 1: Part of Start Page Showing a Patch Available
E:cnt_lmpl

Software Upgrade Recommended
Currently running Lattice Diamond software wersion:
1.1.00.50.42.10

‘We recommend that you use the Following version to
upgrade your Lattice Diamond software in order to
obtain the latest features and bug fixes,

#= & B1.1.00.50.42.10_x02_1200JEDEC-nt

Install Download  Patch version
Mindows anlyd numhber

dialog box, navigate to the location where you want to save the file
and click Save.

Hover the cursor over an icon to see a label for it.

To get a service patch from UPDATE:
1. Start UPDATE:

In Windows: Choose Start > Programs > Lattice Diamond > £}
UPDATE.

In Linux: On a command line, enter <install_path>/bin/lin/update.

2. If you have more than one version of Diamond installed, choose the
version that you want to update in the “Installed versions” box.

3. If you do not have automatic checking enabled, click Update.

4. Check the “Available update versions” box. If there is a service patch
available, the box shows a list of patches.

5. For information about a patch, click the patch version number.

An update notice appears in the lower portion of the window. This notice
includes information about installing the patch and links to the Lattice Web

site for more information.

6. After reading the update notice, do one of the following:

(Windows only) Click Install to immediately install the service patch.

Click Download to save the service patch to a directory and install it

later. In the Save File dialog box, navigate to a location where you
want to save the file and click Save.
See Also
“Setting Options for Updates” on page 17

“Installing a Downloaded Service Patch” on page 20

Lattice Diamond 3.6 Help
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Installing a Downloaded Service Patch

After you have downloaded a service patch, you can install it to update your
Diamond software.

Installing on Windows To install the service patch:

1.
2.
3.

4.

Close all Diamond tools.

Go to the location where you saved the service patch.
Double-click the service patch’s executable file (.exe).
The Lattice Semiconductor Setup program opens.

Follow the on-screen instructions.

Installing on Linux To install a service patch, you need to be listed in the
system’s sudoer file. The sudo utility allows the files to be installed with you as
the owner and with the proper permissions.

To install the service patch:

1.
2.

Close all Diamond tools.
On a command line, change to the directory holding the service patch:
cd <temp_tools>

Run the service patch’s executable file (.rpm) using the sudo and rpm
utilities:

sudo rpm -ivh <service_patch>.rpm

Lattice Diamond 3.6 Help
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Managing Projects

Managing design projects involves a variety of activities: creating and
maintaining the project, keeping track of the stages in the design
implementation process, reviewing reports detailing the results of the process,
and comparing different versions (implementations) of the project. Managing
projects can also include writing Tcl scripts to automate your own design and
test procedures.

Creating a project in Diamond is a simple matter of specifying a location for
the project files, any existing design source files, and the FPGA type. You do
this with the New Project wizard (choose File > New > Project). Diamond
creates a folder with a project file (.Idf) containing basic information about the
project, the beginning of a logical preference file (.Ipf), which controls how the
design is implemented in the map and place-and-route stages, and a default
strategy (Strategyl.sty).

A “strategy” is a collection of settings for controlling the different stages of the
implementation process (synthesis, map, place & route, and so on).
Strategies can control whether the design is optimized for area or speed, how
long place and route takes, and many other factors. Diamond provides a
default strategy, which may be a good collection to start with, and some
variations that you can try. You can modify Strategyl and create other
strategies to experiment with or to use in different circumstances.

The project folder also contains an implementation folder. Implementation
folders contain the source files, process reports, and other information for
different implementations, or versions, of a design. Having different project
implementations helps you to experiment and compare different designs. With
Run Manager (choose Tools > Run Manager) you can process multiple
implementations simultaneously and compare the results. You can check the
details of each implementation in a set of process reports (choose View >
Reports).

Lattice Diamond 3.6 Help
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As you develop your design, routine tasks can be controlled through the
Diamond graphical user interface or through scripts. Diamond comes with
command-line and Tcl commands for many of its functions.
See Also »“Creating a New Project” on page 23

“Using Strategies” on page 47

“Working with Implementations” on page 45

“Viewing Logs and Reports” on page 92

Running Lattice Diamond

The Diamond main window is the primary interface and provides an
integrated environment for managing the project elements and processes, as
well as accessing all Lattice Diamond tools and views.

To run the Diamond main window:

From your Windows desktop, choose Start > Programs > Lattice
Diamond > = Lattice Diamond.

Note

Lattice Diamond is the default Programs folder name when you install the Lattice
Diamond software. Change this name accordingly if you have chosen another
folder name during installation.

From your Linux platform shell window or C-shell window, execute:

<install path>/bin/lin/diamond

Pin Diamond to Start Menu or Taskbar

You can pin Diamond to your Windows Start menu or taskbar, so you can
open it quickly and conveniently, rather than looking for Diamond in the Start
menu.

To pin Diamond to the Start menu or Taskbar:

Choose the Windows Start menu. Find the Lattice Diamond icon. Right-
click the Lattice Diamond icon, and then click Pin to Start Menu or Pin
to Taskbar.

Note

You should not pin Diamond to the Taskbar through the minimized icon on the taskbar
while Diamond is running.

If you want to remove the pinned Diamond from the Start menu or the taskbar,
right-click on a pinned Lattice Diamond icon from the Start menu or the
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taskbar, choose Unpin from Start Menu or Unpin this program from
taskbar.

Managing Diamond Layout

The Diamond main window has many controls, views, tools, reports, outputs,
and a Tcl console. They are very flexible and can be configured to store your
preferred layout by using the Load Layout, Manage Layout, and Save Layout
menu commands.

Refer to the Lattice Diamond User Guide, the “User Interface Operation”
chapter, for more details.

Creating a New Project

A project is a collection of all files necessary to create and download your
design to the selected device. The New Project wizard guides you through the
steps of specifying project name and location, selecting a target device, and
adding existing sources to the new project.

Note

Do not place more than one project in the same directory.

To create a new project:
1. From the Diamond main window, choose File > New > & Project.
The New Project wizard opens.
2. Click Next.
3. Inthe Project Name dialog box, do the following:
Under Project, specify the name for the new project.

File names for Diamond projects and project source files must start
with a letter (A-Z, a-z) and must contain only alphanumeric characters
(A-Z, a-z, 0-9) and underscores ().

To specify a location for your project, click Browse. In the Project
Location dialog box, you can specify a desired location.

Under Implementation, specify the name for the first version of the
project. You can have more than one version, or “implementation,” of
the project to experiment with. For more information on
implementations, refer to “Working with Implementations” on page 45.

When you finish, click Next.

4. Inthe Add Source dialog box, do the following if you have an existing
source file that you want to add to the project. If there are no existing
source files, click Next.
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a. Click Add Source. You can import HDL, schematic, EDIF netlist, LPF
constraints, or Reveal Inserter project files at this time.

Tip

When you create a new project, the Diamond software always creates a default
<project>.lpf file for the project. If you already have an .Ipf file and want to use it in
your new project, you will need to add this .Ipf into the project. In this way this pre-

existing .Ipf file will be used as the active .Ipf. Otherwise, you will need to add this
pre-existing .Ipf later, and mark the <project>.Ipf inactive.

b. Inthe Import File dialog box, browse for the source file you want to
add, select it, and click Open.

The source file is then displayed in the Source files field.
c. Repeat the above to add more files.

d. To copy the added source files to the implementation directory, select
Copy source to implementation directory. If you prefer to reference
these files, clear this option.

e. When you finish, click Next.

In the Select Device dialog box, select a device family and a specific
device within that family. Then choose the options you want for that
device. When you finish, click Next.

In the Select Synthesis Tool dialog box, select the synthesis tool that you
want to use. This choice can be changed at any time. See “Selecting a
Synthesis Tool” on page 80 for more information. When you finish, click
Next.

In the Project Information dialog box, make sure the project settings are
correct and then click Finish.

Note

If you want to change some of the settings, click Back to modify them in the
previous dialog boxes of the New Project Wizard.

See Also

“Tips for Saving and Naming Projects” on page 31

“Reserved File Names” on page 31

Modifying a Project

After creating a project, you can modify the project by using the right-click
menu.

To modify a project:

1. Right-click on any part of the project in the File List view.

The right-click menu varies upon the different part of the project you have
chosen.
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2. You can choose to edit a device in the Device Selector, add source files,
implementations, or strategies as needed to the project, clone a strategy,
set the current highlighted strategy as active strategy, exclude certain
source files from an implementation or remove a file.

3. You can also edit properties of the project in the Project Properties dialog
box. You can set the top-level unit, specify the VHDL Library name, and
Verilog Include Search path in the Project Properties dialog box.

Importing ispLEVER Projects

Design projects created in ispLEVER can easily be imported into Diamond.
The process is automatic except for the ispLEVER process properties, which
are similar to the Diamond strategy settings, and PCS modules. All your
ispLEVER project settings can be handled smoothly in Diamond. After
importing a project, you need to set up a strategy for it and regenerate any
PCS modules.

Note

Before converting an ispLEVER project, make a backup copy of the project. In
ispLEVER, open the project and choose File > Archive Current Project. See the
iSpLEVER Help for details.

To import an ispLEVER design project:
1. In Diamond, choose File > Open > Import ispLEVER Project.

2. Inthe Select ispLEVER Project dialog box, browse to the project’s .syn
file.

3. Click Open.
The Import ispLEVER Project dialog box opens showing the .syn file.

4. |If desired, change the base file name or location for the Diamond project.
If you change the location, the new Diamond files will go into the new
location. By default, the “Copy design source to Implementation’s Source
directory” option is checked. The original source files will be copied to the
new location.

Note

If you choose to copy source files when importing an ispLEVER project, the
following limitations need to be noted:

Only source list in the project will be copied to your current project directory.

The files, .v, .txt, .ngo, and so on, related to an LPC file listed in the project will
not be copied. You can copy them to the current project directory manually.

Schematic symbols will not be copied.

Included Verilog files (specified in the source files) will not be copied.

5. Click OK.
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The project files are converted to Diamond format with the default strategy
settings.

6. Adjust the strategy settings.

See Also “Adjusting PCS Modules” on page 26

Adjusting PCS Modules

PCS modules created with IPexpress have an unusual file structure and need
additional adjustment when importing a project from ispLEVER. There are two
ways to do this adjustment. The preferred method is to regenerate the module
in Diamond. However this may upgrade the module to a more recent version.
An upgrade is usually desirable but if, for some reason, you do not want to
upgrade the PCS module, you can manually adjust the module by copying its
.txt file into the implementation folder. If you use this method, you must
remember to copy the .txt file into any future implementation folders.

To regenerate a PCS module:

1. Find the module in the Input Files folder of the File List view. The module
may be represented by an .Ipc, .v, or .vhd file such as pcs_1.Ipc.

2. If the File List view shows the Verilog or VHDL file for the module, and you
want to regenerate the module, import the module’s .Ipc file:

a. In the File List view, right-click the implementation folder [EH and
choose Add > Existing File.

b. Browse for the module’s .Ipc file, <module_name>.Ipc, and select it.
c. Click Add.
The .Ipc file is added to the File List view.

d. Right-click the module’s Verilog or VHDL file and choose Remove.
3. In File List, double-click the module’s .Ipc file.

The module’s dialog box opens.
4. In the bottom of the dialog box, click Generate.

The Generate Log tab is displayed. Check for errors.
5. Click Close.

In File List, the .Ipc file is replaced with an .ipx file. The IPexpress manifest
(.ipx) file is new with Diamond. The .ipx file keeps track of the files needed
for complex modules.

To manually adjust a PCS module:
1. Open a file window and browse to the new Diamond project.
2. Find the module’s .txt file, <module_name>.txt.

3. Copy the .txt file into the Diamond project’s implementation folder. The
implementation folder’'s name is based on the name of the .syn file. For
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example, if the ispLEVER project has a design_pcs.syn file and a PCS
module named pcs_1, move pcs_1.txt into the design_pcs folder.

Note

If you choose to copy source files when importing an ispLEVER project, the following
limitations need to be noted:

Only source list in the project will be copied to your current project directory.

The files, .v, .txt, .ngo, and so on, related to an LPC file listed in the project will not
be copied. You can copy them to the current project directory manually.

Schematic symbols will not be copied.

Included Verilog files (specified in the source files) will not be copied.

See Also »“Importing iSpLEVER Projects” on page 25

Targeting a Device

Lattice Diamond lets you retarget a design to a different device any time
during the design process.

To target a device:
1. Inthe File List view, double-click the device name.

The Device Selector dialog box opens. It contains all available devices
and their options.

2. Under Select Device, select a device family and a specific device within
that family. Then choose the options you want for that device.

You can also click Online Data Sheet for Device to view the data sheet
for any specific device.
Note

If you could not find the device you want in the device list, select Show Obsolete
Devices. Then the device list will also include obsolete devices.

3. When you finish, click OK.

The specified target device appears in the File List view.

Note

If you have an .ipx file whose device is not the same as the project device, double-click
the .ipx file in the File List view. You will get a Mismatch Device message asking you to
run IPexpress to regenerate the .ipx file. Click Yes if you want to regenerate the .ipx
file.
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Viewing Project Properties

After creating a project, you can view the project-related information in the
Project Properties dialog box.

To view project properties:

1. Right-click on any part of the project in the File List view, and choose
Properties.
The Project Properties dialog box opens.

2. Inthe dialog box, you can see the file name, category, and location of the
selected file. You can even enter values for some of the selected sections
of the project in the Value field.

Saving Project Files

You can save changes to source files and to project properties. You can also
save copies of individual files and whole design projects.

Saving Changes

As you are making changes to source files or to the project properties you
should frequently save the files. Diamond offers three save commands for
this:

File > Save: Saves the currently active item.

File > Save All: Saves all the content changes in the Power Calculator
files (.pcf), Reveal Project files (.rvl), schematic files (.sch), Verilog files
(v, .veri, .ver, .vo, .h), VHDL files (.vhd, .vhdl, .hdl, .vho), EDIF netlist files
(.edf, .edif, .edi, .edn, .edj), preference files (.Ipf, .prf, .tpf), text files (.txt),
synthesis constraint files (.Idc, .sdc), timing preference files (.tpf),
waveform files (.wdl), memory files (.mem), Reveal Analyzer files (.rva),
symbol library files (.lib), symbol files (.sym), and manifest files (.ipx).

File > Save Project: Saves project properties such as the target device,
implementation file lists, and strategy setting.

File > Save Project As: Opens the Save Project As dialog to save the
active project.

Also, if there are any unsaved changes when you close a project, a dialog box
will open offering a chance to specify which files you want to save.

Copying a Source File

You can create copies of source files using Diamond.
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If you make a copy of a source file in the same project folder as the original
file, remember that they must have different names and that modules in
different files must have different names.

To copy a source file:
1. Open the source file with a Diamond tool.
2. Choose File > Save <filename> As.

The “Save as” dialog box opens.

Browse to where you want to save the file.

4. Enter a new file name.

Note

In the Linux version of Diamond, when you save or export a file, the dialog box
does not automatically append an extension to the file name you specify. That is
the standard way Linux handles the Save As dialog box. You need to manually
add the relevant file extension.

5. Choose the file type from the “Save as type” menu. Be careful to choose
the right type or your copy will have the wrong extension and tools will not
recognize it.

6. Click Save.

Copying a Project

You can make a copy of a design project to use as the beginning of another
project. (If you want the copy to backup or move the project, see “Archiving a
Project” on page 30 instead.) This process saves all source and other project

files that are within the project folder to another folder. Referenced files are
not included.

To copy a design project:
1. Choose File > Save Project As.

The Save Project As dialog box opens.

2. Inthe dialog box, browse to where you want to save the copy.

3. Click the Create New Folder button to create a new project folder.

4. Type a new name for the folder and press Enter.

5. Double-click the new folder to open it.

6. If desired, give the project a new name in the “File name” box.

7. If you want the copy to include files generated by the implementation
processes, select Copy generated files.

8. Click Save.

If there are open files, the Save Modified Files dialog box may open.
Select files to be saved before copying and click OK.
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The current design project closes and the new one opens.

Check references to files outside of the project folder. These may need
adjustment.

See Also “Tips for Saving and Naming Projects” on page 31

Archiving a Project

Diamond offers you an easy way to archive the current project. A project
archive is a single compressed file (.zip) containing the information for the
entire project. After archiving a project, you can reload it in the main window
at any time.

When you archive a project that contains source files stored outside the
project folder, the remote files are compressed under the remote_files
subdirectory in the archive.

To archive the current project:

1. In the main window, make sure the project you want to archive is open.
2. Choose File > Archive Project.

3. Inthe Archive Project dialog box, specify the file name and location.

4

If you want to include all files in the project directory, not just source files,
select Archive all files under the Project directory.

Clearing this option may make a much smaller archive by leaving out
nonessential files such as temporary files or documentation. Without this
option Diamond archives only those files it recognizes as part of the
project. With this option Diamond archives all files in the project directory
of all kinds.

5. Click Save.

The archive file is created and stored in the specified location.

To reload the archived project:

1. In the Diamond main window, choose File > Open > Archived Project.
2. Inthe Select Archived Project File dialog box, browse to the archive file.
3. Click Open.
4

In the Open Archived Project dialog box, check the destination directory. If
this is not where you want to place the project files, click the Browse (...)
button.

5. Inthe Browse for Folder dialog box, browse to where you want to place
the project files.

6. Click OK.
7. Inthe Open Archived Project dialog box, click OK.
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The project files are extracted to the specified folder and the project is
opened in Diamond.

See Also “Copying a Project” on page 29

Tips for Defining Projects

Use the following guidelines when defining your projects:

Avoid using VHDL, Verilog HDL, or EDIF reserved words for module and
signal names in any of your source files.

Each source file must have a unique name in the project. You cannot have
two different source files with the same name. You can use the same
source file many times in a design by instantiating the source file. Two
different source files with the same name can cause problems with the
hierarchy. For example, do not use a Verilog file called “compare” and a
schematic file also called “compare.”

Do not include the same module name in different sources within one
project.

Tips for Saving and Naming Projects

Use the following guidelines when saving and naming source files and your
projects:

Do not save more than one project in the same directory.

File names for Lattice Diamond projects and project source files must start
with a letter (A-Z, a-z) and must contain only alphanumeric characters (A-
Z, a-z, 0-9) and underscores ().

Try to shorten the length of the path name and levels of the directory.
Problems might occur when the path of a project is too long.

Reserved File Names

Lattice Diamond reserves some filename extensions for its own use. You
should avoid using the following extensions when naming your own files:

File Extension File Use

_sc Schematic Editor log file

_sy Symbol Editor log file

_wt Waveform Editor Viewer log file
_wWv Waveform Viewer log file

.asc ASCII schematic file
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File Extension File Use

.asy ASCII symbol file

.ed* EDIF netlist

.err Error output file

fpo, .fp1 ORCAstra configuration file

fpm ORCAstra macro file

.his Waveform Viewer history file

.ipx Manifest file. This file is loaded into IPexpress so that

modifications can be made to the module.

Ici Constraint file

.Ico Constraint output from the Fitter (such as the post-fit pinouts)

ct Temporary working copy of the constraint file

.Idc Lattice synthesis constraint file

|df Lattice Diamond project file

Ipc Lattice parameter configuration file created with IPexpress in
iSpLEVER

pf Logical preference file

.nam Binary waveform name file

.pcf Power Calculator project file

.pin Netlist file for generic netlist by pin

.rva Reveal Analyzer file

.l .rvs Reveal Inserter project file

.sch Schematic Editor files

.Sty Lattice Diamond strategy file

.sym Symbol Editor file

.syn ispLEVER project file (reserved only when importing an

iSpLEVER project into Lattice Diamond)

.spf Lattice Diamond Simulation Wizard file

tpf Lattice Diamond Simulation timing preference file
.vis ORCAstra custom Visual Window definition

.wav Waveform Viewer waveforms and trigger information
wdl Waveform Editor display file

.wet Waveform Editor database
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Managing Project Sources

The Diamond software combines design sources into different categories and
list them in the File List view. You can see folders in the File List view. The
source files are classified and listed under these folders. There are Strategies,
Input Files, Synthesis Constraint Files, LPF Constraint Files, Debug Files,
Script Files, Analysis Files, and Programming Files.

The HDL, schematic, edif netlist, and IP Module files can be found in the Input
Files folder. The logic preference files are in the LPF Constraint Files folder.
The Reveal project files can be found in the Debug Files folder. The Power
Calculator, and timing preference files are in the Analysis Files folder.

You can also see implementations listed in the File List view. For details about
implementations, see “Working with Implementations” on page 45.

File List View The File List view of the Diamond main window lists all the
design sources. The sources are categorized by different types and are
identified with different icons. Bold items are active and will be used when
processing the design project. Grayed out items will not be used.

@:, : _______—-——Prujectname
L LFE3-17EA-BFNeid ——— | Device partnumber
=10 Strategies Strategies: Firstfour fwrench icon) are prebuilt and cannot
' Area he changed. Customize Strategy! and others you add.
1/ Assistant
= Guick,
0 Timing
Strategyl
EH o icf ———————Implementations: different versions ofthe design.
= [EH io_icf_alt —— -
=1 Input Files Input Files: design files such Yerilog and WHOL.
,E} in_icf _alkfsourcefiohasic. v Includes files for the design and the testhench.

J!blLl' in_icf_alkfsourcefrompa. v
JEH io_icf_alt/sourcefcompa_modz v

= I Synthesis Constraint Fles ——————— Synthesis Constraint Files: SDC files used by synthesis tools.
D io_icf_alt/source/iobasic.sdc
= | LPF Constraint Filas ————————— LPF Constraint Files: Lattice preference files
ﬁ io_icf_alt/source/io_icflpf used by map and place-and-route stages.
I Debug Files ——on

—— Dehug Files: Reveal files used in an-chip debugging.

) Script Files ——ono
. " ScriptFiles: Simulation VWizard files.

2 &nalysis Files —__

2 Programming Fles —__ T

T Analysis Files: Power Calculator and Timing Preference files.

R Pragramming Files: files far programming a device
such as bitstream or JEDEC.

Files Listed in the File List View

File Type Icon  File Extension
Project Title @ None
Target Device i None
I
Predefined Strategy (Area, I/0 Assistant, [3*' .Sty

Quick, and Timing)
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File Type Icon File Extension
Strategyl (that can be customized) .Sty

o
Implementation |E_E None
Verilog Files E .V, .veri, .ver, .vo, .h
SystemVerilog .SV
VHDL Files .vhd, .vhd|, .hdl, .vho

Schematic Files .sch

EDIF Netlist Files .edf, .edif, .edi, .edn, .edj

IP Module Config Files .ipx

Undefined or incorrect Any source reference

oy | M@ | e

Synthesis Constraint Files D .sdc, .fdc, .Idc
Preference Files EI pf
Reveal Project File Rfl .rvl
Simulation Project File D .Spf
Reveal Analyzer Files ”-;_LB .rva
Timing Preference File Tfl Apf
Power Calculator Files prj .pcf

Note for Linux

In the Linux version of Diamond, when you save or export a file, the dialog box does
not automatically append an extension to the file name you specify. That is the
standard way Linux handles the Save As dialog box. You need to manually add the
relevant file extension.

SystemVerilog Limitations The following tools do not support
SystemVerilog files:

Lattice Synthesis Engine (LSE)—Use Synplify Pro for Lattice or another
synthesis tool that supports SystemVerilog.

Hierarchy
Simulation Wizard

Reveal Inserter and Reveal Analyzer

See Also “Running Processes” on page 69
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Creating a New Source File

You can create a new source from within Diamond or external to Diamond.

To create a new source file:
1. In the Lattice Diamond main window, choose File > New > File.
The New File dialog box opens.

2. Inthe dialog box, select the type of file you want to create. Fill in the file
name, browse to choose a location for the file, check the Add to project
option, choose the Implementation you want the file to be part of, and then
click New.

Diamond starts an editor that you can use to enter the information for your
new source file. For language-based sources, the Source Editor is started.
For schematic sources, the Schematic Editor is started. For module
sources, IPexpress is started.

3. Inthe editor, create a source file.

Some of the files can be directly added to the input files or constraint files
folder of the File List view in Diamond, while some can be called by certain
modules when running certain processes.

Note

File names for Diamond projects and project source files must start with a
letter (A-Z, a-z) and must contain only alphanumeric characters (A-Z, a-z, 0-9)
and underscores ().

In the Linux version of Diamond, when you save or export a file, the dialog box
does not automatically append an extension to the file name you specify. That
is the standard way Linux handles the Save As dialog box. You need to
manually add the relevant file extension.

See Also “Analyzing a Design” on page 53

Importing an Existing Source File into a
Project

You can easily import existing source files into your project. Source files for a
project can be stored in different locations.

The files added to the project appear in the Input Files folder. You can adjust
the file order by drag-and-drop. If several modules are detected as being
uninstantiated, the last one will be automatically treated as the top-level
module. You can also set the top-level module from the implementation
property dialog box.
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To import an existing source file:

1. Choose File > Add > Existing File from Lattice Diamond. Or, with a
project opened in Lattice Diamond, right-click the current implementation
and choose Add > Existing File.

The Add Existing File dialog box opens.
2. Browse for the source file you want to import.
3. Select the file and click Add.

The selected file is added to the Input Files folder of the File List view. If
the source file is stored outside the project folder, the path of the file is
displayed.

Double-click the imported file. The file can be opened in the associated
editor (this is a Windows-only feature).

Tip
If you want a source file that is outside the project folder to be copied to the
project directory, select the Copy file to Implementation’s Source directory

when adding existing file option from the Options dialog box, in the
Environment > General section.

Diamond project creation supports mixed language source files, allowing you
to freely mix Verilog HDL, VHDL, and schematic design. The Diamond
software will figure out the hierarchy structure that is associated with the
module names. You need to pay special attention to the module names and
the case, as Verilog is case-sensitive and VHDL is case-insensitive.

See Also “Analyzing a Design” on page 53
“Setting the Top-Level Unit for Your Project” on page 42

Importing an IPexpress Module

After generating module source files using IPexpress, you can import the
IPexpress manifest file (.ipx) into Lattice Diamond. If the module was
originally customized with ispLEVER, you may see an .Ipc file but no .ipx file.
The .ipx file is new with Diamond. However, Diamond also supports .Ipc files
for backward compatibility. The iSpLEVER .Ipc file can be converted to a
Diamond .ipx file by re-generating the IPexpress module. When you
regenerate a module from Diamond, the .Ipc file is replaced with an .ipx file.
For details on how to import ispLEVER modules, refer to “Adjusting PCS
Modules” on page 26.

To import a module source (.ipx) file:

1. Inthe Lattice Diamond main window, choose File > Add > Existing File.
The Add Existing File dialog box opens.

2. Browse for the .ipx file you generated and select it.

3. Click Open.
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The selected .ipx file is added and listed in the File List view.

Note

When you import an existing ispLEVER project with an existing .Ipc file, you need to
re-open IPexpress using the .Ipc file, regenerate the module, then add the .ipx file to
the Lattice Diamond project.

For information on how to create a module source file, refer to “Designing with
Modules” on page 179.

See Also »“Moadifying a Source File in IPexpress” on page 44

Importlng an IPexpress IP Core

After generating Lattice CORE IP source files using IPexpress, you can import
the IPexpress manifest file (.ipx) into the Lattice Diamond main window. If the
module was originally customized with ispLEVER, you may see an .Ipc file but
no .ipx file. The .ipx file is new with Diamond. However, Diamond also
supports .Ipc files for backward compatibility. When you regenerate an IP core
from Diamond, the .Ipc file is replaced with an .ipx file. For details on how to
import ispLEVER modules, refer to the “Adjusting PCS Modules” on page 26.

To import an IP source (.ipx) file:

1. In the Lattice Diamond main window, choose File > Add > Existing File.
The Add Existing File dialog box opens.

2. Browse for the .ipx file you generated and select it.

3. Click Open.

The selected .ipx file is listed in the File List view.

Note

Some IP cores require factory assistance to generate custom configurations. See the
Intellectual Property section of the Lattice Web site for more details on which IP cores
are user-configurable versus factory-configurable.

”

For information on how to create an IP core, refer to “Designing with Modules
on page 179.

See Also »“Modifying a Source File in IPexpress” on page 44

Adding Reveal Debug Information

Reveal Inserter manages the addition of Reveal debug information into the
Lattice Diamond source file. By default the Reveal Inserter project file (.rvl)
will be automatically added to the File List view once Reveal Inserter has
successfully merged trigger and trace signal features into your design. The
procedure below describes how to manually import an .rvl file.
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To import a Reveal project file (.rvl):

1. Inthe Lattice Diamond main window, choose File > Add > Existing File.
The Add Existing File dialog box opens.

2. Browse for the .rvl file you generated and select it.

3. Click Add.
The selected .rvl file is listed in the File List view.
You can have multiple Reveal project files for your project. However, you

can only set only one .rvl file active at one time.

For more information, refer to “Testing and Debugging On-Chip” on page 981.

Adding a LatticeMico Platform

LatticeMico platforms are modeled with a behavioral Verilog HDL file
(<platform_name>.v) and in some cases a combination of IP core peripherals
generated by IPexpress, and custom peripherals written in VHDL. The Mico
System Builder (MSB) creates a design file list of the entire platform to ease
importing into the Lattice Diamond main window.

To import a platform design file list output by MSB:
1. In the Diamond main window, choose Tools > Options.

2. Inthe Options dialog box, expand the Environment list and select
General.

3. Make sure that the Copy file to Implementation’s Source directory
when adding existing file option is cleared, and click OK.

4. In the File List pane of Diamond, create a new implementation, or select
the implementation that you want to use for the platform files.

5. Choose File > Add Existing File.

6. In the dialog box, browse to the MSB platform file list
<platform_name>soc location, select the source files to be added, and
click Add.

7. Inthe Choose Top Module dialog box, select the top-level source file from
the drop-down menu and click OK.

For complete information on creating a microprocessor platform, refer to the
Lattice Mico System Builder section of the LatticeMico System online Help.

Importing Test Stimulus Files Using Simulation
Wizard

If your design needs Verilog test fixture (.v) or VHDL test bench (.vhd), use
the Simulation Wizard.
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If multiple hierarchical test stimulus files are to be used, you should first import
the top-level test file, and then add lower-level test stimulus as dependency
files. Lattice Diamond will run all these test files in a hierarchical order during
the simulation process.

To import a test stimulus file:

1. In Lattice Diamond, choose Tools > = Simulation Wizard.
The Preparing the Simulator Interface dialog box opens.

2. Click Next.

3. Inthe Simulator Project Name dialog box, enter a name for your
simulation project in the Project name field. Browse to find a desired
location for your project. Then choose either Active-HDL or ModelSim as
the Simulator.

4. Inthe Process Stage dialog box, all the available process stages of the
FPGA implementation strategy are automatically displayed. Choose the
stage you want to run simulation.

5. Click Next.

6. Inthe Add Source dialog box, browse for your desired Verilog test fixture
(.v) or VHDL test bench (.vhd) and select it. Check the Copy Source to
Simulation Directory option if you need.

7. Click Next.

8. Inthe Summary dialog box, all your simulation project information is listed,
including simulator name, project name, project location, simulation stage,
simulation files, and simulation libraries.

Check the “Run simulator” option if you want to run the simulation right
away.

9. Click Finish to exit the Simulator Wizard. Your simulation project (.spf) is
added to the Script Files folder of the File List view.

Note

The simulation flow in Diamond 1.3 or later has been enhanced to support source files
that can be set in the File List view to be used for the following purposes:

Simulation & Synthesis (default)
Simulation only
Synthesis only.

This allows the use of test benches, including multiple file test benches. Additionally,
multiple representations of the same module can be supported, such as one for
simulation only and one for synthesis only.

Refer to “Simulating the Design” on page 297 for more details on how to use
the Simulation Wizard.

Lattice Diamond 3.6 Help

39



MANAGING PROJECTS : Managing Project Sources

Managing Constraint Files
There are different types of constraint files in Diamond.
Synthesis constraint file: SDC, FDC, LDC
LPF constraint file: LPF
About Synthesis Constraint Files Depending on the synthesis tool you
chose, you can add .fdc files for Synplify Pro, .sdc files for Precision, or .Idc

files for Lattice Synthesis Engine (LSE). The files are listed in the Synthesis
Constraint Files folder in the File List view.

Adding, Activating, Editing, and Removing Synthesis Constraint Files
You can add, activate, edit, or remove synthesis constraint files of your
project.

To add a synthesis constraint file:

1. Right-click the Synthesis Constraint Files folder in the File List view, and
choose Add.

2. Choose New File if you want to add a new synthesis constraint file.
Choose Existing File if you want to add an existing synthesis constraint
file.

The selected file is added to your project.

To activate a synthesis constraint file:

Right-click the synthesis constraint file in the File List view of Diamond,
and choose Set as Active.

The selected synthesis constraint file is activated.

Note

You can make zero or one .ldc constraint file active in your project.

You can make multiple .sdc and .fdc constraint files active in your project.

To edit a synthesis constraint file:

Double-click the synthesis constraint file you want to edit from the File List
view of Diamond. Or, right-click the synthesis constraint file you want to
edit from the File List view of Diamond.

The selected synthesis constraint file is opened in the Source Editor. You
can edit the selected file in the editor. See “Using Templates” on page 160
for more information.

To remove a synthesis constraint file:

Right-click the synthesis constraint file in the File List view of Diamond,
and choose Remove.

The selected file is removed from your project.
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About LPF Constraint Files You can add one or multiple logic preference
files (.Ipf) to your project. They are listed in the LPF Constraint File folder of
the File List view.

Note

You can set only one .Ipf file active in your project at one time.

Adding, Activating, Editing, and Removing LPF Constraint Files You
can add, activate, edit, or remove LPF constraint files (.Ipf) of your project.

To add an LPF constraint file:

1. Right-click the LPF Constraint Files folder in the File List view of Diamond,
and choose Add.

2. Choose New File if you want to add a new LPF constraint file. Choose
Existing File if you want to add an existing LPF constraint file.

The selected file is added to your project.

To activate an LPF constraint file:

Right-click the LPF constraint file in the File List view of Diamond, and
choose Set as Active.

The selected file is activated.

Note

You can set only one .Ipf file active in your project at one time.

To edit an LPF constraint file:

Double-click the LPF constraint file you want to edit from the File List view
of Diamond. Or, right-click the LPF constraint file you want to edit from the
File List view of Diamond.

The selected LPF constraint file is opened in Source Editor. You can edit
the selected file in the editor. See “Using Templates” on page 160 for more
information.

To remove an LPF constraint file:

Right-click the LPF constraint file in the File List view of Diamond, and
choose Remove.

The selected file is removed from your project.

See “Applying Design Constraints” on page 347 for more information.
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Setting the Top-Level Unit for Your
Project

It is a good practice to specify the top-level unit (or module) of the design. If
you don’t, Diamond will try to determine the top-level unit. While usually
accurate, there is no guarantee that Diamond will get the correct unit.

You may also want to change the top-level unit when experimenting with
different designs or switching between simulation and synthesis.

Notes for EDIF Modules

In a mixed language design, you cannot set an EDIF module as the top-level unit.
This is also true when a project with EDIF modules is mixed with .ipx files, which
represent modules and IP generated with IPexpress.

In a pure EDIF design, do not use the following procedure. Instead, in the File List
view, arrange the input files so that the top-level unit is in the last file in the list.

To set the top-level unit for your project:
1. Inthe File List view, right-click the active implementation folder [EH.
2. From the drop-down menu, choose Properties.
The Project Properties dialog box opens.
3. Click in the Value cell for Top-Level Unit.
4. Type the name of the top-level unit.

At its right end, the Value cell also shows an arrow for a drop-down menu.
Usually the menu shows one name or just “<Edit>.” But if Diamond found
multiple possible top-level units, the menu will show those names. If the
correct top-level unit is in the menu, you can choose it.

5. Click OK.

If the hierarchy is up to date, the source file that contains the top-level unit
is displayed in bold.

Modifying a Source File

You can edit any of the source files that make up your project by double-
clicking on them to open the corresponding editor.

Note

In order for Windows file associations to work properly with Diamond, in the main
window choose Tools > Options. Then in the Options dialog box, find the
Environment > File Associations section.

Modifying a Source File in Schematic Editor Use the Lattice Diamond
Schematic Editor to edit a schematic file (.sch). You can open the Schematic
Editor in the following ways:

Lattice Diamond 3.6 Help

42



MANAGING PROJECTS : Managing Project Sources

Double-click the schematic file name from the File List view of Lattice
Diamond.

In the File List view, right-click the schematic file and choose Open or
Open with from the pop-up menu.

The Symbol Editor works in conjunction with the Schematic Editor. You can
open the Symbol Editor by creating a new a symbol file in Lattice Diamond.
For details on how to create a symbol, see “Creating Schematic Symbols” on
page 257 in the Schematic Design Entry Help for more detalils.

Modifying a Source File in Source Editor You can use the Source Editor
to enter or edit VHDL (.vhd), Verilog HDL (.v), or Preference (.Ipf) files.

You can open the Source Editor in these ways:
Double-click the text file name in the File List view of Lattice Diamond.

In the File List view, right-click the text file and choose Open or Open with
from the pop-up menu.

Modifying a Source File in Your Favorite Text Editor Similarly, you can
use any text editor to edit the above-mentioned files, and then import them

into your project using File > Add > Existing File from the Lattice Diamond
main window.

Note

A preference file (.Ipf) can also be created or edited in the Spreadsheet View.

You can open any text editor in this way:

In the File List view, right-click the text file and choose Open with from the
pop-up menu. In the Open with dialog box, click Add if you want to add
your favorite text editor; or, click Edit, if you want to edit your favorite text
editor. In the Add or Edit dialog box, specify command arguments for the
external editor. The mapping between the argument substitution values
and the value which replaces them are:

%F = File Name; %L = Line Number

For example, to configure the gVim text editor, use the following command
line: <path>/gvim +%L %F

In the Options dialog box, choose Options > Environment > File
Associations. From the File Associations table, you can see the file
extension and the default associated program. You can choose the file
type you want to open/edit with your favorite text editor. Click the Add
button from the External programs for ... file extension field to add your
favorite text editor. Use the Edit or Remove button to manage your file
and associated editor list.
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After adding or editing the external text editor, you can save it as your default
text editor in the Open with dialog by clicking Save As Default.

Note

If you change a source file in a third-party text editor, you need to choose Design >
Refresh Design so that Lattice Diamond can refresh the process list to reflect the
current process status and update views such as Hierarchy.

Modifying a Source File in IPexpress You can use IPexpress to edit the
module or IP core source (.ipx) file.

To modify a module or IP core source:
1. Inthe File List view, double-click the .ipx file.
IPexpress opens.
2. Make modifications as you want, and then exit IPexpress.

The .ipx file in the File List view is updated. You may need to rerun the design
to reflect the changes you made.

For information on how to use IPexpress, refer to “Designing with Modules”
on page 179.
See Also »“Importing an IPexpress Module” on page 36

“Importing an IPexpress IP Core” on page 37

Excluding a Source File

Sometimes you may want to exclude specific source files from logic synthesis
and simulation. The excluded source files remain in your design project, but
they will not be synthesized or simulated by the software.

To exclude a source file:

1. Inthe File List view, right-click the target source file and choose Exclude
from Implementation.

The selected file is excluded from the implementation. The target file is
grayed out.

Note

To include the source file again, right-click the target source file and choose Include in
Implementation.
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Removing a Source File
You can remove a source from a project by using the Lattice Diamond
Remove command, or the Windows’ Delete command.

Removed source files are no longer part of your project. If you just want to
exclude a file from logic synthesis and simulation, see “Excluding a Source
File” on page 44.

To remove a source file from a project:
1. Inthe File List view, select the file that you want to remove.

2. Right-click the filename and choose Remove, or press the Delete key on
your keyboard.

The Lattice Diamond software removes the source from the project.

Working with Implementations

Implementations define the design structural elements for a project. An
implementation contains the structure of a design and can be thought of as
the source and constraints to create the design. For example, one
implementation may use inferred memory and another implementation may
use instantiated memory. There can be multiple implementations in a project,
but only one implementation can be active at a time and there must be at least
one implementation.

An implementation is automatically created whenever you create a new
project. You can create new implementations using the source files of an
existing implementation. You can also clone (copy) an existing
implementation including all the related files and settings.
Implementations consist of:

Input files

Constraint files

Debug files

Script files

Analysis files

Creating New Implementations

To create a new implementation:

1. With the project opened in Lattice Diamond, choose File > New >
Implementation.

2. Inthe New Implementation dialog box, enter a name for the new
implementation.
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N oo g &

This name also becomes the default name for the folder of the
implementation.

Change the name of the implementation’s folder in the Directory text box if
desired.

Change the location of the implementation’s folder if desired.

Choose the synthesis tool from the drop-down menu.

Choose the default strategy from the drop-down menu.

Add sources files by clicking Add Source and choosing either:
Browser to select individual files.

From Existing Implementation > <implementation name> to use the
source files of an implementation that already exists in this design
project.

Remove unwanted files by selecting the files and clicking Remove
Source.

If you want to copy all of the source files into the new implementation
folder, giving you the freedom to change the files without affecting other
implementations, select the Copy source to implementation directory
option.

To view or set properties of the source files, select a file and click
Properties. The Properties dialog box opens. To change a property, click
in its Value cell. Enter or choose the new setting. Then click OK.

10. Click OK.

Cloning Implementations

To clone an implementation:

1.

In File List view, right-click on the name of the implementation that you
want to copy and choose Clone Implementation.

The Clone Implementation dialog box opens.

In the dialog box, enter a name for the new implementation. This name
also becomes the default name for the folder of the implementation.

Change the name of the implementation’s folder in the Directory text box if
desired.

Decide how you want to handle files that are outside of the original
implementation directory. Select one of the options:

Continue to use the existing references
The same files will be used by both implementations.
Copy files into new implementation source directory

The new implementation will have its own copies that can be changed
without effecting the original implementation.

Click OK.
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6. In File List view, right-click on the name of the default strategy and choose
Edit.

The Strategies dialog box opens.
7. Inthe Process column, choose Translate Design.

8. Check the search paths. If they point to the folder of the original
implementation, change them to use the folder of the new implementation

9. Click OK.
Customizing Files in an Implementation After creating an
implementation, you can choose to include or exclude source files for the
implementation. You can customize files that are under the Constraint Files,
Debug Files, Script Files, and Analysis Files folders.
Customizing Input Files You can choose to:
Add a new source file or add an existing file.
Include the file for Synthesis, Simulation, or Synthesis and Simulation.
Exclude the file from the current implementation.
Remove the file from the project.
Activate Files You can have multiple files under each of the Constraint
Files, Debug Files, Script Files, and Analysis Files folders in the File List view.

But only one file can be active in each of those folders. To change a file’s
status, right-click the file and choose active or inactive.

Saving an Implementation If you want to save an implementation to the
project, choose File > Save Project from the Diamond main window.

See Also “Using Strategies” on page 47

Using Strategies

A strategy provides a unified view of all settings related to the optimization
controls of implementation tools, such as logic synthesis, mapping, and place
and route. Any number of strategies can be applied to your project to find the
best solution to meet your design objectives. For example, you might have
one strategy with a very fast placement and routing attempt to get a quick look
at the design, and another one with a higher effort level that's more thorough
and takes longer to try to meet timing constraints. Although you can create an
unlimited number of strategies, only one can be active at a time for each
implementation, and each implementation must have an active strategy.

Strategy settings are listed in the Strategies dialog box. You can open the
dialog box by double-clicking a strategy name in the File List view. Each
strategy is stored as an .sty file.

There are two different kinds of strategies: predefined strategy and
customized strategy.
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Predefined Strategy Several strategies are predefined and supplied by
Lattice: Area, I/0O Assistant, Quick, and Timing. They are designed to solve
particular types of designs.

Area

The Area strategy will try to minimize area by enabling the tight packing
option available in map. Use this strategy to achieve area requirements. It
is commonly used for low density devices such as MachXO and
MachXO2.

The benefit is that if it works, you will get results in area reduction.
However, applying this strategy to large and dense designs may cause
some difficulties in the place-and-route process with longer run time or not
completing routing.

I/O Assistant

This I/O Assistant strategy will try to place 1/O efficiently for your design at
an early stage. It helps to check if you set a legal 1/0 location that affects
board-level pin-outs.

The benefit is that if it works, you will get results in 1/0O placement
information at first without long runtime after finishing place and route.
However, applying this strategy to your design may take extra runtime on
the design, because it only executes logic synthesis, translation, map, and
I/0 placement processes.

Note

If you choose the 1/0 Assistant strategy for your project, the generated NCD file is
incomplete. Running the Export Files > Bitstream File or Export Files > JEDEC
File process (in the Process view) may fail.

If you want to implement a complete design, you need to choose another
strategy to rerun all the processes again.

Timing

The Timing strategy tries to achieve timing closure. The Timing strategy
uses a very high effort level in place and route. Use this strategy if you are
trying to reach the maximum frequency on your design. If you cannot

meet timing requirement with this strategy, try to customize a strategy with
individual settings.

The benefit is that if it works, you will get results in good timing
performance. However, this strategy may increase your runtime on place
and route compared to the Quick and Area strategies.

Quick

The Quick strategy uses a very low effort level in place and route to get
results with minimum processing time. If your design is small and your
target frequencies are low, this is a good strategy. Even if your design is
large, you might want to start with this strategy to get a first look at place-
and-route results and to tune your preference file with minimum
processing time.
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The benefit is that if it works, you will get results in the least possible time.
The quality of these results in terms of achieved frequency should be
expected to be low, and large or dense designs may not complete routing.

The settings of predefined strategies cannot be modified in the Strategies
dialog box. You can view their settings by:

Double-clicking the predefined strategy name in the Files List view and
opening the Strategies dialog box.

Right-clicking on the predefined strategy nhame in the File List view and
choosing View to open the Strategies dialog box.

Customized Strategy Excluding the predefined strategies, all other
strategies can be customized in the Strategies dialog box. The settings of the
strategy can be edited in the Strategy dialog box. You can edit its settings by:

Double-clicking the strategy name in the File List view and open the
Strategies dialog box.

Right-clicking the strategy in the File List view and choosing Edit to open
the Strategies dialog box.
See Also »“Creating a Strategy” on page 49
“Cloning a Strategy” on page 50
“Adding an Existing Strategy” on page 50
“Specifying Strategy Options” on page 51
“Saving a Strategy” on page 52
“Removing a Strategy” on page 52
“Strategy Reference Guide” on page 1053

Creating a Strategy

You can create a new strategy for your design.

To create a new strategy in Lattice Diamond:
1. Choose File > New > Strategy.
The New Strategy dialog box opens.

2. Inthe New Strategy dialog box, enter a name for the new strategy. Specify
a file name for the new strategy and choose a directory to save the
strategy file (.sty).

The new strategy is with all the default settings of the current design. You can
modify its settings in the Strategies dialog box.

If you want to save the strategy changes to your current project, choose File >
Save Project from the Diamond main window.
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Cloning a Strategy

You can clone any strategy you created or any of the Lattice predefined
strategies from the File List view. The new cloned file will contain all settings
of the strategy being cloned. You can then modify the settings for the cloned
strategy from within the Strategies dialog box.

To clone a strategy:

1. Inthe File List view, right-click on the strategy you want to clone and
choose Clone <name> Strategy.

2. Inthe Clone Strategy dialog box, enter a name for the new strategy in the
Strategy ID field. Specify a file name for the new strategy and choose a
directory to save the strategy file (.sty). By default, when you enter the
strategy ID, the file name is automatically specified the same.

The strategy you cloned is with all the settings of the base strategy. You can
modify the settings for the cloned strategy in the Strategies dialog box.

If you want to save the strategy changes to your current project, choose File >
Save Project from the Diamond main window.

Adding an Existing Strategy

You can add existing strategy to your design.

Note

A strategy copied from another design project may include inappropriate settings, such
as path names, that could cause problems. If you copy a strategy from another project,
review its settings carefully and adjust them as needed.

To add existing strategy to your design:
1. In Lattice Diamond, choose File > Add > Existing Strategy.

2. Inthe Select Existing Strategy dialog box, browse to the desired strategy
file (.sty) and click Open.

3. Inthe Add Existing Strategy dialog box, enter the name for the added
strategy as you want to see it appear in the File List view.

4. If the selected strategy file is not in the current project directory, you may
want to select the Copy strategy file to project directory option.

5. Click OK.
The new strategy appears in the File List view.
6. Double-click the new strategy to open the Strategies dialog box.

7. Carefully review the settings to make sure that they are appropriate for
your current project. Be sure to check the following items:

Under Synthesize Design > LSE, check:
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8.

Macro Search Path

Memory Initial Value File Search Path
Under Translate Design:

Macro Search Path

Memory Initial Value File Search Path
Under Bitstream:

Search Path

Note

If you did not select the “Copy strategy file to project directory” option when adding
the strategy, remember that you are working with the original file, which might also
be used by another project.

When your review is done, click OK.

If you want to save the strategy changes to your current project, choose File >
Save Project from the Diamond main window.

Specifying Strategy Options
You can use the Strategy dialog box to specify settings for a specific design
strategy.

To specify strategy settings:

1.

In the File List view, double-click the active strategy.
The Strategies dialog box opens.

In the left-hand pane, select a process for which you want to specify
settings. The left-hand pane shows a process list. Each of the processes
has its own settings.

In the right pane, double-click the Value column for the setting to be
changed to activate the pulldown menu with choices of settings or to be
able to enter filenames or directory paths into the field.

Select the value from the drop-down list, or type in the text value, and click
Apply.

Repeat steps 2-4 to specify more settings.

When you finish, click OK to close the dialog box.

All your changes to the strategy are updated in the system memory in
your Diamond session. Be aware that these changes are not
automatically written to your current project. If you want to save the
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strategy changes to your current project, choose File > Save Project from
the Diamond main window.

Tip
When a setting is highlighted, its brief definition will be displayed at the bottom of the

dialog box. You can also press F1 to view additional information for the highlighted
option.

See Also “Strategy Reference Guide” on page 1053

Saving a Strategy

If you want to save a new strategy, a cloned strategy, or any change of a
strategy setting to your project, click File > Save Project from the Diamond
main window.

Setting Active Strategy

If you have more than one strategies in the project, you can choose to set an
active strategy.

To set an active strategy:

Right-click the target strategy and choose Set as Active Strategy.

If you want to view the settings of the active Strategy, choose Project >
Active Strategy. From the submenu, choose the settings you want to view.
The Strategies dialog box opens with the settings you have chosen. You can
view or edit the values of the settings.

Removing a Strategy

You can remove a strategy from the design by right-clicking on the target
strategy and choosing Remove.

Getting Help on Strategies

To find the online Help description of strategy settings, do one of the following:

Open the “Strategy Reference Guide” on page 1053 in the Contents pane
of the Lattice Diamond Online Help. The Contents pane displays all
process options in the order they appear in the Strategies dialog box.
Choose the desired process option. You will see the strategies associated
with this process. Use the scroll bar to select a setting and view its
description.
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In the Lattice Diamond File List view, double-click a strategy name to open
the Strategies dialog box. You can then highlight a setting to display its
brief definition at the bottom of the dialog box, or press F1 to view
additional information for the highlighted option.
See Also »“Strategy Reference Guide” on page 1053
“Creating a Strategy” on page 49
“Cloning a Strategy” on page 50
“Adding an Existing Strategy” on page 50
“Specifying Strategy Options” on page 51
“Saving a Strategy” on page 52
“Setting Active Strategy” on page 52
“Removing a Strategy” on page 52

Analyzing a Design

There are a few ways to analyze your design while it is being implemented.

Before synthesis, the Hierarchy view provides a nested list of all modules plus
commands to access the source code for individual modules, to set up test
benches, and more. See “Hierarchy View” on page 53.

After synthesis, the Hierarchy view also provides information on how the
modules are using device resources.

After synthesis, schematic views are also available. These views depend on
which synthesis tool you are using. If you are using Lattice Synthesis Engine
(LSE), you can use Diamond’s Netlist Analyzer to see and analyze the
design. If you are using Synplify Pro, you can use its HDL Analyst. See
Synplify Pro for Lattice User Guide.

After mapping, the Hierarchy view provides updated information on how the
modules are using device resources. Also, if you are using LSE, Netlist
Analyzer shows how the design is mapped to the device’s architecture.

Hierarchy View

The Hierarchy view shows the design hierarchy as a nested list of modules.
The Hierarchy view opens automatically when you open a project. If the
Hierarchy view is not open, choose View > Show Views > Hierarchy from
the Diamond main window.

The Hierarchy view also shows the full path name of the files that define each
module and, once synthesis has been run, the amount of device resources
that each module would consume.
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Commands in the Hierarchy View

Right-click in the Hierarchy view to get several useful commands described
below.

Goto Source Definition This command opens the source editor with the
source code that contains the definition for that object, and automatically

scrolls the view to the position in the code where the object is defined. For
objects that include multi-line definitions, the entire definition is highlighted.

Goto Source Instantiation This command brings you directly to the source
file where the module is instantiated, making it easy to see and fix errors.

Goto RTL Definition After synthesis has been run with LSE, this command
opens Netlist Analyzer with a schematic view of the design element.

Verilog Test Fixture Declarations This command creates the Verilog test
fixture declarations include file (.tfi) based on the Verilog unit selected from
the Hierarchy view. This include file should be referenced by your test fixture
using: ‘include “<file_name>.tfi". By including the.fi file in your simulation test
fixtures, you ensure that the design and the test fixtures stay synchronized.

Verilog Test Fixture Template This command creates a Verilog test fixture
template file (.tft) based on the Verilog unit selected from the Hierarchy view.
The template file includes a Verilog design unit with a module declaration.
Use the procedure below to create a Verilog test fixture from the .tft file.

To create a Verilog test fixture from a Verilog Test Fixture Template (.tft)
file:

1. Open the .tft file from the project directory and save it with a .v file
extension.

2. Import the new .v file into the project as a Verilog test fixture. Then add
codes to the user defined section to complete the stimulus for your
design.

VHDL Test Bench Template This command creates a VHDL template file
(.vht) based on the VHDL unit selected from the Hierarchy view. The template
file includes a VHDL design unit with a component declaration and an
instantiation based on the entity interface of the first VHDL design unit
encountered.

Note

Avoid using user-defined record type array in your design. Try to use standard data
type such as std_logic_vector. Using your own defined record type array may cause
the signal width to be incorrect in the VHDL test bench template file generated.
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Generate Schematic Symbol This command creates a schematic symbol
(.sym) based on the design unit selected from the Hierarchy view. This
process runs an independent utility to convert the NAF file that is associated
with the selected design unit to a SYM file.

Note

Avoid using user-defined record type array in your design. Try to use standard data
type such as std_logic_vector. Using your own defined record type array may cause
the signal width to be incorrect in the schematic symbol file generated.

Set as Top-Level Unit  You can directly set the selected module as the top-
level unit by using this command.

Device Resources

Device resources that would be consumed are shown to the right of each
module. The first number in each column is the number of that resource that
would be used by that module and all of its submodules. The second number,
in parentheses, is the number of that resource that would be used by just that
module, not including any of its submodules. The numbers are updated after
the synthesis and map stages of the implementation process. For definitions
of the resource types, see Table 1 on page 55.

Note

If your source files for the design include one or more EDIF files, the resources shown
may not represent the whole design. After synthesis but before the translate or map
stages, results are only for the files that went through the synthesis tool. EDIF files,
being the result of synthesis, are not included. After the translate or map stages, the
results represent the whole design including any EDIF files.

The Hierarchy view only shows the design. It does not include any Reveal
modules. However, when the top module of the design shows device
resources, it does include the resources of any Reveal module. So, if you
have included a Reveal module, the top module shows more resources than
the submodules add up to.

Table 1: Resource Definitions

Hierarchy View  Synthesis Report Definition

Term Term

LUT4 Orcalut, Lut Four-input look-up tables that can
implement Boolean functions with up to four
variables

Registers FD Sequential elements with clock, enable, and
synchronous or asynchronous set and reset

10 Registers IF, OF Sequential elements (registers) within input/

output blocks
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Table 1: Resource Definitions

Hierarchy View  Synthesis Report Definition

Term Term

DSP MULT MULT Configurable multipliers for high speed
operations

DSP ALU ALU Configurable adders for high speed addition,
subtraction, and logic functions like AND/OR

EBR SP, DP, PDP Embedded Block RAM to store large sets of
data; configurable for word size and depth

Distributed RAM  SPR, DPR RAM distributed with every logic element to
store small sets of data such as register files

ROM ROM EBR configured as read-only memories

PFUMux PFU Dedicated multiplexers that implement 5-
input functions using two LUT4 that directly
drive the mux inputs

L6Mux L6M Dedicated multiplexers that implement 6-
input functions using four LUT4 and two
PFUMux that drive the L6Mux inputs

Carry cells CCuU Dedicated logic cells to implement fast carry
generation and propagation in adders

SLICE Elements with two LUT4 that feed two
registers and associated logic that can
perform functions such as LUT8

Instantiated Anything not covered by the other terms

Changing the Display
You can adjust the display by re-arranging the columns and sorting the rows.
You can also choose which ones you want to see.

To change which columns are displayed:
1. Right-click in any column heading.
2. Inthe drop-down menu, the resource that you want to show or hide.

Note: Resources that are not being used by the design at all are
automatically hidden in Hierarchy view regardless of the option settings.

To re-arrange columns:

Click on the heading of the column that you want to move and drag it to
where you want it.

To sort the modules:
1. Click in the heading of the desired column.

The rows are sorted according to the contents of that column.
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2. To reverse the order of the rows, click in the same column again.

To change the width of columns:
Click on the right-hand border of a column and drag to make that column
narrower or wider.

Saving the Data You can save resource counts for the top-level module as
either an ASCII (.txt) file or a comma-separated values (.csv) file that can be
opened with a spreadsheet tool such as Excel.

To save the data:
1. Right-click on any module row and choose either:
Export Resource to ASCII file
Export Resource to CSV file
2. Inthe dialog box, browse to where you want to save the data.
3. Enter the file name.
4. Click Save.

See Also “Commands in the Hierarchy View” on page 54

About Netlist Analyzer

Netlist Analyzer works with Lattice Synthesis Engine (LSE) to produce
schematic views of your design while it is being implemented. (Synplify Pro
also provides schematic views.) Use the schematic views to better
understand the hierarchy of the design and how the design is being
implemented.

To start Netlist Analyzer:
1. Synthesize the design with LSE.
2. Choose Tools > [ Netlist Analyzer.
The Netlist Analyzer window opens with the RTL netlist showing.

3. Inthe window'’s tool bar, click one of the following buttons:

@ RTL View to see the design’s logic (gates and registers) after LSE has
optimized it

"?,- Technology View to see the design after synthesis and translated into
Lattice primitive modules

"?,- Post-Mapping View (available only after mapping) to see how the
design is mapped to the device’s architecture

'.';_ Open External File to browse to a desired netlist database (.vdb) file

A new tab opens and is filled as described below.
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About Netlist Analyzer Views The Netlist Analyzer window has four parts:
Tool bar provides buttons for various functions.

Netlist browser provides nested lists of module instances, ports, nets, and
clocks.

Schematic view shows a schematic of the design. Depending on the size
of the design, the schematic may be made of multiple sheets.

Mini-map, which is a miniature view of the sheet, helps you pan and zoom
in the schematic view.

Netlist Analyzer can have multiple schematics open. The open schematics
are shown on tabs along the bottom of the window.

Bold lines are buses. Green lines are clock signals.

There are several ways to adjust the view of a schematic and to navigate
through the hierarchy.

Setting Netlist Analyzer Options

With Netlist Analyzer you can specify labels in the schematics, how the
hierarchy gets expanded, the highlight color, and the size of the sheets.

To change tool options:
1. Choose Tools > Options.
The Options dialog box opens.
2. Inthe left-hand list, find and expand Netlist Analyzer.
3. See the following instructions for specific options.
4. When finished, click OK.

To specify labels:
1. Under Netlist Analyzer, select Text.

2. Select the labels that you want to see in the schematics.

To create a schematic bookmark:
1. Under Netlist Analyzer, select Bookmarks

2. Inthe Add Bookmark dialog box, add a name for the bookmark. All
bookmarks are associated with a specific .vdb file with a time stamp. This
feature allows you to save a schematic graph after a series of operations,
such as filter and expand, for future reference. This features also allows
you to save and restore different critical paths of the design.

To control how the hierarchy gets expanded:

1. Under Netlist Analyzer, select Schematic.
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2.

Adjust the values of the following items:

Hierarchy Depth: The number of levels to show when using the
Dissolve Instances command. The default, 0, means to show all
levels.

Levels of Logic to expand: The number of additional levels to show
with the Expand To/From command.

Search depth to expand: The number of additional levels to show with
the Expand to FF/IO and Expand to Primitive commands. The default,
0, means to show all levels.

To change the colors:

1.
2.

Under Netlist Analyzer, select Schematic.

Click on the Select Color or Highlight Color block. The select color is
used to outline objects that you select in the schematic view. The highlight
color is used to outline objects that you want to keep highlighted after
selecting them.

The Select Color dialog box opens.

Select a color by doing one of the following:
Click one of the basic colors on the left.
Click in the color pallet on the right.

Enter values in the boxes at the bottom right. Work in one column or
the other as they are two separate methods of coding color.

The rectangle in the lower-middle changes to show the selected color. You
can change the darkness with the vertical slider at the upper-left.

Click OK.
In the Options dialog box, the color block changes to match.

If you want to see the effect of your change in the views, drag the Options
dialog box aside and click Apply.

To change the sheet size:

1.
2.

Under Netlist Analyzer, select Sheet.

Change the width and height as desired.

Adjusting the Schematic View

Netlist Analyzer schematics are usually displayed on many sheets, depending
on the size of the design. You may also have a few different schematic views
open at the same time.

There are a few ways to change the sheet being displayed and the
arrangement of the views. If you are dissatisfied by the layout of a sheet, you
can try regenerating it.
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To change the sheet being displayed:

Do one of the following:
Click the Next Sheet |= button.
Click the Previous Sheet 4| button.

Click the arrow in the Goto Sheet |#| = button. In the drop-down
menu, choose a sheet number.

Click the name at the end of a net on the left or right side of a
schematic (but not a port). This takes you to the continuation of the net
on another sheet.

To arrange views within the Netlist Analyzer window:

Anytime you open a schematic view it, along with its netlist browser, fills the
Netlist Analyzer window. There is a tab for each view along the bottom of the
window.

To change the arrangement, do one of the following:

Click the Tile = | button to change the views into smaller windows that
are arranged so that you can see them all at the same time.

Click the Cascade |ii}! button to change the views into smaller
windows that are arranged in a cascading, overlapping fashion.

The tabs remain in all modes. Click a tab to bring its window to the top.

In the tile and cascade modes, the schematic windows can be resized and
dragged within the Netlist Analyzer window. Maximizing a window restores
the tab mode.

To change the layout in a sheet:
Right-click in the schematic and choose Regenerate.

The schematic might change to a clearer layout. However, there will often
be no change as the layout is already the best that Netlist Analyzer can
do.

Zooming and Panning

You can zoom and pan within the Netlist Analyzer schematics using a variety
of methods. These include toolbar commands, dragging with the schematic,
and Netlist Analyzer’s mini-map.

Toolbar Commands The following commands are available on the
Diamond toolbar.

&y, ZoomIn— enlarges the view of the entire layout.

=, Zoom Out — reduces the view of the entire layout.
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Ql Zoom Fit — reduces or enlarges the entire layout so that it fits inside the
window.

(@, Zoom To — enlarges the size of one or more selected objects on the
layout and fills the window with the selection.

&1 Pan — enables you to use the mouse pointer to drag the layout in any
direction. This command is useful for viewing a hidden area on the layout after
zooming in.

Zooming with Function Key Shortcuts The following key combinations
enable you to instantly zoom in or out from your keyboard.

Zoom In — Ctrl++

Zoom Out — Ctrl+-

Zooming with the Mouse Wheel The mouse wheel gives you finer zoom
control, enabling you to zoom in or out in small increments.

While pressing the Ctrl key, move the mouse wheel forward to zoom in
and backward to zoom out.

Zooming by Dragging You can zoom by holding the right mouse button
and dragging:

To zoom to fit the window, drag up and to the left. The image adjusts to fill
the window.

To zoom out, drag up and to the right. The distance you drag determines
the amount of zoom. 1 means half as big, 2 means ¥ as big, and so on.
The image is reduced and centered in the window.

To zoom in, drag down and to the right. The distance you drag determines
the amount of zoom. 1 means twice as big, 2 means four times as big, and
so on. The image is enlarged and centered in the window.

To zoom in on a specific area, start at the upper-right corner of the area
that you want to see better and drag to the lower-left corner of the area.
The area that you drag across is adjusted to fill the window.

Zooming and Panning with Mini-Map The mini-map is a small display of a
schematic at the lower-left of the Netlist Analyzer window. The mini-map
shows the entire sheet with a purple rectangle marking the area that is
actually showing in the schematic view.

If the mini-map is not showing, click the Mini-map I button at the lower-right
corner of the schematic view.

To enlarge the mini-map, click on one of the control tabs on the edge of the
mini-map and drag.

To zoom, click on one of the control tabs of the purple rectangle and drag. As
the rectangle changes size, the schematic view zooms in or out.

To pan, click in the purple rectangle and drag it so that it covers the area that
you want to see. As you drag, the schematic view shifts.
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Or, you can click on the spot that you want to see. The schematic view will
jump to be centered on that spot.

Saving Schematics

You can save a schematic as either a PDF or SVG file. As a PDF file, the
whole schematic is a single file with each sheet an 8.5-inch by 11-inch page.
As an SVG file, only the currently displayed sheet is saved.

To save a schematic:

1. If saving as an SVG file, select the desired sheet.

2. Choose File > | Export.

The Export Schematic dialog box opens.

Browse to where you want to save the file.

Enter a file name.

Click the Save as type drop-down menu and choose the format.
Click Save.

o o M w

Printing Schematics
Use the print functions of Diamond to print the schematics.

To print a schematic:
1. Choose File > @ Print Preview.
The Print Preview window opens.

2. Expand the Print Preview window until you are comfortable with the
display of the page.

To maximize the printout, click 'A- for landscape mode.

4. Click the Page setup 1. button and adjust the paper size and margins if
necessary.

5. Click the Print r=h button.

6. Adjust the printer settings if necessary and click Print.

Navigating the Design with Netlist
Analyzer

There are several ways to explore a design. Most start with selecting one or
more objects. Then right-click in the schematic view and choose a command
from the drop-down menu.

These commands help you to:
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Focus on one part of the design
Flatten the layers of hierarchy
Trace the paths between objects

Expand selected parts of the schematic

Most commands can be reversed by clicking the Backward “# button. They
can be repeated by clicking the Forward ® button. To jump back to the
original view after several commands, right-click in the schematic view and
choose Restore Current Schematic.

While exploring a design, you may see a need to set a synthesis constraint. If
S0, you can get a quick start by dragging the port, net, or register to the
relevant tab of LDC Editor. See “Applying Lattice Synthesis Engine
Constraints” on page 353.

To select objects:
Click the Select k button and do one of the following:

Click on the object in the schematic view. Ctrl-click to select more
objects.

Click on the object in the netlist browser. Ctrl-click to select more
objects.

Click and drag to draw a selection rectangle around one or more
modules in the schematic view. This method only selects modules, not
ports or nets.

Right-click in the schematic view and choose Select All Schematic >
Instances. This command selects all module instances showing in all
sheets of the schematic.

Right-click in the schematic view and choose Select All Schematic >
Ports. This command selects all ports showing in all sheets of the
schematic.

Right-click in the schematic view and choose Select All Sheet >
Instances. This command selects all module instances showing in the
current sheet of the schematic.

Right-click in the schematic view and choose Select All Sheet >
Ports. This command selects all ports showing in the current sheet of
the schematic.

You can keep an object highlighted, but not actively selected, by right-clicking
in the schematic view and choosing Highlight. This outlines the selected
objects in the highlight color, making them easy to spot, while you continue to
explore the design. Highlighted objects are not “selected” for commands.
Highlighting can be erased if you use the Backward button enough to hide the
highlighted object.

To erase highlighting and return an object to normal display, select the object.
Then right-click and choose Unhighlight.
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Focusing on Part of the Design

Often you want to focus on just one part of the design. You can filter the
schematic, reducing it to selected modules, trim away objects that are in the
way, or ask for more details of a single module.

To filter the schematic:

1. In either the netlist browser or schematic view, select one or more
modules of interest.

2. Click the Filter Schematic 35 button.

The schematic is replaced with just the selected modules. Only nets
connecting the selected modules are included. Use other commands to
expand the schematic.

To filter with signal paths:
1. Select one or more modules of interest.
2. Right-click anywhere in the schematic view and choose Isolate Path.

The schematic is replaced with just the selected modules and modules
connected to the selected modules. Only nets connecting the modules are
included.

To trim the schematic:
1. Select one or more objects that you do not want to see.
2. Right-click anywhere in the schematic view and choose Less.

The selected objects disappear. If the objects include a branch of a net,
the remaining branches become dotted lines to show that part of the net is
hidden.

To see the structure inside a module:
1. Click the Push down/Pop up % button.
2. Drag the cursor to the module.

If there is further hierarchy to see (that is, the module is not already a
primitive), the cursor changes to a blue down-pointing arrow ¥ .

3. Click in the module with the down-pointing arrow.

The schematic changes to show just the structure of the module at the
next lower level of hierarchy. To go further down the hierarchy, click in one
of these modules with the down-pointing arrow.

After you've started pushing down, the cursor shows a green up-pointing
arrow “+ when it is not over a module. To go back up the hierarchy, click
when this up-pointing arrow is showing.

Remember that if you want to perform other commands in the schematic, you
first need to click the Select k button.
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To quickly push down or pop up:

There is an easy way to push down into a module while staying in select
mode:

Right-click the module and drag straight down until the words “push down”
appear. Then release the mouse button.

To go back up the hierarchy, right-click anywhere in the schematic view
and drag straight up until the words “pop up” appear. Then release the
mouse button.

To work on just one module:

1. Go to the Hierarchy view. If it is not showing, choose View > Show Views
> Hierarchy.

2. Right-click on the desired module and choose Goto RTL Definition.

Netlist Analyzer opens with the RTL view of the module. The rest of the
design is not available in this schematic.

Flattening the Design

Going back and forth through multiple layers of hierarchy can be confusing.
An alternative is to flatten the design, displaying all the layers together. This
makes for a much bigger, much more detailed schematic. But you do not have
to keep track of where you are in the hierarchy. You can flatten the entire
schematic or just selected modules.

To flatten the entire schematic:

Right-click anywhere in the schematic view and choose Flatten
Schematic.

The entire design is shown in terms of primitives.

To return to the original schematic, right-click and choose Unflatten
Schematic.

To flatten a module:
1. Select the module.
2. Right-click and choose Dissolve Instances.

The schematic expands to include the selected module’s primitives.
Boundaries, ports, and labels of the module and any submodules are
included. So you can still identify and select the modules and their ports.

Tracing Paths between Objects

In a complicated schematic it can be difficult to trace a signal but Netlist
Analyzer can do it for you.
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To trace a signal path:
1. Select two or more objects. They can be on different sheets.
2. Right-click and choose Expand > Expand Paths.

Nets and modules between the selected objects are highlighted. Modules
along the paths are expanded to show primitives.

Expanding from a Module

After focusing a schematic to one or a few modules, you may want to see
what the modules are connected to.

To see all the nets attached to a module:

1. Select the module.

2. Right-click and choose one of the following:
Show Connectivity

Highlights all nets attached to the selected module, expanding the
schematic as necessary.

Expand > Expand To/From

Highlights all nets attached to the selected module and all primitives
attached to those nets, expanding the schematic as necessary.

To see the next higher level of the hierarchy:
1. Select a module, right-click and choose Show Context.

2. If nothing happens, click the Push down/Pop up " button. Move the
cursor to the schematic view. If you see the green up-pointing arrow i,
click it.

Depending on the situation, one the above shows the schematic of the next
higher level of the hierarchy.

Expanding from a Port

Instead of expanding all the nets from a module, you can expand the net from
a single port. If the module is not a primitive, you have the choice of
expanding outward or inward to a lower level of the module’s hierarchy. Make
this choice by selecting the port pointing out or the port pointing in.

To see what a single port is attached to:
1. Double-click the port.

The schematic expands to show the port’'s net and one more object that is
on the net.

2. If the net shows as a dashed line, you are seeing only part of the net.
Double-click the port again to see another branch of the net.
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If the net shows as solid line, you are seeing the full net.

If the full net is already visible, nothing happens.

To see a fuller signal path from a single port:

1.

Select the port. If the port is on a module, take care whether it is pointing
out or in.

Right-click and choose Expand.

A sub-menu drops down.

Choose one of the following from the sub-menu:
Expand to FF/IO

Highlights the net until it finds a flip-flop or an 1/O pin, expanding the
schematic as necessary. Modules along the path are expanded to
show primitives.

Current Level > Expand to FF/1O
Same as above except that modules are not expanded.
Expand to Primitive

Highlights the net and all attached primitives, expanding the schematic
as necessary.

Current Level > Expand to Primitive

Same as above except that modules are not expanded.

Expanding from a Net

You can expand a net to show all connected primitives and ports or to show
just the primitive or port driving it.

To see all modules on a net:

1.
2.

Select the net.
Right-click and choose Go to Connected Instances.

Highlights the selected net and all connected primitives and ports,
expanding the schematic as necessary.

To see just the driver of a net:

1.
2.

Select the net.
Right-click and choose Go to Driver.

Highlights the selected net and the driving primitive or port, expanding the
schematic as necessary.
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Searching in Netlist Analyzer

With large designs, finding objects may be easier with a text search. The Find
function in Netlist Analyzer allows you to search for objects in the schematic

using instance, symbol, port, and net names. Found objects can be selected

in the netlist browser and schematic view.

To search the design in Netlist Analyzer:

1.

Choose Edit > 42 Find.
The Find dialog box opens.

Select the type of object that you want to find by clicking one of the tabs at
the top of the dialog box.

Select the part of the design that want to search by selecting a level in the
Search box.

At the bottom-left of the dialog box is the Un-Highlight Search box. Click in
this box and type in your search term. You can use the following
wildcards:

* for any number of characters
? for a single character

Or, click the arrow at the end of the box and choose from previously used
search terms.

Click either Find 200 or Find All.
The found objects are listed in the UnHighlight box.

If you clicked Find 200 and want to see more, click either Next 200 or
Find All until satisfied.

To highlight found objects in the schematic view, do one of the following:

For just some of the objects, select the desired objects in the
UnHighlight box and then click the -> (right arrow) button.

For all of the found objects, click the All - > button.

The selected objects move to the Highlight box and are highlighted in the
netlist browser and schematic view. But the schematic view does not
expand to show objects in other layers or on other pages.

To reduce the number of objects in the Highlight box, select unwanted
objects and then click the <- (left arrow) button. You can find objects in
the Highlight list using the Highlight Search box. Anything entered in the
Highlight Search box is automatically searched for and selected.

When you have the Highlight list the way you want, click Close.

Highlighted objects in the schematic view stay highlighted after the Find
dialog box closes.
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Getting More Information about an Object

You can get more information about an object in the schematic view such as
names, number of fanouts, and the pins that nets connect to. You can also get
the source code for the object.

To get more information about an object:
1. Select one or more objects.

2. Inthe schematic view, right-click the object of interest and choose
Properties.

The Properties dialog box opens showing a list of various properties of the
object.

If the object is a module, the dialog box also has a drop-down menu listing
all the ports of the module. Choosing a port shows the properties for that
port.

If the object is a bus, the dialog box has a drop-down menu listing all the
nets that make up the bus. Choosing a net shows the properties for that
net.

3. When finished, click Close.

To get just the hierarchy name of an object:
1. Select one or more objects.
2. Inthe schematic view, right-click and choose ﬁj Copy.
3. Paste into any text editor.
The format of the name will be similar to this example:

{i:UART INST/u txmitt/add 24}
The first letter is i for instance, n for net, or p for port.

To get the source code for an object:
1. Select one or more objects.

2. Inthe schematic view, right-click the object of interest and choose Jump
to > Jump to HDL File.

Source Editor opens with the code highlighted.

Running Processes

A process is a specific task in the overall processing of a source or project.
Typical processing tasks include synthesizing, mapping, placing, and routing.
You can view the available processes for a design in the Process view. Some
of the processes are device-dependent, such as JEDEC File and Bitstream
File.
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Running Processes

Process View

t

=} ‘:." IMap Design

[z & Place & Route Design

= ': Export Files

ﬁ Synplify Pro

+

+ Translate Design

|:| : Map Trace
O :.' Yerilog Simulation File
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i

[0 2 Place & Route Trace
[ & 1o Timing Analysis

[ & IBIS Madsl

O : ‘ierilog Simulation File
[ & ¥HDL Simulation File
O :." Bitstream File

[] & PROMFile

Processes are grouped into categories according to their functions.

Synthesize Design

By default, this process runs the Synplify Pro Synthesis tool in batch
mode to synthesize the associated HDL design. For details, see
“Synthesizing the Design” on page 562.

If you are using Lattice Synthesis Engine (LSE) as the synthesis tool
(Project > Synthesis Tool, see “Selecting a Synthesis Tool” on page 80
for details), This process will be changed to Lattice Synthesis Engine.
Click on this process and Lattice Synthesis Engine (LSE) runs in batch
mode to synthesize the design.

Translate Design

This process allows you to convert the EDIF file from the synthesis
program to a Lattice internal database. If the design utilizes Lattice
modules (such as Dual-Port RAM, Multiplier, ROM, Shift-Registers, and
Adder/Subtractor), the modules will be expanded in this process. For
details, see “Translating the Design Database” on page 572.

Note for LSE

If you have chosen LSE as the synthesis tool, the Translate Design process
cannot be seen in the Process view. The translate design process is included in
the Synthesize Design process.

Map Design

This process maps a design to an FPGA. Map Design is the process of
converting a design represented as a network of device-independent
components (such as gates and flip-flops) into a network of device-
specific components (for example, configurable logic blocks). For details,
see the Implementing the Design > Mapping section in the online Help.

Map Trace

Trace can be used to run timing analysis in the post-mapping stage in
the FPGA design flow. You can run this process after having mapped
a design. Trace will create a timing report file (.twr) that will help a
designer to determine where timing constraints will not be met. In
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post-map timing analysis, Trace will determine component delay
values and substitute zero values for missing routing delays. If path
delay constraints that are unmet at this stage will be included in the
report and may have to be relaxed.

Verilog Simulation File

This process backannotates the mapped design without timing
information so that you may run a simulation of your design. The
backannotated design is a Verilog netlist.

VHDL Simulation File

This process backannotates the mapped design without timing
information so that you may run a simulation of your design. The
backannotated design is a VHDL netlist.

Place & Route Design

After a design has undergone the necessary translation to bring it into the
Native Circuit Description (.ncd) format, you can run the Place & Route
Design process. This process takes a mapped physical design .ncd file,
and places and routes the design, and outputs a file that can then be
processed by the design implementation tools. For details, see “Place and
Route” on page 588.

Place & Route Trace

Trace can be used to run timing analysis in the post-routing stage in
the FPGA design flow. You can run this process after having routed a
design. Trace will create a timing report (.twr) that will allow a designer
to verify timing. In post-route timing analysis, Trace analyzes your path
delays and will report where these occur in the design.

I/O Timing Analysis

This process runs I/O timing analysis and generates an /O Timing
Report. For each input data port in the design, this process generates
the setup and hold time requirements and min/max clock-to-out delay
for every output port. The computation is performed over all
performance grades available for the device and at the voltage and
temperature specified in the preference file. I/O timing analysis also
automatically determines the clocks and their associated data ports.

Export Files
You can check the desired file you want to export and run this process.
IBIS Model

This process generates a design-specific IBIS model file
(<project_name>.ibs).

IBIS stands for I/0O Buffer Information Specification. IBIS models
provide a standardized way of representing the electrical
characteristics of a digital IC’s pins (input, output, and 1/O buffers). For
details, refer to “Lattice Semiconductor IBIS Models” on page 788.

Verilog Simulation File
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This process backannotates the routed design with timing information
so that you may run a simulation of your design. The backannotated
design is a Verilog netlist.

VHDL Simulation File

This process backannotates the routed design with timing information
so that you may run a simulation of your design. The backannotated
design is a VHDL netlist.

JEDEC File

This process produces a JEDEC file for programming the device. The
JEDEC Standard is the industry standard for PLD formats. In the
Diamond software, JEDEC refers to the fuse map of your design for
the selected device. For details, refer to “Bit Generation” on page 629.

Bitstream File

This process takes a fully routed physical design or Native Circuit
Description (.ncd) file as input and produces a configuration bitstream
(bit images). The bitstream file contains all of the configuration
information from the physical design defining the internal logic and
interconnections of the FPGA, as well as device-specific information
from other files associated with the target device. For details, refer to
“Bit Generation” on page 629.

PROM File

This process takes a bitstream (.bit) file as input and generates output
files in one of several PROM file formats. The output files are used to
program PROMSs. For details, refer to “PROM Generation” on
page 637.
See Also »“Managing Project Sources” on page 33

“Process State” on page 73

“Starting a Process” on page 73

“Forcing a Process to Run” on page 74

“Stopping a Process” on page 74

“Refreshing Process State” on page 75

“Cleaning Up Processes” on page 75
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Process State

The Process view always shows the state of the processes in the active
implementation. Each state is identified with different icons as shown in the

table below.

Process State Icon Description

Initial :: The process has never been run or an input
dependency time stamp has changed since it was last
run.

Completed -y The process has been run successfully.

Warning ';“ The process or report has been run successfully, but
warning messages were issued.

Error i The process did not complete successfully.

Conditions that Re-initialize Process State A process or report is re-
initialized under the following conditions:

A process state earlier in the sequence has changed.

An input file of the process or report has changed since the last run. For
example, changing the .Ipf file will cause the map process to be rerun.

Note

Input file changes are only detected if touched by the Lattice Diamond Source
Editor or a process or report triggered by the Lattice Diamond main window.
Changes applied by third-party text editors will NOT be detected.

Process settings have changed.

Target device has changed. All processes listed in the Process view in the
sequence later than Translate Design will be re-initialized.

The Process > Rerun All function is run.

See Also »“Running Processes” on page 69
“Starting a Process” on page 73
“Forcing a Process to Run” on page 74
“Stopping a Process” on page 74
“Refreshing Process State” on page 75

“Cleaning Up Processes” on page 75

Starting a Process

You can start a process on a single source file or on the entire project.
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To start a process, do one of the following:
Select the process in the Process view. Choose Process > Run.
Right-click the process and choose Run.

Double-click the process.

See Also »“Running Processes” on page 69
“Process State” on page 73
“Forcing a Process to Run” on page 74
“Stopping a Process” on page 74
“Refreshing Process State” on page 75

“Cleaning Up Processes” on page 75

Forcing a Process to Run

If the process is up-to-date (indicated by a check mark to the left of the
process), it will not run again. However, you can force a process to run by
doing the following:

Choose Process > Rerun to start the selected process and run all the
intermediate steps, even if the process is up-to-date. Using Rerun will
force the selected tool to do a clean run overwriting any previous results.

Right-click the highlighted process and choose Rerun.
You can use Process > Rerun All to force all the processes before the
one you selected to rerun. Using Rerun All will also force all tools to do a
clean run overwriting any previous results.
See Also  »“Running Processes” on page 69

“Process State” on page 73

“Starting a Process” on page 73

“Stopping a Process” on page 74

“Refreshing Process State” on page 75

“Cleaning Up Processes” on page 75

Stopping a Process

If you want to stop running certain process, choose Process > |E| Stop.

See Also »“Running Processes” on page 69
“Process State” on page 73
“Starting a Process” on page 73

“Forcing a Process to Run” on page 74
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“Refreshing Process State” on page 75

“Cleaning Up Processes” on page 75

Refreshing Process State

You can choose Design > Refresh Design to refresh the process state. For
example, after running a certain process, you have made changes to a source
file using a source editor outside Lattice Diamond. Then you can use Refresh
Process to check the most recent state of the processes. This will also update
the Hierarchy view and Reveal Inserter with any design changes.
See Also  »“Running Processes” on page 69

“Process State” on page 73

“Starting a Process” on page 73

“Forcing a Process to Run” on page 74

“Stopping a Process” on page 74

“Cleaning Up Processes” on page 75

Cleaning Up Processes

You can use the Process > Clean Up Process command to reset all the
processes as shown in the Process view. This command returns the status of
all of the processes back to their initial = state.

Setting Security Options

Some FPGA device families contain a hard-wired Advanced Encryption
Standard (AES) engine that enables you to download an encrypted bitstream
into the device. The ECP5, LatticeECP2S, LatticeECP2MS, LatticeECP3, and
LatticeXP2 devices are equipped with this AES technology for downloading
encrypted bitstream.

The Lattice Diamond software provides the Security Setting Tool that enables
you to set up both the configuration security and an encryption key for those
devices.

IMPORTANT!

To turn on this security feature, you need to install the Encryption Control Pack.

Unencrypted JEDEC (.jed) and Bitstreams (.bit) can also be encrypted using
Deployment Tool. Refer to:

“Encrypting a JEDEC with Deployment Tool” on page 942
“Encrypting a Bitstream with Deployment Tool” on page 943
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See Also »“Security Setting Dialog Boxes and Security Files” on page 76

“Setting Security and Encryption for FPGA Devices with Security Setting
Tool” on page 77

TN1212 - LatticeXP2 Advanced Security Programming Usage Guide

TN1215 - Advanced Security Encryption Key Programming Guide for
ECP5, LatticeECP3, and LatticeECP2/MS Devices

Security Setting Dialog Boxes and
Security Files

The security setting tool consists of several successive dialog boxes, with
which you can specify security settings for your target device and set a
password to encrypt your security settings.

The Security Settings dialog box enables you to specify a flash protect key for
LatticeXP2, and an encryption key for all other devices.

Once you have specified all the security settings, an encrypted .bek file will be
generated in the project folder to hold the security settings. The .bek file
contains readable header information that identifies the project, software
version, device used, and creation date. The header is not encrypted so that
you can identify the encrypted file.

If you have specified the flash protect key for LatticeXP2, a .key file will also
be created in the project folder. The .key file holds the flash protection key.

The Enter Password dialog box and Change Password dialog box allow you
to set a password to further encrypt your security settings. This password will
be used by Lattice Diamond to encrypt the .bek file and Programmer to
decrypt the .bek file.

IMPORTANT!

You must track and remember all the keys and passwords you have specified. They
will not be stored in any of the design files.

See Also »“Setting Security Options” on page 75

“Setting Security and Encryption for FPGA Devices with Security Setting
Tool” on page 77

“Encrypting a JEDEC with Deployment Tool” on page 942
“Encrypting a Bitstream with Deployment Tool” on page 943
TN1212 - LatticeXP2 Advanced Security Programming Usage Guide

TN1215 - Advanced Security Encryption Key Programming Guide for
ECP5, LatticeECP3, and LatticeECP2/MS Devices
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Setting Security and Encryption for
FPGA Devices with Security Setting
Tool

To run the Security Setting tool and set security settings:

1.

In Lattice Diamond, choose Tools > Security Setting.

The Enter Password dialog box opens. Because the project does not yet
contain a .bek file, the dialog box shows LATTICESEMI as the default
password.

To change the password, click Change to open the Change Password
dialog box.

In the Enter Password field, type in a password of at least eight but no
more than sixteen characters.

Type the password again in the Verify Password field and click OK.
The Security Settings dialog box opens.

To set up keys, check the Advanced Security Settings option in the
Security Settings dialog box.

For LatticeXP2 devices, you have the option to set Flash Protect Key only
or both Encryption Key and Flash Protect Key.

For all other devices, you can only set the Encryption Key.

Select a key format from the Key Format drop-down list, and then type a
key in the text boxes as follows, depending on the format selected:

For the default ASCII format, type alphanumeric values using up to 16
characters.

For hex format, type values of 0 through F, using up to 32 characters.
For binary format, type 0 and 1 values, using up to 128 characters.
Click OK to apply the settings.

A Security Setting message informs you that the encrypted files have
been produced.

Click OK to close the Security Setting dialog box.

Note

The .bek and .key files are stored in the root project directory, instead of the
implementation directory. In case you have more than one implementation, the .bek
and .key files are generated for the active implementation.

See Also »“Setting Security Options” on page 75

“Security Setting Dialog Boxes and Security Files” on page 76
“Encrypting a JEDEC with Deployment Tool” on page 942
“Encrypting a Bitstream with Deployment Tool” on page 943
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TN1212 - LatticeXP2 Advanced Security Programming Usage Guide

TN1215 - Advanced Security Encryption Key Programming Guide for
ECP5, LatticeECP3, and LatticeECP2/MS Devices

Setting Options for Synthesis and Simulation

Diamond is integrated with the Lattice Synthesis Engine (LSE), Synplify Pro
synthesis tool, and the Active-HDL simulation tool. Besides the OEM tools,
you can also let Diamond use LSE, your full-featured versions of Synplify Pro
or Precision as the synthesis tool, and full-featured versions of ModelSim or
Active-HDL as the simulation tool.

This section covers steps on selecting synthesis and simulation tools, defining
file order for synthesis and simulation, customizing synthesis tool processes,
specifying VHDL library name, and specifying the search path for Verilog
include files. Also, how to perform interactive synthesis is discussed in this
section.

About Lattice Synthesis Engine

For most devices, you have the option of using Lattice Synthesis Engine
(LSE) as your synthesis tool instead of Synplify Pro for Lattice or another
third-party synthesis tool.

LSE is a synthesis tool custom-built for Lattice products and fully integrated
with Diamond. Depending on the design, LSE may lead to a more compact or
faster placement of the design than another synthesis tool would do. LSE can
be run from the Diamond main window or through the command line, similar
to the other integrated synthesis tools.
Also, LSE offers the following advantages:

Enhanced RAM and ROM inference and mapping, including:

multiple reads

dual-port RAM in write-through, normal, and read-before-write modes
mapped to EBR

clock enable and read enable packing

mapping for the minimal number of EBR blocks

EBR mapping for minimal power

better support for wide-mode mapping
Comprehensive GSR inference for area and timing

Simpler flow to get an .ngd file: no ngdbuild command or Translate Design
process required

Post-synthesis Verilog netlist suitable for simulation

When considering LSE, note the following limitations:

Lattice Diamond 3.6 Help 78


http://www.latticesemi.com/dynamic/view_document.cfm?document_id=39450
http://www.latticesemi.com/dynamic/view_document.cfm?document_id=39746

MANAGING PROJECTS : Setting Options for Synthesis and Simulation

Not available with LatticeEC, LatticeECP, LatticeSC/M, or LatticeXP.

IP must be generated with a synthesis tool other than LSE. So the
synthesis of IP won't be affected by a change to LSE.

Design code may need to be modified. Modifications may involve some
VHDL requirements and inferring RAM, ROM, and 1/O.

SystemVerilog features are not supported.

Does not include interclock domain paths in timing analysis.

See Also
“Selecting a Synthesis Tool” on page 80

Lattice Synthesis Engine Tutorial

Switching to Lattice Synthesis Engine

When changing to Lattice Synthesis Engine (LSE) from another synthesis
tool, there are a few things to do:

Consider creating a new design implementation. You can experiment with
different settings without losing your previous work. See “Working with
Implementations” on page 45.

Modify the Synopsys Design Constraint (.sdc) file into an .Idc or create a
new .ldc file. See “Lattice Synthesis Engine (LSE) Constraints” on

page 1272 and “Applying Lattice Synthesis Engine Constraints” on

page 353.

Adjust the LSE strategy settings. See “LSE Options” on page 1070 and
“Optimizing LSE for Area and Speed” on page 565.

Review the LSE coding tips and consider applying them to your design.
See “Coding Tips for Lattice Synthesis Engine (LSE)” on page 162.

Review the instructions for integrated synthesis. There are some
differences with LSE. See “Integrated Synthesis” on page 567.

Bus Naming in LSE Output

In the output files from Lattice Synthesis Engine (LSE), bus names are
converted to individual signal names (sometimes known as “bit blasting”).
LSE adds “_c¢_" to the individual signal names. For example, the bus name
sum[0:3] becomes:

See Also

“Consistent Bus Name Conversion” on page 1078

Lattice Diamond 3.6 Help

79


http://www.latticesemi.com/view_document?document_id=50432

MANAGING PROJECTS : Setting Options for Synthesis and Simulation

Selecting a Synthesis Tool

Diamond supports Verilog HDL and VHDL designs using Lattice Synthesis
Engine (LSE), Synplify Pro, or Precision RTL as the synthesis tool.

Diamond is fully integrated with LSE and Synplify Pro. “Fully integrated”
means that you can set options and run synthesis entirely from within
Diamond.

Diamond also supports Mentor Graphics Precision RTL Synthesis but
does not include the tool itself. If you want to use Precision RTL
Synthesis, you need to get the software on your own.

If you prefer, you can use other synthesis tools by running them
independently of Diamond.

You can specify one of them as the synthesis tool for the currently active
implementation of your project. Different implementations can have different
synthesis tools specified.

To select a synthesis tool:

1.
2.

Make sure you have successfully installed LSE, Synplify Pro, or Precision.

From the Diamond main window, choose Project > Active
Implementation > Select Synthesis Tool.

The Project Properties dialog box appears with the active implementation
selected.

In the Project Properties dialog box, double-click the synthesis tool in the
Value column.

From the drop-down menu, select a tool.
Click OK.

If you have chosen Synplify Pro, you can either use Synplify Pro for Lattice
or your own full-featured Synplify Pro. By default, Diamond will use the Lattice
version. If you want to use Synplify Pro for Lattice, you can use the main
window to start running processes. If you want to use your own full-featured
Synplify Pro, you need to specify the directory in the Options dialog:

1.

4,

Choose Tools > Options.

The Options dialog box opens.

In the Environment > Directories tab, clear the use OEM option.
Specify the installation path for Synplify Pro in the Synplify Pro field.

Click OK to save your settings.

If you have chosen Precision as the synthesis tool, you need to specify the
directory in the Options dialog:

1.
2.

Choose Tools > Options. The Options dialog box opens.

In the Environment > Directories tab, specify the installation path for
Precision in the Precision field.

Click OK to save your settings.
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See Also “Customizing Synthesis” on page 84

Specifying VHDL Library Name
The Lattice Diamond software supports VHDL design synthesis using LSE,
Synplify Pro, or Precision Synthesis. You can specify the library name for

synthesizing individual VHDL sources and modules. By default, all project-
related design sources are compiled into the “work” library.

The VHDL library name can also be specified in the Synplify Pro or Precision
Synthesis tool. See Synplify Pro or Precision Synthesis Help for details.

To specify the VHDL library target in the main window:

1. Inthe File List view, right-click the VHDL source for which you want to
specify a library name and choose Properties.

2. Inthe Project Properties dialog box, type in the library name you want in
the Value field and click OK.

The LSE, Synplify Pro, or Precision Synthesis tool will then use the
specified library name to synthesize the selected VHDL source file or
module.

Specifying Search Path for Verilog
Include Files

The Lattice Diamond software supports Verilog design synthesis using LSE,
Synplify Pro, or Precision Synthesis. If a Verilog file is added to your design
and additional files are referenced via the include directive, you can specify
the search path in Lattice Diamond for searching include files.

Note

If the include file in your Verilog file changed after you opened the relevant project in
Diamond, you need to use the Rerun All or Rerun command to force the process to
rerun so that Diamond can reflect the changes of the include file.

You can also specify a Verilog include file search path directly in LSE, Synplify
Pro, or Precision. See “Running SYNTHESIS from the Command Line” on
page 2299, and the Synplify Pro or Precision Synthesis Help for details.

Synplify Pro and LSE Search Path If you select Synplify Pro or LSE as
the synthesis tool, you can only specify the search path for the entire project.
Synplify Pro or LSE searches for the include file in the following order, and
stops at the first occurrence of the include file it finds.

1. The directory of the file that specifies the ‘include’ directive

2. The directories that are specified in the “Search Path” option for the entire
project
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Precision Synthesis Search Path If you use Precision, you can specify the
search path for the project and for each Verilog source file. Precision
searches for the include file in the following order, and stops at the first
occurrence of the include file it finds.

1. The directory of the file that specifies the ‘include’ directive

2. The directories that are specified in the “Search Path” option for the
Verilog source

3. The directories that are specified in the “Search Path” option for the entire
project

Specifying Search Path in Lattice Diamond

To specify the search path in Lattice Diamond:
1. Inthe File List view, do either of the following:

Right-click the implementation hame if you want to specify the search
path for the entire project.

(For Precision Synthesis only) Right-click the Verilog source for which
you want to specify the search path.

2. Choose Properties from the right-click menu.
The Project Properties dialog box opens.

3. Inthe dialog box, select Verilog Include Search Path, and do either of
the following:

If you want to add only one search path, click the Value field to enter a
path.

If you want to add multiple paths, click the ... button from the Value
field to get the Verilog Include Search Path dialog box. In this dialog

box, click the icon to browse for a new path and click OK. The
new path is displayed in the Verilog Include Search Path dialog box.

Repeat to add more paths. You can use the and @] button to

arrange the order of the paths, or use the button to delete a path.
Click OK when you finish.

4. Click OK to exit the Project Properties dialog box.

The search paths you added are applied. The Synplify Pro or Precision
Synthesis tool will use the specified search paths to search for the include
files referenced in your design other than the directory of the file that
specifies the include directive.

Specifying Verilog and VHDL
Parameters

You can add Verilog compiler directives and parameters or VHDL generics for
the whole design in the properties of each design implementation. You may
find this method an easier way to experiment with these settings.
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To add Verilog compiler directives and parameters or VHDL generics:

1. In the File List view, right-click the implementation’s name and choose
Properties.

The Project Properties dialog box opens showing the implementation’s
properties.

2. Inthe HDL Parameters row, click under Value.

3. Type the statements as a single text line with different statements
separated by semi-colons (;).

4. When done, click OK.

Selecting a Simulation Tool

Diamond supports functional and timing simulation for Lattice FPGA devices
using ModelSim or Active-HDL. You can specify either ModelSim or Active-
HDL as the simulation tool for your project in the Simulation Wizard (Tools >
Z* Simulation Wizard from main window). For more details on how to use
Simulation Wizard, see “Simulating the Design” on page 297.

Specifying Input Files for Simulation

Your design probably includes one or more test bench files that you want to
use during simulation but do not want synthesized. You can specify this in the
properties for each input file. New files are automatically marked for both
synthesis and simulation.

To change the synthesis/simulation property of afile:
1. Inthe File List view, right-click the filename.
2. Inthe drop-down menu, choose Include for and then the desired
property:
Synthesis and Simulation
Synthesis
Simulation
You can also set the synthesis/simulation property in the Project Properties

dialog box. You can open the dialog box by choosing Project > Property
Pages.

Defining File Order for Synthesis and
Simulation

The File List view lists design input files in a specific order. The synthesis or
simulation tool uses that order to sequentially synthesize or simulate each
input file. You can adjust the file order by the “drag and drop” operations. The
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file list can include a combination of VHDL, Verilog, and schematic files. If you
have not manually set a top-level module (in the Project Properties dialog box
of the main window), usually the last file on the file list is treated as the top-
level module.

File order is especially important for VHDL files. Package files must be first on
the list because they are compiled before they are used. If design blocks are
spread over many files, you should specify the following file order: the file
containing the entity must be first, followed by the architecture file, and finally
the file with the configuration. Verilog file order is typically important when
‘define statements are dedicated to a single file. This file should be compiled
prior to any files that refer to the variables.

To define the file order for logic synthesis and simulation:

In the Input Files section of the File List view, change the file order as you
like by dragging the file name and dropping it to the required location.

The new file order takes effect immediately. The order will be saved when
you save the design project.

Customizing Synthesis
Lattice Diamond supports Verilog and VHDL synthesizing using Lattice

Synthesis Engine (LSE), Synplify Pro, and Precision.

You can adjust synthesis tool options and perform the logic synthesis process
for your Verilog or VHDL design within Lattice Diamond.

To adjust synthesis tool options and perform the synthesis process:
1. Choose Project > Active Strategy > <synthesis tool> Settings.

2. Inthe Strategies dialog box, by default, the option settings of the selected
process, LSE, Synplify Pro, or Precision, are listed. You can use the
Display catalog to filter the options you need to customize.

3. Double-click the Value field of the option. You can specify the option using
the drop-down menu of the Value field.

4. Click OK to accept the new synthesis tool options and exit the Strategies
dialog box.

5. Inthe Process view, double-click the Synthesize Design process to
execute the selected synthesis tool.

If you prefer leveraging all the interactive features available in the synthesis
tool while maintaining HDL source in the main window, see “Synthesizing the
Design” on page 562 for more details.
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Working with Run Manager

Large designs can quickly get complicated, and the best approach is not
always obvious or definite. There may be many ways to get optimal
performance out of your design—the key is to find one option that works.

In Diamond, each project can contain multiple source files, strategies, and
implementations. Implementations are comprised of selected source files and
only one strategy. You can create multiple implementations to bind different
strategies.

After creating implementations, use Run Manager to run multiple synthesis
and place and route passes, compare the results of multiple implementations
for further analysis to get best solutions. Run Manager helps you to manage
running the design implementation process with multiple project
implementations (versions) and to compare the results. You can monitor
progress, view reports, and quickly identify the best implementation.

See Also “Using Strategies” on page 47

“Working with Implementations” on page 45

Setting Up Run Manager

Before using Run Manager, consider if you want to do multiple place-and-
route runs on individual implementations to get different timing and area
results.

If you have a lot of implementations and don’t want to run them all, you may
want to hide some of them in Run Manager.

Also, consider your system’s ability to run multiple processes. If you have
several implementations running simultaneously in Run Manager, you may
see performance problems because of RAM resource conflicts.

Setting Up Multiple Runs on an Implementation You can get multiple
place-and-route runs, using different seed values, on a single implementation.
The different values can produce significantly different timing and area
results.

To set up multiple place-and-route runs on an implementation:

1. Inthe File List view, right-click on the strategy of the implementation and
choose Edit. Strategies are listed in the Strategies folder. If you are not
sure which strategy is being used, you can check the Implementation
column in Run Manager. It includes the strategy name for each
implementation.

The Strategies dialog box opens.

2. Inthe Process box, on the left, choose Place & Route Design.
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3. Find Placement Iterations and double-click the Value box. Enter the
number of place-and-route runs you want to make. (For more on this
option, see “Placement Iterations” on page 1089.)

4. Find Placement Save Best Run and double-click the Value box. Enter the
number of place-and-route runs you want to see. Run Manager will show
you this many of the best results. (For more on this option, see
“Placement Save Best Run” on page 1089.)

5. Click OK.

Hiding Implementations Run Manager normally shows all the
implementations of the project. But you can choose to hide any of the
implementations from Run Manager except for the active implementation.

To change which implementations are showing:
1. Choose Tools > £ Run Manager.

Run Manager opens with a table listing the implementations available.
The row in bold font indicates the active implementation.

2. If you want to hide the active implementation, right-click an
implementation that you will continue to show and choose Set As Active.

This implementation becomes the active one for the project. The row
changes to bold type and, in File List view, the implementation is
expanded. The previously active implementation becomes inactive and
can be hidden.

3. In Run Manager’s tool bar, click the Show/Hide Implementation [«
button.

The Show/Hide Implementation dialog box opens.

4. In one of the columns, select one or more implementations that you want
to move to the other column.

5. Click the arrow button pointing to the other column.

6. When you have the Hidden and Show lists as you want them, click OK.

Improving System Performance You can improve your system’s
performance while running Run Manager by limiting the number of processes
sharing the memory. Allowing fewer processes means your computer spends
less time swapping data in and out of the hard drive. But fewer processes
than the number of available processors could mean processors sitting idle.
You will need to find a balance based on your computer and the way you tend
to use Run Manager.

To improve performance:
1. Choose Tools > Options.
2. Inthe Options dialog box, choose Environment > General.

3. Find the Maximum number of implementation processes in run
manager option and change the number. The best value is the number of
processors in your computer or fewer.
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Find the Maximum number of multi-par processes in run manager
option and change the number. The best value is the number of
processors in your computer or fewer.

Click OK.

Running Run Manager

After setting up Run Manager (see “Setting Up Run Manager” on page 85),
you are ready to run your implementations.

To process multiple implementations using Run Manager:

1.

Choose Tools > §52 Run Manager.

Run Manager opens with a table listing the implementations available.
The row in bold font indicates the active implementation.

Select the implementations that you want to run by setting the check
boxes. Select them all by clicking the check box in the heading row.

In Run Manager’s tool bar, click the Run button. You can force
implementations that have already been run (the Status column says
Completed) by clicking the Rerun button.

While running, you can pause or stop the runs. Select a running item by

clicking anywhere in its row. Then click either the Pause |[Il| or Stop
button. Run Manager may take a few moments to respond.

To continue a paused run, select it and click the Run button.

Note

The Process menu commands also control Run Manager, but they only affect the
active implementation. This is true whether you choose the command from the
Process menu in the menu bar or the right-click menu in the Process view.

When the runs are complete, compare the statistics that appear. These
statistics provide a quick comparison of the quality of results. See
“Reading the Run Manager Results” on page 88.

If you set up an implementation to do multiple place-and-route runs, click
the plus = sign to show the individual results. The top scoring result for
each implementation is shown in italics and will be used in any further
processing with that implementation.

If you want to save the results, go to Run Manager’s tool bar and click the
Export [3= button. In the Export Run Manager File dialog box, browse to
where you want to save the results and enter a file name. Then click
Save.

All the data showing in Run Manager are saved in a comma-separated
values (.csv) file that can be opened with a spreadsheet tool such as
Excel.

For more details, go to the Reports view. The Reports view shows a tab
with a set of reports for each implementation. To jump to a specific report,
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in Run Manager, right-click the row for the implementation and choose
Show Report > <report>. See “Viewing Logs and Reports” on page 92.

Also, examine the Output view, including checking for any warning or error
messages.

7. After studying the results, you can select one of the implementations and
one of its runs for further development. See “Selecting an Implementation
and Run” on page 90.

Reading the Run Manager Results

Run Manager displays results with a table. Every implementation in the
project gets a row. If an implementation did multiple place-and-route runs,
each run has a row under its implementation. If you don’t see the separate
place-and-route runs, expand the hierarchy tree under the implementation
row.

Bold text shows the active implementation. Italic text shows the active run out
of multiple place-and-route runs. This is the run that will be used in further
processing of that implementation.

There are several columns showing the results for the implementations and
the place-and-route runs. The columns are described below. Compare the
results across rows to see which run worked best.

For the active implementation, you can see the status of the different
processes by looking at the Process view. To see the status of another
implementation, right-click the implementation in Run Manager and choose
Set As Active.

For more details, check the Reports view. The Reports view shows a tab with
a set of reports for each implementation run. See “Viewing Logs and Reports” on
page 92.

Changing the Display You can adjust the display by re-arranging the
columns and sorting the runs. By default, many of the columns are hidden but
you can choose which ones you want to see.

To change which columns are displayed:

Right-click in any column heading and choose the column that you want to
hide or show. Columns that are showing have a check mark. The
Implementation<Strategy> column cannot be hidden.

To re-arrange columns:

Click on the heading of the column that you want to move and drag it to
where you want it.

To change the width of columns:

Do one of the following:
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Right-click in any column heading and choose Adjust Column Width to
Contents.

All columns are adjusted based on their contents.

Click on the right-hand border of a column and drag to make that
column narrower or wider.

To sort the runs:
1. Click in the heading of the desired column.
The rows are sorted according to the contents of that column.

2. To reverse the order of the rows, click in the same column again.

Column Descriptions There are many columns of data available. Most of
these apply only to the implementation rows, not the individual place-and-
route runs.

Implementation<Strategy>: The name of the implementation followed by
the strategy (in angle brackets) that implementation is using. Use the
check boxes to select which implementations to run. This column cannot
be hidden.

Current Step: The implementation process, such as Synthesis and Map,
that is currently running.

Status: The status of the implementation, such as Running, Pause, and
Completed.

Next Step: The next implementation process that will run after the current
process finishes.

Worst Slack: The worst timing slack for all timing constraints. Negative
values indicate timing violations.

Timing Score: The time, in picoseconds, by which the design is failing to
meet the timing constraints. Zero means the run fully met the timing
constraints.

If an implementation has multiple place-and-route runs, the
implementation row shows the value of the active place-and-route run.

Worst Slack (Hold): The worst timing slack for all timing constraints based
on hold time. Negative values indicate timing violations.

Timing Score (Hold): The time, in picoseconds, by which the design is
failing to meet the timing constraints based on hold time. Zero means the
run fully met the timing constraints.

Slice: The number of slices used versus the total number available.

Unrouted Nets: The number of unrouted nets. Anything larger than zero
means that place-and-route did not finish.

If an implementation has multiple place-and-route runs, the
implementation row shows the value of the active place-and-route run.

Run Time: The total run time for the synthesis, map, and place-and-route
processes, including multiple place-and-route runs. Times for translate,
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trace, and exporting files are not included. The format is
<hours>:<minutes>:<seconds>.

Level/Cost: The first number is the Placement Effort Level specified in the
Place & Route Design section of the strategy, not necessarily the effort
used. See “Placement Effort Level” on page 1088.

The second number is the number of placement iterations that were run to
get a solution. If an implementation has multiple place-and-route runs, the
second number is cumulative of preceding runs. That is, if the design only
needs one iteration, the list of place-and-route runs shows 1, 2, 3, ....

The implementation row shows the value of the active place-and-route
run.

Location: The full pathname for the implementation.
Start: When synthesis started. Not applicable for EDIF projects.

Level/Cost: The first number is the Placement Effort Level specified in the
Place & Route Design section of the strategy, not necessarily the effort
used. See “Placement Effort Level” on page 1088.

The second number is the number of placement iterations that were run to
get a solution. If an implementation has multiple place-and-route runs, the
second number is cumulative of preceding runs. That is, if the design only
needs one iteration, the list of place-and-route runs shows 1, 2, 3, ....

The implementation row shows the value of the active place-and-route
run.

Description: An editable text box. Initially it just has the implementation
name but you can change it.

To change the description of an implementation, double-click the
Description cell. Then enter any text you want.

GSR: The number of GSR used versus the total number available.
P10: The number of PIO used versus the total number available.
EBR: The number of EBR used versus the total number available.
PCS: The number of PCS used versus the total number available.
Number Of Signals: The number of signals in the design.

Number Of Connections: The number of connections in the design.

Selecting an Implementation and Run

After studying the results, you can select one of the implementations and one
of its runs for further development.

To select an implementation and run:
1. Right-click on the implementation’s row and choose Set As Active.

This implementation becomes the active one for the project. The row
changes to bold type and, in File List view, the implementation is
expanded. The previously active implementation becomes inactive.
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Finding Results

After you load a design in Diamond, you can find the information you need via

2.

If the implementation has multiple runs, right-click the preferred run and
choose Set As Active.

The results of this run will be used in further development such as
exporting files. The row changes to italic type.

the following ways.

In the active Reports view, choose Edit > Find. You can type the desired
text into the Find field at the bottom-left of the Reports view window. The
first occurrence of the desired text will be found and highlighted in the right
side of the window for you. Click Next or Previous to find more. And
check the Case Sensitive option if needed for the search. While typing in
the text, the Find field will be automatically colored if no occurrence of the
text is found.

In the active Source Editor, after choosing Edit > Find, you will get the
Find and Replace dialog box. You can enter the text you want to search in
the Find What field and start a search. Use the Find Next command to
find more. If you want to replace the current find, you can use the Replace
tab of the dialog box. Check Match Case, Match Whole Word, Search
Up, Regular Expression options as needed. Use the Replace or
Replace All command to replace the text found.

If you want to find information without loading the files, you can choose
Edit > Find in Files from Diamond main window. In the pop-up Find In
Files dialog box, type the text you want to find, specify the search path
and search filters, and check the desired options: Search subdir, Include
hidden files, Match case, Match whole word, and Regular
expressions. Press Find. The results will be displayed in the Find
Results frame. Double-click any of the findings from the Find Results
frame to open the associated source file in the associated editor. For
example, if the finding is in a log file, the log file will be opened in the
Reports view with the first finding appears on the first line.

You can search the Output log by clicking in the Output view (in the text,
not on the tab) and then pressing Ctrl-F. This opens a basic text search

dialog box at the top of the Output view. You can type the text in the Find
text field and start a search.

Find Results View The Find Results view may not be displayed

automatically in your Diamond main window. To turn on the Find Results view,
select View > Show Views > Find Results. A check mark indicates the frame

is displayed.

The Find Results view can be detached from the main window by clicking the
detaching icon on the upper-right corner of the view. After detaching, you can
double-click on the title bar of the view to get it back to the main window.

See Also “Viewing Logs and Reports” on page 92

“Navigating Errors and Warnings” on page 94
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“Finding Text in Logs and Reports” on page 94

Viewing Logs and Reports

Lattice Diamond generates log files for all project activities. The log files
contain processing information, as well as error and warning messages. If you
run processes, reports are generated.

Viewing Logs A log file is displayed in the Output frame as a process is
running. A scroll bar can be used to scroll up and down in the information.

Errors are displayed in red. Warnings are displayed in orange. There are also
information messages. These messages are also displayed in the Warning,
Error, and Info views. These views may not automatically be visible in your
Diamond main window. To turn on the views, choose View > Show Views >
<view>. A check mark indicates the view is displayed.

Viewing Reports The Reports view displays reports for the major
processes.

There are two panes in the Reports view. The left pane lists the Design
Summary information including the report types. The reports in detail are
displayed in the right pane.

Type of Report  Description

Project Summary Lists the summary information of the project including module
name, synthesis tool chosen, implementation name, strategy
name, target device, device family, device type, package type,
performance grade, operating conditions, logic preference file,
software product version, project file name, and location.

Process Reports Lists the synthesis, map, place and route, signal/pad, and
bitstream reports in HTML format.

Analysis Reports Lists the trace and timing reports.

Tool Reports Lists the I/O SSO analysis, hierarchy parsing, PIO DRC, and ECO
Editor reports. Also has a log of Tcl commands used in recent
sessions.

Messages Lists the implementation messages and user defined filters for the
messages.

In the Design Summary pane, there is the report icon [ 1. If a report has been
generated, the icon appears as {#|. If the report is not the most recent version,
the icon appears as “Z]. To view the contents of the entire report, click on the
report to be viewed. The entire report is then displayed in the right pane of the
Reports view. Use the scroll bar to navigate through the report. Some of the
reports are divided into sections (for example, Map, Place & Route, and
Signal/Pad). Expand the report listing to display the sections in a list. Choose
the desired section. The whole report will be displayed with the selected
section displayed at the top of the right pane of the Reports view.
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You can navigate the reports quickly by using the Find function (right-click in
the right pane of the Reports view and choose Find in Text).

Other Reports The Synthesize Design stage produces reports that do not
appear in the Reports view. You can find these reports in the implementation
folder. In the File List view, right-click the implementation name and choose
Open Containing Folder. A window will open showing the contents of the
folder. All of these reports can be read with a text editor.

One of the reports is a detailed description of the device resources that will be
used by the design. This report is much more detailed than the synthesis
report in the Reports view. The report includes the resources used by each
module of the design. Similar information can also be found in the Hierarchy
view. For Synplify Pro, look for <top_module>.areasrr; for Lattice Synthesis
Engine, look for <top_module>.arearep.

See Also “Finding Results” on page 91

Cross-Probing from Reports to
Schematics

While studying one of the timing or trace reports you might want to see where
a module or port is in the design. You can cross-probe, or jump, from the
Lattice Synthesis Engine (LSE) timing report and from the place & route trace
report to a schematic view of the design.

To cross-probe from the LSE timing report to a schematic view:
1. After running synthesis with LSE, open the Reports view.

2. Inthe Design Summary column, click LSE Timing Report. It's under
Analysis Reports.

3. Select text that has the name of one or more module instances or ports of
interest.

4. Right-click and choose Filter in Netlist Analyzer.

Netlist Analyzer opens with the technology netlist view of the selected
objects. For more information, see “About Netlist Analyzer” on page 57
and “Navigating the Design with Netlist Analyzer” on page 62.

To cross-probe from the place & route trace report to a schematic view:

1. After running place & route of the design, choose Tools > Synplify Pro
for Lattice.

2. In Synplify Pro, click the Implementation Directory tab.
3. Find the .twr file and double-click it.
A text editor opens in Synplify Pro with the report.
4. Find the name of an instance or port of interest and select it.

Right-click in the selected name and choose one of the following:
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Filter in Analyst to see the item by itself
Select in Analyst to find the item in the full schematic

6. If a suitable Analyst view is not open, a dialog box asks if you want to
open one. Click Yes.

7. Go to the Analyst schematic view to see the item.

Navigating Errors and Warnings

If an error or a warning results from the specific line in an HDL source file, you
can easily go to that line to edit the source file.

To navigate errors and warnings:

In the Reports, Output, Error, or Warning view, double-click the line
describing the error or warning.

In the Reports, Output, Error, or Warning view, right-click the message
and choose Locate in > Text Editor. If the command is dimmed, there is
no link to a source file.

Your default text editor opens with the appropriate HDL source file at the line
number specified in the error or warning message. You can then modify the
file to debug your design.

See Also “Finding Results” on page 91

Finding Text in Logs and Reports

You can search for text in the Output, Error, Warning, Info, and Reports views.

To search for text in the Output, Error, Warning, and Info views:

1. Right-click in the Output, Error, Warning, or Info view of the Diamond main
window and choose Find in Text.

The Find toolbar appears.

2. Inthe Find text box, enter the text that you want to search for. Check the
Case Sensitive option if you want the text to match exactly as it was
entered into the text box. Or, check the Whole Words option as desired.
As you type each character, the focus in the window changes to where a
match is found.

3. Use the Next and Previous buttons in the Find toolbar to find other
occurrences of the text.

To search for text in the Reports view:
1. Right-click in the right pane of the Reports view, and choose Find in Text.

The Find toolbar appears.
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2. Inthe Find text box, enter the text that you want to search for. Check the
Case Sensitive option if you want the text to match exactly as it was
entered into the text box.

3. Use the Next and Previous buttons in the Find toolbar to find other
occurrences of the text.

See Also “Finding Results” on page 91

Filtering Messages

The number of messages produced by the design implementation process
can be very large. There are several ways to filter these messages to find the
ones of most interest. Messages can be filtered by:

Implementation process (synthesis, translate, map, place & route, export,
or other tool)

Severity (information, warning, and error)
ID number
Text
Filter settings can be saved for use later or to apply to the Output view. Saved

settings are available in the Reports view under Messages > User Defined
Filters.

Messages are automatically sorted by severity: Error, Warning, and Info. Look
for these tabs in the message area of the main window alongside the Output
view. If the one you want is not showing, choose View > Show Views and
select the one you want.

To set filter options:
The message list changes as you set filter options.

1. After running part or all of the implementation process, go to the Reports
view. This view opens automatically. If it is not showing, choose View >
= Reports.

2. Atthe bottom of the Design Summary column, under the Messages folder,
select either All Messages or one of the user defined filters.

Messages appear to the right in a spreadsheet display.

3. [Iffilter options are not visible above the spreadsheet, click the Show Filter
Selection button. It's the arrow at the top-right of the Reports view.

Several check boxes and buttons appear at the top of the view.
4. Select the processes and severity levels you want to hide.

Specify any message ID that you want to hide by right-clicking a message
that has that ID and choosing Filter Messages with This ID.

6. To hide a specific message, right-click on an example of the message and
choose Filter Messages Exactly Like This. This hides all messages with
the same process, severity, ID, and text. The text must be completely the
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same. Messages of the same type but using a different signal or module
name will show.

To see messages hidden by this option, click Filter Details in the Filter
Selection area or right-click in the Message area and choose Filter
Details List. The Detailed Filter List dialog box opens showing just this
set of hidden messages.

7. To stop hiding messages hidden by the Filter Messages with This ID and
the Filter Messages Exactly Like This options, open the Detailed Filter List
dialog box (above). Clear the Filter Enable check box of the desired
messages and click Apply.

Note

You can also select options by right-clicking a message of the type that you want to
hide and choosing one of the Filter Messages commands. These commands hide all
messages with the same process, severity, or ID as the selected message.

To undo all filter settings:
1. Click Reset.

A dialog box opens.
2. Do one of the following:

If there have been changes, you are offered the option of saving the
settings. If you choose to save, see the following procedure.

If there have been no changes, click OK in the dialog box.

To save filter settings:

1. If the filter options are not visible above the spreadsheet, click the Show
Filter Selection button. It's the arrow at the top-right of the Reports view.

2. Click Save Filter.
The Save Filter dialog box opens.
Enter a name for the filter.

4. Click OK.

The new filter’'s name appears in the Design Summary column under
Messages > User Defined Filters.

To apply user defined filters to the Output view:
Filter settings must be saved before they can be applied to the Output view.

1. Before running part or all of the implementation process, go to the Reports
view. If it is not showing, choose View > [Ei Reports.

2. Atthe bottom of the Design Summary column, under the Messages folder,
expand User Defined Filters.

3. Right-click the desired filter and choose Apply "<filter>" to Output View.

A filter icon 7| is placed by the filter’'s name.
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4,

Run the desired implementation processes.

The Output view is loaded as usual except that the specified messages
are missing. To see the missing messages, look in the Error, Warning, or
Info tabs or select All Messages in the Reports view.

To stop using the filter on the Output view, right-click the filter name and
choose Apply "<filter>" to Output View again.

The Output view does not change, but will display all messages from
future processing.

Changing Warnings to Errors

There may be warning messages that you consider to be serious problems
and want to stand out more. You can change these warnings to show the error
severity level in your design project. You can also save these “promotions” to
use in other design projects.

Promotions only show for messages from future actions. Promotions do not
affect the display of messages from past actions.

To change a warning to an error in the Reports view:

1.
2.

In the Reports view, go to the Messages section.

Right-click on the message that you want to promote and choose
Promote Messages with This ID.

Not all warning messages can be promoted so this command may be
dimmed.

To change a warning to an error without the Reports view:

1.

Choose Project > Message Promotion.
The Message Promotion dialog box opens.

In the IDs box, type the ID number of the messages that you want to
promote. Separate multiple ID numbers with semi-colons (; ).

Click Promote.

Not all warning messages can be promoted so some ID numbers may be
rejected.

When you are finished in the Message Promotion dialog box, click Close.

To restore a message ID to the warning level:

1.

Choose Project > Message Promotion.

The Message Promotion dialog box opens.

Select the message that you want to restore to the warning level.
Click Remove.

When you are finished in the Message Promotion dialog box, click Close.
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To save the list of promoted messages for another project:

1.

Choose Project > Message Promotion.
The Message Promotion dialog box opens.
Click Export.

In the Export Promotion dialog box, browse to where you want to save the
list.

Enter a file name.
Click Save.
The list is saved to a file with a “.pmt” extension.

When you are finished in the Message Promotion dialog box, click Close.

To use an existing list of promoted messages:

1.

Choose Project > Message Promotion.

The Message Promotion dialog box opens.

Click Import.

In the Import Promotion dialog box, browse to the list.

Click Open.

The list of messages appears in the Message Promotion dialog box.

When you are finished in the Message Promotion dialog box, click Close.

Getting Help for Messages

Some messages have a link to more information in the online Help. This
information may help to understand what the message is about or how to fix
the problem.

To check for help on a message:

1.

Right-click on the message in the Reports, Error, Warning, or Info view.

A menu appears. The last item in the menu is Help. If it is dimmed, there
is no link.

If the Help command is available, choose it.

The Help opens with the appropriate topic.

Lattice Diamond 3.6 Help

98



= LATTICE Chapter 3

Designing with Lattice
Diamond Platform Designer

Included with the Lattice Diamond software is the Platform Designer tool
which enables you to build and control a complete hardware management
system using the Platform Manager 2, or a MachXO2 with external Analog
Sense and Control (ASC) devices, or an ECP5U/UM with external ASC
devices.

Figure 2: Platform Manager 2 Block Diagram
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As shown in the previous figure, the Platform Manager 2 device is made up of
an ASC block and an FPGA block. These two blocks provide the necessary
programmable building blocks to enable integration of various combinations
of hardware management functions into a single chip. The hardware
management algorithm is implemented within the FPGA block of the Platform
Manager 2. The monitoring and control resources can be scaled up, to meet
application requirements, by adding an external ASC to the Platform Manager
2. Each of the ASCs provides additional monitor and control of up to ten
voltage rails, two temperature sensors and two current sensors. The overall
platform management algorithm that uses the inputs from the external ASC
device(s) is located within the FPGA block of the Platform Manager 2. The
following diagram shows how an ASC device can be connected to a Platform
Manager 2 device to implement a hardware management circuit that monitors
the board voltage rails (V), supply currents (1), and board temperatures (T).

Figure 3: ASC Device Connected to a Platform Manager 2 Device

\\
VMON

MON_ | ASC Platform

¢ Manager 2
DC-DC

Multiple ASC devices (up to 8) can also be connected to a MachX0O2 HC
device (640 LUT or larger), or to an ECP5U/UM device (25F and 45F), similar
to the Platform Manager 2, to offer wider flexibility and control when
implementing a complete hardware management system.
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Figure 4: Connecting Multiple ASCs to Lattice Device
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See Also »“Platform Designer User Interface” on page 101

“Platform Designer Flow” on page 104

About Platform Designer

Platform Designer provides an integrated design environment that enables
you to configure the device, implement the hardware management algorithm,
simulate, assign pins, and finally generate the JEDEC files required to
program and configure the device on the circuit board. It also allows you to
import other HDL files to integrate other desired functions.

See Also »“Launching Platform Designer” on page 105
“Platform Designer User Interface” on page 101

“Platform Designer Flow” on page 104

Platform Designer User Interface

Platform Designer contains separate editors for configuring global settings;
current, temperature, and voltage monitors; fan controller and fault logger
components; ports, nodes, and logic controls. It also provides a view for
checking design rules and resources and building the design. Each editor and
view is accessed from the Platform Designer menu pane on the left, which is
divided into five main sections: Global, Analog, Components, Control, and
Build.

Global The Global Configuration view provides global configuration options,
including options for each ASC device. The global ASC Options provide
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access to configuration settings like the 1°C address and other default
settings. The Device Options enable you to select the programming interface,
clock source, and boot mode.

Components The Components section enables you to configure the fan,
fault logging, hot swap, and PMBus Adapter. It includes the following views:

Fan Controller — The Fan Controller allows you to add a fan, specify the
fan interconnections, and configure the control parameters. The fan
controller can be configured to work with 2-wire, 3-wire, or 4-wire fans,
and up to sixteen fans can be controlled. The fan controller generates a
pulse width modulated (PWM) signal to set fan speeds.

Fault Logger — The Fault Logger enables you to specify and configure
fault conditions that are logged to non-volatile memory. You have the
option of using standard fault logging that is based on voltage, current,
and temperature status; or using the full-featured fault logging.

Hot Swap — (Platform Manager 2 and MachXO2 only.) The Hot Swap
component enables you to configure the ASC for a hysteretic closed-loop
to limit the in-rush current in an application where power is rapidly applied.
Such an application can include such a line card, blade, or a PCB that is
plugged into a “hot” backplane.

PMBus Adapter — (Platform Manager 2 and MachXO2 only.) The
PMBus Adapter component allows you to configure the adapter for
connecting analog Point of Load (POL) DC-DC converters to PMBus
using the ASC and FPGA.

Analog The Analog section enables you to configure the settings for
current, temperature, and voltage monitors. It includes the following editors:

Current — The Current editor enables you to configure the low-voltage and
high-voltage current monitors for each ASC device. Platform Designer
automatically populates the current trip points available based on the
sense resistor selection. You can configure the trip points and other
current monitor settings here.

Temperature — The Temperature editor enables you to configure the
temperature monitors (TMON) for each ASC device. Multiple monitor
levels can be selected for each TMON, with temperature values displayed
in °C.

Voltage — The Voltage editor allows you to configure voltage monitoring,
trimming, margining, and voltage identification (VID) settings for each
ASC device in your system. You can edit multiple settings by using the
Voltage Monitor & Control dialog box. To open the dialog box, double-click
an active cell in the ASC column or the Pins Monitor/Trim column on any
of the three spreadsheets, or right-click the cell and choose Edit. You can
also edit settings individually on the Voltage spreadsheet or the VID
spreadsheet by single-clicking an editable cell.

Control The Control section enables you to configure signals and set the
control logic. It includes the following editors:

Ports & Nodes — The Ports & Nodes editor provides spreadsheets for
viewing the internal nodes and configuring external signals (ports) of the
chip set. The Ports sheet shows all physical FPGA-based PIOs that are
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available for use as external connections to the design and allows you to
assign labels to logical ports, specify the 1/0 and register type, and group
ports of a common type to form a bus. The Nodes sheet shows internal
signals already generated to connect the implemented features of the
design. The nodes sheet allows you to create additional signals for
connecting different features on-chip. The GPIO sheet allows you to
configure and label the ASC-based general purpose 1/0s. The HV Outputs
sheet allows you to label and configure the high-voltage output ports.

Logic — The Logic editor enables you to create sequences, exception
logic, supervisory equations, and timers for one or more state machines. It
also allows you to import modules into your design from HDL code. The
Sequence page of the Logic editor allows you to add state machines and
gives you access to the Multiple State Machines dialog box for managing
the state machine library.

Build The Build view enables you to check the design status, examine the
amount of hardware resources consumed, run DRC check, compile the
design, and generate the merged JEDEC file. The Build view includes a
summary table of enabled components and programming options, and it
shows the amount of hardware resources of the device that have been
consumed by the current design configuration. The Build view enables you to
generate a test bench, including stimulus, for simulating your design. It also
allows you to export a detailed configuration report.

See Also »“Working with Platform Designer Editors” on page 109

Platform Designer Input Files

The input files for Platform Designer include the Platform Designer project file
(.ptm) and HDL source files (.v, .vhd).

The .ptm file holds all of the Analog Sense and Control settings, as well as the
logic and port information, for the active Platform Designer project. A .ptm file
is generated automatically for a new project. You can also add a new or
existing .ptm file, which allows you to choose from multiple project files in a
single implementation.

HDL source files are not required, but you can add them to the Diamond
project. Once the HDL files are added to the Diamond project, you can use
Platform Designer’s Logic Editor to import an HDL module into the Platform
Designer project.

See Also See “Working with Platform Designer Project (.ptm) Files” on
page 108
“Importing HDL Modules” on page 146.

“Creating a New Platform Designer Project” on page 106
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Platform Designer Output Files

Platform Designer automatically generates the background HDL files when
you compile the design. The “Generate Jedec” process produces a merged
JEDEC of the FPGA and ASC JEDEC files for programming. ECP5U/UM
output file is .bit.

See Also »“Building the Design” on page 146

Platform Designer Flow

The number of tasks involved in the Platform Designer flow will vary,
depending on the selected Platform Manager 2, or MachXO2, or ECP5U/UM,
the number of external ASC devices selected, and the types of configuration
needed to complete the design. The following outline shows a typical flow of
required and optional tasks.

1. Create a project in Lattice Diamond. Select the base device and package;
Platform Manager 2, or MachXO2 HC, or ECP5U/ECP5UM. Then add the
number of external ASC devices needed.

2. Specify global settings:

ASC options, including reset type, and default options for voltage,
current, and temperature

device options, including programming interface, clock source, and
boot mode

3. Configure the ports and nodes:

ports and port groups

internal nodes

general-purpose I/Os

high-voltage outputs

4. Configure the analog settings:

Configure the voltage monitors (VMONS):
schematic net names and parameters
trim/margin parameters
voltage identification (VID) tables

Configure the current monitors (IMONS).

Configure the temperature monitors (TMONS).

Configure one or more fans:
fan type and pulse width modulation
fan interconnections

Configure PMBus Adapter.

Enable and configure fault logging.
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5. Define the platform management logic, including sequencing and
monitoring:

timers
sequencer instructions and exceptions for one or more state machines
supervisory logic equations
modules that are imported from HDL
6. Build the design.
Examine the resources consumed.
Run design rule check.

Compile the design to generate the HDL code and synthesize the
logic.

Assign Pins in Spreadsheet View.

Generate the JEDEC to process the design and generate the merged
JEDEC file.

7. Simulate the design.

See Also »“Platform Designer User Interface” on page 101
“Creating a New Platform Designer Project” on page 106

“Working with Platform Designer Project (.ptm) Files” on page 108

Launching Platform Designer

You can launch Platform Designer by creating a new project in Diamond that
targets a Platform Manager 2, or a MachXO2 HC (640 LUT or larger) with
external ASCs, or an ECP5U/UM (25F and 45F) with external ASCs. You can
also launch Platform Designer by opening an existing Platform Designer
project file (.ptm).

Platform Designer is also available from the Diamond Tools menu when you
open an existing project that targets a Platform Manager 2, or a MachX0O2
with external ASCs, or an ECP5U/UM with external ASCs.
See Also »“Creating a New Platform Designer Project” on page 106
“Opening an Existing Platform Designer Project” on page 107
“Working with Platform Designer Project (.ptm) Files” on page 108
“Working with Platform Designer Editors” on page 109
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Creating a New Platform Designer
Project

When you create a new project that targets the Platform Manager 2, or a
MachXO2 HC (640 LUT or larger) with external ASCs, or an ECP5U/UM (25F
and 45F) with external ASCs, Diamond generates a new Platform Designer
project file (.ptm) and opens the Platform Designer user interface.

To create a new Platform Designer project in Diamond:

1. In Diamond, choose File > New Project to open the Create a Lattice
Diamond Project wizard.

2. Click Next.

3. Inthe Project section, type a name for the project and use the Browse
button to navigate to a location.

4. Click Next.

The Add Source section is an optional step that allows you to add HDL
source files to the project or an existing Platform Designer project (.ptm)
file. If you add an existing .ptm file, the default .ptm file will not be added to
the project.

To skip the Add Source step, click Next.

To add source files to the project, click the Add Source button to navigate
to the files and select them, and then click Next.

6. Inthe Select Device dialog box, do one of the following:

Select Platform Manager 2 in the Family section, and then select the
desired LPTM device from the Device section.

Platform Manager 2 devices contain one embedded Analog Sense
and Control (ASC) device. The LPTM21 device allows you to add up
to three external ASC devices. The LPTM20 device allows you to add
one external ASC device. To add an external ASC device, select
LPTM21. The “Select ASC Device” section will then appear near the
bottom of the dialog box.

Select MachX02 in the Family section, and then select the desired
LCMXO2 HC device—640HC or larger—from the Device section.

The “Select ASC Device” section appears near the bottom of the
dialog box. Up to eight ASC devices can be added, depending upon
the size of MachXO2 device.

Select ECP5U/UM in the Family section, and then select the desired
LFE5UM device—25F or 45F—from the Device section.

The “Select ASC Device” section appears near the bottom of the
dialog box. Up to eight ASC devices can be added.

7. Inthe “Select ASC Device” section, select the number of ASC devices you
would like to include.

The package type, performance grade, operating conditions, and part
name are all tied to the device selection.
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8.

10.

Click Next.

In the Select Synthesis Tool dialog box, select the synthesis tool that you
want to use. The choices are Lattice LSE and Synplify Pro and can be
changed at any time.

Click Next.

In the Project Information dialog box, the option “Create Platform Designer
file” is selected by default. This will create a .ptm file using the project
name shown in the File name box and cause Platform Designer to open. If
desired, you can assign a different name for the .ptm file and select a
different directory location.

Note

If you added an existing .ptm file to the project in Step 4, the “Create Platform
Designer file” option will not be available.

Click Finish.

Platform Designer opens within Diamond and loads the .ptm file.

See Also »“Opening an Existing Platform Designer Project” on page 107

“Working with Platform Designer Project (.ptm) Files” on page 108

Opening an Existing Platform Designer
Project

After you have created a project in Diamond that targets a Platform Manager
2, or a MachX0O2 HC (640 LUT or larger) with external ASCs, or an ECP5U/
UM (25F and 45F) with external ASCs, you can open the Platform Designer

project file (.ptm) for the active implementation.

To open an existing Platform Designer project in Diamond:

1.

In Diamond, choose File > Open > Project, and navigate to the Lattice
Diamond file (.Idf) for the Platform Designer project.

Diamond loads the file and shows the .ptm file in the File List view.

Do one of the following:

Click the Platform Designer button h on the toolbar or from the Tools
menu.

Platform Designer opens and loads the active .ptm file

In the File List view, expand the Input Files folder and double-click the
.ptm file that you want to open.

Platform Designer opens and loads the .ptm file.

See Also »“Working with Platform Designer Project (.ptm) Files” on

page 108
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Working with Platform Designer Project (.ptm) Files

The Platform Designer project file (.ptm) holds all of the Analog Sense and
Control settings, as well as the logic and port information, for the active
implementation. When you create a new Platform Designer project, the .ptm
file is generated automatically by Diamond. You can also add a new or
existing .ptm file to your project. The project’s .ptm files are maintained in the
Platform Design Files folder in the File List view for the active implementation,
and the active .ptm file in this folder is displayed in bold. Only one .ptm file can
be active for an implementation.

To add a new .ptm file to a Platform Designer project:

1. Inthe File List view of Diamond, right-click the name of the active
implementation, and choose Add > New File.

2. Inthe dialog box, select Source Files from the Category list, and then
select Platform Designer File.

3. Type a name for the new .ptm file. If desired, select a different location for
the file by clicking the Browse button.

4. Click New.

Diamond loads the new .ptm file and sets it as the active Platform
Designer file for the current implementation.

To add an existing .ptm file to a Platform Designer project:

1. In the File List view of Diamond, right-click the name of the active
implementation, and choose Add > Existing File.

2. Inthe “Files of type” list, select Platform Designer Files from the drop-
down menu.

3. Browse to the location of the desired .ptm file, select it, and click Add.

Diamond loads the .ptm file and sets it as the active Platform Designer file
for the current implementation.

To change the active/inactive status of a .ptm file:

1. If the .ptm file that you want to make active or inactive is still open in
Platform Designer, close it.

2. Right-click the .ptm file and choose the appropriate command: Set as
Inactive or Set as Active.

Opening an Inactive .ptm File Platform Designer allows you to open an
inactive .ptm file to examine the configurations. The inactive file will open in
read-only mode, which will enable you to examine each view but not allow any
changes. Platform Designer will close the active .ptm file, if it is open, before
opening the inactive one. It will also prompt you to save any changes. You will
not be able to execute any of the operations in the Build view (such as
Compile, Generate JEDEC) when viewing an inactive .ptm.

Saving a .ptm File When you save an active .ptm File, Platform Designer
takes all of the configuration changes that are in memory and saves them to
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the .ptm file. When you use the “Save as” command to save the.ptm file with a
different name or to a new location, Platform Designer includes all of the
collateral files for the implementation, as well as any changes in memory. You
can also use the “Save as” command for an opened inactive .ptm file.

See Also “Creating a New Platform Designer Project” on page 106

“Platform Designer Flow” on page 104

Working with Platform Designer Editors

The Current, Temperature, Voltage, and Ports & Nodes editors in Platform
Designer use a format that is very similar to a spreadsheet. The columns for
these editors are arranged in the order of the most commonly used settings.
For example, in the Voltage editor, the four most commonly used columns—
ASC Device, Pins Monitor/Trim, VMON Schematic Net Name, and Nominal
Profile 0—are positioned first and are locked from horizontal scrolling so that
they are always visible for association with other columns and for easy
access. The cells of columns that are locked from horizontal scrolling are
colored with a light gray background. Columns for less frequently used
settings, such as Window Mode, are positioned further to the right and are not
locked from horizontal scrolling. The cells of these columns have a white
background.

Platform Designer editors differ in a couple of ways from standard
spreadsheet formats. In Platform Designer spreadsheets, when you click a
cell to enter a value, you click only once and then choose a selection from the
drop-down menu or type a value, depending on the type of cell selected.
Because of this, navigating from cell to cell by keyboard is slightly different,
and copying or cutting and pasting from multiple cells is not supported. The
following sub-topics explain how to use the features of Platform Designer
editors.

Sort by Columns You can sort the row order by a single column by clicking
the column heading. An up arrow in the heading indicates that the rows are
sorted in ascending order. Click the heading again to sort the list in
descending order.

In the Voltage, Current, and Temperature editors, you can also sort the rows
by multiple columns.

To sort by multiple columns:
1. Choose View > ;'4:: Sort to open the Sort by Column(s) dialog box.

2. Select the first column to sort by from the “Sort by” drop-down menu. Click
Ascending or Descending to control the order of the sorted rows.

3. Use the “Then by” boxes to select additional columns, as well as the
Ascending/Descending option for each column. Click More to add more
“Then by” menus if needed.

The rows will be sorted first by the column specified in the “Sort by” box
and then by the additional columns in the “Then by” boxes in sequence.
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4. Click OK.

To return to the default layout:
Right-click any column heading and choose Default Layout option. This
returns the sorted order to the original view.

Adjust Column Width You can adjust column widths manually or choose
the right-click command to fit the column to the text.

To adjust the column width manually:

Drag the vertical border on the right of a column heading.

To fit the column width to the text, do one of the following:
Double-click the vertical border on the right of a column heading.
Right-click the desired column heading and choose Fit Column.
Choose View > Column > Fit All Columns to fit all column widths to the
text.

Hide and Re-display Columns You can hide a single column in the
Voltage, Current, or Temperature editor or select several columns that you
want displayed or hidden.

To hide a single column:

Right-click the desired column heading and choose Hide Column.

To hide several columns:

1. Choose View > Column > Visible Columns or press Shift+F5 to open
the Visible/Hide Columns dialog box.

2. Do one of the following:

In the “Show these Columns list,” select the columns that you want to
hide, and then click the single-arrow button to move them to the “Hide
these Columns” list.

Click the double-arrow button to move all columns to the “Hide these
Columns” list, and then select those you want displayed by selecting
them and moving them to the “Show these Columns” list.

3. Click OK.

To re-display some of the hidden columns:

Press Shift+F5, and move the hidden columns back to the “Show these
column(s) list.”

To re-display all columns:

Press Shift+F5, and click the double-arrow button to move all hidden
columns to the “Show these column(s)” list.
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Edit Cell Values The editable cell values in each editor are color-coded
blue or black. Blue indicates a default value, and black indicates an edited
value. Values that appear in gray are values that cannot be edited, including
tool calculated settings or settings that are implied by other areas of the editor.

To edit a single cell value, click once inside the editable cell and enter or
select a new value. In the Voltage editor, you can use the Voltage Monitor and
Control dialog box to edit the properties for an entire row. See “Setting
Multiple VMON/Trim Properties” on page 116.

You can copy or cut a text entry of a single editable cell and paste it into
another cell of the same type. You can do this by using the right-click menus
or the standard Ctrl+C, Ctrl+X, and Ctrl+V keyboard shortcuts. Copying and
pasting multiple cells is not supported.

Right-click a Text-entry Cell to Open the Complete Menu The right-click
menu will sometimes vary for text-entry cells, depending on whether you have
single-clicked a cell for editing or have highlighted the entire cell. For
example, on the Ports sheet, when you single click a Logical Name cell, the
text in the cell is highlighted so that you can type a new label. But if you right-
click while only the text is highlighted, the menu will display editing commands
such as cut, copy, paste, or delete, but it will not include the Add Group or
Show In commands.

To access the complete right-click menu for a text-entry cell:
Right-click a cell without clicking it to highlight the entire cell.

If you have already single-clicked the cell, press the Enter key to highlight
the entire cell.

Navigate from Cell to Cell Because of the convenient one-click access to
parameters in the Current, Temperature, Voltage, and Ports & Nodes editors,
navigating by keyboard from cell to cell involves an additional small step.

To enable the navigation capability, do one of the following:

Select a cell in the ASC Device column or the Pin column by single-
clicking it.

If you have already opened an editable cell by clicking it, press Enter to
highlight the entire cell. If the cell contains a drop-down menu, you might
need to press Enter a second time to enable navigation.

Note

If you have single-clicked an editable cell in one of the columns that are locked
from horizontal scrolling, you will only be able to navigate among the cells of the
locked columns after you press Enter. To enable full navigation afterward, click a
cell in the ASC Device column or Pin column, or click an editable cell in a column
that is not locked from horizontal scrolling and press Enter.
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You can then use the arrow keys to move up and down the cells of a column
or across the cells in a row. You can also use the Tab key and the Shift+Tab
combination to move forward and back across a row. When you have reached
a targeted cell for editing, single-click the cell. To continue navigating
afterward, press the Enter key.

Setting Global Options

For a new Platform Designer project, you would normally begin by using the
Global Configuration view to configure those features that affect the entire
design. This includes device options for operation mode and externally
connected components such as dual-boot SPI flash. It includes ASC global
options as well as options for each individual ASC of the target chip set.

See Also “Setting ASC Options” on page 112
“Setting Device Options” on page 113
“Configuring a SPI Flash Model” on page 114

Setting ASC Options

The ASC options are divided into global ASC options, which affect the entire
project, and specific ASC options that affect only a given ASC. Use the left
portion of the ASC Options to set the values for each individual ASC, and use
the Global ASC Options on the right to set global ASC values.

Options for Each ASC The following options are available for individual
ASCs:

ASC Name — labels the ASC with a unique name that will identify it
globally.

CLT Rate — sets the closed loop trim update rate, in pus or ms.

I°C Base Address (ASCO only) — sets the 4 MSB in the 7-bit 1°C address
of ASCO. This base 4 MSB is common for all ASCs in the system. This
setting is not available for ECP5U/UM based designs. The I°C base
address is locked to the default value.

I°C External Resistor — displays the resistor values that are used by the
ASC to set the three LSB of the 1°C address. See the ASC data sheet for
more details.

I°C Address — displays the full address of each ASC, using the configured
base address and the 3 LSB that are set by the external resistor.

UES Bits — sets a 32-bit user electronic signature for storing unique data
inside the ASC. This setting is not available for ECP5U/UM based
designs.

Reset Type — configures the reset type as mandatory or optional. For
ASCQO, the reset type is fixed to mandatory. Mandatory ASCs have their
reset signals tied together on the board. If one of these ASCs needs to be
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reset, the whole system is reset. Optional ASCs are handled individually
and have a dedicated reset signal.

Reset Source — displays the port defined in the reset source for an
optional reset type.
Global ASC Options The following global options affect all ASCs:

EIA Resistor Standard — limits the resistor selection to the EIA standard
selected or, if Exact is selected, calculates the exact resistor values. This
value is used by the TRIM calculator in the voltage editor. It determines
which resistor values will be recommended by the calculator.

Open Resistor Threshold — sets the maximum resistor value above which
the resistor is treated as an open circuit. This setting is used by the TRIM
calculator.

DC-DC Options

DC-DC Library Directory — sets the location for the DC-DC Library.
The default directory location is inside the Diamond installation sub-
directories.

Build DC-DC Library — opens the DC-DC Library Builder Wizard,
which enables you to add or edit a DC-DC Converter model.

VID Options

VID Tables Directory — sets the location for the voltage ID tables. The
default directory location is inside the Diamond installation sub-
directories.

Build VID Tables — opens the VID Table dialog box, which enables you
to add or edit a VID table.

Voltage, Current, and Temperature Options

The Voltage, Current and Temperature monitors are populated with
default trip points each time a new project is started. The ASC Global
Options Default Trip Point Selections allow you to change the default trip
points for each of the monitor types at the start of a new project.

See Also “Configuring Voltage Identification (VID) Tables” on page 121

“Defining DC-DC Converter Models” on page 119

Setting Device Options

Select the Device Options tab of the Global Configuration View to configure
the operation mode and the external connected components.

Operation Mode Options The Operation Mode section includes the
following options:

Programming Interface:

MachXO2 and Platform Manager 2: JTAG or 12c
ECP5U/UM: JTAG only.
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Background Programming:
Platform Manager 2 and MachXO2 — None, 12C, or JTAG.

ECP5U/UM — JTAG or SPI (Background Programming Interface to
SPI Flash).

8MHz Clock Source for Device Operation — ASCO or Global_Clock
External Connected Components The External Connected Components
section includes the following options:

SPI Models Directory — Select a location for the SPI models directory.

Build SPI Models — Configure a new SPI model and add it to the SPI
Models Directory, or edit or delete an existing SPI model.

Boot Mode — Normal or Dual Boot. When Dual-Boot is selected, the SPI
model option will appear. Dual-boot requires that a SPI flash be specified.
ECP5 only supports Normal mode - ECP5 dual boot is configured through
Diamond Deployment Tool.

ASC I1°C Write Feature — This feature allows you to configure the I2C write
access to the ASC. This feature is locked to Enabled in the ECP5 solution.

When “Disabled” is selected, it prevents writing to the ASC on-chip
registers over the 12C bus.

When “Enabled” is selected, it allows writing to the ASC on-chip
registers over the 1°C bus.

When “Controlled by ASCx_GPIO1” is selected, the ASCx_GPIO1
input is used to control whether 12C write access is enabled.

FPGA Port (External Connection) — This option appears when

“Controlled by ASCx_GPIO1” has been selected. You will need to

select the FPGA port that will connect to the GPIO1 on all ASCs.

Afterwards, the GPIO1 will be changed to “IN” type for each ASC.
See Also “Defining DC-DC Converter Models” on page 119

“Configuring a SPI Flash Model” on page 114

Configuring a SPI Flash Model

You can use the Global Configuration View to add and configure a new SPI
flash model or edit a current one. The SPI flash models are saved in the SPI
Models directory. The default directory location is inside the current project
sub-directories.

To configure a SPI flash model:
1. Inthe Global Configuration View, select the Device Options tab.

2. Inthe External Connected Components section on the right, do one of the
following:

Click Add/Edit SPI Model in the Value column of SPI Options.

Lattice Diamond 3.6 Help

114



DESIGNING WITH LATTICE DIAMOND PLATFORM DESIGNER : Configuring Voltage Sense (VMON) and Control (TRIM)

If you are using Dual Boot mode, select Add/Edit SPI Model from the
Dual-Boot SPI Flash pop-up menu in the Value column.

The SPI Models Configuration dialog box opens and displays the library of
currently available SPI models.

3. Do one of the following:
To edit an existing SPI model, select it from the list on the left.

To add a new SPI flash model, click New, and then select the newly
created model from the list.

4. Optionally, give the selected model a unique name, by single-clicking the
name and typing a new one.

5. Select the desired values for the Flash Configurations and Flash Opcodes
by double-clicking the value cell and choosing from the menu, and then
press enter. Click Apply to save one or more selected values or to save
all the values for a selected model.

6. If desired, select a different SPI flash model from the list, and repeat Steps
4 and 5.

7. When all options have been set for all the models you are configuring,
click OK.

See Also “Setting ASC Options” on page 112
“Setting Device Options” on page 113

Configuring Voltage Sense (VMON) and Control

(TRIM)

The Voltage editor enables you to manage voltages and settings related to
voltage monitors (VMONS) and trim channels in the Platform Manager 2 or
external ASC devices. You can edit a voltage property by clicking the desired
cell on the Voltage spreadsheet, or you can use the Voltage Monitor and
Control dialog box to edit multiple properties. Double-clicking a VMON/Trim
cell in the Pins Monitor/Trim column opens the Voltage Monitor and Control
dialog box. From the Voltage Monitor and Control dialog box, you can access
the DC-DC Converter Library and the VID Table library.

Setting up the trim and margin capabilities involves the DC-DC Library
Builder, which is used to define the voltage adjustment characteristics of the
power supply or supplies that you wish to use. The Trim/Margin portion of the
Voltage Monitor and Control dialog box is then used to configure each trim
channel for the desired power supplies and output voltages. The following
diagram illustrates this flow:

Modifications to existing DC/DC library files must be made from within the DC/
DC Library Builder Wizard. The DC-DC Converter selection, as well as
changes in the desired target voltages, can be made in the Trim/Margin
section of the Voltage Monitor and Control dialog box. It is strongly advised
that library files not be modified while trim cells are being configured, because
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this can create confusion and make it difficult to detect errors in your work. If a
“discrete” supply is to be used at several different voltages, a separate library
entry for each unique output voltage should be created.

The Trim/Margin dialog enables you to recalculate the trim with a minimum
amount of parameter re-entry. Target voltages need to be re-entered only if
the desired supply type is changed.

See Also »“Defining DC-DC Converter Models” on page 119
“Setting VMON Properties” on page 117

Setting Multiple VMON/Trim Properties

The easiest way to set multiple properties for a selected voltage monitor
(VMON) or high-voltage monitor (HVMON) is to use the Voltage Monitor &
Control Properties dialog box. The edited settings will then be displayed in the
Voltage editor.

To access the Voltage Monitor & Control Properties dialog box:

1. Select the tab in the Voltage editor for those settings that you want to
configure.

2. In the Pins Monitor/Trim column, double-click the VMON that you want to
configure. Alternatively, right-click and choose Edit from the pop-up
menu.

The Voltage Monitor & Control Properties dialog box opens and displays
the Voltage, Trim/Margin, or VID section, depending on the tab you
selected in the Voltage editor.

The number of tabs available in the Voltage Monitor & Control Properties will
depend on whether the selected VMON supports an associated TRIM pin.
Most of these properties can also be defined individually on the Voltage
spreadsheet.
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See Also “Setting VMON Properties” on page 117
“Setting Trim and Margin Properties” on page 118
“Configuring Voltage Sense (VMON) and Control (TRIM)” on page 115

Setting VMON Properties

The Voltage section of the Voltage Monitor & Control Properties dialog box
allows you to specify the nominal voltage and the logical names and trip
points for each comparator.

Schematic Net Name — This can consist of any combination of
alphanumeric characters.

Nominal Voltage — This defines both the nominal voltage and the closed
loop trim target value for voltage profile 0. If the value is 5.7V or more and
the monitor is not an HYMON, the voltage will be used to calculate an
external resistor divider and select an associated trip point. A negative
voltage will calculate a divider reference as well as the resistor divider.
Acceptable values are from -100 volts to 100 volts.

Logical Name — The logical names, for comparators A and B, are used in
the logic builder to control the sequence and equations based on the
VMON status.

Trip Point Selection — A specific VMON trip point, for comparator A and
comparator B, is associated with each logical name.

64 ps Glitch Filter — When selected, this option configures the comparator
so that supply glitches narrower than 64 microseconds are ignored. The
output will transition only if the changed status remains active for a period
longer than 64 microseconds. If this option is not selected, the comparator
output will toggle within 16 microseconds from the time the voltage
transitions through the appropriate trip point.

Window Mode — To use the window mode, the Comparator B threshold
should be lower than the threshold setting of comparator A. The window
mode output will replace the comparator A output. The window output is
logical high if the Comparator B output is high and the Comparator A
output is low (i.e., the voltage monitor reading is between Comparator A
and Comparator B).

External Resistor Divider — This section is used for monitoring a voltage
whose highest trip point exceeds 5.70V or is a negative voltage. These
values are calculated automatically when the nominal voltage specified is
negative or exceeds 5.70V. You can overwrite these values to work with
your preferred components.

Rsupply — Valid value range is 10 ohms to 10 M ohms

Rground — Valid value range is 10 ohms to 15 K ohms. The Rground
maximum value is restricted to maintain the accuracy of the voltage
monitors.

Divider Reference — Valid value range is 2.5 V to 6 V. The divider
reference is used when monitoring voltages below ground. The
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external divider is connected between the negative supply being
monitored and a positive reference supply.

See Also “Configuring Voltage Sense (VMON) and Control (TRIM)” on
page 115

Setting Trim and Margin Properties

The Trim/Margin section of the Voltage Monitor and Control dialog
boxenables you to configure the trim cell operating mode and desired output
voltages measured at a voltage monitor (VMON).

Trim Schematic Net Name — This can consist of any combination of
alphanumeric characters.

Trim Configuration Mode — The Trim Calculator, which is selected by
default, calculates resistor interface and DAC values from the target
voltages and DC-DC converter.

Manual trim configuration mode allows you to select the CLT loop polarity
and to manually enter the DAC code for each voltage profile.

DC-DC Converter — Select a DC-DC converter model from the drop-down
menu. The menu includes all of the models that are in the DC-DC Library.
To add a new model, scroll down and select Add/Edit DC-DC to open the
DC-DC Library Builder Wizard.

CLT Loop Polarity — If you selected Manual for the trim configuration
model, select the polarity for closed loop trim.

Voltage profile — Enter a desired output voltage for each profile. These
profiles are used, along with the nominal voltage profile (profile 0), as the
targets for the trim calculator.

DAC Output Range (BPZ Voltage) — If you are using the Trim Calculator,
the bipolar zero output voltage range will be calculated automatically. If
you are using manual trim configuration mode, select the value from the
drop-down menu.

If you have selected Trim Calculator for the trim configuration mode, click the
Calculate button after you have made your selections. The dialog box will
then provide the following information:

the resistor values needed to interface the DAC to the TRIM pin in the DC-
DC converter

the voltage that will be achieved with each of the voltage profiles
the DAC code needed to produce each of the desired output voltages
If a profile target voltage is outside an achievable range, it will be tagged with

*Error. To resolve errors, click the Error Details button and follow the
instructions for obtaining a possible solution.

Setting Trim Configuration Options Use the Trim Configuration Options
dialog boxto adjust settings and to help resolve a target voltage error.
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Click the Options button in the Trim/Margin Properties dialog box to set the
following options:

Maximum DAC Code Range — This setting and the Max Supply
Adjustment Range work together to define the sensitivity of the trim
system. The value entered defines the DAC value required to trim the
supply voltage by the amount specified in the Max Supply Adjustment
Range box.

Max Supply Adjustment Range — This value defines how much the power
supply output voltage will change when the DAC code is at the value in
the Maximum DAC Code Range box.

Attenuation Crossover Voltage — If the voltage in Voltage Profile O is
greater than the voltage in the Attenuation Crossover Voltage text box, the
DAC input attenuator will be enabled. The attenuation crossover voltage
should be selected so that the attenuation bit is turned on if any portion of
the trim range is over 2.048 volts. The default value of 1.9 volts is
appropriate in most cases.

Vbpz Selection — When Auto is selected, the bi-polar zero output voltage
is calculated automatically to reach all the target voltages. Selecting one

of the other voltages (0.6V, 0.8V, 1V, or 1.25V) can sometimes reduce the
number of resistors.

See Also “Configuring Voltage Sense (VMON) and Control (TRIM)” on page 115

Defining DC-DC Converter Models

The DC-DC Library Builder Wizard enables you to define the voltage
adjustment characteristics of DC-DC converters and voltage regulators. This
information is stored in a library so that any given model of DC-DC converter
can be used in multiple trim cells or Platform Designer projects without having
to re-enter the information each time.

You can add new DC-DC converter models to the library, delete models, or
edit the parameters of a model at any time by launching the wizard. Any
converter model in the library can be selected in the Trim/Margin portion of
the Voltage Monitor and Control dialog box.

You can launch the DC-DC Library Builder Wizard from the Global
Configuration view or from the Voltage Monitor and Control dialog box.

To launch the DC-DC Library Builder Wizard from the Global
Configuration View:

1. Inthe Global Configuration view, select the ASC Options tab.

2. Inthe DC-DC Options section of Global ASC Options, click Add/Edit
DC-DC.

To launch the DC-DC Library Builder Wizard from the Voltage Monitor
and Control dialog box:

1. Inthe Voltage view, select the Trim/Margin tab.
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4.

Double-click a cell in the DC-DC Converter column or a VMON/Trim cell in
the Pins Monitor/Trim column.

In the Voltage Monitor and Control dialog box, click the DC-DC Converter
drop-down menu.

Scroll down and choose Add/Edit DC-DC.

The DC-DC Library Builder Wizard provides the option of creating a new entry
in the library (using the New button) or modifying an existing entry. The flow
for both operations is similar, the only exception being that when an existing
entry is being edited, the previously saved parameters appear in the different
dialog box sections of the Wizard.

To define a DC-DC converter model:

1.

In the DC-DC Converter Model Selection, select a model from the list, or
click New to add a new model.

The Library Builder classifies all DC-DC converters and regulators into
four different families:

Supplies that can be adjusted up or down a few percent about a
nominal voltage by connecting a resistor between the supply’'s TRIM
pin and its output or ground.

Supplies that can be adjusted over a wide range by connecting a
resistor between the supply's TRIM pin and ground.

Supplies that can be adjusted over a wide range by connecting a
resistor between the supply’s TRIM pin and Vout.

Supplies that use an external feedback network. The Library Builder
calls this a “discrete” implementation.

Click Next to open the Select the type of DC-DC Converter section.
Select the type of DC-DC Converter and click Next.

The wizard opens the configuration section of the dialog box, which
enables you to set the parameters for the type of converter you selected.

For the Trim-up Trim-down supply type and the Programmable supply
type, the dialog box asks for several trimming examples to be entered,
and the supply's adjustment characteristics are determined from the data.
Many power supply data sheets provide tables of resistor values needed
to achieve various different outputs. These examples can be entered
directly into the dialog box.

For discrete implementation types, the dialog box requests the values of
the feedback network components and the internal reference voltage.
From the data, the supply's adjustment characteristics are determined.
When a specific model of voltage regulator will be used several times to
produce different voltages, separate library entries will be needed for each
unique set of feedback network components.

4. After setting the configuration parameters, click Finish.

See Also “Setting Multiple VMON/Trim Properties” on page 116

“Setting VMON Properties” on page 117
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“Setting Trim and Margin Properties” on page 118

Configuring Voltage Identification (VID)
Tables

Voltage identification tables define the target voltage outputs of a DC-DC
converter based on inputs of a selected bus. The VID section of the Voltage
Monitor and Control dialog box enables you to select and configure a VID
table for the selected voltage monitor. If your design does not yet contain VID
tables, you can build them and add them to the VID Table Library.

Building VID Tables The Voltage — VID Table Library interface enables you
to build a library of voltage identification tables. By default, Platform Designer
stores the VID tables inside the Diamond installation sub-directories. You can
specify a different location in the Global ASC Options section of the Global
Configuration View.

To create a new VID table:

1. Inthe Voltage editor, open the VID Table library dialog box by using one of
the following methods:

Open the Voltage Monitor & Control Properties dialog box by double-
clicking the VMON/TRIM cell. Select the VID tab, and choose Add /
Edit a table from the VID Lookup Table drop-down menu.

In the Global Configuration View, select the ASC Options tab. In the
VID Options section on the right, click Add / Edit a table.

2. Inthe VID Table Library dialog box, click New to open the Create New VID
Table dialog box.

3. Type a name for the VID table in the text box, and then select the table
size from the drop-down menu.

4. In the Auto fill section, specify a voltage starting value and step size.

Alternatively, you can manually enter each value in the table by double-
clicking each Voltage (V) cell and typing a value. If you choose manual
entry, skip Step 5.

5. Select either the Top Down or Bottom Up option, and then click Fill.

Platform Designer fills in the voltage for each VID value, based on the
step size and starting value. You can edit any of these values as desired.

6. Click OK.

The new VID table is added to the VID Library and will be listed in the VID
Table menu in the Voltage editor and in the Voltage Monitor & Control
Properties dialog box.

Selecting and Configuring the VID Table The VID page of the Voltage
editor enables you to select the VID lookup table from the VID Table Library
and select the bus, strobe port or node, and VID strobe edge. You can also
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select and configure the VID table from the Voltage Monitor & Control dialog
box.

Editing a VID Table To edit a VID Table, open the VID Table library dialog
box by using any of the methods described in Step 1. Select a VID table and
click Edit. In the Edit the VID Table dialog box, change the settings as desired
and click OK.

See Also “Configuring Voltage Sense (VMON) and Control (TRIM)” on page 115

Configuring Current Sense (IMON)

The Current editor allows you to set parameters for the current monitor
(IMON) and high-voltage current monitor (HIMON) for each Analog Sense
and Control device. Each monitor includes settings for two precision
comparators (A and B) and one fast (F) comparator.

Schematic Net Name — Each IMON or HIMON must be identified by a
unique name. The name can consist of any combination of alphanumeric
characters.

Logical Name — The monitor’s comparator outputs A, B, and F must each
be identified by a unique name. The name can consist of any combination
of alphanumeric characters.

Sense Resistor (Ohm) — The sense resistor value will be the same for all
comparators within the monitor and can range from .0001 to 1000000.0
ohms.

Trip Point Selection (Amps) — The selected trip point, for comparators A,
B, and F, will be associated with each logical name. The trip points
available are determined by the Sense Resistor value.

Hysteresis — Hysteresis can be enabled or disabled for comparators A
and B. This automatically updates the available trip point selections.

Glitch Filter (1) — The glitch filter can be enabled or bypassed for
comparators A and B. When Yes is selected, this option configures the
comparators so that supply glitches narrower than 64 microseconds are
ignored.

Window Mode — Window mode can be used for comparators A and B. To
use the window mode, the Comparator B threshold should be lower than
the threshold setting of comparator A. The window mode output will
replace the comparator A output. The window output is logical high if the
Comparator B output is high and the Comparator A output is Low.

Low Side Sense — When Yes is selected, this sets the low voltage side
sense for comparators A, B, and F. It is not available for high-voltage
sense monitors.

The Programmable Gain Amplifier (PGA) Gain setting is displayed by the tool
based on the selected trip points. This information is used when performing A/
D measurements of the current over 1°C.
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The V-Drop (V) and Peak Power (W) are calculated based on the values
entered for trip point and sense resistor.

See Also “Configuring Voltage Sense (VMON) and Control (TRIM)” on
page 115

Configuring Temperature Sense (TMON)

The Temperature editor allows you to set parameters for the external
temperature sensor interfaces (TMON1, TMONZ2, etc) and the internal
temperature sensor (TMON _Int). The temperature monitor function includes
an A/D converter measurement with averaging support, as well as an alarm
monitor function with programmable hysteresis and filtering. Each TMON
channel includes two separate programmable comparison points. The
temperature sensor hardware also supports a configurable offset and ideality
factor. The parameters for each temperature monitor comparator can be set in
Platform Designer’s Temperature editor, as follows:

Schematic Net Name — The schematic net name must be unique and can
consist of any combination of alphanumeric characters.

Logical Name — This must be a unique name that will identify each TMON
pin and comparator output. It can consist of any combination of
alphanumeric characters.

Monitoring Type — Over temperature (OT) or under temperature (UT)
monitoring can be selected.

Trip Point Selection — This sets the trip point for the comparator in degrees
Celsius.

Hysteresis — This defines the hysteresis for updating the trip point output
for the comparator.

Monitor Alarm Filter (Depth) — This sets the number of consecutive alarms
that must be detected before setting the comparator output high.

Measurement Averaging (Filter Coefficient) — This sets the coefficient on
the averaging filter implemented on the temperature sensing of the
TMON.

Offset — This calibration value is used to correct the temperature reading,
in degrees Celsius for the TMON.

Short Fault Measurement Reading — This defines the measurement
reading under a short fault condition. It implies the Open fault
measurement reading as well. See the Platform Manager 2 or MachXO2
data sheet for more details.

Ideality Factor — This calibration value is used to correct the diode
imperfection for the TMON.

Sensor Configuration — The external temperature monitors can be
configured to interface with several different transistor circuits.

See Also “Configuring Fan Control” on page 124
“Configuring Voltage Sense (VMON) and Control (TRIM)” on page 115
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Configuring Fan Control

Platform Designer’s Fan Controller provides fan control for 2-wire, 3-wire, or
4-wire fans. The fan controller supports multiple fan speeds, under-speed
alarm detection, and a configurable startup pulse. It enables you to set three
levels of speed control through the pulse width modulated (PWM) signal. Up
to 18 separate fans can be controlled.

To configure fan control:

1. Select Fan Controller from the menu pane, and then select a fan in the
“Fan in System” list or add a new fan by clicking the add button J¥ on the
lower left.

2. Inthe Type Setting section on the Parameters page, select the fan type
from the drop-down menu.

3. If you selected 3 Wire (Low Side Drive), 3 Wire (High Side Drive), or 4
Wire, also specify the Sense Type for alarm detection, as follows:

If the fan supports a locked signal as fan feedback to indicate that the
fan is locked or stuck, select Alarm (Active High) or Alarm (Active
Low).

If the fan includes a tachometer feedback signal, select Tach (2
Pulses/Rev), and then do the following:

In the Alarm Interval box, type a value for the number of ms that
will be allowed between pulses before an under-speed violation is
registered.

Select a value between 1 and 10 from the Alarm Filter Count. This
is the number of times the alarm interval must be detected before
the Alarm signal will be asserted.

With tachometer feedback, a +/- 10% hysteresis will be applied to the
corresponding assertion/de-assertion of the failure count to prevent a
false alarm.

4. Inthe PWM Setting section, use the sliders to select a duty cycle
percentage for Speed3, Speed2, and Speedl.

Each can be set in 5% increments, ranging from 5% to 95%. The fastest
speed must be assigned to Speed3, with the middle speed assigned to
Speed2, and the slowest speed assigned to Speedl.

5. Use the slider to specify the PWM frequency. The frequency can be set in
increments of 0.8 kHz, up to 80.0 kHz.

6. Select the polarity for the PWM signal, based on the nature of the
MOSFET switch and on-board buffers.

Refer to the fan data sheet and the board requirements for information
about the correct setting of PWM polarity.

7. Optionally, enable the Startup Control and select the pulse duration, in
increments of .25s for the startup period.

When startup control is enabled, the fan controller will send a kickstart
pulse of the chosen duration to the fan before switching to the selected
PWM setting.

Lattice Diamond 3.6 Help

124



DESIGNING WITH LATTICE DIAMOND PLATFORM DESIGNER : Setting Fault Logging Options

8. Select the InterConnections tab.

The InterConnections page allows you to specify the signals that the
Platform Designer will use as fan controller ports. Each fan has an
independent set of interconnections.

The PWM Out and Tach/Alarm Sense are the external connections to the
fan. The other signals (Speed Sel 1 ... Alarm Out) are logical connections
that set the operation of the fan controller during runtime.

9. Assign the PWM Out and Tach/Alarm Sense to external ports by dragging
the desired ports from the Signal Pool.

10. Drag the desired signals from the Signal Pool to set the logical
connections for Speed Sel, Run Off, Run Full, and Alarm Out.

See Also “Configuring Temperature Sense (TMON)” on page 123
“Configuring Voltage Sense (VMON) and Control (TRIM)” on page 115

Setting Fault Logging Options

The Fault Logger, available from the Components section of the menu pane,
enables you to specify and configure fault conditions that are logged to non-
volatile memory. You have the option of using standard fault logging that is
based on voltage, current, and temperature status; or using the full-featured
fault logging. By default, fault logging is disabled.

Each ASC device contains a block of EEPROM memory that can be used for
either the V, I, T Fault Log or for User Tag Operation. The User Tag Memory is
enabled automatically when fault logging is disabled or when full-featured
fault logging is selected. It is disabled when V, I, T fault logging is selected.

V, I, T Fault Logging When you select this option, the Analog Sense and
Control device will log the voltage (V), current (1), and temperature (T) status
when a fault is detected. The V, I, T fault log supports the logging of 8 signals
per Analog Sense and Control device, in addition to the V, I, T signals. These
can be digital 1/0 or other signals.

To configure V, |, T fault logging:

1. Inthe Fault Logger, select Enable V, |, T Fault Log from the options
shown at the top left.

2. Select a signal name from the Fault Logging Trigger Signal Name drop-
down menu. This signal can be an output from the user logic, an external
digital I/O, or a specific monitor alarm signal.

3. Inthe “Basic Configuration” section, select the type of memory to log to:
EEPROM or SRAM. The EEPROM is non-volatile, but a log takes longer
to execute. The SRAM memory is volatile but is executed more quickly.

4. The V, |, T fault log supports the logging of 8 signals per Analog Sense
and Control device in addition to the V, |, T signals. These can be digital I/
O or other signals. For each signal that you want to log, drag it from the
“User Signals to Log” list over to a D cell of the desired ASC.
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Full-Featured Fault Logging The full-featured fault logging uses either the
UFM Flash memory within the device or an external SPI flash memory. Full-
featured fault logging is available for Platform Manager 2 LPTM21 devices
and for MachXO2 devices of 1200 and above. ECP5U/UM devices support
full-featured fault logging with external SPI flash memory only - UFM is not
available in ECP5U/UM.

To configure full-featured fault logging (Platform Manager 2 and
MachXOz2 only):

1.

In the Fault Logger, select Enable Full-Featured Fault Log from the
options shown at the top left.

Select a signal name from the Fault Logging Trigger Signal Name drop-
down menu. This signal can be an output from the user logic, an external
digital I/O, or a specific monitor alarm signal.

n the “Basic Configuration” section, do the following:

a. From the drop-down menu, select the contiguous ASCs that you want
logged.

b. SelectInclude Timestamp if you want Platform Designer to include a
32-bit timestamp timer.

c. Select a signal to be used as the busy signal name from the “Busy”
Signal Name menu. This signal is an output from the fault logger and
can be used to inform the user logic that a fault log recording is in
progress.

d. Select a “Log to” option: the on-chip UFM memory or external SPI
flash.

e. If you selected External SPI Flash as the “Log to” option, use the
Model drop-down menu to select the external flash model to be used
for fault logging.

In the User Log Fields menu, located above the user log table on the right,
select the number of additional bits to record in the fault log.

For each additional signal that you want to log, drag it from the “User
Signals to Log” list over to a D cell of the desired user log column.

To configure full-featured fault logging (ECP5U/UM only):

1.

3.

In the Fault Logger, select Enable Full-Featured Fault Log from the
options shown at the top left.

Select a signal name from the Fault Logging Trigger Signal Name drop-
down menu. This signal can be an output from the user logic, an external
digital I/O, or a specific monitor alarm signal.

Select a signal to be used as the busy signal name from the “Busy” Signal
Name menu. This signal is an output from the fault logger and can be
used to inform the user logic that a fault log recording is in progress.

In the “Basic Configuration” section, do the following:

a. From the drop-down menu, select the contiguous ASCs that you want
logged.
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4,

b. Select either Disable Time Stamp, Internally Generated Time Stamp,
or Externally Assigned Time Stamp. The internally generated
timestamp option includes the 1s per bit, 32-bit timestamp. The
externally assigned timestamp option will automatically update the
Nodes view to include a 32-bit node group, called FL_Timestamp,
which can be assigned by the user based on an external, highly
accurate timestamp.

c. In SPI Memory Configuration, select Log to Configuration SPI Memory
or Log to Alternate SPI Memory.

d. Use the Model drop-down menu to select the external flash model to
be used for fault logging.

In the User Log Fields menu, located above the user log table on the right,
select the number of additional bits to record in the fault log.

For each additional signal that you want to log, drag it from the “User
Signals to Log” list over to a D cell of the desired user log column.

In the “Fault Log Memory Space” section, do the following:

a. Enter the Start Address. This is a Hex input used by the IP to
determine the starting address available to the fault logger. This
setting allows the user to share the SPI memory with multiple boot
images or other information. The default address is 0x030000.

b. Enter the size in K Bytes.

c. The End Address is automatically calculated and displayed by
Platform Designer. The displayed value confirms for the user that it is
safe to share the SPI memory with multiple boot images or other
information.

The full-featured fault logger automatically adds a 16-bit node group
called FL_Record_Counter to the nodes view. This nodes group can be
connected to user logic to provide the number of Fault Records currently
stored in memory.

See Also “Configuring a SPI Flash Model” on page 114

Configuring Hot Swap

(Platform Manager 2 and MachXO2 only.) Platform Designer's Hot Swap
utility enables you to configure a hot swap component that will control the in-
rush current in applications where power is rapidly applied, such as a circuit
board that is plugged into a backplane. The Hot Swap utility contains a
separate page for each of the following three tasks:

Hot Swap — Specify the settings of a hot swap component.

Interface — Connect the hot swap component to the Platform Manager 2
resources.

InterConnections — Connect the hot swap component to the hardware
management logic.
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To specify the settings of a hot swap component:

1.
2.

Select Hot Swap from the Components section of the menu pane.

On the Hot Swap page, select a hot swap component from the list or
create a new hot swap component by clicking the add button “i* on the
lower left.

Specify the desired options and settings:
Input Supply

VN — Input voltage. This is the supply voltage input, which is used
to charge C| pap- Together with Iy ax, C oap and the MOSFET

SOA (Safe Operating Area) information will be used to calculate
the hot swap parameters, including the number of phases, voltage
and current trip points.

Ivax — Maximum current available from the input supply.

MOSFET Parameters

Load/Supply — Allows you to place the MOSFET at either the
Supply or the Load. Select the setting that matches your
application.

MOSFET Name — Used, for informational purposes only, to track
the part number of the MOSFET in your application.

V1/A1l — Voltage/Current data point pair from the MOSFET SOA
curve found in the MOSFET datasheet.

V2/A2 — Voltage/Current data point pair from the MOSFET SOA
curve. V1 must be greater than V2, and A1 must be less than A2.

Current Sensing Configuration

Rg — Sense Resistor used in the application. Platform Designer

uses this sense resistor value to calculate available current
sensing trip points.

Current Sense Amp choices — Determines the current sense amp
circuit used in the application.

The choice among “External and VMON,” “External and IMON,”
and “IMON (Internal)” will determine whether additional current
sensing circuit information is required. The choice also determines
which monitor circuits are available for assignment in the Interface
tab. Certain configurations of V,y and Current Sense Amp are

prohibited, such as using IMON (Internal) with V,y voltages above
13.2V.

Low Side option — Determines whether the IMON is used in a near
ground hot swap application (such as -48V). Selecting this option
enables the Low-Side Sense feature in the IMON circuit.

Hot Swap Settings

CLoap — The load capacitor charged up during the hot swap
operation. This value is used to calculate the hot swap
parameters, including the number of phases and the voltage and
current trip points.
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4.

Fast Shutdown Limit — Sets the current limit for fast shutdown
during hot swap. The menu is automatically populated with
available current limit trip points related to the Sense Resistor and
Current Sense Amp settings. If the current exceeds the selected
limit during hot swap, the hot swap will be aborted and the over
current error signal will be asserted. This feature can be disabled
by selecting “None.”

Cooldown Period — The period used by the hot swap algorithm to
ensure that the MOSFET does not overheat. Each time the hot
swap algorithm detects a timeout, remaining in a phase longer
than 10 ms, the cooldown period will be used as a wait time prior
to resuming the hot swap operation.

Hot Swap Name — A user-defined name for the hot swap setup.
After all the parameters have been selected, click the Calculate button.

The V| oap and Ip graphs are updated with the estimated Voltage and
current profiles based on the calculated Hot Swap algorithm and settings.
The Results/Comments area is updated with information, including the
number of hot swap phases and the number of VMON and IMON
channels required to support the hot swap implementation.

The hot swap calculation might not be able to provide a solution for all
circuit configurations. In this case, error information is displayed in the
Diamond message console.

If the results are not satisfactory, adjust the settings and calculate again.

To connect the hot swap component to Platform Manager 2 resources:

1.

After you are satisfied with the hot swap calculation results, select the
Interface tab.

The Interface page consists of several menus that are used to assign
VMONSs, IMONs, HVOUT, GPIO and PIO channels to the different hot
swap functions. When you assign VMON, IMON, and HVOUT channels in
the Interface tab, their settings, such as trip point thresholds, will be
updated automatically.

Select the desired setting from each of the drop-down menus in the gold-
colored boxes, as follows:

VN Monitor — Associates a VMON channel with the input voltage

monitoring function of a given hot swap. This VMON channel can be
re-used across multiple hot swap components, if they use the same
input voltage. The V|y Monitor can be from any ASC in the Platform

Manager 2 system.

Selecting a V| Monitor is mandatory.

ASC - Specifies the ASC device to be used. The ASC menu is
automatically populated with the ASCs used in the system. All
channels from the drop-down menus inside the pink rectangle will be
selected from the chosen ASC.
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MOSFET/Charge Pump Driver — Associates an HYOUT or GPIO with
the controlled output signal used in the hot swap algorithm.

Selecting an HVOUT or GPIO is mandatory.

Current Sensing Monitor — Specifies the IMON or VMON channel for
current sensing. The channels available are those that support the
configurations that were set on the Hot Swap page.

Selecting a current sensing monitor is mandatory.

Fast Current Sense Monitor — Specifies an IMON or VMON channel
for fast current sense. This menu is used only when a fast shutdown
limit is selected on the Hot Swap page. It is used in conjunction with
the fast current sense output, fast path input, and fast shutdown
signal.

Fast Current Sense Output — Specifies an HYOUT or GPIO as a fast
output signal. This menu is populated with the output signals available
on the ASC.

Fast Path Input — Specifies a signal for fast path input. This menu is
populated with the PIO signals from the FPGA 1/0O used in the Platform
Manager 2 system. The signal should be externally connected to the
fast current sense output signal in the application.

Fast Shut Down Output — Specifies a signal for fast shutdown output.
This menu is populated with the PIO signals from the FPGA 1/O used
in the Platform Manager 2 system. The signal is controlled by the hot
swap IP and will perform a fast shutdown of the MOSFET when
necessary.

Load Voltage Monitor(s) — Specifies the load VMON or HYMON. This
menu is populated with the voltage monitor channels from all ASCs in
the Platform Manager 2 system. The number of drop-down menus
available is determined by the number of phases required by the hot
swap algorithm. These menus can be filled with voltage monitor
channels from any ASC in the system.

Selecting a load voltage monitor from each available menu is
mandatory.

To connect the hot swap component to the hardware management logic:
1. Select the Interconnections tab.

The Interconnections page includes a set of control signals that are used
to connect the hot swap component to the hardware management logic.
Each of these signals is typically assigned to a node.

2. Drag the desired signal from the Signal Pool over to the appropriate box,
as follows:

Hot Swap Enable — Input signal to the hot swap component. Asserting
this signal high will start the hot swap operation.

Over-Current Clear — Input signal to the hot swap component. This
signal needs to be asserted to clear any existing Over-Current Error
status.
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Hot Swap Done — Output signal from the hot swap component. This
signal is asserted by the hot swap component to inform the hardware
management logic that the hot swap operation was successfully
completed. This signal is cleared when the hot swap enable signal is
asserted again.

Hot Swap Error — Output signal from the hot swap component. This
signal is asserted by the hot swap component to inform the hardware
management logic that an error occurred during the hot swap
operation. This signal is cleared when the hot swap enable signal is
asserted again.

Over-Current Error — Output signal from the hot swap component.
This signal is asserted by the hot swap component to inform the
hardware management logic that an overcurrent error occurred during
the hot swap operation. This is in addition to the fast path shutdown
behavior. This signal will be cleared when the over-current clear signal
is asserted.

Configuring PMBus Adapter

(Platform Manager 2 and MachXO2 only.) PMBus is a serial communication
bus that allows a microcontroller to configure and monitor Digital Point of
Load (DPOL) DC-DC Converters. The PMBus Adapter allows the connection
of analog POLs to the PMBus controller using the FPGA and ASC. Multiple
POLs may be mapped to different pages configured in the PMBUS adapter.
Dedicated pages for voltage, current, and temperature monitoring are
provided.

The PMBus adapter supports Packet Error Checking and SMBAlert options.
The PMBus adapter supports a pre-defined subset of PMBus commands.

To configure PMBus Adapter:
In the PMBus Adapter tab, select Enable PMBus Adapter at the top left.

The PMBus tab contains controls and the ASC Page Mapping table
control. When Enable PMBus Adapter is checked, controls and the
related PMBus Nodes tab are enabled. To view PMBus ports and nodes,
refer to “Viewing PMBus Ports and Nodes (Platform Manager 2 and
MachXO2 Only)” on page 133.

The following options are available to configure PMBus Adapter:

Enable packet Error Checking (PEC) Enables/disables the packet error
checking option.

Enable SMBAlert Enables/disables the SMBAlert output pin..

PMBus Bus Speed Specifies PMBus bus speed. The two available values
are 100KHz and 400KHz.
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PMBus Slave Address Specifies PMBus slave address. Only legal slave
addresses are selectable from the drop-down list.

ASC Page Mapping Specifies the PMBus page mapping of voltage
monitors (VMONSs), Current Monitors (IMONs) and Temperature Monitors
(TMONSs) of the ASC devices in the design. The resource list view on the left
contains the VMON , IMONs, and TMON signals that are part of the current
design. The user can drag and drop the VMON. IMON, and TMON signals
from the resource list view and assign them to PMBus pages on the right.

VMON, IMON, and TMON signals can be assigned to page numbers as
follows:

VMON - 0x00-0x2F

IMON - 0x30-0x3F

TMON - 0x40-0x5F

The default values on the ASC page mapping table views is None. When the
user drags the VMON, IMON, or TMON signals from the resource list on the
left and drops it in the table view, a dynamic design rule check (DRC) is
performed in the background to verify whether the assigned page is valid or
conflicts with already assigned pages.

Implementing the Platform Management Algorithm

Implementing the platform management algorithm involves labeling and
configuring ports and nodes, and then building logic instructions based on
these configurations. In Platform Designer, it involves the use of the Ports &
Nodes editor and the Logic editor.

See Also “Designing Control Sequences” on page 139

Configuring and Viewing Ports and
Nodes

Use the Ports & Nodes editor to view internal nodes and configure external
signals (ports) of the Platform Manager 2 or MachXO2/ECP5U/UM device;
configure and label the ASC-based general-purpose 1/Os; view PMBus Ports
and Nodes; and label and configure the high-voltage output ports. You can
build control logic based on the labels you apply.

See Also “Designing Control Sequences” on page 139

Configuring Ports

The Ports section of the Ports & Nodes editor shows all physical FPGA-based
P1Os that are available for use as external connections to the design.
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You can assign a user label to a logical port. A port requires a type: IN, OUT,
INOUT or GRESET. The port also includes attributes for group, register type
and reset level.

For register type, in addition to Registered or Combinatorial, you have the
option of using “Registered Sync with ASC.” The MachXO2/ECP5U/UM
output is much faster than the ASC output because of the 3-wire interface
propagation delay. So when you select the “Registered Sync with ASC”
option, Platform Designer will add a delay for MachXO2 outputs to make sure
that they are triggered in the same step.

After the design is compiled, you can cross-probe from the Ports sheet to
Diamond’s Spreadsheet View or Netlist View to make pin assignments. Right-
click a cell and choose Show In > Spreadsheet View or Show In > Netlist
View.

Viewing PMBus Ports and Nodes (Platform

Manager 2 and MachXO2 Only)

The PMBus tab is enabled only if the PMBus Adapter is enabled. For
information on enabling PMBus Adapter, refer to “Configuring PMBus
Adapter” on page 131.

The PMbus tab lists all of the available PMBus ports/nodes that can be
connected to the Logic Controls, including Sequence, Supervisory equation,
and HDL Import. These nodes are managed in the user logic in order to
complete the configurable PMBUS support.

The PMBus ports/nodes table view includes three read-only columns:
Logical Name/Function The node names listed in this column are the

nodes that are added to the user signal pool and which connect the logic to
the PMBus Adapter for support of PMBus commands..

Grouped By This column lists the PMBus status word or byte name with the
correct bit index. Nodes that are not used are set to zero.

Logic Connection This column shows the node direction with respect to
the user logic; In goes into the user logic and Out is driven from the user logic.
See Also »“Creating a Port Group” on page 133

“Designing Control Sequences” on page 139

“Working with Platform Designer Editors” on page 109

Creating a Port Group

The group feature allows you to combine ports of a common type, using
vector notation, to form a bus. The selected ports cannot be shared among
multiple groups.
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To create a port group:

1. On the Ports sheet or the Nodes sheet, right-click any cell of a port or
node that is not already part of a group and choose Add Group from the
pop-up menu.

2. Inthe New Group dialog box, type a hame for the group in the Group
Name text box.

3. From the Available Ports list, select the ports that you want to include in
the group, and then click the - button to place the ports in the Selected
Ports list. o

4. Click Add.

To modify a port group:

1. Right-click a cell in the Group By column that references the port group
you want to edit and choose Modify Group from the pop-up menu.

2. In the Modify Group dialog box, use the appropriate buttons to add ports
to the Selected Ports list or remove them from the list.

3. Click Update.

To remove a port group:
Right-click any cell and choose Remove Group. From the sub-menu,
select the group you want to remove.

See Also »“Designing Control Sequences” on page 139

“Working with Platform Designer Editors” on page 109

Configuring Nodes

The Nodes sheet enables you to add and configure internal nodes in your
design. You can assign user labels to new and existing nodes and select the
register type and reset level attributes.

To add a node:

1. Press the Insert key, or right click an existing node and choose ADD
NODE.

2. Assign a unique name to the node and select the Register Type and
Reset Level.

To delete one or more nodes:

Highlight the rows you want to delete by selecting the row numbers in the
first column, and then press the Delete key. Alternatively, right-click and
choose REMOVE NODE(s).

Nodes can also be grouped, following the same process as described in
“Creating a Port Group” on page 133.
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Some nodes are automatically allocated to the component logic or other
features such as fault log enable and timers.
See Also »“Designing Control Sequences” on page 139

“Working with Platform Designer Editors” on page 109

Configuring General-Purpose 1/0s

The GPIO sheet allows you to enable and assign a user label to an
ASC-based general purpose 1/0.

For each GPIO pin, you can specify the following:
A unique name to identify the pin.
The type: IN or OUT
Reset Level: Set High or Set Low

For pins GPIO2 and GPIO3 of each ASC, you can also select the following:
Source

Polarity: True or Inverted

See Also “Designing Control Sequences” on page 139

Configuring High-Voltage Outputs
The HV Outputs sheet allows you to enable and assign a user label to a high-
voltage output port.
For each HVOUT pin, you can specify the following:
A unique logical hame to identify the HVOUT pin.
The output setting: Charge Pump or Open Drain
The target voltage for the output (Charge Pump mode only)

The source current in micro-amps for the output (Charge Pump mode
only)

The sink current in micro-amps for the output (Charge Pump mode only)
The output mode: Static or Switched

The selected frequency for the ouput in kHz (Switched mode only)

The duty cycle for the output (Switched output mode only)

The output source

The output polarity: True or Inverted

A high or low reset level
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Designing with the Logic Editor

Included with the Lattice Diamond Platform Designer is the LogiBuilder™
Logic editor, which enables you to define a power supply sequence controller
and monitor or other control circuits for implementing the platform
management algorithm. The tools include a set of instructions for building the
sequence based on conditional events and timer delays.

See Also
“Designing Control Sequences” on page 139

“Sequence Controller Instruction Set” on page 137

About the Logic Editor

The Logic editor simplifies the design process by allowing you to select from
menus instead of writing complex code. It enables you to add and configure
timers and import HDL modules. It also supports vector notation for bus
structures.

After entering the set of instructions, you can compile the design and simulate
the sequence or control events. When the design is compiled, synthesizable
HDL code is generated based on the sequencer and supervisory logic.

“Designing Control Sequences” on page 139

“Sequence Controller Instruction Set” on page 137

Logic Editor User Interface

The LogiBuilder Logic editor includes separate views for building the logic
instructions and exceptions, entering supervisory equations, and defining
timers. An additional view is provided that allows you to import HDL modules
into your design.

Sequence — The Sequence view enables you to define the step-by-step
instructions for controlling outputs for a selected state machine. When
compiled, sequencer instructions implement a digital logic state machine
within the PLD core.

Exceptions — The Exceptions section allows you to define equations
that will trigger sequence controller exceptions to modify outputs and
jump out to an alternative sequence step. Exceptions can be
selectively applied to any sequencer step. When compiled, exception
instructions are merged with the digital logic state machine of the PLD
core.

State Machine — A tab for each state machine is shown at the bottom
of the Sequence view, which allows you to select the active state
machine for editing. You can also add a new state machine by clicking
the + tab. Right-click a state machine tab to open the Multiple State
Machine dialog box, which enables you to add and delete state
machines.
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Supervisory — The Supervisory view enables you to define combinatorial
and registered logic independent of the sequencer control logic. When
compiled, supervisory equations are concurrent to the digital logic state
machine of the PLD core.

Timers — The Timers view enables you to define timers for control
sequences. To add a new timer, press the Insert key or click the Add
button.

Imported HDL — The Imported HDL view enables you to add HDL
modules from HDL source that is included in the design project.

See Also »“Designing Control Sequences” on page 139
“Managing Multiple Control Sequences” on page 140.
“Entering Supervisory Equations” on page 144
“Defining Timers” on page 140

“Sequence Controller Instruction Set” on page 137

Sequence Controller Instruction Set

The LogiBuilder Logic editor of Platform Designer provides the following
instructions for designing control sequences:

BEGIN STARTUP SEQUENCE The BEGIN STARTUP SEQUENCE
instruction signals to LogiBuilder that any instructions past this point may be
interrupted by jumps specified in exceptions. This instruction may be deleted
from a sequence, but not inserted.

OUTPUT The OUTPUT instruction is used to turn on or turn off the output
signals. A single OUTPUT instruction can be used to simultaneously change
the status of any number of output signals.

WAIT FOR <Boolean Expression> The WAIT FOR <Boolean expression>
instruction suspends execution of the sequence until the specified expression
becomes TRUE. Outputs can be assigned in this instruction. These outputs
are asserted as soon as the sequencer enters the instruction.

WAIT FOR <Boolean Expression> with Timeout The WAIT FOR
<Boolean expression> with Timeout instruction suspends execution of the
sequence until the specified expression becomes TRUE or the selected timer
expires. The timer is started when the sequence enters the instruction.

WAIT FOR <timeout> The WAIT FOR <timeout> instruction is used to
specify a fixed delay in the execution sequence. The value of <timeout> is
determined by which timer is specified. (The timer must first be configured on
the Timers page).
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IF <Boolean Expression> THEN GOTO <step x> ELSE GOTO <step y>
The If/Then/Else instruction provides the ability to modify sequence flow
depending on the state of inputs. If <Boolean expression> is TRUE, the next
step in the sequence will be <step x>, otherwise the next step will be <step

y>.

IF <timeout> THEN GOTO <step x> ELSE If <Boolean Expression>
GOTO <step y> ELSE GOTO <step z> This instruction provides the ability
to modify sequence flow depending on the state of inputs with an additional
timeout feature. If Timer <n> has expired, the next step in the sequence will
be <step x>; otherwise, if <Boolean expression> is TRUE, the next step will
be <step y>. If <Boolean expression> is FALSE and Timer <n> has not
expired, then the next step will be <step z>. This instruction only checks the
values of <Boolean expression> and Timer <n>; it does not start or reset the
timer.

GOTO <step x> The GOTO instruction forces the sequence to jump to
<step x>.

Start Timer This instruction starts the selected timer. The status of the timer
must be checked using another instruction or combinational logic.

Stop Timer This instruction stops and resets the selected timer.

NOP The NOP instruction does not affect any of the outputs or the
sequence of execution. It is effectively a single-cycle delay.

HALT The HALT instruction stops execution of the sequence.

BEGIN SHUTDOWN SEQUENCE The BEGIN SHUTDOWN SEQUENCE
instruction signals to LogiBuilder that any instructions past this point will not
be interrupted by jumps specified in exceptions. This feature allows code
used for handling exceptions not to be interfered with by other exceptions that
may occur. This instruction may be deleted from a sequence, but not inserted.

General Information on Instructions

All instructions are able to assign outputs, except for NOP, BEGIN STARTUP
SEQUENCE, and BEGIN SHUTDOWN SEQUENCE. The outputs are
assigned immediately when the sequencer enters the instruction.

The GOTO and If/Then/Else instructions cannot jump to the Wait for (timeout
value), Wait for (Boolean) with Timeout, or Start Timer instruction.

See Also »“Designing Control Sequences” on page 139
“Managing Multiple Control Sequences” on page 140
“Editing Sequence Instructions” on page 141

“Entering Supervisory Equations” on page 144
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Designing Control Sequences

The sequencer instructions define the steps for controlling selected outputs.
The exceptions define the equations that will trigger sequence controller
exceptions to modify outputs and jump out to an alternative sequence step.
Exceptions can be selectively applied to any sequencer step. When compiled,
the control sequence instructions implement a digital logic state machine
within the PLD core.

To design a control sequence:

1.

In the LogiBuilder Logic editor, select the Sequence tab. If your design
uses multiple state machines, select the one that you want to use for the
sequencer instructions.

In the sequence (upper) portion of the editor, click Step 1 Begin
Shutdown Sequence to highlight it.

Double-click Step 1 or press the Insert key on your keyboard to open the
Insert Step Dialog box.

In the dialog box, choose an instruction type, and click OK. Repeat as
necessary to add sequence steps.

Double-click each instruction step to open the appropriate Edit Properties
dialog box.

Select the desired instruction properties in the Edit dialog box, and click
OK.

To add exceptions, do the following:

a. Double-click <end-of-exception-table> in the exceptions (lower)
portion of the editor, or highlight it and press the Insert key.

b. Repeat as necessary to add additional exceptions.

c. Double-click each exception placeholder, to open the Exception
Properties dialog box. Alternatively, right-click the placeholder and
choose Properties.

d. Click the Edit button at the top right of the dialog box to open the
Boolean Expression Editor. Set the expression that will trigger the
exception and click OK.

e. Inthe Exception Properties dialog box, select the desired exception
properties, and click OK.

See Also »“Sequence Controller Instruction Set” on page 137

“Editing Sequence Instructions” on page 141
“Editing Exceptions” on page 144

“Managing Multiple Control Sequences” on page 140
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Managing Multiple Control Sequences

The LogiBuilder Logic editor supports multiple state machines for power-up
sequence and control. The state machines are defined separately but can
interact through nodes or common logic functions. Each state machine is built
up in a separate tab in the Sequence section of the Logic editor.

To manage multiple control sequences:
1. Inthe LogiBuilder Logic editor, select the Sequence tab.

The name of each currently defined state machine is displayed in a
separate tab at the bottom. You can add a new state machine by clicking
the tab that contains the + sign. To delete a state machine, you must use
the Multiple State Machines dialog box.

2. Right-click a tab for a state machine and choose Multiple State Machine
from the pop-up menu. Alternatively, use the Ctrl+M keyboard shortcut.

3. Inthe Multiple State Machines dialog box, do one or all of the following:

Select a state machine and type a unique name for it in the State
Machine Name text box.

Delete a state machine by selecting it and clicking Delete SM.
Click Add SM to add a new state machine.
4. Click OK.

See Also »“Sequence Controller Instruction Set” on page 137

“Designing Control Sequences” on page 139

Defining Timers

Use the LogiBuilder Logic editor to set up timers for control sequences. After
you have defined timers, they will be displayed in the properties dialog boxes
for sequences that include timeouts. This will allow you to select the timeout

value from the list.

To define a timer:
1. Inthe Logic editor, select the Timers tab.

2. Click the Add button at the bottom or press the Insert key to create a new
timer.

The timer is added to the list and given a default name.

3. If desired, click the default name in the Timer Name column and type a
unigue name.

4. Click the Clock Source cell and select a source from the drop-down menu.
ECP5U/UM only support the 62.5 kHz logic sequence clock as a timer
source clock.
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5. Click the Period Cell. Select a time unit from the drop-down menu, and
then specify the value.

Note

Timer delay settings must be longer than 160 ps.

The number of LUT resources required to generate the timer is
automatically recalculated.

See Also “Sequence Controller Instruction Set” on page 137

Editing Sequence Instructions

The dialog boxes provided by the Logic editor enable you to set up and edit
sequence instruction properties, Boolean expressions, and exceptions. The
appropriate dialog box automatically opens when you double-click an inserted
step or exception for editing.

See Also “Sequence Controller Instruction Set” on page 137

Editing Boolean Instruction Properties

When you double-click a Boolean step for editing, the appropriate properties
dialog box opens. Each Boolean instruction’s properties dialog box allows you
to define output control properties, specify whether the instruction is
interruptible by an exception, edit the Boolean expression, and enter
descriptive comments. Boolean expressions such as conditional branches,
also allow you to specify “timeout” and “goto” properties.

Edit “Wait for Bool” Properties This dialog box allows you to define a
“wait for” Bool statement and specify output signal values.

Edit “Wait for Bool With Timeout” Properties This dialog box allows you
to set up a “wait for” Boolean statement with an auto timeout. If the Boolean
condition is met before the selected timer expires, the sequencer will continue
to the next step. If the condition is not met and the timer expires, the
sequencer will go to the specified step. The timer is started when the
sequence enters this instruction step. The “with output” option specifies
output signals that occur after the timer expires and transitions to the “Then
Goto” step.

Conditional Branch (IfThenElse) This dialog box enables you to set up a
conditional statement that checks a Boolean condition and then branches to
an instruction step.

The sequence will jump to the selected “Then Goto” step if the condition is
true. The “With Output” option specifies output signal values that occur
after the “Then Goto” transition.

The sequence will jump to the selected “Else Goto” step if the expression
is false. The “With Output” option specifies output signal values that occur
after the “Else Goto” transition.
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Edit “IfThenElse with Timeout” Properties This dialog box allows you to
set up a conditional statement that checks a Boolean condition and the status
of a timer.

If the timer has expired, the sequencer will go to the “On Timeout Goto
Sequencer step.” The “with Output” option specifies output signal values
that occur after the step transition.

If the Boolean condition is met before the selected timer expires, the
sequencer will go to the selected “Goto Sequencer step if no timeout and
the Boolean expression is satisfied” step. The “With Output” option
specifies output signal values that occur after the step transition.

If neither the Boolean condition is met nor the selected timer has expired,
the sequencer will go to the “Else Goto Sequencer step.”

Note

This instruction checks the selected timer but does not start it. The timer must be
started using a “Start Timer” instruction or supervisory logic.

See Also “Sequence Controller Instruction Set” on page 137

Editing Boolean Expressions

The Boolean Expression Editor allows you to set up a Boolean expression
using logic operators and a list of available inputs. You can enter the
expression manually in the Expression text box at the top or select from the
Logic Signal Pool and operators.

To edit a Boolean expression:

1. Onthe Sequence page, double-click the Boolean instruction that you want
to edit.

2. Inthe Edit properties dialog box, click Edit Boolean Expression.

You can enter the Boolean expression manually, if desired, by typing it
into the Expression text box at the top and clicking OK. Otherwise,
proceed with Steps 3-5.

3. Double-click a signal or bus from the Logic Signal Pool to add it to the
expression.

You can use the Filter input box below the signal pool to reduce the
number of signals available. The signal pool only displays signals with the
character string contained in the filter box.

4. Click the desired operator to add it to the expression.

The following special vector operator is available for comparisons
between buses and single-bit signals:

BITEXTEND (#) — Extends single bit to <wide> type vector. The
BITEXTEND operator is only valid for single-bit signals.

5. Click OK.
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The Boolean Expression Editor checks the expression for correctness and
will issue a message if an error is encountered.

See Also “Sequence Controller Instruction Set” on page 137

Editing Timeout Properties

The properties dialog boxes for “Wait for Timeout,” “Start Timer,” and “Stop
Timer” enable you to select a defined timer, specify outputs, and specify
whether the step can be interrupted by an exception.

All properties dialog boxes for sequence instructions that include timeouts—
for example, the “Wait for Bool with Timeout"—allow you to select from a
“Timeout” list of timers that have been defined. The properties dialog boxes
for these instructions do not allow you to change the clock source and period
for a selected timer. To do this, you must use the Timers sheet.

See Also »“Defining Timers” on page 140.

Editing Goto, NOP, and Halt Properties

The Edit “Goto” instruction properties dialog box allows you to specify the
destination step for a GOTO (or branch) type of instruction, set the output
signal values, enter a comment, and specify whether the instruction is
interruptible by an exception.

The Edit NOP Properties dialog box allows you to enter a comment and
specify that the NOP instruction is interruptible by an exception. A NOP step
is essentially a single-cycle delay; it does not affect any of the outputs or the
sequence of execution.

The Edit Halt Properties dialog box allows you to specify output values, enter
a comment, and specify that the instruction is interruptible by an exception. A
Halt step stops the execution of the sequence.

See Also »“Sequence Controller Instruction Set” on page 137

Editing Outputs

The Edit Output Properties dialog box enables you to select the outputs for a
sequence instruction. It is immediately available when you double-click an
Outputs instruction. For other instructions, it is accessible through the “Output
Control” button or “With Output” button of the properties dialog box for the
selected sequence.

Any single signal can be set to “Do not Modify,” which preserves the signal
value; or it can be set to a binary, hexadecimal, or decimal literal value.

Port groups can also be set to Increment, Decrement, Increment with
Saturation, or Decrement with Saturation. These operations support counter
implementations in the logic. The “with Saturation” instructions will saturate at
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all Os (decrement) or all 1s (increment). The decrement and increment
operations will roll over.

See Also »“Creating a Port Group” on page 133

Editing Exceptions

You can add an exception for use in a control sequence by double-clicking the
<end-of-exception-table> line in the Exceptions section of the Sequence page
or selecting it and pressing the Insert key. Afterwards, double-click the
inserted exception placeholder to set the properties.

In the Exception Properties dialog box, you can type the expression that will

trigger the exception in the Expression text box at the top. Alternatively, click
the Edit button to open the Boolean Expression Editor and select the signals
and operators for the expression.

Select the step that the sequence will go to when the exception is
encountered.

Then, in the Logic Signal Pool, you can select output signals or groups that
will be modified when the exception occurs.

Note

Any output signals that are controlled by the exception expression are active at all
times. These outputs will be modified, even if the sequence is currently in a non-
interruptible step.

See Also »“Designing Control Sequences” on page 139
“Editing Boolean Expressions” on page 142

“Sequence Controller Instruction Set” on page 137

Entering Supervisory Equations

The supervisory equations define combinatorial and registered logic
independent of the sequencer control logic. The supervisory equations are
always active and execute in parallel to the sequencer logic.

To enter supervisory equations:
1. Inthe LogiBuilder Logic editor, select the Supervisory tab.

2. Insert an equation placeholder by double-clicking the <end-of-
supervisory-logic-table> marker. Alternatively, highlight the marker and
press the Insert key on your keyboard.

3. Double-click the equation placeholder to open the Supervisory Logic
Equation Entry dialog box.
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4. Select the output signal of the Supervisory equation. The output signal is
chosen from the available pool, which can be reduced using the filter
input. Output signal groups can also be assigned.

5. Choose the assignment type. A signal can be assigned combinatorially, as
D flip-flop, or as asynchronous set or reset. Only signals that are already
assigned in the sequence, or assigned as D flip-flop in other equations,
can be assigned as asynchronous set or reset.

6. Edit the expression either directly in the expression or click Edit to use the
Boolean Expression editor.

7. Click OK to complete the equation definition.

Note

The sequencing, exceptions, and supervisory equations are combined together during
the compilation process. Outputs that are already assigned in the sequence cannot be
assigned as D type in the logic equations. They can only be accessed by
asynchronous reset or preset equations.

See Also »“Editing Boolean Expressions” on page 142

Copying and Pasting Sequences and
Equations

The LogiBuilder Logic editor allows you to copy, cut, and paste control
sequences, exceptions, and supervisory equations. If you are copying
multiple instructions, they must be contiguous.

To copy or cut and paste in the Logic editor:

1. Select the sequences, exceptions, or equations that you want to copy or
cut.

Note

The Begin Startup Sequence, Halt (end of program), <end of exceptions table>,
and <end of supervisory table> cannot be included in your selection. If you include
them, you will receive an error message.

2. Choose Edit > Copy or Edit > Cut or use the Ctrl+C or Ctrl+X keyboard
shortcut.

3. Select the step, exception ID, or equation, where you wish to insert the
copied items.

4. Choose Edit > Paste or use the Ctrl+V keyboard shortcut.

The copied items are pasted before the selected step, exception, or
equation. Branch targets will not be pasted along with the instruction or
equation. These need to be re-entered manually.

If you need to undo the action, chose Edit > Undo or use the Ctrl+Z
keyboard shortcut.
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See Also “Sequence Controller Instruction Set” on page 137

Importing HDL Modules

The LogiBuilder Logic editor enables you to add an HDL module to a Platform
Designer project. You must first add the source file to your Diamond project.
Only one module can be imported into a Platform Designer project. To include
multiple modules, you must structure a top-level module that you will pass to
Platform Designer.

To import an HDL Module:
1. In Diamond’s main window, choose File > Add > Existing File.

2. Navigate to the directory that contains the Verilog or VHDL source file,
select the file and click Add.

Diamond adds the file to the project and displays it in the Input Files folder
of the File List view.

3. In Platform Designer, open the Logic editor and select the Imported HDL
tab.

4. Select the Enable Imported HDL option. This will parse the input files for
modules available to import.

5. Select the module from the Module Name menu.

Platform Designer populates the File Location of the chosen module
automatically. It also populates the Instance Name text box with the name
of the module and adds the “Inst” extension. The left portion of the screen
will be populated with any parameters available for definition in the
imported HDL, as well as port information from the module.

6. If desired, rename the module instance by typing a new name in the
Instance Name text box.

7. Assign values to the available HDL parameters.

8. For each port of the imported module, drag the desired signal from the
Logic Signal Pool over to the Signal Name cell. The Logic editor’s DRC
checking will inform you if the signal you are trying to map is not
compatible.

Building the Design

The Build view enables you to do a final design rule check, examine resource
utilization, compile the design, assign pins, implement the design, and
generate the merged JEDEC file. This view enables you to generate a test
bench, including stimulus, for simulating your design. It also enables you to
export a detailed configuration report.
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Checking Design Rules

Design rules are checked automatically each time you issue a save command
or run synthesis. Automatic design rule checking also prohibits you from
entering or pasting invalid data into cells that have pre-defined ranges or
numeric data types.

You can also use the Build view to run manual design rule check at any time.

To run manual design rule check:
Click the DRC button at the top of the Build view.

The results are displayed in the Output view of Diamond’s main window.

Examining Resource Utilization

The Build view of Platform Designer displays a summary of the hardware
resources that are being used by the current design configuration. It provides
estimates of the consumption of device resource logic, major blocks, and 1/0Os
of the current design. The Look Up Tables, Embedded Block RAM, and
Programmable IOs area of the resource summary are updated after you run
the Generate JEDEC step.

The Component Summary table at the top of the Build view indicates the
status of the design components and programming options. The lower portion
of the view provides a list of resources used in the design and the percentage
of each resource consumed. At the bottom left corner, a green check mark or
red X indicates the status of the implementation. When any options have been
changed that affect the build output, the status will be marked “Not Current.”
You will then need to click the Compile button, to update the output, and
complete the Pin Assignment and Generate JEDEC steps. If the
implementation is successful, with no errors, the status will change to Current.

Compiling the Design
When you compile the design, Platform Designer generates the HDL code
and synthesizes the logic design.

To compile the design:
In the Build view of Platform Designer, click the Compile button.

If you have unsaved changes in your design, the Save Modified Files
dialog box will open. Select the .ptm file in the Modified File list and any
others that you want to save and click OK.

Platform Designer compiles the design and takes it through the synthesis
and translation processes.
See Also “Examining Resource Utilization” on page 147

“Exporting a Detailed Configuration Report” on page 148
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Assigning Pins
After compiling the design in Platform Designer, you can open Diamond’s
Spreadsheet View to assign pins.

To assign pins:

1. In the Build view, click Pin Assignments.
Spreadsheet View opens to the Port Assignments sheet.

2. Select the pin cells in the Pin column for the signals you want to assign.
Right-click the selected cells and choose Assign Pins.

4. Make your selections in the Assign Pins dialog box, and click Assign
Pins.

See Also “Assigning Signals in Spreadsheet View” on page 449 in
Diamond online help.

Generating the JEDEC

The Build view enables you to generate a merged JEDEC file after pin
assignment. This process merges the JEDEC of the FPGA with the ASC
JEDECs.

To generate the merged JEDEC file:
In the Build view, click Generate Jedec.

When the process is completed, the Summary Status at the bottom of the
Build view will be set to Current.

Exporting a Detailed Configuration
Report

After the design has been successfully compiled and implemented, the Build
view shows a green check mark, indicating that the status is current. This
allows you to export a detailed report of the design’s configuration.

To export a detailed configuration report:
Select the Build view and click the Export Configuration Report button.

Platform Designer automatically exports the report, named
<project_name>_report.txt, to your project directory. You can view the
report by following the link displayed after the report is exported.

The report lists the components utilized in the design, along with the
component settings for each feature. The report also includes full
configuration information for the analog portion of the design.
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Simulating the Design

After the design has been compiled successfully, you can perform functional
simulation using Platform Designer and the Diamond Simulation Wizard.
Platform Designer enables you to create a test bench file, based on the ASC
configurations and specified connections, and it generates a stimulus file
based on clock and non-clock data signals that you specify.

Generating a Stimulus and Test Bench
File

After the design has been compiled successfully, you can specify the
connections and signals for functional simulation. Platform Designer uses this
information, plus the port-related information from the FPGA top-level HDL

and the ASC configuration files, to generate a stimulus file and a test bench
file.

To generate a stimulus file and a test bench file:

1. In the Build view of Platform Designer, click the Generate Stimulus
button.

The dialog box opens to the “Connections between FPGA and ASCs”
page. The “From” and “To” sections, at the top, list all the FPGA ports and
ASC signals that you can use to establish new board-level connections.
The “Connection” section, at the bottom, displays the default hardware
connections between the FPGA and all ASC devices in the design. These
cannot be edited or removed.

2. Click the “add connection” button <2 on the bottom left.
A new row is added at the bottom of the Connection section.
3. Scroll down to the newly added row, and then do the following:

a. Select the desired signal in the “From” column in the top section and
drag it to the “From Signal” cell in the newly created row at the bottom.

b. Likewise, select the desired signal in the “To” column in the top section
and drag it to the “To Signal” cell in the newly created row at the
bottom.

c. Type aname for the new net in the Net Name cell of the newly created
row.

Only a connection’s Net Name can be edited after you have selected the
signals. To change the signals of a connection, you must remove the
connection and replace it. To remove a connection, click any cell in the
connection, and then click the X button.

4. Repeat Step 3 for each new connection you want to add.
Select the Stimulus tab, and then do the following:

a. Select the Clock tab on the left to edit the stimulus of clock signals.
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Click the “add clock stimulus” button *2¢ on the bottom left to

add a clock. The system clock signal, ASCO_CLK, will be shown
when this tab is opened, and it cannot be edited.

Select the desired clock signal from the Signal Name drop-down
menu, and then select an initial value, 1 or 0, from the Initial Value
menu.

In the Frequency or Period cell, type a value, select the
measurement unit, and press Enter. The period is calculated
automatically when you enter the frequency and vice versa.

b. Select the Data tab on the left to add stimulus for non-clock signals.

Click the “add data stimulus” button ©¢ on the bottom left to add
a new row.

Click inside the Signal Name column and choose a signal from the
drop-down menu.

The column following the Signal Name specifies the initial value.
Click inside the cell and select the numerical type—Bin, Hex, or
Dec—and then enter a value. Enter a value in each subsequent
cell where the signal changes.

You do not need to enter a value for each signal in each cell. Enter
a value in a cell only when the value changes. The input value will
be held at the last entered value if no entry is made in a cell.

You can also select a bus and enter the values. The values can be
entered as Binary, Decimal, or Hexadecimal for bus signals.

Repeat the above steps to add stimulus for more non-clock
signals.

Add time entries for the additional columns in the top row of the
display. You can select the time base to use as you enter each
time value. The time entries are absolute time references rather
than relative to each other. Therefore, the time values must be
increasing from left to right.

When you add a time entry in the last column on the right, a new
column gets added on the right, allowing you to enter an additional
time value if desired.

To add or remove a column, right-click the time entry top row
where you want to insert or remove a column and choose Insert
Before, Insert After, or Remove. Make sure that the time entry cell
is not open for editing before you right-click. If it is open for editing,
press the Enter key, and then right-click to access the pop-up
menu.

6. Click OK.

Simulating the Design

When you generate the stimulus for the design, the following four files are
automatically created:
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<project_name>_design.v This file serves as a wrapper of the MachX02/
ECP5U/UM and ASC for functional simulation

<project-name>_test.v This file serves as the top-level file for functional
simulation

<project-name>_design_post.v This file serves as a wrapper of the
MachXO2 and ASC for timing simulation.

<project-name>_test_post.v This file serves as the top-level file for timing
simulation

You can use Diamond’s Simulation Wizard " to create the simulation project
for the Platform Manager 2 or MachXO2/ECP5U/UM design and export the
simulation project into Aldec Active-HDL or ModelSim. After opening the
Simulation Wizard, follow the on-screen prompts to create the simulation
script.

When you create the simulation project in the Diamond Simulation Wizard
and click Finish, the Aldec Active-HDL software will start automatically. If
“Run Simulation” (the default value) was selected in the Simulation Wizard,
the project will be loaded into the simulator. The project files will be compiled,
and the simulation waveform window will open with all the top-level signal
names. You can add signal names from within the design to the waveform
window if you wish to see other signals from your design. See the Aldec
Active-HDL Help for more information about adding signal names to the
waveform window.

The simulation will run for a period of 1 s after it is loaded and compiled. You
can run it for additional time by using the Run command in the Active-HDL
console view. To run the simulation for 100 ps, type the command <run 100
us> and press the Enter key. The length of time to run your simulation will
depend upon the design and the stimulus file you created.

For each ASC configuration, the Simulation Wizard will copy the following files
to the simulation folder:

cfg_eeprom.hex

flut_eeprom.hex

i2caddress.hex

trim_eeprom.hex

The Simulation Wizard will also copy the memory file (.mem) for the “VID
table” and the MICO “scratchpad” and “prom” files.

The Simulation Wizard will not copy any memory or data file from an imported
HDL module. If you have imported an HDL module into your Platform
Designer project, you will need to copy it manually into the simulation folder.

See Also “Simulation in Diamond” on page 297 in Diamond online help.
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Working with Power Calculator

When using Platform Designer with Power Calculator, the most accurate
power calculation is accomplished when using Power Calculator in integrated
mode within your projects.

When calculating power for Platform Manager 2 and MachX02/ ECP5U/UM

designs using an ASC device, the Diamond integrated Power Calculator tool
imports a data file generated by the Platform Designer software. This data file
is generated in the current implementation directory and should not be edited
by the user.

Platform Designer calculates the power mode for each ASC used and
generates a data file containing each ASC, the power used by that ASC, and
the power supply used (if relevant). Refer to the description of the “ASC” on
page 757 page in Diamond Power Calculator online help. The data file
contains both external ASC devices used and the ASC internal component in
the Platform Manager 2 device.

The power consumed by an ASC device is determined by the number of
HVOUTSs used in the design. The data file, which is generated from Platform
Designer and which has an .apw suffix, includes the number of HYOUTSs used
and the power model equation. The data file lists all ASCs and the power
used by each and is located in the design implementation directory. This file is
read by Power Calculator and then the additional power from the ASC
devices is added to the total power displayed. This data is displayed in the
Power Calculator Power Summary tab, Power by Block (W) section and the
ASC page.

Power calculation for ASCs is different than for other Lattice devices. To
calculate power consumption for ASCs, the following equations are used:
Current = Io+l,yout X#HVOUT

Power = Vccx Current

Power = Ve x (Ig+ lyyout X #HVOUT)

There are four variables:

Vee = 36V

lo = 23mA

lhvout = 2MA

#HVOUT = Number of HV Outputs used

The above calculations are only used when Power Calculator is used in the
integrated mode or used with a PCF file generated in this mode. To
understand the different methods power is calculated refer to the list below.

Power Calculator Integrated mode

Calculates power from multiple ASC devices for Platform Manager 2, or
MachXO2 HC (640 LUT or larger) with external ASCs, or ECP5U/UM
(25F and 45F) with external ASCs.
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Power Calculator standalone mode

Calculates power only from the internal ASC in the Platform Manager 2
device. ASC power is estimated as a fixed value, not a variable amount
based on the number of HYOUTSs used.

Can correctly calculate ASC power based on HYOUTs used only if
opened with a PCF file generated by Power Calculator in integrated mode
instead of loading NGD database.

Power Estimator standalone mode

Calculates power only from the internal ASC in the Platform Manager 2
device. ASC power is estimated as a fixed value, not a variable amount
based on the number of HYOUTSs used.

Can correctly calculate ASC power based on HYOUTs used only if
opened with a PCF file generated by Power Calculator in integrated
mode.

See Also  »“Analyzing Power Consumption” on page 745 in Diamond online

help.
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Entering the Design

You can enter your design in several different ways and you can use the ways
in almost any combination. Lattice Diamond accepts, and helps create,
Verilog, VHDL, schematic, and EDIF files. Design files can be created within
Diamond or outside using third-party tools. Diamond also helps you use a
variety of pre-made modules, ranging from simple functions to whole
processors.

Here, “entering the design” refers to describing the logic of the design. Setting
specifications to control synthesis or simulation or to control how the design is
implemented in hardware are treated as a separate topic. (See “Applying
Design Constraints” on page 347.) You will almost always want to at least
start entering your design before setting constraints.

Verilog and VHDL The hardware design languages (HDL) Verilog and
VHDL are the usual ways to describe complex logic designs. You can create
HDL files using you preferred HDL editor and then add them to your Diamond
design project, or you can create or edit them within Diamond. See “HDL
Design Entry” on page 156.

Modules Modules are functional bits of design that can be re-used
wherever that function is needed. To help your design along, Lattice
Semiconductor provides a variety of modules for common functions. They are
optimized for Lattice device architectures and can be customized. Use these
modules to speed your design work and to get the most effective results. See
“Designing with Modules” on page 179.

LatticeMico Platforms A special kind of module is the LatticeMico platform.
LatticeMico platforms are full-featured 32-bit processors and 8-bit controllers
plus peripheral components created with LatticeMico System, an option add-
on to Diamond. LatticeMico System provides the processor, the controller,
and a variety of peripheral components. With it, you can customize the
platform and debug C and C++ code. See “Designing with LatticeMico
Platforms” on page 228.
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Schematic Design An alternative to HDL is schematic design, in which you
graphically lay out modules and other components and wire them together.
Schematic is a very visual method but lacks the abstraction possible in an
HDL. Schematic design may be better suited for smaller designs or smaller
portions of a design. It's also a good way to lay out the top level of a design.
The detailed workings of lower levels could then be done in an HDL. See
“Schematic Design Entry” on page 230.

EDIF Actually, EDIF (Electronic Design Interchange Format) is not a way to
enter a design but is instead a way to exchange design data between different
EDA systems. But EDIF files can be added to a Diamond design project like
input files such as Verilog and VHDL. You may want to add EDIF files
because you prefer to use another synthesizer or because you have EDIF
files of modules that you want to re-use from another project. Diamond
supports EDIF 2 0 0. See “Importing an Existing Source File into a Project” on
page 35.
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HDL Design Entry

Diamond supports HDL design including pure VHDL design, pure Verilog
design, and mixed VHDL and Verilog HDL design. You can use the integrated
Source Editor to create and edit your HDL source files and any text-based
files.

Source Editor is a text entry tool of Lattice Diamond. You can use this tool to
create and edit text-based files, such as HDL files, preference files, script
files, test files, and project documentation files. Like many other advanced
editing tools, it supports multiple file editing, wheel mouse scrolling, as well as
popup menus for cut, copy, and paste operations. If a data source changes
since the view was initialized, the view will detect this condition and provide
you an option to refresh it.

Designed particularly for HDL file editing, Source Editor highlights the
std_logic keywords and displays different HDL syntax elements with different
colors. The color scheme can be customized in the Options dialog (Tools >
Options from the main window) of the Diamond main window, the Source
Editor > Colors section. Also, Source Editor enables you to check correct
pairing of parenthesis constructs and offers rich template features.

Note

Do not leave blank spaces in file names when you save source files in Source Editor,
otherwise the files could fail to generate the database.

If you are going to use Lattice Synthesis Engine (LSE) to synthesize the
design, there are helpful Verilog and VHDL coding tips in “Coding Tips for
Lattice Synthesis Engine (LSE)” on page 162.

See Also “Running Source Editor” on page 156

“Viewing Logs and Reports” on page 92

Running Source Editor

You can run Source Editor in several ways.

To run Source Editor, do one of the following:

From the File List view, double-click a language file—for example,
filename.vhd

From the Diamond main window, choose File > New > File. In the New
File dialog, choose a text-based source, for example Verilog Files. Fill in
the File name and Location, click New.
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Creating HDL Source Files in Source
Editor

You can create an HDL source file in Source Editor.

To create an HDL source in Source Editor:

1. From the Diamond main window, choose File > New > File. In the New
File dialog, choose Verilog Files or VHDL Files from the Source Files list.

2. Inthe pop up New File dialog, fill in the File name and Location, choose
the file extension in the Ext field.

3. Check the Add to project option if you want to add this source to the
current project.

4. click New.

In the pop up Source Editor, you can enter the text. When finished editing,
click File > Save from the Diamond main window.

Tip
You can detach Source Editor from the Diamond main window by clicking the Detach
Tool icon on the upper right corner of Source Editor. If you want to attach Source Editor

back to the main window, click the Attach Window icon on the upper right corner of
Source Editor window, or choose Window > Attach Window from Source Editor.

Editing Text Files

This section describes the editing functions in Source Editor.

Editing a Column of Text
You can cut, copy, and paste a column of selected text in Source Editor. You
can also use the Tab key to increase the left indention of the selected column.

To cut, copy, and paste a column of text:

1. Hold down Alt, and then click and hold the left mouse button down to form
a rectangle that you want to edit.

IMPORTANT!

This feature does not work on a Linux platform, because the Alt key is occupied by
the Linux system.

2. Use the right-click commands or the commands on the Edit menu to cut,
copy, and paste the selected text.

To indent a column of text:
1. Place the cursor in front of the text you want to indent.

2. Choose Edit > Advanced > Indent. Or, press Tab.
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Source Editor increases the indent of the selected text column by one tab
size. By “Matching Braces, Parenthesis, and Brackets” on page 158, you
can change the position of the indent.

To uppercase a selection:
1. Highlight the text you want to change to uppercase.

2. Choose Edit > Advanced > Uppercase Selection. You will see the
highlighted text become uppercase.

To lowercase a selection:
1. Highlight the text you want to change to lowercase.

2. Choose Edit > Advanced > Lowercase Selection. You will see the
highlighted text become lowercase.

To comment text:

1. Highlight the text you want to add comment, or place the cursor in front of
the text.

2. Choose Edit > Advanced > Comment/Uncomment. You will see “--" put
ahead of the text (VHDL file only). You can add comment after “--” (VHDL
file only).

Matching Braces, Parenthesis, and Brackets

Source Editor monitors brace ( {} ), parenthesis ( () ), and bracket ([])
constructs. You can match an opening brace (or bracket or parenthesis) with
a closing one, and vice versa.

To jump to the matching brace, parenthesis, or bracket:

1. In Source Editor, place the editing cursor adjacent to an opening or
closing parenthesis (or bracket or brace).

2. Choose Edit > Advanced > Match Brace.

The cursor will move to the corresponding opening or closing parenthesis
(or bracket or brace). This allows you the check for the balanced braces
around functions and statements.

You can use the Edit > Advanced > Select to Brace command to force the
matching brace, parenthesis, or brackets to be highlighted along with the text
in between the two braces, parenthesis, or brackets,

Using Bookmarks

You can insert bookmarks into the source file to mark places where you need
to enter variables. Afterwards, each time you load the file, you can use the
Edit > Bookmarks command to jump to those marks and enter or edit
variables.

To insert bookmarks in a file:

1. In Source Editor, open the file where you want to insert bookmarks.
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Click the place you want to insert a mark.
Choose Edit > Bookmarks > Toggle Bookmark.
A mark is inserted at the beginning of the line where the cursor points.

Repeat step 2 and 3 to add more marks if so desired.

To find marks in a file:

3.

In Source Editor, open the file where you want to find marks.

Choose Edit > Bookmarks > Previous Bookmark, or Edit >
Bookmarks > Next Bookmark.

The cursor jumps to one mark or the other. You can start typing from the
desired marked place to enter or edit the variable.

Repeat step 2 to find, enter, or edit more marks if so desired.

Using AutoComplete
When you type a keyword into Source Editor, choose Edit > Advanced >
AutoComplete. A list of the matching values will be presented. You can then:

Choose the first matching value by pressing Enter directly.

Choose an alternate matching value by using the up/down arrow keys and
then press Enter.

Continue typing the rest of the value. If no matching value is found,
nothing will be entered.
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Using Templates

Source Editor provides templates for creating VHDL, Verilog, and constraint
files. Templates increase the speed and accuracy of design entry. You can
also create your own templates. Remember to replace dummy variables in
the template with your own logic.

You can use Source Editor's View > Template Editor menu to locate and
access template files. After clicking this menu, you can see the Template
Editor pane located in the upper left of Source Editor. Templates are available
for:

Verilog

VHDL

SDC (Synopsys Design Constraints. Can also be used for FDC files.)

LDC (Constraints for LSE.)
Each category has folders for System Templates and User Templates.
System Templates holds the standard templates that come with Diamond. For
Verilog and VHDL, these include commands for instantiating PMI modules
and common elements of the language. For SDC and LDC, System
Templates holds templates for the supported constraint statements. User
Templates allows you to create your own templates for future use.
See Also »“Lattice Module Reference Guide” on page 1316

“Lattice Synthesis Engine (LSE) Constraints” on page 1272

Inserting a Template into Your Source File
You can insert templates into a source file you are editing with Source Editor.

To insert a template into your source file:

1. Open the source file in Source Editor. See “Running Source Editor” on
page 156.

2. Choose View > Template Editor.

Two additional panes open in Source Editor. The upper pane shows the
list of template folders. The lower pane is blank.

3. Place the cursor where you want to insert a template. This should be in a
blank line.

4. Select the template you want to use in the template list.
The code of the template appears in the lower pane.

5. Right-click the template name and choose Insert to text.
The selected template is inserted into the file after the cursor.

6. Be sure to replace all placeholders with real values. Placeholders are
terms between angle brackets such as “<event_expression>.”
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7. If you inserted a PMI template, also add parameter values and I/O signal
names. For information about allowed parameter values, see the section
on the module in the “Lattice Module Reference Guide” on page 1316.

8. If needed, make further changes such as adding code to execute within a
case statement.

See Also »‘“Instantiating a PMI Module” on page 190

Creating a New Template

You can create new templates for your own use and save them into the User
Templates folders. The new templates will be available for all implementations
in the design project.

You can also create sub-folders to organize the templates that you create. If
you plan on creating many templates, think about the organization before you
start. There is no easy way to move templates once they have been created.

To create a new template:

1. Open a source file in Source Editor. This can be a file that you will use the
new template in or a blank file that you will delete after creating the
template. See “Running Source Editor” on page 156.

2. Choose View > Template Editor.

Two additional panes open in Source Editor. The upper pane shows the
list of template folders. The lower pane is blank.

3. In Template Editor, expand the appropriate folder so that its User
Templates folder is showing. Every top level folder has a User Templates
folder. If the User Templates folder already has contents, expand it so you
can see the contents.

4. If you want to create a sub-folder, right-click User Templates or one of its
sub-folders and choose New Folder. Then right-click the new folder and
choose Rename. Type the desired folder name and press Enter.

5. Right-click User Templates or one of its sub-folders and choose New
Template.

A new template icon appears under the folder.

6. Right-click the new template icon and choose Rename. Type in the
desired template name and press Enter.

7. Type the code for your template in the lower pane of Template Editor.

The new template is automatically saved.

Deleting a User Template
You can only delete templates from a User Templates folder.

There is no undo command. Be sure you have the right template and want to
permanently remove it.
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To delete a template:

1. Open asource file in Source Editor. This can be a file that you are using or
a blank file that you will delete after creating the template. See “Running
Source Editor” on page 156.

2. Choose View > Template Editor.

Two additional panes open in Source Editor. The upper pane shows the
list of template folders. The lower pane is blank.

3. In Template Editor, expand the folders so that the desired folder or
template is showing.
Caution

Deleting a folder also deletes all templates under the folder.

4. Right-click that template or folder and choose Delete.

Coding Tips for Lattice Synthesis
Engine (LSE)

If you are going to use LSE to synthesize the design, the following coding tips
may help. Mostly the tips are about writing code so that blocks of memory are
“inferred”: that is, automatically implemented using programmable function
units (PFU) or embedded block RAM (EBR) instead of registers. There are
also tips about inferring types of I/O ports and avoiding conflicts between
VHDL packages.

About VHDL Coding

LSE tends to apply the VHDL specification strictly, sometimes more strictly
than other synthesis tools. Following are some coding practices that can
cause problems with LSE:

ieee.std_logic_signed or unsigned When preparing VHDL code for LSE,
you can include either:

USE ieee.std_logic_signed.ALL,;

or:

USE ieee.std_logic_unsigned.ALL;

DO NOT include both statements. Code with both signed and unsigned
packages could fail to synthesize because operators would have multiple
definitions. Some synthesis tools may allow this but LSE does not.

Strict Variable Typing LSE is stricter about variable type requirements than
some other synthesis tools. A std_logic_vector signal cannot be assigned to a

std_logic signal and an unsigned type cannot be assigned to a
std_logic_vector signal. For example:
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din : in unsigned (data width - 1 downto 0);
dout : out std logic vector (data width - 1 downto 0));

dout <= din; -- Illegal, mismatched assignment.

Such mismatched assignments generate errors that stop synthesis.

About Inferring Memory

There are two ways to produce RAM and ROM in a design. You can write
code for the design so that the synthesis tool infers the memory or you can
instantiate predefined IPexpress or PMI memory modules.

Inferring memory means that LSE, based on aspects of the code, implements
a block of memory using programmable function units (PFU) or embedded
block RAM (EBR)—PFU for small memories, EBR for large—instead of
registers. LSE can infer synchronous RAM that is:

single-port, pseudo dual-port, or true dual-port
with or without asynchronous reset of the output
with or without write enables

with or without clock enables
LSE can also infer synchronous ROM.

One of the advantages of inferring memory is that the design is portable to
almost any FPGA architecture. PMI modules, on the other hand, are
optimized for Lattice FPGAs and IPexpress modules are optimized for just
one FPGA family. Also, because the inferred memory is not a black box,
there’s full access for tools and to timing and area data.

However, there may be less efficient use of the FPGA architecture. Also, not
all kinds of memory can be inferred. In these situations you may prefer to use
IPexpress or PMI modules. With these modules you can also use Memory
Generator to easily create memory initialization files. See “Designing with
Modules” on page 179.

The following sections describe how to write code to infer different kinds of
memory with LSE.
See Also

“Inferring RAM” on page 163

“Inferring ROM” on page 173

Inferring RAM

The basic inferred RAM is synchronous. It can have synchronous or
asynchronous reads and can be either single- or dual-port. You can also set
initial values. Other features, such as resets and clock enables, can be added
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as desired. The following text lists the rules for coding inferred RAM.
Following that, Figure 5 on page 164 (Verilog) and Figure 6 on page 165
(VHDL) show the code for a simple, single-port RAM with asynchronous read.

To code RAM to be inferred, do the following:
Define the RAM as an indexed array of registers.

To control how the RAM is implemented (with distributed or block RAM),
consider adding the syn_ramstyle attribute. See “syn_ramstyle” on
page 1303.

Control the RAM with a clock edge and a write enable signal.

For synchronous reads, see “Inferring RAM with Synchronous Read” on
page 166.

For single-port RAM, use the same address bus for reading and writing.

For dual-port RAM, pseudo and true, see “Inferring Dual-Port RAM” on
page 168.

If desired, assign initial values to the RAM as described in “Initializing
Inferred RAM” on page 172.

Figure 5: Simple, Single-Port RAM in Verilog

module ram (din, addr, write en, clk, dout);
parameter addr width = 8;
parameter data width = 8;
input [addr width-1:0] addr;
input [data width-1:0] din;
input write en, clk;
reg [data width-1:0] mem [(l<<addr width)-1:0];
// Define RAM as an indexed memory array.

always @(posedge clk) // Control with a clock edge.
begin
if (write en) // And control with a write enable.
mem|[ (addr)] <= din;
end
assign dout = meml[addr];
endmodule

See Also

“About Verilog Blocking Assignments” on page 174
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Figure 6: Simple, Single-Port RAM in VHDL

library IEEE;
use IEEE.std logic 1164.all;
use IEEE.std logic unsigned.all;

entity ram is

generic (
addr _width : natural := 8;
data width : natural := 8);
port (

addr : in std logic vector (addr width - 1 downto 0);

write_en : in std _logic;

clk : in std logic;

din : in std_logic_ vector (data_width - 1 downto 0);

dout : out std logic vector (data width - 1 downto 0));
end ram;

architecture rtl of ram is
type mem type is array ((2** addr width) - 1 downto 0) of
std logic_vector(data width - 1 downto 0);
signal mem : mem type;
-- Define RAM as an indexed memory array.

begin
process (clk)
begin
if (clk'event and clk = 'l') then --Control with clock edge
if (write en = 'l') then -- Control with a write enable.
mem (conv_integer (addr)) <= din;
end if;
end if;

end process;
dout <= mem(conv_integer (addr)) ;
end rtl;
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Inferring RAM with Synchronous Read

For synchronous reads, add a register for the read address or for the data
output. Load the register inside the procedure or process that is controlled by
the clock. See the following examples. They show the simple RAM of Figure 5
on page 164 (for Verilog) and Figure 6 on page 165 (for VHDL) modified for
synchronous reads. Changes are in bold text.

Verilog Examples

Figure 7: RAM with Registered Output in Verilog

module ram (din, addr, write en, clk, dout);
parameter addr_ width = 8;
parameter data width = 8;
input [addr width-1:0] addr;
input [data width-1:0] din;
input write en, clk;
output [data width-1:0] dout;
reg [data width-1:0] dout; // Register for output.
reg [data_width-1:0] mem [(l<<addr width)-1:0];

always @ (posedge clk)
begin
if (write en)
mem[ (addr)] <= din;
dout = mem[addr]; // Output register controlled by clock.
end
endmodule

Figure 8: RAM with Registered Read Address in Verilog

module ram (din, addr, write en, clk, dout);
parameter addr_ width = 8;
parameter data width = 8;
input [addr width-1:0] addr;
input [data width-1:0] din;
input write en, clk;
output [data width-1:0] dout;
reg [data_width-1:0] raddr; // Register for read address.
reg [data width-1:0] mem [(l<<addr width)-1:0];

always @ (posedge clk)
begin
if (write_en)
begin
mem|[ (addr)] <= din;
end
raddr <= addr; // Read addr. register controlled by clock.
end
assign dout = mem[raddr];
endmodule
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VHDL Examples

Figure 9: RAM with Registered Output in VHDL

library IEEE;
use IEEE.std logic 1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is

generic (
addr width : natural := 8;
data width : natural := 8);
port (

addr : in std logic_vector (addr width - 1 downto 0);
write en : in std logic;
clk : in std logic;

din : in std logic vector (data_width - 1 downto 0);
dout : out std logic vector (data width - 1 downto 0));
end ram;

architecture rtl of ram is
type mem type is array ((2** addr width) - 1 downto 0) of
std logic_ vector(data width - 1 downto 0);
signal mem : mem type;

begin
process (clk)
begin
if (clk'event and clk = '1l') then
if (write en = '1') then
mem (conv_integer (addr)) <= din;
end if;
end if;

dout <= mem(conv_integer (addr)) ;
-- Output register controlled by clock.
end process;
end rtl;
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Figure 10: RAM with Registered Read Address in VHDL

library IEEE;
use IEEE.std logic 1164.all;
use IEEE.std logic unsigned.all;

entity ram is

generic (
addr width : natural := 8;
data width : natural := 8);
port (

addr : in std logic vector (addr width - 1 downto 0);
write_en : in std _logic;
clk : in std logic;

din : in std_logic_ vector (data_width - 1 downto 0);
dout : out std logic vector (data width - 1 downto 0));
end ram;

architecture rtl of ram is
type mem type is array ((2** addr width) - 1 downto 0) of
std_logic_vector(data_width - 1 downto 0);
signal mem : mem_type;

begin
process (clk)
begin
if (clk'event and clk = '1l') then
if (write en = '1') then
mem (conv_integer (addr)) <= din;
end if;

raddr <= addr;
-- Read address register controlled by clock.
end if;
end process;
dout <= mem(conv_integer (raddr)) ;
end rtl;

See Also

“Inferring RAM” on page 163

Inferring Dual-Port RAM
For dual-port RAM, pseudo or true:

Use two address buses.

If the design does not simultaneously read and write the same address,
add the syn_ramstyle attribute with the no_rw_check value to minimize
overhead logic.

If writing in Verilog, use non-blocking assignments as described in “About
Verilog Blocking Assignments” on page 174.

The following examples are based on the simple RAM of Figure 5 on
page 164 (for Verilog) and Figure 6 on page 165 (for VHDL).
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Verilog Examples

Figure 11: Pseudo Dual-Port RAM in Verilog

module ram (din, write en, waddr, wclk, raddr, rclk, dout);
parameter addr width = 8;
parameter data width = 8;
input [addr width-1:0] waddr, raddr;
input [data width-1:0] din;
input write en, welk, rclk;
output [data width-1:0] dout;
reg [data width-1:0] dout;
reg [data_width-1:0] mem [(l<<addr width)-1:0]
/* synthesis syn ramstyle = "no rw check" */ ;

always @ (posedge wclk) // Write memory.
begin

if (write en)

mem [waddr] <= din; // Using write address bus.

end
always @(posedge rclk) // Read memory.
begin

dout <= mem[raddr]; // Using read address bus.
end

endmodule

Figure 12: True Dual-Port RAM in Verilog

module ram (dina, write ena, addra, clka, douta,
dinb, write enb, addrb, clkb, doutb);
parameter addr width = 8;
parameter data width = 8;
input [addr width-1:0] addra, addrb;
input [data width-1:0] dina, dinb;
input write ena, clka, write emnb, clkb;
output [data width-1:0] douta, doutb;
reg [data width-1:0] douta, doutb;
reg [data_width-1:0] mem [(l<<addr width)-1:0]
/* synthesis syn ramstyle = "no_rw check" */ ;

always @ (posedge clka) // Using port a.
begin
if (write ena)
mem[addra] <= dina; // Using address bus a.
douta <= mem[addral ;
end
always @(posedge clkb) // Using port b.
begin
if (write_enb)
mem[addrb] <= dinb; // Using address bus b.
doutb <= mem[addrb] ;
end
endmodule
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VHDL Examples

Figure 13: Pseudo Dual-Port RAM in VHDL

library IEEE;
use IEEE.std logic 1164.all;
use IEEE.std_logic_unsigned.all;

entity ram is

generic (
addr width : natural := 8;
data width : natural := 8);
port (

write_en : in std _logic;

waddr : in std logic_vector (addr width - 1 downto 0);

wclk : in std logic;

raddr : in std logic vector (addr width - 1 downto 0);

rclk : in std logic;

din : in std_logic_vector (data_width - 1 downto 0);

dout : out std logic_vector (data width - 1 downto 0));
end ram;

architecture rtl of ram is
type mem type is array ((2** addr width) - 1 downto 0) of
std _logic_vector(data_width - 1 downto 0);
signal mem : mem type;
attribute syn ramstyle: string;
attribute syn ramstyle of mem: signal is "no_ rw check";
begin
process (welk) -- Write memory.
begin
if (welk'event and weclk = 'l') then
if (write en = '1') then
mem (conv_integer (waddr)) <= din;
-- Using write address bus.
end if;
end if;
end process;
process (rclk) -- Read memory.
begin
if (rclk'event and rclk = '1l') then
dout <= mem(conv_integer (raddr)) ;
-- Using read address bus.
end if;
end process;
end rtl;
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Figure 14: True Dual-Port RAM in VHDL

library IEEE;
use IEEE.std logic 1164.all;
use IEEE.std logic unsigned.all;

entity ram is

generic (
addr _width : natural := 8;
data width : natural := 8);
port (
addra : in std logic vector (addr width - 1 downto 0);

write _ena : in std_logic;

clka : in std logic;

dina : in std _logic_vector (data width - 1 downto 0);

douta : out std logic vector (data width - 1 downto 0);

addrb : in std logic vector (addr width - 1 downto 0);

write enb : in std logic;

clkb : in std logic;

dinb : in std logic_vector (data width - 1 downto 0);

doutb : out std logic vector (data _width - 1 downto 0));
end ram;

architecture rtl of ram is
type mem type is array ((2** addr width) - 1 downto 0) of
std logic_vector(data_width - 1 downto 0);
signal mem : mem type;
attribute syn ramstyle: string;
attribute syn ramstyle of mem: signal is "no_ rw check";
begin
process (clka) -- Using port a.
begin
if (elka'event and clka = '1l') then
if (write ena = 'l') then
mem (conv_integer (addra)) <= dina;
-- Using address bus a.
end if;
douta <= mem(conv_integer (addra)) ;
end 1if;
end process;
process (clkb) -- Using port b.
begin
if (clkb'event and clkb = '1l') then
if (write enb = 'l') then
mem (conv_integer (addrb)) <= dinb;
-- Using address bus b.
end if;
doutb <= mem(conv_integer (addrb)) ;
end if;
end process;
end rtl;

See Also

“Inferring RAM” on page 163
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Initializing Inferred RAM

Create initial values for inferred RAM in the usual ways for initializing memory.

Verilog In Verilog, initialize RAM with the standard $readmemb or
$readmemh tasks in an initial block. Create a separate file with the initial
values in either binary or hexadecimal form. For example, to initialize a RAM
block named “ram”:

reg [7:0] ram [0:255];
initial
begin

Sreadmemh ("ram.ini", ram);
end

The data file has one word of data on each line. The data needs to be in the
same order in which the array was defined. That is, for “ram [0:255]" the data
starts with address 0; for “ram [255:0]” the data starts with address 255. The
ram.ini file might start like this:

0A /* Address 0 */
23
5C

VHDL In VHDL, initialize RAM with either signal declarations or variable
declarations. Define an entity with the same ports and architecture as the
memory. Use this entity in either a signal or variable statement with the initial
values as shown below.

For example, to initialize a RAM block named “ram,” define an entity such as:

entity ram init is

port (
clk : in std logic;
addr : in std logic_vector (7 downto 0);
din : in std logic_vector (7 downto 0);

we : in std logic;

dout : out std logic_vector (7 downto 0));
end;
architecture arch of ram init is

type ram init arch is array (0 to 255)

of std logic vector (7 downto 0);

Then use the entity in a signal statement:

signal ram : ram init _arch := (
"0oo001010",
"oolio00011",
"o01i011100",

others => (others => '0'));

Or use the entity in a variable statement:

variable ram : ram init_arch := (
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1 => "00001010",
others => (1=>'1l', others => '0'));

See Also

“Inferring RAM” on page 163

Inferring ROM
To code ROM to be inferred, do the following:

Define the ROM with a case statement or equivalent if statements.
Assign constant values, all of the same width.

Assign values for at least 16 addresses or half of the address space,
whichever is greater. For example, if the address has 6 bits, the address
space is 64 words, and at least 32 of them must be assigned values.

To control how the ROM is implemented (with distributed or block ROM),
consider adding the syn_romstyle attribute. See “syn_romstyle” on
page 1305.

Figure 15: ROM Inferred with Case Statement in Verilog

module rom(data, addr) ;
output [3:0] data;
input [4:0] addr;
always @(addr) begin
case (addr)

0 : data = 'h4;
1 : data = 'h9;
2 : data = 'hil;
15 : data = 'h8§;
16 : data = 'hl;
17 : data = 'hO;
default : data = 'hoO;
endcase
end
endmodule

Lattice Diamond 3.6 Help

173



HDL Design Entry

Figure 16: ROM Inferred with If Statement in VHDL

entity rom is

port (addr : in std logic_ vector (4 downto 0);
data : out std logic vector (3 downto 0) );
end rom;

architecture behave of rom is

begin
process (addr)
begin
if addr = 0 then data <= "0100";
elsif addr = 1 then data <= "1001";
elsif addr = 2 then data <= "0001";

elsif addr = 15 then data <= "1000";
elsif addr = 16 then data <= "0001";
elsif addr = 17 then data <= "0000";
else data <= "00O0O";
end if;
end process;
end behave;

About Verilog Blocking Assignments

LSE support for Verilog blocking assignments to inferred RAM and ROM,
such as “ram[(addr)] = data;,” is limited to a single such assignment. Multiple
blocking assignments, such as you might use for true dual-port RAM (see
Figure 17 on page 174), or a mix of blocking and non-blocking assignments
are not supported. Instead, use non-blocking assignments (<=). See

Figure 18 on page 175.

Figure 17: Example of RAM with Multiple Blocking Assignments (Wrong)

always @ (posedge clka)

begin
if (write_ena)
ram[addra] = dina; // Blocking assignment A
douta = raml[addral;
end
always @ (posedge clkb)
begin
if (write_enb)
ram[addrb] = dinb; // Blocking assignment B
doutb = raml[addrb];
end
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Figure 18: Example Rewritten with Non-blocking Assignments (Right)

always @ (posedge clka)
begin
if (write ena)
ram[addra] <= dina;
douta <= raml[addral];
end
always @ (posedge clkb)
begin
if (write enb)
ram[addrb] <= dinb;
doutb <= ram[addrb];
end

About Verilog Generate Blocks

If a module has multiple generate blocks, LSE requires that they each block
have a different name. Assign names with begin statements. See Figure 19

on page 175.

Figure 19: Generate Blocks with Assighed Names

generate

begin: Rl gen // Name first generate block.
genvar 1i1;
for (il1=0; 1il<=15; i1=11+1)

regset R1 (.clk(clk[il]), .qg(glil]),.d(d[i1]));
end
endgenerate
generate
begin: IR0 gen // Name second generate block.
genvar 1i;
for (i=0; i<=7; i=i+1)
ioreg IR0 (.clk(clk([0]), .reset(rst[il), .q(qglil)
end
endgenerate
Inferring 1/O
To specify types of 1/O ports, follow these models.
Verilog
Open Drain:

output <ports;
wire <output enables>;
assign <ports> = <output enable> ? 1'b0 : 1'bz;

Bidirectional:

inout <ports;
wire <output enables>;

,.d(df[il));
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wire <output drivers;
wire <input signals;

assign <port> = <output enable> ? <output driver> : 1'bz;
assign <input signal> = <ports>;

VHDL

Tristate:

library ieee;
use ieee.std_logic_1164.all;
entity <tbuf> is

port (
<enable> : std logic;
<input sig> : in std logic_vector (1 downto 0);
<output_sig> : out std logic_vector (1 downto 0));
end tbuf2;
architecture <port> of <tbufs> is
begin
<output sig> <= <input sig> when <enable> = 'l' else "ZZ";
end;
Open Drain:

library ieee;
use ieee.std logic 1164.all;
entity <od> is
port (
<enable> : std logic;
<output_sig> : out std logic_vector (1 downto 0));
end od2;
architecture <port> of <od> is
begin
<output _sig> <= "00" when <enable> = 'l' else "ZZ";
end;

Bidirectional:

library ieee;

use ieee.std logic 1164.all;

entity <bidir> is

port (
<direction> : std logic;
<input sig> : in std _logic_vector (1 downto 0);
<output_sig> : out std logic_vector (1 downto 0);

<bidir sig> : inout std logic vector (1 downto 0)) ;

end bidir2;

architecture <port> of <bidirs is

begin
<bidir sig> <= <input sig> when <direction> = '0' else "ZZ";
<output_sig> <= <bidir sigs>;

end;

Lattice Diamond 3.6 Help 176



HDL Design Entry

Customizing Source Editor
You can set file and window modes, set encoding, and configure line number
showing, text wrapping, and printing options in Source Editor.

Setting File and Window Modes

Source Editor offers you the flexibility to configure file and window modes,
such as line number showing, text wrapping, and printing options. The
configuration can be applied to the current file, the specified types of files, or
any new files created in Source Editor.

To set file modes:

1. In Source Editor, choose View > Language. You will see list of menu
items beside, cpp, hypertext, perl, python, tcl, verilog, vhdl, preference,
and edif.

2. Choose the desired file mode from the list. Source Editor will become that
specific language sensitive.

To set window modes:

1. In Source Editor, choose Window > Attach Window. The Source Editor
window is attached to the Diamond main window.

2. If want to detach Source Editor from the Diamond main window, click the
Detach Tool icon on the upper-right corner of Source Editor.

Customizing Source Editor from the Diamond Main Window

To customize Source Editor settings in the Diamond main window:
1. In the Diamond main window, choose Tools > Options.
2. Inthe Options dialog, find the Source Editor section.

You can set settings in the each related section.

General

Show Line Number: Displays line numbers of the files (on the left
side of the Editor).

Show Indicator Margin: Displays the side bar where you can click to
select the whole row.

Show Folder Margin: Displays the side bar (on the left side of the
Editor) that is used to fold/unfold the syntax.

Tab Size: Specifies how many spaces are entered
when a tab character is pressed.

Set Default Brings back to the default setting.

Fonts

Lists the current fonts used in Source Editor. If you want to change the
current fonts, click the font box. From the pop-up Select Font dialog, you
can select the desired font. Click OK to quit the dialog. The selected font
name, font type, and font size will be displayed.
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Set Default Brings back to the default font setting.
Colors

Lists the syntax elements and the current color settings for them. Click the
color box to choose a different color.

Set Default Brings back to the default font setting.

If you want to change to use your own text editor other than Source Editor,
you can customize to add your own text editor and associate files to your own
text editor program in the Options dialog (Tools > Options from the Diamond
main window), the Environment > File Associations section.

References

This section includes the following references.

Verilog HDL Language Reference
If you have installed Synplify Pro for Lattice, refer to the Synplify and Synplify
Pro for Lattice Reference Manual in the Synplify Pro installation directory.

VHDL Language Reference
If you have installed Synplify Pro for Lattice, refer to the Synplify and Synplify
Pro for Lattice Reference Manual in the Synplify Pro installation directory.
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Designing with Modules

Modules are functional bits of design that can be re-used wherever that

function is needed. Creating such modules with hardware design languages

is common practice. To help your design along, Lattice Semiconductor

provides a variety of modules for common functions. They are optimized for
Lattice device architectures and can be customized. Use these modules to

speed your design work and to get the most effective results.

Lattice Semiconductor’s modules come in a variety of forms:

IPexpress provides a variety of functions ranging from the most basic,

such as arithmetic and memory, to much more complex functions. With
IPexpress these modules can be extensively customized. They can be
created as part of a specific project or as a library for multiple projects.
See “Creating IPexpress Modules and IP” on page 180.

However, many of these modules can also be used with PMI (see next
item). To decide which method to use, see “Use PMI or IPexpress?” on
page 180.

PMI (Parameterized Module Instantiation) is an alternate way to use some
of the modules that come with IPexpress. With PMI, instead of using
IPexpress, you directly instantiate a module into your HDL and customize
it by setting parameters in the HDL. You may find this easier than using
IPexpress if your design requires many variations of the same module. To
decide which method to use, see “Use PMI or IPexpress?” on page 180.

Clarity Designer provides modules similar to those from IPexpress but for
ECP5. As with IPexpress, with Clarity Designer you can customize these
modules. Clarity Designer also helps you connect these modules to each
other and place the PCS and DDR modules in the device’s architecture.
See “Creating Clarity Designer Modules” on page 200.

LatticeMico32 microprocessors and LatticeMico8 microcontrollers are
exceptions in that they are not customized with IPexpress. LatticeMico32
and LatticeMico8 have their own development environment. To design
with LatticeMico System, see “Designing with LatticeMico Platforms” on
page 228.

Reference designs provide you with a starting point on creating your own
modules. Lattice Reference Designs are available in Verilog and VHDL,
and can be downloaded from the Lattice Web site: www.latticesemi.com/

ip.
Lattice library primitives are very basic functions, such as logic gates and
flip-flops. They can be directly instantiated as HDL into designs. But this is

an advanced technique and should usually be avoided. For more
information, see “Designing with Lattice Library Primitives” on page 198.

Of course you can also create your own modules and that is fully supported

too. In fact, Diamond supports creating your own black-box modules. See
“Creating Your Own Black Box Modules” on page 195.
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Use PMI or IPexpress?

Many IPexpress modules are also available as PMI modules. Why would use
one instead of the other?

PMI is a convenient way to use modules of the same type but that vary from
instance to instance. This eliminates the need to create a separate module for
each instance using IPexpress.

For example, a design might require dozens of FIFOs that are functionally the
same but require different address depths. With PMI, you could insert the
same FIFO instantiation command wherever it's needed in the HDL and just
change the address depth parameter as you go. The alternative would be to
use IPexpress to generate different modules for each variation and then insert
the instantiation template for each of them. In such a situation, you might find
the PMI method easier and faster.

But before deciding to use a PMI module, compare it to the equivalent
IPexpress module. Often IPexpress provides more options than PMI does.
IPexpress also assures that all of your option selections and parameter
settings are legal. PMI offers no error checking.

Also be aware that PMI requires some extra steps for simulation and
synthesis. PMI modules are treated as black boxes in design projects. So
simulation outside of Diamond, with a third-party simulator, requires compiling
a simulation library. And synthesis requires that a synthesis header file be
added to the design project or to the project of a standalone synthesis tool, if
using one. For more details, see “Requirements for Simulation and Synthesis with
PMI” on page 191.

See Also
List of PMI modules, see Table 67 on page 1318
“Creating IPexpress Modules and IP” on page 180
“Using PMI” on page 189

Creating IPexpress Modules and IP

IPexpress is an easy way to use a collection of functional blocks from Lattice
Semiconductor. There are two types of functional blocks available through
IPexpress: modules and IP. IPexpress enables you to extensively customize
these blocks. They can be created as part of a specific project or as a library
for multiple projects.

Modules: These basic, configurable blocks come with IPexpress. They
provide a variety of functions including 1/O, arithmetic, memory, and more.
Open IPexpress to see the full list of what's available. Also see the Lattice
Module Reference Guide.

IP: Intellectual property (IP) are more complex, configurable blocks. They are
accessible through IPexpress, but they do not come with the tool. They must
first be downloaded and installed as a separate step before they can be
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accessed from IPexpress. To see all that’s available and to learn about
licensing and other vendors of IP, go to the Lattice Web site:
www.latticesemi.com/ip.

Overview of the IPexpress Process Below are the basic steps of using
IPexpress modules and IP. For details of performing these steps, see the
following topics.

1.

Start running IPexpress. It can be started from Diamond’s Tools menu
after you open your design project. If you want to create a library of
configured modules or IP, IPexpress can be opened as a stand-alone tool
to create a library of modules.

If you want to use a Lattice IP that’s not visible, it must be downloaded
and installed first. This can be done from IPexpress.

Customize the module/IP. These modules and IP can be extensively
customized for your design. The options may range from setting the width
of a data bus to selecting features in a communications protocol. At a
minimum you need to specify the design language to use for the output.

Generate the module/IP and bring its .ipx file into your project. Prior to
generating the module/IP, select the option “Import IPX to Diamond
Project.” This will then automatically bring the .ipx file into your project
after the generation step completes. If you do not select this option, then
after generation, add the .ipx file to your project as you would with any
other source file (such as a Verilog or VHDL file). If using IPexpress
standalone, there is no project to automatically add the .ipx file.

Instantiate the module/IP into the project’s design. An HDL instance
template is generated during the generation step to simplify this step.

IPexpress modules and IP can be further modified or updated later. After
the .ipx file has been added to the Diamond project, it is visible in the
project’s file list. Double-clicking the .ipx file brings up the module/IP’s
configuration dialog box where changes can be made and the generation
process repeated.

See Also

“Running IPexpress” on page 182

“Downloading IPexpress IP” on page 182

“Installing a Downloaded IP” on page 183

“Generating a Module or IP with IPexpress” on page 184
“IPexpress Output Files for Modules” on page 186

“Regenerating a Module or IP with IPexpress” on page 186
“Importing an IPexpress Module or IP into a Project” on page 187

“Instantiating an IPexpress Module or IP” on page 188

Lattice Diamond 3.6 Help

181


http://www.latticesemi.com/ip

Designing with Modules

Runnlng IPexpress

IPexpress can be run as part of the open design project or as a separate,
stand-alone tool. When run as part of a project, module selection is limited to
modules that work with the project's FPGA. When run as a stand-alone tool,
all modules are available and they can be created for any device type.
IPexpress is usually run as part of a project. Stand-alone mode can be used to
create a library of modules.

On Linux, IPexpress can also be run from the command line as a stand-alone
tool.

To run IPexpress with your design project:

Choose Tools > BY IPexpress.

To run IPexpress as a stand-alone tool, from your Windows desktop:

From the Start menu, choose Programs > Lattice Diamond >
Accessories > EE':' IPexpress.

To run IPexpress from the Linux command line:

From the Linux command line, navigate to the <install_path>/bin/lin
directory and enter ./ipexpress on the command line.

Note

If this path has been included in your PATH environment variable definition, you
do not have to navigate to it.

Downloading IPexpress IP

You can use IPexpress to download and install the latest IP available from
Lattice Semiconductor. Before you can download any IP, you need to set up
an Internet connection. If you haven't already, choose Tools > Options. In the
Options dialog box, select Environment > Network Settings and fill in the
dialog box.

The Web site also has links to other vendors of IP. To see all that's available
and to learn about licensing and other vendors of IP, go to the Lattice Web
site: www.latticesemi.com/ip.

To download Lattice IP:

1. If you are working on Linux and this is the first IP you have ever installed,
go to your home directory and, with a text editor, create an empty file
named ipsetting_l.Ist. Enter no text: the file must be empty and must
have this name. If you find you already have a file with this name, do not
change it. This is a text file listing your IP and their path names.

2. InIPexpress, click the IP Server ﬂ button, located at the upper-left of the
tool.

3. Click IP in the left pane.
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5.

6.

The software connects to the Lattice Semiconductor Web site.
Expand the folder tree and select the IP you want to download.

Information about the IP appears in the right pane including links for
additional information.

IP that are not compatible with your version of Diamond have an X on their
icons. You can still download and install these IP but you need to upgrade
your Diamond software to use them. Look for software requirements in the
right pane.

Do one of the following:
To download and install the IP, right-click the IP and choose &g Install
in the pop-up menu.
To just download the IP for later installation, right-click the IP and
choose % Download in the pop-up menu.

Follow the on-screen instructions.

See Also »“Installing a Downloaded IP” on page 183

Installing a Downloaded IP
After downloading an IP, you must install it to make it available in IPexpress.

Installing on Windows To install the IP:

1.
2.
3.

If IPexpress is open, close it.

Go to the location where you saved the IP.
Double-click the executable file (.exe).

The Lattice Semiconductor Setup program opens.
Follow the on-screen instructions.

Open IPexpress to see the installed IP. Click the Local ® button and then
expand the IP folder tree.

Only IP that work with the selected device and your version of Diamond
are available. Unavailable IP have a red X icon, §, beside them.

If you started IPexpress from Diamond’s main window, the selection is
automatically limited to the device of the design project.

If you are running IPexpress in stand-alone mode and want access to all
the IP, choose All Device Families from the menu in the toolbar.

Installing on Linux To install an IP that you downloaded earlier on Linux,
the process depends on whether the download is a tar file (.tar.gz) or a shell
file (.sh).

To install the IP from a tar file:

1.

If this is the first IP you have ever installed, go to your home directory and,
with a text editor, create an empty file named ipsetting_|l.Ist. Enter no
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text: the file must be empty and must have this name. If you find you
already have a file with this name, do not change it. This is a text file
listing your IP and their path names.

2. Go to the location where you saved the IP.

3. Enter the following in a command line:
tar -zxvf <filename>.tar.gz

4. In IPexpress, click the Import User Configurable IP = button.

5. Inthe dialog box, browse to the installation directory for the IP and select
nodeinfo.cfg.

6. Click Open.

7. To see the installed IP, click the Local Bl button and then expand the IP

folder tree.

To install the IP from a shell file:
1. Go to the location where you saved the IP.
2. Enter the following in a command line:
sh <filename>.sh <Diamond install path>/bin/lin [<destination path>]

The <destination path> is the full path name of where you want the IP to
be installed. If not included, the IP will be installed in the current directory.

The first time you install an IP, IPexpress creates a file, ipsetting_l.Ist, in
your home directory. This is a text file listing your IP and their path names.

3. To see the installed IP, click the Local Bl button and then expand the IP
folder tree.

Generating a Module or IP with IPexpress

Use IPexpress to generate a customized functional block from any module or
installed IP.

Note

Lattice Synthesis Engine (LSE) is not currently used to generate IP. When LSE is
selected to be used for your design, the IP generation step (done within IPexpress) will
use Synplify Pro.

ROM modules require that a memory initialization (.mem) file be available
before generating a customized module. The memory initialization file is
optional with RAM modules. See “Creating a Memaory Initialization File with
Memory Generator” on page 192.

To generate an IP or module:

1. If you are running IPexpress as a stand-alone tool, then choose a device
family from the menu in the toolbar. Only modules and IP that work with
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that device and your version of Diamond will be available. Unavailable
modules will have a red X icon, &t or @, beside them.

If you started IPexpress from a Diamond project (Diamond’s main
window), the functional block selection is automatically limited to the
device of the design project.

2. In the Module/IP tree, select the module or IP that you want to generate.
To get more information about the module or IP, click the About tab.

4. In the Configuration tab, specify general project information and the base
file name for the module or IP. If you started IPexpress from a Diamond
project (Diamond’s main window), all but File Name and Module Output
have been filled in from the design project. You can still change Project
Path if you want.

Project Path is the location for the customized module’s files.

File Name is the base name for the module’s files (that is, with no
extension).

Module Output is how the module will be coded.

Device Family is the device family that the module will be optimized
for. This can be different from the device family selected in the toolbar.

Part Name is the exact device that the module will be optimized for.

Synthesis is the synthesis tool that will be used while generating the
module.

5. Click Customize.
The module’s dialog box opens.

6. In the dialog box, choose desired options. To get information about the
options, click Help. Also, check the About tab in IPexpress for links to
technical notes and user guides. IP may come with additional information.

As the options change, the schematic diagram of the module changes to
show the ports and the device resources the module will need.

7. To automatically import the .ipx file into your project when the module/IP is
generated, select Import IPX to Diamond project (not applicable in
IPexpress stand-alone mode). If you do not select this option, the .ipx file
must be added to the project. See “Importing an IPexpress Module or IP
into a Project” on page 187.

8. Click Generate.

9. Click the Generate Log tab to check for warnings and error messages.

See Also

“Creating a Memory Initialization File with Memory Generator” on
page 192

“IPexpress Output Files for Modules” on page 186
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IPexpress Output Files for Modules

IPexpress creates the following output files for modules under the specified
Project Path. The <file_name> comes from the File Name specified in the
Configuration tab.

IPexpress creates some different files for IP. These are documented in the
IP’s associated user guide.

Table 2:

File Name Description

<file_name>.ipx Manifest file. This file is loaded into IPexpress so that
modifications can be made to the module.

<file_name>.Ipc Parameter file.

<file_name>.naf Internal file. Do not edit.

<file_name>.srp Report file.

<file_name>.sym Internal file. Do not edit.

<file_name>.tmpl.v Instantiation template for Verilog netlist.

<file_name>.tmpl.vhd Component/instantiation template for VHDL netlist.

<file_name>.txt Configuration file for PCS and System Bus modules.

<file_name>.v Verilog HDL file for both synthesis and simulation.
Verilog output files declare implicit wire types.

<file_name>.vhd VHDL file for both synthesis and simulation.

<file_name>_generate.log IPexpress log file.
msg_file.log Log message file.
tb_<file_name>_tmpl.v Verilog test bench template.

tb_<file_name>_tmpl.vhd VHDL test bench template.

Regenerating a Module or IP with IPexpress

By regenerating a customized module or IP you can modify any of its settings
including: device type, design language, and any of the options specific to the
module. You can also update older modules or IP to the latest version.

Regenerating can be done to modify an existing module or to create a new
but similar one.

Note

If the module was originally customized with ispLEVER, you may see an .Ipc file but no
.ipx file. The .ipx file is new with Diamond. However, Diamond also supports .Ipc files
for backward compatibility. When you regenerate a module from ispLEVER, the .Ipc
file is replaced with an .ipx file.
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To just change the option settings of a module or IP that is already in a design
project, double-click the module’s .ipx file in the File List view. This opens
IPexpress and the module’s dialog box showing the current option settings.
Then go to step 6 below.

To regenerate a module or IP:
1. In IPexpress, click the Regenerate % button.

2. Inthe Regenerate view of IPexpress, choose the IPX source file of the
module or IP you wish to regenerate.

3. IPexpress shows the current settings for the module or IP in the Source
box. Make your new settings in the Target box.

4. If you want to generate a new set of files in a new location, set the location
in the IPX Target File box. The base of the file name will be the base of all
the new file names. The IPX Target File must end with an .ipx extension.

5. Click ReGenerate.
The module’s dialog box opens showing the current option settings.

6. In the dialog box, choose desired options. To get information about the
options, click Help. Also, check the About tab in IPexpress for links to
technical notes and user guides. IP may come with additional information.

As the options change, the schematic diagram of the module changes to
show the 1/0O and the device resources the module will need.

7. To import the module into your project, if it's not already there, select
Import IPX to Diamond project (not available in stand-alone mode).

8. Click Generate.
9. Check the Generate Log tab to check for warnings and error messages.
10. Click Close.

Importing an IPexpress Module or IP into a Project

After generating module source files using IPexpress, you can import the
module by importing the IPexpress manifest file (.ipx). Modules and IP have
several files of different types but you only need to import the .ipx. The .ipx file
identifies the components needed to make up the module or IP.

Note

If the module was originally customized with ispLEVER, you may see an .Ipc file but no
.ipx file. The .ipx file is new with Diamond. However, Diamond also supports .Ipc files
for backward compatibility. If there’s no .ipx file, select the .Ipc file.

Importing the module may not be necessary if the “Import IPX to Diamond
project” option was selected when the module was generated.
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To import a module:

1. Inthe File List view, right-click the implementation folder (|E_E) and choose
Add > Existing File.

2. Browse for the customized module’s .ipx file, <file_name>.ipx, and select
it.

3. Click Open.
The .ipx file is added to the File List view.

4. Check the Output Panel for error messages. If the module is not targeted
for the current device, try double-clicking the file to regenerate the
module.

After importing the module, you can further customize it for your design
project including changing the device type, design language, and any of the
options specific to the module. You can also update older modules or IP to the
latest version. See “Regenerating a Module or IP with IPexpress” on

page 186.

Instantiating an IPexpress Module or IP

IPexpress modules and IP are instantiated the same way other modules are
in your HDL. When you generate modules and IP in IPexpress, the tool also
produces a Verilog or VHDL file with the necessary instantiation commands.
You can copy and paste the contents of this file into one of your source files.

Before you instantiate any IPexpress module, check that it is compatible with
your design project’s device. When they were created, the modules were
optimized for a specific device and may depend on that device’s architecture.
A module may not work with a different type of device and may need to be
regenerated. If so, see “Regenerating a Module or IP with IPexpress” on
page 186.

The instantiation file is located in the folder that the module was created in.
The file name is based on the module’s name: <module name>_tmpl.v or
<module name>_tmpl.vhd.

Copy the instantiation command and paste it into one of your source files.
Then add an instance name and signal names to the module ports.

Note

The following I/O modules from IPexpress cannot be used as the top level of a design.
These must be instantiated within another module: DDR, DDR_GENERIC,
DDR_MEM, DQS, and SDR.

Before running any processes on the design, make sure that the IPexpress
module or IP has been imported into the project. See “Importing an IPexpress
Module or IP into a Project” on page 187.
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Using PMI

PMI (Parameterized Module Instantiation) is an alternate way to use some of
the modules that come with IPexpress. With PMI, instead of using IPexpress,
you directly instantiate a module into your HDL and customize it by setting
parameters in the HDL. You may find this easier than using IPexpress if your
design requires many variations of the same module.

But PMI requires some extra steps for simulation and synthesis. PMI modules
are treated as black boxes in design projects. So simulation outside of
Diamond, with a third-party simulator, requires compiling a simulation library.
And synthesis requires that a synthesis header file be added to the design
project or to the project of a standalone synthesis tool, if using one.

See Also
“Use PMI or IPexpress?” on page 180
List of PMI modules, see Table 67 on page 1318
“PMI Process Steps” on page 189
“Instantiating a PMI Module” on page 190

“Requirements for Simulation and Synthesis with PMI” on page 191

PMI Process Steps

This section provides a brief listing of the process steps you take when using
PMI.

1. Using Source Editor, insert PMI modules in the HDL source files. This is
the recommended method because it includes the PMI instance
templates, which require minimal editing.

2. Observe the PMI requirements to ensure successful functional simulation.

Since PMI block generation occurs post-synthesis, functional simulation
uses simulation models for these blocks. If you are running simulation in
Aldec Active-HDL, these models are automatically used. If you are using
another simulator, you must first compile the simulation library.

See “Requirements for Simulation and Synthesis with PMI” on page 191
for more details.

3. Add the PMI synthesis header files to your design project or to your stand-
alone synthesis tool’s project.

When synthesis is run, your PMI block instance will pass through the
process as a black box definition. The PMI synthesis header file contains
a comprehensive list of all necessary module/component declarations.
This saves you from having to create these declarations yourself or to
obtain them from some other source.

See “Requirements for Simulation and Synthesis with PMI” on page 191
for details.

4. After synthesis, run the Translate Design process (EDIF2NGD and
NGDBUILD). Note: If you are using LSE as the synthesis tool, Translate
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5.

Design is automatically included with synthesis. During this step, the
module generation that is required to implement the various instances in
your design is performed. This process will result in the output of multiple
.ngo files that are then input into one output .ngd file.

Perform the remaining implementation steps as you would normally.

Instantiating a PMI Module

PMI modules are instantiated the same way other modules are in your HDL.
The Diamond software provides a template for the Verilog or VHDL
instantiation command that specifies the customized module’s ports and
parameters. You customize the module by changing the parameters.

To instantiate a PMI module:

1.

With Source Editor, open the source file that will receive the module. See
“Running Source Editor” on page 156.

Place the cursor in the desired spot for the instantiation command.
Choose View > Template Editor.
The Template Editor view appears.

In Template Editor, open the System Templates > PMI folder and select
the module.

The code of the template shows in the lower box of the Template Editor
view.

Right-click the template and choose Insert to text.
The instantiation command is copied into your source file.

Add an instance name, set parameter values, and add signal names to
the corresponding module ports in the instantiation command. For
information about allowed parameter values, see the section on the
module in the “Lattice Module Reference Guide” on page 1316.

Figure 20: PMI Instantiation Command Example

Verilog

pmi counter
#(.pmi_data width(),
.pmi_updown (), <

VHDL

Change instance name — <your inst label> : pmi_counter
generic map (

.pmi_family ()
)

Add parameter values ———p pmi_data width => ,
pmi updown => ,
pmi_family =>

<your_inst_labels(.Clock(), )

.Clk_En(),

port map (

Aclr (), <
.UpDown () ,
.Q()

)

Add signal names ———» Clock => ,
Clk _En => ,
Aclr => ,
UpDown => ,
Q =>
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7. Save and close the source file.

Note

Simulation and synthesis require additional preparation. VHDL also has some
additional requirements. See “Requirements for Simulation and Synthesis with PMI” on
page 191.

Requirements for Simulation and Synthesis with
PMI

Unlike IPexpress module generation, which produces source files that contain
all of the necessary code for simulation, the PMI module code is a black box
definition of an IPexpress module. For this reason, simulation models for
these blocks must be available to supplement the code for simulation. For
synthesis, a PMI synthesis header file needs to be added to the project.

VHDL designs have a few additional requirements for both synthesis and
simulation.

PMI Simulation Models For Aldec Active-HDL, the PMI models are
automatically available. When using ModelSim, or any other simulator, you
must first compile the simulation library (pmi_work) from the sources, which
are in:

<install_dir>/cae_library/simulation/verilog/pmi

Note

No VHDL PMI models exist. The pmi_work library is compiled from Verilog modules
and used in both Verilog and VHDL simulation. The VHDL simulation must run in a
mixed-HDL environment.

PMI Synthesis Header Files The PMI synthesis header files for Verilog and
VHDL, respectively, are at:

<install_dir>/cae_library/synthesis/verilog/pmi_def.v
<install_dir>/cae_library/synthesis/vhdl/pmi_def.vhd

If you are running synthesis from inside Diamond (the integrated flow), add
the PMI synthesis header file to your design project by right-clicking the
implementation folder (|E_E) in the File List view and choosing Add > Existing
Source.

If you are running the synthesis tool outside Diamond (the interactive or
stand-alone flows), add the PMI synthesis header file to your synthesis tool
project.

VHDL Requirements When performing simulation for VHDL PMI, you also
need to compile the PMI component declaration file into your work library. The
file is at:
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<install_dir>/cae_library/simulation/vhdl/pmi/pmi_def.vhd

At the top of your source file, add two lines:

use work.pmi components.all;
library pmi_ work;

The first line includes the PMI components defined in the header file. The
second line is required by some simulators, such as Active-HDL, for
successful library binding.

Creating a Memory Initialization File

A memory initialization (.mem) file is an ASCII text file that specifies the initial
contents for the memory modules in your design. A .mem file is required to
create ROM and optional when creating RAM modules with IPexpress or PMI.

A .mem file can be most easily created or edited using Diamond’s Memory
Generator. But you can also create a .mem file using any text editor. Use the
file format described in the following section.

See Also

“Creating a Memory Initialization File with Memory Generator” on
page 192

“Memory Initialization File Format” on page 193

Creating a Memory Initialization File with Memory

Generator

Diamond’s Memory Generator is the easiest way to create or edit a memory
initialization file.

To create a memory initialization file:

1. Choose File > New > File.

The New File dialog box opens.

Under Categories, click Other Files.

Under Source Files, click Memory Files.

Fill in a name and location for the new memory initialization file.

Click New.

o M 0N

The Memory Generator E’? tab opens showing the file name that you
specified.

6. In the Options view, set file format and memory size in the File Format,
Depth, and Width boxes. See “Memory Initialization File Format” on

Lattice Diamond 3.6 Help

192



Designing with Modules

page 193 for more information. Then click Update to apply your changes
and refresh the display.

Note

If you close the Options view and want to get it back, choose View > Options
View.

7. Inthe Options view, choose the Address Radix and Data Radix for the
display.

Note

The Radix settings only specify in which format the addresses and data values are
displayed and entered in the Memory Generator window. They do not affect the
memory data format recorded in the .mem file. The data format in the .mem file
depends on the File Format option.

8. Fill in the memory contents in the right pane using the following methods:

Click in a cell and type in the value. You can use the arrow and Tab
keys to move between cells.

The values you enter should match the format specified in the Data
Radix box. Values that are too large are displayed in blue. You are not
allowed to save a file with blue values.

To find a location in a large memory, type the address into the “Jump
to” box and click Go.

To fill a block of memory with the same value, type the first and last
addresses of the block into the From and To boxes (under Filling).
Type the memory value into the Fill box. Then click Fill.

9. When you finish, choose File > Save <filename>.

See Also “Memory Initialization File Format” on page 193

Memory Initialization File Format

A memory initialization (.mem) file is an ASCII text file that consists of a
header followed by lines of memory data. The data must be in one of the
following formats: Bin (binary), Hex (hexadecimal), or Address-Hex
(described below).

For hexadecimal values, both upper and lower case can be used. If the data
has fewer bits than the specified data width, the most significant bits are filled
with 0. Any address not specified will be filled with 0.

Comments can be added at any point after the header (defined below) by
starting the comment with a pound sign (#) or two slashes (//). The comment
then includes everything to the end of the line. Comments may be added to
any of the data, but never add comments to the header.
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Header A .mem file starts with a header, which declares the file format,
memory size, and address and data display radix for Memory Generator. The
syntax of the header is:

#Format=Bin | Hex | AddrHex
#Depth=<1-65536>
#Width=<1-256>
#AddrRadix=<index_number>
#DataRadix=<index_number>
#Data

The <index_number> can be one of the following numbers. AddrRadix and
DataRadix can have different values.

Binary: 0

Octal: 1
Decimal: 2
Hexadecimal: 3

For example, the following header says the .mem file is using the binary
format for a 32x8 memory. When displayed in Memory Generator, the address
will be shown in hexadecimal and the data will be shown in binary.

#Format=Bin
#Depth=32
#Width=8
#AddrRadix=3
#DataRadix=0
#Data

Bin and Hex Formats The data is represented in binary or hexadecimal
format. Each line of data specifies the contents for one memory location,
starting with address 0. That is, the first line is for address 0, the second line is
for address 1, and so on. For each line, the data is interpreted as least
significant bit on the right.

For example, in the Bin format, the following lines will initialize address 0 to
“00011011", address 1 to “11111010” (assuming it is a 32x8 memory).

# for a 32x8 memory
11011
11111010

In the Hex format, the following lines will initialize address 0 to “003B”,
address 1 to “FBOA” (assuming it is a 32x16 memory).

# for a 32x16 memory
3B
FBOA

AddrHex The data is represented in hexadecimal format. Each line consists
of an address followed by a colon and then any number of data words,
separated by spaces:
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<address>:<data> <data> <data> ...

The data will be applied starting at <address> and filling in sequentially from
there.
For example:

A0:03 F3 3E 4F
B2:3B 9F

will initialize AO with 03, Al with F3, A2 with 3E, A3 with 4F, B2 with 3B, and
B3 with 9F. The other addresses will be initialized to 0. So A4 through B1 will
be set to 0.

See Also »“Creating a Memory Initialization File with Memory Generator”
on page 192

Creating Your Own Black Box Modules

In some cases, you may not want to distribute HDL source code because of
the risk of changes or of exposing proprietary information. So, Lattice
Semiconductor offers a compiled Native Generic Object (NGO) netlist format
as an alternative to HDL.

Advantages and Disadvantages An NGO netlist has the following
advantages over HDL source code;

Hides details of internal logic

Easy to distribute

Optimized to meet timing or area requirements

Optional grouping and floorplan constraints

On the other hand, an NGO netlist:
May not be portable across all device families
Cannot be parameterized
Overview of the Black Box Process The following are the basic steps for

creating and using a black box module. For details about performing these
steps, see the topics listed under “See Also.”

1. Create an NGO netlist.

Start with a design project just for the module and add some attributes.
Then run the synthesis and Translate Design processes.

2. Create support files.
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In addition to the NGO netlist, users of the black box module will need
additional information such as declaration and instantiation templates, a
data sheet, a simulation model, and timing attributes.

Note

NGO blocks will be given a unique name which is constructed by appending the
parameter value to the name of the NGO module as in the following example.

For the following module :
module my add sub (DataA, DataB, Add Sub, Result);

parameter bit width = 6;

endmodule

After generating the NGO file, the ngo must be renamed with the parameter value
appended to the module name as shown below:

“my_add_sub_6.ngo”

3. Instantiate the module.
Following the instructions from the module’s data sheet, copy the
declaration and instantiation templates into your design project.
See Also
“Creating an NGO Netlist” on page 196
“Support Files for the Black Box Module” on page 197

“Instantiating a Black Box Module” on page 198

Creating an NGO Netlist

To create an NGO netlist for a black box module, you just need to add
synthesis attributes to the ports and run the synthesis and Translate Design
processes. The exact procedure depends on your synthesis tool: Translate
Design runs as a part of Lattice Synthesis Engine (LSE); Translate Design is a
separate step with Synplify Pro.

To create an NGO netlist for a module:
1. Create a design project for the module.
2. Ifusing:
LSE, set “Use 10 Insertion” to False in the Synthesis options.

Synplify Pro, set “Disable 10 Insertion” to True in the Synthesis
options.

3. If you want to include floorplan information, add grouping (UGROUP/
HGROUP) or placement (REGION, LOC) attributes.

Floorplan constraints can improve performance with some designs but
may make the NGO netlist less portable across devices.

4. Synthesize the design.
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If using LSE, an NGO netlist (.ngo) file is created.
5. If using Synplify Pro, double-click Translate Design in the Process view.

An NGO netlist (.ngo) file is created.

Support Files for the Black Box Module

To maximize the value of a black box module, you need to create additional
material such as declaration and instantiation templates, a data sheet, a
simulation model, and timing attributes. The declaration and instantiation
templates are the minimum information someone else will need to use the
module. The other items are recommended but not required.

Declaration Templates Users will need to know how to declare the module
in their designs. The simplest way to is to supply a file with the code. In the
file, create an empty Verilog module or VHDL architecture declaration. Add
“black box” synthesis attributes for the module and any ports that must attach
to external P1Os. See Figure 21 on page 197 for an example (the synthesis
attribute is for Synplify Pro).

Figure 21: Verilog Sample Declaration

module top (DAT B, DAT A, CD, CK, DAT, OE)

/* synthesis syn black box black box pad pin="DAT B[15:0]" */;
input CD;

input CK;

input OE;

input [15:0] DAT;

inout [15:0] DAT B;

output [15:0] DAT A;

endmodule

Instantiation Template Users will also need a template for instantiating the
module. In another file, create a Verilog or VHDL instantiation template such
as shown in Figure 22 on page 197. Include the “FILE=" attribute for the .ngo
file name. The synthesis attribute is for Synplify Pro.

Figure 22: Verilog Sample Instantiation Template

// Register/Bidirectional Circuit (Lattice NGO)
top top 1 (

.DAT B (DAT B),

.DAT A (DAT A),

.CD (CD),

.CK (CK),

.DAT (cnt),

.OE (OE))

/* synthesis FILE="top.ngo" */;

Data Sheet Users will probably need more information to use the module
effectively. So create a data sheet for the module with details about what the
module does, I/O port function and format, and support contacts.
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Simulation Model To fully simulate their designs, users will need a
simulation model of the module. Base the model on RTL code. If there are
restrictions on how the module is used, pre-compile the model for the target
simulator. If you provide the RTL itself, make it clear that the RTL should not
be re-synthesized unless you are willing to risk timing changes.

Timing Attributes To fully analyze the timing of their designs, users will
need timing information for the module. Create an example use of the module
and run static timing analysis. Then add “black box timing” attributes to the
Verilog module or VHDL component declaration file.

Instantiating a Black Box Module

A black box module may come with a few files besides the .ngo file. The
module should come with a template for the instantiation command and an
empty Verilog module or VHDL component declaration. The module may also
come with a datasheet, a simulation model, or an example implementation.
See “Support Files for the Black Box Module” on page 197.

If there’s a datasheet, refer to it for information about the module and
instructions for its use.

Note

Check what device the module was created for. If your design project is not using the
same or a very similar device, the module may not work.

To instantiate an NGO module:
1. Do one of the following:
Copy the .ngo file to the local project folder.

Specify the file’s location in the Macro Search Path setting of the
Translate Design process in the project’s strategy.

2. Copy and paste the instantiation template and the module declaration into
your design files. This can be done with Diamond’s Source Editor or you
can use any text or HDL editor.

3. Inthe instantiation command, add an instance name and signal names to
the corresponding module ports.

Designing with Lattice Library
Primitives

Any Lattice library primitive described in the “FPGA Libraries Reference
Guide” on page 1571 can be instantiated as a Verilog module or VHDL
component in your RTL design. This sort of “gate-level” design can be error-
prone and should be limited to a small number of primitives if attempted at all.

In general, Lattice recommends you rely on IPexpress to generate modules
that are built with Lattice library primitives.
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To minimize the amount of code overhead required to design with a library
primitive, Lattice provides a Verilog and VHDL synthesis header library file for
each major FPGA device family. Refer to the “Lattice Synthesis Header
Libraries” on page 563 topic for details. Typically the module is treated as a
“black box” which causes the synthesis tool to pass instances of the library
primitive into the target netlist untouched.

Global signals for global set/reset (GSR), power-up reset (PUR), tri-state all
(TSALL), and the internal oscillator (OSCA, OSCC, OSCD, OSCE, OSCF)
can be used within structural models built with Lattice library primitives. For
more information, see “How to Use the Global Set/Reset (GSR) Signal” on
page 1113, “How to Use the Tristate Interface (TSALL) Global Signal” on
page 1129, and “How to Use the Internal Oscillator” on page 1131

The “FPGA Libraries Reference Guide” on page 1571 contains descriptions,
pinouts, and schematic diagrams of all library primitives for Lattice FPGA
libraries.
See Also »"“FPGA Libraries Reference Guide” on page 1571

“Lattice Synthesis Header Libraries” on page 563

“Simulation Library Files” on page 304

“How to Use the Global Set/Reset (GSR) Signal” on page 1113

“How to Use the Internal Oscillator” on page 1131

“How to Use the Power Up Set/Reset (PUR) Global Signal” on page 1128

“How to Use the Tristate Interface (TSALL) Global Signal” on page 1129
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Creating Clarity Designer Modules

Improving design entry has been a goal for many generations of software
tools. Early tools used only designer entered source and very small basic cell
library blocks. Later tools expanded the area for pre-made or generated
blocks. But these tools only provide single-block generation. As multiple
complex blocks are used in devices, resource allocation problems often
occur. These issues require blocks to be planned together and potentially can
even require blocks to be generated with certain options to allow maximum
utilization. To solve these problems tools that can provide capabilities beyond
simple module generation are required.

Clarity Designer Benefits and Features

Clarity Designer is a tool within the Lattice Diamond software environment
that addresses the need to be able to generate and plan multiple blocks
together. Clarity Designer is used for configuration of blocks, building the
connections between blocks, and planning the resources used by the PCS
and DDR blocks in the design. For device families supported by Clarity
Designer, IPexpress functionality is accomplished along with functionality for
building and planning. The IPexpress tool is disabled when using a device
family supported by Clarity Designer. Device families that are not supported
yet by Clarity Designer still require the use of IPexpress. Clarity Designer is
currently only available for the ECP5 device family. A comparison chart
between IPexpress and Clarity Designer features is shown in Table 3.

Table 3: IPexpress versus Clarity Designer

|IPExpress Clarity Designer

Configuration / Generation

Modules Yes Yes

IP Yes Yes

Download IP Yes Yes
Building

Rule checking Mo Yes

Generate Connectivity Mo Yes

Connection Assistance Mo Yes

Design Reuse Mo Yes
Planning (PCS & DDR)

Pre-Synthesis Mo es

Placement Assistance Mo Yes

Rule checking Mo es

Graphical usage Mo Yes
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Configuration and Importing

Clarity Designer produces design (.sbx) files that can be used in the design
project like an HDL file or an IPexpress generated (.ipx) file. A key difference
compared to IPexpress generated files is that Clarity Designer files can
contain multiple modules or IP blocks, not just a single block and can
represent a subsystem. With IPexpress, the process is to generate a module
or IP. This is one step since an IPexpress file can only contain one module or
IP. For Clarity Designer, the saving of a file is a separate step. Modules or IP
are configured and then more modules or IP can optionally be added within
the same file. Additionally, since building and planning can also be done,
saving the file and generating the blocks needs to be done as a later step.

Figure 23: Clarity Designer Module and IP Configuration
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Configuring modules is done by going to the Catalog tab, selecting the
Lattice IP tab at the bottom of the window, and selecting a module or IP and
then double-clicking. A separate dialog box will open that allows the
appropriate options to be set and, when the configure button is pressed, this
information will be added to the Clarity Designer file that is currently open.

To add new IP, when the Catalog tab is selected, select the Lattice IP Server
tab at the bottom of the window, and click the IP folder to get an updated list of
the available IP. Select the IP you want to download from the available list and
click the Download or Install button. Once the IP is installed, it can be
configured as explained above.

If an existing project is being migrated to Clarity Designer from IPexpress,
existing IPexpress files in the design must be imported and saved as Clarity
Designer files. To import existing .ipx files, in the Catalog tab, select the
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Import IP tab at the bottom of the window. In the window you can now select
the existing file and include the name of the converted module for use in
Clarity Designer. After completing the necessary fields, press the Import
button to complete the process. Each existing IPexpress file must be imported
individually.

A unique feature in Clarity Designer compared to IPexpress is the ability to
use an RTL module within the design as a block within the Clarity Designer
file. This is the same as instantiating a block within an HDL module. It is
important to understand that RTL modules are imported into Clarity Designer
are not automatically updated when the RTL is changed. The tool must be
manually refreshed if the RTL is updated. To import an RTL module, the HDL
source code must already be in the Diamond project and showing in the file
list. Then from the Catalog tab, select the Diamond tab at the bottom of the
window. This will show an elaborated view of the design hierarchy. Double-
click the instance that should be imported. The imported module will be
available in the Builder tab for connecting to the rest of the design.

Building

Once one or more modules or IP have been configured, then any connections
between them or to the top of the subsystem (file) can be set. Each Clarity
Designer file is the equivalent of a subsystem like an HDL module.
Information in the file can be self-contained within the subsystem or
connected to the top where it can connect to a higher level of the design
hierarchy. The Builder function allows blocks to be connected to each other or
to the top of the design file (equivalent to an HDL module description of the
blocks and connections). The Builder tab provides two ways to approach this
task. See Figure 24 on page 203.

In the Components view, there are columns showing the components used,
connections, connection type, and a column named “Export.” The Export
column is for connecting a signal to the top of the Clarity Design file. Checking
this column for a signal means that signal connects to the top of the file so it
can be used at a higher level in the hierarchy. By default the Export column is
checked when a module is created in order to mimic the behavior with
IPexpress for creating a file with a single module. The Export column should
be unchecked for signals that are connections between modules.

The Schematic view provides a schematic of the Clarity Designer module
including a block for each module that you've added, external ports, and wires
connecting them all.

Ports can be connected to each other or to the top of the Clarity Designer
module in one of two ways in the Schematic view:

Selecting them and then choosing from the right-click menu. To connect
signals between modules, select the first signal, then Control-click on the
second signal. Right-click on either signal name and then select Connect
from the popup menu to complete the connection. Multiple signals can be
connected by selecting them in this manner. To disconnect signal
connections between modules, right-click on the signal and select
Disconnect in the popup menu. Signals can be renamed by double-
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Figure 24: Clarity Designer Building
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clicking the signal name and typing in the new name. Refer to “Building
with the Schematic View” on page 215.

Using right-click and drag- and-drop functionality to connect available
components, ports, and pins to other available components, ports, and
pins. Refer to “Building with the Schematic View” on page 215.

The primary use of the builder functionality is to improve ease of use for
connecting multiple modules. To connect signals between modules, select the
first signal, then Control-click on the second signal. Right-click on either signal
name and then select Connect from the popup menu to complete the
connection. Multiple signals can be connected by selecting them in this
manner. To disconnect signal connections between modules, right-click on the
signal and select Disconnect in the popup menu. Signals can be renamed in
the Property and Design tabs by double-clicking the signal name and typing in
the new name. Signals cannot be renamed in the Schematic View.

Planning and Determining Usage

After configuring and connecting modules, modules and IP can be placed in
the Planner tab. Currently only PCS-based modules and IP, and DDR-based
modules and IP are supported for placement. Other design elements should
still be placed using Spreadsheet View or through LPF constraints.

In addition, the real-time resource usage report allows you to monitor the
resource usage during the Planning phase. The usage information is updated
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after each planning operation. The report displays used resources and total
available resources, as shown in Figure 25.

Figure 25: Clarity Designer Planning
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Design elements that can be placed are shown in the left panel and a chip-
level view of the FPGA and available resources are shown on the right.
Elements can be dragged from the left panel onto the appropriate resource on
the right panel to be placed. When an element is dragged onto a resource that
can be used, the cursor will change to a “+” to show a valid solution is
possible. The chip view on the right can be zoomed in and out to help with
placing the design elements. Design elements can be dragged as a group or
as individual elements to be placed.

For details on how to do placement on PCS/SERDES and DDR modules,
“PCS/SERDES Planning” on page 216 and “DDR 1/O Planning” on page 222.

Diamond Integration

Clarity Designer outputs source files that are used in a Diamond project like
other source file types such as VHDL, Verilog, EDIF, or IPexpress files. Clarity
Designer files must be added to the file list in order to be used for a project.

To be added to the file list, the file must be generated. This should be done
after the configuration, building, and planning steps. To generate the file, click
the Generate button in the Clarity Designer window toolbar.
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Currently Diamond projects support using Clarity Designer files either as a
module for a level of hierarchy within a design project using HDL as the top
level or as the top level of the design project.

Usage 1—Used as a Module If a Clarity Designer file is used as a module
within an existing design, it must be instantiated within an HDL file, similar to
how IPexpress modules are instantiated within an existing HDL design. Within
an HDL design, multiple Clarity Designer files can be used. However, within a
Clarity Designer file, an instantiated module cannot be another Clarity
Designer file.

Currently, using Clarity Designer files as modules within an HDL design is
recommended. This allows the current hierarchy of a design to be used
without significant changes. If a Clarity Designer file is used as the top-level of
the design, the design hierarchy must meet the requirements specified for
top-level use.

Note that when instantiating generated subsystems in an HDL module, it is
important to use the instance template generated by Clarity Designer. Top-
level I/Os in the subsystem use port names based on instance and port
names by default. Additionally, the instance needs an HDL attribute to
indicate it is a Clarity Designer instantiation. Templates can be found in the
directory in which the .sbx file was saved.

Usage 2—Top-Level of Design If a Clarity Designer file is used as the top-
level of the design, the following requirements must be followed.

All modules and IP must be directly instantiated within this file. Modules
cannot be instantiated within an HDL file. For example, a PLL module
must be in the top-level Clarity file. It cannot be instantiated within an HDL
file.

Any HDL in the design must be imported into the file as a module. HDL
files can contain a hierarchy of other HDL modules, but no Clarity
Designer modules or IP can be instantiated within the HDL.

Clarity Designer files cannot be used as modules within another Clarity
Designer file.

Basic Tasks

Tool usage falls into two primary methods: migrating existing designs in
Clarity Designer and starting new designs in the tool.

Design Migration versus New Designs

When migrating an existing design into Clarity Designer, it is recommended
that the design hierarchy should be unchanged and each existing IPexpress
(.ipx) file should be imported into Clarity Designer and replaced with a new
Clarity Designer (.sbx) file as illustrated in Figure 26 on page 206. The
exceptions to this are PCS/SERDES and DDR modules and IP. Since these
should be placed together for efficient resource use, the PCS/SERDES
modules need to be in one Clarity Designer file and DDR modules in another
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file. This means one module should be imported and then the existing Clarity
Designer file should have the other modules copied and instantiated within it.
See “Importing Existing PCS or DDR Modules or IP” on page 209 on steps
needed for this.

Figure 26: Migrating Existing Designs in Clarity Designer
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*  One module perfile + Migrated from |IPexpress
+  One module perfile

Existing Design Migration

New designs can be optimized for efficient use in Clarity Designer. Modules
that have a high amount of interconnection should be placed in the same
Clarity Designer file. Modules at the same hierarchy level even though they
are not interconnected can also be placed within the same file, as shown in
Figure 27 on page 206. This will reduce the effort to configure, generate, and
save them independently. The goal for new designs should be to use the tools
most efficiently for your design structure rather than follow the same method
needed for using IPexpress.

Figure 27: New Design Entry in Clarity Designer
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Running Clarity Designer

To run Clarity Designer, first ensure that your device supports it. If it does not,
it may support IPExpress instead.

To open the Clarity Designer startup dialog, do one of the following:

Choose Tools > UEEI Clarity Designer
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Click EEE Clarity Designer in the toolbar

The tool can also be launched by choosing File > New > " File to create a
new Clarity Designer file. Double-clicking an existing Clarity Designer file in
the File List view will open that file and launch the tool. Only one Clarity
Designer file can be open at a time.
Clarity Designer allows you to do the following tasks:

Configure modules and IP from the Catalog tab

Download and install new IP from the Catalog tab

Import IPexpress (.ipx) files from an existing project and convert them into
Clarity Designer format

Import HDL modules from the project for use as modules within Clarity
Designer

Connect modules from the Builder tab
Place PCS/SERDES and DDR elements into FPGA resources from the
Planner tab

Using Single Module Generation The Start Clarity Designer to generate
a single Component SBX option that appears when launching Clarity
Designer provides a streamlined interface for generating single modules. This
mode hides the Builder and Planner interfaces in Clarity Designer’s main
interface, as well as the DRC and Generate toolbar menus in Clarity
Designer’s toolbar menu. When customizing a module/IP, the Instance Path is
editable and the Module Output does not have a default value.

To generate a module with Single Module Generation:

1. Open the Clarity Designer startup dialog

2. Select Start Clarity Designer to generate a single Component SBX
3. Click Start
4

Double-click an item in the Clarity Designer catalog to open the
“Customize” dialog

5. Set the configuration options and click Configure to generate the module

Clarity Designer will use this information to create and save the SBX file. If
it does not exist in the Diamond File List, a pop-up dialog box will appear
to confirm whether the file should be added to the File List.

To modify a module with Single Module Generation:

1. Open the Clarity Designer startup dialog

2. Select Open Clarity Design

3. Choose a Single Module/IP SBX file from the “Design File” list
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4,

Click Open

Note

You can also open a project by double-clicking it in the main window’s File List tab.

Modify the configuration options
Click Configure

Diamond will process the project file if the new SBX file is the project file.
After the Configuration dialog closes, Clarity Designer will stay open in
Single Component Mode.

Importing Existing Modules and IP from an Existing

Desi gn

Modules and IP that were generated with IPexpress and are in the project can
be imported into Clarity Designer. They must be imported and configured, and
the file generated and saved in the file list. Once the Clarity Designer (.sbx)
file is saved in the file list, the existing IPexpress files must be deleted from
the file list in order to successfully implement the design. The steps are shown
below.

To import an IPexpress module:

1.

o M DN

10.

Open Clarity Design using the toolbar, Tools menu, or by creating a new
file.

In Clarity Designer, click the Catalog tab.
Click the Import IP tab (at the bottom of the view).
Click Browse.

In the Open IPX File dialog box, browse to the .ipx or .Ipc file of the
module. Use the .ipx if it is available.

Click Open.
Most of the Import IP view is filled in.

Type in a name for Target Instance. This is the name that will be used for
the configured module in the Clarity Designer project.

In the Target area, choose a Core Version. Usually you will leave it with
the latest version.

Click Import.
The module’s dialog box opens.

In the dialog box, choose desired options. To get information about the
options, click Help. Also, check the About tab in the Lattice IP view for
links to technical notes and user guides. Downloaded IP may come with
additional information.

As the options change, the schematic diagram of the module changes to
show the ports and the device resources the module needs.
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11. Click Configure.
12. Click the Generate Log tab to check for warnings and error messages.
13. Click Close.

14. Click Generate in the Clarity Designer toolbar and import the Clarity
Designer file into the File List view.

15. Delete the original IPexpress file from the File List view.

The module or IP is now configured and is available in the Builder tab for
connections. It is recommended that the Clarity Designer file be saved and
the process repeated for each existing IPexpress file. This will allow the
original design hierarchy to be reused without changes. However, if any of the
modules or IP use PCS/SERDES or DDR resources, use the procedure
below.

Importing Existing PCS or DDR Modules or IP

Modules and IP that were generated with IPexpress and are in the project can
be imported into Clarity Designer. They must be imported and configured, the
file generated and saved in the file list. Once the Clarity Designer (.sbx) file is
saved in the file list, the existing IPexpress files must be deleted from the file
list in order to successfully implement the design. The steps are shown below
for when an existing module or IP uses PCS/SERDES or DDR resources.
This procedure is different because PCS modules or DDR modules should be
in the same Clarity Designer file to allow proper planning of the resources in
the FPGA.

To import a PCS or DDR module:

1. Open Clarity Design using the toolbar, Tools menu, or by creating a new
file.

In Clarity Designer, click the Catalog tab.
Click the Import IP tab (at the bottom of the view).

Click Browse.

o &~ DN

In the Open IPX File dialog box, browse to the .ipx or .Ipc file of the
module. Use the .ipx if it is available.

6. Click Open.
Most of the Import IP view is filled in.

7. Type in a name for Target Instance. This is the name that will be used for
the configured module in the Clarity Designer project.

8. Inthe Target area, choose a Core Version. Usually you will leave it with
the latest version.

9. Click Import.
The module’s dialog box opens.

10. In the dialog box, choose desired options. To get information about the
options, click Help. Also, check the About tab in the Lattice IP view for
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links to technical notes and user guides. Downloaded IP may come with
additional information.

As the options change, the schematic diagram of the module changes to
show the ports and the device resources the module needs.

11. Click Configure.
12. Click the Generate Log tab to check for warnings and error messages.
13. Click Close.

14. Repeat steps 2 - 13 for each existing module using the same resources
(all PCS/SERDES modules should be in one Clarity Designer file and all
DDR modules in another Clarity Designer file).

15. Click Generate in the Clarity Designer toolbar and import the Clarity
Designer file into the File List view.

16. Delete the original IPexpress file from the File List view.

The modules or IP are now configured and are available in the Builder tab for
connections. They will also show in the Planner tab to allow those resources
to be placed. Consolidating multiple modules within a single hierarchy level in
a Clarity Designer file may require the original design hierarchy to be
modified. This will vary for different designs on a case by case basis. Although
this may cause design changes, there is a benefit to doing this. By putting the
DDR modules, for example, in the same file these resources can now be
planned together and feedback given on whether a valid placement is
possible. Previously, constraints would need to be entered and if the solution
was not valid, later implementation engine stages would generate errors. This
new methodology is a faster and easier solution to placing resources within
an FPGA and getting feedback if the solution is possible.

Current Restrictions

Clarity Designer contains several restrictions in this release. The list below
lists the general usage restrictions. Restrictions within each module or IP are
dependent upon the FPGA target and the use of that module or IP.

Using Clarity Designer file as the top level of a design

All modules and IP must be directly instantiated within this file.
Modules cannot be instantiated within an HDL file.

Any HDL in the design must be imported into the file as a module.
HDL files can contain a hierarchy of other HDL modules, but no Clarity
Designer modules or IP can be instantiated within the HDL.

Clarity Designer files cannot be used as modules within another
Clarity Designer file.

Builder tab connections
Cannot set HDL parameters of user modules.
Cannot tie ports with constants.
Cannot connect ports to logic equations.

Implementation process
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No IPexpress (.ipx) files are allowed in the File List view.

Clarity Designer (.sbx) files must be generated before they can be put
into the File List view.

Clarity Designer files must be in the File List view in order to correctly
implement the design.

IP or Module Generation

IP or Module configuration is accomplished in the Catalog tab. Existing
modules and installed IPs are listed in the Lattice IP sub-tab in the Catalog

tab.

Downloading Additional IP

All available modules are installed with the Lattice Diamond software
installation. Additional IP are downloaded from a Lattice IP site within the
Clarity Designer tool. To add additional IP, the Lattice IP Server tab is used to
download and install them.

To download Lattice IP:

1.

If you are working on Linux and this is the first IP you have ever installed,
go to your home directory and, with a text editor, create an empty file
named ipsetting_l.Ist. Enter no text: the file must be empty and must
have this name. If you find you already have a file with this name, do not
change it. This is a text file listing your IP and their path names.

In Clarity Designer, click the Catalog tab.

Click the Lattice IP Server sub-tab, located at the bottom of the tool.
Click IP in the left pane.

The software connects to the Lattice Semiconductor Web site.
Expand the folder tree and select the IP you want to download.

Information about the IP appears in the right pane including links for
additional information.

Do one of the following:

To download and install the IP, right-click the IP and choose Install
in the pop-up menu.

To just download the IP for later installation, right-click the IP and
choose % Download in the pop-up menu.

Follow the on-screen instructions.
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Installing a Downloaded IP
After downloading an IP, you must install it to make it available in Clarity

Designer.

Installing on Windows To install the IP:

1. If Clarity Designer is open, close it.

2. Go to the location where you saved the IP.

3. Double-click the executable file (.exe).
The Lattice Semiconductor Setup program opens.

4. Follow the on-screen instructions.
Open Clarity Designer to see the installed IP. Click the Catalog tab and
then the Lattice IP tab. Then expand the IP folder tree.

Installing on Linux To install an IP that you downloaded earlier on Linux,
the process depends on whether the download is a tar file (.tar.gz) or a shell
file (.sh).

To install the IP from a tar file:

1. Ifthis is the first IP you have ever installed, go to your home directory and,
with a text editor, create an empty file named ipsetting_l.Ist. Enter no
text: the file must be empty and must have this name. If you find you
already have a file with this name, do not change it. This is a text file
listing your IP and their path names.

N

Go to the location where you saved the IP.

w

Enter the following in a command line:
tar -zxvf <filename>.tar.gz
4. In Clarity Designer, click the Import User Configurable IP = button.

5. Inthe dialog box, browse to the installation directory for the IP and select
nodeinfo.cfg.

Click Open.

To see the installed IP, click the Catalog tab and then the Lattice IP tab.
Then expand the IP folder tree.

N oo

To install the IP from a shell file:
1. Go to the location where you saved the IP.
2. Enter the following in a command line:
sh <filename>.sh <Diamond install path>/bin/lin [<destination path>]

The <destination path> is the full path name of where you want the IP to
be installed. If not included, the IP will be installed in the current directory.

The first time you install an IP, the installer creates a file, ipsetting_l.Ist, in
your home directory. This is a text file listing your IP and their path names.

Lattice Diamond 3.6 Help

212



Creating Clarity Designer Modules

3. To see the installed IP, click the Catalog tab and then the Lattice IP tab.
Then expand the IP folder tree.

Configuring Modules or IP

To customize a module or IP with Clarity Designer, go to the Catalog tab. After
the module or IP has been configured, it will be available in the Builder tab
and, if it uses PCS/SERDES or DDR resources, the Planner tab.

To configure a module or IP:
1. Inthe Catalog tab, double-click the IP that you want to configure.

A dialog box opens with some general information about the IP. To get
more information about the IP, see the About tab to the right in Clarity
Designer.

2. Inthe dialog box, specify the Instance Name. Instance Name is the base
name for the module’s files (that is, with no extension).

Choose from the Module Output menu. This is how the IP will be coded.
4. Click Customize.
The IP’s dialog box opens.

5. Inthe dialog box, choose desired options. To get information about the
options, click Help. Also, check the About tab in Clarity Designer for links
to technical notes and user guides. Downloaded IP may come with
additional information.

As the options change, the schematic diagram of the module changes to
show the ports and the device resources the IP needs.

6. Click Configure.
7. Click the Generate Log tab to check for warnings and error messages.
8. Click Close.

The IP is added to the Builder tab and, if it uses PCS/SERDES or DDR
resources, to the Planner tab.

Building
After configuring modules and IP, they need to be connected to each other

and to the top of the Clarity Designer subsystem. The Builder tab provides two
ways to approach this task:

The Components view provides a spreadsheet listing all of the modules
and their ports. The columns show how the ports are connected.

The Schematic view provides a schematic drawing of the modules and
their ports. You can drag the parts to see how they fit together.

Click the tab at the bottom of the Builder view to select the mode that you
want to start with. You can change mode anytime you want.

Lattice Diamond 3.6 Help

213



Creating Clarity Designer Modules

Once building is complete, the subsystem can be planned or generated and
saved if no planning is required. Once the subsystem has been generated,

the design can be implemented with the design flow in the Lattice Diamond
software.

Building with the Components View

The Components view lists all of the modules in the Clarity Designer project
along with all of their ports. For each port there are three fields:

Connection is the name of the connecting net that you will define in
Builder.

Type is how the port was connected:
“un-connected” indicates the signal has not been connected yet.
“fabric” indicates a user-defined connection.
“internal” indicates a connection made in the Planner tab.
“pad-pin” indicates a connection to the I/O of the FPGA.

Export is checked when the signal is connected to the top of the
subsystem.

To connect a port to the top of the Clarity Designer subsystem:

Select the check box in the Export column.

The default name of the connecting net appears in the Connection column
for the selected port. This will also be the name of the port in the Clarity
Designer subsystem. The default name is based on the module and port
names of the port. You can change the name by double-clicking it and
typing over it.

To connect module ports to each other:

1.

If you want to change a connection, right-click one of the ports and choose
Disconnect.

Select the ports that you want to connect together. You can select several
input ports if they will all use the same source. There can be no more than
one output port selected. There can be zero output ports selected if one of
the input ports has its Export box selected.

Output ports have yellow arrows that point left. Input ports have dark
blue arrows that point right.

Right-click the name of one of the selected ports and choose Connect.

The default name of the connecting net appears in the Connection column
for each of the selected ports. The default net name is based on the
module and port names of the output port. You can change the net name
by double-clicking it in any row and typing over it.
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Building with the Schematic View

The Schematic view provides a schematic of the Clarity Designer module
including a block for each module that you've added, external ports, and wires
connecting them all. The Schematic view also has two additional panes:

The Design pane provides a nested list of all modules, their ports, and the
ports of the Clarity Designer module.

The Property pane provides information about the selected object (in the
General tab) and a list of related wires (in the Connections tab).

To connect a port to the top of the Clarity Designer subsystem:

1.
2.

Select the port.
Right-click in the schematic and choose Export.

The default name of the connecting net appears in the Connections tab of
the Property pane. This will also be the name of the port in the Clarity
Designer subsystem. The default name is based on the module and port
names of the port.

To connect module ports to each other using right-click:

1.

If you want to change a connection, select one of the ports. Then right-
click in the schematic and choose Disconnect.

Select the ports that you want to connect together. You can select several
input ports if they will all use the same source. There can be no more than
one output port selected. There can be zero output ports selected if one of
the input ports has its Export box selected.

In the Design pane, output ports have yellow arrows that point left.
Input ports have dark blue arrows that point right.

Right-click the name of one of the selected ports and choose Connect.

The default name of the connecting net appears in the Connection column
for each of the selected ports. The default net name is based on the
module and port names of the output port.

To connect module ports to each other using drag-and-drop:

1.

If you want to change a connection, select one of the ports. Then right-
click in the schematic and choose Disconnect.

Select the output pin of the port you wish to connect, and using the left
mouse button, drag-and-drop it onto the pin of the input port you wish to
which you wish to connect. A green check mark appears if the
connection is allowed.

Release the left mouse button to make the connection. In the top portion
of the example shown in Figure 28 on page 216, the
adderl_Result_Im[15] output bus is dragged and dropped onto the
available DataA-Im[15:0] input of adder2. The bottom portion of the figure
shows the resulting connection when the left mouse button is released.
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Figure 28: Drag and Drop Connections in Schematic Editor
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PCS/SERDES Planning

In order to plan the PCS/SERDES resources, the PCS or SERDES modules
must be generated using the Catalog tab. If there is any connectivity between
these modules, these connections must be completed in the Builder tab. “IP
or Module Generation” on page 211 and “Building” on page 213 describe how
these tasks can be accomplished. Once the modules are generated, the
placement of the PCS or SERDES modules can be planned in the Planner
tab.

PCS Configuration

An example for creating the SERDES Eye Demo using ECP5 is shown in
Figure 29 on page 217. For this application both the Extref and PCS modules
must be selected and configured from the Catalog tab.

Each module must be configured independently. Once both modules have
been configured, they will appear in the Builder tab. They can then be
connected to other modules in the subsystem or exported to the level above
for connection in RTL code to the rest of the design. See “IP or Module
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Figure 29: PCS Configuration Example
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Generation” on page 211 and “Building” on page 213 for details on module
configuration and building.

PCS Planning

To place the generated PCS module and the Extref modules, they can be
dragged and dropped from the Resource listing on the left side of the Planner
tab to the resources in the chip view on the right. The PCS-related resources
are shown in the bottom section of the chip view as show in Figure 30 on
page 218.

By placing the PCS module and the Extref, Clarity Designer will incorporate
the placement of PCS module and the Extref block to the location
automatically without any additional constraints or editor preferences.

Once all PCS related resources are placed, then the DRC can be used to
check that there are no DRC errors and use the generate button to complete
the Clarify Designer subsystem and incorporate it into the Diamond project
design flow.

Using Multiple PCS Modules in a Single DCU

To place multiple PCS channels in the same DCU, proper care must be taken
to ensure that the two PCS blocks used in the design should be using the
same external reference clock frequency and TXPLL settings for both the
channels in the same DCU.

For example, a PCI Express x1 at 2.5 Gbps and a Gigabit Ethernet channel
can share the same DCU using the half-rate option on the Gigabit Ethernet
channel. When a DCU shares a PCI Express x1 channel with a non-PCI
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Figure 30: PCS-Related Resources
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Express channel, the reference clock for the DCU must be compatible with all
protocols within the DCU.

Figure 31: Using Multiple PCS Modules in a Single DCU
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The placed DCU channels will be displayed as shown in Figure 32 on
page 219.
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Figure 32: Placed DCU Channels
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DCU Settings

In order to choose the TX and RX settings for the DCU, double-click the
placed channel of the DCU and choose the input clock to the TXPLL inside
and the reference clock for the RX side of the DCU as shown below:

Figure 33: Setting DCU Clocks
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If there are multiple protocols that use the same reference clock or one
protocol with a single reference clock frequency, choose the input to the TX
and RX input clocks (TXPLL and RX setting clock) on the DCU. Either the
Primary Clock input from the FPGA logic or a clock input from Extref
components of DCUO can be used.

Multiple Protocols on the Same Device

If multiple protocols have to be supported using a single ECP5 device that has
different reference clocks, then the same DCU cannot be supported. A
different DCU has to be implemented with its own external reference clock
and Tx PLL settings with a PCS block to support multiple protocols as shown
in Figure 34 on page 221.

The placed DCU channels will be displayed as shown in Figure 35 on
page 221.

DCU Settings with Multiple Protocols

In order to choose the TX and RX settings for the DCU, double-click the
placed channel of the DCU and choose the input clock to the TXPLL inside
and the reference clock for the RX side of the DCU as shown in Figure 36 on
page 222.

If there are multiple protocols, choose the input to the TX and RX input clocks
(TXPLL and RX setting clock) on the second DCU. Use either the Primary
Clock input from the FPGA logic or inputs from the Extref components of
DCUO or DCUL1.
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Figure 34: Using Multiple Protocols in the Same Device
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Figure 35: Placed DCU Channels
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Figure 36: Setting DCU Clocks
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DDR 1/O Planning

In order to plan the DDR 1/Os, the DDR modules must be generated using the
Catalog tab. If there is any connectivity between these modules, these
connections must be completed in the Builder tab. “IP or Module Generation”
on page 211 and “Building” on page 213 describe how these tasks can be
accomplished. Once the modules are generated, you can plan the placement
of the DDR modules in the Planner tab.

Planner View for DDR Modules

Once DDR modules are generated, they are listed in the Planner. The
resources required by each of the DDR modules are listed next to the module
name. This includes the number of I/O required, number of PLLs used, and
number of DLLs used by that module.

Each DDR module, when expanded, will show the clock groups under that
module. The ports and primitives in each of the DDR modules is grouped
based on the clocking requirement. All ports and elements clocked by the
same clock are listed in a given clock group. This clock group could be a high
speed “ECLK” (edge clock) group for interfaces that use a gearbox (x2 or x4)
or a slower speed “SCLK” (primary clock) group for interfaces that do not use
a gearbox (x1).

Each clock group will include:
Port list
Primitive list
ECLK and ECLKBRIDGE resources (if used by that module)
Once a port is placed, the Placement column shows pin numbers next to each

of the ports and the ECLK resources shows the ECLK that was used for that
interface.
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The figure below shows how an interface will look when listed in the Planner
tab. This interface is used for an example to show the clock grouping and port
list. This Interface has two ECLK groups. Each group lists the ports clocked
by that ECLK, the primitives that are clocked by that clock, and the ECLK
resources.

Note that in this release, the ECLK resource section lists all the ECLKs and
ECLKBRIDGESs available on the device even though only one ECLK is used
in the clock group. Once the interface is assigned it will only show placement
information for the ECLK that is used by that interface.

Figure 37: DDR Modules in the Planner View
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Reconfiguration of an Interface

An interface can be reconfigured by right-clicking and selecting Config. This
will allow you to change the interface parameters by opening the dialog box
for that module.

Placing a DDR Interface

The following steps should be used to place any of the generated DDR
interfaces.

1. Select the clock group under a given interface and then drag and drop
onto the chip view. A valid location is indicated by a “+” symbol. Once the
location is selected, the interface pins will be placed in a counterclockwise
direction.

The following also happens:
The pins used are displayed in the chip view.
The corresponding IOLOGIC cell will be highlighted.
If the group is an ECLK group, the ECLK tree used will be displayed.

The left pane will also display the locations of the Ports, ECLKs, and
Primitives.

2. Drag and drop of a clock group will only place the data pins of that
interface. The clock input pins in that interface will have to be placed
manually. Expand the clock group and select the clock input pin. Drag it
onto the dedicated clock pin. Right-click in the chip view to get the option
to filter out all the dedicated clock pins.

The following happens:

Once the clock pin is placed, the PLL, DLL, CLKDIV, and
ECLKBRIDGE used by the DDR module will be displayed in the chip
view.

The left pane will also display the locations of these modules.

If an interface cannot be placed in the location when the ports are dropped
due to architectural limitations, all the data ports will be placed in the next
available location. If it is a clock input port, Planner will not place the port and
will issue a DRC message in the Output view.

DDR Interface Planning Guidelines

Here are some general rules to follow when placing DDR modules. Refer to
the “High Speed Interface” technical note for the device for details on
placement of each type of DDR interface using Clarity.

On DDR interfaces, the data ports have to be placed before placing the
clock input ports. Once the data ports are placed, manually drag and drop
the CLKIN port to the desired location. The PLL, DLL, and CLKDIV used
with the clock are not placed until the input CLK port is placed. This also
applies to REFCLK input ports of PLL modules when generated with the
DDR modules.
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On drag-and-drop of any interface, only data pins are placed. You have to
manually place the clock input to any of the GDDRX interfaces as
explained in “Placing a DDR Interface” on page 224.

When placing the data ports, Planner does not use the dedicated clock
sites on the device. These are reserved for the clock inputs.

You must try to place all the data and clock ports of a given interface on
one side. If there is a requirement to go around the corner to the other
side, Planner uses the ECLKBRIDGE if it is available on that device. You
must enable the ECLKBRIDGE when configuring the IP. Refer to the
“High Speed I/O Interfaces” technical note for the device for details on
how to use Planner to plan an interface with an ECLKBRIDGE.

There are only a limited number of high speed clock (PLL, DLL, and
ECLK) and 1/O logic elements on each device. Planner does not allow
interfaces to be placed if it runs out of resources.

Planner always places the pins in a counterclockwise direction. You must
drag and drop interfaces at the optimum location so that pins are not lost
during planning. For example, if you require that all pins be placed in a
single bank, the interface should be dropped at the first valid location of
that bank counting counterclockwise so pins do not overflow to the next
bank. Similarly, if all pins need to be on the same side, you must drag and
drop at the first valid pin of the side. If you drag it into the edge of the side,
the ports will automatically overflow to the other side, which forces
Planner to use an ECLKBRIDGE when it is not required.

When placing a GDDRX or DDR_MEM module that requires a PLL
module, you can either choose to generate a PLL with the interface
module or use a stand-alone module. If you choose to generate a PLL
with the DDR interface, you must also choose the input buffer standard for
the CLKI input of the PLL. This is required for Planner to correctly place
the PLL. This will apply for GDDR.TX “centered” and DDR Memory
modules.

If planning the DDR Memory IP Cores, refer to the IP Core user manual
for guidelines on placement of each IP module.

The chip view after placement of interfaces is shown in Figure 38 on

page 226. This figure highlights some of the DDR resources that get used for
an interface. For more details on the DDR resources, refer to the “High Speed
I/O Interface” technical note for the device.

Viewing Interface Placement
Once an interface has been placed, you can view the placement by:

Clicking on the port in the left pane to locate it in the chip view. The
location of this port is highlighted in the chip view.

Clicking on the placed pin in the chip view, which will highlight the port in
the left pane.
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Figure 38: DDR Resources in the Planner View
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Resetting or Modifying Placement
Once the interface has been placed, it can be reset or modified using the
following methods:

If the entire interface placement has to be reset, right-click on the
Interface name in the left pane and choose Reset.

If the assignments for one of the clock groups under the interface have to
be reset, right-click on the clock group in the left pane and choose Reset.
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If placement for a signal port has to be modified, choose the port in the left
pane and drag and drop it to its new location.

If placement for a signal port has to be reset, right-click on the port in the
left pane and choose Reset.

Note

Clarity does not support multiple select on ports. The workaround is to modify
placement of each port or modify placement of the entire clock group

Filtering Pin Types

You can get to the filter by either right-clicking on the chip view or on the
toolbar. Planner allows filtering of dedicated PCLK pins, PLL/DLL clock pins,
True LVDS pins, VREF pins, and so on. These will vary for each device. Refer
to the “High Speed Interface” technical note for the device to see the options
available.

Design Rule Check

Once all the interfaces are placed, you can click % DRC in the toolbar to see
the list of warning and error messages.

Current Restrictions

Planner does not see the signal connectivity in Builder. The workaround is
to export the ports to the SBX file and make the connectivity outside of the
SBX module. So any clock sharing between different DDR modules has to
be external to the SBX.

Stand-alone PLL are not available in Planner for placement or connection.
Any connections to stand-alone PLL have to be done externally to the
SBX.
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Designing with LatticeMico Platforms

Lattice Diamond allows you to import a platform that you have created in
LatticeMico System. Such a platform includes a microprocessor and
peripheral components that can be implemented in a Lattice FPGA device.

LatticeMico System is included as an optional installation with Diamond,
through an open IP core licensing agreement. It can also be downloaded from
the Lattice web site. LatticeMico System enables you to build the embedded
processor platform using MicoSystem Builder and afterwards incorporate the
platform’s source files into a Diamond project. After generating the data file,
you can use the Programmer tool to program the FPGA device or boot
memory device on your target system.

For complete information about building a LatticeMico platform, see the Mico
System Builder section of the LatticeMicoSystem online Help.

See Also “About LatticeMico System” on page 228
“Running LatticeMico System” on page 229
“Adding a LatticeMico Platform” on page 38

About LatticeMico System

LatticeMico System is based on the Eclipse C/C++ Development Tools, which
provide an open-source framework for building software. It contains two
integrated tools and a debugger that combine with the Diamond software to
build the microprocessor platform on an Lattice FPGA device and write the
software code to drive it.

Lattice Mico System Builder (MSB) The Mico System Builder enables you
to generate a platform description and associated HDL for a hardware
implementation, choose peripheral components to attach to the LatticeMico32
microprocessor or LatticeMico8 microcontroller, and specify connectivity
between peripheral components.

After generating the platform in MSB, you can import the HDL files into
Diamond, perform functional and timing simulation, place and route the
design, and download the bitstream to the Lattice FPGA device using the
Programmer tool.

For complete information about using MSB to generate a platform, refer to the
Mico System Builder section of the LatticeMico System online Help.

Lattice Software Project Environment (SPE) and Debugger The Lattice
Software Project Environment enables you to develop the C or C++
application code that runs on platforms created with MSB, use the debugger
to validate the code, and deploy the application code to on-chip or flash
memory.

For complete information about using SPE to develop an application for tthe
LatticeMico32 microprocessor or LatticeMico8 microcontroller, refer to the
Lattice Software Project Environment section of the LatticeMico System
online Help.
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See Also »“Running LatticeMico System” on page 229
“Adding a LatticeMico Platform” on page 38

Running LatticeMico System

If you are using Microsoft Windows, you can start LatticeMico System from
the Windows Start menu. If you are using Linux, you can start LatlticeMico
System from the command line.

To open LatticeMico System using the Windows Start menu:

Choose Start > Programs > Lattice Diamond > Accessories >
LatticeMico System

To open LatticeMico System using Linux:
1. Navigate to the following directory in the installation:
<install_path>ispcpld/bin
2. Type the command source setup lv.csh.
Or, if you are using the Korn shell, type source setup lv.sh.
3. Change to the LatticeMico installation directory.
4. Type LatticeMicoLauncher.
LatticeMico System opens in a separate window. To create a new platform for
your design, click the MSB button to open the Mico System Builder
perspective.
See Also »“About LatticeMico System” on page 228
“Adding a LatticeMico Platform” on page 38
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Schematic Design Entry

The Diamond schematic design environment is a set of tools that allows you
to capture the structure of a design as either a flat description or a hierarchical
set of components and the connectivity between these components. Then you
can use this description to drive logic synthesis, implementation, and
verification tools of the FPGA design flow. Schematics can be drawn on
multiple “sheets” and be a variety of sizes.

Schematic Editor works in conjunction with Symbol Editor and Symbol Library
Manager. You design by laying out symbols for basic functions and other
modules and drawing wires between their ports. You can also create your own
library of custom schematic symbols.

Schematic Overview

Unless you're using them just for documentation, schematics are actually the
starting point of the development process, not the goal. The schematic will
eventually be used to analyze the device's behavior using logic simulation
and implement the logic into the target device using place and route. The
Lattice Diamond software includes a Schematic Editor for creating and editing
schematic sources. The figure below is an example schematic that represents
2-bit comparator gate.

Figure 39: Schematic Sample of a 2-bit Comparator
Comparator library element from lattice. lib

|2 AGEBZ

20 GE
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BO
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In the above schematic there are five inputs (labeled A0, Al, BO, B1, and CI)
and one output (GE). The function of 12 is to perform a comparison of A[1:0]
and B[1:0] with CI serving as carry-in.

In the FPGA design flow, Diamond creates a structural HDL model of the
schematic in terms of component instances as in the following Verilog and
VHDL.

Depending on the target device and version of the software, a symbol library
may be provided or you may create your own symbols using Symbol Editor. A
symbol library, lattice.lib, is provided for gate-level design of Lattice FPGA
device families. The Lattice FPGA symbol library represents a sub-set of the
library elements documented in the “FPGA Libraries Reference Guide” on
page 1571. In addition, IPexpress automatically produces schematic symbols

Figure 42 on page 232 is a much more complex schematic.
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Figure 40: Verilog HDL of a 2-Bit Comparator Schematic

/* Verilog model created from schematic sample.sch -- Feb 27,
2006 13:44 */
module sample( A0, Al, BO, Bl, CI, GE );
input AO0;
input Al;
input BO;
input B1;
input CI;
output GE;
AGEB2 I2 ( .AO0(AO0), .Al(Al), .BO(BO), .B1(B1l), .CI(CI), .GE(GE)
)i
endmodule // sample

Figure 41: VHDL of a 2-Bit Comparator Schematic

-- VHDL model created from schematic sample.sch -- Feb 27
13:43:23 2006

LIBRARY ieee;

USE ieee.std _logic_1164.ALL;

USE ieee.numeric_std.ALL;

entity SAMPLE is

Port ( A0 : In std logic;
Al : In std logic;
BO : In std_logic;
Bl : In std_logic;
CI : In std_logic;
GE : Out std logic );

end SAMPLE;

architecture SCHEMATIC of SAMPLE is
SIGNAL gnd std logic := '0';
SIGNAL vcc std logic := '1';
component AGEB2

Port ( A0 : In std logic;

Al : In std logic;
BO : In std logic;
Bl : In std_logic;
CI : In std_logic;
GE : Out std logic );

end component;

begin
I2 : AGEB2

Port Map ( AO=>A0, Al=>Al, B0=>B0, B1l=>Bl, CI=>CI, GE=>GE
)i
end SCHEMATIC;

What is a Schematic?

The schematic file (saved as a .sch file) describes your circuit in terms of the
components used and how they connect to each other. The schematic can be
used to create HDL structural models for logic simulation or synthesis. A
schematic can represent a simple logic process (such as an AND gate) or a
more complex component in your design (such as a memory function). It can
also represent the top-level of your design.
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Figure 42: Complex Schematic Sample
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What do Schematics Consist of? A schematic is composed of the
following items:

Symbols - These can be symbols from the standard symbol libraries, symbols
representing other schematics you have drawn (Block symbols), or symbols
you have created from scratch.

Wires - Wires connect the symbols. They can be single-signal (nets) or
multiple-signal (buses).

I/O Ports - I/O ports show where signals enter or exit the schematic and the
direction (polarity) of the signal. That is, whether it is an input, output, or bi-
directional signal.

Attributes — Attributes are used to add functional characteristics such as user
constraints to wires or symbols that are interpreted by tools like logic
synthesis and place and route. Schematic attributes are translated into
Verilog or VHDL attributes by the schematic netlister.

Graphics and Text - Graphics and text are usually added to display
explanations. They are optional and have no electrical meaning.

A valid schematic must contain at least the first three components—symbols,
wires, and I/O ports. For instance, a single, isolated component symbol
cannot be the only element in a schematic. The schematic must include 1/0
ports for the external connections to the schematic, and these ports must be
connected to the symbol with wires.

Symbols Symbols are graphic representations of components. The term
“symbol” usually refers to an electrical symbol, such as a gate or a sub-circuit.
You can draw graphic-only symbols (such as title blocks) with Symbol Editor,
but these have no electrical meaning.
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Figure 43: A Valid Schematic
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Figure 44: Invalid Schematic (No Wires or 1/O Ports)
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Symbols are the most basic elements of a schematic. Symbols represent
primitive design elements, whether those elements are complete gates or a
complex macro. A symbol can also be the hierarchical representation of a
sub-circuit, or a “Block” symbol.

Each schematic symbol is a file ending with a .sym extension, and may be
included in a library file with a .lib extension. The symbol file contains four
types of information: graphics, text, pins, and attributes.

Pins Symbol pins are the connecting points between the symbol and the
schematic wiring. If the symbol represents an individual component, the
symbol pin represents the physical pin where a conductor can be attached. If
the symbol represents a subcircuit (block symbol), the symbol pin represents
a connection to an internal net of the subcircuit.

Wires Wires are the lines that electrically connect the symbol pins. Symbol
pins are the only connection points for wires. You cannot connect wires to the
symbol body itself.

There are two types of wires: single-wire nets and multiple-wire buses. Buses
allow more than one signal to be routed as a single line.

Wires (both nets and buses) are added to schematics using the Edit > Add >
Wire or the Edit > Add > Net Name commands of Schematic Editor.

There is only one kind of wire you can add (using the Edit > Add > Wire
command). Whether it is a net or a bus depends on how you name the wire
(using the Edit > Add > Net Name command). For instance, buses are
named as <busname> [<numberlist>] where <busname> is the name of the
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bus and <numberlist> is an optional list of numbers separated by commas
representing each net in the bus.

You would normally name all wires that connect to inputs or outputs and any
internal nets with signals you want to view during simulation. You can use any
name you like, but you usually choose a hame that suggests the name or
function of the signal carried by that wire. If you do not give a wire a name,
Schematic Editor automatically supplies one, of the form N_<n> (where <n>is
an integer).

Giving a single wire a compound name creates multi-wire buses. You can
then tap off any signal you want anywhere along the bus.

Buses are most often used to group related signals, such as a 16-bit data
path. However, a bus can be any combination of signals, related or not. Buses
are especially useful when you need to route a large number of signals from
one side of the schematic to the other.

Buses also make it possible for a single 1/0 port to connect more than one
signal to a Block symbol. The signal names do not have to match, but both
pins must carry the same number of signals.

I/0 Ports 1/O ports mark the points at which signals leave or enter the
schematic. They are required. Any unconnected wire without an I/O port will
eventually be flagged as an error when you try to create a netlist or run the
simulator.

I/0 ports are added to schematics using the Edit > Add > 10 Port command
in Schematic Editor.

The 1/O port automatically takes the name of the wire it is attached to. If the
wire is a bus, the port will have the same compound name as the bus.

When a Block symbol and its matching schematic are created, the 1/0O ports
for the signals that enter and leave the schematic must have the same names
as the corresponding pins on the Block symbol. The matching names identify
which signal attaches to which pin.

Attributes Attributes of the schematic specify characteristics of the design
that are interpreted by implementation tools in the design flow. Often
attributes specify directives or preferences for logic synthesis or place and
route in the FPGA design flow. See “Schematic Attributes” on page 270 for
more details.

Each symbol has a number of predefined attributes that describe its
component type and other unchanging characteristics. Other attributes can be
given values after the symbol is placed in the schematic.
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Like symbols and symbol pins, nets (the wiring that connects symbols to each
other and makes external connections) can also have attributes. These
attributes include the net's name, as assigned in the schematic.

Note

Net attributes for a sub-set of syslO Buffer preferences are supported for the FPGA
design flow.

Graphics and Text Graphics are pictures of the symbols. Symbol graphics
have no electrical meaning and show only the position of the component in
the circuit. A symbol’s attributes and pins, not the graphics that represent it,
define the electrical behavior of a symbol. Explanatory or descriptive text
displayed with a symbol is also considered “graphic” information without
electrical meaning.

Although symbols, wires, and 1/O ports are visible, graphical items, they also
have a functional or electrical meaning. In this context, “graphics” refers to the
non-functional graphical parts of the schematic.

For example, you might add graphics showing the expected waveforms at
different points in the circuit. Or, you could draw the company's logo and add it
to each schematic for identification.

The most common use of graphics is to create a title block. The block shows
the name and address of your company, and can include the company logo
and blank spaces for the project name, schematic sheet number, and so on.

Title block symbols are available in the title.lib or lattice.lib libraries. You can
modify the symbols in Symbol Editor and save the file (with the same name)
in the project directory, or you can use Symbol Library Manager to add the
revised symbol to your own custom symbol library file.

Text, like graphics, can provide additional information about the schematic or
its project. Text can be placed anywhere on a schematic, even if it overlaps
symbols or wires.

Text is added to schematics using the Edit > Add > Text command.

Naming Schematic and Symbol Files When you name schematic or
symbol files, observe the following rules:

Observe DOS file naming conventions. The dollar sign ($) cannot be the
first letter of a file name, however.

Do not type a file name extension; Schematic Editor will add it
automatically. If you enter a non-standard extension, Schematic Editor will
replace it with the correct extension (.sch for schematics, .sym for
symbols, and .lib for symbol libraries).

Symbol files must have the same name as the schematic file or HDL
module that the symbol represents. For example, if you create a symbol
for a Verilog module named “foo,” the symbol’s file must be named
“foo.sym.”
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Instances of a symbol in a design cannot use the same name as the
symbol itself.

Symbols

Symbols are graphic representations of components. The term “symbol”
usually refers to an electrical symbol, such as a gate or a sub-circuit. You can
draw graphic-only symbols (such as title blocks) with Symbol Editor, but these
have no electrical meaning.

Wires

Wires electrically connect schematic symbols. The symbol pins are the
connection points for the wires. They can be single-signal (nets) or multiple-
signal (buses).

I/0O Ports

An 1/O port is a special indicator that identifies a net name as a device input,
output, or bidirectional signal. This establishes net polarity (direction of signal
flow) and indicates that the net is externally accessible. An I/O port can either
denote an I/O port of a design if it is in the top level schematic or denote an I/
O marker in a lower level schematic.

Bus Taps

Signals enter or exit a bus at points called bus taps. A bus tap can be added
to any existing bus, net, or wire. If a net or wire is not already a bus, adding
the tap automatically promotes it to a bus.

Selecting the Type of HDL Files Generated for
Schematic

To select the HDL file type generated from your schematic:
1. In the File List view, right-click the Project name and choose Properties.

The Project Properties dialog box opens with the project name is selected
at the top of the left pane.

2. Inthe right pane of the Project Properties dialog box, find Schematic HDL
Type and select its Value cell.

3. Click the Value cell again to reveal a menu. Choose the desired HDL type.
The default is Verilog.

4. Click OK.
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Basic Schematic Editor Operation

Schematic Editor uses an action—object command structure. That is, you
select the action you want to perform (usually from a menu), and then you
select the object you want to act on.

For example, to move a symbol from a schematic, you first select the Move
command from the Edit menu. Then you drag the symbol to move it.

Almost all commands remain in effect until you select a different command.
For example, if the Add Wire command is active, you can continue to draw
wires until you select a different command.

Edit Menu

The Edit menu consists of the following commands:

Table 4: Edit Menu Commands

Command Description Available Shortcuts

Undo Allows you to reverse the edit process. The Undo command Schematic Editor Toolbar: ¥
operates on all commands that change a schematic or symbol Symbol Editor Keyboard:
(such as Cut, Paste, Add, Move, Drag, Attribute Window, Object Ctrl+z '
Properties, and Clear), but it does not reverse those commands
that do not change the drawing.

The Undo command backs up one event each time it is issued. It
can reverse all changes since the file was opened or saved.
Saving a file discards the record of the preceding changes, and
they cannot be undone or redone.

Redo Reverses the effects of the Undo command. The Redo command Schematic Editor Toolbar; &1
can go forward, playing back the undone events until it reaches  Symbol Editor Kevboard:
the end of the Undo log (the point when the first Undo in the Ctr)I/+Y ’
sequence was issued).

The Redo log is discarded whenever the current version of a
symbol or schematic is saved. Once the log is discarded, the
Redo command cannot recover undone commands.

Cut Removes data (nets, graphics, symbols, or text) from the Schematic Editor Toolbar: .;ﬁg.
schematic and places it in the clipboard. The previous contents ~ Symbol Editor .

. ) Keyboard:
of the clipboard are erased. The items can then be pasted from Cirl+X
the clipboard into another schematic.

Copy Copies items from the schematic to the clipboard. The items can Schematic Editor Toolbar: ﬁj
then be pasted in another schematic. Symbol Editor Keyboard:

Ctrl+C

Paste Places the contents of the clipboard into the schematic. When Schematic Editor Toolbar: ij,

you select this command, the pasted contents are attached to the Symbol Editor K .
: . . eyboard:
mouse pointer. Click the mouse pointer to place the contents to Ctrl+V
the right spot.
Find Finds wire and symbol instances on the schematic. Schematic Editor Toolbar: 1:5
Keyboard:
Ctrl+F
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Table 4: Edit Menu Commands (Continued)

Command

Clear

Select All

Add

Move

Drag

Move, Drag

Mirror

Rotate

Highlight

Sheet

Symbol Origin

Expand page

Attribute Window

Symbol Type

Object Properties

Description

Deletes the selected items from the schematic drawing. Deleted
items are not copied to the clipboard and the clipboard's contents

are not affected.

Selects all the items in the schematic.

Opens a menu for adding objects. See “Add Menu” on page 239.

Enables the Move mode. Moves one or more elements (wire or
symbol) to a different location within the schematic. You can
move items in three ways. See “Moving Symbols” on page 269.

Enables the drag mode. Moves portions of objects while the rest
of the object remains in place. The effect is to stretch or
reposition the item, altering its basic shape or direction.

In Symbol Editor, Drag has the same function as Move. After
selecting an item, you can move the cursor to the selected item,
press the right mouse button, and move the item to the desired
place when the cursor becomes a cross.

Works with items already attached to the cursor with the Add >
Symbol command, Edit > Paste, or Edit > Move. The object is
reflected through an imaginary vertical line each time the Mirror
command is selected. The Mirror command can be combined
with the Rotate command to produce eight standard orientations.
See “Transforming Symbols” on page 269.

Works with items already attached to the cursor with the Add >
Symbol command, Edit > Paste, or Edit > Move. The object is
rotated 90° counter-clockwise each time the Rotate command is
selected. The Rotate command can be combined with the Mirror
command to produce eight standard orientations. See
“Transforming Symbols” on page 269.

Selects the whole wire if a segment of the wire has been

selected.

You can control your sheets in this dialog box.

Assigns an origin or changes the current origin. See “Setting the
Symbol Origin” on page 264.

Increases the work area for the symbol. See “Expand Page” on

page 240.

Selects the attribute names for the symbol. See “Adding an
Attribute Window to a Symbol” on page 267.

Selects the symbol type. See “Schematic Symbol Overview” on

page 257.

Assigns attribute values for symbols and wires. See “Assigning
Attribute Values in a Schematic” on page 275.

Available
Schematic Editor
Symbol Editor
Schematic Editor
Symbol Editor

Schematic Editor
Symbol Editor

Schematic Editor

Schematic Editor

Symbol Editor

Schematic Editor

Schematic Editor

Schematic Editor

Schematic Editor

Symbol Editor

Symbol Editor

Symbol Editor

Symbol Editor

Schematic Editor
Symbol Editor

Shortcuts

Keyboard:
Delete
Keyboard:
Ctrl+A

Toolbar: &

Toolbar: Q‘)

Keyboard:
Ctrl+M

Keyboard:
Ctrl+R

Toolbar: ¢

Keyboard:
Ctrl+L

Lattice Diamond 3.6 Help

238



Schematic Design Entry

Add Menu

The Add menu consists of the following commands:

Table 5: Add Menu Commands

Command

Select

Zoom Area

Pan

Wire

Net Name

Bus Tap

Symbol

Instance Name

10 Port

Big Bubble

Bubble

Description

Enables the selection mode, allowing you to select items on the
schematic.

Enables you to zoom in on the schematic by pressing the left
mouse button and drawing a box around the area of interest. See
“Using the Zoom and Pan Tools” on page 438.

Enables you to see another part of the schematic by clicking and
dragging. See “Using the Zoom and Pan Tools” on page 438.

Adds wires between symbol pins. See “Wiring a Schematic” on
page 278.

Gives each net an unique reference name. Net hames can
contain only letters, numbers, apostrophes (single quote), and
underscores. Net nhames are not case-sensitive.

When you save your schematic, Schematic Editor automatically
assigns names to unnamed nets. These names are in the form
N_nn, where nn is an integer. You can override the Editor-
assigned names by assigning your own names.

See “Entering a Net Name” on page 282.

Adds a bus tap to a bus, net, or wire. See “Adding a Bus Tap” on
page 287.

Opens the Add Symbol dialog box, which lets you select a
symbol and place it on a schematic. Symbols come from symbol
libraries or folders. Click on the schematic to place the symbol.
See “Adding Symbols to the Schematic” on page 267.

Names an instance symbol. Opens the Add Instance Name
dialog box where you can enter an instance name. Then click on
the instance symbol to name it.

The instance name cannot be the same as a symbol name in the
Lattice schematic library.

Each symbol that is placed in a schematic is called a symbol
“instance.” Each instance of a symbol must have an unique
reference name. Schematic Editor automatically assigns names
to unnamed symbols each time the schematic is saved. These
names are in the form I_nn, where nn is an integer.

Adds an /O port to a net. Before this operation, the net should
already have a name. After you select an I/O port in the Add 10
Port dialog box, click on the net's name, then the 1/0O port is
placed on the schematic. See “Specifying Signal Direction” on
page 284.

”

Adds a big bubble to the layout. See “Drawing Negation Bubbles
on page 263.

Adds a bubble to the layout. See “Drawing Negation Bubbles” on
page 263.

Available

Schematic Editor

Symbol Editor

Schematic Editor

Symbol Editor

Schematic Editor

Symbol Editor

Schematic Editor

Schematic Editor

Shortcuts

Toolbar: &

Toolbar: €4,

1
Toolbar: )
Toolbar:

Toolbar:

Schematic Editor Toolbar: |

Schematic Editor Toolbar: .5

Schematic Editor Toolbar: **

Schematic Editor Toolbar: ==

Symbol Editor

Symbol Editor

Toolbar: [

Toolbar: [
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Table 5: Add Menu Commands (Continued)

Command

Pin

Arc

Circle

Line

Rectangle

Text

Description

Assigns pins that correspond to I/O markers on the underlying
schematic and connects the device represented by the symbol to
the rest of the circuit. See “Adding Pins to a Symbol” on

page 265.

Adds arcs to the drawing. These arcs are graphics only and have
no electrical meaning in either the schematic or symbol. You can

draw as many arcs as you like until you select another command.

An arc is drawn from a starting to an ending point. These points
can be defined by dragging the mouse from the starting point to
the end point. Then release the button.

You see an arc that starts and ends on the selected points and
passes through the cursor. Move the cursor to change the shape
of the arc. When the arc has the shape you want, click to add the
arc to the drawing. If you decide not to draw the arc, right-click
anywhere in the window to discard the selected points and
restart the command.

If you move the cursor outside of the schematic’s borders, the
arc disappears until you move the cursor inside.

See “Drawing Circles and Arcs” on page 263.

Lets you draw circles, which are graphics and have no electrical
significance. You can draw as many circles as you like until you
select another command. See “Drawing Circles and Arcs” on
page 263.

Lets you add individual line segments to the drawing. These line
segments are graphics and have no electrical meaning in the
schematic or symbol. You can draw as many lines as you like
until you select another command. See “Drawing Lines” on
page 262.

Lets you add rectangles to the drawing. These rectangles are
graphics only and have no electrical meaning in the schematic or
symbol. You can draw as many rectangles as you like until you
select another command. See “Drawing Rectangles” on

page 263.

Adds fixed text to the drawing. Text is used for adding notes, title
blocks, and other information to the symbol or schematic. Text
has no electrical meaning.

The size and justification of the text is set by parameters in the
dialog box.

See “Drawing Text” on page 263.

Expand Page

Available Shortcuts

Symbol Editor ~ Toolbar: ]

Schematic Editor Toolbar:
Symbol Editor

Schematic Editor Toolbar:
Symbol Editor

Schematic Editor Toolbar:
Symbol Editor

Schematic Editor Toolbar:
Symbol Editor

Schematic Editor Toolbar: g
Symbol Editor

The initial work area is 40 x 40 primary grids. After a symbol has been
created, Symbol Editor provides a work area that is approximately twice the

height and width of the symbol.
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When a symbol grows too large to fit, choose this command to enlarge the
work area. Its initial use increases the size to 80 x 80 Primary grids.
Subsequent use adds increments of 20 grids, up to a maximum of 400 x 400
grids.

The extra area is added at the right and bottom of the symbol. If more space
is needed on the left or top, choose the Move command to shift the entire
symbol.

Pay attention that the origin is not part of the symbol. If you move the symbol,
the origin does not move with it. Be sure to reposition the Origin if you move
the symbol.

Hierarchical Design with Schematics
and HDL

A design with more than one level is called hierarchical. A single-level design
is referred to as being flat. Converting a section of circuitry to a block makes a
flat design hierarchical. This is commonly referred to as “hierarchical” design.

The Lattice Diamond software supports full hierarchical design by using
schematics, HDL modules, or a mix of both. Hierarchical structuring permits a
design to be broken into multiple levels, either to clarify its function or to
permit the reuse of functional blocks. For instance, a large, complex design
does not have to be created as a single module. By using a hierarchical
design, each component or piece of a complex design can be created as a
separate module.

A design is hierarchical when it is broken up into functional blocks, or
modules. For example, you could create a top-level schematic describing an
integrated circuit. In the schematic, you could place a Block symbol (a Block
symbol represents a functional block) that provides a specific function of the
chip. You can then elaborate the underlying logic for the Block symbol as a
separate schematic or as a separate HDL module.

The module represented by the Block symbol is said to be at one level below
the schematic in which the symbol appears. Or, the schematic is at one level
above the Block's module. Regardless of how you refer to the levels, any
design with more than one level is called a hierarchical design.

Advantages of Hierarchical Design

The most obvious advantage of hierarchical design is that it encourages
modularity. A careful choice of the circuitry that composes your module will
give you a Block symbol that can be reused.

Another advantage of hierarchical design is the way it lets you organize your
design into useful levels of abstraction and detail. For example, you can begin
a project by drawing a top-level schematic that consists of nothing but Block
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symbols and their interconnections. This schematic shows how the project is
organized but does not display the details of the modules (Block symbols).

You then draw the schematic for each Block symbol. These schematics can
also contain Block symbols for which you have not yet drawn schematics.
This process of decomposition can be repeated as often as required until all
components of the design have been fully described as schematics.

Breaking the schematic into modules adds a level of abstraction that lets you
focus on the functions (and their interaction) rather than on the device that
implements them. At the same time, you are free to view or modify an
individual module.

Although there are many ways of “breaking apart” a complex design, some
may be better than others. In general:

Each module should have a clearly defined purpose or function and a
well-defined interface.

Look for functions or component groupings that can be reused in other
projects.

The way in which a design is divided into modules should clarify the
structure of the project, not obscure it.

Hierarchy vs. Sheets

Creating a hierarchical design is not the same as creating a schematic with
multiple sheets. In a schematic, you can add as many sheets as desired to
extend beyond the original sheet. However, regardless of how many sheets
you add, all the components of the design are still at a single level; all sheets
are still contained in the same module.

Approaches to Hierarchical Design

Hierarchical designs consist of one top-level module. This module can be of
any format, such as VHDL, Verilog HDL, or schematic. Lower-level modules
can be of any supported sources and are represented in the top-level module
by functional blocks or other “place-holders.”

Following are some rules you need to follow when creating a hierarchical
design in Diamond for a FPGA design.

The top-level source can be of any format, such as VHDL, Verilog HDL,
schematic, or EDIF netlist.

For hierarchical Schematic/VHDL or Schematic/Verilog HDL designs:

If the upper-level source is a schematic file, the lower-level source can
be either a HDL file or a schematic file.

If the upper-level source is a HDL file, the lower-level source can only
be a HDL file.

For EDIF designs:

Lattice Diamond 3.6 Help

242



Schematic Design Entry

Hierarchical EDIF design is not allowed.

You can create the top-level module first, or create it after creating the lower-
level modules. For example, in Schematic Editor you can create schematic
project components in any order and then combine them into a complete
design. You can draw a schematic first and create a Block symbol for it
afterwards; or you can specify the Block first and create the schematic for it
later.

Hierarchical Design Structure Considerations

Apply the following considerations when using hierarchical design techniques.
We take a hierarchical schematic design as an example (shown below). The
rules implied in the example are also applicable to other types of hierarchical
designs.

Hierarchical Design Structure The example below shows a 8-bit decoder
circuit (DEC8E) constructed from two DEC4E symbols. The right side of the
figure shows the underlying components. The two decoder symbols represent
a total of eight AND gates and four inverters.

This hierarchical building process could be repeated by using Schematic
Editor's Design > Generate Symbol command to create a symbol for
schematic DECS8E, and then placing the DEC8E symbol in a higher-level
schematic. If you created a schematic for a 16-bit decoder, DEC16E, by
placing two copies of symbol DEC8E, you would be defining a circuit with a
total of 24 gates. But instead of having to view 24 gates on a single level, you
can work with symbols that represent gates, at the appropriate level of detail.

Hierarchical Naming In the DEC4E schematic example below, an AND3
gate has the instance name I1. In schematic DEC8E, two copies of the
symbol DECAE are placed and assigned instance names |1 and 12.
Schematic DEC8E, therefore, contains two copies of AND3 gate I1.

L]

) Mo
: |~
NV | “
17 .
DECAE —Zro> . 5"
S[0] Z0 Z[0 = N A 20
O oq 3| — L AND3
51 72 Z2] IV
—EN 55 73] ) | 13
12 z1
T AND3
SE=TE
- Pz 2
o[ S0 74 Z[5 ' 2>
P 1) I =t - 78]
EN——EN 73 Z[7] AND3
L =
T AND3
[Er
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Automatic Aliasing of Nets When a design is loaded, nets take the name
of the highest (top-level) net in the design. That is, the name of top-level net
propagates downward through the hierarchy to override the local name. By
forcing all nets to the same name, this aliasing feature greatly speeds signal
tracing in a multi-level design.

In the preceding example, the net name S[0] and S[1] of I1(DECA4E) is
overridden by the higher-level external reference to become S[2] and S[3].
This override becomes the reference at all levels of the hierarchy.

Note

The hierarchical HDL output produced by the schematic system will retain the local
names as defined by the schematic.

Creating a Hierarchical Schematic Design

You can generate a hierarchical design in the following way:

1. Create a schematic or HDL design for a lower level module.

2. Generate a schematic symbol for the lower level module. See:
“Creating a Block Symbol from a Schematic” on page 263
“Creating a Symbol from an HDL Module” on page 264

3. Store the new symbol in one of three ways:

Move the symbol to the same folder as the project file or the upper
level schematic file.

Add the symbol to a library (see “Using Lattice Symbol Library” on
page 247). Make sure the library is specified the User Defined Symbol
Libraries strategy option. Choose Tools > Options to check. See
“Adding Symbol Libraries to Schematic Editor” on page 256.

Add the folder of the symbol into the User Defined Symbol Libraries
strategy option. Choose Tools > Options to check. See “Adding
Symbol Libraries to Schematic Editor” on page 256.

4. Choose Edit > Add > Symbol to add the symbol to an upper level
schematic. See “Adding Symbols to the Schematic” on page 267.

Schematic Hierarchy Example

The figure below shows an example of how a symbol corresponds to an
underlying schematic. In this figure, pin A on the Block symbol corresponds to
the net in the schematic, which is also named A. The other pins, B, CI (Carry
In), CO (Carry Out) and SUM, also correspond to hamed nets in the
schematic.

A Block Symbol and its Underlying Schematic

This following figure shows one top-level schematic with module I/Os and net
attributes to specify syslO Buffer preferences.
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Beginning a New Schematic Design

To begin a new schematic design:
1. In the Diamond window, choose File > New > File.
The New File dialog box opens.

2. Inthe New File dialog box, do the following:
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a. Under Categories, select Source Files.

b. Under Source Files, select Schematic Files.

c. Specify Name and Location for the new schematic file.
d. Click New.

Schematic Editor opens with a new, untitled sheet.

Converting a Schematic Design to Another Device

You can first target this design to the new device. As some symbols are only
valid for some specific devices, you may find that some symbols cannot be
used for the new device. Replace these symbols with new symbols that
support the new device, according to the list of Schematic Symbols. See “List
of Schematic Symbols” on page 248.

Opening Schematic Editor

To open Schematic Editor, you can either open an existing Schematic Design
(see “Opening an Existing Schematic Design” on page 246) or create a new
schematic file (see “Creating a New Source File” on page 35).

Opening an Existing Schematic Design

You can open schematic design files through the File List view of a design
project or directly, outside of any design project.

To open a schematic design from within a design project:

1. Inthe File List view, find the schematic file under the Input Files folder.
The entry looks like this:

B <path>/<filename>.sch
2. Double-click the schematic file.

Schematic Editor opens with the selected file.

To open a schematic design outside of any design project:
1. Choose File > Open > # File.

2. Inthe Open File dialog box, in the file type menu at bottom-right, choose
Schematic Files (*.sch).

Browse to the desired schematic file.
4. Click Open.

Schematic Editor opens with the selected file.
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Network Operation

When schematics, symbol files, and other project components are shared on
a network, some form of overwrite protection is required. The system does not
allow two people to work on the same file at the same time.

Schematic Editor uses the crash-recovery log file (described in the preceding
section) to ensure single-user access. If you try to open a file and Schematic
Editor finds a log file for it, you are asked if someone else is using the file. If
you answer Yes, you cannot access the file.

If you answer No, you will be allowed to open the file, even if someone else is
editing it. Check with anyone who might be using the file before answering
No.

Using Lattice Symbol Library

The Lattice FPGA Symbol Library provides Boolean logic gates and
synchronous elements for gate-level design. For macro-sized elements like
architectural blocks, arithmetic, or memories it is recommended that you use
the IPexpress interface to configure and generate schematic symbols and
files for implementation. The Lattice schematic library provides dozens of
library elements for gate-level schematic design.

The library file, lattice.lib, is composed of library elements compatible with
most Lattice FPGA device families.

Symbol Library Manager allows you to manage libraries of symbols (.sym
files) used in your designs. With Symbol Library Manager, you can view two
types of symbol libraries: folder and binary. Folder libraries are simply
directories that contain symbols. Binary libraries are .lib files that contain
many symbols. You can clean up your folder structure and save disk space by
organizing your symbols into binary libraries. Symbol Library Manager allows
you to create your own binary libraries and maintain them by adding,
extracting, deleting, copying, and renaming the symbols in the libraries.

Symbol Categories The Lattice FPGA Symbol Library for schematic design
is based on a sub-set of the library elements documented in the “FPGA
Libraries Reference Guide” on page 1571. The Libraries Guide is organized
into functional categories by device family and provides details on function, I/
O, and device compatibility.

For a complete list of all the symbols provided in the Lattice FPGA Symbol
Library, see “List of Schematic Symbols” on page 248.

Attributes Schematic Editor for FPGA and MachXO Crossover
Programmable devices supports the ability to specify HDL Attributes as
schematic symbol attributes or net attributes. For more information, see “List
of Schematic Attributes” on page 271.

Logic Constants Logic constants are a common construct in digital design
to represent a static value.
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Schematic Editor provides two special nets named VCC or GND that produce
logic constants in the HDL output. To create a VCC or GND net, use the Edit >
Add > Net Name feature to name a wire stub. Specify VCC or GND.
Depending on the orientation of the wire, a special symbol for the net will
appear as shown in the first sample circuit below.

The FPGA Symbol Library provides two symbols: VHI and VLO to represent
bit value 1 or O respectively. To create a multi-bit value constant, use a
combination of buses and symbols as shown in the second sample circuit
below.

Figure 45:
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Bus Declarations Schematic Editor allows you to create discontinuous bus
ranges, for example MyBus [15:12] and MyBus [3:0], in separate regions of
the schematic design. To avoid semantic problems in the resulting Verilog
HDL or VHDL model of the translation process, the HDL model writer will
create one bus declaration to cover the range: MyBus [15:0].

I/0O Cell Usage The Lattice FPGA Symbol Library contains several 1/O cell
library elements (such as IB, OB, and BB) to help define the syslO Buffer
interface to the design. However, in general, it is not necessary to add these
library elements to your schematic design. The logic synthesis process
(Precision RTL or Synplify Pro) will automatically add them.

I/0 Buffer Usage The Lattice FPGA Symbol Library for schematic design is
based on a sub-set of the “FPGA Libraries Reference Guide” on page 1571.

List of Schematic Symbols

The Lattice schematic library, lattice.lib, is composed of library elements
compatible with most Lattice FPGA device families. The following table lists
all the schematic symbols included in the library file. Click the symbol name to
learn its functionality and device compatibility.

Lattice Diamond 3.6 Help

248



Schematic Design Entry

Table 6:
Category

Logic Gates

Miscellaneous

Comparators

Adders/Subtractors

Multipliers

Counters

In addition there are four more title blocks available in title.lib: FPTITLE,
REV_BLK, SPTITLE, STITLE.

Library Element GSR Effect

AND: AND2, AND3, AND4, ANDS

NAND: ND2, ND3, ND4, ND5

OR: OR2, OR3, OR4, OR5

NOR: NR2, NR3, NR4, NR5

XOR: XOR2, XOR3, XOR4, XOR5, XOR11, XOR21
XNOR: XNOR2, XNOR3, XNOR4, XNOR5

Carry-Chain: CCU2B

Delay: DELAY

Inverter: INV

Logic High: VHI

Logic Low: VLO

Readback controller: RDBK

Synchronous Release Global Set/Reset Interface: SGSR

A >=B: AGEB2
A <=B: ALEB2
A /=B: ANEB2

Adder: FADD2, FADD2B
Subtractor: FSUB2, FSUB2B
Adder/Subtractor;: FADSU?2

Multiplier: MULT2

Up Counter: CU2
Bidirectional Counter: CB2
Down Counter: CD2
CD4P3BX

CD4P3DX

CD4P3IX

CD4P3JX
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Table 6:

Category Library Element

GSR Effect

Loadable Counters Loadable Bidirectional Counters:
LB2P3AX
LB2P3AY
LB2P3BX
LB2P3DX
LB2P3IX
LB2P3JX

Loadable Down Counters:
LD2P3AX

LD2P3AY

LD2P3BX

LD2P3DX

LD2P3IX

LD2P3JX

Loadable Up Counters:
LU2P3AX

LU2P3AY

LU2P3BX

LU2P3DX

LU2P3IX

LU2P3JX

Clear
Preset

Clear
Preset

Clear
Preset

Flip-Flops D-Type Flip-Flops (Positive-level enable):
FD1P3AX
FD1P3AY
FD1P3BX
FD1P3DX
FD1P3IX
FD1P3JX

D-Type Flip-Flops (No enable input):
FD1S3AX

FD1S3AY

FD1S3BX

FD1S3DX

FD1S3IX

FD1S3JX

Loadable D-Type Flip-Flops:
FL1P3AY

FL1P3AZ

FL1P3BX

FL1P3DX

FL1P3IY

FL1P3JY

FL1S3AX

FL1S3AY

Clear
Preset

Clear
Preset

Preset
Clear

Clear
Preset
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Table 6:

Category

Library Element GSR Effect

Latches

Data Latches:

FD1S1A Clear
FD1S1AY Preset
FD1S1B

FD1S1D

FD1S1lI

FD1S1J

Loadable Data Latches:

FL1S1A

FL1S1AY Clear
FL1S1B Preset
FL1S1D

FL1S1I

FL1S1J

Multiplexers

2:1 Mux: MUX21
4:1 Mux: MUX41
8:1 Mux: MUX81
16:1 Mux: MUX161
32:1 Mux: MUX321

PFU Mux: PFUMX
LUT6 Mux: L6MUX21

1/0 Cells

Input Buffers: IB, IBPD, IBPU
Output Buffers: OB, OBCO, OBZ, OBZPD, OBZPU, OBW
Bidirectional Buffers: BB, BBPD, BBPU, BBW

LVDS Input Buffer: ILVDS
LVDS Output Buffer: OLVDS

PIC Flip-Flops

Input PIC Flip-Flops:
IFS1P3BX
IFS1P3DX
IFS1P3IX

IFS1P3JX
ILF2P3BX
ILF2P3DX

ILF2P3IX

ILF2P3JX

Output PIC Flip-Flops (System Clock):
OFS1P3BX

OFS1P3DX

OFS1P3IX

OFS1P3JX

PIC Latches

Input PIC Latches (System Clock):
IFS1S1B

IFS1S1D

IFS1S1I

IFS1S1J
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Table 6:
Category Library Element GSR Effect
Special Cells Combinatorial Elements: ORCALUT4, ORCALUTS5,
ORCALUT6, ORCALUT7, ORCALUTS8
Dynamic Clock Selection: DCS
Internal Oscillators: OSCA, OSCC, OSCD, OSCE, OSCH
Startup: STRTUP
Tri-State All: TSALL
Global Set/Reset: GSR
Power Up Set/Reset: PUR
Title Blocks title_a, title_b, title_c, title_d, title_e

Creating a New Symbol Library

One of the first things you will probably want to do with Symbol Library
Manager is to create a binary library for storing your own symbols or for
storing symbols specific to a design.

To create a new symbol library:

1. In the Diamond window, choose File > New > & File.
The New File dialog box opens.

2. Under Categories, select Other Files.

3. Under Source Files, select [&1 Symbol Library Files.

E

Specify the file name without any extension. The .lib extension is added
automatically.

Click Browse.
In the Location dialog box, browse to where you want to put the file.
Click Select Folder.

© N o U

In the New File dialog box, click New.

Symbol Library Manager opens, allowing you to create a symbol library.
Now you can open other libraries and add symbols to your new library.
See Also »“Adding Symbols to a Library” on page 253

“Copying Symbols to a Library” on page 254

Opening an Existing Symbol Library

You can open an existing symbol library file from the Diamond main window.
There are additional methods for symbol library files and folders from the
Symbol Library Manager window.
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To open a symbol library file:

This method is only for symbol library (.lib) files, not library folders. This
method can be used from the Diamond main window or from a detached
Symbol Library Manager window.

1.

Choose File > Open > & File. (File > & Open File if in a detached
Symbol Library Manager window.)

In the Open File dialog box, in the file type menu at bottom-right, choose
Symbol Library Files (*.lib)

Browse to the desired symbol library file.
Click Open.

Symbol Library Manager opens with the selected symbol library.

To open a symbol library (file or folder) that is in your search path:

1.

Select an open Symbol Library Manager view and choose File > Open
From Search Paths.

The Open Library From Search Paths dialog box opens.
In the dialog box, select the library you want to open.

Selecting a folder that contains more than one .sym file allows you to
access all of those .sym files. However, selecting a folder that contains a
lib file will not let you edit that .lib file unless the file name is specified in
the search paths.

Click OK.

The selected symbol library opens and the first symbol in the list is
selected.

To open a folder library that is not in your search path:

1.

Select an open Symbol Library Manager view and choose File > Open
Folder.

In the dialog box, browse to the desired folder.
Click Select Folder.

The selected symbol library opens and the first symbol in the list is
selected.

Adding Symbols to a Library

To add symbols to alibrary in Symbol Library Manager:

1.
2.

Open the library to which you want to add a symbol.

Choose Edit > Add Symbol(s) or right-click any symbol in the library and
choose Add Symbol(s) from the pop-up menu.

The Add Symbols to Library dialog box opens.
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3.

Go to the location of the folder that has the symbol you want to add, and
then select the symbol. You can select more than one symbol at a time by
using the Shift and Ctrl keys on your keyboard.

Click Open.

Symbol Library Manager copies the symbol into the current library. The
original symbols still exist and may be deleted if so desired.

Extracting Symbols from a Library

You can copy a symbol from a binary library to a folder library with the Extract
Symbol(s) command.

To extract symbols from a library:

1.

Open the binary library (.lib) from which you want to extract a symbol and
select the symbol. You can select more than one symbol at a time by
using Shift and Ctrl keys on your keyboard.

Choose Edit > Extract Symbol(s) or right-click the symbol and choose
Extract Symbol(s) from the pop-up menu to open the dialog box.

Type the path where you want to extract the file, or click Folders to
browse for the path.

Click OK.

Symbol Library Manager copies the selected symbol from the binary
library to the folder library. You can use the File > Open Folder command
to verify that the symbol was, in fact, copied.

Copying Symbols to a Library

You can copy a symbol to either a binary library or a folder library with the
Copy Symbol(s) command.

To copy symbols to a library:

1.

Open the library from which you want to copy a symbol and select the
symbol. You can select more than one symbol at a time by using Shift and
Ctrl keys on your keyboard.

Choose Edit > Copy Symbol(s) or right-click the symbol(s) and choose
Copy Symbol(s) from the pop-up menu.

The Copy Symbols dialog box opens.

Type the path to the folder library or binary library, or click Folders or
Libraries to browse for the path.

Click OK.

Symbol Library Manager copies the selected symbol from the current
library to the new library.
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Deleting Symbols from a Library
You can delete a symbol from a binary or folder library.

To delete a symbol from a library:

1. Open the library from which you want to delete a symbol and select the
symbol. You can select more than one symbol at a time by using Shift and
Ctrl keys on your keyboard.

2. Choose Edit > Delete Symbol(s), press the Delete key on your keyboard,
or right-click the symbol(s) and choose Delete Symbol(s) from the pop-
up menu.

Symbol Library Manager deletes the selected symbol from the current
library.

Renaming Symbols in a Library
There are times when you want to change the name of a symbol.

To rename a symbol:

1. Open the library that contains the symbol you want to rename and select
the symbol.

2. Choose Edit > Rename Symbol(s) or right-click the symbol and choose
Rename Symbol(s) from the pop-up menu.

The Rename Symbol dialog box opens.
Type the new name for the selected symbol.
4. Click OK.

The selected symbol will now appear with the new name.

Note

Symbol nhames will be converted to module names in HDL. It is recommended that you
follow the module name rules in HDL when naming symbols.

Saving a Symbol Library

The Save File command in Symbol Library Manager saves the changes to the
existing library file. You can use the Save File As command to save the library
with another file name.

Symbol library files have the extension .lib. Below shows the steps of saving a
symbol library with the Save File As command.

To save a symbol library with the Save File As command:
1. In Symbol Library Manager, choose File > Save <filename> As.

The Save As dialog box opens.
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2. Go to the folder in which you want to save the library.
3. Type in a base name for the library.

Symbol Library Manager adds the .lib extension automatically when you
specify the base name.

4. Click Save.

Viewing Symbol Properties from Symbol Library

Manager

You can view properties associated with any symbol in a library with the
Symbol Properties dialog box. However, you cannot edit symbol properties in
this dialog box.

To view symbol properties from Symbol Library Manager:
1. Open a library and select the symbol whose properties you want to view.

2. Choose Edit > Properties or right-click the symbol and choose
Properties from the pop-up menu to open the Symbol Properties dialog
box.

The dialog box has three tabs: General, Pins, and Attributes. The General tab
has information on the name of the symbol and the location of the library it is
in. The Attributes tab displays various attributes of the symbol. The Pins tab
displays pin attributes. A pin's attributes may be viewed by selecting the pin
whose attributes you wish to view.

Adding Symbol Libraries to Schematic Editor

After creating a symbol library, you need to tell Schematic Editor about it.
Then the library and its collection of symbols will appear in Schematic Editor’s
Add Symbol dialog box.

To add a symbol library to Schematic Editor:
1. In the Diamond window, choose Tools > Options.

2. Inthe left-hand pane of the Options dialog box, look under Schematic
Editor and select User Defined Symbol Libraries.

The right-hand pane shows a list of user-defined symbol libraries. The
libraries that come with Diamond are not shown.

3. Click Add Library (for a .lib file) or Add Folder.
The Add Symbol Library dialog box opens.

4. Browse to the library file (.lib) or folder that you want to add.
Click Open.
The selected library is added to the list.
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6. To change the order of the libraries in the Add Symbol dialog box, select a
library and click Up or Down.

7. When you finish, click Apply or OK.

Creating Schematic Symbols

You can use Symbol Editor to construct schematic symbols. Besides the
various lines, arcs, and boxes needed to create a symbol. You can add text to
give information about the symbol and its relationship with the rest of the
circuit.

You can also use Schematic Editor to create a block symbol from a
schematic.

Schematic Symbol Overview

Symbol Types Four types of symbols can be created in Symbol Editor. Use
the Symbol Type command on the Edit menu to select symbol types.

Cell Symbol

Cell symbols represent the primitive cells (transistors, resistors, diodes,
and so on) used to design integrated circuits. The pins on cell symbols are
named for identification in netlists.

Block Symbol

Block symbols are used to build a hierarchical design. Each block symbol
represents a schematic or HDL module at the next-lower level of the
hierarchy. Bus pins are permitted on block symbols.

Graphic Symbol

Graphic symbols add information that is not part of the circuitry. Graphic
symbols are typically used for tables and notes. No pins are associated
with graphic symbols, and they are never included in the hierarchy or
netlists.

Master Symbol

Master symbols are used for title blocks, logos, revision blocks, and other
standardized graphic symbols. You can add text to a master symbol to
display the company name, address, project description, date, and so on.

Symbol Elements Schematics are constructed from symbols. A symbol
can represent any logic component. Symbols are connected with wires (in
Schematic Editor) to create a complete schematic whose behavior can be
verified and simulated.

A symbol is a picture; it has no inherent electrical meaning. Its electrical
characteristics are supplied by attributes that describe the symbol's behavior.
(The behavior of a Block symbol is described by the schematic file associated
with that Block symbol.).
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The Lattice Diamond software supplies you with an extensive set of symbols.
You can also use Symbol Editor to create Block symbols that represent a
complete schematic, or part of one.

Symbols are composed of graphic, pin, and attribute elements.

Graphic elements are the picture of the symbol. They have no electrical
meaning; they show only the location of the component in the schematic.

Pin elements on a symbol are points where a wire can be attached. The
pins and wires are connected between symbols to circuit elements.

Buses cannot be connected to pins unless the pin is a bus pin. Only
ordered buses can be connected to bus pins.

Attribute elements are properties of a symbol, pin, or net. Attributes can
describe how the Fitter will optimize the symbol, or where it is placed in
the device.

Pins Symbol pins are connection points for wires. Pins on Gate,
Component, and Cell symbols represent the connection points on the device
(pins or pads). Pins on a Block symbol represent connections from one level
of the hierarchy to the level below. Because Graphic and Master symbols do
not represent electrical components, you cannot attach pins to them.

Pins are the only symbol elements restricted to locations on the Primary grid,
since wires must begin and end on Primary grid points.

Bus Pins A bus pin is used to connect a bus to a symbol. Naturally, a bus
pin must have as many nets or signals as the bus that connects to the pin.

One way to create a bus pin is to give a pin a name of the form:
bus_name[index1-index2]

Where bus_name is the name of an internal bus, and index1 and index2
specify the range of signals you want to connect. For example, if you need to
connect nine signals, index1 could be 5 and index2 could be 13.

Alternatively, a bus pin can be defined by giving it a compound name—a list of
bus names separated with commas (,):

namel, clk, mux[0-3], toggle

Bus pins are allowed only on Block, Cell, and Component symbols. When a
bus pin is created on a Component symbol, the numbers of the physical pins
must be specified in the symbol definition.

These pin numbers are a list of pins assigned to the pin attributes BusPin_A
through BusPin_H. When assigning bus pins, the normal PinNumber pin
attribute must not have an assigned value.

The pin list can be divided sequentially among the eight attributes. Each
individual attribute can hold about 200 characters. The list is delimited with
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commas or spaces, and can specify sequences of pins in parentheses () or
square brackets [ ]. Examples are

BusPin A = 1, 3, 5, (7:10)

7 pins: 1, 3, 5, 7, 8, 9, 10
BusPin B = Al B[2:4] C1

5 pins: Al, B2, B3, B4, Cl

Attributes A symbol and each of its pins can have attributes. An attribute
has a name and a value.

Symbol Attributes

Symbol Attributes are characteristics or properties associated with a
symbol. Examples of symbol attributes are PartNum, InstName, Width,
and Type.

You can edit symbol attributes in the Object Properties Setting dialog box.
Pin Attributes

Pin Attributes are characteristics or properties associated with a pin.
PinName, Polarity, and PinNumber are examples of Pin Attributes.

More on Pin Attributes Pin attributes generally have no meaning except as
literal text. It is only when other programs read this text that it acquires any
other meaning. There are a few exceptions:

The Pin Name on Block symbols must match the name of the net
connected to this pin on the underlying schematic in the hierarchy. The
Pin Name can represent a single signal, or it can be a compound name
representing a bus. All signals represented by a pin must exist on the
underlying schematic.

The Use or Polarity attribute has a default value of Input. You need to
assign a value only if the Use or Polarity is other than Input. The other
legal values are Output and Bidir (bidirectional).

The values for Load and Drive attributes must be integers and use
consistent units. Input pins use the attributes LoadLow and LoadHigh.
Output pins use the attributes DriveLow and DriveHigh, while bidirectional
pins use both the Drive and Load attributes.

For gate symbols, pin numbers should be added in Symbol Editor as a list
of pin numbers. For component symbols, a single pin number should be
specified.

Opening Symbol Editor

To open Symbol Editor, you can either open an existing symbol (see “Opening
an Existing Symbol” on page 260) or create a new symbol file (see “Creating
a New Symbol File” on page 260).
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Opening Symbol Library

To open a symbol library, you can either open an existing library (see
“Opening an Existing Symbol Library” on page 252) or create a new library file
(see “Creating a New Symbol Library” on page 252).

Opening an Existing Symbol

You can open an existing symbol file from Diamond’s main window.

To open an existing symbol file:
1. Inthe Diamond window, choose File > Open > [ File.

2. Inthe Open File dialog box, in the file type menu at bottom-right, choose
Symbol Files (*.sym)

3. Browse to the desired symbol file.
4. Click Open.

Symbol Editor opens with the selected symbol.

Creating a New Symbol File

You can open Symbol Editor to create a new symbol.

To create a new symbol:

1. Inthe Diamond window, choose File > New > 3 File.
The New File dialog box opens.

2. Under Categories, select Other Files.

Under Source Files, select & Symbol Files.

»

Specify the file name without any extension. The .sym extension is added
automatically.

Click Browse.
In the Location dialog box, browse to where you want to put the file.
Click Select Folder.

© N o U

In the New File dialog box, click New.

Symbol Editor opens allowing you to create the symbol.

See Also »“Creating a Block Symbol from a Schematic” on page 263

“Creating a Symbol from an HDL Module” on page 264

Saving a Symbol

You can store a symbol in a library for use in many designs, or keep it in the
design directory for use in a specific design.
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The Save File command in Symbol Editor saves the changes to the existing
symbol file. You can use the Save File As command to save the symbol with
another file name, which is useful when you're designing several similar
symbols. Save the original, modify it, then save the new version with a new
name.

Symbol files have the extension .sym. Below shows the steps of saving a
symbol with the Save File As command.

To save a symbol with the Save File As command:

1. In Symbol Editor, choose File > Save <filename> As.
The Save as Symbol File dialog box opens.

2. Go to the folder in which you want to save the symbol.

3. Type in a base name for the symbol.

Symbol Editor adds the .sym extension automatically when you specify
the base name.

4. Click Save.

Printing a Symbol

You can print a symbol using the Print command.

To print a symbol:
1. In Symbol Editor, choose File > Print.
The Print dialog box opens.

2. Select the print options that you want and click OK.

Checking a Symbol for Errors

You can check symbols for errors at any time. Symbol Editor writes an error
report to a file and opens it after the check is run. Clicking an error in the list
highlights the error in the drawing.

The following types of errors are detected and reported:

Block symbols should have a schematic with the same name in the
current directory.

Symbols of type other than Block are usually primitives and should not
have a schematic of the same name in the current directory.

Each pin should have a PinName in a Block or Cell, and a PinNumber in a
Gate or Component.

Pins in Component and Pin symbols can only have one PinNumber.

Pins in the same group of a Gate must all have the same Polarity, Load
and Drive.
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Pins on Block symbols should not have Load or Drive specifications.

Pins on non-Block symbols should have Load or Drive specified. Input
pins should specify Load but not Drive. Output pins should specify Drive,
unless the pin is tristate. In that case, Load should also be specified,
representing the load in the High-Z state. Bidirectional pins should specify
both Load and Drive.

To check a symbol for errors:

1. In Symbol Editor, choose Designh > Drc Check.
Symbol Editor opens an error report.

2. Select an error from the list.

The system displays the corresponding location of the error with a cross
mark over it.

Drawing Operations

This section describes the operations that are generally applicable to drawing
the graphic for a symbol.

Setting the Line Weight Graphic objects can be drawn in two line weights:
normal and wide.

Normal lines (default) are the same width as the wires in a schematic. You
might use this weight for drawing all elements.

Wide lines are twice the width of Normal lines, the same weight as schematic
buses. For example, you might use this weight to illustrate a bus pin
connection.

To set the line weight:
1. In the Diamond window, choose Tools > Options.
The Options dialog box opens.
2. Inthe dialog box, click Graphic Options under Symbol Editor.
3. To draw wide lines, select Use Wide Line.

All elements you enter are drawn as wide lines until you change this
setting. Changing the line width does not alter the width of elements
already drawn. It only affects the elements drawn after the change.

4. Click Apply or OK.

Drawing Lines When clicking to place the end points, lines are constrained
to three principal directions: vertical, horizontal, and 45°. When you drag the
line, the line can be at any angle as long as the end points fall on the grid
being used. To show or hide the grid, choose Tools > Options in the
Diamond window. Then select Show Grid in Symbol Editor Graphic Options.
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Use the Add Line command to draw a line or an outline. When you draw a
line, the line can be at any angle.

Drawing Rectangles Many symbols are based on a rectangular body. For
non-rectangular symbols such as inverters or multiplexers, use the Line
command to draw the outline.

Drawing Circles and Arcs You can place full circles with the Add Circle
command and create portions of circles with the Add Arc command. Arcs are
useful for the curved sections of NAND and NOR gates.

Drawing Negation Bubbles Negation bubbles are graphical and have no
electrical significance. (Adding a negation bubble to a symbol does not
change its logic. You must modify the symbol's attributes or the underlying
schematic file.) You can add small or large bubbles:

Click on the Drawing Toolbar to draw a bubble one-half the Primary
grid unit in diameter

Click  onthe Drawing Toolbar to draw a bubble one Primary grid unit
in diameter

With either command, a bubble is attached to the cursor. Click the desired
position in the schematic to place a bubble.

Drawing Text Text can be added anywhere in the drawing window. Typical
uses of text include:

Notes about the symbol
Title blocks
Cross references

Fixed text (as opposed to text appearing in attribute windows) can be drawn in
up to eight sizes. (In the Windows version of the Diamond software, eight
sizes are available. In the Linux version, three sizes are available.) Text can
be left justified, right justified, or centered. Use the Add Text command to
specify font size and text content and justification in the Add Text dialog box.

Creating a Block Symbol from a Schematic

Block symbols are used to build a hierarchical design. Each block symbol
represents a schematic or HDL module at the next-lower level of the
hierarchy. You can create a block symbol from the currently loaded schematic
in Schematic Editor or for an HDL module selected in the Hierarchy view (see
“Creating a Symbol from an HDL Module” on page 264).

To create a block symbol from the currently loaded schematic:
1. Open the schematic design in Schematic Editor.

2. Choose Design > Generate Symbol.
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A generic block symbol is created at:
<install dir>/tmp/<schematic name>.sym.

3. Use Symbol Editor to customize the new block symbol.

See Also “Adding Symbols to the Schematic” on page 267

Creating a Symbol from an HDL Module

The Lattice FPGA Symbol Library provides dozens of pre-defined symbols for
gate-level schematic design. You can also create customer symbols (*.sym)
from an existing Verilog or VHDL module. These symbols can later be added
to your schematic design source.

Once a symbol is created, you can modify it in Symbol Editor.

To create a schematic symbol from an existing HDL module:

In the Hierarchy view, right-click the module that you want to create a
symbol for, and choose Generate Schematic Symbol.

The Diamond software writes a new schematic symbol file (*.sym) into the
project directory using the interface ports defined by your HDL module.

See Also »“Adding Symbols to the Schematic” on page 267

Preparing Symbols for Schematics

A symbol needs special links so that it can be recognized and placed in a
schematic. These links consist of pins, attributes, attribute windows, and the
symbol origin. You can define these links before adding symbols to
schematics.

Setting the Symbol Origin

When a symbol is placed in Schematic Editor, the symbol is attached to the
cursor. The point on the symbol attached to the cursor is called the origin of
the symbol.

A newly created symbol has no origin. When the symbol is saved, the origin
defaults to the upper-left corner of the symbol. You can assign an origin or
change the current origin with the Symbol Origin command in Symbol Editor.

To set the symbol origin:

Choose Edit > Symbol Origin and click the desired location. (The origin
does not have to be on or within the symbol; it can be outside.)

After you assign a new origin, the symbol coordinate tick marks relocate.

The Origin is not part of the symbol. If you move the symbol, the Origin does
not move with it. Be sure to reposition the origin if you move the symbol.
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Positioning Master Symbols

Master symbols cannot be freely placed on a schematic sheet. Instead, they
are automatically positioned at one of the corners. This permits resizing the
sheet without having to move the title block or other annotations.

The sheet corner is determined by the location of the symbol's origin. If the
origin is placed at the upper-right corner of the Master symbol, for example,
the symbol will be positioned at the upper-right corner of the sheet.

Master symbols do not have pins.

Adding Pins to a Symbol

Symbol pins correspond to I1/0 markers on the underlying schematic and
connect the device represented by the symbol to the rest of the circuit.

Pins are usually attached to the symbol on short lines extending outward from
the symbol's body. However, pins can be attached anywhere inside or outside
the symbol, with or without connecting lines.

Pins are electrical elements and are therefore restricted to locations on major
grid intersections. There can be only one pin at any location.

To add a pin to a symbol:

1. In Symbol Editor, choose Edit > Add > Pin, or click on the Drawing
Toolbar.

2. Click where you want to place a pin.

If that point already has a pin, the system displays an error message. Pins
appear in Symbol Editor as small squares.

Adding a Pin Name

You can use the Object Properties command to add pin names.

To add pin names:

1. In Symbol Editor, select the pin for which you want to add a name.
The pin appears highlighted in red.

2. Choose Edit > Object Properties.
The Object Properties Setting dialog box opens.

3. Inthe left-hand list, select the pin from the Pins list.

The corresponding pin attributes are displayed in the right-hand table in
alphabetical order.

4. Double-click the Value cell for the PinName attribute, and type in the
name you want.
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5. Click Apply.

Note

If you want the pin names to be displayed, use the Name Location field in the Object
Properties Setting dialog box to set the display position of pin names. See “Setting the
Display Position of Pin Names” on page 266 for details.

See Also »"“Adding Pins to a Symbol” on page 265

Setting the Display Position of Pin Names

You can use the Object Properties Setting dialog box to control the pin name
position relative to the pin.

To set the display position of pin names:
1. In Schematic Editor, select the pin you want to work with.
2. Choose Edit > Object Properties.

The Object Properties Setting dialog box opens.

In the left-hand list, select the pin from the Pins list.

4. Under Name Location, select an option among the available choices:
showing the pin name on the left, top, right, or bottom of the pin; or
showing the pin name vertically. Also, you can set the offset value, the
distance of the pin name from the pin.

5. Click Apply.

The pin name appears at the specified position.

Note

The Offset is measured in Secondary grid units. The maximum Offset is 127.

See Also »“Adding a Pin Name” on page 265

Adding or Changing a Pin Attribute Value

Pin Attributes are characteristics or properties associated with a pin.
PinName, Polarity, and PinNumber are examples of Pin Attributes.

To add or change pin attribute values:

1. In Symbol Editor, select the pin for which you want to add or change
attributes.

2. Choose Edit > Object Properties.
The Object Properties Setting dialog box opens.

3. Inthe left-hand list, select the pin from the Pins list.
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The attributes for the selected pin are displayed in the right-hand table in
alphabetical order.

4. Double-click the Value cell for the desired attribute, type in a new value,
and click Apply.

The attribute value is assigned to the selected pin.

See Also “Pin Attributes” on page 259

Adding an Attribute Window to a Symbol

Attribute windows are predefined areas on or near a symbol or pin in which
attribute values are displayed. In Symbol Editor, the window only contains the
attribute name. When the symbol is instantiated in a schematic drawing, the
attribute window contains the attribute value for that instance, rather than the
attribute name.

Attribute windows do not have a visible outline. If no value is displayed, there
is no indication that an attribute window has been defined.

To add an attribute window to a symbol in Symbol Editor:
1. Choose Edit > Attribute Window.

The Attribute Window dialog box opens. It contains all attribute names.
2. Select the desired attribute name from the list.

The attribute name is attached to the cursor.

3. Click to place the symbol attribute window at the desired position on (or
near) the symbol.

Two narrow bars appear beside the window's name, in a position
indicating the text justification. For example, a right-justified name has the
bars at the right end of the name.

4. Close the dialog box when you finish.

Adding Symbols to the Schematic

You can use the Add Symbol command on the Edit menu to select and add
symbols to a schematic. Symbols come from a symbol library, or you can
create your own symbols using Symbol Editor. Symbol files have the file
extension .sym. Symbol libraries have the file extension .lib.

To select and add a symbol to a schematic:
1. In Schematic Editor, choose Edit > Add > Symbol.
The Add Symbol dialog box opens.
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2. Inthe dialog box, choose a library from the Library list.
Tip
If you want your own library of custom schematic symbols to appear in the Library

list, you need to specify them in advance. See “Adding Symbol Libraries to
Schematic Editor” on page 256.

3. From the Symbols list, select a symbol.
The symbol is attached to the cursor.

4. After the symbol is attached to the cursor, click the location in the
schematic where you want to place the symbol. If you pick the wrong
symbol or change your mind, right-click anywhere in the window to
remove the symbol from the cursor. You can then select a different
symbol.

Note

The symbol remains attached to the cursor, so that you can place multiple copies
without having to reselect the symbol.

See Also »“Using Lattice Symbol Library” on page 247

Deleting Symbols

To delete a symbol from a schematic:
1. In Schematic Editor, click the symbol that you want to delete.
2. Choose Edit > Clear.

The symbol is deleted from the schematic.

Copying Symbols
If an instance of the symbol you want already appears in the schematic, you
can copy it to another location.

To copy a symbol:
1. In Schematic Editor, choose Add > Symbol.
2. Click the instance that you want to copy.
A copy of that symbol is attached to the cursor.
3. Click the location in the schematic where you want to place the symbol.

Schematic Editor places a copy of the symbol at that location. The symbol
remains attached to the cursor, so that you can place multiple copies
without having to reselect the symbol.
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Selecting Symbols

You can select one or more symbols in Schematic Editor. The selected
symbols are highlighted in red.

To select symbols:
1. Choose Edit > Add > Select, or click k on the drawing toolbar.
2. Do either of the following:

Click the symbol.

Draw a rectangle area around the desired symbols.

You can continue to select symboals, in either of the above mode, as long
as you hold down the Shift key.

Note

You cannot deselect a symbol by clicking it again. To deselect symbols, click any
empty space on the schematic sheet.

Transforming Symbols
You can mirror or rotate symbols in Schematic Editor before you place them.

To mirror a symbol before placing it:

When the symbol is attached to the cursor, choose Edit > Mirror.

To rotate a symbol before placing it:

When the symbol is attached to the cursor, choose Edit > Rotate.

Moving Symbols

You can move symbols in Schematic Editor in three ways.

To move a single symbol:

1. Select k from the drawing toolbar.

2. Choose Edit > Move.

3. Click the symbol that you want to move.

4. Drag it to a new location to move the symbol there.

Net names, attributes, and instance names are moved as well as the physical

representation of the symbol. A priority list determines which item is selected
if the cursor points at two or more items when the mouse button is clicked.

To move all symbols in an area:

1. Select k from the drawing toolbar.
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2. Choose Edit > Move.

3. Drag the mouse to define a rectangle area around the symbols that you
want to move.

When the mouse button is released, all items totally enclosed by the
rectangle are selected.

4. Drag the selected symbols to a new location.

All items totally enclosed by the rectangle are moved.

To move a group of symbols:

1. Select k from the drawing toolbar.

2. Choose Edit > Move.

3. Select one or more items, as either a single item or area.

As each item or area is selected, it is highlighted. You can continue to
select items, in either single item or area-selecting mode, as long as you
hold down the Shift key.

4. Drag the selected group to a new location.

All items in the group are moved. The relative position of the items in the
group is maintained.

Schematic Attributes

You use attributes to describe the characteristics or properties belonging to,
or associated with, a symbol, pin, or net. Attributes only apply to describing
characteristics in schematics. HDL source files have their own syntax for
describing characteristics.

For pre-defined schematic attributes supported by FPGA and MachXO
devices, see “List of Schematic Attributes” on page 271.

For more information on attribute usage, see the syslO User Guides on the
Lattice Web site.

Attribute Use Attributes are primarily used to control certain aspects of
design optimization and signal placement. You can also use attributes to
control design implementation.

Attribute Types There are two types of attributes used in Schematic Editor:
symbol and net.

Symbol attributes describe features related to a whole symbol. Symbol
attributes usually apply only to the symbol on which they appear.

Net attributes describe characteristics associated with nets.
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Setting Attribute Values In the FPGA device flow, Schematic Editor
passes attribute information to the output netlist as Verilog HDL or VHDL
attributes depending on the project type specified when you define a project.
For those attributes that can be edited, you can set or override the values as
follows.

You can set symbol and pin attribute values for all occurrences of a
symbol in Symbol Editor.

You can override the attribute values in any schematic where the symbol
appears by using Schematic Editor.

Default Values Attribute values in a symbol definition become the default
values for each symbol instance. These values are frequently overridden in
the completed design to reflect the design’s application.

When you are in Symbol Editor, any attribute values you set in Symbol Editor
will be used.

When you are in Schematic Editor, any attribute values you set in Schematic
Editor will be used. If you did not specify attributes for the symbol in
Schematic Editor, Schematic Editor will use the values set for the symbol in
Symbol Editor.

Attributes that apply to all instances of a symbol are generally assigned
values when the symbol is created. Attributes that apply to a single instance
(such as the instance name) are assigned after a symbol has been placed in
the design.

The symbol libraries supplied with the Diamond software have predefined
values for all the attributes required by most simulators and netlisters.

Displaying Attribute Values on a Schematic Attribute values are
displayed in attribute windows. Before an attribute can be displayed on a
schematic, an attribute window number must be assigned to the attribute in
Symbol Editor.

List of Schematic Attributes

Schematic Editor for FPGA and MachXO Crossover Programmable devices
supports the ability to specify HDL attributes as schematic symbol or net
attributes. HDL attributes are interpreted by place and route implementation
software.

Schematic Editor supports schematic attributes summarized in the following
tables for Precision RTL Synthesis, Synplify Pro, and Diamond. For detailed
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information on the above Synplify attributes, see “Synthesis Attributes and
Directives” in the Synplify and Synplify Pro for Lattice Reference Manual.

Table 7: Table of FPGA HDL Attributes for Precision RTL Synthesis

HDL Attribute

black _box

don't_touch

hierarchy

noopt

nopad

preserve_driver

preserve_signal

Attribute Type

Symbol

Symbol

Symbol

Symbol

Net

Net

Net

Description and Syntax

Tells Precision RTL Synthesis that the module should not be compiled
or optimized. Only the interface need be defined for synthesis.

Values: True | False

Tells Precision RTL Synthesis to pass the module through synthesis
without optimizing or unmapping.

Values: True | False
Tells Precision RTL Synthesis to maintain the hierarchy of the module.

Values: Preserve | Flatten

Tells Precision RTL Synthesis that an instance should not be optimized
or changed.

Values: True | False

Tells Precision RTL Synthesis to not place an 1/0 pad on the specified
port when the design is mapped to the technology.

Values: True | False

Tells Precision RTL Synthesis to preserve the specified signal and the
driver in the design. Specifies that both a signal and the signal name
must survive synthesis.

Values: True | False

Tells Precision RTL Synthesis to preserve the specified signal in the
design.

Values: True | False

Table 8: Table of FPGA HDL Attributes for Synplify Pro

HDL Attribute

syn_black_box

syn_direct_enable

syn_force_pads

Attribute Type

Symbol

Net

Net

Description and Syntax

Tells Synplify Pro to treat the module as a black box during synthesis.

Values: 1| O; True | False

Tells Synplify Pro to use the signal as the enable input to an enable flip-
flop when multiple candidates are possible. (LatticeECP/EC,
LatticeECP2/M, LatticeSC/M, LatticeXP, and MachXO only)

Values: 1 | 0; True | False

Tells Synplify Pro to enable or disable 1/O insertion on a port level or a
global level.

Values: 1| O; True | False

Lattice Diamond 3.6 Help

272



Schematic Design Entry

Table 8: Table of FPGA HDL Attributes for Synplify Pro

HDL Attribute

syn_hier

syn_keep

syn_netlist_hierarc

syn_noarrayports

syn_noclockbuf

syn_noprune

syn_maxfan

syn_preserve

syn_useioff

Attribute Type

Symbol

Net

Symbol

Symbol

Net

Symbol

Net

Net

Net

Description and Syntax

Tells Synplify Pro how to control the amount of hierarchical
transformation that occurs across boundaries on module or component
instances during optimization.

Values: Soft (default) | Firm | Hard | Remove | Macro | Flatten |
Flatten,Soft | Flatten,Firm | Flatten,Remove

Tells Synplify Pro to not remove the internal signal during synthesis and
optimization.

Values: 1| O; True | False

Tells Synplify Pro whether or not to generate the hierarchy in the EDIF
output when you assign the attribute to the top-level module of your
design. The default (true) is to allow hierarchy generation.

Values: 1| 0; True | False

Tells Synplify Pro to treat the ports of a design unit as individual signals
(scalars), not as buses (arrays) in the EDIF file.

Values: 1 | 0; True | False

Tells Synplify Pro to disable automatic clock buffer insertion.

Values: 1| O; True | False

Tells Synplify Pro whether or not to remove instances that have outputs
that are not driven.

Values: 1| O; True | False

Tells Synplify Pro the fanout limit for an individual input port or register
output. (LatticeECP/EC, LatticeECP2/M, LatticeSC/M, LatticeXP, and
MachXO only)

Values: integer

Tells Synplify Pro to prevent sequential optimizations across a flip-flop
boundary during optimization and preserves the signal.

Values: 1| O; True | False

Tells Synplify Pro to pack flip-flops in the I/O ring to improve input/
output path timing. (LatticeECP/EC, LatticeECP2/M, LatticeSC/M,
LatticeXP, and MachXO only)

Values: 1| O; True | False

Table 9: Table of FPGA HDL Attributes for Diamond

HDL Attribute
BBOX
BBOXTYPE
BLOCKNET
BUS

COARSE

Attribute Type
Symbol
Symbol

Net

Net

Symbol

Values
<height>.<width>
Obsolete. Do not use.
<name>
<bus_name>

CDELO | CDEL1 | CDEL2 | CDEL3

Lattice Diamond 3.6 Help

273



Schematic Design Entry

Table 9: Table of FPGA HDL Attributes for Diamond

HDL Attribute
COMP

DCSMODE

DELAYTYPE

DIFFCURRENT

DIFFRESISTOR

DIN
DOUT
DRIVE

ENDPOINT

FINE
FIXEDDELAY
FREQUENCY
GSR
HGROUP
HULOC
HURLOC

IMPEDANCE

IMPEDANCEGND

IMPEDANCEVCCIO

INBUF
IO_TYPE
LOAD

LOC

MAXDELAY
NOCLIP
NOMERGE
NORETIME
OPENDRAIN
PCICLAMP

PERIOD

Attribute Type
Symbol
Symbol

Symbol
Symbol/Net
Symbol/Net
Symbol
Symbol

Net

Symbol/Net

Symbol

Net

Net

Symbol
Symbol
Symbol
Symbol
Symbol/Net
Symbol
Symbol
Symbol

Net

Symbol
Symbol/Net

Net
Net
Net
Symbol
Net
Net

Net

Values
<comp_name>

NEG | POS | HIGH_LOW | HIGH_HIGH | LOW_LOW | LOW_HIGH |
CLKO | CLK1

CFGBIT | DLL | PCLK | ECLK

NA|2|35]|4|6

Off (default) | 100 | 150 | 200 (only for differential buffers)
<cell_name>

<cell_name>

NA|2]|4]|8 (default) | 12| 16 | 24

Obsolete. Use Spreadsheet View to apply the TO keyword in the
BLOCK, MAXDELAY, and MULTICYCLE constraints instead.

FDELO | FDEL1 | FDEL2 | ... | FDEL47

False | True

<value> (expressed in MHz)

ENABLE | DISABLE | FORCEENABLE | IPENABLE
<identifier>

R<row_number>C<column_number>
R<row_number>C<column_number>

Off (default) | 25|33 | 50 | 100

Off (default) | 16.7 | 20 | 25| 33| 50 | 100 (Impedance down)
Off (default) | 16.7 | 20 | 25| 33| 50 | 100 (Impedance up)
Off | On

<buffer_type>

<integer>.<integer>

<string>

Default is None (floating).
<value> (expressed in ns)
1

<net_name>

<string>

On | Off (default)

On | Off (default)

<value> (expressed in ps)
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Table 9: Table of FPGA HDL Attributes for Diamond

HDL Attribute
POWERSAVE
PULLMODE
PWRSAVE
RBBOX
REFCIRCUIT
REGION
SLEW
SLEWRATE

STARTPOINT

TERMINATEGND
TERMINATEVCCIO
TERMINATEVTT
UGROUP

VCMT

Attribute Type

Values

Net Obsolete. Do not use.

Net Up (default) | Down | None | Keeper | PCIClamp

Symbol Off (default) | On

Symbol <height>.<width>

Symbol/Net Off (default) | Internal | External (for differential buffer)

Symbol <identifier>

Symbol 1-100

Net Fast | Slow | NA (LatticeSC/M only)

Net Obsolete. Use Spreadsheet View to apply the FROM keyword in the
BLOCK, CLOCK_TO_OUT, MAXDELAY, and MULTICYCLE
constraints instead.

Symbol/Net Off (default) | 50 | 100 | 120

Symbol/Net Off (default) | 50 | 100 | 120

Symbol/Net Off (default) | 60 | 75| 120 | 150 | 210

Symbol <identifier>

Symbol/Net OFF (default) | VCMT | VTT | DDR_II

Assigning Attribute Values in a Schematic

Schematic Editor enables you to assign attribute values for symbols and nets.
See “List of Schematic Attributes” on page 271 for schematic attributes
supported by Lattice FPGA devices.

Following the steps below, you can assign attribute values in a schematic (the
procedure takes assigning the DOUT symbol attribute as an example).

To assign an attribute value in a schematic:

1.
2.

In Schematic Editor, open the schematic you want to work with.

In the Schematic area, select the symbol for which you want to assign the
DOUT attribute.

Choose Edit > Object Properties.

In the pop-up dialog box, click the plus sign before Symbols to show the
symbol name.

Select the symbol name. All its symbol attributes are displayed in the
right-hand table.

In the attributes list, double-click the Value cell for DOUT, type 1 in the cell,
and then click Apply to save the assignment.

The value 1 is assigned to the DOUT attribute.
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7. Click OK to close the dialog box.

The above example takes assigning symbol attribute values as an example. If
you want to assign a net attribute value, select a net in Step 2, and then
perform the same operations to show the net attributes list and assign
attribute values.

The net attribute LOC is used to lock pins. Double-click the Value cell for LOC
in the net attributes list, type in a pin name in the edit box, and then click
Apply. The selected net will be locked to the pin.

Net attributes also include 1/O configuration attributes such as I0_Type, Drive,
Slewrate, Pullmode, PCIClamp, OPENDRAIN, and various synthesis tool
attributes. See “List of Schematic Attributes” on page 271 for schematic
attributes supported by Lattice FPGA devices.

Schematic Sheets

A sheet is a page of a schematic. A schematic file can consist multiple sheets.
The schematic sheets can be added, deleted, resized, and renumbered.

Adding a New Sheet

You can add new (blank) sheets to an existing schematic.

To add a new sheet to a schematic:
1. Choose Edit > Sheet.
2. Inthe Sheet Operating dialog box, click New.

3. Inthe pop-up dialog box, enter a sheet number, select a sheet size, and
click OK.

4. In the Sheet Operating dialog box, click OK.

Schematic Editor adds the new sheet to the list.

Resizing Sheets

You can change the sheet size to any of several sizes that are based on the
standard paper sizes of the American National Standards Institute (ANSI).

Table 10: Schematic Sheet Sizes

Paper Size In Inches In Millimeters Similar I1SO Size
ANSI A (letter) 11x 8.5 279 x 216 A4
ANSI B (ledgeror 17 x 11 432 x 279 A3
tabloid)
ANSI C 22 x17 559 x 432 A2
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Table 10: Schematic Sheet Sizes

Paper Size In Inches In Millimeters Similar ISO Size
ANSI D 34 x22 864 x 559 Al
ANSI E 44 x 34 1118 x 864 AO

To resize a sheet:

1.
2.

Choose Edit > Sheet.

In the Sheet Operating dialog box, select the Size cell of the sheet that
you want to change.

Click Resize.

The Resize Sheet dialog box opens, displaying the current size of the
selected sheet.

Select the desired new size from the drop-down menu.
Click OK.
In the Sheet Operating dialog box, click OK.

Renumbering Sheets
You can change the number of any sheet in the schematic.

To renumber a sheet:

1.
2.

Choose Edit > Sheet.

In the Sheet Operating dialog box, select the sheet number that you want
to change, and click Renumber.

The Change Sheet Number dialog box opens.
Type the new sheet number in the dialog box and click OK.
In the Sheet Operating dialog box, click OK.

Schematic Editor changes the number of the sheet to the new number.

Re-sequencing Sheets

You can use the Resequence Sheet command to sequentially renumber,
starting at sheet 1, all the sheets in the drawing and remove any skipped
numbers.

To resequence sheets in your schematic:

1.
2.

Choose Edit > Sheet.
In the Sheet Operating dialog box, click Resequence, and then click OK.

Schematic Editor resequences the sheets and deletes all unused
(skipped) numbers.
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Printing Sheets

For schematic sheets, the Print command prints whatever is showing in the
Schematic Editor window. Print acts much like a screen capture tool. You may
need to experiment with Print Preview to get the printout that you want.

To print schematic sheets:
1. Click =/ to detach Schematic Editor from Diamond’s main window.
2. Click View > @ Zoom Fit.

3. Adjust the height or width of the Schematic Editor window so the sheet fills
the window with the same small margin on all sides.

4. Choose File > & Print Preview.
The Print Preview window opens.

5. Expand the Print Preview window until you are comfortable with the
display of the page.

6. To maximize the printout, click A~ for landscape mode.

7. Click the Page Setup | button and adjust the paper size and margins if
necessary.

8. If you are not happy with the way the page looks, close Print Preview,
adjust the Schematic Editor window, and open Print Preview again.

9. Click the Print &= button.
10. Adjust the printer settings if necessary and click Print.

With a little experience, you will be able to skip using Print Preview and just
choose File > & Print after adjusting the Schematic Editor window.

Wiring a Schematic

Wires electrically connect schematic symbols. The symbol pins are the
connection points for the wires. The Add Wire command is used to add wires
between symbol pins. However, you can also use the Add Net Name and Add
Bus Tap commands to add single wire segments.

Wiring Constraints

Schematic Editor enforces a number of wiring constraints. Most are intended
to encourage clean layout and prevent ambiguous wiring patterns.

All wire segments must end on Primary grid points.

Wire segments must be oriented on the 90° axes.

A maximum of three wires can connect at a pin or 1/O port.
A net can have only one name (simple or compound).

Two I/O ports with different net names cannot be connected by a wire.
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An 1/O port can connect only to a wire segment, never a pin. (Add a wire
segment if you want a marker to be near a pin.)

An 1/O port cannot be placed in the middle of a diagonal line, only at the
end.

An /O port cannot be placed at the crossing point of two wires, even if the
wires are connected.

A tap can only be placed on a vertical or horizontal section of a wire.
Only one bus tap can be made at any point on a bus.

A bus can contain only individual signals, not other buses. Attempting to
give a net in a bus either a compound name or the name of another bus is
flagged as an error.

The relationship between an ordered bus (that is, a bus with a compound
name) and the signals in that bus is strictly enforced. Naming the bus or
one of its signals in a way that breaks this relationship is not permitted.
For example, you cannot assign a bus tap a name that is not in the bus.

Drawing a Wire Using the Point-to-point Method

To draw a wire using the point-to-point method:

1.
2.

Choose Edit > Add > Wire.

Click the first point of the wire. Two dotted lines, horizontal and vertical,
stretch from the selected point to the cursor. As you move the cursor, the
lines change from horizontal to vertical (or vertical to horizontal)
depending on the position of the cursor relative to the first point.

When the first dotted section has the length and direction you want, click a
second time.

The first dotted section changes to the wire color and its position is fixed.
A new dotted section is now added to the “rubber band” line. You can add
additional wire segments by repeating steps 2 and 3.

To end the wire, click twice at the same point (or right-click).

The wire terminates automatically if the point you click falls on a pin
terminal.

Drawing a 4-way Connection

To form an intersecting connection:

1.
2.

Start with a single wire.

Add one or two additional wires at right angles to the first wire from a point
on the first wire. This type of connection is automatically marked with a
connect dot to distinguish it from unconnected crossing wires.
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Selecting Wires

You can select one or more wires in Schematic Editor. The selected wires are
highlighted in red.

To select wires:
1. Choose Edit > Add > Select, or click k on the drawing toolbar.
2. Inthe schematic, do either of the following:

Click a wire to select it. You can continue to select more wires by
holding down the Shift key.

Draw a rectangle area to enclose the desired wires. The wires inside
the area are selected.

Note

When selecting wires, the area-selecting method only allows you to select one
area. You cannot use the Shift key to select additional areas.

You cannot deselect a wire by clicking the wire again. To deselect wires, click any
empty space on the schematic sheet.

Changing Wire Length or Direction

After wires are placed to the schematic, you can drag the wire ends to
lengthen or shorten them, or change their routing directions.

To change wire length or direction:

1. Choose Edit > Add > Select, or click k on the drawing toolbar.
2. Choose Edit > Drag.

3. Select one or more wires that you want to change.

4

Place the mouse cursor near the wire end of the selected wire(s). When
the cursor changes to ‘%’ click and drag the wire end to the desired
place.

Note

If the node connected with the wire end that you drag only has one linked
connection, dragging the wire end moves the entire wire instead of changing its
length or direction.

You cannot shorten wires if you have selected too many wires which are very close
to each other. Shortening wires by dragging requires enough space to avoid wire
overlapping. In such cases, you can shorten the wires one by one or adjust their
positions before shortening them.

Deleting a Wire Connection

You can delete wires from the schematic in two ways using the Clear
command.
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To delete a single wire or wire segment:
1. Click the wire or wire segment that you want to delete.
2. Choose Edit > Clear.

The wire is deleted. If the cursor points at more than one item, the items
are deleted based on a priority list.

To delete wires enclosed in an area:
1. Drag a rectangle area to enclose the wires that you want to delete.
2. Choose Edit > Clear.

All totally enclosed wires are deleted when you release the mouse.
Portions of wires enclosed by the rectangle are also deleted. All wire
segments outside the rectangle remain. All wires that cross the rectangle
are cut into wire segments.

Nets and Buses

This section introduces the concepts of nets and buses, as well as procedures
on creating and naming nets and buses.

Nets

Any single- or multi-wire connection between pins is called a net (“network”).
The following topics explain how nets are named and how multi-wire nets
(called buses) are created and named.

Net Names

The nets (networks) form the electrical connections among the components.
Every net has a name, either assigned by you or by Schematic Editor. Net
names have two principal functions: identification and interconnection.

Note

If your instance names use brackets [ ], parentheses (), or curly braces { }, the
software replaces these characters with an underscore ( _) because they are illegal
characters in HDL.

Meaningful net identifiers make a design easier to understand. Nets are
usually given the names of the signals they carry.

If you do not assign a name, Schematic Editor automatically assigns a unique
name when you save the file, in the form of N_nn, where nn is an integer.

You can override any name assigned by Schematic Editor and assign one of
your own by using the Add Net Name command from the Edit menu.
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Interconnection If a wire segment attached to a symbol pin is given the
name of a net or bus, the pin is attached to that net or bus, even if you haven't
drawn the connection on the schematic.

Two or more wires with no visible connection on the schematic are
automatically connected if they have the same net name. Each wire is called
a branch of that net. Inter-sheet connections are created in this way.

You can easily find implicit net connections with the Drc Check command from
the Design menu. Click any net or bus. All wires with the same name are
highlighted, on all sheets of the current schematic.

Nets with different names cannot be connected. Schematic Editor will warn
you if you try to “short” them.

Legal Characters in Net Names The following characters can be used in
net names:

Table 11:
Character Description
A-Z, a—z, 0-9 All alphanumeric characters. Case is not significant.

Apostrophe (single quote)

Underscore

Reserved Names If B is the first character of a net name, the underscore
cannot follow it as the second character (as in B_). The underscore cannot be
used in a net name of the form “N_nn" (where “nn” is any integer). These
names are reserved by Schematic Editor for nets that have not been named
by the user.

Entering a Net Name

Use the Add Net Name command from the Edit menu to assign a name of
your own choice to a net. Your name replaces any name Schematic Editor
may already have assigned. If you assign the same name to two separate
nets (“branches”), they are connected, even though no connection appears
on the schematic. This feature makes it easy to connect widely spaced
components without having to draw long wires across the schematic.

Net names you assign are always displayed; Editor-assigned names are not
displayed. To avoid cluttering the schematic, you should name only these
nets:

That connect to other schematics.
Whose functions need documentation or clarification.
Whose signals you want to reference in simulation or timing analysis.

Whose signals you want to identify in the Fitter report.
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To enter a net name:
1. In Schematic Editor, choose Edit > Add > Net Name.

2. Inthe pop-up dialog box, enter a name. The name is attached to the
cursor. You can then place it to the schematic.

Placing a Net Name

Once a net name (or group of names) is attached to the cursor, there are
three ways to place it.

Click an empty space to place the net name at an empty point on a
sheet. This will be an error unless a net is eventually connected to the
name flag.

Click a net to place the net name on the selected net. If you click at the
end of a net, the net name extends from the end. If you click the middle of
a net, the net name is centered just above the net.

Drag to create the net and place the net name on the newly created net.
The net name and a single net segment can be placed simultaneously.
You can then place subsequent wires and names by clicking a pin.

Note

You can only define a horizontal or vertical net segment in this way. If either end of
the segment connects to a perpendicular net or bus, a bus tap is created at that
end of the segment. If the net was not a bus, it is promoted to one.

The position of the name is determined by the segment ends at the time of
placement. If both ends are connected, the name is placed in the middle. If neither
end of the segment is connected, the name is placed at the starting point. If only
one end of the segment is connected, the name is placed at the unconnected end.

After you drag the mouse to or from a pin, you can place subsequent net names by
clicking a pin. You do not need to drag. A wire segment is automatically added, of
the same length as the one previously dragged. The name is attached as
described above.

The segment ends determine the position of the name at the time of
placement. If both ends are connected, the name is placed in the middle. If
neither end of the segment is connected, the name is placed at the starting
point. If only one end of the segment is connected, the name is placed at the
unconnected end.

After you drag the mouse to or from a pin, you can place subsequent net
names by clicking a pin. You do not need to drag. A wire segment of the same
length as previously dragged is automatically added. The name is attached as
described above.
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Renaming a Net

To rename a net:
1. In Schematic Editor, choose Edit > Add > Net Name.

2. Inthe pop-up dialog box, type the new net name. The new name is
attached to the mouse cursor.

3. Torename the net (that is, all branches of the net, across all sheets),
press and hold down Shift as you click. You can click anywhere on the
net.

The new net name replaces the old one.
If the renamed net has an 1/O port:
The I/O port is removed if you click to rename a specific branch.

The I/O port is kept if you hold down Shift to rename all branches.

Important

Remember that renaming a single branch disconnects that branch from the rest of the
net and connects it to the net (if any) with the new name.

Note

If the name of a branch is displayed two or more times on a single branch, you cannot
rename the branch. You must first use the Clear command to remove the extra
name(s).

Specifying Signal Direction

An 1/O port is a special indicator that identifies a net name as a device input,
output, or bidirectional signal. This establishes net polarity (direction of signal
flow) and indicates that the net is externally accessible.

The Schematic Editor Drc Check command uses I/O ports to flag any
discrepancies in the polarity of marked signals and the symbol pins.

To add a port:

1. Make sure the net has a hame. Nets must be nhamed before ports can be
attached.

2. Choose Edit > Add > = 10 Port.
The Set IO Type dialog box appears.

3. Inthe drop-down menu on the left of the dialog box, choose the port
direction. (Or select None to remove an existing port.)

4. If the net name is not at the end of the net where the port will go, choose
Edit > Add > * Net Name. The Set |0 Type dialog box changes to the
Set Wire Name dialog box. In the text box, type the name of the net. The
port must be given the same name as the net.
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5. Click the end of the wire. Or you can draw a box around one or more net
names if the names are attached to the ends of their wires.

The port, along with the net name, appears extending from the end of the
wire.

Note

You can place, remove, or change several ports at one time by dragging a box
around the wire ends.

A net should only have one I/O port per sheet.

To change a port:
1. Choose Edit > Add > = |0 Port.
The Set IO Type dialog box appears.

2. Inthe drop-down menu on the left of the dialog box, choose the new port
direction. (Or select None to remove an existing port.)

3. Click the end of the wire. Or you can draw a box around one or more
ports.

Buses

A bus combines two or more signals into a single wire. Buses are a
convenient way to group related signals. This grouping can produce a less
cluttered, functionally clearer drawing and clarify the connection between the
main circuit and a Block symbol.

The figure below shows how a circuit appears before and after a bus has
replaced individual wires. The two schematics are electrically equivalent.

Circuit before and after a bus has replaced individual wires.
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Ordered Buses An ordered bus has a compound name consisting of the
names of the signals that comprise the bus. Any signals can be combined into
an ordered bus, whether they are related.

A net becomes an ordered bus when it is given a compound name. The net is
promoted to an ordered bus containing the nets listed in the compound name.
(The net is redrawn at twice its regular thickness to indicate that it's now a
bus.)

A compound name is a list of two or more net names, separated by commas.
For example:

READ, WRITE, MYNAME

represents the three signals READ, WRITE, and MYNAME. Spaces in
compound names are ignored.

Adding a sequence of numbers to a name can also form a compound name.
The sequence is specified as a starting number, an ending number, and an
optional increment (default = 1). The numbers are positive integers, and are
delimited by commas (, ), dashes (—), or colons (: ). The sequence is
enclosed in brackets [ ], parentheses (), or curly braces { }.

The following are examples of sequential compound names.

Table 12:

Sequential Name Signals

DATA[0-7] DATA[0] DATA[1] ... DATA[7]
ADDR(0,14,2) ADDR(0) ADDR(2) ADDR(4) ... ADDR(14)
10{4:23:3} 10{4} 10{7} 10{10} ... 10{22}

If the increment is greater than one, the ending number will not appear in the
sequence if it does not equal the starting number plus an integral multiple of
the increment (as in the third example above).

A compound name can also combine individual names and compound names
in any order.

Table 13:
Sequential Name Signals
CS,DATA{0:7},WR CS DATA{0} DATA{1} ... DATA{7} WR
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The order of the signals in the bus is the same as the order in which they are
specified. The order is significant only when the bus is connected to a bus pin.
(Bus pins are described in a later section, “Bus Pins” on page 288.”)

Note

If your instance names use brackets [ ], parentheses (), or curly braces { }, the
software replaces these characters with an underscore ( _ ) because they are illegal
characters in HDL language.

Unordered Buses An unordered bus is nothing more than an unnamed
wire with bus taps. A net with a single name (or any unnamed wire) is
promoted to an unordered bus by attaching one or more bus taps to it. The
order of the signals within an unordered bus is not defined and has no
significance.

Although the order of the signals in an unordered bus has no significance, you
must name the wires connecting to the bus taps, because Schematic Editor
would otherwise have no way of determining which symbol pin at one end
connects to which symbol pin at the other end

Unordered buses provide a convenient way to route signals through the
schematic with a minimum of visual clutter. They have no other function.

Unordered buses cannot connect to bus pins, because bus pins represent an
ordered sequence of signals.

Adding a Bus Tap

Signals enter (or exit) a bus at points called bus taps. A bus tap can be added
to any existing bus, net, or wire. If a net or wire is not already a bus, adding
the tap automatically promotes it to a bus.

To add a bus tap:

1. Choose Edit > Add > Bus Tap.

2. Position the cursor on the bus or wire where the tap is required.
3. Drag the mouse to draw a wire perpendicular to the bus.

4. Release the mouse button when the wire is the desired length.

Bus taps can be made only on vertical or horizontal sections of a bus. Tap
connections are shown as two diagonal lines.

More than one tap can be taken from the same signal, to simplify routing or
permit a cleaner layout. But you cannot add a bus tap to an existing bus tap.
You will get the error message “Forming Multilevel Bus.”
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Naming the Tap

Once the tap has been added, choose the Edit > Add > Net Name command
to name it. If the tap is from an ordered bus, the tap’s name must match the
name of a signal in the bus. If it does not, Schematic Editor will flag it as an
error.

Note

Wires entering and leaving any bus (ordered or unordered) must be tagged with a net
name to indicate which signal is being tapped. Unnamed taps will eventually be
flagged as errors.

Bus Pins

A pin represents either a physical pin on a real component or a signal from a
lower-level schematic.

A bus pin represents a group of pins or signals. You create a bus pin by giving
a pin a compound name. That is, a list of signals. If the pin connects to a
Block symbol, each of the signals listed in the bus pin name must also appear
in the schematic. This defines the connection between the Block symbol and
its underlying schematic.

Ordered buses can connect directly to bus pins. The number of bits or signals
attached to the bus must match the number of bits or signals attached to the
bus pin.

The first signal in the bus (by definition, the first signal in the bus's name) is
connected to the first signal represented by the pin. The remaining signals in
the bus are connected to the remaining pins in the same order you assigned
the signal names to the pins.

Connecting to Pins

A tapped signal connects to an ordinary symbol pin in the usual way. An
ordered bus connects to a bus pin (a pin with multiple connections) directly.
No taps are needed; the connections are made automatically. The first signal
in the bus connects to the first signal in the bus pin, the second to the second,
and so forth. Both the bus and the bus pin must contain the same number of
signals.

Compound Names

The input and output nets of an iterated instance can be given either single
names or compound names. If the inputs or outputs are given a compound
name, their nets are promoted to buses in which each instance's input or
output is a separate signal.

Iterated buses work like any other bus. You can attach a bus (with the same
number of signals) directly to them, as you would any other bus.

Lattice Diamond 3.6 Help

288



Schematic Design Entry

Single Names

If an iterated input or output is given a single net name, there is only one input
or output net, and all the inputs or outputs connect in parallel to that single
net. In the figure below, the input net is given a single name and the inputs of
all four gates are connected in parallel to the net.
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This feature is used most often on inputs, not outputs. Paralleled outputs
represent a “wired-OR” configuration, which is usually drawn as separate
gates, rather than as an iterated instance.

Nets on Iterated Instances

Iterated instances allow a single symbol instance to represent multiple
instances in a parallel connection. The figure below shows two ways of
representing four parallel buffers. On the right, four separate inverters are
added to the schematic. On the left, one symbol with the instance name of
INV[0:3] represents the bank of four inverters.
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Bus and Net Connections to Iterated Instance

You can make an iterated instance of any symbol. A simple (non-bus) pin on
an iterated instance remains a simple pin. The iteration does not convert the
pin to a bus pin. The same rules of connection to a simple pin still apply.
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Connections to the nets of iterated instances are made according to the
following rules.

Table 14: Rules for Connection to Nets of Iterated Instances

Connection
Simple net to simple pin

Bus to bus pin

Simple net to bus pin

Bus to simple pin

Rule
The net connects to corresponding pin on each instance.

Successive bus signals connect to successive bus pins on successive
instances. The bus and bus pin must have the same number of nets.

Not permitted. Only a bus can connect to a bus pin.

The Nth signal of the bus connects to the scalar pin of the Nth instance. The
width of the bus and the number of instances must match.

Creating a Tap, Wire, and Net Name At Once

You can use the Net Name command in Schematic Editor to create the tap, a
wire, and the net name at once.

To create a tap using the Net Name command:
1. In Schematic Editor, choose Edit > Add > Net Name.

2. Inthe pop-up dialog box, type a net name contained in the bus to be
tapped. The name is attached to the mouse cursor.

3. Point to the place on the schematic where you want the free end of the
bus tap.

4. Drag the mouse to the bus and release the mouse button.

The tap is made, and the free end is labeled with the signal name.

Saving a Schematic

The Save File command in Schematic Editor saves the changes to the
existing schematic file. You can use the Save File As command to save the
schematic with another file name.

Schematic files have the extension .sch. Below shows the steps of saving a
schematic with the Save File As command.

To save a schematic with the Save File As command:
1. In Schematic Editor, choose File > Save File As.
The Save as Schematic File dialog box opens.
2. Go to the folder in which you want to save the schematic.
3. Type in a base name for the schematic.

Schematic Editor adds the .sch extension automatically when you specify
the base name.
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4. Click Save.

Debugging a Schematic

Schematic Editor has two levels of checking that report or prevent errors early
in the design process.

First level errors are detected as you enter your schematic. For example,
Schematic Editor will not let you draw an isolated wire that forms a closed
loop without connecting to anything else. It won't let you short together nets
with different names.

Second level errors are recognized in the context of a complete design. An
unconnected wire or pin, or an unnamed signal tapped from a bus, are normal
during the first stages of a design. Some potential errors are always indicated,
such as the dots on open pins and hanging line ends. Otherwise, errors of this
type are reported only when schematics and symbols are combined in the
design hierarchy.

You can check for errors and potential errors at any time.

See Also “Checking a Schematic for Errors” on page 291

Checking a Schematic for Errors
You can use the Drc Check command to detect errors that are only

meaningful in a completed schematic or symbol.

Schematic Errors The following schematic errors are detected:
Bus Taps should be named.
Isolated Net Name Flags are not permitted.

If the ShowSymbolPins option is enabled, each pin on symbols in this
schematic should be connected to a net.

If the MarkOpenEnds option is enabled, there should not be any
unconnected net ends.

Only ordered buses can be connected to a bus pin on a symbol.
Only ordered buses can be marked with 1/O ports.

Nets should not be marked with more than one 1/O port.

A bus tap and its bus should not both be marked with an 1/O port.

If there is a symbol for this schematic, the following errors are detected by
the schematic checker:

Each pin must have a corresponding net with an 1/0 port whose direction
matches the Polarity of the pin.

Each net marked with an I/O port must correspond to a pin.

Symbol Errors The following symbol errors are detected:
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Block symbols should have a schematic with the same name in the
current directory.

Symbols of a type other than Block are primitives and should not have a
schematic of the same name.

Each pin in a Block or Cell must have a Name. Each pin in a Gate or
Component should have a PinNumber.

Every pin in a Gate must appear in the same number of sections.
Therefore, all PinNumber attributes must have the same count of pin
numbers.

Pins in Component and Pin symbols can have only one PinNumber.

Pins in the same Gate group must have the same Polarity, Load and
Drive.

Pins on symbols that are not Blocks should have Load or Drive
specifications. Input pins should have Load but not Drive. Output pins
should have Drive, but not Load, unless the pin is tristate, in which case it
should have a Load that represents the load in the High-Z state.
Bidirectional pins should have both Load and Drive.

Pins on Blocks should not have Load or Drive specifications.

Checking Errors

To check a schematic for errors:
Choose Design > Drc Check.

The software opens an error report in a pop-up text window and writes the
information to a file.

Highlighting a Net

You can use the Select icon k to trace nets in a schematic. Selecting a net
changes its color (or turns it into a dashed line on a monochrome monitor). If
the net is a signal in a bus, the bus is also highlighted.

To highlight a net:

1. Click k on the drawing toolbar.

2. Click the net that you want to highlight.
The color of the net changes.

3. To remove highlighting, click any blank area in the schematic.

Troubleshooting FPGA Schematic Design

This section describes common problems and solutions for the schematic
design flow.

Lattice Diamond 3.6 Help

292



Schematic Design Entry

Verilog Functional Simulation Model (vericode.exe) or VHDL Functional
Simulation Model (vhdl.exe):

ERROR: Missing I/O marker for pin <pin names>
ERROR: Missing pin for I/O marker on net <net name>

Caused by a mismatch between 1/O ports of a schematic (.sch) and a related
schematic symbol (.sym). A common mistake is to overlook creating a symbol
for the top-level schematic of a project.

ERROR: Polarity mismatch on pin - I/O marker for net <net name>

Caused by a polarity (or type) mismatch between an I/O port and symbol pin.
A common mistake is attempting to read or feedback a signal marked with an
Output marker.

ERROR: --- Pins in symbol - <symbol names.sym
ERROR: --- IOs in schematic - <schematic names>.sym

Caused by a mismatch between I/O ports and a related schematic symbol. A
common mistake is modify the I/O ports and not update the related schematic
symbol (.sym). A common mistake is to overlook creating a symbol for the
top-level schematic of a project.

Schematic Editor > DRC:

Different I/0 marks on net <net name>

Caused by multiple I/O ports on the same net.

Pin <pin name> has wrong I/O mark

Caused by a mismatch between I/O ports and a related schematic symbol. A
common mistake is that you modified the 1/0 ports and not updated the
related schematic symbol (.sym). A common mistake is to overlook creating a
symbol for the top-level schematic of a project.

Bus <bus name> and signal <signal name> marked as I/0

Caused by multiple I/O ports on the same net.

Unconnected pin <instance name>-<pin names

Caused by an unwired pin. In general it is good practice to tie unused inputs
to a logic constant such as the VHI or VLO library element. Unused outputs
can remain unconnected.

Signal count mismatch on pin <instance name>-<pin name>

Caused by a range mismatch between the bus pin of a symbol instance and
the bus wire.
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ModelSim:

Unresolved reference to GSR_INST
Unresolved reference to PUR_INST
Unresolved reference to TSALL INST

ModelSim reports:

** Error: (vsim-3043) <path>/cae library/simulation/verilog/
machxo/FL1S3AY.v (15) : Unresolved reference to 'PUR_INST'

Many synchronous library elements from the Lattice FPGA Symbol Library
contain references to global signals related to Global Set/Reset (GSR), Power
Up Reset (PUR), or Tri-State All (TSALL). To establish a driver on these
“global” nets you must instantiate the related library element in your design or
test fixture. For more information, refer to the following topics:

“How to Use the Global Set/Reset (GSR) Signal” on page 1113
“How to Use the Power Up Set/Reset (PUR) Global Signal” on page 1128
“How to Use the Tristate Interface (TSALL) Global Signal” on page 1129

Customizing Work Environment
You can use the Options dialog box to set schematic display and work
environment for the schematic tools.

To access Schematic Editor or Symbol Editor options, choose Tools >
Options in the Diamond main window. Then select Schematic Editor or
Symbol Editor in the Options dialog box.

Turning On/Off Grid Display

You can use the Options dialog box to turn on or off the grid display in
Schematic Editor and Symbol Editor.

To turn grid display on or off:
1. Inthe Diamond window, choose Tools > Options.
The Options dialog box opens.

2. Inthe dialog box, click Graphic Options under Schematic Editor or
Symbol Editor.

3. Select Show Grid.
4. Click Apply or OK.
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Changing the Color Scheme

You can change the current color scheme for Schematic Editor and Symbol
Editor.

To change the current color scheme:
1. In the Diamond window, choose Tools > Options.
The Options dialog box opens.

2. Inthe dialog box, select Color Options under Schematic Editor or
Symbol Editor.

Select the colors you want to use as the new scheme.
4. Click Apply or OK.

Tool Options for Schematic Editor Colors
You can change the colors for the following items in the dialog box:

Background: Color of sheet background

Wire: Color of wire on sheet

Symbol: Color of symbol on sheet

Add Wire: Not used

Add Bustap: Not used

Highlight: Color of highlighted objects

Selected: Color of selected objects

Drc Check: Color of cross line which marks errors
Panel: Color of sheet panel including frame and pixels

Selected Box: Not used

Tool Options for Symbol Editor Colors

You can change the colors for the following items in the dialog box:
Background: Color of sheet background

Wire: Color of wire on sheet

Symbol: Color of symbol on sheet

Add Wire: Not used
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Add Bustap: Not used

Highlight: Color of highlighted objects

Selected: Color of selected objects

Drc Check: Color of cross line which marks errors
Panel: Color of sheet panel including frame and pixels

Selected Box: Not used
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Simulating the Design

This topic explains how to perform functional and timing simulation by using
the Diamond tools and third-party simulators.
See Also »“Functional Simulation” on page 298
“Simulation Environment” on page 298
“Design Source Files” on page 298
“Creating a New Simulation Project in Diamond” on page 299
“Exporting VHDL and Verilog Simulation Files” on page 300
“Verifying Designs with Timing Simulation” on page 301
“Timing Simulation in the FPGA Process Flow” on page 302
“Third-Party Simulators” on page 302

Simulation in Diamond

Diamond provides you with an interface to create a new simulation project file
that you can import into a standalone simulator. Diamond supports Active-
HDL and ModelSim simulation file for file exports. To create testbenches for
simulation in Diamond, generate all testbenches in your third-party tool using
an imported simulation project (.spf) file.
See Also »“Functional Simulation” on page 298

“Simulation Environment” on page 298

“Design Source Files” on page 298

“Creating a New Simulation Project in Diamond” on page 299

“Exporting VHDL and Verilog Simulation Files” on page 300
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Functional Simulation

Functional simulation is the process of verifying that the model of the design
matches the functional specification. Functional simulation helps identify logic
errors in a design before it is programmed into a device.

In the Diamond design flow, to perform functional simulation on designs
modeled with Verilog HDL or VHDL, you can peform pre-synthesis functional
simulation on your source HDL or netlist using a third party simulator. In
Diamond use the subprocesses Verilog Simulation File and VHDL
Simulation File to produce a post-map source simulation file for functional
simulation of primitive gate-level logic during that stage in the flow..

HDL Simulators The Diamond software and model libraries are qualified
with a variety of popular HDL simulators, including Aldec Riviera Pro®, Aldec
Active-HDL®, Cadence® NC-Verilog®, Cadence® NC-VHDL®, Cadence®
NCSim®, Mentor Graphics® ModelSim®, Mentor Graphics Questa®,and
Synopsys® vCSs®.

See Also »“Simulation in Diamond” on page 297

Simulation Environment

In the Diamond software environment provides library model resources in
both Verilog HDL and VHDL formats to support stand-alone simulation with
Aldec, Cadence, Mentor Graphics, and Synopsys simulators. Using the
simulation wizard inside of the Diamond software, you can create simulation
project files that can be exported and brought into standalone simulators.

In addition, you can use Diamond’s backannotation tools to extract gate-level
models and the timing data. This type of simulation is convenient if you want
to simulate a design file outside the current project. Stand-alone operation
enables you to choose your own settings and preferences.

You can customize the simulation by creating a different script (.do) file that
contains commands equivalent to the ModelSim or Active-HDL graphical user
interface (GUI) commands. For information about creating your own
simulation scripts, see Aldec’s Active-HDL online Help.

See Also “Simulation in Diamond” on page 297

Design Source Files

The third-party simulators enable you to simulate the operation of your design
in the following design entry formats:

Schematic format (<design>.sch) — Describes the circuit in terms of the
components used and how they connect to each other. These schematics
are automatically translated into Verilog or VHDL format.

VHDL format (<design>.vhd) — Describes the circuit in Very High-Speed
IC hardware description language (VHDL) format.
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Verilog HDL format (<design>.v) — Describes the circuit in Verilog format,
which is an industry-standard hardware description language used to
describe the behavior of hardware that can be implemented directly by
logic synthesis tools.

See Also “Simulation in Diamond” on page 297

Creating a New Simulation Project in
Diamond

This topic describes how to use the Diamond Simulation Wizard to create a
simulation project (.spf) file so you can import it into a standalone simulator.

1.

In Diamond, click Tools > Simulation Wizard or click the “ icon in the
toolbar. The Simulation Wizard opens.

In the Preparing the Simulator Interface page click Next.

In the Simulator Project Name page, enter the name of your project in the
Project Name text box and browse to the file path location where you want
to put your simulation project using the Project location text box and
Browse button.

When you designate a project name in this wizard page, a corresponding
folder will be created in the file path you choose. If you add a subdirectory
to the default file path the wizard will prompt you to create a new directory.
Click Yes in the popup dialog that asks you if you wish to create a new
folder.

Click either the Active-HDL or ModelSim simulator check box and click
Next. Note that if ModelSim is not installed, it will appear grayed out and
will not be selectable.

Note

Please note here that if you want to use ModelSim that you must precompile all of
the Lattice library files in the simulator before you proceed through the Simulation
Wizard. Diamond provides precompiled library files for Active-HDL.

In the Process Stage page choose what type of Process Stage of
simulation project you wish to create. Valid types are RTL, Post-Synthesis
Gate-Level, Post-Map Gate-Level, and Post-Route Gate-level+Timing.
Only those process stages that are available are activated.

Note that you can make a new selection for the current Strategy if you
have more than one defined in your project.

The software supports multiple strategies per project implementation
which allows you to experiment with alternative optimization options
across a common set of source files. Since each strategy may have been
processed to different stages, this dialog allows you to specify which stage
you wish to load.

In the Add Source page, select from the source files listed in the Source
Files list box or use the browse button on the right to choose another
desired source file.
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7.

By default, the Analyze HDL and test bench option is checked. This
option allows you to specify a top level simulation testbench. Uncheck
this box if you do not wish to specify a top level simuation testbench.

If you wish to keep the source files in the local simulation project
directory you just created, check the Copy Source to Simulation
Directory option.

Click Next. If the Analyze HDL and test bench option was checked in the
previous page, specify a name for the top level simulation test bench in
the Simulation top box the Parse HTL and Test Bench page.

Click Next, and a Summary page appears and provides information on
the project selections including the simulation libraries. By default the Run
simulator, Add top-level signals to waveform display, and Run
simulation check boxes are enabled. Their functionality is as follows:

The Run simulator option will launch the simulation tool you chose
earlier in the wizard in the Simulator Project Name page when you
perform Step 9.

The Add top-level signals to waveform display option can only be
selected if the Run simulator box is checked. This option adds top-
level signals to the waveform in the simulation tool when you perform
Step 9.

The Run simulation option can only be selected if the Add top-level
signals to waveform display option is checked. This option causes
your simulation tool to run the simulation automatically when you
perform Step 9.

Click Finish. The Simulation Wizard Project (.spf) file and a simulation
script DO file are generated after running the wizard. You can import the
DO file into your current project if desired. If you are using Active-HDL, the
wizard will generate an .ado file and if you are using ModelSim, it creates
and .mdo file.

See Also “Simulation in Diamond” on page 297

Exporting VHDL and Verilog Simulation
Files

In Diamond, you can export project simulation source files to simulate into
your third-party vendor simulation tool for timing simulation.

To export a VHDL or Verilog file in Diamond:

1. Inthe Process view, under the Export Files process check either the
VHDL Simulation File or Verilog Simulation File subprocess.

2. Double click the Export Files process to run the export feature. This will
generate a back-annotated version of your design file in an .ldb file, a
VHDL netlist (.vho) simulation file, and an SDF timing file.

Note:
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You can also use Tcl Diamond commands in the Tcl Console to accomplish
this task as shown below:

prj_run Export -task TimingSimFileVHD
prj run Export -task TimingSimFileVlg

See Also »“Simulation in Diamond” on page 297

Timing Simulation

The Diamond software supports two types of timing verification: dynamic
timing simulation and static timing analysis. See the Static Timing Analysis
topic and related information for more information on that type of design
verification.

To facilitate timing simulation, Diamond allows you to export simulation files
that you can import into a simulator for design verification using dynamic
timing simulation. In the Process view under Export Files use the Verilog
Simulation File and VHDL Simulation File to export a simulation project file
to a standalone Aldec Active-HDL® or Mentor Graphics® ModelSim®
hardware design language (HDL) simulator. Some simulators allow a
combination of both languages to be simulated concurrently. This scenario is
common when mixing IP cores.

See Also »“Verifying Designs with Timing Simulation” on page 301

“Timing Simulation in the FPGA Process Flow” on page 302

Verifying Designs with Timing
Simulation

Timing simulation is based on an event-driven simulator and requires you to
specify a test vector (waveform). Where timing analysis returns partial timing
information, dynamic timing simulation (timing simulation) gives you detailed
information about gate delays and worst-case circuit conditions. Because the
total delay of a complete circuit depends on the number of gates the signal
sees and on the way the gates have been placed in the device, you can only
perform timing simulation after you have implemented the design. Timing
simulation also requires several input files to run.

Diamond simulation files can be imported into HDL simulators (e.g., Aldec’s
Active-HDL or Mentor Graphics’ ModelSim) for dynamic timing simulation.
You can simulate FPGA devices by using any popular third-party HDL
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simulator. Dynamic simulation analyzers have considerably longer run times
than a static timing analysis tool like the Diamond TRACE program.

Note

You cannot generate text fixtures in Diamond. All simulation must be done outside of
the Diamond software using simulation files in a supported simulator. For guidelines
using third-party EDA simulators with Diamond software, see your vendor
documentation or the following references.

See Also »“Timing Simulation” on page 301

Timing Simulation in the FPGA Process
Flow

The following figure shows the place of timing simulation in the FPGA process
flow as a part of design verification. To learn more about timing analysis using
static timing analysis tools, see the appropriate topics in this Help system.

See Also “Timing Simulation” on page 301

Third-Party Simulators

This section explains how to use Aldec Active-HDL, Aldec Riviera Pro,
Cadence NC-Verilog, Cadence NC-VHDL, Cadence NCSim, Mentor Graphics
ModelSim / Questa, and Synopsys VCS software to simulate designs that
target Lattice Semiconductor FPGAs. It shows you how to use these
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Figure 46: Timing Simulation Flow Chart
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simulators to perform functional register-transfer-level (RTL) simulation, post-
map simulation, and place-and-route gate-level simulation with and without

timing simulation.

Note

Lattice Semiconductor does not supply the Synopsys VCS, Cadence NC-Verilog,
Cadence NC-VHDL, Cadence NCSim, Aldec Riviera Pro, or Mentor Graphics
ModelSim / Questa simulators. You must obtain them independently.

See Also »“Simulation Library Files” on page 304

“Performing Simulation with Aldec Riviera Pro” on page 307
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“Performing Simulation with Aldec Active-HDL” on page 312
“Performing Simulation with Cadence NC-Verilog” on page 313
“Performing Simulation with Cadence NC-VHDL” on page 317

“Performing Mixed-Language (Verilog and VHDL) Simulation with
Cadence NCSim” on page 321

“Performing Simulation with Mentor Graphics ModelSim / Questa” on
page 322

“Performing Simulation with Synopsys VCS” on page 324

“Performing Mixed-Language (Verilog and VHDL) Simulation with
Synopsys VCS-MX” on page 325

“Performing Mixed-Language (Verilog and SystemVerilog) Simulation with
Synopsys VCS-MX” on page 326

“Referencing Black-Box Models” on page 327

Simulation Library Files

This section describes where to find the source simulation library files for
FPGA device families. In addition to source files, compiled versions of the
simulation library files are available for Aldec Active-HDL Lattice Edition (LE).
When you install Active-HDL LE, precompiled libraries are automatically
installed in the Diamond installation directory.

There are no precompiled library files available for ModelSim / Questa. If you
choose to associate your Diamond project with the ModelSim / Questa
simulator in the Simulation Wizard, you need to precompile all of the source
libary files in ModelSim / Questa before using the Simulation wizard.

VHDL and Verilog library source files are also installed in the cae_library
directory. These source files are always installed, whether or not you install
Active-HDL LE.

The sources of some of the library models are not provided, so Lattice
delivers them as black-boxes. This means for those models, Lattice provides
either precompiled libraries (ModelSim / Questa) or encrypted HDL sources
(Riviera Pro, NCSim, and VCS). For further details, refer to “Referencing
Black-Box Models” on page 327.

Verilog Source Library Files The Verilog functional and behavioral
simulation library files are installed with the Diamond software in the locations
shown in the following table.

Table 15: Verilog Functional and Behavioral Simulation Library File
Locations

FPGA Family Library Location
ECP5U/UM <install_dir>/cae_library/simulation/verilog/ecp5u
LatticeeC <install_dir>/cae_library/simulation/verilog/ec
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Table 15: Verilog Functional and Behavioral Simulation Library File

Locations
FPGA Family
LatticeECP
LatticeECP2/M
LatticeECP3
LatticeXP
LatticeXP2
LatticeSC
LatticeSCM
MachXO
MachX02

MachXO3L

Platform Manager

Platform Manager2

Library Location
<install_dir>/cae_library/simulation/verilog/ecp
<install_dir>/cae_library/simulation/verilog/ecp2
<install_dir>/cae_library/simulation/verilog/ecp3
<install_dir>/cae_library/simulation/verilog/xp
<install_dir>/cae_library/simulation/verilog/xp2
<install_dir>/cae_library/simulation/verilog/sc
<install_dir>/cae_library/simulation/verilog/scm
<install_dir>/cae_library/simulation/verilog/machxo
<install_dir>/cae_library/simulation/verilog/machxo2
<install_dir>/cae_library/simulation/verilog/machxo3|
<install_dir>/cae_library/simulation/verilog/Iptm

<install_dir>/cae_library/simulation/verilog/Iptm2

VHDL Source Library Files The VHDL functional and behavioral
simulation library files are installed with the Diamond software in the locations
shown in the following table.

Table 16: VHDL Functional and Behavioral Simulation Library File

Locations
FPGA Family
ECP5U/UM
LatticeEC
LatticeECP
LatticeECP2/M
LatticeECP3
LatticeXP
LatticeXP2
LatticeSC
LatticeSCM
MachXO
MachX0O2

MachXO3L

Library Location
<install_dir>/cae_library/simulation/vhdl/ec/ecp5u
<install_dir>/cae_library/simulation/vhdl/ec/src
<install_dir>/cae_library/simulation/vhdl/ecp/src
<install_dir>/cae_library/simulation/vhdl/ecp2/src
<install_dir>/cae_library/simulation/vhdl/ecp3/src
<install_dir>/cae_library/simulation/vhdl/xp/src
<install_dir>/cae_library/simulation/vhdl/xp2/src
<install_dir>/cae_library/simulation/vhdl/sc/src
<install_dir>/cae_library/simulation/vhdl/scm/src
<install_dir>/cae_library/simulation/vhdl/machxo/src
<install_dir>/cae_library/simulation/vhdl/machxo2/src

<install_dir>/cae_library/simulation/vhdl/machxo3|
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Table 16: VHDL Functional and Behavioral Simulation Library File

Locations
FPGA Family

Platform Manager

Platform Manager 2

Library Location

<install_dir>/cae_library/simulation/vhdl/lptm

<install_dir>/cae_library/simulation/vhdl/Iptm2

Compiled Verilog Libraries for Aldec Active-HDL The following table
shows the location of the compiled Verilog simulation libraries for Aldec

Active-HDL.

Table 17: Aldec Active-HDL Compiled Verilog Simulation Libraries

Library Name

ovi_ecp5u/
ovi_ecp5um

ovi_ec
ovi_ecp

ovi_ecp2/
ovi_ecp2m

ovi_ecp3
ovi_machxo
ovi_machxo2
ovi_machxo2

ovi_lptm

ovi_lptm2

ovi_sc/ovi_scm
ovi_xp

ovi_xp2

Directory Tree

<install_dir>/active-hdl/Vlib/ovi_ec5u

<install_dir>/active-hdl/Vlib/ovi_ec
<install_dir>/active-hdl/Vlib/ovi_ecp

<install_dir>/active-hdl/Vlib/ovi_ecp2

<install_dir>/active-hdl/VIib/ovi_ecp3
<install_dir>/active-hdl/Vlib/ovi_machxo
<install_dir>/active-hd|/Vlib/ovi_machxo2
<install_dir>/active-hdl/Vlib/ovi_machxo2

<install_dir>/active-hdl/Vlib/ovi_lptm

<install_dir>/active-hdl/VIib/ovi_lptm2

<install_dir>/active-hdl/Vlib/ovi_sc
<install_dir>/active-hdl/VIib/ovi_xp

<install_dir>/active-hdl/Vlib/ovi_xp2

Files

*V

* Vv
*V

* v

*V
* Vv
*V
*V

*v

* v

*V
*v

* v

Devices

ECP5U/UM

LatticeEC
LatticeECP

LatticeECP2/M

LatticeECP3
MachXO
MachX0O2
MachX02

Platform
Manager

Platform
Manager 2

LatticeSC/M
LatticeXP

LatticeXP2

Compiled VHDL Libraries for Aldec Active-HDL The next table shows
the location of the compiled VHDL simulation libraries for Aldec Active-HDL.

Note

The ECP5U/UM VHDL library is actually a mixed-language (VHDL/Verilog) library that

is suited for use in VHDL designs.
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Table 18: Aldec Active-HDL Compiled VHDL Simulation Libraries

Library Name
ecp5u/ecp5um
ec

ecp
ecp2/ecp2m
ecp3

machxo
machxo2
machxo3l

Iptm

Iptm2

sc/scm
Xp
Xp2

Directory Tree
<install_dir>/active-hdl/Vlib/ecp5u
<install_dir>/active-hdl/Vlib/ec
<install_dir>/active-hd|/Vlib/ecp
<install_dir>/active-hdl/Vlib/ecp2
<install_dir>/active-hdl/VIib/ecp3
<install_dir>/active-hdl/Vlib/machxo
<install_dir>/active-hdl/Vlib/machxo2
<install_dir>/active-hdl/VIib/machxo3l

<install_dir>/active-hdl/Vlib/Iptm

<install_dir>/active-hdl/Vlib/Iptm2

<install_dir>/active-hdl/Vlib/sc
<install_dir>/active-hd|/Vlib/xp

<install_dir>/active-hdl/VIib/xp2

Files
*vhd, *.v
*vhd
*.vhd
*.vhd
*.vhd
*vhd
*vhd
*vhd
*.vhd

*.vhd

*.vhd
* vhd
*.vhd

Devices
ECP5U/UM
LatticeEC
LatticeECP
LatticeECP2/M
LatticeECP3
MachXO
MachX0O2
MachXO3L

Platform
Manager

Platform
Manager 2

LatticeSC/M
LatticeXP

LatticeXP2

Compiled Mixed-Language Libraries for Aldec Active-HDL The next
table shows the location of the compiled mixed-language simulation libraries

for Aldec Active-HDL.

Table 19: Aldec Active-HDL Compiled Mixed-Language Simulation Libraries

pmi_work

<install_dir>/active-hdl/vlib/pmi_work

*V

See Also  “Third-Party Simulators” on page 302

Not device-
specific. These
are for
parameterized
module
Instantiation.

Performing Simulation with Aldec

Riviera Pro

This section explains how to perform simulation with the Aldec Riviera Pro

simulator.
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Creating or Updating Lattice Semiconductor's FPGA Vendor Libraries
Create VHDL or Verilog libraries by following the procedures in this section.

Creating VHDL Libraries If you do not have Lattice Semiconductor's FPGA
VHDL libraries as pre-compiled vendor libraries, the following steps are
required to create them:

1.

Create Lattice Semiconductor's FPGA VHDL libraries:

# create new VHDL libraries
alib ecp5u

alib sc

alib ec

alib xp

alib ecp

alib machxo

alib ecp2

alib xp2

alib ecp3

alib machxo2

alib machxo31l

alib lptm

alib lptm2

amap scm ./sc

amap ecp2m ./ecp2
amap ecp5um ./ecp5u

Note

The VHDL library names are strict.

For each of the above VHDL libraries compile the source files by using the
acom command:

acom -work <library name> -reorder <vhdl lib src folders/
* .vhd

where:

<vhdl 1ib src_folders is the folder containing VHDL source
files for the appropriate Lattice Semiconductor library
<library names.

For the ecp5u library, there is an extra step required. You must also
compile the Verilog source files by using the alog command:

alog -work <library name> <vhdl 1lib src folder>/*.v
where:

<vhdl 1ib src_folders is the folder containing VHDL source
files for the appropriate Lattice Semiconductor library
<library names.

If you want to place the debugging information in the library, use the —dbg
switch. Debugging may slow down simulation.

Set the status of the newly created library as read-only to prevent
accidental overwriting:

setlibrarymode -ro <library name>
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Creating Verilog Libraries If you do not have Lattice Semiconductor's
FPGA Verilog libraries as pre-compiled vendor libraries, the following steps
are required to create them:

1. Create Lattice Semiconductor's FPGA Verilog libraries:

# create new Verilog libraries
alib ovi_ecp5u

alib ovi_sc

alib ovi_ec

alib ovi_xp

alib ovi_xp2

alib ovi_ecp

alib ovi_ecp2

alib ovi_ecp3

alib ovi machxo

alib ovi_machxo2

alib ovi_machxo3l

alib ovi_ lptm

alib ovi lptm2

amap ovi_scm ./ovi_sc

amap ovi_ecp2m ./ovi_ecp2
amap ovi_ecp5um ./ovi_ecp5u

Note

The Verilog library names are not strict, but they conform to Aldec's naming
convention for Verilog vendor libraries.

2. For each of the above Verilog libraries, compile the source files by using
the alog command:

alog -quiet -work <library name> <verilog lib src_folders/
*.v

where <verilog 1ib src_folder> is the folder containing the Verilog
source files for the <1ibrary name> library.

If you want to place the debugging information in the library, use the —dbg
switch. Debugging may slow down simulation.

Note

Ignore the warning messages.

3. Set the status of the newly created library as read-only to prevent
accidental overwriting:

setlibrarymode -ro <library name>

Updating Lattice Semiconductor's Vendor Libraries If you obtained the
updated source code of Lattice Semiconductor's FPGA libraries, you can
update the VHDL libraries, Verilog libraries, or both by using the following
procedure (for each one of the VHDL or Verilog libraries):

1. Using the cd command, navigate to the directory where your vendor
library resides. The vendor libraries are usually located in the
<install_dir>/vlib folder when pre-compiled by Aldec.

2. Setthe library mode to read-write by using the setlibrarymode command:
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setlibrarymode -rw <library names>

3. Compile the source code into the library. Use the acom command for
VHDL source files and the alog command for Verilog source files.

acom -work <library names -reorder <library src folders/
*.vhd

or

alog -quiet -work <library name> <library src folders/*.v

Note

For the ecp5u VHDL library, you must perform both of the above steps.

4. Set the library to the read-only mode to prevent accidental overwriting:

setlibrarymode -ro <library names>

Note

You can enter the commands either in command-line mode or in the graphical
console. Alternatively, you can write a macro that will prepare and compile the
libraries, as follows:

1. Include in the macro the appropriate commands for the libraries that you want
to create or update.

2. Run the runvsimsa script (Linux) or the runvsimsa.bat batch file (Windows)
command with the macro as a command-line argument.

Performing Verilog Simulation Use the procedures described in this
section to perform a Verilog simulation.

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 15:

alib work
alog -v2k -work work <design name>.v <test bench>.v
asim work.<test bench>

Note

If you have a pre-existing work library, you can clear its contents by using the following
command:

adel -1lib work -all

Post-Map and Place-and-Route Gate-Level Simulation Use the
following commands to perform post-map and place-and-route gate-level
simulation:

alib work

alog -quiet -v2k -work work -1 <library name> <design names>.vVO
<test_bench>.v

asim -0O5 +access +rw -L <library name> work.<test bench>

where <library_name> is the FPGA Verilog library to be searched for the low-
level units.
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Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following procedure to perform post-map and place-and-route gate-level
simulation with timing:

1. Addthe sdf annotate line at the top-level test bench:

$sdf annotate ("<design name>.sdf", <instance names,
,<sdf log>, "MAXIMUM") ;

2. Use the following commands to perform the simulation:

alib work

alog -quiet -v2k -work work -1 <library name>

<design name>.vo <test bench>.v

asim -O5 +access +rw -L <Iibrary name> work.<test bench>

Performing VHDL Simulation Use the procedures described in this
section to perform a VHDL simulation.

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 16:

alib work
acom -work work <design name>.vhd <test bench>.vhd
asim -t ps work.<test bench>

Note

If you have a pre-existing work library, you can clear its contents by using the following
command:

adel -1lib work -all

Post-Map and Place-and-Route Gate-Level Simulation Use the following
commands to perform post-map and place-and-route gate-level simulation:

alib work
acom -work work <design name>.vho <test bench>.vhd
asim -t ps -noglitchmsg work.<test benchs>

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following commands to perform post-map and place-and-route gate-level
simulation with timing:

alib work

acom -work work <design name>.vho <test benchs>.vhd
asim -t ps -noglitchmsg -sdfmax

/<instance name>="<design name>.sdf" work.<test benchx>

Note

The “/” character is Aldec’s default hierarchy separator.

See Also  “Third-Party Simulators” on page 302
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Performing Simulation with Aldec
Active-HDL

You can use the same procedure as in “Performing Simulation with Aldec
Riviera Pro” on page 307 for creating or updating Lattice Semiconductor’s
FPGA (vendor) libraries and simulating Verilog or VHDL designs in Active-
HDL with a few modifications. Refer to the Active-HDL On-line Documentation
for more details.

An alternative and easy way recommended for updating the Lattice
Semiconductor FPGA libraries with Active-HDL is to obtain the pre-compiled
Lattice Semiconductor FPGA libraries directly from the following directory:

<Diamond_installation folders/active-hdl/Vl1ib

You can either copy these libraries, along with the Library.cfg file, to your
Active-HDL Vlib folder, overwriting any old libraries, or you can modify the
Active-HDL Vlib/Library.cfg file to map to the Lattice Semiconductor FPGA
libraries installed with Diamond (you can instead perform the mapping with
the amap command).

Running Aldec Active-HDL in Stand-Alone Mode If you are running
Active-HDL in stand-alone mode—that is, you are not accessing it through the
Diamond graphical user interface—you should do the following to avoid
elaboration (ELBREAD) errors when selecting top-level unit or compiling files
from the design pop-up menu:

1. From the top-level menu, select Design > Settings.

2. Under Category in the left pane of the Design Settings dialog box, select
General > Compilation > Verilog.

3. Inthe right (Verilog) pane under Verilog libraries, click the Add Library

4. Select the reference Verilog libraries that are needed in your design. You
can select multiple libraries by holding the CTRL key.

5. Click OK.
6. Click OK in the Design Settings dialog box.

This design setting also adds the -I <verilog_library _name> option to the viog
command, then it recognizes (or allows you to set) the top-level unit.

After setting the top-level unit (or testbench), you can start the simulation by
clicking Simulation > Initialize Simulation from the top-level menu.

Note

If you are compiling and simulating your design by using a .do file, the steps just given
are not needed. Instead, you should add -l with vlog, add -L with vsim, or both in your
.do file.
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If you are running Active-HDL in stand-alone mode and you are using at least
one of the ASIC blocks, such as PCS or SYSBUS, in your design, you must
do the following:

1. Change the directory to the design folder, that is, where the PCS or
SYSBUS configuration file resides:

cd <design folder>
2. Set the simulation directory to the design (current) folder:

set SIM WORKING_ FOLDER .

Setting the SIM_WORKING_FOLDER option forces the Active-HDL simulator
to look for the configuration or input files in the design folder (by default
Active-HDL looks for input files in the <work> and <work>/src folders only,
where <work> is the Active-HDL working library folder). If you do not set this
option, the simulation will fail and Active-HDL will issue an error about a
missing configuration file.

This option is also necessary if your simulation is expecting any input files in
the design folder rather than in the <work> or <work>/src folders, unless you
place the input file path in your HDL code.

See Also  “Third-Party Simulators” on page 302

Performing Simulation with Cadence
NC-Verilog

This section explains how to perform simulation with Cadence NC-Verilog.

Setting Lattice Semiconductor Libraries Before simulating Lattice
Semiconductor FPGA designs in the Cadence NC-Verilog simulator, you must
perform the following steps to specify the Lattice Semiconductor simulation
libraries.

Creating Library Definition Files Before using the NC-Verilog simulator to
simulate your design project, you must first create two library definition files
named hdl.var and cds.lib in your project folder. The hdl.var and cds.lib files
define which libraries are accessible and where they are located. The hdl.var
file contains optional statements that can be used to define variables such as
the default work library, and the cds.lib file contains statements that map
logical library names to their physical directory paths.

For example, your local hdl.var file may include the following:

DEFINE work work

Your local cds.lib file can include the following:

DEFINE ecp5u vlog <compile dirs/ecp5u_vlog
DEFINE ecp5um vlog <compile dirs/ecp5u_vlog
DEFINE ec_vlog <compile dirs/ec_vlog
DEFINE ecp vlog <compile dir>/ecp vlog
DEFINE ecp2 vlog <compile dir>/ecp2 vlog
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DEFINE ecp2m vlog <compile dir>/ecp2 vlog
DEFINE ecp3_vlog <compile dir>/ecp3 vlog
DEFINE xp vlog <compile dirs/xp_vlog

DEFINE xp2 vlog <compile dir>/xp2 vlog

DEFINE machxo vlog <compile dirs/machxo_vlog
DEFINE machxo2 vlog <compile dir>/machxo2 vlog
DEFINE machxo31l vlog <compile dirs/machxo3l vlog
DEFINE lptm vlog <compile dir>/lptm vlog
DEFINE lptm2 vlog <compile dirs>/lptm2 vlog
DEFINE sc_vlog <compile dir>/sc_vlog

DEFINE scm_vlog <compile dirs/sc_vlog

DEFINE work ./work

Note

<compile_dir> refers to the location of the compiled device libraries.

Cadence provides a utility called NCLaunch to set up the necessary
initialization files and to compile the Verilog source libraries. NCLaunch is
available as part of the 2.1 and later releases. Otherwise, setting up the
initialization files and compiling the Verilog source libraries is a manual
process.

You can create the hdl.var and cds.lib files with any text editor. You must map
the physical locations to the logical names before proceeding to the next step.
On the Linux platform, you can create these names by using the mkdir
command as follows:

mkdir -p <compile dir>/ecp5u_vlog
mkdir -p <compile dir>/ec_vlog
mkdir -p <compile dir>/ecp_vlog
mkdir -p <compile dir>/ecp2 vlog
mkdir -p <compile dir>/ecp3_vlog
mkdir -p <compile dir>/xp_vlog
mkdir -p <compile dir>/xp2_ vlog
mkdir -p <compile dir>/machxo vlog
mkdir -p <compile dir>/machxo2 vlog
mkdir -p <compile dir>/machxo3l vlog
mkdir -p <compile dir>/lptm vlog
mkdir -p <compile dir>/lptm2_vlog
mkdir -p <compile dir>/sc_vlog

If you want the logical library names to be available for all designs, use
INCLUDE or SOFTINCLUDE in the location of your master hdl.var and cds.lib
files.

For example, you can add the following line to your master cds.lib file:

INCLUDE Spath/cds.lib

Note

The path variable specifies the location of your own cds.lib file.

Or, you can directly include the library definitions in the master hdl.var and
cds.lib files.
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Now the master hdl.var and cds.lib files include the Lattice Semiconductor
library definitions. The next time that you want to simulate Lattice
Semiconductor designs in the NC-Verilog simulator, you do not need to create
you own hdl.var and cds.lib files again.

Parsing and Analyzing Lattice Semiconductor Simulation Libraries
After creating your own hdl.var and cds.lib files, you must parse and analyze
the Lattice Semiconductor simulation libraries by using the NC-Verilog
simulator. These libraries must be parsed and analyzed only once.

To parse and analyze Lattice Semiconductor Verilog simulation libraries, run
the following commands in the NC-Verilog simulator:

ECP5U Verilog:

ncvlog -messages -work ecp5u vlog
$Diamond install path/cae library/simulation/verilog/ecp5u/
* v

LatticeEC Verilog:

ncvlog -messages -work ec_vlog
$Diamond install path/cae_library/simulation/verilog/ec/*.v

LatticeECP Verilog:

ncvlog -messages -work ecp vlog
$Diamond install path/cae library/simulation/verilog/ecp/*.v

LatticeECP2 Verilog:

ncvlog -messages -work ecp2 vlog
$Diamond install path/cae library/simulation/verilog/ecp2/
* v

LatticeECP3 Verilog:

ncvlog -messages -work ecp3_vlog
$Diamond install path/cae_library/simulation/verilog/ecp3/
* .V

LatticeXP Verilog:

ncvlog -messages -work xp vlog
$Diamond install path/cae_library/simulation/verilog/xp/*.v

LatticeXP2 Verilog:

ncvlog -messages -work xp2 vlog
$Diamond install path/cae_library/simulation/verilog/xp2/*.v

MachXO Verilog:

ncvlog -messages -work machxo vlog
$Diamond install path/cae library/simulation/verilog/machxo/
* v

MachXO2 Verilog:

ncvlog -messages -work machxo2 vlog
$Diamond install path/cae_library/simulation/verilog/
machxo2/*.v

MachXO3L Verilog:

ncvlog -messages -work machxo3l vlog
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$Diamond install path/cae library/simulation/verilog/
machxo31l/*.v

Platform Manager Verilog:

ncvlog -messages -work lptm vlog
$Diamond install path/cae_ library/simulation/verilog/lptm/
* v

Platform Manager 2 Verilog:

ncvlog -messages -work lptm2 vlog
$Diamond install path/cae library/simulation/verilog/lptm2/
* v

LatticeSC Verilog:

ncvlog -messages -work sc_vlog
$Diamond install path/cae_library/simulation/verilog/sc/*.v

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 15:

rm -rf work

mkdir work

ncvlog -work work <design name>.v <test_bench>.v
ncelab -1ib binding -access +rwc work.<test benchs>
ncsim -GUI work.<test bench>

Note

If you are using NCSim version 5.4 or older, remove the —lib_binding option from the
ncelab command.

Post-Map and Place-and-Route Gate-Level Simulation Use the following
commands to perform post-map and place-and-route gate-level simulation:

rm -rf work

mkdir work

ncvlog -work work <design name>.vo <test bench>.v
ncelab -1lib_binding -access +rwc work.<test_ bench>
ncsim -GUI work.<test bench>

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following procedure to perform post-map and place-and-route gate-level
simulation with timing:

1. Add the sdf _annotate line at the top-level test bench:
$sdf annotate ("<design name>.sdf", <design name>,
,<sdf log>, "MAXIMUM") ;

2. Use the following commands to perform the simulation:

rm -rf work

mkdir work

ncvlog -work work <design name>.vo <test bench>.v
ncelab -1ib binding -access +rwc work.<test benchs>
ncsim -GUI work.<test bench>

See Also  “Third-Party Simulators” on page 302
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Performing Simulation with Cadence
NC-VHDL

This section explains how to perform simulation with Cadence NC-VHDL.

Setting Lattice Semiconductor Libraries Before simulating Lattice
Semiconductor FPGA designs in the Cadence NC-VHDL simulator, you must
perform the following steps to set the Lattice Semiconductor simulation
libraries.

Creating Library Definition Files Before using the Cadence NC-VHDL
simulator to simulate your design project, you must first create two library
definition files named hdl.var and cds.lib in your project folder. The hdl.var and
cds.lib files define which libraries are accessible and where they are located.
The hdl.var file contains optional statements that can be used to define
variables such as the default work library, and the cds.lib file contains
statements that map logical library names to their physical directory paths.

For example, your local hdl.var file can include the following:

DEFINE work work

Your local cds.lib file may include the following:

DEFINE ecp5u <compile dirs/ecp5u_vhdl
DEFINE ecp5um <compile dirs/ecp5u vhdl
DEFINE ec <compile dirs>/ec_vhdl

DEFINE ecp <compile dirs/ecp vhdl

DEFINE ecp2 <compile dirs>/ecp2 vhdl
DEFINE ecp2m <compile dirs/ecp2 vhdl
DEFINE ecp3 <compile dirs>/ecp3_vhdl
DEFINE xp <compile dir>/xp vhdl

DEFINE xp2 <compile dirs/xp2 vhdl

DEFINE machxo <compile dirs/machxo_vhdl
DEFINE machxo2 <compile dirs/machxo2 vhdl
DEFINE machxo31l <compile_dir>/machx03l_vhdl
DEFINE lptm <compile dirs>/lptm vhdl
DEFINE lptm2 <compile dir>/lptm2_ vhdl
DEFINE sc <compile dirs>/sc_vhdl

DEFINE scm <compile dirs>/sc_vhdl

DEFINE work ./work

Note

<compile_dir> refers to the location of the compiled device libraries.

Cadence provides a utility called NCLaunch to set up the necessary
initialization files and to compile the VHDL source libraries. NCLaunch is
available as part of the 2.1 and later releases. Otherwise, setting up the
initialization files and compiling the VHDL source libraries is a manual
process.

You can create the hdl.var and cds.lib files with any text editor. You must map
the physical locations to the logical names before you proceed to the next
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step. On the Linux platform, you can create these names by using the mkdir
command as follows:

mkdir -p <compile dir>/ecp5u_vhdl
mkdir -p <compile dir>/ec_vhdl
mkdir -p <compile dir>/ecp vhdl
mkdir -p <compile dir>/ecp2_ vhdl
mkdir -p <compile dir>/ecp3_vhdl
mkdir -p <compile dir>/xp_vhdl
mkdir -p <compile dir>/xp2 vhdl
mkdir -p <compile dir>/machxo_ vhdl
mkdir -p <compile dir>/machxo2 vhdl
mkdir -p <compile dirs/machxo31l vhdl
mkdir -p <compile dir>/lptm vhdl
mkdir -p <compile dir>/lptm2_vhdl
mkdir -p <compile dir>/sc_vhdl

If you want the logical library names to be available for all designs, use
INCLUDE or SOFTINCLUDE in the location of your master hdl.var and cds.lib
files.

For example, you can add the following line to your master cds.lib file:

INCLUDE Spath/cds.lib

Note

The path variable specifies the location of your own cds.lib file.

Or, you can directly include the library definitions in the master hdl.var and
cds.lib files.

Now the master hdl.var and cds.lib files include the Lattice Semiconductor
library definitions. The next time that you want to simulate Lattice
Semiconductor designs in the NC-VHDL simulator, you do not need to create
you own hdl.var and cds.lib files again.

In addition to defining Lattice Semiconductor VHDL libraries, you must map
the vital2000 logical library to the IEEE library location by adding the following
line to your cds.lib file:

DEFINE vital2000 <NC VHDL Libraries_Folder>/IEEE

Note

The <NC_VHDL _libraries_folder> variable specifies the folder containing the NC-
VHDL libraries.

Parsing and Analyzing Lattice Semiconductor Simulation Libraries
After creating your own hdl.var and cds.lib files, you must parse and analyze
the Lattice Semiconductor simulation libraries by using the NC-VHDL
simulator. These libraries must be parsed and analyzed only once.

To parse and analyze Lattice Semiconductor VHDL simulation libraries, run
the following commands in NC-VHDL simulator.

Lattice Diamond 3.6 Help

318



SIMULATING THE DESIGN : Third-Party Simulators

ECP5U VHDL:

ncvhdl -messages -work ecp5u -smartorder
$Diamond install path/cae library/simulation/vhdl/ecp5u/src/
* . vhd

ncvlog -messages -work ecp5u $Diamond install path/
cae_library/simulation/vhdl/ecp5u/src/*.v

LatticeEC VHDL:

ncvhdl -messages -work ec -smartorder
$Diamond install path/cae library/simulation/vhdl/ec/src/
* . vhd

LatticeECP VHDL:

ncvhdl -messages -work ecp -smartorder
$Diamond install path/cae_library/simulation/vhdl/ecp/src/
*.vhd

LatticeECP2 VHDL:

ncvhdl -messages -work ecp2 -smartorder
$Diamond install path/cae library/simulation/vhdl/ecp2/src/
* . vhd

LatticeECP3 VHDL:

ncvhdl -messages -work ecp3 -smartorder
$Diamond install path/cae_library/simulation/vhdl/ecp3/src/
*.vhd

LatticeXP VHDL.:

ncvhdl -messages -work xp -smartorder
$Diamond install path/cae library/simulation/vhdl/xp/src/
* . vhd

LatticeXP2 VHDL:

ncvhdl -messages -work xp2 -smartorder
$Diamond install path/cae_library/simulation/vhdl/xp2/src/
*.vhd

MachXO VHDL:

ncvhdl -messages -work machxo -smartorder
$Diamond install path/cae library/simulation/vhdl/machxo/
src/*.vhd

MachXO2 VHDL:

ncvhdl -messages -work machxo2 -smartorder
$Diamond install path/cae_library/simulation/vhdl/machxo2/
src/*.vhd

MachXO3L VHDL:

ncvhdl -messages -work machxo3l -smartorder
$Diamond install path/cae library/simulation/vhdl/machxo31/
src/*.vhd

Platform Manager VHDL:

ncvhdl -messages -work lptm -smartorder
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$Diamond install path/cae library/simulation/vhdl/lptm/src/
* . vhd

Platform Manager 2 VHDL.:

ncvhdl -messages -work lptm2 -smartorder
$Diamond install path/cae_ library/simulation/vhdl/lptm2/src/
*.vhd

LatticeSC VHDL:

ncvhdl -messages -work sc -smartorder
$Diamond install path/cae library/simulation/vhdl/sc/src/
* . vhd

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 2:

rm -rf work

mkdir work

ncvhdl -work work <design name>.vhd <test benchs>.vhd
ncelab -1ib_binding -access +rwc work.<test_bench>
ncsim -GUI work.<test bench>

Note

If you are using NCSim version 5.4 or older, remove the —lib_binding option from the
ncelab command.

If you receive warning messages during compilation, see “Warning Messages
Caused by Std_Logic Declarations” on page 321.

Post-Map and Place-and-Route Gate-Level Simulation Use the following
commands to perform post-map and place-and-route gate-level simulation:

rm -rf work

mkdir work

ncvhdl -work work <design name>.vho <test bench>.vhd
ncelab -1ib binding -access +rwc work.<test benchs>
ncsim -GUI work.<test benchs>

If you receive warning messages during compilation, see “Warning Messages
Caused by Std_Logic Declarations” on page 321.

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following procedure to perform post-map and place-and-route gate-level
simulation with timing:

1. Compile the SDF file:
ncsdfc <design name>.sdf
This command generates the compiled SDF file, <design_name>.sdf.X.

2. Create an <sdf_cmd> file with the following contents:

COMPILED_SDF_FILE = “<design name>.sdf.X”, SCOPE =
:<instance name>,
LOG_FILE = “<sdf_log>”, MTM_CONTROL = "MAXIMUM";

3. Use the following commands to perform the simulation:
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rm -rf work

mkdir work

ncvhdl -work work <design name>.vho <test bench>.vhd
ncelab -1lib binding -access +rwc -sdf cmd file <sdf cmd>
work.<test bench>

ncsim -GUI work.<test benchs>

If you receive warning messages during compilation, see “Warning Messages
Caused by Std_Logic Declarations” on page 321.

Warning Messages Caused by Std_Logic Declarations When you set
vital_levell as an attribute for the architecture, Cadence NC-VHDL issues
several warning messages during compilation about an unapproved type in
the vital2000 library models. These messages are caused by Cadence NC-
VHDL's strict interpretion of std_logic signal declarations in the architecture as
signal types. You can make this interpretation less strict by using the following
option:

ncvhdl -relax
This option does not affect the actual simulation.

See Also  “Third-Party Simulators” on page 302

Performing Mixed-Language (Verilog
and VHDL) Simulation with Cadence
NCSim

The steps involved in performing Verilog/VHDL mixed-language simulation
with Cadence NCSim are straightforward and use most of the information
provided in the previous two sections (“Simulation Library Files” on page 304
and “Performing Simulation with Cadence NC-VHDL” on page 317):

1. Set up your local cds.lib and hdl.var files to include all the libraries that
you use in your design. Each library can be Verilog only, VHDL only, or a
mixed-language library containing both VHDL entities and Verilog
modules. The libraries can be Lattice Semiconductor FPGA libraries,
protected libraries (for example, special-block or IP libraries), or your own
design libraries.

2. Compile your Verilog files, using the ncvlog command.
3. Compile your VHDL files, using the ncvhdl command.

4. Elaborate the top-level unit (or test bench) in your mixed-language design,
using the ncelab command.

5. Simulate the top-level unit (or test bench), using the ncsim command.
Following is an example of the procedure used for simulating a mixed-

language design that consists of your own VHDL design files, the LatticeSC
VHDL source files, and the Lattice PCSA encrypted Verilog module:
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1. Compile the LatticeSC VHDL source files into the LatticeSC VHLD library,
as explained in “Performing Simulation with Cadence NC-VHDL” on
page 317.

2. Compile the Lattice PCSA encrypted Verilog source file into the same
LatticeSC VHDL library as follows:

ncvlog -messages -work sc <install dirs/cae library/
simulation/blackbox/pcsa-ncv.vp

3. Create a local folder for the work library:
mkdir work

4. Add the following lines to your local hdl.var file:
DEFINE WORK work

5. Add the following lines to your local cds.lib:

DEFINE sc <Path to NCSim-compiled SC VHDL lib>
DEFINE work ./work

6. Compile your VHDL design and test bench files:
ncvhdl <design names>.vhd <test benchs>.vhd
7. Elaborate your top-level unit (test bench):
ncelab -1lib binding -NOMXINDR -access +rwc <test bench>

The —~NOMXINDR option is added to ncelab to avoid MXINDR errors. This
option is necessary for mixed-language designs.

8. Simulate your test bench:

ncsim -GUI <test bench>

Performing Simulation with Mentor
Graphics ModelSim / Questa

This section explains how to perform simulation with the Mentor Graphics
ModelSim / Questa simulator.

Setting Lattice Semiconductor Libraries Before simulating Lattice

Semiconductor FPGA designs in the Mentor Graphics ModelSim / Questa
simulator, you must compile the Lattice Semiconductor simulation libraries
using the cmpl_libs command available from the Diamond's TCL console.

For details about using this command, refer to “Simulation Libraries
Compilation Tcl Command” on page 2430.

To enable Diamond’s batch interface to ModelSim / Questa, change the
default simulation tool setup and directory reference as follows:

1. Choose Options > Environment Options.

2. Click on the Directories tab.
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3. Change the path setting to the ModelSim / Questa executable on the tab
to the new version.

4. Click OK.

Mapping to ModelSim / Questa Libraries The library compilation target
folder should also be your simulation working directory. Otherwise, you need
to copy the library mappings from modelsim.ini at the target folder (or the file
itself) into your local or master modelsim.ini.

After running simulation libraries compilation using the cmpl_libs TCL
command, a modelsim.ini file will be created at the target folder chosen for the
compiled libraries. That file will have the proper mappings for these compiled
libraries.

Performing Verilog Simulation Use the procedures described in this
section to perform a Verilog standalone simulation with ModelSim / Questa.

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 15:

vlib work
vlog -work work <design names.v <test bench>.v
vsim work.<test bench>

Note

If you have a pre-existing work library, you can clear its contents by using the following
command:

vdel -1ib work -all

Post-Map and Place-and-Route Gate-Level Simulation  Use the
following commands to perform post-map and place-and-route gate-level
simulation:

vlib work
vlog -work work <design name>.vo <test bench>.v
vsim -L <library name> work.<test bench>

where <library_name> is the FPGA Verilog library to be searched for the low-
level units.

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following procedure to perform post-map and place-and-route gate-level
simulation with timing:

1. Addthe sdf annotate line at the top-level test bench:

$sdf annotate ("<design name>.sdf", <instance name>,
,<sdf log>, "MAXIMUM" ) ;

2. Use the following commands to perform the simulation:

vlib work
vlog -work work <design name>.vo <test bench>.v
vsim -L <Ilibrary name> work.<test bench>
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Performing VHDL Simulation Use the procedures described in this
section to perform a VHDL standalone simulation with ModelSim / Questa.

Functional RTL Simulation Use the following commands to perform a
functional RTL simulation with one of the libraries shown in Table 16:

vlib work
vcom -work work <design names.vhd <test benchs>.vhd
vsim -t ps work.<test benchs>

Note

If you have a pre-existing work library, you can clear its contents by using the following
command:

vdel -1lib work -all

Post-Map and Place-and-Route Gate-Level Simulation Use the following
commands to perform post-map and place-and-route gate-level simulation:

vlib work
vcom -work work <design name>.vho <test bench>.vhd
vsim -t ps +no_glitch msg work.<test bench>

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following commands to perform post-map and place-and-route gate-level
simulation with timing:

vlib work

vcom -work work <design names.vho <test bench>.vhd
vsim -t ps +no_glitch msg -sdfmax

<instance name>="<design name>.sdf" work.<test_ bench>

See Also  “Third-Party Simulators” on page 302

Performing Simulation with Synopsys
VCS

This section explains how to perform simulation with Synopsys VCS for
Verilog-only designs.

For VHDL designs, refer to “Performing Mixed-Language (Verilog and VHDL)
Simulation with Synopsys VCS-MX” on page 325.

For SystemVerilog designs, refer to “Performing Mixed-Language (Verilog
and SystemVerilog) Simulation with Synopsys VCS-MX” on page 326.

Functional RTL Simulation Use the following vcs command to perform a
functional RTL simulation with one of the libraries shown in Table 15:

vces -RI <design name>.v <test bench>.v
-y <Lattice verilog library location> +libext+.v +v2k
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Post-Map and Place-and-Route Gate-Level Simulation Use the following
vcs command to perform post-map and place-and-route gate-level simulation:

ves -RI <design name>.vo <test bench>.vo
-y <Lattice verilog library location> +libext+.v +v2k

Post-Map and Place-and-Route Gate-Level Simulation with Timing Use
the following procedure to perform post-map and place-and-route gate-level
simulation with timing:

1. Addthe sdf annotate line at the top-level test bench:

$sdf annotate ("<design name>.sdf", <instance name>,
,<sdf log>, "MAXIMUM") ;

2. Use the following ves command to perform the simulation:

ves -RI <design name>.vo <test benchs>.v
-y <Lattice verilog library location> +libext+.v +v2k

See Also  “Third-Party Simulators” on page 302

Performing Mixed-Language (Verilog
and VHDL) Simulation with Synopsys
VCS-MX

In order to run mixed-language simulation with VCS, you must have a special
license for VCS-MX. Contact Synopsys if you do not have one.

“Performing Simulation with Synopsys VCS” on page 324 describes how to
simulate a Verilog-only design by simply using the vcs command. In order to
simulate a VHDL-only or a Verilog/VHDL mixed-language design, extra steps
are required (with extra commands). In general, if your design contains VHDL
source code, you must analyze it by using the vhdlan utility. And, if your VHDL
design instantiates a Verilog design within it, you must use the vlogan utility.
Mixed-language designs are categorized into either VHDL-top or Verilog-top
designs, where each one has its own procedure for running the simulation
with VCS-MX tools. For more details, refer to the VCS MX/VCS MXi User
Guide.

Following is an example of the procedure used for simulating a Verilog/VHDL
mixed-language design that consists of your own VHDL design files, the
ECP5U VHDL library source files, and the ECP5U black boxes encrypted
Verilog source file.

1. Create local folders for the ECP5U VHDL and the work libraries:
mkdir ecp5u vhdl work

2. Create (or modify) your local synopsys_sim.setup file, and add the
following lines:

WORK > DEFAULT
DEFAULT : ./work
ECP5U: ./ecp5u_vhdl
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3. Analyze the ECP5U VHDL library:

vhdlan -work ECP5U <ecp5u vhdl src folder>/ECP5UCOMP.vhd \
<ecp5u_vhdl src_ folder>/ECP5U_SEQ.vhd \
<ecp5u_vhdl src_ folders/ECP5U IO.vhd \
<ecp5u_vhdl src_ folders/ORCA_CMB.vhd \
<ecp5u_vhdl src folder>/ORCA_MEM.vhd \
<ecp5u_vhdl src_ folder>/ORCA_MISC.vhd \
<ecp5u_vhdl src folder>/ORCA_LUT.vhd \
<ecp5u_vhdl src folder>/gsr pur_ assign.vhd

vlogan -work ECP5U <ecp5u vhdl src folders/*.v

vhdlan -work ECP5U <ecp5u vhdl src_ folders/ECP5U_SL.vhd

where <ecp5u_vhdl src_ folder> refers to <install_dir>/cae_library/
simulation/vhdl/ecp5u/src.

4. Analyze the Lattice black box modules from the encrypted Verilog source
as follows:

vlogan -work ECP5U <install dir>/cae library/simulation/
blackbox/ecp5u_black boxes-vcs.vp

5. Analyze your VHDL design and test bench files:
vhdlan <design names.vhd <test bench>.vhd

6. Compile the simulation executable from your top-level unit (test bench):
scs -mhdl <test bench>

7. Simulate your test bench by running the simulation executable:

scsim

See Also  “Third-Party Simulators” on page 302

Performing Mixed-Language (Verilog
and SystemVerilog) Simulation with
Synopsys VCS-MX

In order to run mixed-language simulation with VCS, you must have a special
license for VCS-MX. Contact Synopsys if you do not have one.

“Performing Simulation with Synopsys VCS” on page 324 describes how to
simulate a Verilog-only design by simply using the vcs command. In order to
simulate a Verilog/SystemVerilog mixed-language design, extra steps are
required. In general, if your design contains SystemVerilog code, then you
need first to compile the Lattice library sources and/or encrypted modules
using the vlogan utility. For more details about running mixed-language
designs, refer to the VCS MX/VCS MXi User Guide.

Following is an example of the procedure used for simulating a Verilog/
SystemVerilog mixed-language design that consists of your own
SystemVerilog design files, modules from the MachXO2 Verilog source files
and the machxo2_black boxes encrypted Verilog source file.
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1. Create local folder for the work library:
mkdir work

2. Create (or modify) your local synopsys_sim.setup file, and add the
following lines:

WORK > DEFAULT
DEFAULT : ./work

3. Analyze the machxo2_black boxes modules from their encrypted Verilog
source file as follows:

vlogan +v2k <install dirs/cae library/simulation/blackbox/
machxo2_black_boxes-vcs.vp

4. Compile your SystemVerilog files and simulate your design with top-level
unit (test bench):

vcs -mhdl -RI <design name>.v <test_bench>.v -y
<install dir>/cae_ library/simulation/Verilog/machxo2
+libext+.v

See Also  “Third-Party Simulators” on page 302

Referencing Black-Box Models

Some high-value models, such as ECP5UM DCU, are not distributed as HDL
open source. In these cases, either HDL encrypted sources or pre-compiled

libraries are provided for the respective simulator. By default, Diamond installs
archives for each encrypted or pre-compiled model in the following directory:

<install dir>\cae_library\simulation\blackbox
For older devices (LatticeSC, LatticeEC, LatticeECP, LatticeECP2,
LatticeECP3, LatticeXP, LatticeXP2, Platform Manager and MachXO), each

file or folder name indicates the model and simulator supported using the
following format:

<model>[-aldec|-ncv|-ves].vp | folder <models/

where:
<model> is the name of the Verilog simulation model.

-aldec indicates that the model is provided as encrypted Verilog source
for the Aldec Riviera Pro simulator. These models can also be compiled
for Aldec Active-HDL simulator, but it is recommended to use the Lattice-
provided pre-compiled libraries for Aldec Active-HDL simulator.

-ncv indicates that the model is provided as encrypted Verilog source for
the Cadence NCSim simulator.

-ves indicates that the model is provided as encrypted Verilog source for
the Synopsys VCS simulator.

<mode1>/ is a folder indicating that the model is available as a pre-
compiled library for the Mentor Graphics ModelSim / Questa simulator.
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For example, the file JTAGA-vcs.vp contains the JTAGA encrypted Verilog
model for Synopsys VCS.

For newer devices (ECP5U, MachX02, MachXO3L and Platform Manager 2),
all the black-box models for each device family are contained in a single .vp
file or a single folder for each simulator, in the following format:

<device>_black boxes[-aldec|-ncv|-ves].vp | folder
<device>_ black boxes/

Some Verilog models are pre-compiled or encrypted differently for VHDL.
Those models will have the following format:
[<model>|<device> black boxes] vhdlib[-aldec|-ncv|-ves].vp |

folder [<models|<device> black boxes] vhdlib/

If the models are supplied as encrypted Verilog models, you must compile
them with other source files for the same device into the same library (both
Verilog and VHDL) for the respective simulator. Refer to each respective
section for each third-party simulator in “Third-Party Simulators” on page 302.

For ModelSim / Questa pre-compiled libraries, if you have a higher version of
ModelSim / Questa simulator, you need to refresh the library as follows:

vlog -refresh -work <library namex>

For VCS encrypted sources, make sure you compile the files for Verilog, but
not for SystemVerilog. For example, use the +v2k option.

If a README file is provided, examine it in each archive file for any further
compilation instructions.

See Also  “Third-Party Simulators” on page 302

Using the Global Set/Reset (GSR) Signal

Lattice FPGA device simulation models provide the Global Set/Reset
Interface (GSR) signal for use with all Lattice FPGAs.

Details regarding the architecture of global signals are described in the data
sheet for each device family on the Lattice Web site.

For more information on the GSR library element, see “FPGA Libraries
Reference Guide” on page 1571.

For more information on GSR and RTL Functional Simulation, see “RTL
Functional Simulation and the GSR Resource” on page 1118.

For more information on how to use the GSR signal, see “How to Use the
Global Set/Reset (GSR) Signal” on page 1113.
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Creating Waveform Test Stimulus

Creating Waveform Test Stimulus

Once you have completed your design (or a module of the design), you will
want to test it to confirm that it behaves the way you expect it to. Simulation
requires a test stimulus file that specifies the input waveforms.

You can graphically create a waveform test stimulus file with the Waveform
Editor. You see exactly what each waveform will look like, as well as its timing
relationship to all the other waveforms.

The Waveform Editor window consists of two panes. The left-hand Waveform
Editing area is used for graphically creating and editing waveforms. The right-
hand pane includes three views for setting pulse/waveform properties and
using patterns.

The following design flow illustrates how you would typically create a stimulus
file with the Waveform Editor.

1. Create a waveform file (.wdl).

2. Set Time Unit for the simulation.

3. Select the signals for which you want to define stimuli.

4. Draw the stimulus for each input.
5

Export the waveform information to a stimulus file.

Creating a Waveform File

You can create a new waveform file (.wdl) in Lattice Diamond.

To create a new .wdl file:
1. Inthe Diamond window, choose File > New > File.
2. Inthe New File dialog box, do the following:
Under Source Files, select WaveForm Files.
Specify the file name and location.

Select Add to project if you want to include the new file in the current
project directory.

Select an implementation name from the Implementation name drop-
down list.

Click New.

The Waveform Editor opens with a blank window.

Setting Simulation Time Unit

You can select the Time Unit for the simulation database. In the simulation
stimulus file, stimulus values are specified at intervals of the specified Time
Unit.
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All stimulus events occur at, and have lengths of, integral multiples of the
Time Unit. This feature makes it easier to draw waveforms because all
Transitions are automatically forced to occur at multiples of the Time Unit.

Note

A long Simulation Time combined with short Time Units may require an excessive
amount of computer resources. Be sure you have selected duration values appropriate
for your design before you begin simulation.

To set simulation time unit:
1. Inthe Waveform Editor, choose Edit > Timing Settings.
The Time Settings dialog box opens.

2. Select the time units you want and click OK.

Creating Waveforms
Before drawing waveforms in the Waveform Editor, you may need to specify
time unit for the simulation. See “Setting Simulation Time Unit” on page 329.

If you make an error when creating waveforms, choose Edit > Undo. The
Waveform Editor allows you to perform an unlimited number of Undos and
Redos until you save the file.

To create a waveform:

1. Be sure you are in the Edit mode. If not, choose Edit > Edit Mode or click
the 1.# icon on the toolbar to switch to the Edit mode.

2. At the bottom of the right-hand pane, click the Pulse tab to display the
Pulse Properties view.

Note

If the Pulse tab is not available, choose View > Pulse Properties View to display
it.

3. Choose Edit > New Wave.
The Add New Wave dialog box opens.
4. In the dialog box, do the following:
Type a name for the new wave in the Wave Name box.
Select the polarity for the new waveform.
Click Add.

The new waveform name is displayed in the Waveform Editing area.
The letter behind the waveform name indicates its polarity. “I” stands
for Input, “O” for Output, “B” for Bidirectional, “T” for Test Point, and
“G” for Global. A pattern name begins with a dollar sign ($).
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You may keep the dialog box open and continue to add more
waveform names. When you finish, click Close.

5. Inthe Waveform Editing area, click the new waveform name to highlight it.

6. Move the mouse to the waveform section of the window and click where
you want the first Transition. (You must click inside the area next to the
highlighted name.)

A blue line is drawn showing the first section (called a Pulse) of the
waveform. You can also see two black horizontal lines above and below
the new pulse, indicating it is currently selected.

7. Keep the pulse selected. Then do the following in the Pulse Properties
view.

In the State box, select a state for the selected pulse and press Enter.

If you are adding a bus pulse, you can select Set Value in the State
box, and then enter the value in the Value box below it. The value
entered in the Value box must be in hexadecimal format.

In the Duration box, enter a time value.

You don’t have to enter the time unit. The Waveform Editor
automatically appends the time unit specified in the Time Settings
dialog box to the time value. To apply a different time unit, see “Setting
Simulation Time Unit” on page 329.

8. In the Waveform Editing area, click again to create the second Transition.
The pulse drawn has the opposite state of the first pulse.

9. Set the properties for the second pulse.

10. Continue clicking and setting properties to complete the waveform.

11. Choose File > Save File to save the new waveform.

Note

The commands on the View menu allow you to zoom in and zoom out on the
waveforms, to view them in more or less detail.

Creating Bus Waveforms

You can create bus waveforms in the Waveform Editor. Bus waveforms can
be expanded to separate waveforms in the Waveform Editing area.

Bus waveform pulses are displayed as elongated hexagons, as shown below.

Figure 47:

(+)a[012]1k000)< 001 o }
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Tip
You can double-click the plus sign before a bus name to display the individual

waveforms included in the bus. However, you cannot edit those individual waveforms.
You can only edit the bus waveform.

To create a bus waveform:

1. Be sure you are in the Edit mode. If not, choose Edit > Edit Mode or click
the 1.~ icon on the toolbar to switch to the Edit mode.

2. At the bottom of the right-hand pane, click the Pulse tab to display the
Pulse Properties view.

Note

If the Pulse tab is not available, choose View > Pulse Properties View to display
it.

3. Choose Edit > New Wave.
The Add New Wave dialog box opens.

4. In the Wave Name box, enter the bus name by adding a bit range to the
name. See the following examples:

A[0:2], which you can expand to A[0], A[1], and A[2].
A, B, C, D, which you can expand to A, B, C, and D.
[Al1...A3], which you can expand to A1, A2, and A3.
5. Select Polarity for the new bus waveform.
6. Click Add and then Close.

The new bus name is displayed in the Waveform Editing area. You can
double-click the plus sign before the bus name to expand the bus.

7. Click the new bus name to highlight it.

8. Move the mouse to the waveform section of the window and click where
you want the first Transition. (You must click inside the area next to the
highlighted name.)

A bus pulse is drawn showing the first section of the bus waveform. You
can also see two black horizontal lines above and below the bus pulse,
indicating it is currently selected.

9. Keep the pulse selected. Then do the following in the Pulse Properties
view.

In the State box, select Don’t Care or High-Z, or select Set Value and
then enter the bus value in the Value box below it. The value entered
in the Value box must be in hexadecimal format.

Bus pulses can have any value that can be represented by the
number of bits in the bus. For example, any pulse in an eight-bit bus
waveform can be assigned a value between 0 and 255. Bus pulses
are given default values, in sequential order: 0, 1, 2, 3, and so on. You
can change any of these values at any time.
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The format of the bus value displayed in the Waveform Editing area is
set by the Bus Radix option in the Options dialog box. To select a
different Bus Radix format, see “Changing the Waveform Display
Options” on page 345.

In the Duration box, enter a time value.

You don’t have to enter the time unit. The Waveform Editor
automatically appends the time unit specified in the Time Settings
dialog box to the time value. To apply a different time unit, see “Setting
Simulation Time Unit” on page 329.

10. In the Waveform Editing area, click again to create the second Transition,
and set the properties for the second bus pulse.

11. Continue clicking and setting properties to complete the bus waveform.

12. Choose File > Save File to save the new bus waveform.

Note

The commands on the View menu allow you to zoom in and zoom out on the
waveforms, to view them in more or less detail.

Creating and Using Patterns

You may find yourself drawing the same waveform over and over again. The
Waveform Editor allows you to name and define arbitrary waveforms, called
Patterns, which you can then add to or insert in any other waveform. After a
pattern is inserted to another waveform, it becomes a series of pulses, and
loses its identity as a pattern. When you modify a pattern, the waveforms that
use that pattern will not change.

A pattern name begins with a dollar sign ($). Patterns normally represent
single-bit data. You can create a bus pattern by adding a bit range to the
name, as shown below:

$buspat[7:0]

Bus patterns cannot be added to single-bit waveforms, or vice versa. Also, the
number of bits in a bus pattern must match the number of bits in the bus
waveform to which it is added.

To add a pattern name in the Waveform Editor:

1. Inthe Waveform Editor, choose Edit > New Wave.
The Add New Wave dialog box opens.

2. Inthe Polarity drop-down box, select Pattern.

3. Inthe Wave Name box, type a name for the pattern. The name should
begin with a dollar sign ($). If you do not include a dollar sign, the
Waveform Editor automatically adds one.
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5.

Click Add to add the pattern’s name to the Waveform Editing area. The
dialog box remains open, so you can continue to add pattern names
without having to reselect the command.

Click Close.

You can then draw the waveform for your pattern.

To draw a pattern:

1.

Be sure you are in the Edit mode. If not, choose Edit > Edit Mode or click
the 1.7 icon on the toolbar to switch to the Edit mode.

At the bottom of the right-hand pane, click the Pulse tab to display the
Pulse Properties view.

Note

If the Pulse tab is not available, choose View > Pulse Properties View to display
it.

In the Waveform Editing area, highlight the pattern name for which you
want to create a waveform.

Move the mouse to the waveform section and click where you want the
first Transition. (You must click inside the area next to the highlighted
name.)

A blue line is drawn showing the first section (called a Pulse) of the
waveform. You can also see two black horizontal lines above and below
the new pulse, indicating it is currently selected.

Keep the pulse selected. Then do the following in the Pulse Properties
view.

In the State box, select a state for the selected pulse and press Enter.

If you are adding a bus pulse, you can select Set Value in the State
box, and then enter the value in the Value box below it. The value
entered in the Value box must be in hexadecimal format.

In the Duration box, enter a time value.

You don’t have to enter the time unit. The Waveform Editor
automatically appends the time unit specified in the Time Settings
dialog box to the time value. To apply a different time unit, see “Setting
Simulation Time Unit” on page 329.

In the Waveform Editing area, click again to create the second Transition.
The pulse drawn has the opposite state of the first pulse.

Set the properties fro the second pulse.

Continue clicking and setting properties to complete the waveform.

Choose File > Save File to save the new pattern.

Once the pattern is drawn, you can add it to a waveform or another pattern.
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To add a pattern to a waveform or another pattern:

1. Be sure you are in the Edit mode. If not, choose Edit > Edit Mode or click
1

the icon on the toolbar to switch to the Edit mode.

2. At the bottom of the right-hand pane, click the Pattern tab to display the
Pattern view.

The Pattern List box lists all the patterns defined in the current waveform
file in alphabetical order.
Note

If the Pattern tab is not available, choose View > Pattern View to display it.

3. Inthe Waveform Editing area, select the pulse where you want to insert
the pattern.

4. In the Pattern view, select the name of the pattern you want to add and
click Insert.

The pattern is inserted before the selected pulse.

You can also use the Copy command on the Edit menu to copy a pattern to
the clipboard, and then use the Paste command to insert it in another
waveform. The pattern, however, is inserted only as a series of pulses, and
loses its identity as a pattern.

Importing Signal Names from a NAF File

A NAF file is an intermediate file generated by the Generate Schematic
Symbol command in the Hierarchy view. It is a text file that lists signal names
and types in design modules. A typical NAF file looks like the following:

c[2] o
c[1l] o
c[0] o
clk i
rst 1

ExtTrigOutPort0 o

Importing signal names from a NAF file is much quicker than adding
waveform names one by one using the Edit > New Wave command.

Note

For detailed information on how to run Generate Schematic Symbol in the Hierarchy
view, see “Creating a Symbol from an HDL Module” on page 264.

To import signal names from a NAF file:
1. Inthe Waveform Editor, select Edit > Import Wave.

The Import Wave dialog box opens.
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2. Click Browse to display the Open Existing Waveform File dialog box.
3. Select a .naf file and click Open.

All the signals contained in the .naf file are then listed in the Imported
Wave box. You can narrow the list by using the Filter options on the left.

Next you will add signal names to the Selected Wave box. Only the names
listed in the Selected Wave box will be added to the waveform display.

4. In the Imported Wave box, click to highlight the signal names that you
want to import. You can use the Shift or Ctrl key to highlight multiple
names.

5. Click > to add the highlighted signal names to the Selected Wave box.
Tip
You can use the four arrow buttons in the middle to add or remove signal names in
the Selected Wave box.

> — Adds the signal names highlighted in the Imported Wave box to the Selected
Wave box.

>> — Adds all the signal names in the Imported Wave box to the Selected Wave
box.

< — Deletes the signal names highlighted in the Selected Wave box.

<< — Clears all signal names from the Selected Wave box.

6. Click OK. The signal names in the Selected Wave box are added to the
waveform display.

After adding signal names, you can then start drawing waveforms for them.
See “Creating Waveforms” on page 330 for detailed information on how to
draw waveforms.

Adding Test Points

You can add waveforms for internal nodes (that is, nets that do not have
external connections or I/O markers) in the Waveform Editor window. These
internal nodes are called test points.

Test points can be used to “force” internal nodes to specific values during
simulation. However, not all simulators support this function. Check your
simulator documentation to see if you can define arbitrary values for internal
nodes.

To add a test points from the Waveform Editor:
1. Inthe Waveform Editor, choose Edit > New Wave.
The Add New Wave dialog box opens.
2. Inthe Wave Name box, type the name of the test point.
3. Inthe Polarity box, select Test Pt.
4. Click Add to add the test point to the Waveform Editing area.
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After adding the Test Points, you can then start drawing waveforms for them.
See “Creating Waveforms” on page 330 for detailed information on how to
draw waveforms.

Selecting Waveforms or Pulses

You can select waveforms or pulses (a Pulse is a section of a waveform
between two Transitions) in the Edit operatio] smnode. If you are not in the Edit
mode, choose Edit > Edit Mode or click the icon on the toolbar to switch
to the Edit mode.

To select a waveform:

Click the name of the waveform you want to select.

To select pulses:
To select a single pulse, click anywhere within a pulse.

To select multiple successive pulses, drag the cursor across the waveform
to cover several pulses.

The selected pulse(s) will be marked with thick black lines above and
below it.

Graphically Changing the Length of a
Pulse

In the Waveform Editor, a section of a waveform between two Transitions is
called a Pulse. You can graphically change the length of any pulse. The
length of a pulse can also be changed by specifying the pulse duration in the
Pulse Properties view. See “Setting Pulse State and Duration” on page 338
for details.

To change the length of a pulse graphically:
1. Click the pulse you want to lengthen or shorten.

The pulse becomes selected, marked with thick black lines above and
below it.

2. Click and hold down the mouse button on the selected pulse.

The selected pulse and its preceding or succeeding pulse (depending on
where you click) both change to dotted lines.

3. Drag the mouse to the left or right to change the length of the pulse.

If you select the last pulse in a waveform, dragging changes the length
of that pulse and extends or shortens the waveform.

If you select a pulse within the waveform, dragging alters the start or
ending time of the Transition. The preceding or succeeding pulse is
lengthened and the selected pulse shortened (or vice versa). The total
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length of both pulses (and of the complete waveform) does not
change.

If you press and hold Shift before you click a pulse, dragging only
changes the length of the selected pulse. The preceding or
succeeding pulse lengths do not change. Any pulses to the left or right
of the selected pulse are moved (without modification) to
accommodate the lengthened or shortened pulse. Use this mode to
adjust a pulse without changing anything else in the waveform.

Remember that pulses always have a length that is an integral multiple of the
Time Units selected in the Timing Settings dialog box.

Setting Pulse Properties

In the Waveform Editor, a section of a waveform between two Transitions is
called a Pulse. You can use the Pulse Properties view to change pulse
properties, including state, duration, scaling, and repeat options.

To display the Pulse Properties view, click the Pulse tab at the bottom of the
right-hand pane. If the Pulse tab is not displayed, choose View > Pulse
Properties View.

Note

You cannot select a pulse or change pulse properties for individual waveforms
included in a bus. However, you can select pulses on a bus waveform and change
pulse properties.

Setting Pulse State and Duration

Before setting pulse state and duration, make sure you are in the Edit
operation mode. If not, choose Edit > Edit Mode or click the 1.# icon on the
toolbar to switch to the Edit mode.

To change the state of a pulse:

1. Inthe Waveform Editor, select a pulse by clicking anywhere within the
pulse.

2. Inthe Pulse Properties view, select the desired state in the State box. If
you are working with a bus pulse, you can select Set Value in the State
box, and then enter the value in the Value box below it. The value entered
in the Value box must be in hexadecimal format.

Changing a pulse from Low to High or High to Low effectively removes it
from the waveform, since it now has the same value as the pulses on
either side.

To change the duration of a pulse:

1. Inthe Waveform Editor, select a pulse by clicking anywhere within the
pulse.
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2. Inthe Pulse Properties view, click inside the Duration edit box and type a
time value.

You don’t have to enter the time unit. The Waveform Editor automatically
appends the time unit specified in the Time Settings dialog box to the time
value. To apply a different time unit, see “Setting Simulation Time Unit” on
page 329.

Repeating Pulses

You can use the Pulse Properties view to repeat successive pulses in a
waveform. The pulses at the end of a waveform can be repeated forever in
the Waveform Editor.

Note

A single pulse cannot be repeated. To repeat pulses, you must select more than
two successive pulses.

Pattern pulses cannot be repeated forever.

To repeat pulses:

1. Be sure you are in the Edit operation mode. If not, choose Edit > Edit
Mode or click the 1.# icon on the toolbar to switch to the Edit mode.

2. Inthe Waveform Editing area, select the pulses that you want to repeat by
dragging the cursor across the waveform to cover several successive
pulses. The selected pulses are marked with thick black lines above and
below them.

3. Inthe Pulse Properties view, do either of the following:

In the Repeat edit box, type any integer larger than 1, and then press
Enter.

The selected pulses are repeated by the specified multiple.

If the selected pulses are located at the end of a waveform, you can
select Forever to repeat the selected pulses forever.

Note

The simulation time for the Repeat Forever waveform can be controlled by the run
time or conditional settings in a simulator.

Scaling Patterns and Waveforms

You can use the Pulse Properties view to make any pattern, pulse(s), or an
entire waveform longer by scaling it.

To scale patterns and waveforms:

1. Be sure you are in the Edit operation mode. If not, choose Edit > Edit
Mode or click the 1.7 icon on the toolbar to switch to the Edit mode.
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2. Inthe Waveform Editing area, select the pulse(s) that you want to scale by
clicking anywhere within the pulse or dragging the cursor across the
waveform to cover several successive pulses. The selected pulses are
marked with thick black lines above and below them.

If you want to scale an entire pattern or waveform, select all its pulses.
In the Pulse Properties view, click inside the Scale edit box.
4. Type any integer larger than 1, and press Enter.

The length of the selection is multiplied by this value. (A pulse is multiplied
only if it is not part of a Repeat Forever waveform.)

If a complete waveform contains a pattern, that pattern is scaled along
with the rest of the waveform. (The original definition of the pattern is
unaffected by the scaling.)

See Also “Selecting Waveforms or Pulses” on page 337

“Graphically Changing the Length of a Pulse” on page 337

Setting Waveform Polarity and Offset

The Waveform Properties view allows you to change waveform polarity and
add an offset at the beginning of a waveform.

You cannot change waveform polarity or offset for patterns.

To display the Waveform Properties view, click the Waveform tab at the
bottom of the right-hand pane. If the Waveform tab is not displayed, choose
View > Waveform Properties View.

Note

You cannot change waveform properties for individual waveforms included in a bus.
However, you can set properties for the bus waveform.

To set waveform properties:

1. Inthe Waveform Editing area, select the waveform name for which you
want to change properties.

The Waveform Properties view displays the waveform details in the Wave
Data box, including the state and duration for each pulse in the selected
waveform.

2. Inthe Waveform Properties view, do the following:

To change polarity for the selected waveform, select a different
polarity in the Polarity box.

The letter behind the waveform name changes to indicate the updated
polarity.

To add an offset at the beginning of the waveform, enter the offset
value in the Offset box. The offset value must be a number greater
than O.
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The waveform shifts to the right if the offset value was increased or to
the left if the offset value was decreased.

Deleting, Cutting, Copying, Pasting, and
Duplicating Pulses or Waveforms

Pulses or waveforms that can be selected (a single pulse, multiple successive
pulses, or the entire waveform) can be deleted, cut, or copied to the clipboard
for pasting elsewhere.

To delete, cut, or copy pulses or waveforms:
1. Select the waveform or pulse(s) that you want to edit.
2. Do any of the following:

Choose Edit > Clear.

The selected waveform or pulse(s) is removed, but is not copied to the
clipboard.

Choose Edit > Remove Wave.

The Remove Waves dialog box opens. In the Wave List, select one or
more waveforms to be deleted and click Remove. You can use the
Shift or Ctrl key to select multiple waveforms or select and remove
them one at a time.

To cut a waveform or pulse(s), choose Edit > Cut.

The selected waveform or pulse(s) is removed, and is copied to the
clipboard.

To copy a waveform or pulse(s), choose Edit > Copy.

The selected waveform or pulse(s) is copied to the clipboard without
being removed.

To paste the copied waveform or pulse(s) into the current waveform:
1. Select a single pulse, multiple successive pulses, or an entire waveform.
2. Choose Edit > Paste.

The data in the Clipboard will replace the selected waveform or pulse(s).

To duplicate a waveform:

1. Select the waveform name that you want to duplicate.

2. Choose Edit > Duplicate Wave.
The software adds an exact copy of the selected waveform to the display,
and adds “_0" to the waveform name.

See Also “Selecting Waveforms or Pulses” on page 337
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Saving Waveforms

The first time you save a waveform file, the Waveform Editor creates a
project.wdl file. The .wdl file contains the waveforms in WDL (waveform
description language) format. You can use the Save As command to save the
file under a different base name to create multiple stimulus files for a single
project.

Caution

You can perform an unlimited number of Undos and Redos until you save the file. At
that point, the files are updated and all Undo/Redo information is lost. Do not save the
file if there are still changes you want to Undo or Redo.

The Waveform Editor can automatically save the file you are working on. You
can use the Options dialog box to select an auto-save option.

To set auto-save options:

1. In the Diamond window, choose Tools > Options.
The Options dialog box opens.

2. Inthe left-hand pane, select Waveform Editor.

3. Inthe right-hand pane, under Auto Save, select 1 Minute, 5 Minutes, or
10 Minutes to let the system automatically save your file every 1, 5, or 10
minutes. Or select Never Save to cancel the auto-save function.

4. Click OK.

Showing Waveforms

Sometimes waveforms have been hidden from view. You can restore the view
of hidden waveforms using the Show command.

To show a hidden waveform in the Waveform Editor:
1. Choose Edit > Show Wave.

The Show Waves dialog box opens. The Wave List box displays all the
available signals. You can use the Filter options on the left to narrow the
signal list.

2. Inthe Wave List, select the name of the signal you want to show. You can
use the Shift or Ctrl key to select multiple signal names.

3. Click Show.

The software restores the view of the selected waveform.
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Hiding Waveforms

If you decide not to display a particular waveform, you can temporarily hide it
without deleting it from the Waveform Editor database.

To hide a waveform:

1. In the waveform Editing area, select the name of the waveform you want
to hide.

The Waveform Editor highlights the waveform name.
2. Choose Edit > Hide Wave.

The Hide Wave command hides the highlighted waveform name and its
waveform.

Viewing Waveform and Pulse Properties
When you are in the Edit mode, you can select a waveform or a pulse in the
Waveform Editing area and view its properties.

Pulse properties like pulse state, duration, and scale are displayed in the
Pulse Properties view. Waveform data, polarity, and offset are displayed in the
Waveform Properties view.

To view pulse information in the Pulse Properties view:

1. Make sure you are in the Edit mode. If not, choose Edit > Edit Mode or
click the 1. icon on the toolbar to switch to the Edit mode.

2. At the bottom of the right-hand pane, click the Pulse tab to display the
Pulse Properties view.

Note
If the Pulse tab is not available, choose View > Pulse Properties View to display
it.

3. Inthe Waveform Editing area, select a pulse.

The selected pulse is marked with thick black lines above and below it.
The pulse information will appear in the Pulse Properties view.

To view waveform data in the Waveform Properties view:

1. Atthe bottom of the right-hand pane, click the Waveform tab to display
the Waveform Properties view.

Note

If the Waveform tab is not available, choose View > Waveform Properties View
to display it.

2. Inthe Waveform Editing area, select any waveform name on the left.
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The selected waveform name is highlighted. The waveform data will
appear in the Waveform Properties view.

Using a Marker

A marker is a red vertical line on the waveform time line. It is useful as a
reference point to query the simulation data.

To place a marker:

1. Inthe Waveform Editing area, click the place on the time line where you
want to insert a marker. You can use the Jump to commands on the View
menu to locate the exact place.

A query bar (a black vertical line) appears.
2. Choose View > Place Marker.

A marker is inserted at the current location of the query bar. You may not
see the red marker because it is covered by the black query bar. Click
anywhere else to move the query bar, and then you will see the red
marker.

To move the query bar to the marker:

1. Inthe Waveform Editing area, click anywhere on the time line to position a
query bar.

2. Choose View > Jump to > Marker.
The query bar is re-positioned at the marker.

This is useful when you are displaying the time line at high magnification
and you would have to press the Left or Right keys many times to return to
the marker.

To hide a marker:
In the Waveform Editor, choose View > Hide Marker.

The marker is removed from the waveform display.

Positioning the Query Bar with the
Jump to Commands

A query bar is a black vertical line on the waveform time line used to query the
simulation data. You can use the Jump to commands on the View menu to
position the query bar to a specific time.

To position a query bar:

1. Inthe Waveform Editing area, click anywhere on the time line to display a
query bar.
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Table 20:

2. Choose View > Jump to, and then select the required command to

position the query bar to the specific time.

The below table describes each Jump to command in detail.

Command Name Description

Next Change

Marker

Time...

Time=0

Time=End

Tick Left

Tick Right

10 Left

10 Right

Moves the query bar to the next transition in the currently selected signal.
If the currently selected signal is a bus, the query bar moves to the next
transition of any signal in the bus.

This command is typically used to traverse the simulation data. Starting at
a primary input (which is the most common activity initiator), you can jump
from one initiating event to another. You can find later events on other
signals that result from the changes on the primary input.

Positions the query bar at the marker. The principal use of this command
is simply to return the query bar to the marker. This is especially useful
when you are displaying the time line at high magnification and you would

have to press Shift+Left or Shift+Right many times to return to the marker.

For information on how to place a marker, see Figure on page 344.

Opens a dialog box that allows you to move the query bar to a specified
time.

Moves the query bar to time=0. This is the left-most point on the time axis
of the waveform.

Moves the query bar to the last time point of the simulation. This is the
right-most point on the time axis of the waveform.

Moves the query bar one tick mark to the left (“backwards” in time). The
interval between tick marks changes as you change the time scale with
the Zoom commands.

Moves the query bar one tick mark to the right (“forward” in time). The
interval between tick marks changes as you change the time scale with
the Zoom commands.

Moves the query bar one major tick mark to the left (“backwards” in time).
The interval between tick marks changes as you change the time scale
with the Zoom commands.

Moves the query bar one major tick mark to the right (“forward” in time).
The interval between tick marks changes as you change the time scale
with the Zoom commands.

Keyboard Shortcut

+

Home

End

Left

Right

Shift+Left

Shift+Right

Changing the Waveform Display

Options

You can use the Options dialog box to control the following waveform display

options.

Bus Radix — Controls how bus values are displayed in the Waveform

Editor.
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Show Grid Lines — Shows or hides grid lines in the Waveform Editor.

Color — Specifies the Waveform Editor color scheme.

To change the waveform display options:

1.

In the Diamond window, choose Tools > Options.
The Options dialog box opens.
In the left-hand pane, under Waveform Editor, select General.

In the right-hand pane, specify the Bus Radix and Show Grid Lines
options as you want.

In the left-hand pane, under Waveform Editor, select Color.
The current color settings are shown in the right-hand pane.

Click on the current color to open the Select Color dialog box, select the
desired color, and click OK.

Click OK to apply your settings and close the Options dialog box.

Exporting the Stimulus File

The Waveform Editor saves the waveforms you create in it as a .wdl file. You
can export (create) a Verilog (.tf) or VHDL (.vht or .tb) stimulus file from a .wdl
file at any time. The Waveform Editor translates the waveform database in the
.wdl file into the stimulus format in the appropriate output files. You can then
use the exported stimulus file to simulate your design in a simulator.

To export the stimulus file:

1.
2.

3.

In the Waveform Editor, choose File > Export.
In the Export Waveform File dialog box, do the following:

Click Browse to specify the existing .wdl file which includes the
waveform information you want to export.

Click Browse to specify the name and location of the output file.

In the Export Type box, select an export format. This appends the
appropriate file extension to the output file.

Click OK.

The Waveform Editor exports the stimulus file to the specified location.
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Chapter 6

Applying Design Constraints

Constraints are instructions applied to design elements to guide the design
toward desired results and performance goals. They are critical to achieving
timing closure or managing reusable intellectual property (IP). The most
common constraints are those for timing and pin assignment, but constraints
are also available for placement, routing, and many other functions.

Constraints can include timing constraints defined in synthesis constraint files
(SDC) or HDL attributes. SDC is used for the synthesis tool. Post-synthesis
constraints known as preferences can also be specified. The flow combines
these together. All three sources of constraints specify design goals.
Synthesis, map, and place-and-route work to meet these goals. Timing
analysis reports whether or not the goals were met.
See Also »“Constraints Reference Guide” on page 1133

“Multiple Entry Constraint Flow” on page 348

“Using Preferences” on page 362

“Setting Preferences” on page 442

“Migrating Pin Assignments” on page 468

“Integrated Synthesis” on page 567

“Achieving Timing Closure” on page 555

“Lattice Synthesis Engine (LSE) Constraints” on page 1272
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Multiple Entry Constraint Flow

Constraints from mutiple sources can be used and modified in Lattice
Diamond in multiple ways, such as: timing constraints from SDC or LDC
synthesis files; constraints defined in HDL source files; or with post-synthesis
constraints known as logical preferences that are defined in the logical
preference file (.Ipf).

You can set constraints using one or more of the following methods:

You can assign HDL attributes in the HDL or schematic source files. After
synthesis and translation, these defined attributes can be viewed and
modified in Diamond’s preference views, and the modifications can be
saved to the logical preference file.

If you are using the Lattice Synthesis Engine, you can assign SDC
constraints using the Lattice Design Constraints (LDC) Editor and save
them to an .Idc constraints file. If you are using Synplify Pro, you can
assign SDC constraints using the SCOPE editor tool and save them to an
.sdc file.

You can apply SDC constraints added in Diamond by enabling the new
“Use LPF Created from SDC in Project” strategy option. Refer to “Using
SDC Constraints in Place and Route” on page 352.

You can assign logical preferences in the logical preference file (.Ipf) using
a text editor or Diamond’s preference-editing views: Device View,
Spreadsheet View, Package View, Netlist View, NCD View, and Floorplan
View.

You can use Spreadsheet View to modify timing constraints that have
been defined in Synplify Pro or Lattice Synthesis Engine (LSE) and save
the modified constraints as preferences to the active .Ipf file.

The constraints entered from multiple entry points are resolved in the
Diamond software. Refer to “Resolving SDC Constraints with Other
Constraints from Multiple Flow” on page 353.

The following figure shows a high-level flow of how constraints from mutiple
sources can be used and modified in Lattice Diamond.
See Also »“Constraints Reference Guide” on page 1133

“Using SDC Constraints” on page 351

“Using Preferences” on page 362

“Adding FPGA Attributes to HDL” on page 553

Constraint Implementation

The following steps illustrate how you might assign constraints and implement
them at each stage of the design flow, using synthesis constraints, logical
preferences and timing analysis.

1. Define the constraints in the pre-synthesis stage using one or both of the
following methods:
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Figure 48:
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Define constraints as attributes within the HDL or schematic model.

Define timing constraints using Synplify Pro or Lattice Synthesis
Engine (LSE).

Synthesize and translate the design.

When Synplify Pro is used, the synthesis process translates the design
into an EDIF netlist. Run the Translate Design process to translate the
EDIF netlist into a binary logical native generic database (.ngd) file, which
will contain all HDL attributes.

When LSE is used, the synthesis process both synthesizes the design
and translates it into an .ngd file.

The synthesis process writes timing constraints that were defined in
Synplify Pro or LSE to a synthesis .Ipf file in the project directory. The
synthesis .Ipf will not appear in Diamond, but the timing constraints will be
displayed in Diamond’s Spreadsheet View and color-coded as synthesis
values.

Open one or more of the following views to define new constraints, called
preferences, or to modify existing constraints from the source files and
save them as preferences:

Spreadsheet View — Modify timing constraints that were defined in the
synthesis tool and save them as logical preferences to the active.lpf file.
Set timing objectives such as fMAX and 1/O timing. Define signaling
standards and make pin assignments. Assign clocks to primary or
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secondary routing resources. Set parameters for simultaneous switching
outputs and perform SSO analysis. Define groups of ports, cells, or ASIC
blocks. Create UGROUPSs from selected instances to guide placement
and routing. Establish REGIONs for UGROUPs or to reserve areas of the
floorplan. Run PIO design rule checking.

Device View — Examine FPGA device resources. Reserve sites that
should be excluded from placement and routing.

Netlist View — View the design tree by ports, instances, and nets. Assign
pins for selected signals. Set timing constraints. Define groups from
selected ports or registers. Create UGROUPs from selected instances to
guide placement and routing.

Package View — View the pin layout of the design. Modify signal
assignments and reserve pin sites that should be excluded from
placement and routing. Examine the status of SSO pins. Run PIO design
rule checking.

Floorplan View — View the device layout. Draw bounding boxes for
UGROUPs. Draw REGIONSs for the assignment of groups or to reserve
areas. Reserve sites and REGIONSs that should be excluded from
placement and routing. Run PIO design rule checking.

Save the preferences to the logical preference file (.Ipf).
Run the Map Design process (map).

This process reads the .ngd and .Ipf files and produces a native circuit
description (.ncd) file and a physical preference (.prf) file. The .prf file is
derived from preference-related .ngd attributes and the .Ipf file. Non-
preference-related .ngd attributes are written directly into the .ncd file.

The .prf file is an internal file generated by the Map engine that contains
preferences used by the PAR engine. It should not be edited, because the
changes will be lost when it is regenerated.

Run the Map TRACE process and examine the timing analysis report.
Modify preferences as needed and save them.

Run the Place & Route Design process (par).

This process reads the post-MAP .ncd file and the .prf file, and appends
placement and routing to a post-PAR .ncd file.

Open one of the following views, as desired, to examine timing and
placement and create new UGROUPs.

Timing Analysis View — Examine details of timing paths. Cross-probe
selected paths to Floorplan and Physical Views. Create one or more
timing preference files (.tpf) and experiment with sets of modified
preferences for the purpose of timing analysis, using the TPF
Spreadsheet View. Select and export the desired timing preferences from
TPF Spreadsheet View to the regular Spreadsheet View. From
Spreadsheet View, save the timing preferences to the .Ipf file.

NCD View — Examine placement assignments. Create new UGROUPs,
as needed, from selected instances.

Cross-probe to Logic Block View from NCD View, Floorplan View, or
Physical View, to view logic details of a selected component.
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10. Modify preferences or create new ones using any of the preference-
editing views. Save the preference changes and rerun the Place & Route
Design process.

11. Repeat Steps 3 through 10 until timing objectives are met.
You can repeat the flow using a new implementation of your design with a

different set of preferences. See “Working with Run Manager” on page 85 and
“Managing Project Sources” on page 33.

Note

Refer to Importing ispLEVER Projects to ensure the compatibility of designs that use
the ispLEVER constraint data flow.

See Also »“Preference Flow” on page 364
“Preference-Editing Views and Memory” on page 392
“Using Diamond’s Preference Views” on page 391
“Analyzing Static Timing” on page 683
“Achieving Timing Closure” on page 555

Using SDC Constraints

You can enter constraints in the synthesis design constraints (SDC) file using
one of the following two synthesis tools:

Lattice Synthesis Engine (LSE) LDC Editor

For more information about entering constraints with LDC Editor, refer to
“Applying Lattice Synthesis Engine Constraints” on page 353.

Synplify Pro SCOPE Constraints Editor

For more information about entering constraints with Synplify Pro SCOPE
Constraints Editor, in the Synplify Pro online help, refer to “SCOPE
Constraints Editor” help.

During synthesis, a read-only logical preference file (.Ipf) is generated, which
can be included and specified as the active preference file in your Diamond
project.
The following Synopsis Design Constraints can be set in the SDC.:
“create_clock” on page 1274
“create_generated_clock” on page 1276
“set_clock_groups” on page 1277
“set_false_path” on page 1278
“set_input_delay” on page 1279

“set_max_delay” on page 1280
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“set_min_delay” on page 1280
“set_multicycle_path” on page 1281
“set_output_delay” on page 1281

For more information about these constraints, refer to “Synopsys Design
Constraints (SDC)” on page 1272.

Constraints entered from multiple entry points are resolved in the Diamond
software. Refer to “Resolving SDC Constraints with Other Constraints from
Multiple Flow” on page 353.

See Also »“Using SDC Constraints in Place and Route” on page 352

“Conflicting HDL Attributes, Constraints, and Preferences” on page 386

“Using Diamond’s Preference Views” on page 391

Using SDC Constraints in Place and
Route

When you chose the “Use LPF Created from SDC in Project” strategy setting,
constraints set in Lattice Synthesis Engine (LSE) LDC Editor or Synplify Pro
SCOPE Constraints Editor will be applied during the Diamond software Place
& Route process.

To use SDC constraints in Place & Route

1. Specify “Use LPF Created from SDC in Project” in your project’s strategy.
Refer to “Specifying Strategy Options” on page 51.
Note

Refer to the “Strategy Reference Guide” on page 1053 for more information about
LSE and Synplify Pro versions of the “Use LPF Created from SDC in Project”
strategy.

2. Run the Synthesize the Design process. Refer to “Running Processes” on
page 69.

3. Set the new LPF file as the active file. Refer to “Managing Constraint
Files” on page 40.

4. Run the Place & Route Design process. Refer to “Running Processes” on
page 69.

See Also »“Using SDC Constraints” on page 351
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Resolving SDC Constraints with Other
Constraints from Multiple Flow

When you have multiple sources of constraints, the Diamond software follows
specific rules to resolve conflicting constraints. Refer to “Preference Conflict
Resolution” on page 379.

See Also  “Multiple Entry Constraint Flow” on page 348

Applying Lattice Synthesis Engine
Constraints

Diamond'’s Lattice Synthesis Engine (LSE) enables you to set Synopsys®
Design Constraints (SDC), which are directly interpreted by the synthesis
engine. When you use LSE, these SDC constraints are saved to a Lattice
Design Constraints file (.Idc). You can create several .Idc files and select one
of them to serve as the active synthesis constraint file for an implementation.
You can also cause a synthesis preference file to be generated when the
design is synthesized. The synthesis preferences can then be merged with
the logical preference file (.Ipf).

Lattice Design Constraints (LDC) Editor, as well as Source Editor, are
available for creating and editing .Idc files. LDC Editor provides a spreadsheet
style user interface that enables you to quickly create and edit Synopsys
Design Constraints.

See “Synopsys Design Constraints (SDC)” on page 1272 for descriptions of
the SDC constraints that are supported by the Lattice Synthesis Engine and
LDC Editor.

See Also »“Defining Synthesis Constraints Using LDC Editor” on page 353
“Creating a New LDC Synthesis Constraint File” on page 354
“Integrated Synthesis” on page 567
“Optimizing LSE for Area and Speed” on page 565

Defining Synthesis Constraints Using LDC Editor

LDC Editor presents the contents of a Lattice Design Constraints File (.Idc) in
a spreadsheet style format. You can use LDC Editor to open and edit a
current .Idc file or create a new one. Individual sheets are provided for
defining clocks, setting input and output delays, and defining delay paths for
multicycle, minimum and maximum delays, and false paths.

By default, LDC Editor is launched when you create a new .Idc file. Each
sheet of LDC Editor allows you to define synthesis constraints by double-
clicking a cell and selecting or typing a value.
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Each row includes an Enabled check box, which is selected by default. If you
clear this check box, the constraint is ignored by LSE. This can be an easy
way to test different settings.
See Also »“Creating a New LDC Synthesis Constraint File” on page 354
“Defining Clocks Using LDC Editor” on page 356
“Setting Input and Output Delays Using LDC Editor” on page 357
“Defining Delay Paths Using LDC Editor” on page 358
“Defining Clock Groups in LDC Editor” on page 358
“Defining Generated Clocks in LDC Editor” on page 359
“Setting Attributes in LDC Editor” on page 359
“Generating a Synthesis Preference File” on page 361

“Synopsys Design Constraints (SDC)” on page 1272

Running LDC Editor

Run LDC Editor by opening or creating an .Idc file for an implementation.

Note

In order to open or create an .ldc file, LSE must be the selected synthesis tool for
the project. Choose Project > Synthesis Tools and select Lattice LSE.

You can have multiple .Idc files for an implementation, but only one can be
opened in LDC Editor at a time.

To run LDC Editor, do one of the following:

Double-click an .ldc file name in the Synthesis Constraints Files folder in
the File List view.

If you have set Source Editor to be the default program for .Idc files, right-
click the .Idc file name in the File List view and choose Open With. In the
Open With dialog box, choose LDC Editor and click OK.

If no .Idc file exists yet for the active implementation, create an .ldc file as
described in Creating a New LDC Synthesis Constraint File.

See Also »“Managing Constraint Files” on page 40

“Using Source Editor for LDC Files” on page 360

Creating a New LDC Synthesis Constraint File
Before you create a new .Idc file, verify that Lattice Synthesis Engine has
been selected as the synthesis tool. In the Processes tab, “Lattice Synthesis
Engine” should be listed under “Synthesize Design.” If it is not listed, choose
Project > Synthesis Tool, and select Lattice LSE.
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To make sure that the LDC file opens in LDC Editor instead of Source Editor,
verify that LDC Editor has been selected as the default program in Tool >
Options > Environment > File Associations.

To create a new .ldc synthesis constraint file:
1. Choose File > New > File.

Alternatively, right-click the Synthesis Constraint Files folder and
choose Add > New File.

2. Inthe New File dialog box, select Source Files from the Categories list.
Select £* LDC Files from the Source Files list.

3. Type a name for the new .ldc file and specify the directory location.

4. Select the Add to Implementation option if you want to use the file with
the currently active implementation.

5. Click New.

LDC Editor opens and displays the spreadsheet and three tabs for
creating and editing synthesis constraints. If you selected the Add to
Implementation option, the new .ldc file will appear in the Synthesis
Constraint Files folder.

Drop-down menus of source elements are provided when you double-
click the Clock Source cells or the Inputs/Outputs Ports cells.
Note

If manual compilation has been selected as the default, the lists of source
elements might not be displayed. Choose Design > Compile i to display them.

6. Enter or edit values for clocks, inputs and outputs, and delay paths:

a. Double-click a cell and type a new value, or select a value from the
drop-down list.

b. Use the arrow keys or the Tab key to move to another cell and select it
for editing.

c. To add a new row, right-click inside a row and choose Insert Row
from the pop-up menu.

7. Choose File > Save.

See Also »“Defining Clocks Using LDC Editor” on page 356
“Setting Input and Output Delays Using LDC Editor” on page 357
“Defining Delay Paths Using LDC Editor” on page 358
“Synopsys Design Constraints (SDC)” on page 1272
“Managing Constraint Files” on page 40
“Integrated Synthesis” on page 567
“Optimizing LSE for Area and Speed” on page 565
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Setting Design Rule Checks for LDC Editor

LDC Editor runs a design rule check (DRC) to verify that the constraints you
enter are legitimate. You can control when these checks happen. By default,
the DRC happens before saving the .Idc file. You can also set it to happen
while you are creating the constraints for immediate feedback. The DRC
marks any problems and gives you a chance to correct them.

To set when LDC Editor runs DRC:
1. Choose Tools > Options.
The Options dialog box opens.
2. Inthe left frame, choose LDC Editor.
3. If you want to run DRC:
before saving the .Idc file, select Run DRC check before saving.
while creating constrains, select Enable realtime DRC check.

If you clear both options, the DRC never runs. In that case, you may be
saving incomplete or inaccurate constraints.

4. Click OK.

Defining Clocks Using LDC Editor

The Clocks tab of LDC Editor enables you to define an alias to be associated
with an existing clock port or net from the source file. You can also define
clocks by dragging-and-dropping from Netlist Analyzer into LDC Editor.

To define a clock using LDC Editor:

1. Double-click the Source cell to select an existing clock pin, port, or net.
2. If desired, enter an alias for the clock in the Clock Name cell.

3. Enter a clock period in nanoseconds in the Period(ns) cell.
4

If desired, you can specify the duty cycle. Double-click the Waveform Low
Edge cell and enter the length of the high portion of the cycle in
nanosecond. The default duty cycle is 50%. The waveform starts with the
rising edge.

To define a clock in LDC Editor using Netlist Analyzer:
1. Start Netlist Analyzer. Refer to “About Netlist Analyzer” on page 57.

2. Select desired clock object (port or net) from Netlist Analyzer and drag-
and-drop into Clock Name cell of the LDC Editor Clocks tab.

If desired, enter an alias for the clock in the Clock Name cell.
4. Enter a clock period in nanoseconds in the Period(ns) cell.

If desired, you can specify the duty cycle. Double-click the Waveform Low
Edge cell and enter the length of the high portion of the cycle in
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nanosecond. The default duty cycle is 50%. The waveform starts with the
rising edge.
See Also »“create_clock” on page 1274
“Creating a New LDC Synthesis Constraint File” on page 354
“About Netlist Analyzer” on page 57

Setting Input and Output Delays Using LDC Editor

The Inputs/Outputs tab of LDC Editor enables you to specify input and output
delays relative to a clock. You can also define input and output delays by
dragging-and-dropping from Netlist Analyzer into LDC Editor.

To set an input or output delay using LDC Editor:
1. Double-click the Type cell to select the type of delay (input or output).
2. Select from the input or output ports in the Port cell.

3. Inthe Clock cell, select an existing clock or an alias name that has been
defined for a clock.

4. Select either Max or Min or neither. Do not select both.
Max means that the delay value refers to the longest path.
Min means that the delay value refers to the shortest path.

Neither means that the maximum and minimum delays are assumed
to be equal.

5. Enter a delay value in nanoseconds in the Value(ns) cell.

To set an input or output delay in LDC Editor using Netlist Analyzer:
1. Start Netlist Analyzer. Refer to “About Netlist Analyzer” on page 57.

2. Select from the input or output ports from Netlist Analyzer and drag-and-
drop into the Port cell of the LDC Editor Input/Outputs tab.

3. Inthe Clock cell, select an existing clock or an alias name that has been
defined for a clock.

4. Select either Max or Min or neither. Do not select both.

5. Enter a delay value in hanoseconds in the Value(ns) cell.

See Also »"Defining Clocks Using LDC Editor” on page 356
“set_input_delay” on page 1279
“set_output_delay” on page 1281
“Creating a New LDC Synthesis Constraint File” on page 354
“About Netlist Analyzer” on page 57
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Defining Delay Paths Using LDC Editor

The Delay Paths tab of LDC Editor enables you to define a Multicycle path,
specify a Max_Delay or a Min_Delay for a timing path, and identify a False
path that is to be excluded from timing analysis. You can also perform the
same functions by dragging-and-dropping from Netlist Analyzer into LDC
Editor.

To define a delay path using LDC Editor:
1. Double-click the Delay Type cell and select the type of delay.

2. Specify the path information, delay, and cycles as appropriate for the
selected delay type.

To define a delay path in LDC Editor using Netlist Analyzer:
1. Start Netlist Analyzer. Refer to “About Netlist Analyzer” on page 57.

2. Select object (port, net, or register) from Netlist Analyzer and drag-and-
drop into the From or To cell of the LDC Editor Delay Paths tab.

3. Specify the path information, delay, and cycles as appropriate for the
selected delay type.

See Also »“set_multicycle_path” on page 1281
“set_max_delay” on page 1280
“set_min_delay” on page 1280
“set_false_path” on page 1278
“Creating a New LDC Synthesis Constraint File” on page 354
“About Netlist Analyzer” on page 57

Defining Clock Groups in LDC Editor

The Clock Groups tab of LDC Editor enables you to define clock groups that
are mutually exclusive or asynchronous with each other in a design so that
the paths between these clocks are not considered during timing analysis.

To define clock groups using LDC Editor:
1. Double-click the Type cell and select the type of clock group.

2. Specify the group information as appropriate for the selected clock group.

See Also »“set_clock groups” on page 1277

“Creating a New LDC Synthesis Constraint File” on page 354
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Defining Generated Clocks in LDC Editor

The Generated Clocks tab of LDC Editor enables you to define internally
generated clocks. You can also perform the same functions by dragging-and-
dropping from Netlist Analyzer into LDC Editor.

To define generated clocks using LDC Editor:
1. Inthe Source cell, select the source clock for the generated clock.

2. Specify the other values as appropriate for the generated clock.

To define generated clocks in LDC Editor using Netlist Analyzer:
1. Start Netlist Analyzer. Refer to “About Netlist Analyzer” on page 57.

2. Select the source clock from Netlist Analyzer and drag-and-drop into the
Source cell of the LDC Editor Generated Clocks tab.

3. Specify the other values as appropriate for the generated clock. You can
also specify the Master Clock and Object values by dragging from Netlist
Analyzer.

See Also »“create_generated_clock” on page 1276

“Creating a New LDC Synthesis Constraint File” on page 354

Setting Attributes in LDC Editor

The Attributes tab of LDC Editor enables you to specify Synplify Lattice
Attributes that are supported by the Lattice Synthesis Engine (LSE). You can
also define objects by dragging-and-dropping from Netlist Analyzer into LDC
Editor.

To set attributes using LDC Editor:
1. Double-click the Attribute cell and select the desired attribute.

2. Specify object type, object, value type, and value, as appropriate for the
attribute.

To set attributes in LDC Editor using Netlist Analyzer:
1. Start Netlist Analyzer. Refer to “About Netlist Analyzer” on page 57.

2. In LDC Editor Attribute tab, double-click the Attribute cell and select the
desired attribute.

3. Specify object type and value, as appropriate for the attribute.

4. Select object (port, net, or register) from Netlist Analyzer and drag-and-
drop into the Object cell of the LDC Editor Attribute tab.

Note

You can also drag-and-drop an object from Netlist Analyzer to the Object cell of
LDC Editor Attribute tab before you specify the attribute. Object type will then be
selected automatically. You can then specify attribute and value.
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See Also »"“HDL Attributes” on page 1282
“Creating a New LDC Synthesis Constraint File” on page 354
“About Netlist Analyzer” on page 57

Compiling the Design Using LDC Editor

By default, LDC Editor is set to compile the design automatically. With
automatic compilation, LDC Editor automatically performs checks as to
whether the design data is outdated. This happens whenever LDC Editor is
launched or activated. If the design data is found to be outdated, the
compilation will begin at once.

You can change this default setting to manual compilation, which will cause
LDC Editor to check the data only when the Compile command is used.

To change to manual compilation:

1. Choose Tools > Options.

2. Select LDC Editor from the list of tools.

3. Inthe “Run LSE synthesis compile step” options, select Manually.
4

If you want the editor to run a check for any rule violations each time you
save the .Idc file, select Run DRC check before saving.

5. Click OK.

To compile the design manually:
Choose Design > Compile or click the Compile £ button on the toolbar.
LDC Editor checks the design data. If the data is found to be outdated, it
begins the compilation.

See Also »‘“Integrated Synthesis” on page 567

Using Source Editor for LDC Files

Any .ldc file that you have created using LDC Editor can be viewed and edited
in Source Editor. Likewise, an .Idc file that you have created in Source Editor
can be viewed and edited in LDC Editor.

One advantage of using Source Editor is that it allows you to open multiple
Idc files at once, whereas LDC Editor will load only one .Idc file at a time.

To open an .ldc file in Source Editor:
1. Inthe File List view, expand the Synthesis Constraints folder.

2. Right-click the name of the .Idc file you want to open and choose Open
With.

3. Inthe dialog box, select Source Editor and click OK.
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The .Idc file opens in Source Editor window as an ASCII file.

See Also »“Changing the Default Editor for LDC Files” on page 361

Changing the Default Editor for LDC Files

Diamond gives you the option of setting Source Editor or LDC Editor as the
default program for .Idc files.

To change the default editor for .Idc files:
1. Choose Tools > Options.

2. Inthe Environment section of the Options dialog box, select File
Associations.

3. Inthe Extensions column of File Associations, scroll down to Idc.

4. In the Default Programs column, choose Source Editor or LDC Editor
from the drop-down menu.

The next time you create or select an .Idc file, it will open in the editor you
selected as the default.

See Also »“Managing Constraint Files” on page 40

Optimizing for Timing
The SDC constraints that you set in the .Idc file will drive optimization of the
design if you set the optimization goal for timing in the active strategy file.

To set the optimization goal for timing:

1. From the File List view, expand the Strategies folder and double-click the
name of the active strategy.

2. Inthe Strategies dialog box, select LSE from the Synthesis Design folder
in the Process pane.

3. Inthe LSE pane on the right, scroll down to Optimization Goal and select
Timing in the Value column.

4. Click OK.

See Also »“Synopsys Design Constraints (SDC)” on page 1272
“Optimizing LSE for Area and Speed” on page 565

Generating a Synthesis Preference File

You have the option of automatically generating a synthesis preference file for
an implementation when you synthesize the design. The generated synthesis
file includes preferences that are equivalent to those in the .Idc file. These
synthesis preferences can later be merged with those of the active .Ipf file.
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To automatically generate a synthesis preference file:

1. From the File List view, expand the Strategies folder and double-click the
name of the active strategy.

2. Inthe Strategies dialog box, select LSE from the Synthesis Design folder
in the Process pane.

3. Inthe LSE pane on the right, scroll down to Output Preference File and
select True in the Value column.

See Also “Integrated Synthesis” on page 567

Adding an LDC File to an Implementation

You can add multiple .Idc files to an implementation and view each of them in
LDC Editor.

To add an existing .Idc file to an implementation:

1. Inthe File List view, right-click the Synthesis Constraints Folder and
choose Add > Existing File.

2. Browse to the directory that contains the desired .Idc file, select the file,
and click Add.

The file is added to the implementation and is displayed in the Synthesis
Constraint Files list.

See Also “Managing Constraint Files” on page 40

Activating an LDC File

To apply the synthesis constraints, you need to identify an .Idc file as the
active one for the implementation.

To activate an .ldc file for an implementation:
Right-click the file name and choose Set as Active LDC.

By default, the active .ldc file is compiled when you synthesize the design.

See Also “Managing Constraint Files” on page 40

Using Preferences

Preferences are constraints that guide the design toward performance goals.
They can be created and edited using Diamond’s six preference-editing
views, or they can be created and edited manually in the logical preference
file (.Ipf) using a text editor. Preferences, unlike HDL attributes, are written to
the .Ipf file.
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This section describes the major types of preferences and the role they play in
the design flow. For complete descriptions of all preferences, see the
“Constraints Reference Guide” on page 1133.

The Logical Preference File

The logical preference file (.Ipf) is your source file for storing constraints. It is
the constraint file used as input for developing and implementing the design.
A new .Ipf file is automatically generated when you create a new project. It is
assigned the project file name by default and set as the active constraint file
for the project’s initial implementation.

The Map Design process depends on the .Ipf file. If you map the design and
then modify the active .Ipf file, the map process and any downstream
processes must be rerun.

You can create and modify logical preferences in the .Ipf file using Diamond’s
preference-editing views, or you can modify the .Ipf file directly using a text
editor. Typically, you will start with a small .Ipf file, which might contain basic
timing preferences. For a complex design, the .Ipf file might be modified
several times during the course of design as timing and placement goals are
refined.

The .Ipf file can also be used to override attributes that exist in the HDL
source. When you modify these constraints in the .Ipf file, they will take
precedence over those in the HDL file.

Unlike the .prf file, which is generated by the map process, the .Ipf file
contains only user-defined preferences.

Working with Multiple .Ipf Files Diamond enables you to add new or
existing preference files to your project and experiment with different sets of
constraints. Each added .Ipf file is listed in the LPF Constraint Files folder on
Diamond'’s File List view. You can then activate a different .Ipf file for a
selected implementation.
See Also »“Adding a Logical Preference File to a Project” on page 443

“Activating a Preference File” on page 444

“Managing Project Sources” on page 33

“Integrated Synthesis” on page 567

“Preferences and the Design Flow” on page 365

“Preference-Editing Views and Memory” on page 392

“Physical View” on page 429

“Logic Block View” on page 430
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Preference Flow

Diamond provides six views for editing preferences. You can also modify
preferences manually in the logical preference file (.Ipf) using a text editor.
After routing, you can examine finer details in the read-only Physical View and
Logic Block View.

Synthesis constraint files (SDC) can be processed using either Lattice

Synthesis Engine (LSE) or Synplify. Refer to “Multiple Entry Constraint Flow”
on page 348.

Figure 49:
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See Also »“Multiple Entry Constraint Flow” on page 348
“Preferences and the Design Flow” on page 365
“Preference-Editing Views and Memory” on page 392
“Physical View” on page 429
“Logic Block View” on page 430
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Preferences and the Design Flow

Design constraints, including logical preferences and HDL attributes, work on
design elements that are present in the logical domain, which is the user’s
netlist. In the design flow, logical preferences are specified in the logical
preference file (.Ipf), usually after synthesis and translation. HDL attributes are
specified in the source files and are transferred into the binary native generic
database (.ngd) file through logic synthesis and the Translate Design process
(ngdbuild). The mapping process maps logical .ngd elements to physical
elements in the native circuit description file (.ncd), and it translates logical
preferences to physical preferences in the physical preference file (.prf).

Logical Domain References The logical domain refers to the objects in the
.ngd, which is a direct translation of the EDIF netlist. The following HDL
example, “Verilog Hierarchical Design,” illustrates the objects that will be
transferred to the .ngd by the synthesis and translation processes.

Figure 50:

module verilog hierarchical design(g, a, b, sel, r_ 1, clk,
rst) ;

output [7:0] qg;

input [7:0] a, b;

input sel, r 1, clk, rst;

wire [7:0] mux out, reg out;

mux mux_1 (.out(mux_out), .a(a), .b(b), .sel(sel));
reg8 reg8 1 (.clk(clk), .data(mux out), .g(reg out),
.rst(rst));

rotate rotate 1 (g, reg out, clk, r_ 1, rst);

endmodule

In the following .1pf file for the “Verilog Hierarchical Design” example, the
timing, floorplan, and I/O preferences are defined in terms of objects of the
logical domain—the ports, nets, or cell instances from the “verilog hierarchical
design” cell in the EDIF file. The .Ipf file illustrates package/floorplan locations
of the FPGA device such as package locations P7, K4, and E13.

While logic synthesis might rename or adjust the original design hierarchy, it is
generally easy to relate logical domain references to the original HDL or
schematic-based model of the design.

The Map Program The map program performs two major roles in the
Diamond design flow:

It maps the .ngd library elements into elements in the native circuit
description file (.ncd), which is referred to as the physical domain. Logical
elements of the .ngd (such as ports, flip-flops, and LUTs) are mapped to
physical elements of the .ncd (such as slices and I/O components).
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Figure 51:

COMMERCIAL ;
BLOCK RESETPATHS ;
BLOCK ASYNCPATHS ;
# Timing Preferences
FREQUENCY PORT "clk" 66 MHz;
INPUT_SETUP ALLPORTS 2.5ns CLKPORT "clk";
# Floorplan Preferences
UGROUP "Crit_ Path"

BLKNAME mux_1/out 4

BLKNAME rotate 1/q 7

BLKNAME reg8 1/q 1;
# I/O Preferences
LOCATE COMP ‘'"clk" SITE "P7";
LOCATE COMP '"rst" SITE "K4";
LOCATE COMP ‘'"sel" SITE "E13";

It interprets all logical preferences from the .Ipf and the .ngd files and,
where appropriate, translates them into equivalent physical preferences in
the physical preference file (.prf).

The map program also performs design rule checking when interpreting
preferences. Logical constraints from the .Ipf/.ngd are validated against the
logical database (.ngd) file. Any logical references that do not exist in the .ngd
are reported as semantic warnings and ignored by default. You can change
the default by setting the “Ignore Preference Errors” property of the Map
Design process to False in the project Strategy dialog box. This will cause the
map program to error and will make these issues more visible.

When you update and save the .Ipf during the design flow, the project gets
initialized back to pre-map status and you must rerun the map process.

Note

If the time stamp of the .Ipf for the project is newer than the post-map .ncd file, the Map
Design and Place & Route Design processes will be reset. If you want to avoid
resetting the project state, avoid saving any additions or changes to the .Ipf file. You
can still view the in-memory preferences in Preference Preview.

You can also use Timing Analysis View to experiment with sets of timing preferences
and obtain quick analysis without rerunning Map and Place & Route. See “Using
Timing Analysis View” on page 721.

Preferences in the .prf File The map process translates physical
counterparts of logical preferences, as required, into the physical preference
(.prf) file. Preferences listed in the .prf file result from both logical preferences
and HDL attributes.

In the following .prf file for the “Verilog Hierarchical Design” example, the
timing, 1/O, and floorplan preferences of the .Ipf have been translated by the
design mapper to references that are compatible with the .ncd. In this
example, most preferences appear unchanged; the object identifiers are
common between the .ngd and .ncd. However, the UGROUP preference in
the .Ipf has been translated into a PGROUP with object references that reflect
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the post-map design and the consolidation of logical domain blocks into
physical components.

Figure 52:

SCHEMATIC START ;

# map: version Diamondvl.O0 PROD Build (133) -- WARNING: Map
write only section -- Fri Jun 11 09:06:59 2010

SYSCONFIG PERSISTENT=OFF CONFIG MODE=SLAVE SERIAL DONE OD=ON
DONE_EX=OFF MCCLK FREQ=2.5 CONFIG_ SECURE=OFF WAKE UP=21
COMPRESS_CONFIG=OFF INBUF=OFF ENABLE NDR=OFF ;
PGROUP "Crit Path"
COMP "rotate 1/SLICE 4"
COMP "reg8 1/SLICE 6"
COMP "mux_1/SLICE_13";
LOCATE COMP "rst" SITE "K4"
LOCATE COMP '"clk" SITE "P7"
LOCATE COMP "sel" SITE "E13" ;
FREQUENCY PORT "clk" 66.000000 MHz ;
SCHEMATIC END ;
BLOCK RESETPATHS ;
BLOCK ASYNCPATHS ;
INPUT SETUP ALLPORTS 2.500000 ns CLKPORT "clk"
COMMERCIAL ;

Although it is possible to add preferences to the .prf file manually, this method
is definitely not recommended because it would have to be done again each
time after remapping.

Physical Domain References In cases where there is a one-to-one
correlation between a logical object and a silicon device element, the physical
domain reference uses the same identifier as the logical domain reference.
This is common for objects such as ports, EBRs, PLL/DLLs, and DSP blocks.
But objects that are consolidated into slices—such as ports, flip-flops and
LUTs—are renamed with a SLICE identifier.

Floorplan View presents a graphical view of the physical placement of
elements after the Place & Route process. The tool tips and status bar provide
logic information and location for placed components. You can view the
precise logical identifiers for a SLICE component by double-clicking the
component on the Floorplan View layout to open Logic Block View. Logic
Block View's schematic representation displays the logical names of registers
within the slice.

You can also cross-probe to Netlist View to view the precise logical identifiers.

See Also »“HDL Attributes” on page 1216
“The Logical Preference File” on page 363
“The Physical Preference File” on page 390

“Preference Conflict Resolution” on page 379
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Figure 53:
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Preferences to Improve Timing

Timing preferences control the timed paths in an FPGA design. They are
essential for good placement and routing results and for complete timing
analysis. The following timing preferences are available in Spreadsheet View:

Global Preferences Sheet — Block Path

Block Asynchpaths — Blocks all

Timing Preferences Sheet

paths from pads to FF inputs for the frequency and period preferences.

Block Reset Paths — Blocks timing constraints on all asynchronous reset
paths in the design.

Block RD During WR Paths — Prevents timing analysis of RAM executing
a read-during-write on the same address in a single clock period. This is
recommended if your design contains PFU-based RAMSs.

FREQUENCY/PERIOD - Specify a frequency
or period requirement on each clock net or clock port in the design. The
PAR_ADJ keyword for PERIOD and FREQUENCY allows you to vary
timing requirements for place-and-route results versus the requirements
reported by TRACE, the timing analysis tool. This allows you to
experiment more efficiently with over-constraining your design to achieve
the best possible timing results.

INPUT_SETUP — Each clocked input should have an input setup
preference.

CLOCK_TO_OUT - Each clocked output should have a clock-to-out
preference.

Block NET or PATH — All nets or paths specified should be ignored
(blocked) by timing analysis.

MULTICYCLE - Specify which paths’ timing constraints can be relaxed.

MAXDELAY - Identify a maximum total delay for a net, bus, or path in the
design

Lattice Diamond 3.6 Help

368



APPLYING DESIGN CONSTRAINTS :  Using Preferences

After placement and routing, you can experiment with different sets of timing
preferences using Timing Analysis View, which provides a timing preference
file (tpf) version of Spreadsheet View. Included in the TPF Spreadsheet View
are Global, Timing, and Group preference sheets.

Note

The map report (.mrp) contains an “ASIC Components” section that lists the ASIC
instances and type used in the design. All other registers in the report are CELLSs.
There might be times when you need to apply a timing preference, such as
MULTICYCLE or MAXDELAY, that requires specification of CELL or ASIC; but you are
not sure whether the specific instance is an ASIC or a CELL. In these situations, run
the Map Report process.

Path Checking on Timing Preferences When a timing preference is
specified, the software does a path check. The path checked depends upon
the preference. The following table illustrates the path checks made for each
timing preference:

Timing Preference Description

PERIOD/FREQUENCY On a clock net, generates a check for delays on all
paths that terminate at a pin that has a setup or
hold timing constraint relative to the clock net.

MAXDELAY PATHCLASS Checks the delay of the specified class of paths:

OUTPUTPATHS — all paths to primary output pins
of the device

CLOCKPATHS — all paths to clock inputs of
SLICE/FSLICEs and PICs

ENABLEPATHS — all paths to clock enable inputs
of SLICE/FSLICEs

SYNCPATHS — all paths to SLICE/FSLICE and
PIC synchronous inputs

ALLPATHS — a superset of these path classes

CLOCK_TO_ouT/ Specifies the delay offset for an external data input/

INPUT_SETUP output relative to an external clock input, and
generates delay checks on syncpaths and
outputpaths.

BLOCK Provides a means of blocking timing checks on

specific nets, paths (containing the specified net),
or path classes reported in the verbose report.

RESETPATHS — specifies all asynchronous set/
reset paths, through an asynchronous set/reset pin
on a design component.

ASYNCPATHS — All paths from pads to FF inputs
will be blocked for the frequency and period
preference.

MULTICYCLE Allows for relaxation of previously defined PERIOD
or FREQUENCY constraints on a path.
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See Also »“Auto Generating Timing Preferences” on page 475
“Using Timing Preference Files (.tpf)” on page 488
“Analyzing Static Timing” on page 683
“Achieving Timing Closure” on page 555
“Preferences” on page 1134

“HDL Attributes” on page 1216

Preferences for Floorplanning

Floorplanning involves the placement of logical component instances or
signals of a synthesized design to package pins or other sites of the device
floorplan to improve the design’s performance.

I/O Assignments 1/O planning involves both the configuration of the
programmable syslO buffers to meet signal standard requirements as well as
package pin locations to meet signal routing specification of the printed circuit
board design.

The FPGA's PIO buffer varies by location around the chip die and might
support a subset of potential signal standards, depending on the location.
Some pins might have special dedicated connections to programming or
clocking circuits of the chip and put restrictions on how pin assignments can
be made. Diamond’s Package View and Spreadsheet View enable you to
define the correct preferences for pin assignments (LOCATE COMP), port
groups (DEFINE GROUP) and port attributes (IOBUF).

See the sections “Assigning Signals” on page 449; “Setting Port, Net, and Cell
Attributes” on page 458; and “Defining Port, Cell, and ASIC Groups” on
page 489.

Logical Groups One of the main floorplanning methods is to group logical
instances into a universal group (UGROUP) or hierarchical group (HGROUP).
UGROUP is intended for grouping blocks in hierarchies or no hierarchy.
HGROUP, which is usually defined as part of a VHDL architecture or a Verilog
module declaration, is used to infer a unique placement group for each
instance of a block. UGROUPs and HGROUPs can include PFU, PFF, EBR,
and DSP-based logic.

UGROUPs and HGROUPs are translated by the design mapper (map) into
PGROUPs, which directs the placer algorithm of PAR to place the group
members in proximity. Diamond’s Spreadsheet View, Netlist View, and
Floorplan View enable you to create and edit UGROUPs

Note

The Diamond preference views do not support the creation or editing of HGROUPs.

UGROUPs and HGROUPs and their related attributes facilitate partitioning
the logical design. When a UGROUP or HGROUP is defined, the mapping
program prevents logical elements of different groups from being mapped into
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the same block and achieves a natural partitioning of the mapped design.
After mapping, the place and route process interprets the groups and places
the grouped physical elements in proximity, effectively minimizing the
connections between them.

See “Grouping Logical Components” on page 489.

Placement Groups Placement groups (PGROUP) are inferred by the Map
process from any HGROUP and UGROUP definitions that exist in the logical
preference (.Ipf). When you use UGROUPs and HGROUPSs, you are using the
logical domain, which gives you control over how functions are grouped
relative to each other. After mapping, these groups appear in the physical
preference (.prf) file as PGROUPs.

Note

The legacy PGROUP preference is no longer supported for grouping PFF, PFU, EBR,
and DSP-based logic in the logical preference file. Use the UGROUP preference
instead.

The DEFINE GROUP preference should be used instead of the legacy P1O-based
PGROUP preference. Although you can still create a PIO-based PGROUP in the
logical preference file using a text editor, this is not recommended. The Diamond
preference views do not support the display or editing of PIO-based PGROUPs.

See Also “UGROUPS” on page 378

Preferences for Programming

The Global preferences sheet allows you to set configuration

The Lattice sysCONFIG feature is the non-JTAG interface supported by
Lattice FPGA devices. The keywords for the sysCONFIG preference, which
are available on the Global Preferences sheet, enable you to

Global Preferences

Global preferences are constraints that affect the entire design. They include
preferences for setting voltage and temperature, preferences for blocking
timing analysis on all paths of a certain type, configuration (sysCONFIG)
preferences, and user code. Most of these preferences are available from the
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Table 21:

Preference Name

BACKGROUND_RECONFIG

BANK

BANDGAP

BLOCK ASYNCHPATHS

BLOCK INTERCLOCK
DOMAIN PATHS

BLOCK JITTER

BLOCK RD DURING WR
PATHS

BLOCK RESETPATHS

COMPRESS_CONFIG

CONFIG_IOVOLTAGE

Global sheet of Spreadsheet View. The list of available preferences varies by
device family. See the references below the table for more information about
sysCONFIG features for Lattice FPGA device families.

Supported Devices

ECP5U/UM

All
MachX0O2

All

All

All

All

All

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeSC/M,
MachX02, MachXO3L,
Platform Manager 2

ECPS5, LatticeECP3

Description

NOTE! The use of this preference is risky is
recommended for advanced users only.

ON — Allows user to reconfigure device in user mode.

OFF (default) — Disables this preference.
Specifies the VCCIO voltage level of the 10 bank.

ON (default) — Statically enables analog PLL circuitry,
power-on reset, oscillator, and referenced 1/Os.

OFF — Disables this preference.
ON (default) — Blocks timing analysis on all paths from

pads to FF inputs for the FREQUENCY and PERIOD
preference.

OFF — Disables this preference.
NOTE! The use of this preference is risky and not
recommended.

ON - Specifies all paths involving data transfer between
registers that are clocked by different clock nets—even
when those clock nets are related.

OFF (default) — Disables this preference.

ON - Blocks timing analysis on input and system jitter.

OFF (default) — Disables this preference.

ON — Globally blocks timing analysis on RAM read
paths during the write operation.

OFF (default) — Disables this preference.

ON (default) — Blocks timing analysis on all
asynchronous set/reset paths, through an
asynchronous set/reset pin on a design component.

OFF — Disables this preference.

ON (default) — Generates a compressed version of the
bitstream file. The device will route the compressed
bitstream through the decompression engine during
configuration.

OFF — Disables this preference. It is possible for the
compressed bitstream to be larger than the
uncompressed bitstream.

Sets the voltage for the sysCONFIG bank. This attribute
tells the software the voltage that is required in this bank
to satisfy the sysCONFIG requirements.
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Table 21:

Preference Name

CONFIG_MODE

CONFIG_SECURE

CONFIGURATION

CUSTOM_IDCODE

DONE_EX

DONE_OD

DONE_PULL

DUALBOOTGOLDEN

Supported Devices

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeXP2, LatticeSC/M

All

MachX02, MachXO3L,
Platform Manager 2

MachX02, MachXO3L,
Platform Manager 2

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeXP2, LatticeSC/M

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeXP2

ECPS5, LatticeSC/M

MachXO3LF

Description

Specifies the configuration mode. The configuration
modes available, as well as the default mode, will
depend on the targeted device.

Allows you to set the security of the device.
ON - Blocks Read Back of the configuration memory.
OFF (default) — Enables Read Back through any port.

Note: For LatticeECP2 devices, use the Security
Settings interface from the Diamond Tools menu to set
this preference.

Specifies settings for storing the configuration bitstream.

CFG (default) — Stores the configuration bitstream,
including EBR init, in the configuration flash array and
does not allow it to overflow into the UFM.

CFG_EBRUFM - Stores the configuration bitstream
(not including EBR init) in the configuration Flash array
and stores EBR init data in the lowest page addresses
of the user flash memory (UFM).

CFGUFM - Stores the configuration bitstream, including
EBR init, in the configuration flash array and allows it to
overflow into the UFM.

EXTERNAL — Stores the configuration bitstream,
including EBR init, in an external memory device.

Specifies a 32-bit value to be used as the JTAG ID of
the device when the MY _ASSP feature is enabled.

Determines if the wake-up sequence is triggered by an
external DONE signal.

ON — Delays wake-up until the DONE pin is driven high
by an external signal and synchronous to the clock.

OFF (default) — Synchronously wakes up when the
internal Done bit is set and ignore any external driving of
the DONE pin.

If DONE_EX is set to ON, DONE_OD should be set to
the default value of ON.

ON (default) — Configures the DONE pin as an open
drain configuration.

OFF — Disables this preference.

ON (default) — Configures the DONE pin with a pull up.
OFF — Disables this preference.

INTERNAL (default) — Controls the Dual Boot Golden
File Location. This setting specifies an internal location.

EXTERNAL — Specifies an external Dual Boot Golden
File Location.
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Table 21:

Preference Name

ENABLE_NDR

ENABLE_TRANSFR

GSR_NET

12C_PORT

INBUF

JTAG_PORT

MASTER_SPI_PORT

Supported Devices

LatticeECP2/M,
LatticeECP3

MachX02, MachXO3L,
Platform Manager 2

All

MachX02, MachXO3L,
Platform Manager 2

LatticeECP/EC,
LatticeECP2/M, LatticeXP,
LatticeXP2, MachXO

MachX02, MachXO3L,
Platform Manager 2

ECPS5, LatticeXP2,
MachX02, MachXO3L,
Platform Manager 2

Description

OFF (default) — 1/0s are tri-stated during
reconfiguration.

ON - Enables Non-disruptive Reconfiguration (NDR),
which allows the device to be reconfigured while I/Os
are in Leave-Alone mode.

DISABLE (default) — Leaves the Freeze |10 and
Freeze_MIB fuses off and disables the TransFr function.

ENABLE — Turns on the Freeze_|O and Freeze_MIB
fuses to enable the TransFR function.

Assigns a specified net as the input to the global set/
reset (GSR) buffer inferred by the design mapper
(MAP).

ENABLE — Makes the 1°C port active for configuration
access by preventing the dual-purpose pins from being
used as I/O pins.

DISABLE (default) — Makes the dual-purpose pins
related to the 1°C port available as user 1/O pins.

On — Turns on the input buffers. You must set this
preference to On when you need to perform boundary
scan testing.

Off — Disables all unused input buffers to save power.
LatticeECP/EC, LatticeECP2/M: defaults to Off
LatticeXP, LatticeXP2, MachXO: defaults to On
ENABLE (default) — Prevents the JTAG pins from being
used as ordinary 1/Os.

DISABLE — Allows the assigning of signals to the JTAG
pins. A high signal on the JTAGENB would then be
required to re-enable the JTAG port, after which the 4
pins would become dedicated JTAG pins.

ENABLE — Allows SRAM to be configured using the
external Master SPI port.

DISABLE (default) — Prohibits the use of the external
Master SPI port for SRAM configuration.

EFB_USER (MachX0O2 and MachXO3L only) —
Reserves the SPI pins for user Master SPI mode in the
embedded function block (EFB)
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Table 21:

Preference Name

MCCLK_FREQ

MUX_CONFIGURATION _

PORT

MY_ASSP

ONE_TIME_PROGRAM

PERSISTENT

POR

Supported Devices

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeSC/M, MachXO2,
MachXO3L, Platform
Manager 2

MachX02, MachXO3L,
Platform Manager 2

LatticeXP2, MachXO2,
MachXO3L, Platform
Manager 2

LatticeXP2, MachXO2,
MachXO3L, Platform
Manager 2

LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeSC/M

MachX0O2

Description

When you have determined that the a device will be a
Master Configuration device and will provide the
clocking source for configuration, the CCLK will become
an output clock with the frequency set by the user. At
the start of configuration the device operates with the
default Master Clock Frequency of 2.5MHz. One of the
first configuration bits set will be the Master Clock. Once
the Master Clock configuration bits are set, the clock will
start operating at the user-defined frequency.

MCCLK_FREQ is used to control the Master Clock
frequency. It defaults to the lowest frequency depending
on target device.

ENABLE - Controls dynamic muxing of JTAG and 10s
with JTAGEN.

DISABLE (default) — Prevents the disabling of all
configuration ports.

ON - For LatticeXP2 devices, causes the USERCODE
to be used as a custom device ID. For MachXO2 and

MachXO3L devices, changes the JTAG IDCode of the
device to the contents of the CUSTOM_IDCODE field.

OFF (default) - Uses the regular Lattice device ID code.

ON - Protects the Flash memory from erasure or
reprogramming.

OFF (default) — Allows erasure and programming of the
Flash memory.

When using the sysCONFIG port, this keyword must be
set to ON (except for LatticeECP3 devices) to reserve
the dual-purpose pins for configuration. The ON option
lets the software know that all the dual purpose
configuration pins will NOT be available for the fitter to
use.

For LatticeECP3 devices, the SLAVE_PARALLEL
option reserves all sysCONFIG pins; and the SSPI
option reserves only the slave SPI port.

ON (default) — Statically enables power-on reset when
BANDGAP is turned on.

OFF — Disables this preference.
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Table 21:

Preference Name

SDM_PORT

SHAREDEBRINIT

SLAVE_PARALLEL_PORT

SLAVE_SERIAL_PORT

SLAVE_SP|_PORT

STRTUP

SYSTEM_JITTER

TEMPERATURE

TRACEID

Supported Devices

MachX02, MachXO3L,
Platform Manager 2

MachX02, MachXO3L,
Platform Manager 2

ECP5

LatticeECP4U/M

ECPS5, LatticeXP2,
MachX02, MachXO3L,
Platform Manager 2

LatticeECP3

All

All

MachX02, MachXO3L,
Platform Manager 2

Description

Self-download mode port.

DISABLE (default) — Permits the SDM pins to be used
as regular 1/O pins.

PROGRAMN - Retains the PROGRAMN pin as a
dedicated SDM pin.

PROGRAMN_DONE — Retains the PROGRAMN and
DONE pins as dedicated SDM pins.

PROGRAMN_DONE_INITN — Retains the
PROGRAMN, DONE, and INITN pins as dedicated
SDM pins.

ENABLE - Allows sharing of the same init file used by
multiple EBRs.

DISABLE (default) — Does not allow sharing of the init
file.

ENABLE — Makes the 8-bit slave parallel port
available after configuration.

DISABLE (default) — Prohibits the 8-bit slave parallel
port from accessing the SRAM after configuration and
allows the dual purpose pins to be used as general
purpose 10’s.

ENABLE — Makes the slave serial port available
after configuration.

DISABLE (default) — Prohibits the slave serial port from
accessing the SRAM after configuration, and allows the
dual purpose pins to be used as general purpose 10’s.

ENABLE (default) — Allows on-chip Flash to be
programmed and read back using the external Slave
SPI port.

DISABLE — Prohibits the use of the external Slave SPI
port for on-chip Flash programming.

EXTERNAL (default) | TCLK | CCLK | MCLK

Specifies the clock source to be used for
synchronization with the start-up sequence.

Specifies the peak-to-peak system jitter for timing
analysis. The value specified overwrites the default
value. It should not be smaller than the default value for
the device.

Assigns an operating junction temperature for the part
that changes the derating factor for timing.

Specifies a code for storing device data, much like
USERCODE but in binary format.
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Table 21:

Preference Name

TRANSFR

UNIQUE_ID

USERCODE

VOLTAGE

WAKE_ON_LOCK

WAKE_UP

Supported Devices

ECP5

ECP5

All

All

LatticeXP2, LatticeECP3

ECPS5, LatticeECP/EC,
LatticeECP2/M,
LatticeECP3, LatticeXP,
LatticeXP2, LatticeSC/M

Description

OFF (default) — Leaves the Freeze_|O and Freeze_MIB
fuses off and disables the TransFr function.

ON — Turns on the Freeze_lO and Freeze_MIB fuses to
enable the TransFR function.

Defines the upper sixteen bits of an automatic 32-bit
USERCODE that will be used to identify the design.

Enter binary, hex, or ASCII values to program the
Usercode bits.

Note: The use of CHECKSUM as USERCODE is
supported for LatticeXP2 devices. AUTO format, which
enables UNIQUE_ID, is supported for ECP5 devices.

Assigns a value for nominal FPGA core voltage

Determines whether the device will wait for the
PLL to lock before beginning the wake-up
process.

OFF (default) — the device will wake up regardless
of the state of the PLL lock signal.

ON - the device will not wake up until the PLL lock
signal for the given PLL is active.

Specifies the wake-up sequence. The default value is
determined by the DONE_EX setting.

DONE_EX = OFF: defaults to 21 and ranges between 1
and 25

DONE_EX = ON: defaults to 4 and ranges between 1
and 7

See Also Setting Global Preferences
TN1260, ECP5 sysCONFIG Usage Guide
TN1053, LatticeEC/ECP sysCONFIG Usage Guide
TN1108, LatticeECP2/M sysCONFIG Usage Guide
TN1169, LatticeECP3 sysCONFIG Usage Guide
TN1080, LatticeSC sysCONFIG Usage Guide
TN1082, LatticeXP sysCONFIG Usage Guide
TN1141, LatticeXP2 sysCONFIG Usage Guide
TN1204, MachXO2 Programming and Configuration Usage Guide

TN1279, MachXO3L Programming and Configuration Usage Guide
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UGROUPs

A universal group (UGROUP) is a group of logical components that are to be
packed close together. A UGROUP instructs the mapper not to pack
unrelated logic into the same block. The UGROUP will be translated by the
mapping process to a placement group (PGROUP) in the physical preference
file (.prf), giving instructions to the placer to place the components in close
proximity to each other. These groups are for mapping and placement only;
they have no direct timing influence. See “DEFINE GROUP” on page 1152 for
a different type of group that is usable for timing constraints.

Note

The Diamond preference views do not support the creation or editing of PGROUPs.

UGROUPs can be defined in the logical preference file (.Ipf) or in the HDL
source.

UGROUPs can include anchored or floating PFU, PFF, and EBR blocks,
which can be bounded or unbounded. UGROUPSs that include DSP blocks
must be anchored. If a floating UGROUP includes a DSP block in the .Ipf file,
the system will issue a warning and ignore the block during mapping,
placement and routing.

UGROUPs in the Logical Preference File

You can create or edit UGROUPs manually with a text editor using the ASCII
pf file and the UGROUP preference syntax. You can also create UGROUPs
using the Diamond preference views. UGROUPs from the HDL source are
displayed in Spreadsheet View. If the UGROUPs are anchored (bounded or
unbounded), they will also be displayed in Floorplan View. After being
modified and saved, they will appear in the .Ipf file. Use any of the following
methods to create or edit UGROUPs:

In the Group sheet of Spreadsheet View, create a new UGROUP and add
instances; or modify an existing UGROUP.

In Netlist View, create a new UGROUP from selected instances.
In NCD View, create a new UGROUP from selected instances.

In Floorplan View, draw a new UGROUP bounding box and add
instances; modify an existing UGROUP; or create a new UGROUP from
selected routed instances.

When you issue the “Save” command from any preference view, Diamond
writes the new and modified UGROUPs to the currently active .Ipf file.

UGROUPs in the HDL

Two main logical group preferences are available as attributes in the HDL and
are displayed in the Group sheet of Spreadsheet View after the Translate
Design process. They include:
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UGROUP — The UGROUP attribute is used in the HDL for grouping
components within hierarchies or across hierarchies. When you run the
Translate Design process and open the design in Spreadsheet View, you will
see these groups listed in the Group preference sheet. If you modify and save
these groups, they will also appear in the .Ipf file.

HGROUP — The UGROUP attribute is almost always the type of logical group
that is used. However, the HGROUP attribute (also referred to as hierarchical
group), can be used for grouping components within a module that is to be
instantiated multiple times. During synthesis, the HGROUP is expanded into
individual instances. Each instance is then displayed as a unique UGROUP in
the Group sheet of Spreadsheet View. After you modify these groups and
save the design, they will appear in the .Ipf file. HGROUPS are not commonly
used, and their functionality can be duplicated by assigning UGROUPs with a
distinct name to each instance.

Note

The Diamond preference views do not support the creation or editing of HGROUPs.

Logical groups specified in the HDL design file are displayed in the Group
sheet of Spreadsheet View. However, logical groups that are created in the
Spreadsheet View are kept in the post-synthesized logical preference file (.Ipf)
and are not back annotated to the HDL design file.

Note

HDL groups that are modified and saved in Diamond are added to the .Ipf file.
Afterwards, the .Ipf file takes precedence. If you want the original HDL preference to be
honored, you must delete the conflicting preference in Diamond or you must delete it
directly from the .Ipf file using a text editor.

See Also “Preferences for Floorplanning” on page 370
“Creating UGROUPSs” on page 492

Preference Conflict Resolution

When more than one preference is ascribed to a single design element, some
preferences will take precedence over others, depending on the level of
specificity, the order of the conflicting preferences, and redundancy between
the HDL source and the logical preference file (.Ipf). The software resolves
such conflicts by adhering to the following rules of precedence:

Timing preferences that have a higher priority than others take
precedence when the same design objects are constrained in two or more
preferences. For example, the higher-priority BLOCK preference takes
precedence over the lower-priority MULTICYCLE preference.

See “Timing Preference Priority” on page 380

When more than one preference applies to a net or path, more specific
preferences are honored before less specific ones. For example,
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individual net/path preferences supersede group (bus) preferences, and
group preferences supersede global preferences.

When more than one preference at the same specificity level exists for a
block/comp/net/path, the preference that occurs last in the preference file
takes precedence.

Note

MAXDELAY PATH (FROMI/TO) preferences will supersede ALLPATHS, PERIOD,
or FREQUENCY preferences where possible.

When an attribute in the HDL conflicts with a preference in the logical
preference file, the preference in the .Ipf file has precedence. For
example, when a given register is included in both a UGROUP attribute
and a logical preference definition, the logical preference is honored.

See “Conflicting HDL Attributes, Constraints, and Preferences” on
page 386 and “Conflicting IOBUF Constraints” on page 382

HGROUPs and UGROUPs in the HDL do not appear in the .Ipf unless
they have been modified and saved to the .Ipf file. Afterwards, the groups
in the .Ipf file take precedence over those in the HDL. Conversely, logical
groups created in the Diamond preference views are kept in the .Ipf file
and are not back annotated to the HDL design file.

When two or more UGROUPs are identified with the same name in the .Ipf
file, the group that appears last is honored.

When different UGROUPs in the .Ipf file contain one or more of the same
members, the UGROUP that appears last is honored.

Timing Preference Priority

The following list shows the priority of timing preferences, beginning with the
highest priority BLOCK preference and ending with the lowest priority
PERIOD/FREQUENCY preference:

1. BLOCK
2. INPUT_SETUP/CLOCK_TO_OUT
3. MULTICYCLE

4. MAXDELAY

5. PERIOD/FREQUENCY

In the following example, two preferences are assigned to port Q.

Figure 54:

MAXDELAY TO PORT "Q" 10 ns;
BLOCK PATH TO PORT "Q";

The BLOCK PATH TO PORT “Q” preference negates the MAXDELAY
preference. The resulting TRACE Report (.twr) file lists both preferences:
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Figure 55:

Preference: MAXDELAY TO PORT "Q" 10.000000 ns ;
0 items scored, 0 timing errors detected.

Preference: BLOCK PATH TO PORT "Q"
1 item scored, 0 timing errors detected.

The TRACE report does not indicate that the MAXDELAY preference has
passed the constraint requirements, and it was not scored. If you remove the
BLOCK preference and retain just the MAXDELAY preference, the TRACE
report will show that the preference passes the constraint of 10 ns.

Figure 56:

Preference: MAXDELAY TO PORT "Q" 10.000000 ns ;
1 item scored, 0 timing errors detected.

Passed: The following path meets requirements by 7.415ns

Logical Details: Cell type Pin type Cell/ASIC name (clock net +/-)
Source: FF Q Q 0io (from CLK c +)
Destination: Port Pad Q

Delay: 2.585ns (66.8% logic, 33.2% route), 2 logic levels.
Constraint Details:
2.585ns physical path delay d MGIOL to Q meets
10.000ns delay constraint by 7.415ns

Physical Path Details:

Name Fanout Delay (ns) Site Resource
C20UT_DEL --- 0.384 IOL T24A.CLK to IOL_T24A.INFF d MGIOL (from CLK c)
ROUTE 1 0.858 IOL_T24A.INFF to B14.PADDO Q c
DOPAD_ DEL --- 1.343 B14.PADDO to B14.PAD Q
2.585 (66.8% logic, 33.2% route), 2 logic levels.
Report: 2.585ns is the maximum delay for this preference.

For timing preferences with the same priority level, more specific preferences
are honored over less specific ones. For example:

In this example, net W gets 10 ns because this preference is more specific
than ALLNETS
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Figure 57:

MAXDELAY NET W 10 NS;
MAXDELAY ALLNETS 30 NS;

Redundant Timing and I/O Assignments In the following timing
preferences example, order and specificity determine the preference that will
be honored.

Figure 58:

MAXDELAY NET W 10 NS;

MAXDELAY ALLNETS 30 NS;

DEFINE BUS B NET Y NET Z;
DEFINE BUS A NET Y NET X NET W;
MAXDELAY BUS B 20 NS;

MAXDELAY BUS A 25 NS;

MAXDELAY NET W 15 NS;

In this example, the MAXDELAY priority is as follows:

Net W gets 15 ns because this preference is more specific than BUS or
ALLNETS and it comes after the 10 NS preference.

Net X gets 25 ns because the BUS A preference is more specific than
ALLNETS.

Net Y gets 25 ns because the BUS A preference comes after the BUS B
preference.

Net Z gets 20 ns because the BUS preference is more specific than
ALLNETS.

All other nets get 30 ns.

Note

MAXDELAY PATH (FROM/TO) preferences will supersede ALLPATHS, PERIOD, or
FREQUENCY preferences if possible.

You can relax a global delay constraint with a more specific constraint under
most conditions. For example, assume that there is a period preference of 50
ns on CLKB, which dictates that the maximum delay from STARTPOINT to
ENDPOINT be 50 ns. You want to relax the period from STARTPOINT to
ENDPOINT to 100 ns. To do this, you must define the STARTPOINT and the
ENDPOINT, and then you must use the MAXDELAY FROM/TO preference.

Conflicting IOBUF Constraints

IOBUF constraints can sometimes conflict with one another, especially when
they appear in both the HDL and the .Ipf file or when they are used for
individual ports as well as port groups. When there are conflicting IOBUF
constraints, the following rules of precedence apply.
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Attributes in the HDL and LPF for the Same Port or Port Group When
conflicting IOBUF attributes exist in the .Ipf file and in the HDL for the same
port or port group, those in the .Ipf file will take precedence.

Beginning with Diamond 3.2, IOBUF attribute changes that you make in
Spreadsheet View for a specific port or port group will be combined with non-
conflicting attributes that exist in the HDL for the same port or port group.
When you save the changes, the combination will be recorded in the .Ipf file.

For example, the HDL source assigns the following to Port A:
input A /* synthesis |IO0_TYPE=LVCMOS18 PULLMODE=UP LOC=12 */;

You open Spreadsheet View’s Port Assignments sheet and change |IO_TYPE
to LVCMOS33 and set CLAMP to ON for Port A. When you save the changes,
Diamond combines the non-conflicting HDL attributes with the Spreadsheet
View changes and records them in the .Ipf file as follows:

IOBUF PORT "A" CLAMP=ON IO _TYPE=LVCMOS33 PULLMODE=UP ;

The non-conflicting PULLMODE attribute from the HDL is added to the .Ipf
file, as is the CLAMP attribute that was set in Spreadsheet View. The
LVCMOS18 I0_TYPE from the HDL is replaced by LVCMOS33 from
Spreadsheet View.

The LOC=12 pin assignment from the HDL does not appear in the .Ipf file,
because it is a placement constraint. If you had changed the pin assignment
to pin 14 in Spreadsheet View and saved it, it would appear in the .Ipf file as a
separate preference: LOCATE COMP "A" SITE "14"

When you set new IOBUF preferences manually using a text editor, conflicting
IOBUF attributes in the .Ipf file will completely override the HDL attributes for
the same port or port group when the design is mapped. The exceptions to
this rule are I0_TYPE and the placement constraint LOC.

An 10_TYPE attribute that exists in the HDL will be honored unless the .Ipf
file contains an 10_TYPE constraint for the same port or port group.

Beginning with Diamond 3.1, the placement constraint LOC does not get
overridden by an IOBUF preference for the same port or port group unless
it is redefined by a LOCATE preference in the .Ipf file. See “Migrating
Designs from Previous Releases” on page 385.

ALLPORTS Attribute and HDL Attributes All IOBUF attributes that exist
in the HDL will get overridden by the Map process when the ALLPORTS
attribute is used in the .Ipf file. The one exception is IO_TYPE, which will be
maintained unless the ALLPORTS attribute specifies a different I0_TYPE.

For example, the HDL source assigns PULLMODE=UP for Port A. Later, in
Spreadsheet View, the I0_TYPE in the All Ports row is changed from
LVCMOS25 to LVCMOS33. When the design is placed and routed, all of the
ports are given the LVCMOS33 IO_TYPE, including Port A. But the
PULLMODE for Port A reverts to DOWN, which is the default setting. The only
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way to return to the original PULLMODE=UP for Port A is to change it in the
pf file and rerun Map and Place & Route.

When you use ALLPORTS in the .Ipf file to make global IOBUF assignments,
make sure that you move any existing HDL IOBUF assignments to the .Ipf file.

Conflicting LPF Attributes for the Same Port or Group When two
IOBUF preferences appear in the .Ipf file for the same port or group, the one
that occurs last will be honored and will override the one that appears earlier.
The one exception is I0_TYPE, which be maintained unless the preference
that occurs later specifies a different IO_TYPE. See “Combining Multiple
IOBUF Preferences” on page 385.

For example, the following preferences for Port A appear in two different
places in the .Ipf file:

IOBUF PORT "A" SLEWRATE=SLOW PULLMODE=DOWN;

IOBUF PORT "A" SLEWRATE=FAST;

When the design is mapped, the SLEWRATE=FAST preference, which
appears last, will be honored. The earlier preference will be completely
overridden, which means that PULLMODE will revert to the default setting.

Conflicting LPF Attributes Between Ports, Groups, and ALLPORTS
When the .Ipf file contains IOBUF preferences that conflict among one or
more ports, groups, and/or ALLPORTS, the more specific IOBUF preference
takes precedence and will override the less specific preference. The one
exception is IO_TYPE, which will be maintained unless the more specific
preference specifies a different IO_TYPE.

For example, the following preferences show conflicting IOBUF attributes
between Port A and a port group that includes Port A.

DEFINE PORT GROUP "iogroup" "A*";
IOBUF GROUP "iogroup" IO TYPE=LVCMOS33 PULLMODE=UP;
IOBUF PORT "A" IO TYPE=LVCMOS18 CLAMP=OFF;

In the above example, a wildcard (A*) has been used to select ports for the
“iogroup” port group, including Port A. When the design is mapped, the
attributes for the more specific IOBUF Port A preference will be honored:
IO_TYPE=LVCMOS18 and CLAMP=OFF.

In the following example, there is a conflict between the IOBUF preference for
ALLPORTS and the IOBUF preference for Port A.

IOBUF ALLPORTS PULLMODE=UP;
IOBUF PORT "A" SLEWRATE=SLOW;
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When the design is mapped, the more specific IOBUF preference for Port A
will be honored. SLEWRATE will be set to SLOW for Port A, and the
PULLMODE setting will revert to the default setting.

In the following example, there is a conflict between the IOBUF preference for
ALLPORTS and the IOBUF preference for the “iogroup.”

IOBUF ALLPORTS IO TYPE=LVCMOS33 CLAMP=ON;
IOBUF GROUP "iogroup" PULLMODE=UP;

When the design is mapped, only the IO_TYPE will be maintained from the
ALLPORTS preference. PULLMODE will be set to UP for all ports in the
“iogroup,” and CLAMP will revert to the default setting.

Migrating Designs from Previous Releases A design that was created
with an earlier Diamond version might be affected by the following
precedence rule change in Diamond 3.1:

An IO_TYPE attribute in the .Ipf file is no longer honored when there is a
subsequent IOBUF preference in the .Ipf file for the same port or port
group. The IO_TYPE from the preference that appears first will either
revert to the default or to one specified in the preference that appears last.

A LOC attribute in the HDL will be honored. It will not get overridden by an
IOBUF preference as long as there is no LOCATE preference for the
same port or port group in the .Ipf file.

A BANK attribute in the HDL will be honored. It will not get overridden by
an IOBUF preference as long as there is no IOBUF BANK preference for
the same port or port group in the .Ipf file.

When you use a design that was created in an earlier version, make sure that
you move constraints from the HDL into the LPF file for the IOBUF attributes
that you want to maintain.

Combining Multiple IOBUF Preferences When you have multiple IOBUF
preferences in the .lpf file for the same port or port group, make sure that you
combine them into one preference.

For example, the following two preferences appear in the .Ipf file:

IOBUF PORT "a" IO TYPE=LVTTL33 PCICLAMP=ON;

IOBUF PORT "a" PULLMODE=DOWN;

Except for the IO_TYPE, the second of these preferences, which appears last
in the .Ipf file, will override the first preference. This means that the
PCICLAMP=0ON will revert to the default OFF setting when the design is
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mapped. To maintain the PCICLAMP=0N setting, simply combine these two
preferences into one.

IOBUF PORT "a" IO TYPE=LVTTL33 PULLMODE=DOWN PCICLAMP=ON;

See Also »“Conflicting HDL Attributes, Constraints, and Preferences” on
page 386

“Defining I/O Defaults” on page 458
“Defining Port, Cell, and ASIC Groups” on page 489

Conflicting HDL Attributes, Constraints, and

Preferences

Using a combination of HDL attributes and preferences is a powerful
technique for constraining the implementation tools. However, it is possible to
introduce a combination of HDL attributes and logical preferences that are
redundant and in conflict with each other. When such conflicts occur, the
preference in the .Ipf file takes precedence.

Conflicting Pin Assignments: When there is a conflicting pin assignment
between the HDL and the preference file, the assignment in the preference
file will take precedence. For example, SPI_PIN_D has a LOC attribute of
W25 in the source file. Later, in Spreadsheet View, the pin is assigned to site
U21 and saved to the .Ipf file. When the design is placed and routed, the U21
location is honored instead of the W25 assignment. The only way to return to
the original W25 site assignment is to delete the LOCATE preference from the
Apf file.

The following is an HDL example of conflicting pin assignments:
Input SPI_PIN_D /* synthesis LOC = “W25" */;

The following is an LPF example of conflicting pin assignments, which
overrites HDL:

LOCATE COMP “SPI_PIN_D” U21; (this is LPF, it over-rides HDL))

The same is true for IOBUF attributes. For example, the HDL assigns
“my_signal” to L5 with OPENDRAIN set to ON. Later, OPENDRAIN is
changed to OFF in Spreadsheet View. The pin assignment remains at L5, and
the OPENDRAIN setting of OFF is honored.

See “Conflicting IOBUF Constraints” on page 382

Redundant UGROUP Declarations In the following example, two group
preferences with the same name contain different members:

When the design is mapped, the first occurrence of Group_0, with members
reg0 and reg1, is ignored. Warnings will appear in the output log and in the
map report.
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Figure 59:

UGROUP "Group 0"
BLKNAME regO0
BLKNAME regl;

UGROUP "Group 0"
BLKNAME reg2
BLKNAME reg3;

The following example contains two group preferences with different names
that contain the same members.

Figure 60:

UGROUP "Group 1"
BLKNAME reg6
BLKNAME reg7;

UGROUP "Group 2"
BLKNAME regé6
BLKNAME reg7;

When the design is mapped, Group_1 is ignored because its members
conflict with the membership declared in Group_2 that appears second.
Warnings will appear in the output log and in the map report.

Conflict between UGROUP and LOCATE COMP The following example
contains a combination of group and location preferences that conflict:

Figure 61.:

UGROUP "Group 0" BBOX 9 9

BLKNAME Il

BLKNAME I2;
LOCATE UGROUP "Group 0" SITE "EBR_R36C6"
LOCATE COMP "I1l/pdp_ram 0" SITE "EBR R36C22" ;

The Group_0 contains two blocks of the design. One element of block 11, an
embedded block RAM (EBR) named pdp_ram_0, is placed at a specific EBR
device site (EBR_R3C22) using the LOCATE preference.

Because LOCATE is more specific than a UGROUP preference, when the
place and route program encounters this condition, it honors the LOCATE
preference. It does not necessarily place pdp_ram_0 in proximity to the other
members of Group_0. No warnings or errors are generated.

The following example contains a member (ip_ram_dqg_0_1_0) that has a
LOCATE preference. This results in the removal of this member from the
UGROUP during placement. The LOCATE preference for this member will not
influence the placement of the other members of the UGROUP, because this
member has been removed from the UGROUP.
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Figure 62:

UGROUP "grpl"
BLKNAME ip ram dg 0 0 1
BLKNAME ip ram dg 0 1 0;

LOCATE UGROUP "grpl" REGION "region 1" ;

LOCATE COMP "ip ram dg 0_1 0" SITE "EBR_R29C8" ;

The UGROUP “grpl” will continue to be put in “region_1", but grp_1 now only
has the single member: ip_ram_dq 0 0 1. The elementip_ram_dq_ 0 1 0
will be placed at site “EBR_R29C8".

Redundant DEFINE GROUP Declarations Resolution of conflicting
DEFINE GROUP preferences, such as port groups, is not handled
consistently across all programs. The style of declaration shown in the
following example should be avoided. It contains port groups that have the
same name but contain different members.

Figure 63:

DEFINE PORT GROUP "Group 0"

"do (o) "

"do (1) " ;

DEFINE PORT GROUP "Group 0"

"do(2)"

"do (3)" ;

INPUT SETUP GROUP "Group_ O"INPUT DELAY 5.000000 ns HOLD
3.000000 ns CLKPORT "CLK" ;

The first occurrence of Group_0 with members dO(0) and d0O(1) is ignored by
the preference views, however, the second occurrence of Group_0 with
member d0(2) and d0O(3) is ignored by the TRACE (trce) and PAR programs.
Both groups are passed into the physical preference file by map. Ignored
groups are not reported by the system in this example.

See Also »“The Logical Preference File” on page 363

“The Physical Preference File” on page 390

Changes to Net Names Between Preferences and
Reports

If you define certain preferences, such as a net name, and you re-run
synthesis, the name of that net may be changed. If you have an opportunity to
refer to a port versus a net, you should always use the port, because the
name will be more constant from run to run.

If must specify a net, it's possible that the net name can change, so you must
manage them.

One way specify net names is to specify those constraints through SDC. If a
net constraint is specified in SDC, that constraint will get updated
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automatically by synthesis, because synthesis will write the logical preference
file (.Ipf) for each run. Refer to “Using SDC Constraints” on page 351.

In some instances, constrained net names in the logical preference file (.Ipf)
differ from those in the physical preference (.prf) file because optimization
takes place during the mapping process. In most instances, the mapper
honors the preference, althought it may change the net names in the .prf.

A message will be written to the output log when this happens to show each
net name as it appears in the .Ipf file and the conversion to the new name as it
appears in the .prf file.

Net Names in the .Ipf File For example, the following timing preferences
appear in the .lIpf file:

Figure 64:

MULTICYCLE FROM CLKNET "clkl bn" TO CLKNET "clk2 dn" 6.000000
ns ;

INPUT_SETUP ALLPORTS 8.000000 ns CLKNET "clkl_cn"

INPUT_SETUP ALLPORTS 9.000000 ns CLKNET "c1k2_dn"

CLOCK _TO_OUT ALLPORTS 10.000000 ns CLKNET "clkl dn" ;

CLOCK _TO_OUT ALLPORTS 11.000000 ns CLKNET "clk2 bn" ;

Equivalent Net Names in the .prf File During the mapping process, nets
get merged or optimized, and their equivalent nets are found and converted to
the original preference. The preferences and equivalent nets then appear in
the .prf file. For example:

Figure 65:

MULTICYCLE FROM CLKNET "clkl in c¢" TO CLKNET "clk2 in c"
6.000000 ns ;

INPUT SETUP ALLPORTS 8.000000 ns CLKNET "clkl in c" ;
INPUT SETUP ALLPORTS 9.000000 ns CLKNET "clk2 in c"
CLOCK_TO_OUT ALLPORTS 10.000000 ns CLKNET "clkl in c"
CLOCK_TO_OUT ALLPORTS 11.000000 ns CLKNET "clk2 in c"

Net Names Matched in the Output Log To match up the net names shown
in the .prf with those shown in the .Ipf, open the Output log and scroll down to
the “Optimizing” section. This section shows the net name that has been
“clipped” for each preference and the new name that the preference has been
moved to. For example:

Whenever the mapper does not find the equivalent net, it does not write a
message to the Output file. Instead, it issues a warning in the Map Report file
(.mrp). For example:
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Figure 66:

Optimizing...

Net
Net
Net
Net
Net
Net
Net
Net

clkl bn
clk2 dn
clk2 dn
clk2 _dn
clk2 _bn
clkl dn
clkl cn
clkl cn

is
is
is
is
is
is
is
is

clipped.
clipped.
clipped.
clipped.
clipped.
clipped.
clipped.
clipped.

Preference MULTICYCLE on "clkl bn" is moved to "clkl in c".
Preference MULTICYCLE on "clk2 dn" is moved to "clk2 in c".
Preference INPUT SETUP on "clk2 dn" is moved to "clk2 in c".
Preference USE SECONDARY on "clk2 dn" is moved to "clk2 in c".
Preference CLOCK TO OUT on "clk2 bn" is moved to "clk2 in c".
Preference CLOCK TO OUT on "clkl dn" is moved to "clkl in c".
Preference INPUT SETUP on "clkl cn" is moved to "clkl in c".
Preference USE PRIMARY on "clkl cn" is moved to "clkl in c".
Figure 67:

WARNING: Net "net a" is clipped. Preference INPUT SETUP on
"net_a" is ignored.

The Physical Preference File

The physical preference file (.prf) is an ASCII output of the Map Design
process. Preferences saved in the logical preference file (.Ipf) are written to
the native circuit description (.ncd) and to the .prf file during the map process.
The map process rewrites the physical preference file each time it is
executed. The .prf file is used as an input file to placement and routing and
TRACE.

Note

A physical preference file should never be saved as an .Ipf file, because a .prf file is
quite different. A .prf file saved as an .Ipf file will not perform as expected.

In the Diamond flow, the .prf file is considered a background file and is not
visible in the File List. Though the .prf file can be opened from the project
directory, its use for modifying preferences is no longer necessary and not
recommended in most cases. You can use a Timing Preference File (.tpf),
available from Timing Analysis View, to experiment with timing preferences
and view the analysis without having to remap the design. But if you edit
physical preferences in the .prf file, they will be inconsistent with logical ones
in the .Ipf, and they will be obsolete when mapping is rerun. It is better to
define preferences in the logical preference file (.Ipf) through the Diamond
preference views or with a text editor. This ensures that preference
assignments in both the logical and physical domains stay in sync when the
design is remapped.

Preferences from the .Ipf file that have been modified or validated by map are
listed inside the SCHEMATIC START and SHEMATIC END section, and they
will be removed or replaced the next time the Map Design process is run.
Preferences with syntax errors are preserved when the .prf file is read. Tools
that write out preference files—for example, the Map Design process (map)—
will automatically write the preserved preferences. Such a file, when read
back in, will again produce syntax errors unless the erroneous preferences
are corrected.
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The .prf file can contain any number of preferences, both logical and physical,
and any number of comments in any order. A comment consists of either a
pound sign (#) or double slashes (//) followed by any number of other
characters up to a new line. The program automatically comments out illegal
preferences.
See Also »“Analyzing Static Timing” on page 683

“Preferences” on page 1134

“Setting Preferences” on page 442

Using Diamond’s Preference Views

Diamond provides six views for editing design constraints known as
preferences. These preference-editing views, which are available from the
Diamond toolbar and Tools menu, include “Spreadsheet View” on page 393,
“Package View” on page 410, “Device View” on page 415, “Netlist View” on
page 416, “NCD View” on page 417, and “Floorplan View” on page 417.

Additionally, two read-only preference views are provided after placement and
routing: “Physical View” on page 429, which enables you to view a more
detailed layout of the design; and “Logic Block View” on page 430, which
provides details of a selected block in schematic or tabular format.

Diamond’s preference views enable you to develop constraints that will
shorten turn-around time and achieve a design that conforms to critical circuit
performance requirements. They enable you to perform the following tasks:

Define timing constraints based on design signals and logic elements
Define syslO Buffer properties based on design signals

Constrain clock signals to particular routing spines

View, assign, and validate design signals and package pins

Assign voltage reference pins

Inspect the programming of design elements

Group components and set REGIONS to help meet timing goals
Cross-probe elements between physical and logical domains

Perform DRC tests to ensure legal pin assignments or to detect
incomplete or illegal conditions within the physical design database

Generate simultaneous switching output (SSO) reports

Back annotate post-route pin assignments to a logical preference file

See Also »“Using the Zoom and Pan Tools” on page 438
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Preference-Editing Views and Memory

Diamond provides six views for preference editing: Spreadsheet View, Device
View, Package View, Netlist View, NCD View, and Floorplan View. Each of
these views operates on preference access data that is stored in memory and
shared across all six views. As soon as you create or modify a preference in
one preference view, it is reflected immediately in all open preference views
and in the status bar. When there are preference changes in memory, the tab
of each open preference view is marked with an asterisk, and the status bar
displays “Preferences Modified” on the bottom right.

i’ Spreadsheet View * [0 | Freferences Modified |

Because of the shared memory between all preference-editing views, closing
one or even all views does not delete the unsaved changes from memory, and
you will not be prompted to save when you close a view. Diamond’s status bar
will always display “Preferences Modified” when you have unsaved
preference changes, even when all preference views are closed.

Saving In-Memory Preference Changes You can save in-memory
preference changes from any of the preference-editing views, with the
exception of NCD View. When you issue the “Save” command, Diamond
writes all of the preference changes stored in memory to the logical
preference file, regardless of the preference views that were used for editing.
The asterisks and the “Preferences Modified” indicators disappear as soon as
you save the changes.

Diamond will prompt you to save in-memory preference changes each time
you run a process, close the project, clear the tool memory, or exit Diamond.

Keeping Track of Unsaved Preferences Preference Preview is useful for
keeping track of unsaved preference changes. Preference Preview lists all
preferences that are already saved in the .Ipf file, followed by the preferences
that are in memory only. You can open the .Ipf file, as well as Preference
Preview, to do a side-by-side comparison.

Figure 68:
[ prepillpf & & x |Eh Preference Preview [£ g x
BLOCE ASYNCPATHI ; BLOCK ASYMCPATHS
BLOCK RESETPATHS ; BLOCK RESETPATHS ;
BLOCK TNTERCLOCKDOMATN EATHS ; | ||BLOCK INTERCLOCKDOMAIN PATHS ;
LOCATE COMP "d0_7" SITE "Ca" ;
LOCATE COMP "d0_g" SITE "DS";
LOCATE COMP "d0_S" SITE "D9" ; Unsaved
LOCATE COMP "d0_4" SITE "A11" ; preferences
LOCATE COMP "d0_3" SITE "A15" ;
LOCATE COMP "d0_2" SITE "B14" ;
< >

See Also “Discarding In-Memory Preference Changes” on page 533
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Note

Preference Preview does not show unsaved changes that have been made manually
to the .Ipf file.

“The Logical Preference File” on page 363
“Previewing Preferences Before Saving” on page 531

“Saving Preferences” on page 530

Spreadsheet View

Spreadsheet View provides a tabular format for viewing and assigning logical
preferences. It displays all preferences, including those that have been
assigned from other preference-editing views. It also displays timing
constraints that have been set in the synthesis tool.

As soon as you have specified the target device, you can use Spreadsheet
View to set global preferences. After synthesis and translation, you can use all
of the following preference sheets to create and modify constraints:

Port Assignments The Port Assignments sheet provides a signal list of the
design and shows any pin assignments that have been made. All ports
assigned in the Logical Preference File (.Ipf) and in the Native Generic
Description (.ngd) file are displayed.

By default, the ports are grouped by direction—Input, Output, and
Bidirectional—plus an “Others” category that includes user-defined port
groups. This allows you to quickly focus, for example, on Output ports by
closing the display of Input ports or vice versa. If you prefer to display the port
rows in a single un-grouped alphabetical list, clear the “Show Group Row(s)”
selection from the View > Display Group Row(s) menu.

The Port Assignments sheet enables you to assign or edit pin locations and
other attributes by entering them directly on the spreadsheet. It also allows
you to assign multiple signals, by right-clicking the selected signals and
opening the Assign Pins dialog box. Any assignment problems are indicated
with a warning icon A in the signal Name column. The warning icon will
appear for any invalid 1/0 assignment or combination.

Pin Assignments The Pin Assignments sheet provides a pin list of the
device and shows the signal assignments that have been made. In the Dual
Function column, pins that can be used for I/O assignments or for another
function, such as Vref, are identified.

By default, the rows of pins are grouped by bank number. You can also view
the differential pin pair groupings within each bank by selecting “Show
Differential Group Row(s)” from the View > Display Group Row(s) menu. To
view the group of non-assignable pins, select “Show Non-user Assignable Pin
Row(s).” If you prefer to display the rows of pins in a single un-grouped
alphabetical list, clear the “Show Group Row(s)” selection from the View >
Display Group Row(s) menu.
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The Pin Assignments sheet enables you to edit signal assignments or assign
new signals by right-clicking selected pins and opening the Assign Signals
dialog box.

Clock Resource The Clock Resource sheet enables you to apply a clock
domain to the device's primary or secondary clock or prohibit the use of
primary and secondary clock resources to route the net. For LatticeECP2
devices, it enables you to use edge clock resources. For LatticeECP3
devices, it enables you to assign a secondary clock to a clock REGION that
has been defined.

Route Priority The Route Priority sheet enables you to set the PRIORITIZE
preference, which assigns a weighted importance to a net or bus. To set this
preference, drag the desired nets from Netlist View to the Route Priority
sheet. You can then select a priority value for each net. Values range from 0 to
100.

Cell Mapping The Cell Mapping sheet enables you to set the USE DIN and
USE DOUT cell preferences for flip-flops in your design. The PIO Register
column allows you to set the register to True or False. The True setting moves
registers into the 1/0s. The False setting moves registers out of the I/0s. To
set these preferences, drag the desired registers from Netlist View to the Cell
Mapping sheet.

Global Preferences The Global Preferences sheet enables you to set
preferences that affect the entire design, such as junction temperature and
voltage; BLOCK preferences applied to all paths of a particular type; and
USERCODE. Also included in the Global sheet are sysCONFIG preferences
for FPGA devices that support the sysCONFIG configuration port.

Timing Preferences The Timing Preferences sheet displays all timing
preferences that have been set in the design, including BLOCK preferences
for specific nets, FREQUENCY, PERIOD, INPUT_SETUP, CLOCK_TO_OUT,
MULTICYCLE, and MAXDELAY. It displays, in green font, the timing
constraints that have been set in the synthesis tool and allows you to modify
them and save the modified constraints to the .Ipf file as preferences. You can
create a new timing preference by double-clicking the preference name,
which opens the dialog box. To modify an existing timing preference, double-
click the preference name, edit the information in the dialog box, and click the
Update button.

Group The Group sheet displays any groups that have been created and
enables you to define a new cell, port, or ASIC group or create a new
universal group (UGROUP). Double-click the group type to open the dialog
box and create a new group preference. To modify an existing group
preference, double-click the group name, edit the information in the group
dialog box, and click the Update button.

Misc Preferences The Miscellaneous sheet enables you to define
REGIONSs, assign Vref locations, and reserve resources by setting a
PROHIBIT preference. To set a new miscellaneous preference, double-click
the preference type to open the dialog box. To modify an existing
miscellaneous preference, double-click the preference name, edit the
information in the dialog box, and click the Update button.
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See Also »“Assigning Signals” on page 449
“Color Coding of Cell Values” on page 396
“Setting Port, Net, and Cell Attributes” on page 458
“Setting Timing Preferences” on page 475
“Grouping Logical Components” on page 489
“Working with Preference Sheets” on page 397
“Migrating Pin Assignments” on page 468
“Selecting a Device for Possible Pin Migration” on page 468

“Viewing Incompatible Pins” on page 470

How Constraints are Recorded in Spreadsheet View

Spreadsheet View presents the union of constraints that originate from the
HDL or schematic source or from the logical preference file (.Ipf). Each cell of
the preference sheet is color-coded to reflect the origin or status.

If any default, referenced, or HDL-based source constraint is modified,
Diamond will add a preference to the .Ipf file to record the change. Since
preferences in the .Ipf file have precedence over other constraint sources, the
design mapper will ignore any conflicting constraints when the design is
implemented. Diamond does not overwrite the original HDL or schematic
constraint declaration. To restore the original constraint, you must delete the
preference in the .Ipf file.

Many preferences have one or more parameters. It is possible, therefore, to
assign one parameter in the HDL or schematic source and another parameter
for the same preference in Spreadsheet View. Except for IOBUF attributes,
Diamond will write the union of all parameters to the .Ipf file. For IOBUF
attributes that exist in the .Ipf file and in the HDL for the same port or port
group, those in the .Ipf file will completely override those in the HDL. The
exception to this rue is IO_TYPE and the placement constraint LOC, which
will not get overriden.

For example, the IOBUF preference includes the parameter PULLMODE for
an 1/0 port. Given a schematic-based I0_TYPE=LVCMOS12 attribute for the
I/0O port, if the PULLMODE parameter is modified within Spreadsheet View to
PULLMODE=NONE, the following preference will appear in the .Ipf file:

IOBUF PORT "my signal" IO TYPE=LVCMOS12 PULLMODE=NONE;

This IOBUF preference combines the I0_TYPE attribute from the source file
with the new PULLMODE parameter that was made in Spreadsheet View.

See Also »“Conflicting HDL Attributes, Constraints, and Preferences” on
page 386

“Conflicting IOBUF Constraints” on page 382
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Color Coding of Cell Values

The original font colors of cell values in Spreadsheet View are blue, gray,
black, orange, green, and maroon. These colors, which can be changed in the
Options dialog box, are based on the status of the cell values: default value,
read-only value, modified (normal) value, referenced value, source value, or
schematic value. The following descriptions explain the original color coding
of these values.

Blue font — Blue represents the default value of a preference. For
example, the NONE value of PULLMODE for an HSTL I/O type is
displayed in blue. Default values can be modified but not deleted.

Blue also represents a value that is automatically assigned by the place &
route process and written to the .ncd file. These values are displayed
inside parentheses to distinguish them from default values.

Gray font — Gray represents a read-only value, one that cannot
immediately be changed. For example, the N/A value in the Vref column is
displayed in gray when no Vref pin has yet been set or when Vref is not
available for the selected I/O type. Gray also distinguishes pins that
cannot be used as general-purpose I/Os.

Black font — Black is the normal font color for a new or edited preference
and represents a modified value, which can be a value that has been
saved to the logical preference file (.Ipf). For example, pin assignments
made in the Port Assignments sheet and Block preferences made in the
Global Preferences sheet are displayed in black. Modified values can be
changed to the default value and font color, or to no value, by pressing the
Delete key.

Orange font — Orange represents a value for an element that is referenced
by another preference. For example:

If a port is a member of an IOBUF GROUP that has a Vref
assignment, the port’s Vref cell value will be displayed in orange
unless it has been individually modified.

If the Allports I/O Type is modified, the 1/O type for all ports that have
not been individually modified will be displayed in orange.

Referenced values can be modified but not deleted.

Green font — Green represents the value from the design source. For
Spreadsheet View, the source is the native generic database file (.ngd),
which includes preferences from the HDL source code or EDIF file. The
.ngd file also includes default configuration preferences, which appear in
the Global Preferences sheet; and I/O types, which appear in the Port
Assignments sheet. All of these source values from the .ngd file are
displayed in green. Source values can be modified but not deleted.

Maroon font — Maroon represents a value from a schematic source file.
Schematic values can be modified but not deleted.

Green font — Green represents a value from a timing constraint that was
set in the synthesis tool. These SDC constraints are output to a synthesis
pf file when the design is synthesized, and they are displayed in the
Timing Preferences sheet when the strategy option “Use LPF Created
from SDC in Project” has been enabled. By default, this option is set to
True. Synthesis constraint values can be modified and saved as
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preferences, but not deleted. When you modify a synthesis constraint
value and save it, the constraint is converted to a timing preference and
saved to the active .Ipf file.

Display of Incompatible Pins If you have selected a different device of the
same family and package for possible pin migration, the rows of any
incompatible pins will be dimmed on the Pin Assignments sheet.

See Also »“Spreadsheet View” on page 393
“Package View” on page 410
“Netlist View” on page 416
“Assigning Signals” on page 449
“Migrating Pin Assignments” on page 468

“Viewing Incompatible Pins” on page 470

Working with Preference Sheets

Spreadsheet View provides nine spreadsheets for setting and editing
preferences. Preference values in spreadsheets are displayed in font colors
based on their origin or status, and invalid values are highlighted in red.

The following techniques are useful for editing and viewing preferences in
Spreadsheet View.

Enter data into table cells You can enter data into the table cells of
Spreadsheet View in several ways:

Double-click the cell that you want to edit.

The cell changes to a drop-down menu or a text box, or it opens a dialog
box, depending on the type of preference you are changing. You can then
select from the menu, type a text entry, or select options and settings in
the dialog box.

Right-click the cell that you want to edit and choose from the pop-up
menu. For a text entry, such as USERCODE, choose Edit Cell and type
the string.

To edit multiple cells at once, select the cells, right-click, and choose from
the pop-up menu.

Cross-probe a signal assignment After a signal is assigned to a specific
pin, you can cross-probe to Package View, Device View, Netlist View, or
Floorplan View. After placement and routing, you can also cross-probe to
NCD View.

To cross-probe a signal assignment:

In the Port Assignments or Pin Assignments sheet, right-click the desired
pin name or signal and choose the desired view from the Show in menu.

The selected view is activated, and the pin is highlighted on the layout or
design tree.
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Sort a preference list You can sort a list on a preference sheet by a single
column or more than one column.

By default, the ports on the Port Assignments sheet are sorted alphabetically
within each group: input pins, output pins, bi-directional pins, and user-
defined groups. Also by default, the pins on the Pin Assignments sheet are
sorted alphabetically within each bank group. If you prefer to sort the rows
based on a single un-grouped alphabetical list, clear the “Show Group
Row(s)” selection from the View > Display Group Row(s) menu.

To sort a list by a single column:

Select the desired preference sheet, and then click the heading of the
column you want to sort.

An up arrow is displayed in the heading, indicating that the list has been
sorted by the column in ascending order. Click the heading again to sort
the list in descending order.

To sort a list by more than one column:
1. In Spreadsheet View, select the desired preference sheet.
2. Choose View > 4 Sort.

3. Inthe Sort dialog box, select the first column to sort by from the “Sort by”
drop-down menu. Click Ascending or Descending to control the order of
the sorted list.

4. Use the “Then by” boxes to select additional columns, as well as the
Ascending/Descending option for each column. Click More to add more
“Then by” menus if needed.

The list will be sorted first by the column specified in the “Sort by” box and
then by the additional columns in the “Then by” boxes in sequence.

5. Click OK.

Display an error or warning description Errors and warnings are
highlighted with a triangular icon A inside a cell.

To display the error or warning description:
Hold your mouse pointer over the cell that contains the icon.
A description of the error is displayed in a tool tip.

Change the font of cell values You can change the font style and size of
information that is displayed in the spreadsheet cells.

To change the font of spreadsheet cells:
1. Choose Tools > Options.

2. Inthe Options dialog box, select Spreadsheet View, and then select
Font.

3. Click the Sheet Font button, which shows the current font and size.
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4. In the Select Font dialog box, select the desired font, style, and size and
click OK.

5. Click OK to close the Options dialog box.

Adjust the font color of cell values The font colors of values in preference
cells are based on their status: default value, read-only value, modified
(normal) value, referenced value, source value, or schematic value. Refer to

“Color Coding of Cell Values” on page 396 for default colors and detailed
explanations of these values.

To change the font color of cell values:
1. Choose Tools > Options.

2. Inthe Options dialog box, select Spreadsheet View, and then select
Color.

Click the color box for the type of value you would like to change.
4. Choose the desired color from the Select Color dialog box and click OK.
Click OK to close the Options dialog box.

Adjust columns You can adjust column widths manually or choose the
right-click command to fit the column to the text.

To adjust the column width manually:
Drag the vertical border on the right of a column heading.

When you fit the column width to the text, all the text in the column is
displayed.

To fit a column to the text, do one of the following:
Double-click the vertical border on the right of a column heading.

Right-click the desired column heading and choose Fit Column.

To fit all columns to the text:
Choose View > Column > Fit All Columns or press the F5 function key.

Rearrange the positions of columns You can move the position of any
editable column on the Port Assignments Sheet or Pin Assignments sheet.

To rearrange the position of an editable column:

1. On the Port Assignments or Pin Assignments sheet, hold down the
column’s heading with your mouse pointer.

2. Drag the heading to the left or right to the desired position, and then
release the mouse button.

Hide and re-display columns You can hide a single column or select
several columns that you want displayed or hidden.
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To hide a single column:

Right-click the desired column heading and choose Hide Column.

To hide several columns:

1. Choose View > Column > Visible Columns or press Shift+F5 to open
the Visible Columns dialog box.

2. Do one of the following:

In the “Show these Columns list,” select the columns that you want to
hide, and then click the single-arrow button to move them to the “Hide
these Columns” list.

Click the double-arrow button to move all columns to the “Hide these
Columns” list, and then select those you want displayed by selecting
them and moving them to the “Show these Columns” list.

3. Click Ok.

To re-display some of the hidden columns:

Press Shift+F5, and move the hidden columns back to the “Shows these
Columns list.”

To re-display all columns:

Choose View > Column > Fit All Columns or press the F5 function key.
Auto complete  When you type an entry into a cell in the 1/O Types column,
the cell presents a list of matching values. You can then:

Choose the first (or only) matching value by pressing Enter.

Choose an alternate matching value by using the up/down arrow keys and
then pressing Enter.

Continue typing the rest of the value. If no matching value is found,
nothing will be entered.

Edit a sequence of cells in a column Spreadsheet View enables you edit
the cells in a column sequentially without moving your mouse. It does this by
automatically moving the focus to the next cell.

To edit a sequence of cells:
1. Enter the data in a cell and press Enter.
The cell below the edited one is activated.

2. Proceed to edit the data in the active cell, press Enter, and continue to the
next cell until you have finished editing the cells in the column.

You can also pass to the next cell without editing the current one by
pressing Enter.

Delete cell contents You can clear cells of their new or edited contents in
the Port Assignments, Pin Assignments, Clock Resource and Global
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Preferences sheets. When you do this, Diamond empties the cells of their
contents or redisplays the default or referenced values.

To delete the edited values from one or more cells:
Select the cells that you want to clear and do one of the following:
Press the Delete key.
Right-click the selected cell and choose Clear from the pop-up menu.
Choose Edit > Clear.
Diamond empties the cells of any values or re-displays the default or
referenced values.

Delete row contents You can delete the assignments from one or more
selected rows on the Port Assignments sheet. For each cell in the selected
rows, Diamond empties the contents, or it re-displays the default, source, or
referenced value.

To delete the assignments in one or more rows:

Select the rows that you want to clear, right-click, and choose Clear
Selected Row(s). Alternatively, choose Edit > Clear Selected Row(s).

Across the columns of the selected rows, Diamond empties some cells.
For others, it reverts to a referenced, source, or default value, as follows:

a referenced value defined in a port group or in All Ports
a source value defined in the .ngd file
a default value defined in the legal combination table
Cut, copy, and paste cell contents  You can cut or copy cell contents and

paste them into other cells in the same column of a Port Assignments, Cell
Mapping, Clock Resource, or Route Priority sheet.

To copy or cut and paste cell contents:
1. Select the cells that you want to cut or copy.
2. Choose Edit > Copy or Edit Cut or use the Ctrl+C or Ctrl+X shortcut.

3. Select the first cell in the column where you want to begin pasting the cell
contents.

4. Choose Edit > Paste or use the Ctrl+V shortcut.

Use fill down/fill up editing Fill Down/Fill Up editing is supported in Port
Assignments, Cell Mapping, Clock Resource, and Route Priority sheets. In
these preference sheets, you can fill a range of cells within the same column
by dragging down across cells or by using the Fill Down command.

Lattice Diamond 3.6 Help

401



APPLYING DESIGN CONSTRAINTS : Using Diamond’s Preference Views

To fill arange of cells by dragging:

1. Highlight the source cell which contains a valid value, and then move your
mouse to the lower-right corner of the cell. The cursor changes to a cross
symbol.

2. Drag the cross down over the range you want to fill.
The destination cells are filled with the same value as in the source cell.
Or

If you are working with the Pin Location column, you can drag down to
increment the pin numbers in the destination cells.

To fill arange of cells by using the Fill Down command:

1. Highlight the source cell together with the range of destination cells below
it. The source cell must be at the top of the selected range and contain a
valid value.

2. Choose Edit > Fill Down or press Ctrl+D.
The destination cells are filled with the same value as in the source cell.
Or

If you are working with the Pin Location column, the destination cells will
be filled with incremental pin numbers following the number specified in
the source cell.

See Also »“Changing the Grouped Display of Ports and Pins” on page 402
“Filtering the Display of Ports and Pins” on page 403
“Adding Custom Columns” on page 404

Changing the Grouped Display of Ports and Pins

By default, the rows of ports and pins in Spreadsheet View are grouped by
category. This grouped display allows you to easily view one category by
closing others. For example, you can focus on Bidirectional ports by closing
the Input and Output categories. Simply click the arrow in front of a
displayed category to open or close it. When you sort one or more columns,
the ports and pins are sorted alphabetically within each group.

On the Port Assignments sheet, all ports that are defined in the native generic
description file (.ngd) and the logical preference fie (.Ipf) are displayed. The
rows are grouped by Input, Output, Bidirectional, and by “Other,” a category
that includes user-defined P1O groups and “Nonexistent” ports. Nonexistent
ports are ports that do not exist in the .ngd file, even though they are defined
in the logical preference file. You can delete a row for a port that exists only in
the.lpf file by right-clicking and choosing “Delete Selected Row(s).” You also
have the option of viewing differential pair groups for all LVDS ports that have
been defined in the source file.

On the Pin Assignments sheet, the rows are grouped by Bank number, and
you have the option of viewing differential pin pair groups within each bank.
You can also view all non-assignable pins as a single group. Because the pins
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are grouped by bank, the BANK column does not appear on the Pin
Assignments sheet when the grouped display is turned on. But you can view
the BANK column by turning off the grouped display.

To view differential pair groups:

On the Port Assignments sheet or Pin Assignments sheet, choose View >
Display Group Row(s) > Show Differential Group Row(s).

Any LVDS ports that have been defined in the source are now displayed in
differential groups on the Port Assignments sheet, and the rows displayed
on the Pin Assignments sheet are organized by differential pin-pair groups
within each bank.

To view the group of non-assignable pins:

On the Pin Assignments sheet, choose View > Display Group Row(s) >
Show Non User-Assignhable Pin Rows.

The Non User-Assignable category is added to the bottom of the sheet
and includes rows for all pins that are not user-assignable.

You can also turn off the grouped display of ports and pins at any time in order
to view each list as a single un-grouped alphabetized list.

To turn off the grouped display of ports and pins:

On the Port Assignments sheet or Pin Assignments sheet, choose View >
Display Group Row(s) > Show Group Row(s).

All ports and pins are now listed in a single un-grouped alphabetized list.
Each of the View > Display Group Row(s) commands acts as a toggle key to
turn the grouped display on or off. When the display is turned on, the menu
item shows a check mark in front of it.

See Also “Filtering the Display of Ports and Pins” on page 403

“Adding Custom Columns” on page 404

Filtering the Display of Ports and Pins

Both the Port Assignments sheet and the Pin Assignments sheet enable you
to filter each column so that only the row contents that you specify are
displayed.

To filter the display of ports and pins:

1. On the Port Assignments or Pin Assignments sheet, right-click any
column heading and choose Filter > Enable Filter.

Each column heading now appears with a downward-pointing arrow on
the right.

2. Click the arrow for the column that you want to filter.
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The filter dialog box opens and displays a list of the items that appear in
the row contents for that column. By default, all items are selected.

3. Do one of the following to filter the list:

Clear the individual items that you do not want to appear on the
spreadsheet.

Clear the Select All selection at the top, and then select the types of
items that you want to appear on the spreadsheet.

4. Click OK.
Repeat Steps 2-4 for other columns that you want to filter.

When you have finished, the spreadsheet displays the filtered contents.
The row numbers are displayed in blue font, and a filter button [~
appears in the heading of each filtered column.

To edit a column’s filtered list:

Click the filter button and modify the selections in the filter dialog box.

To disable the filtering for a single column:

Click the filter button and choose K Clear Filter From <column name>.

To disable the filtering for all columns:

Right-click any column heading and choose Filter > Disable Filter.

See Also »“Changing the Grouped Display of Ports and Pins” on page 402
“Adding Custom Columns” on page 404

Adding Custom Columns

Spreadsheet View allows you to create custom columns on the Port
Assignments sheet and the Pin Assignments sheet. Custom columns enable
you to add your own information, such as notes for specific signals or pins or
design data for third-party tools. You can create an unlimited number of
custom columns, and you can include the column when you export to a
Lattice CSV file or a Pin Layout File.

Custom columns can be added and edited at any stage of the design flow.
Since custom columns are excluded from the generation of preferences, they
do not cause a mapped implementation to get initialized back to pre-map
status. The information is not added to the active logical preference file (.Ipf)
but is automatically saved with your project and made available for all
implementations.

To add a custom column:

1. In Spreadsheet View, select the Port Assignments or Pin Assignments
tab.
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2. Right-click the column heading of any editable column and choose Insert
Custom Column.

3. Inthe Custom Column dialog box, type a name for the column. The name
must be uniqgue to the selected preference sheet and must not conflict
with a column heading that is built in to the Port Assignments sheet or the
Pin Assignments sheets.

Note

Because the Port Assignments and Pin Assignments sheets act independently of
one another, it is possible to use the same name for a custom column on each of
these sheets. When you later export a pin layout file, Diamond will append “_port”
or “_pin” to distinguish each custom column.

4. Click OK.

The custom column appears on the spreadsheet. The column heading
name is displayed in italic font to distinguish it as a custom column.

5. Enter the desired information into the cells of the custom column as
desired.

The custom column information is automatically saved with the project
and is available for each implementation.

Editing a Custom Column You can edit or delete cell contents of a custom
column, rename the heading, or remove the entire column.

To edit or delete a cell’s contents:

Double-click a cell, and then type a new value or press the Delete key.

To edit a custom column heading:

1. Right-click the custom column heading and choose Edit Custom
Column.

2. Type a new name in the dialog box and click OK.

To remove a custom column:

Right-click the custom column heading and choose Remove Custom
Column.

See Also »“Working with Preference Sheets” on page 397

“Exporting a Pin Layout File” on page 548

Searching Preference Sheets

Spreadsheet View provides Find dialog boxes for the Port Assignments, Pin
Assignments, Clock Resource, Route Priority, and Cell Mapping preference
sheets. Except for Pin Assignments, each of these preference sheets enables
you to replace the contents of located preference cells.
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Searching Port or Pin Assignment Sheets The Port Assignments and Pin
Assignments sheets enable you to locate any string, including a preference, a
pin assignment, and any built-in value such as a pad name. The dialog box for
the Port Assignments sheet includes options for both finding and replacing.

To search for a string on the Port or Pin Assignments sheet:

1. Select the Port Assignments or Pin Assignments tab, and then do one of
the following:

Click a cell that contains the cell value you want to find, and then
choose Edit > Find or press Ctrl+F.

The Find dialog box is populated with the cell value.

Click an empty cell and choose Edit > Find or press Ctrl+F to open
the Find dialog box, and then type the name of the signal, pin,
keyword, or other string you want to locate. Type the first few
characters of the name to locate multiple items.

2. Select the “Match case” or “Match whole word” options as desired.
3. Click Find Next.

Afterwards, you can continue to click the Find Next button or press the
Enter key to locate each instance.

4. To search back toward the top, select Search Up and click Find Next or
press Enter.

5. If you are using the Port Assignments sheet and the items you are
locating are user preferences or keywords that you want to replace, do the
following:

a. Click the Replace button at the top of the dialog box, and then enter
the desired replacement preference or keyword in the “Replace with”
text box.

b. Click the Replace button at the bottom of the dialog box to replace the
next found item. To replace all found instances, click Replace All.

Searching Clock Resource, Route Priority, and Cell Mapping Sheets
Use the Find dialog boxes to locate a clock preference keyword, a priority
number for prioritized nets, or keywords for registers used as flip-flops.

To find a cell value without replacing it:

Choose Edit > Find or press Ctrl+F.

To find and replace a cell value:
1. Do one of the following:

Select the cell that contains the value you want to find and choose
Edit > Replace or press Ctrl+H.

The value appears in the “Find what” text box of the dialog box.

Choose Edit > Replace or press Ctrl+H and type the cell value that
you want to find.
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2. Inthe “Replace with” text box, type the value that you want to use as
replacement, and then do one of the following:

To replace all cells that contain the “Find what” value, click Replace
All.

To replace some but not all cells that contain the “Find what” value,
click Find Next until the cell is highlighted that you want replaced, and
then click Replace. Repeat for each cell that you want replaced.

Displaying I/O Placement Assignments in

Spreadsheet View

After placement and routing, you have the option of viewing or hiding all the
assignments that have been written to the native circuit description (.ncd) file.
This includes automatic assignments made by Place & Route (PAR) and
assignments that originated from the HDL source or the logical preference file
(.Ipf). By default, the display of I/O Placement assignments from the .ncd is
turned on in Spreadsheet View.

To display or hide .ncd assignments:

Choose View > Display 10 Placement or click the Display IO Placement
button /w on the toolbar.

This command acts as a toggle key and turns the display of /0 placement
assignments on or off.

When “Display 10 Placement” is turned on, NCD assignments are displayed
differently, depending on whether they originated from a source or constraint
file or were assigned by the placement and routing process.

Placement Assignments Originating from a Source or Constraint File
Placement assignments from the .Ipf file appear in black, or in the color
designated for “Normal Value” in the Options dialog box. Those from the HDL
source appear in green or in the color designated for “Source Value” in the
Options dialog box. But unlike the display of these values before placement
and routing, each assignment is now displayed twice: once normally and once
in parentheses. The value in parentheses represents the value written to the
native circuit description file (.ncd). When you change a post-PAR value, the
new value, followed by the .ncd value in parentheses, is displayed. When you
save the change, all values in parentheses are cleared.

Placement Assignments Made by PAR Placement assignments made by
the Place & Route process (PAR) are displayed in blue font or in the color
designated for “Default Value” in the Options dialog box. Pin and bank
assignments are displayed in parentheses and appear only once. All other
assignments are displayed twice: once normally and once in parentheses.
When you edit the value for one of these assignments, the font color is
changed to black, or the “Normal Value” color. The value you assigned then
appears without parentheses, followed by the PAR-assigned value in
parentheses.
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When you edit preferences after placement and routing and save them, the
PAR-generated assignments are cleared from Spreadsheet View and only the
assignments from the source or .Ipf file are displayed. The “Display 10
Placement” command is then unavailable until you rerun Place & Route.

Hiding Default Values

You have the option of hiding the default values shown on the Port
Assignments, Pin Assignments, and Global Preferences sheets. Hiding the
default values narrows the display to preference, source, and read-only
values. When turned on, default values are displayed in blue font, or in the
font color that you have designated for “Default Values” in the Options dialog
box. You can hide them and display them again at any time.

To hide or display default values:
Choose View > Show Default Value
This command acts as a toggle key and turns the display of default values
on or off. A check mark indicates that they are to be displayed.

After placement and routing, if “Display IO Placement” is enabled, all
assignments written to the .ncd file by Place & Route (PAR) are displayed in
the default font color on the Port Assignments and Pin Assignments sheets.
Each PAR-assigned value is displayed inside parentheses to distinguish it
from a default value.

Adding Preferences from the Toolbar

You can quickly add timing preferences, a grouping assignment, or a Vref
location by clicking the appropriate preference button on the toolbar. After you
add the new preference, it is displayed in the appropriate preference sheet.

To add a new preference using the Spreadsheet View Toolbar:

1. Click the preference toolbar button for the preference you want to add:
& adds a BLOCK preference.
UL adds a PERIOD or FREQUENCY preference.

adds an INPUT_SETUP or CLOCK_TO_OUT preference.

R

adds a MULTICYCLE preference.

adds a MAXDELAY preference.

'3

| adds a DEFINE GROUP preference for a cell, port, or ASIC group.

= adds a LOCATE VREF preference.

2. Inthe preference dialog box, specify the parameters and click Add or OK.
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The new preference is displayed in the Timing, Group, or Misc preference
sheet.

Using Filters and Wildcards

The preference dialog boxes of Spreadsheet View provide a quick way to
locate and filter design elements such as PORT, NET, ASIC PIN, and CELL
objects. Many of the filters in these dialog boxes enable you to use wildcards
to specify multiple elements that you want included in a single preference.
Wildcards can be especially useful in large designs, because they reduce the
number of preferences and conserve memory.

In the following example, the expression phase ¢ {1,3,5} istyped in the
Block Preference filter. When the Go button is clicked, only the three nets in
the Available Nets list is displayed.

¥ Block Preference

Tvpe

(%) Block Mets () Block Path For Groups

Available hets:
[ a phase_c_1

| "la phase_c_3
| "La phase_c_5

Filker: |phase_c_{1,3,5¢ :

Clicking OK adds the preference with the wildcard expression as a single item
to the existing BLOCK Preference list. It will be added as a single preference
to the logical preference file with the Save command.

Note

Wildcard notation is not available with all preference parameters. See the individual
preference descriptions in the “Constraints Reference Guide” on page 1133 for
wildcard support.

Filter and Wildcard Support in Spreadsheet View Filters and wildcard
expressions are supported in the following preference dialog boxes:

Block

Group Assignment
INPUT_SETUP/CLOCK_TO_OUT
MAXDELAY
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MULTICYCLE
PERIOD/FREQUENCY

Wildcard Expressions The following basic wildcard expressions can be
used with filters:

* Match any (zero or more) characters.
? Match any single character.
?+ Match one or more characters.

{...} Match the enclosed list or range. The range can include a string of
characters separated by commas, a lexical range separated by a dash (-),
or an integer range separated by a colon (©).

{...}*+ Match one or more occurrences of any character from the
preceding list.

For more detailed information about wildcard expressions and syntax, see
“Using Wildcard Expressions in Preferences” on page 517.

Package View

Package View shows the pin layout of the device and displays the
assignments of signals to device pins. Package View interacts with Netlist
View for assigning pins, enabling you to drag selected signals to the desired
locations on the pin layout to establish LOCATE preferences. Each pin that is
assigned with a LOCATE preference is color-coded to indicate the port
direction of the related signal port. Package View allows you to edit these
assignments, and it allows you to reserve sites on the layout that you want to
exclude from placement and routing.

Banks and pin types are differentiated by color on the layout. You can use the
Color Legend dialog box, available from the Package View toolbar, to view
and change the default color coding. You can also use the Pin Display
Selection dialog box to filter the display so that only certain banks and pin
types are shown.

As you move your mouse pointer slowly over the layout, pin descriptions and
locations are displayed in tool tips and in the status bar. The “View > Show
Differential Pairs” command displays fly wires between differential pin pairs
and identifies the positive differential pins with a magenta-colored + indicator.

Package View is available as soon as the target device has been specified.
See Also »“Assigning Signals Using Package and Netlist Views” on
page 454
“Modifying Signal Assignments in Package View” on page 455
“Migrating Pin Assignments” on page 468
“Selecting a Device for Possible Pin Migration” on page 468

“Displaying Incompatible Pins” on page 413
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“Using the Zoom and Pan Tools” on page 438

Using the “Show” Commands

The View menu in Package View provides two groups of “Show” commands.
The first group consists of commands that are mutually exclusive; when one
command is activated, the others become inactive. The second group
consists of commands that are not mutually exclusive; they can be activated
at the same time that another “Show” command is active.

In addition to the View menu, the “Show” commands are available from the
pop-up menu when you right-click a blank space on the Package View layout.

Mutually Exclusive Commands When one of the following commands is
activated, the other three are made inactive:

Show Bank 10

Show Port Groups

Show DQS Groups

Show SSO View
Non-mutually Exclusive Commands The following commands can be
activated while another “Show” command is active:

Show Pin Display Selection Dialog

Show Differential Pairs

Show Incompatible Pins

Show Placement

Displaying Bank 1/0O Assignments

By default, Package View displays any assigned 1/Os within each color-coded
bank. The bank I/O display is turned off, though, when the display for Port
groups or DQS groups is turned on.

To display bank 1/Os:
In Package View, choose View > Show Bank IO
The I/O assignments are displayed within each bank. Port groups, DQS
groups, and SSO View are hidden.

See Also »“Displaying Incompatible Pins” on page 413

Displaying Port Groups

Package View enables you to view the placement of assigned port groups on
the pin layout. Each port group is color-highlighted with the same distinctive
color that is displayed in the Group sheet of Spreadsheet View.

Lattice Diamond 3.6 Help

411



APPLYING DESIGN CONSTRAINTS : Using Diamond’s Preference Views

To display port groups:
In Package View, choose View > Show Port Groups.

The color-coded port groups are displayed. Bank 1/O assignments, DQS
groups, and SSO View are hidden.

Displaying DQS Groups
You can view the placement of DQS groups in color-coded format on Package
View's pin layout by turning on the “Show DQS Groups” command.

To display DQS Groups:
In Package View, choose View > Show DQS Groups.

The color background of each DQS group is displayed. Bank I/O
assignments, port groups, and SSO View are hidden.

Displaying SSO View

The “Show SSO View” command, available from Package View, displays the
output pins that have been selected for SSO analysis. Tool tips for each pin
provide SSO details. Output pins that passed SSO analysis are color-coded
green; those that failed are color-coded red. This command also opens the
SSO report in the Output window.

To display the SSO View:
In Package View, choose View > Show SSO View.

The SSO analysis output pins are displayed, color-coded according to
pass or fail status. Bank I/O assignments, port groups, and DQS groups
are hidden. The tool tip for each SSO pin includes information from the
SSO Analysis Report.

Displaying Differential Pin Pairs

Package View’s “Show Differential Pairs” command enables you to identify all
the differential pin pairs on the layout. When this command is activated, fly
wires are displayed that connect the differential pin pairs. Each unplaced
positive differential pin displays a small magenta-colored cross in the upper
right corner. By default, these indicators are hidden.

To display differential pin pairs:
In Package View, choose View > Show Differential Pairs.

The layout displays the fly wires connecting differential pins and the cross
indicator for each positive differential pin.
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The “Show Differential Pairs” command acts as a toggle key and displays
a check mark when the differential pair fly wires are displayed. To turn off
the display, select the command again to remove the check mark.

Displaying Incompatible Pins

The “Show Incompatible Pins” command opens a dialog box that enables you
to select one or more devices of the same family and package and then view
the pins on the layout that would not be available or would have a different
function were you to switch devices.

To display incompatible pins on the pin layout:

In Package View, choose View > Show Incompatible Pin, and in the
dialog box, select one or more devices and click OK.

Package View displays each incompatible pin with a dark circle behind the
pin square.

C)

See Also »“Migrating Pin Assignments” on page 468

“Selecting a Device for Possible Pin Migration” on page 468

Displaying I/O Placement Assignments in Package
View

After placement and routing, Package View enables you to examine all pin
assignments that have been written to the native circuit description file (.ncd),
including those made by Place & Route (PAR). A rotated square in the
background of each placed pin serves as a placement indicator when the
“Display 10 Placement” command is turned on. The pin assignments that
originated from the logical preference file (.Ipf) are displayed with a color fill to
distinguish them from PAR-assigned pins.

To display I/0 Placement assighments in Package View:

In Package View, choose View > Display 10 Placement or click the
Display 10 Placement button j« on the toolbar.

A rotated square appears in the background of each placed pin. PAR-
assigned pins are displayed with no color fill.
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W

Pin assignments that originated from the .Ipf file are displayed with a color
fill.

&

The “Display 10 Placement” command acts as a toggle key and displays a
check mark when the assignments are displayed. To turn off the display,
select the command again to remove the check mark.

When you edit pin assignments after placement and routing and save them,
the placement indicators are cleared from Package View. The “Display 10
Placement” command is then unavailable until you rerun Place & Route.

Changing the Default Color Coding

The color coding in Package View is used to differentiate each bank and each
type of pin. You can easily view the significance of each color by opening the
Color Legend, which is available on the Package View toolbar. The Color
Legend dialog box also enables you to change the default color coding for
banks and pin types.

To change the default color coding for banks and pins:
1. Click the Color Legend button [ on the Package View toolbar.
2. Inthe dialog box, select the Banks or Pins tab.

3. Click the color box in front of the desired bank or pin type that you want to
change.

4. In the Select Color dialog box, select a different color and click OK.

If you want to change more than one color, click Apply in the Color
Legend dialog box, and then repeat Steps 3 and 4. To revert to the default
colors, click Restore Defaults.

6. When you have finished color editing, click Close.

Filtering the Display of Banks and Pin Types

When you open Package View, it shows all banks and pin types by default.
You can use the Pin Display Selection dialog box to filter the banks and pin
types so that only selected banks and pin types are displayed.

To filter the display of banks and pin types in Package View:

1. In Package View, choose View > Show Pin Display Selection Dialog or
click the Pin Display Selection button §# on the toolbar.

2. Do one of the following:
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To eliminate the display of a few items, clear the check mark in front of
each item that you do not want displayed.

To filter the display so that just a few items are displayed, click Clear
All, and then select the banks and pin types that you want to see
displayed. At least one bank must be selected.

For example, to display only the dual function pins that are available in
Bank 5, you would click Clear All, and then you would select Bank 5
in the Visible Banks section and Dual Function in the General
Purpose section.

3. Click Close.

Package View displays only the items that you selected.

To re-display all banks and pin types:

Reopen the Pin Display Selection dialog box, click Select All, and then
click Close.

Package View displays all items.

When you close Package View and re-open it, it automatically reverts to the
default view and displays all banks and pin types.

See Also “Using the “Show” Commands” on page 411

Reversing the Pin Layout View

You can reverse the view of Package View 's device pin layout from a bottom
to a top perspective or vice versa.

To reverse the pin layout view:
In Package View, choose View > Top View or View > Bottom View.

The View command acts as a toggle key and changes to its opposite,
depending on the current view.

Device View

Device View provides an alphabetized index of device resources based on
the target device. Statistics in Device View include:

DCS blocks

Assignable PIO cells, categorized by bank
IOLOGIC sites

PFF and PFU slices

DQS blocks

PCS blocks

sysDSP blocks
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sysMEM blocks

PLL and DLL blocks

DDR support with bonded DQS, categorized by bank

Other embedded ASIC blocks.
The right-click menu of Device View enables you to assign PROHIBIT
preferences for sites that you want to exclude from placement and routing.

From Device View, you can cross-probe selected resources to their sites in
Package View, Floorplan View, and Physical View.

Device View is available as soon as the target device has been specified.

See Also »“Reserving Sites” on page 508

Netlist View

Netlist View displays the design elements of the post-synthesis native generic
database (NGD) netlist. The NGD is a binary speed-optimized data structure
that is used by the system to browse the logical netlist. Netlist View organizes
the netlist by ports, instances, and nets, and it provides a toolbar button and
design tree view for each of these categories. Each design tree view is
equipped with utilities for filtering the list and searching for elements. Netlist
View enables you to set location, timing, and group preferences.

Ports design tree

Right-click selected signals to assign pin locations, create port groups, or
assign INPUT_SETUP and CLOCK_O_OUT preferences.

Drag selected signals to Package View to assign them on the pin layout.

— Instances design tree

Right-click selected instances to create UGROUPSs. Right-click selected
registers to create cell groups or UGROUPs.

Drag registers to the Cell Mapping sheet of Spreadsheet View to specify
registers for flip-flops.
1, Nets design tree

Right-click a selected clock net to set a PERIOD or FREQUENCY
preference. Right-click a selected net to set a BLOCK preference.

Drag selected nets to Spreadsheet View's Route Priority sheet to prioritize
them.

Netlist View is available after synthesis and translation.

See Also  »“Modifying Pin Assignments Using Netlist View” on page 453
“Assigning Signals Using Package and Netlist Views” on page 454
“Creating UGROUPSs” on page 492
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“Setting Timing Preferences in Netlist View” on page 486

“Setting LOCATE Preferences in Floorplan View” on page 472

NCD View

NCD View, available after a successful run of Place & Route, provides a
categorized index of synthesized design resources and consumption based
on the target device and the in-memory native circuit description (NCD)
database. Statistics cover System P10s, User PIOs, PFUs, PFFs, sysDSP
blocks, sysMEM blocks, IOLOGIC, PLL/DLLs, and other embedded ASIC
blocks.

NCD View is organized by nets and instances and provides a toolbar button
and design tree view for each of these categories. Each design tree view is
equipped with utilities for filtering the list and searching for elements.

= Instances design tree

Right-click selected instances to create a new UGROUP or to view logic
details in Logic Block View.

Cross-probe selected instances to Netlist View, Floorplan View, or
Physical View; and cross-probe PIO instances to Package View.

1, Nets design tree

Right-click a selected net to view the connection in Floorplan View or the
complete physical path in Physical View

See Also »“Viewing Logic Details of Components” on page 432

“Creating UGROUPSs” on page 492

Floorplan View

Floorplan View provides a large-component layout of your design. It displays
user constraints from the logical preference file (.Ipf) and placement and
routing information. All connections are displayed as fly-lines. Floorplan View
allows you to create REGIONs and bounding boxes for UGROUPs and
specify the types of components and connections to be displayed. As you
move your mouse pointer slowly over the floorplan layout, details are
displayed in tool tips: the number of resources for each UGROUP and
REGION; the number of utilized slices for each PLC component; and the
name and location of each component, port, net, and site.

If your design contains partitions, for the incremental design flow, you can
display and edit the partitions in Floorplan View. See “Floorplan View and
Physical View Partition Support” on page 663 for details.

Floorplan View is available as soon as the target device has been specified.

See Also »“Creating UGROUPS” on page 492
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“Creating a REGION” on page 502

“Setting LOCATE Preferences in Floorplan View” on page 472
“Viewing Logic Details of Components” on page 432

“Using Incremental Design Flow” on page 640

“Using the Zoom and Pan Tools” on page 438

Displaying Assignments and Connections

The Floorplan View toolbar allows you to select the types of elements that will
be displayed on the layout, including REGIONs, UGROUPs, placed
components, and component connections. These commands are also
available from the View menu.

Display Placement — displays all placed components, including
assignments originating from the logical preference file (.Ipf) and those made
by Place & Route. The Display Placement button controls the Display
Placement Group button, the Display Congestion button, and the three
Display Connection buttons below it. It must be active in order for group
member components, routing congestion, and component connections to be
displayed.

[ Display Placement Groups — highlights the placed UGROUP component
sites with the designated color fill.

j":: Display Congestion — Displays a representation of the amount of routing
congestion for a PLC component or site. When Display Congestion is turned
on, a highlighted rectangle overlays the site. The thickness of the rectangle
represents the percentage of congestion for the row and column location. The
tool tip for the location shows the precise percentage of congestion.

.. Display Connections To/From Selection(s) — This command controls the
two Display Connections buttons below it. When active, it enables you to
activate one or both of these buttons to view the connections between

selected components, outside of selected components, or both:

.., Display Connections Between Selection(s) — shows the connections

between selected components.

... Display Connections Outside of Selection(s) — shows the

connections that extend outside of the selected components.

Display Placement Preferences — shows placement assignments that
originated from the .Ipf file. When this button is active, placed components
assigned with a LOCATE preference are distinguished with a cross-hatch
pattern.

Note

The Display Placement Preferences button must be active in order to access the
editing commands for creating or editing a UGROUP or REGION, prohibiting a site, or
setting a LOCATE preference.
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The Display Placement Preferences button also controls the three buttons
below it. These buttons enable you to view REGIONs and UGROUPs and the
logical connections between them.

(i Display REGIONSs — shows the bounding boxes of REGIONSs that

exist in memory or in the logical preference file.

(L} Display UGROUPs — shows the bounding boxes of UGROUPs that
exist in memory or in the logical preference file.

}"f Display Logical Connections — shows the logical connections
between UGROUPs, including those assigned to REGIONS, and between
UGROUPs and assigned PIO sites. The connections are based on the
logical instances within each UGROUP.

Note

Connections in Floorplan View are displayed at a high level of abstraction and do
not reflect the complete physical path. When you cross-probe a delay path from
Timing Analysis View, Floorplan View displays the delay path connection, but it
does not enable you to cross-probe the path to other views. To examine the
physical path, cross-probe from Timing Analysis View to Physical View instead of
Floorplan View.

) Displays partitions that are included in an incremental design flow.

See Also
“Using the Zoom and Pan Tools” on page 438
“How Assignments are Displayed in Floorplan View” on page 419
“Display of FPGA Elements” on page 424

“Using Incremental Design Flow” on page 640

How Assignments are Displayed in Floorplan View

Floorplan View displays assignments from the logical preference file (.Ipf) at
any stage of the design flow. These can include assigned sites, UGROUPSs,
REGIONSs, and reserved resources. After routing, it displays all placements
assigned by the Place & Route process, as well as assignments originating
from the .1pf file.

The “Display” commands on the toolbar or the View menu control the display
of assignments. The types of assignments displayed will depend on whether
the commands “Display Placement,” “Display Placement Preferences,” or
both are activated.

Assigned Sites After placement and routing, a site to which a component
has been assigned appears on the layout with a solid fill.
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Figure 69:

]

If the assignment originated from the logical preference file or the HDL
source, the site will be filled and overlaid with a cross-hatch pattern when both
“Display Placement” and “Display Placement Preferences” are activated.

Figure 70:

When only “Display Placement Preferences” is activated, an assignment
originating from the logical preference file or HDL source is displayed with the
cross-hatch pattern but without the fill.

Figure 71:

[

Reserved Sites Sites reserved with the PROHIBIT preference are
displayed with a gray pattern.

Figure 72;

]

PLC Blocks (PFU and PFF) After placement and routing, a programmable
logic cell (PLC) in which one or more logical components have been placed
will appear on the layout with a solid fill until you zoom in. The color fill will be
darker or lighter in shade, depending on how many sites are used.

Figure 73:

1 slice used

2 slicesused —— | magza RIC24 . —— 3 slices used

As you zoom in so that individual slices are visible, only the slices that contain
placed logical components are displayed with a color fill.
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Figure 74:

R3C220

_\ Assigned slices in close-up

R3 G230 view of PLC block

- e

When Display Congestion is turned on, a highlighted rectangle is displayed
that represents the amount of congestion for the row and column location.
The tool tip shows the precise percentage of congestion.

Figure 75:

|Site RBCZ2D, 25.00% congested

FRCI0

UGROUPs Anchored UGROUPs are displayed when both the “Display
Placement Preferences” and “Display UGROUPs” commands are activated.
An anchored unbounded UGROUP is indicated with a small square icon at
the upper left of the assigned anchor location. The icon becomes visible as
you zoom in. .:1

A bounded UGROUP is displayed with a solid border, corresponding to the
assigned width and height, and a dotted pattern between blocks. UGROUPs
are distinguished from one another by their designated colors. After
placement, the sites that contain the member elements of the UGROUP are
filled with the designated color when the “Display Placement Groups”
command is activated.

Figure 76:
R3CES =g i R 2 F2osds
RaC s REC 4G RIOCHZ | | F30CH3
Bounded UGROUP Placed UGROUP members

REGIONs REGIONSs are displayed when both the “Display Placement
Preferences” and “Display REGIONs” commands are activated. A REGION
bounding box is shown with a solid border and a solid fill between blocks. It is
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Figure 77:

Note

To quickly view the color legend for all UGROUPs or REGIONS in the design, click the
color legend button on the toolbar, and then select the UGROUPs or REGIONs
tab.

distinguished from other REGIONS by its designated color. When a REGION
is reserved with the Prohibit command, it is overlaid with a gray dotted
pattern.

REGION

Reserved REGION

See Also »“Displaying Assignments and Connections” on page 418
“Assigning Signals” on page 449
“Creating UGROUPSs” on page 492
“Creating a REGION” on page 502
“Reserving Sites” on page 508
“Reserving REGIONSs” on page 509
“Setting LOCATE Preferences in Floorplan View” on page 472
“Floorplan View and Physical View Partition Support” on page 663

Viewing and Changing the Color Coding

The Color Legend dialog box in Floorplan View provides a color map of items
such as sites and connections, plus all UGROUPs and REGIONSs that are in
the design. It enables you to quickly edit the color of each of these items. You
can also change the color of a UGROUP or REGION by using the pop-up
menu on the floorplan layout.

To view and edit the color coding:
1. Click the Color Legend button on the toolbar.

The Floorplan View Color Legend shows three tabs: Item Types, which
displays the colors of connections, selected items, and types of sites;
UGROUPs, which shows the color coding of each UGROUP preference in
the design; and REGIONSs, which shows the color coding of each
REGION preference in the design.
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2. Select the tab for the category that you want to view or change.

3. Click the color box in front of the UGROUP, REGION, or item type that you
want to change.

4. Select a color from the Select Color dialog box and click OK.

If you want to change more than one color, click Apply in the Color
Legend dialog box, and then repeat Steps 3and 4. To revert to the default
colors for sites or connections, click Restore Defaults.

6. When you have finished color editing, click Close.

To change the color of a UGROUP or REGION from the pop-up menu:

1. On the floorplan layout, select the UGROUP or REGION that you want to
change.

2. Right-click the selection and choose Edit Color. Select a color from the
Select Color dialog box and click OK.

Going to a Specific Site
Floorplan View provides a “Go To Location” dialog box for quick navigation to
a specific column and row on the layout.

To go to a specific site:

1. In Floorplan View, right-click an empty space on the layout and choose Go
to Location.

2. Inthe dialog box, enter the desired Row and Column.
3. Click OK.

Floorplan View zooms in to the location you specified.

See Also »“Using the Zoom and Pan Tools” on page 438

“Searching for Design Elements” on page 439
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Display of FPGA Elements

The following table describes the graphical representations of FPGA
component blocks and ports that are visible on the floorplan layout. These
elements can be cross-probed between Device View’s categorized list and

Floorplan View. For complete information about FPGA logic design primitives,

see the “FPGA Libraries Reference Guide” on page 1571.

Table 22: FPGA Elements

Object

ALU

AMBOOT

CIBTEST

CLKDIV

CLKDIVTEST

CLKFBBUF

DCC

Assignable

Yes

Yes

No

Yes

No

Yes

No

Note

FPGA elements that are specific to certain devices are so noted below the description.

Description Location syntax
Arithmetic Logic Unit, configurable as a 24-bitor = R<row> C<column>
54-bit ternary adder/subtractor.

ECP5, LatticeECP3

Automatic multiple boot that enables the AMBOOT

LatticeECP3 device to reconfigure itself upon SED
failure.

LatticeECP3

Common interface block test. CIBTEST blocks are

used for internal hardware testing only. CIBTESTs

are positioned around the chip and in rows near

special blocks such as EBRs, MULTs, and MACs.

Clock divider block. LatticeECP2/3

ECP5, LatticeECP2/3, LatticeSC/M, LatticeXP2, = R<row> C<column>
MachX02, MachXO3L, Platform Manager 2 LatticeSC/M

CLKDIV1A, CLKDIV1B,
CLKDIV1C, CLKDIV1D

MachX02
TCLKDIVO, TCLKDIV1
BCLKDIVO, BCLKDIV1

Clock divider block test. Used for internal
hardware testing only.

Clock feedback buffer that provides a dummy CLKFBBUFO
feedback delay between PLL clk output and PLL ~ CLKFBBUF1
fb port. Two are provided per device (1k and

above)

MachX02, MachXO3L, Platform Manager 2
Dynamic Quadrant Clock Enable/Disable. For
internal use only.

ECPS5, LatticeECP3, MachX02, MachXO3L,
Platform Manager 2
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Table 22: FPGA Elements

Object Assignable  Description Location syntax

DCM Yes Dynamic clock MUX incorporating a multiplexer DCM6, DCM7
function, for primary clock tree bank 6 and 7.

MachX02, MachXO3L, Platform Manager 2

DCS Yes Dynamic clock select, a global clock buffer For most devices:
incorporating a §mart multlplgxer function. The ULDCO, ULDC1
DCS takes two independent input clock sources
. . URDCSO0, URDCS1
and avoids glitches or runt pulses on the output
lock dl f when th ble sianal i LLDCSO, LLDCS1
clock regardless of when the enable signal is LRDCSO0, LRDCS1
turned on.

ECPS5, LatticeEC, LatticeECP/2/M, LatticeECP3,
LatticeSC/M, LatticeXP/2 “M_DCS” SITE “LLDCS1”

where:

UL is upper left
UR is upper right
LL is lower left
LR is lower right

For LatticeSC and
LatticeSCM devices:

DCSTA, DCSTB
DCSLA, DCSLB
DCSRA, DCSRB
DCSBA, DCSBB

Example:

Example:
“U_DCS” SITE “DCSTA”

where:

DCST is top
DCSL is left
DCSR is right
DCSB is bottom

DLL Yes Delay-locked loop, a digital circuit used to perform R<row> C<column>
clock management functions on and off the chip. For LatticeSC and
LatticeSCM devices:

DLL_[UL][UR][LL][LR]C[CDE
F]

Example: DLL_LLCC
where:

UL is upper left, UR is upper
right,

LL is lower left, LR is lower
right

C is component

DLLDEL Yes Slave delay line for generating the desired delay in R<row> C<column>
DDR/SPI4 applications.

ECP5, LatticeECP2/M, LatticeECP3, MachXO2,
MachXO3L, Platform Manager 2
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Table 22: FPGA Elements

Object Assignable
DQS Yes
DQSDLL Yes

DQSDLLTEST No

EBR Yes

ECLKBRIDGECS Yes

ECLKSYNC Yes
EFB Yes
FSLICE Yes

Description

Data strobe signal block that provides the required
clock alignment for DDR memory interfaces.

Not available for LatticeSC/M

Delay-locked loop block for the data strobe signal.
The DLL generates a 90-degree phase shift
required for the DQS signal in DDR memory
interfaces.

LatticeECP2/3, LatticeXP2, MachX02,
MachXO3L, Platform Manager 2

Delay-locked loop for data strobe signal test. Used
for internal hardware testing only.

Embedded Block RAM, a large dedicated fast
memory block that can be configured as ROM or
RAM.

Edge clock bridge clock select, a high-speed clock
bridge that takes the high-speed edge clock
sources from the top and bottom.

ECP5, MachX02, MachXO3L, Platform Manager
2

Edge clock synchronization block for DDR
memory.

ECP5, LatticeECP3, MachX0O2, MachXO3L,
Platform Manager 2

Embedded function block for a hard IP. For the
MachXO2 device, it contains a SPI, two 12Cs, and
a timer/counter peripheral. The block is connected
to a WISHBONE bus in slave mode.

MachX02, MachXO3L, Platform Manager 2

One of four interconnected slices in a
programmable fast functional unit (PFF). Each
FSLICE is capable of logic, ripple, and ROM
modes of operation but not RAM. FSLICE sites
are displayed in white by default.

Location syntax

LDQS<row> RDQS<row>
TDQS<column>
BDQS<column>

where:
L is left, R is right
T is top, B is bottom.

LDQSDLL, RDQSDLL

where:
L is left, R is right

EBR_R<row> C<column>
Example: EBR_R27C56

ECLKBRIDGECSO,
ECLKBRIDGECS1

LECLKSYNC1,
LECLKSYNC2,
TECLKSYNCL1,
TECLKSYNC2,
RECLKSYNC1,
RECLKSYNC2,
BECLKSYNC1,
BECLKSYNC2

WHERE:
L is left, R is right,
T is top, B is bottom

EFB

R<row> C<column>
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Table 22: FPGA Elements

Object Assignable
IOL or IOLOGIC Yes
JTAG N/A
M[3:0] Yes
MAC Yes
MACO Yes
MULT Yes
PCNTR Yes
PCS Yes,
when not

connecting to
a system bus

Description

Input and output logic blocks.

Joint Test Action Group Controller. It provides the
control and interconnect circuit used by the
boundary scan function

Non-JTAG dedicated configuration mode select
pads.

LatticeSC/M

Multiply-accumulate block.

LatticeECP/2/3, LatticeECP2M, LatticeSC/M
Mask array for cost optimization block, an ASIC
block for implementing various functions.
LatticeSCM

Multiplier digital signal processing block that
implements a multiply with no addition or
accumulator nodes.

ECPS5, LatticeEC, LatticeECP/2/3

Power Controller block.
MachX02, MachXO3L, Platform Manager 2
Physical coding sublayer. When connected to a

system bus, the interconnect to the system bus
determines the location.

ECPS5, LatticeSC/M, LatticeECP3

Location syntax

L<row>A|B

R<row> A|B

T<column> A|B B<column>
A|B

where:

L is left, R is right,
T is top, B is bottom

JTAG

The configuration mode pads
can be assigned as user
input by pin name.

Example:

LOCATE COMP
“USERINPUT1” SITE “K23,

R<row>
C<column>

MACO blocks must be
located as shown in the
logical preference file
provided for each Lattice
MACO IP.

Example:

LOCATE COMP
“spi4_256c¢h/s4dp/s4dp_hc”
SITE “LLMACOOQ”;

MULT9|MULT18|MULT36

R<row> C<column>

PCNTR

If not connecting to a system
bus, the PCS should be
assigned as described in the
PCS application note.

Example:

LOCATE COMP
“pcs_instance_name_in_hier
archy” SITE “PCS36000";
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Table 22: FPGA Elements

Object Assignable
PERREG Yes
PICTEST No

PIO (P) Yes

PLL Yes
PLLREFCS Yes
PRADD Yes
RESETN Yes

Description

Persistent User Register. Stores information from
16-bit registers and keeps the data intact during
reconfiguration.

LatticeECP3

Programmable interface cell test, used for internal
hardware testing only.

Programmable input-output block, often
accompanied by an IOL or IOLOGIC block, that
provide high-speed I/O registers and buffering to
support a variety of signal interface standards.
Two PIOs connected to syslO buffers are the
physical blocks of programmable interface cells
(PICs).

Phase-locked loop, a block with a voltage- or
current-driven oscillator that is constantly adjusted
to match in phase and therefore lock on the
frequency of an input signal.

PLL reference clock select, which supports
dynamic reference clock switching.

ECP5, MachX02, MachXO3L, Platform Manager
2

Pre Adder for DSP block
ECP5

Non-JTAG dedicated configuration res et input
pad. RESETN is assigned to the specific input
shown in the device's data sheet.

LatticeSC/M

Location syntax

PERREG

L<row>A|B|C|D
R<row> A|B|C|D
T<column> A|B|C|D
B<column> A|B|C|D
where:

L is left, R is right,
T is top, B is bottom

Note: Generally, PIOs should
be located by their external
pin names. For example,
AK47

R<row> C<column>

For LatticeSC and
LatticeSCM devices:

PLL_[UL]J[UR][LL][LR]C[AB]
Example: PLL_LLCA
where:

UL is upper left, UR is upper
right,

LL is lower left, LR is lower
right

C is component

LPLLREFCS (for 1k and
above)
RPLLREFCS (for 4k and
above)

R<row> C<column>

Example:

LOCATE COMP
“USERINPUTRESETBAR”
SITE “H5";
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Table 22: FPGA Elements

Object
SED

SLICE

SPLL
STF

TSALL

Assignable  Description Location syntax

Yes

Yes

Yes

Yes

Yes

Soft error detect, an IP that checks for changes in SED
the state of a configuration SRAM bit due to

colliding alpha or neutron particles. The soft error

detect IP can be set to automatically reconfigure

the device on error.

ECPS5, LatticeECP2/3, LatticeXP2, MachXO2,
MachXO3L, Platform Manager 2

One of four interconnected slices in a R<row>C<column>
programmable functional unit (PFU). Each SLICE A|B|C|D

is capable of logic, ripple, ROM, and RAM modes

of operation. By default, SLICE sites are displayed

in lavender.

Simple phase-locked loop. R<row>C<column>
Store to flash block for user flash module (UFM) STF

operations.

LatticeXP2

Tri-state all, an element that puts all TSALL

programmable input cells on the device in a tri-
state condition.

MachXO, MachX02, MachXO3L, Platform
Manager, Platform Manager 2

Physical View

Physical View provides a read-only detailed layout of your design that
includes switch boxes and physical wire connections. Routed connections are
displayed as Manhattan-style lines, and unrouted connections are displayed
as flylines. As you move your mouse slowly over the layout, the name and
location of each REGION, group, component, port, net, and site are displayed
as tool tips.

Displaying Components and Connections The Physical View toolbar
allows you to select the types of elements that will be displayed on the layout.

«» Displays local wires, those that expand across several blocks.
j Displays long wires, those that expand over a large area of the chip.

4 Displays pin wires, short wires that are used to connect two or more net
pIns.

Displays switch boxes, switching matrix resources located at the
junctions of horizontal and vertical local lines.

@ Displays switches, contact points employed for signal switching between
resources on the chip.
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it Displays sites, unused or vacant blocks to which logic can be assigned.

# Displays components, blocks that have assigned logic.
* " Displays routes, physical connections between resources on the chip
after the design has been routed.

1~ Displays unrouted nets, those that PAR failed to route or those that could
not be routed because a site associated with a net was unlocked by the user.

Displays the latest timing path selected in Timing Analysis View.

Displaying UGROUPs and REGIONs The Physical View toolbar also
enables you to display or hide UGROUPs and REGIONSs that exist in memory
or that have been saved to the logical preference file.

(i) Display REGIONSs — shows the bounding boxes of REGIONSs.
(L} Display UGROUPs — shows the bounding boxes of UGROUPs.

Highlighting Elements Use the View menu’s Highlight/Unhighlight
commands to highlight selected nets or sites or to remove the highlighting.

Viewing Highlighted Items, Prohibited Sites, and Labels Use the View
menu’s Layer commands to display highlighted items, prohibited sites, and
the textual labels of sites and components.

Note

When the text display has been turned on, a label will sometimes overlap the edge of
the symbol or even appear aligned with the symbol below it. However, when you hold
the mouse pointer over the symbol, the correct label will appear in the tool tip.

Displaying Partitions If your design includes partitions for the incremental
design flow, you can display them in Physical View. See “Floorplan View and
Physical View Partition Support” on page 663 for details.

See Also »“Viewing Logic Details of Components” on page 432

i

“Auto Cross-probing Between Floorplan, Physical, and Logic Block Views'’
on page 437

“Using Incremental Design Flow” on page 640

“Using the Zoom and Pan Tools” on page 438

Logic Block View

Logic Block View enables you to examine logic details of one or more placed
and routed components. It provides either a schematic or tabular view,
depending on the type of component selected.
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Schematic views of PIO and PFU/PFF components can be accessed from
NCD View, Floorplan View, and Physical View. Tabular views of PLL, EBR,
and DSP blocks can be accessed from Floorplan View and Physical View.

See Also »“Viewing Logic Details of Components” on page 432

“Auto Cross-probing Between Floorplan, Physical, and Logic Block Views”
on page 437

“Using the Zoom and Pan Tools” on page 438

Opening Logic Block View

You can open a schematic Logic Block View from Floorplan View, Physical
View, or NCD View. Schematic views are available for PFU/PFF slice
components or PIO components. For tabular views of EBR, PLL, and DSP
components, you must use either Floorplan View or Physical View.

To open a Logic Block View from Physical View or Floorplan View:

1. Using the zoom tool, enlarge the area that contains the components you
want to examine; or cross-probe to a single component from Netlist View
or NCD View.

2. Select one or more components, right-click, and choose Logic Block
View from the pop-up menu. Alternatively, double-click a single
component to open it in Logic Block View.

To open a schematic Logic Block View from NCD View:
1. Select the Instances folder in NCD View.

2. From the Instances design tree, select one or more instances that you
want to examine.

3. Right-click the selected instances and choose Logic Block View.
The Logic Block View opens in the main window. If you selected multiple

components, the multiple views will be arranged in tabs at the top of the main
window.

See Also »“Changing the Maximum Number of Logic Block Views” on
page 431

“Exporting an Image of a Schematic Logic Block View” on page 433

Changing the Maximum Number of Logic Block

Views

You can use the Options dialog box to change the number of Logic Block
Views that can be open at the same time. The default maximum number is 15,
but you can change it to a lower number or increase it up to 25.
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To change the number of Logic Block Views that can be open at the
same time:

1. Choose Tools > Options.
2. Inthe Options dialog box, select Physical View, and then select General.

3. Inthe right pane, enter the desired number in the text box for “Maximum
number of Logic Block Views can be opened (1-25),” and click OK.

Viewing Logic Details of Components

Logic Block View provides either a schematic or a tabular view, depending on
the type of component selected.

Viewing Schematic Details of I/Os and PFUs The schematic Logic Block
View displays color-coded details for device elements 10B, 10L, and PFU/
PFF.

To view more details of a schematic Logic Block View:
Use the zoom buttons to enlarge the display.

Double-click a LUT to view a list of look-up table equations. Alternatively,
select a LUT and click the EQU button on the vertical toolbar.

Hold the mouse pointer over schematic symbols to view information in tool
tips.

Viewing Tabular Details of PLL, EBR, and DSP Blocks The Logic Block
View presents a tabular version of details for sysCLOCK PLL, sysMEM EBR,
and sysDSP blocks and illustrates the device element programming. It lists
the properties and shows the features that are enabled and the values for
each. It also lists all physical site pins associated with the DSP block and
includes port names.

For more detailed information on the types of blocks displayed in the tabular
Logic Block View, see the following references:
sysPLL How to Design with sysCLOCK PLLs and DLLs

TN1263, ECP5 sysCLOCK PLL/DLL Design and Usage Guide

TN1049, LatticeECP/EC and LatticeXP sysCLOCK PLL Design and
Usage Guide

TN1103, LatticeECP2/M sysCLOCK PLL/DLL Design and Usage Guide
TN1178, LatticeECP3 sysCLOCK PLL/DLL Design and Usage Guide
TN1089, MachXO sysCLOCK Design and Usage Guide

TN1199, MachX0O2 sysCLOCK PLL Design and Usage Guide

TN1282, MachXO3L sysCLOCK PLL Design and Usage Guide
TN1098, LatticeSC sysCLOCK and PLL/DLL User’s Guide

TN1126, LatticeXP2 sysCLOCK PLL Design and Usage Guide
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sysMEM EBR How to Design with FPGA Memories
TN1264, ECP5 Memory Usage Guide
TN1051, Memory Usage Guide for LatticeECP/EC and LatticeXP Devices
TN1104, LatticeECP2/M Memory Usage Guide
TN1179, LatticeECP3 Memory Usage Guide
TN1094, On-Chip Memory Usage Guide for LatticeSC Devices
TN1092, Memory Usage Guide for MachXO Devices
TN1201, Memory Usage Guide for MachXO2 Devices
TN1290, Memory Usage Guide for MachXO3L Devices
TN1137, LatticeXP2 Memory Usage Guide

sysDSP How to Design with sysDSP

Exporting an Image of a Schematic Logic Block
View

The Export command for Logic Block View enables you to capture a bitmap
image of an open schematic view.

To export a schematic Logic Block View image:
1. Open the Logic Block View that you want to save as a bitmap image.
2. Choose File > Export or click the Export button [, on the vertical toolbar.

3. Inthe Export Image File dialog box, select the location for the image, and
then type a name for the image in the File name text box.

4. Click Save.

A bitmap image of the schematic view is saved in the directory you
specified.

Cross-Probing Between Views

Diamond’s preference-editing views allow you to select an element in one
view and quickly display the corresponding logical or physical element in a
different view. For example, you can cross-probe a component in Floorplan
View to view the logical elements in Netlist View; or you can cross-probe a
signal in Spreadsheet View to examine its placement on the pin layout of
Package View.

To cross-probe an element from one view to another:
1. Right-click an element in any view.

2. Choose Show in, and then choose the desired view from the pop-up
menu.
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The following tables show the cross-probing availability for each preference
view.

Table 23: Cross-probing from Spreadsheet View

Preference Sheet Assignment Cross-probe to

Port Assignments Pin Package View
Device View
Netlist View
NCD View

Floorplan View

Pin Assignments Signal Package View
Group Port Group Package View

Anchored UGROUP Floorplan View
Misc REGION Floorplan View

Table 24: Cross-probing from Package View

Element Cross-probe to

Assigned pin Netlist View
Spreadsheet View
Floorplan View

Device View

Site Floorplan View

Device View

Table 25: Cross-probing from Device View

Element Cross-probe to
DQS, IOL, PFF, PFU, PLL/DLL, Floorplan View
DCC/DCS, sysDSP, sysMEM Physical View
Others: GSR, JTAG, Oscillator, etc. Floorplan View
Physical View
Assignable PIO Cell Package View
Floorplan View
Physical View
Unassignable PIO Cell Floorplan View
Physical View
DDR Support with bonded DQS Package View

Floorplan View

Physical View
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Table 26: Cross-probing from Netlist View

Element Cross-probe to

Assigned port Package View

Instance Floorplan View
Physical View
NCD View

Net Floorplan View
Physical View

Table 27: Cross-probing from NCD View
Element Cross-probe to
IOL instance Netlist View
Floorplan View
Physical View
PCS block Netlist View
Floorplan View
Physical View
PFF slice Netlist View
Floorplan View
Physical View
PFU slice Netlist View
Floorplan View
Physical View
User PIO Netlist View
Package View
Floorplan View
Physical View
PLL/DLL Netlist View

Floorplan View

Physical View
sysDSP block Netlist View

Floorplan View

Physical View
sysMEM block Netlist View

Floorplan View

Physical View
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Table 27: Cross-probing from NCD View (Continued)

Element Cross-probe to

Others: GSR, JTAG, Oscillator, etc. Floorplan View
Physical View

Net Floorplan View

Physical View

Table 28: Cross-probing from Floorplan View

Element Cross-probe to
Assignable PIO site Device View
Physical View

Package View

Placed PIO Device View
Netlist View
NCD View
Physical View

Package View

Placed IOL Device View
Netlist View
NCD View
Physical View
Any non-PIO site Device View
Physical View
Any non-PlO placed component Device View
Note: To cross-probe PFF or PFU Netlist View
components, select individual slices. NCD View
Physical View
Port Physical View
UGROUP Spreadsheet View
REGION Spreadsheet View
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Table 29: Cross-probing from Physical View
Element Cross-probe to
Site Device View
Floorplan View
Placed component Device View
Netlist View
NCD View
Floorplan View
Net NCD View

Floorplan View

See Also “Auto Cross-probing Between Floorplan, Physical, and Logic
Block Views” on page 437

Auto Cross-probing Between Floorplan,
Physical, and Logic Block Views

When both Floorplan View and Physical View are open, an item that you
select in one of these views is automatically selected in the other. This auto
cross-probing is especially useful for immediately examining connections in
both views. Additionally, when you open the Logic Block View for a selected
component, the component is selected in both Floorplan View and Physical
View.

The auto cross-probing tool does not zoom in to selected items or change the
focus of the targeted view, and it does not open the targeted view if it is not
already open. But when both Floorplan View and Physical View are open,
auto cross-probing enables you to immediately examine objects in the context
of each type of layout.

For example:

Select a component in Floorplan View. Switch to Physical View and click
the Zoom To qﬁ% button to view the selected component.

Select a net in Physical View. Switch to Floorplan View to examine the net
in the larger component layout.

Double-click a component in Floorplan View to open Logic Block View.
Select a net in Logic Block View.

Switch to Floorplan View to view the highlighted net in the larger
component layout.

Switch to Physical View to view the highlighted net in the more
detailed layout.

See Also “Cross-Probing Between Views” on page 433
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Using the Zoom and Pan Tools

The Diamond toolbar provides zoom tools for the layout views: Package View,
Floorplan View, Physical View, and Logic Block View. In addition, the vertical
toolbar included with Package View and Floorplan View provides commands
that work together with the zoom tools to help you navigate to different objects
and areas of the layout. Also, both Physical View and Logic Block View
provide an area zoom that is controlled through the left mouse button. All of
the layout views enable you to zoom in and out using the mouse wheel and
function key combinations, and to pan using the arrow keys.

Diamond Toolbar Zoom Commands The following commands are
available on the Diamond toolbar and in the View menu for each layout view.

@y, ZoomIn— enlarges the view of the entire layout.

=, Zoom Out — reduces the view of the entire layout.
(d Zoom Fit — reduces or enlarges the entire layout so that it fits inside the
window.

@, Zoom To — enlarges the size of one or more selected sites, components,
or connections on the layout and fills the window with the selection. The Zoom
To command is available for all layout views except Logic Block View.

Area Zoom with the Mouse in Physical and Logic Block Views In
Physical View and Logic Block View, you can enlarge an area of the layout by
holding the left mouse button and dragging to the right and downward.
Afterwards, you can zoom out of the area by dragging your mouse upward
and to the left.

Vertical Toolbar Commands for Package View and Floorplan View The
Select, Pan, and Zoom Area commands are available from the vertical toolbar
in Package View and Floorplan View. They are also available from the “Mouse
Tools” section of the View menu. These commands are mutually exclusive,
meaning that only one of them can be active at a time. Each allows you,
however, to continue using the Diamond toolbar zoom commands.

k Select — enables you to select objects on the layout by clicking an
individual object or by dragging around an area to select multiple objects. It
also enables you to move an assignment to a different location by dragging it.
After selecting objects, you can zoom in with the Zoom To command. The
Select command is activated by default. When Select is active, the Pan and
Zoom Area commands are disabled.

;:-"? Pan — enables you to use the mouse pointer to drag the layout in any
direction. This command is useful for viewing a hidden area on the layout after
zooming in. When Pan is active, the Select and Zoom Area commands are
disabled.

(), Zoom Area — enables you to immediately enlarge an area of the layout by
dragging to the right and downward with your mouse. When Zoom Area is
active, the Select and Pan commands are disabled.
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Panning with the Mouse in Physical and Logic Block Views After
zooming in to a section of the layout, in Physical View or Logic Block View,
you can press and hold the mouse wheel to drag the layout in any direction.

Zooming with Function Key Shortcuts The following key combinations,
available for all the layout views, enable you to instantly zoom in or out from
your keyboard:

Zoom In — Ctrl++

Zoom Out — Ctrl+-
Zooming with the Mouse Wheel The mouse wheel gives you finer zoom
control, enabling you to zoom in or out in small increments. While pressing the

Ctrl key, move the mouse wheel forward to zoom in and backward to zoom
out. The mouse wheel zoom is available for all the layout views.

Panning with the Arrow Keys After enlarging the layout with the zoom
tools, you can use the keyboard arrow keys to pan horizontally or vertically to
different areas of the layout. Panning with the arrow keys is available for all
the layout views.

Searching for Design Elements

Diamond'’s preference views enable you to search for design elements—
either through a Find dialog box or through Find and Filter text boxes within
the view.

Device View, Netlist View, and NCD View each provide Find and Filter text
boxes at the top of the window. Diamond highlights the found objects and
enables you to navigate through them and cross-probe to other views.

Spreadsheet View, Floorplan View, and Physical View each provide a Find
dialog box. See the topic “Working with Preference Sheets” on page 397 for
information about searching in Spreadsheet View. The Find dialog box in
Floorplan View and Physical View enables you to search for components,
nets, and sites.

To search for design elements in Device View, Netlist View, or NCD View:
1. Open the desired view.
2. The Find and Filter text boxes appear at the top of the window.
3. To narrow the scope of the search, use wildcards in the Filter text box.
Use the asterisk to match one or more characters.
Use the question mark to match any single character.

The view displays only those items that contain the characters you
entered.

4. To locate a single design element from the list, type the name in the Find
text box and press Enter.

The found element is brought to the top of the view and highlighted.
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5. To navigate through a list of elements that contain the same characters,
use wildcards in the Find text box, and then press Enter.

The first element containing the characters you entered is brought to the
top of the view and highlighted. Press Enter again to go to the next
element in the list.

To search for components, nets, or sites in Floorplan View or Physical
View:

1. Open Floorplan View or Physical View, and then choose Edit > Find or
press Ctrl+F.

2. Inthe Find dialog box, type the name of the component, net, or site that
you want to find. Use the asterisk and question mark characters to
perform wildcard searches.

3. Select the type from the Find Type drop-down menu.

4. Select Match Whole Word and Match Case as desired, to narrow your
search to a complete name or to match upper and lower case letters.

5. Click Find Next or Select All.
The item or items are highlighted on the layout.

Use the Find Next and Find Previous buttons to navigate from one found
item to another. Each will be highlighted on the layout.

See Also “Going to a Specific Site” on page 423

Using Drag-and-Drop to Make
Assignments

Diamond’s preference-editing views provide a convenient drag-and-drop
feature for making assignments or editing them. This feature is available
between Netlist View and Spreadsheet View, between Netlist View and
Package View, and between Netlist View and Floorplan View. The drag-and-
drop feature is also available within Package View and within Floorplan View.
This feature allows you to perform the following actions:

Drag signals from Netlist View to Package View to assign them to pin
locations.

Drag assigned signals within Package View to reassign them to other
locations.

Drag nets from Netlist View to the Route Priority sheet of Spreadsheet
View to set routing priority.

Drag registers from Netlist View to the Cell Mapping sheet of Spreadsheet
View to specify them as input or output flip-flops.

Drag EBR, DSP, PCS, PLL, and ASIC block instances from Netlist View to
Floorplan View to set LOCATE preferences.

Drag non-SLICE logical components within Floorplan View to reassign
them to other locations.
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Drag UGROUPs and REGIONS within Floorplan View to reassign them to
other locations.

Undoing and Redoing Assignments

Diamond’s Undo and Redo commands allow you to reverse preference
changes that were made in a selected preference view. You can make
multiple assignments, undo them all, and then redo them as desired. When all
of your manual assignments have been undone or redone, the Undo or Redo
command becomes dim. When you save your preference changes, the undo
and redo commands are disabled.

Note

The Undo command will not remove the in-memory preference change indicators: the
asterisk from a preference view tab or the “Preferences Modified” from the status bar.
To remove these indicators after all assignments have been undone, use the Save
command.

The commands are available from the Edit menu and from the Undo k) and
Redo &1 buttons on the Diamond toolbar.

The standard Windows keyword shortcuts are also available:
Press Ctrl+Z to undo an assignment.

Press Ctry+Y to redo an assignment.

Spreadsheet View Undo and Redo commands are available after design
translation to reverse a preference change that was made in Spreadsheet
View or pin assignments made in Netlist View. The commands are also
available after Place & Route to reverse changes made in NCD View.

Package View Undo and Redo commands are available after design
translation to reverse the following actions that were performed in Package
View: signal re-assignments, unlocking of pin assignments, and prohibiting of
pin sites.

Device View Undo and Redo commands are available after design
translation to reverse any PROHIBIT preferences that were made in Device
View.

Netlist View Undo and Redo commands are available after design
translation to reverse any unlocking of assigned pins that was done in Netlist
View.

Floorplan View Undo and Redo commands are available after design
translation to reverse component, group, or REGION assignments and
PROHIBIT preferences that were made in Floorplan View.

See Also “Previewing Preferences Before Saving” on page 531
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Printing a Preference View
You can print any preference sheet or any layout view. Diamond provides a
preview for each view, enabling you to select options before printing.

Printing a Preference Sheet Any of the preference sheets can be printed.
Categories, such as sysCONFIG, or groups are automatically expanded for
the purpose of printing.

To print a preference sheet:

1. In Spreadsheet View, select the preference sheet that you want to print.
2. Choose File > Print Preview.

3. Select from the toolbar options at the bottom, and then click Print.

Printing a Layout View You can print a copy of the layout from Floorplan
View, Package View, Physical View, or Logic Block View.

To print a layout:
1. Select the layout view that you want to print.
2. Choose File > Print Preview.

3. Select from the toolbar options at the top, and then click the Print button.

Setting Preferences

Preferences can be defined in the logical preference file (.Ipf) at any stage of
the design flow, but they are typically defined after synthesis and translation.
You can use Diamond’s preference-editing views or a text editor. Afterwards,
the mapping process adds the changes to the physical preference (.prf) file
and updates the native circuit description (.ncd).

Note

If you have a large design in the 100K LUT range and the logical preference file
contains a large number of preferences (approximately five thousand), you might
encounter the “out of memory” system error. See “Using Wildcard Expressions in
Preferences” on page 517 to see how to reduce the number of preferences.

Diamond'’s preference-editing views allow you to specify many FPGA
preferences, saving you the time it normally takes to write out logical
preference syntax manually. These views include Spreadsheet View, Package
View, Device View, Netlist View, NCD View, and Floorplan View.

Diamond implements simple error checking to ensure that the user
assignments are applicable to the selected FPGA device and that there are
no conflicting assignments. If the user preferences conflict with the selected
device, the software will display these preferences in red. For example, if you
change the device type after specifying some pin assignments, the non-
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applicable pin assignments will be displayed in red. You can delete these
preferences within Diamond’s preference views or within the .Ipf file.

The validity of all the nets and ports are also checked against the logical
native generic database (.ngd) file. If the .Ipf file contains any of the physical
naming in a net or a cell, it will result in an error condition. Physical names
cannot be validated in the pre-map stage.

After the Translate Design process, you can view and edit any preferences
that were passed from the HDL as attributes. When you edit these
preferences or add new ones, you are writing changes in the form of logical
preferences directly into the .Ipf file. These preferences will be written to the
physical preference file (.prf) by the mapping process.

Adding a Logical Preference File to a
Project

When you create a new project in Diamond, a logical preference file (.Ipf) is

automatically generated and assigned the same name as the FPGA project.
All changes that you make to logical constraints will be saved to this file until
you create a new logical preference file or add an existing one.

Adding a new or existing .Ipf file allows you to experiment with a different set
of preferences for each implementation.

To add an existing .Ipf file:

1. Choose File > Add > Existing File. Optionally, right-click the active
implementation and choose Add > Existing File.

2. Inthe Add Existing File dialog box, do the following:

a. Choose Constraint Files (*.Ipf) from the “Files of type” drop-down
menu.

b. If you want to add the file to the implementation directory, select the
option Copy file to Implementation’s Source directory.

c. Navigate to the .Ipf file that you want to use and click Add.

The selected .Ipf file is added to the Constraint Files folder. If the file came
from a directory outside your current project and you did not select the
option to copy the file to the implementation directory, the relative path will
be shown.

To create a new .Ipf file and add it to the project:

1. Choose File > New > File or use the keyboard shortcut Ctrl+N.
Optionally, right-click the active implementation and choose Add > New
File.

2. Inthe New File dialog box, under Categories, select Source Files.

3. Inthe Source Files pane, select Preference Files.
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4. In the Name box, type a new file name and select the Ipf extension from
the Ext drop-down list.

5. Accept the current directory for the new .Ipf file or use the Browse button
to select a different directory.

6. Select the Add to Implementation option to add the new file to the active
implementation. Selecting this option also adds the file to the LPF
Constraint Files folder in the File List view.

7. Click New.
The new .Ipf file opens in the Source Editor window. The file name
appears in the Constraints Files list for your current implementation.
Note

If you did not select the Add to Implementation option, the file will not appear in the
Constraint Files folder. To add it, use the procedure for adding an existing
preference file.

See Also »“Activating a Preference File” on page 444
“Saving Preferences to a Different .Ipf File” on page 531

“Integrated Synthesis” on page 567

Activating a Preference File

When your project’s Constraint Files folder contains more than one .Ipf file,
you can select one of them to serve as the active preference file for the
current implementation.

To activate a preference file:
1. Select the .Ipf file in the Constraint Files folder.
2. Right-click the selected file and choose Set as Active Preference File.

If there are modified preferences or file changes in memory for your
currently open project, the “Save Modified Files” dialog box will appear. If
this happens, either click OK to save all files or clear the check marks in
front of any files that you do not want to save and click OK.

The newly activated .Ipf file now appears in bold type and will be used in
processing the current implementation. All open preference views are
refreshed and display any preferences contained in the newly activated file.

Setting Global Preferences

The Global sheet of Spreadsheet View enables you to set constraints that
affect the entire design, such as voltage, temperature, global BLOCK
preferences, and configuration preferences. The list of these preferences
varies by device family.
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To set global preferences:
1. In Spreadsheet View, select the Global Preferences tab.

2. To edit the value for a global or sysCONFIG preference, do one of the
following:

Double-click the value and enter a new one.

The table cell changes format. If the cell changes to a text box, type
the new value. If it changes to a box with a drop-down menu, choose
the value from the list.

Right-click the preference value cell and select the desired value from
the pop-up menu. For a text entry, choose Edit Cell, and then type the
new value.

3. Toreturn to the default value, highlight the value and press the Delete key
or right-click the value and choose Clear.

For MachXO2 devices, the Global Preferences sheet allows you to specify the
VCCIO voltage setting for each bank. The VCCIO setting will then appear in
the read-only BANK _VCCIO column of the Port Assignments sheet for any
signal or bank assignments. It will also appear in the BANK_VCCIO column of
the Pin Assignments sheet. For other devices, the BANK_VCCIO preference
can be set manually in the logical preference file (.Ipf).

For LatticeSC/M devices, the Global Preferences sheet allows you to specify
voltage derating preferences for VCC, VCC12P, VCCAUX, and VCCIO. For
other devices, voltage derating preferences can be set manually in the .Ipf file.
See Also »Global Preferences

TN1260, ECP5 sysCOFIG Usage Guide

TN1053, LatticeEC/ECP sysCONFIG Usage Guide

TN1108, LatticeECP2/M sysCONFIG Usage Guide

TN1169, LatticeECP3 sysCONFIG Usage Guide

TN1080, LatticeSC sysCONFIG Usage Guide

TN1082, LatticeXP sysCONFIG Usage Guide

TN1141, LatticeXP2 sysCONFIG Usage Guide

TN1204, MachX0O2 Programming and Configuration User Guide

TN1279, MachXO3L Programming and Configuration Usage Guide

Setting Temperature and Voltage
Derating

The following tables show the min-max junction temperature range and the
supported voltages for derating for each Lattice device family. The nominal
values are specified where applicable. Lattice Diamond will use these values
for DRC checks. Except for LatticeSC/M devices, voltage derating
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preferences are set manually in the .Ipf file. They include VCC_DERATE,
VCC1P2_DERATE, VCCAUX_DERATE, VCCIO_DERATE, and
VREF_DERATE.

Note

The data ranges listed in the tables are derived from data collected during test
conditions that might not match your unique operating conditions. You should compare
your own data to ensure reliability. Also refer to relevant data sheets or application
notes on the Lattice web site for updated information. Contact technical support for
more information.

Table 30: LatticeECP/EC Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40C 100 C N/A
VCC 1.14V 1.26V 1.2V
VCCAUX 3.135V 3.465V 3.3V
VCCIO 1.14V 3.465V N/A
VCCREF -05V 3.75V N/A

Table 31: LatticeECP2/M Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATAURE -40 C 100 C N/A
VCC 1.14V 1.26 V 1.2V
VCCAUX 3.135V 3.465V 3.3V
VCCIO 1.14V 3.465V N/A
VCCREF -05Vv 3.75V N/A

Table 32: LatticeECP3 Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40 C 100 C N/A
VCC 1.14V 1.26 V 1.2V
VCCAUX 3.135V 3.465V 3.3V
VCCIO 1.14V 3.465V N/A
VCCREF
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Table 33: LatticeECP4 Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40 C 100 C N/A
VCC 1.14V 1.26 V* 1.2V
VCCAUX 3.135V 3.465V 33V
VCCIO 1.14V 3.465V N/A
VCCREF

Table 34: LatticeXP Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40 C 100 C N/A
VCC 1.14V 1.26 V 1.2V
(1.2 V devices)

VCC 1.71V 3.465V 25V
1.8V, 2.5V, 3.3V devices)

VCCAUX 3.135V 3.465V 33V
VCCIO 1.14V 3.465V N/A
VCCREF 0.5V 3.75V N/A
Table 35: LatticeXP2 Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40C 100 C N/A
VCC 1.14V 1.26 V 12V
VCCAUX 3.135V 3.465V 3.3V
VCCIO 1.14V 3.465V N/A
VCCREF 05V 3.75V N/A
Table 36: LatticeSC/M Temperature and Voltage Derating
Symbol Min. Max. Nominal
TEMPERATURE -40 C 105C N/A

VCC 95V 1.26 V 1.2V
VCC12 1.14V 1.26 V 1.2V
VCCAUX 2375V 2.625V 25V
VCCIO 1.14V 345V N/A

(Banks 1, 4, 5)

Lattice Diamond 3.6 Help 447



APPLYING DESIGN CONSTRAINTS : Setting Preferences

Table 36: LatticeSC/M Temperature and Voltage Derating (Continued)

Symbol Min. Max. Nominal

VCCIO 1.14V 2.625V N/A
(Banks 2, 3, 6, 7)

VCCREF -05V 36V N/A

Table 37: MachXO Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40 C 100 C N/A
VCC 1.14V 3.465V 1.2V

(1.2 V devices)

VCC 1.71V 3.465V N/A
(1.8V,25V,3.3V

devices)

VCCAUX 3.135V 3.465V 3.3V
VCCIO 1.14V 3.465V N/A
VCCREF -05Vv 3.75V N/A

Table 38: MachXO2 Temperature and Voltage Derating

Symbol Min. Max. Nominal
TEMPERATURE -40C 100 C N/A
VCC 114V 1.26 'V 1.2V

(1.2 V devices)

VvCC 2375V 3.465V 25Vor33V
(2.5V, 3.3V

devices)

VCCIO 1.14V 3.465V N/A
VCCREF

See Also »“Setting Preferences in a Text Editor” on page 510
“TEMPERATURE” on page 1196
“VOLTAGE” on page 1215
“VCC_NOMINAL” on page 1211
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Setting a Global Set/Reset Net
Preference

The GSR_NET Preference dialog box allows you to specify a net as the input
to the global set/reset (GSR) buffer inferred by the design mapper.

To set a Global Set/Reset Net preference:
1. In Spreadsheet View, select the Global tab.

2. Double-click Global Set/Reset Net to open the New GSR_NET
Preference dialog box.

Alternatively, right-click and choose New GSR_NET.

3. Inthe dialog box, select one or more nets from the Available Logical Nets
list and click the > button to move the selection to the Selected Logical
Nets list.

You can use wildcards in the Filter text box to narrow the list of nets. To
move all available nets to the Selected Logical Nets list, click the >>
button.

4. Click Add.

Your selection of one or more nets is displayed on the Global preference
sheet under “Global Set/Reset Net.” When you save the preference, each
net is added to the .Ipf file as a separate GSR_NET preference.

Assigning Signals

Diamond'’s Spreadsheet View and Netlist View enable you to assign signals to
pin locations. You can also assign signals by dragging them from Netlist View
to pin locations on the Package View layout. Signals can be assigned or
reassigned at any stage of the design flow.

Assigning Signals in Spreadsheet View

Spreadsheet View provides two methods for assigning signals to pin
locations:

Use the Port Assignments sheet to assign pins to listed signals. The Port
Assignments sheet displays signals by port type and signal names.

Use the Pin Assignments sheet to assign signals to listed pins. The Pin
Assignments sheet lists pins by pin, pad name, bank, dual function, and
polarity.

Both views enable you to make single or multiple assignments. Saved pin
assignments are written to the logical preference file as LOCATE preferences.

Assigning Pins Using the Port Assignments Sheet For a single pin
assignment, you can simply double-click the pin cell for a given signal and
type the desired pin name. For multiple pin assignments, use the Assign Pins
dialog box, as explained below.
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To assign pin locations:

1. Select the pin cells, in the Pin column, for the signals that you want to

assign.

Note

PCS-related signals for ECP5, LatticeECP2M, LatticeSC, and LatticeECP3
designs, are displayed in a dim font, indicating that they are read-only. For more
information, refer to TN1261, ECP5 SERDES/PCS Usage Guide, TN1124,
LatticeECP2M SERDES/PCS Usage Guide; TN1145, LatticeSC flexiPCS/
SERDES Design Guide; and TN1176, LatticeECP3 SERDES/PCS Usage Guide.

To select multiple pin cells, do one of the following:

Drag down the pin column or use the Ctrl+click or Shift+click
combination.

For a bus, open Netlist View and detach it. Select the bus from the
Ports list of Netlist View and drag it to the Port Assignments Sheet of
Spreadsheet View. All the rows for the bus signal names become
highlighted.

Right-click the selected cells in the Pin column and choose Assign Pins.

In the Assign Pins dialog box, the signals you selected are displayed in
boldface in the left pane. In the pin list next to it, the same number of pins
are displayed in bold at the top of the list. The software automatically
interprets the design files and displays the pin filters that should be
enabled by default. For example, if you selected an LVDS25 type of port in
Spreadsheet View, the polarity section on the right will show the True P-
side filter as enabled. If you selected a BLVDS type of port, it will show the
Emulated P-side filter as enabled.

Clear or select the desired options under Pin Types to narrow or expand
the list of available pins, and then select Auto Sort or Manual Sort.

If Auto Sort is selected, select the desired sorting option under “Sort
by,” and then select Ascending or Descending order.

If Manual Sort is selected, use one of the following methods to drag
pins and place them in the desired order:

Click one pin to select it, and then drag it to the desired location.

Use the Shift key to select several adjacent pins at once and
release the mouse button. Afterwards, drag the highlighted pins to
the desired position.

From the pin list, select the pin location where you would like the
assignment to begin.

The dialog box highlights the selected pin and displays in bold type the
sequence of pins following it—one for each signal.

Note

If you have used the “Incompatible Pins” dialog box to select a device for possible
pin migration, the incompatible pins will be displayed in a dim font on the pin list. If
you have disabled the incompatible pins, Diamond will assign the next available
pin for each pin that has been disabled.
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From the Assign Pin drop-down menu at the bottom left, select the desired
Assign Pin option: every, every second, every third, or every fourth pin.

To check the validity of the selected pin assignments, click Check Pins.

A message box appears that lists any assignment errors. If errors are
reported, repeat Steps 4—6 until the pin check is free of errors.

Click Assign Pins.

Assigning Signals Using the Pin Assignments Sheet For a single
assignment, you can simply double-click the Signal Name cell for a selected
pin to open the Assign Signals dialog box. For multiple assignments, right-
click the selected cells.

To assign signals:

1.

In the Signal Name column, select one or more cells for the signals that
you want to assign. You can drag down the column to select multiple
signal cells or use the Ctrl+click or Shift+click combination.

Note

If you have used the “Incompatible Pins” dialog box to select a device for possible
pin migration, the incompatible pins will be displayed in a dim font. If you have
disabled the incompatible pins, Diamond will assign the next available pin for each
pin that has been disabled.

Right-click the selected cells in the Signal Name column and choose
Assign Signals.

In the Assign Signals dialog box, the pins you selected are displayed in
boldface in the left pane. In the signal list next to it, the same number of
signals are displayed in bold at the top of the list.

Clear or select the desired options under Signal Types to narrow or
expand the list of available signals, and then select Auto Sort or Manual
Sort.

If Auto Sort is selected, select the desired sorting option under “Sort
by.”

If Manual Sort is selected, use one of the following methods to drag
signals and place them in the desired order:

Click one signal to select it, and then drag it to the desired
location.

Use the Shift key to select several adjacent signals and release
the mouse button. Afterwards, drag the highlighted signals to the
desired position.

Select Ascending or Descending order.

From the signal list, select the signal where you would like the assignment
to begin.

The dialog box highlights the selected signal and displays in bold type the
sequence of signals following it—one for each pin.

To check the validity of the signal assignments, click Check Signals.
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7.

A message box appears that lists any assignment errors. If errors are
reported, repeat Steps 6 and 7 until the signal check is free of errors.

Click Assign Signals.

See Also »“"Modifying Assignments in Spreadsheet View” on page 452

“Color Coding of Cell Values” on page 396
“Defining IOBUF Preferences” on page 460
“Setting Preferences for Port Groups” on page 492
“Back Annotating Assignments” on page 474
“IO_TYPE” on page 1244

TN1262, ECP5 syslO Usage Guide

TN1056, LatticeECP/EC and LatticeXP syslO Usage Guide.
TN1102, LatticeECP2/M syslO Usage Guide
TN1177, LatticeECP3 syslO Usage Guide
TN1088, LatticeSC PURESPEED I/O Usage Guide
TN1136, LatticeXP2 syslO Usage Guide

TN1091, MachXO syslO Usage Guide

TN1202, MachX02 syslO Usage Guide

TN1280, MachXO3L syslO Usage Guide

Modifying Assignments in Spreadsheet View

You can modify pin assignments in Spreadsheet View before or after
placement and routing. After routing, you can also modify assignments that
were made automatically by the Place & Route Process.

To modify assignments:

1.

From the Port Assignments sheet or Pin Assignments sheet, select the
assignments that you want to modify, right-click, and choose Assign Pins
or Assign Signals.

Follow the same procedure for assigning pins or signals in Spreadsheet
View.

To modify assignments made automatically by Place & Route:

1.

Choose View > Display 10 Placement.

All the placed and routed assignments are displayed in parentheses,
including user assignments. User assignments appear twice—once
without parentheses and once in parentheses—and they are displayed in
black font or the font color that has been designated for “Normal” in the
options dialog box. Assignments that were made automatically by Place &
Route appear only once. They are displayed in parentheses and are
distinguished by blue font or the font color designated for “Default Values.”
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2. Select the assignments made by Place & Route that you want to modify,
right-click, and choose Assign Pins or Assign Signals.

3. Follow the same procedure for assigning pins or signals in Spreadsheet
View.

The assignments are now displayed in black font. Those that were
assigned by Place & Route now appear in parentheses, preceded by the
new assignments.

To remove assignments:

Select the assigned pins or signals that you want to delete, and then press
the Delete key. Optionally, right-click the selected assignments and
choose Clear.

Note

Only user assignments can be deleted. Assignments made automatically by Place
& Route can be modified but not deleted.

Assigning Pins Using Netlist View
Netlist View enables you to select the signals from the design tree that you
want to assign.

To assign pins:

1. From the Netlist View design tree, expand the category of signals that you
want to assign.

2. Select the signals that you want to assign, right-click, and choose Assign
Pins.

3. Follow the procedure for assigning pins using the Port Assignments sheet.
See Also »“Assigning Signals Using Package and Netlist Views” on
page 454

“Back Annotating Assignments” on page 474

Modifying Pin Assignments Using Netlist View

Netlist View enables you to select the assigned signals from the design tree
that you want to reassign.

To modify pin assignments:

1. Select the assigned signals that you want to modify, right-click, and
choose Assign Pins.
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2.

Follow the procedure for assigning pins using the Port Assignments sheet.

Note

You can also modify one or more pin assignments by dragging from Netlist View to
a different location in Package View.

To remove pin assighments:

Select the assigned signals that you want to remove, right-click, and
choose Unlock.

Assigning Signals Using Package and Netlist Views

You can drag signals from Netlist View onto the Package View pin layout to
assign them or reassign them.

To assign signals using Netlist and Package views:

1.
2.

Choose Tools > Package View.
Click the Show Pin Display Selection 4% button on the toolbar.

The Pin Display Selection dialog box, by default, shows that all pin types
and banks are selected.

In the dialog box, clear the types of pins and banks that you do not want to
appear on the layout.

Click Close.

To display the fly wires for differential pins, choose View > Show
Differential Pairs.

Note

For IO_TYPEs that require differential pins, Diamond automatically prohibits you
from assigning the complement of a differential pin that is already assigned.

Choose Tools > Netlist View. The Ports design tree should be displayed.
If it is not, click the Ports = = button on the toolbar.

Do one of the following:

Click the Detach Tool button = at the top right to open Netlist View in
a separate window, and then position Netlist View alongside Package
View.

Click the Split Tab Group button [f§ on the toolbar to separate Netlist

View into a tab group, and then select Package View in the main tab
group. Both views now appear side-by-side.
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8. From the Netlist View window, expand the list of ports and select the
desired signals or bus.

Note

PCS-related signals for ECP5, LatticeECP2M, LatticeSC, and LatticeECP3
designs, are displayed in a dim font, indicating that they are read-only. For more
information, refer to TN1261, ECP5 SERDES/PCS Usage Guide, TN1124,
LatticeECP2M SERDES/PCS Usage Guide; TN1145, LatticeSC flexiPCS/
SERDES Design Guide; and TN1176, LatticeECP3 SERDES/PCS Usage Guide.

9. Drag your selection to the desired location on the Package View layout
and release the mouse button.

Package View fills the specified pin locations with color and assigns
multiple signals in the order they were selected. The assignments are also
shown in Netlist View and in the Port Assignments sheet of Spreadsheet
View. When you save the assignments, each is written to the .Ipf file as a
LOCATE preference.

Click the “Integrate All Tools” button to integrate the detached Netlist View
with the main window.

Click the “Merge Tab Group” button EE to merge the split tab into the main tab
group.

See Also »“Back Annotating Assignments” on page 474

Modifying Signal Assighments in Package View
Package View enables you to use drag-and-drop to move one or more signal
assignments to unlocked pins. It also allows you to move a single signal
assignment to a pin that is already locked and swap the two assignments.

To modify one or more assignments in Package View:

1. Select the device pins on the layout that contain the assignments you
want to modify.

To select only one pin, click it once so that it is highlighted. Use the Cirl
key or the Shift key to select more than one pin, or drag your mouse
around multiple pins to select them.

2. Slowly move the mouse toward the desired unlocked pin location.

As you begin to drag, the cursor displays a crossed-out circle symbol. The
cursor changes to an arrow as you move it over valid pins. Keep dragging
until you have reached the targeted location.

3. When the cursor displays the arrow symbol over the targeted location,
release the mouse button.

Note

If you are modifying a single assignment, make sure that the pin is highlighted
before you try to drag it. If you try to drag a pin before it is highlighted, you will
activate the multiple selection tool.
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To swap two assignments:

1. Select the single device pin that contains the assignment you want to
swap.

2. Drag the selected signal to the desired locked pin location and release the
mouse button.

3. Inthe dialog box click Swap assignments.

To remove assignments in Package View:
1. Select the pins that contain the assignments you want to remove.

2. Right-click the selected pins and choose Unlock.

See Also »"Maodifying Pin Assignments Using Netlist View” on page 453
“Assigning Signals in Spreadsheet View” on page 449
“Modifying Assignments in Spreadsheet View” on page 452
“Migrating Pin Assignments” on page 468
“Selecting a Device for Possible Pin Migration” on page 468

“Viewing Incompatible Pins” on page 470

Modifying Signal Assignments in Floorplan View

In Floorplan View, you can modify a signal assignment by dragging it from one
P10 to another. You can modify an assignment that originated from the logical
preference file (.Ipf) or one that was made automatically by Place & Route
(PAR).

To modify a signal assignment in Floorplan View:

1. Make sure that the “Display Placement” button is turned on if you will
be modifying a PAR-assigned 1/O. If you will be modifying an 1/0O
assignment from the .Ipf file, make sure that the “Display Placement
Preferences” button i is turned on.

2. In Floorplan view, zoom in so that you can easily view the placed PIO
component that you want to reassign and the targeted location.

P10 components that were assigned automatically by PAR are displayed
with a solid color fill. PIO components whose assignments originated from
the .Ipf file are displayed with a color fill and a cross-hatch overlay.

3. Drag from the assigned site to the targeted location and release the
mouse button.

The previous location is now displayed with a fill and no cross-hatch, and
the targeted location is displayed with the cross-hatch and no fill. The
targeted location will appear in the .Ipf as a LOCATE preference when you
save the change.

See Also »“How Assignments are Displayed in Floorplan View” on
page 419
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“Setting LOCATE Preferences in Floorplan View” on page 472

Setting Vref Locations

Lattice FPGA devices commonly provide two input pins per bank that can
serve as on-chip voltage references (Vref) for the 1/O types that require them.
Spreadsheet View enables you to name and assign the specific voltage
reference pins for these I/O types. If you do not assign Vrefs for 1/O types that
require them, the software will automatically create them for you. However,
automatically generated Vrefs will not be added to the .Ipf file if you decide to
back annotate assignments.

After you have specified a Vref location, you can associate the Vref pin with a
port group or with single signals. All Vrefs that you define are written to the
logical preference file as LOCATE preferences.

Note

The Vref preference is not available for MachXO and Platform Manager devices.

To set Vref locations:

1. In Spreadsheet View, click the Vref Locations button % on the toolbar to
open the Create New VREF dialog box.

Alternatively, select the Misc Preferences sheet and double-click VREF
LOCATE in the Preference Name column.

2. Inthe dialog box, under VREF Name, type a new VREF string.

3. If available, select a voltage rail from the Rail drop-down list.

Note

The Rail option is available and required for LatticeSC/M devices only.

4. Under SITE, select the desired pin location.
5. Click Add.

The Misc Preferences sheet opens, displaying the list of Vrefs in the
VREF LOCATE list.

6. To add more Vrefs, repeat steps 1-5.

When you save the design, Vref assignments appear in the .Ipf file as
LOCATE preferences.

To modify a Vref location:

1. Open the Misc Preferences sheet.

2. Expand VREF LOCATE and double-click the Vref that you want to modify.
Alternatively, right-click the Vref and choose Modify.

3. Inthe Edit VREF Property dialog box, select the desired site and click
Update.
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To delete a Vref:
1. Inthe Misc Preferences sheet, select the Vref you want to remove.
2. Press the Delete key or right-click and choose Delete.
For more details on Vref usage, refer to the syslO Usage Guide for your
targeted device family:
TN1262, ECP5 syslO Usage Guide
TN1056, LatticeECP/EC and LatticeXP syslO Usage Guide
TN1102, LatticeECP2/M syslO Usage Guide
TN1177, LatticeECP3 syslO Usage Guide
TN1088, LatticeSC PURESPEED I/O Usage Guide
TN1136, LatticeXP2 syslO Usage Guide
TN1091, MachXO syslO Usage Guide
TN1202, MachX02 syslO Usage Guide
TN1280, MachXO3L syslO Usage Guide

See Also »"Defining IOBUF Preferences” on page 460
“Setting Preferences for Port Groups” on page 492
“Back Annotating Assignments” on page 474

“IO_TYPE” on page 1244

Setting Port, Net, and Cell Attributes

Spreadsheet View's Port Assignments Sheet, Clock Resource sheet, Route
Priority sheet, Cell Mapping sheet, and Global Preferences sheet enable you
to set attributes for ports, nets, and cells. They allow you to set I/O port
attributes, assign net priorities, specify registers for flip-flops, and set junction
temperature and voltage.

Defining 1/0O Defaults

Diamond allows you to set values for all ports in your design at once. There
are two ways to do this: use the ALLPORTS preference, which is available in
Spreadsheet View, or manually create a DEFINE PORT GROUP preference
in the .Ipf file to create a group that includes all ports. Each of these methods
allows you set default values while at the same time retaining values for
individual ports or port groups that are set with other preferences.

For example, in a MachXO2 design, you might want to change the default I/O
type to LVCMOS33, which would allow you to select a drive strength of 24 for
individual output ports. But you might want to maintain the Vref settings for a
port group with 1/0 type SSTL18_|. When you change the default to

LVCMOS33 for all of the ports, Diamond changes the 1/O type to LVCMOS33
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for ports that use the default; but it maintains the SSTL18_1 I/O type for the
port group that uses the Vref assignment.

For example, in a LatticeSC design, you might want to change the default 1/O
type to HSTL15_ 1, which would allow you to select an impedance setting of
50 for individual output ports. But you might want to maintain the impedance
setting of 100 that you have already set for a port with 1/0 type LVCMOS25.
When you change the default to HSTL15_ 1 for all of the ports, the software
changes the 1/0 type to HSTL15 1 for ports that use the default; but it
maintains the LVCMOS25 I/0O type and impedance of 100 for the output port
that you have already set.

You should use care when defining I/O defaults, especially if your design
includes I/O settings in the HDL. Any existing IOBUF attributes in the HDL will
get overridden by the Map process when an ALLPORTS preference or an all-
ports PORT GROUP is used in the .Ipf file. Before you define 1/0O defaults,
make sure that you move any existing HDL IOBUF assignments to the .Ipf file.

Defining I/O Defaults Using ALLPORTS The ALLPORTS row in
Spreadsheet View's Port Assignments sheet enables you to quickly define a
default setting for I/O attributes. It can be especially useful for setting the 1/0
type default.

To define default settings Using ALLPORTS:
1. In Spreadsheet View, select the Port Assignments tab.

2. Double-click the desired attribute cell in the ALLPORTS row and select a
value from the drop-down list. Optionally, right-click the cell and select a
value from the pop-up list.

The newly selected value is displayed in orange, or the font color
designated for “Reference Value,” for all of the ports that do not have
other values already assigned.

Note

The range of attribute values available with the ALLPORTS row reflect the
intersection of valid values across all port types. To access all available values,
use individual ports or port groups.

You can return to the original default setting by selecting the attribute cell
and pressing the Delete key.

The following is an example of an ALLPORTS preference.

IOBUF ALLPORTS IO TYPE=LVCMOS33 PULLMODE=UP;

Defining I/O Defaults Using DEFINE PORT GROUP The DEFINE PORT
GROUP preference enables you to use a wildcard to include all ports in one
group. Afterwards, you can use Spreadsheet View to set IOBUF values for the
entire group.
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To define 1/0 defaults using a port group:

1. In the logical preference file, create the port group using the following
syntax with the “*” wildcard:

DEFINE PORT GROUP "<group name>" "*" ;

After you have created the port group and saved it in the .Ipf file, the group
appears at the bottom of Spreadsheet View's Port Assignments sheet.
When there are other port groups in the .Ipf file, Diamond issues a
warning for each port that exists in one of these other groups.

2. In Spreadsheet View'’s Port Assignments sheet, scroll down to the port
group row and select the desired IOBUF values from the appropriate
columns.

The following is an example of an all-ports group, with IOBUF settings:

DEFINE PORT GROUP "all ports" "*" ;
IOBUF GROUP "all ports" IO TYPE=LVCMOS18 PULLMODE=DOWN ;

See Also »“IO_TYPE” on page 1244
“Conflicting IOBUF Constraints” on page 382

Defining IOBUF Preferences

Spreadsheet View’s Port Assignments sheet enables you to define IOBUF
preferences for individual ports and port groups. IOBUF attributes include
BANK, IO_TYPE, PULLMODE, SLEWRATE, and many others. The available
attributes will vary, depending on the selected Lattice device. These modified
attributes will be written as IOBUF preferences in the logical preference file

(-Ipf).

The IOBUF preference does not support the use of wildcards. But you can
use wildcards with the DEFINE GROUP preference to create a port group.
Afterwards, you can assign IOBUF preferences to the entire group of ports at
once. Port groups are shown at the bottom of the Port Assignments sheet.
See also “Defining 1/0 Defaults” on page 458.

To define IOBUF preferences:

1. In Spreadsheet View, select the Port Assignments sheet.
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2. Double-click the cell in the attribute column that you want to modify for a
given signal or port group and choose a value from the drop-down menu.
Optionally, right-click the cell and choose a value from the pop-up menu.

Note
For some designs, the OPENDRAIN attribute cannot be set to ON in Spreadsheet
View but must be set in the HDL. Refer to the syslO Usage Guide for the device
family.
3. Press Enter.
The modified value now appears in black font in the preference sheet or in
the font color designated for “Normal Value.“
See Also »“IOBUF Attributes” on page 461
“Back Annotating Assignments” on page 474
TN1262, ECP5 syslO Usage Guide
TN1056, LatticeECP/EC and LatticeXP syslO Usage Guide
TN1102, LatticeECP2/M syslO Usage Guide
TN1177, LatticeECP3 syslO Usage Guide
TN1088, LatticeSC PURESPEED I/O Usage Guide
TN1136, LatticeXP2 syslO Usage Guide
TN1091, MachXO syslO Usage Guide
TN1202, MachXO2 syslO Usage Guide
TN1280, MachXO3L syslO Usage Guide

IOBUF Attributes

The following table describes the available attributes in the Port Assignments
sheet for defining IOBUF preferences.

The options that you can select for these attributes will depend on the
combinations that are legal for each device type. See the references below
the table under See Also.

Table 39:

Attribute Supported Devices Description

BANK VCCIO All Sets the VCCIO voltage level of the 10 bank.

CLAMP ECP5, MachX0O2, MachXO3L, Turns on the non-PCl-compliant clamp for smaller

Platform Manager 2 MachXO2 and MachXO3L devices. For 1200, 2k, 4k,

7k, and 10k devices, provides the option of setting the
PCI-compliant clamp in the bottom bank.

DIFFCURRENT LatticeSC/M Sets the output current level for differential signals.

Settings include 2, 3P5, 4, 6.
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Table 39:
Attribute

DIFFDRIVE

DIFFRESISTOR

DRIVE

EQ_CAL

HYSTERESIS

IMPEDANCE

I0_TYPE

MULTDRIVE

OPENDRAIN

PCICLAMP

Supported Devices

ECPS5, LatticeECP3, MachX02,
MachXO3L, Platform Manager 2

ECPS5, LatticeSC/M, LatticeECP3

All

LatticeECP3

ECP5, MachX02, MachXO3L,
Platform Manager 2

LatticeSC/M

All

LatticeECP3

All

LatticeECP/EC, LatticeECP2,
LatticeECP3, LatticeXP, LatticeSC/
M, MachXO 1200/2280

Description

Sets the differential current drive strength for the
MINILVDS output standard. Differential outputs
with different DIFFDRIVE settings cannot be
placed in the same 10 bank. Settings include 1.6,
1.65,1.7,1.75, 1.81, 1.87, 1.93, 2.0.

Note: The DIFFDRIVE value must be enclosed
in quotation marks in the logical preference file.

Provides differential termination for differential I/O
types. Settings include OFF, 100, 150, 200.
OFF is the default.

Specifies the drive strength for bidirectional and output
buffers.

Provides equalization filtering for single-ended inputs
on both true and complementary I/Os and for
differential inputs on true 1/Os.

Note: Only the default 0 value is valid for EQ_CAL.

Sets the amount of hysteresis for the PCI, LVTTL
and LVCMOS input and bidirectional 1/0
standards.

Sets the on-chip programmable output impedance.
Depending on the I/O type and other selected
attributes, settings can include OFF, 25, 33, 50, 100.

OFF is the default.
Sets the I/0 standard for the signal or port group.

Sets the drive strength for individual output buffers for
the MINILVDS output standard. Differential outputs
with different MULTDRIVE settings can be placed in
the same 10 bank. Settings include 1X, 2X, 3X, 4X.

Note: The MULTDRIVE value must be enclosed in
quotation marks in the logical preference file.

ON - specifies open-drain for an output or bidirectional
buffer.

OFF is the default.

Note: For some designs, the OPENDRAIN attribute
cannot be set to ON in Spreadsheet View but must be
set in the HDL. Refer to the syslO Usage Guide for the
device family.

ON - turns on the programmable PCI clamp diode.
OFF is the default.
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Table 39:
Attribute

PULLMODE

PWRSAVE

REFCIRCUIT

SLEWRATE

TERMINATEGND

TERMINATEVCCIO

TERMINATEVTT

TERMINATION

Supported Devices

All

LatticeSC/M

LatticeSC/M

All

LatticeSC/M

LatticeSC/M

LatticeSC/M, LatticeECP3

ECP5

Description

Specifies the pull mode option:
UP - pull-up (default)

DOWN - pull-down

NONE - pull off

KEEPER - bus keeper

Reduces power dissipation on comparator types of
input pins.

ON - Turns on the power save capability.
OFF is the default.

Specifies a reference circuit for an output or
bidirectional buffer. Settings include OFF, INTERNAL,
EXTERNAL.

OFF is the default.

Sets the slew rate for output and bidirectional buffers.
Options are SLOW or FAST.

SLOW is the default except for LatticeECP3 devices.

Sets the on-chip parallel input and output termination
to ground. Depending on the 1/O type and other
selected attributes, settings can include OFF, 50, 100,
120.

OFF is the default.

Sets the on-chip parallel input and output termination
to VCCIO. Depending on the I/O type and other
selected attributes, settings can include OFF, 50, 100,
120.

OFF is the default.

Sets the on-chip input parallel termination to VTT.
Depending on the I/O type and other selected
attributes, settings can include OFF, 60, 75, 120, 150,
210.

OFF is the default.

Sets the on-chip input parallel termination to VCCIO/2.
This parallel termination is achieved using a
programmable Thevenin termination scheme of 50/75/
150 ohms to VCCIO/2.

OFF is the default.
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Table 39:
Attribute

VCMT

VREF

Supported Devices Description

LatticeSC/M Establishes a common mode voltage for input buffer

elements. Depending on the I/O type and other
selected attributes, settings can include OFF, VCMT,
VTT, DDR_II.

OFF is the default.

All except MachXO and Platform Assigns a defined voltage reference for the signal
Manager or port group.

See Also »“IO_TYPE” on page 1244
“Defining IOBUF Preferences” on page 460
TN1262, ECP5 syslO Usage Guide
TN1056, LatticeECP/EC and LatticeXP syslO Usage Guide.
TN1088, LatticeSC PURESPEED I/O Usage Guide
TN1102, LatticeECP2/M syslO Usage Guide
TN1177, LatticeECP3 syslO Usage Guide
TN1136, LatticeXP2 syslO Usage Guide
TN1091, MachXO syslO Usage Guide
TN1202, MachXO2 syslO Usage Guide
TN1280, MachXO3L syslO Usage Guide

Setting Clock Preferences

The Clock Resource sheet enables you to apply a clock domain to the
device's primary or secondary clock or prohibit the use of primary and
secondary clock resources in routing the net. For LatticeECP2 and
LatticeXP2, it allows you to use edge clock resources to minimize the delay
from the clock sources to I/O registers. For LatticeECP3 devices, it also
enables you to specify a defined clock REGION, instead of a quadrant, for a
secondary clock.

For clock enable (CE) or local set reset (LSR) signals, a secondary clock can
be assigned or prohibited. Clocks for a clock net can be prohibited with the
Prohibit Both command. This command writes a PROHIBIT PRIMARY and a
PROHIBIT SECONDARY preference to the logical preference file (.Ipf).

For a primary clock, you can also specify DCS or PURE for routing the clock
spine. DCS will route the clock spine using the dynamic clock resource;
PURE will route the clock spine without using the DCS routing resource.

The settings that you specify are written to the logical preference file (.Ipf) as
USE PRIMARY, USE SECONDARY, PROHIBIT PRIMARY, PROHIBIT
SECONDARY, USE EDGE, and PROHIBIT EDGE preferences.
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To set clock preferences:
1. In Spreadsheet View, select the Clock Resource sheet.

2. Inthe Selection, Quadrant, and DCS/PURE columns, double-click the cell
for a given signal and choose the desired setting from the drop-down list.
Optionally, right-click the cell and choose the setting from the pop-up
menu.

Note

When a clock REGION is specified for a secondary clock, the REGION
<region_name> <region_clock_space> preference must precede the USE
SECONDARY preference that references it in the logical preference file.

Setting Output Load

The OUTPUT LOAD preference enables you to modify loading on output
buffers from the default 0 pFs for timing analysis. You can specify the output
load in the Port Assignments sheet of Spreadsheet View.

To set output load:
1. In Spreadsheet View, select the Port Assignments tab.

2. Double-click the cell in the Outload column that you want to modify for a
given output signal and type the desired output load value.

Setting Maximum Skew

The MAXSKEW preference sets a maximum signal skew between a driver
and loads on a specific clock signal.

To set the maximum skew:
1. In Spreadsheet View, select the Port Assignments tab.

2. Double-click the cell in the MaxSkew column that you want to modify for a
given signal, and type the desired maximum skew value.

3. To specify the maximum skew for clock load only, double-click the Clock
Load Only cell and choose True.

Assigning Route Priorities

The PRIORITIZE preference enables you to assign a priority to a selected
net. Values range from 0 (lowest priority) to 100 (highest). This preference is
used by the placement and routing (PAR) process, which assigns long lines
by net priority and routes higher-priority nets before routing lower-priority nets.

To assign route priorities:

1. In Spreadsheet View, select the Route Priority tab.
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The Route Priority sheet contains three column headings: Type, Name,
and Prioritize.

2. Choose Tools > Netlist View and click the nets button & . from the Netlist
View toolbar.

3. Do one the following:

Click the Detach Tool button ' at the top right to open Netlist View in
a separate window, and then position Netlist View alongside
Spreadsheet View.

Click the Split Tab Group button [f§ on the toolbar to separate Netlist

View into a tab group, and then select Spreadsheet View in the main
tab group. Both views now appear side-by-side.

4. In Netlist View, expand the Nets list in the design tree.
5. Use Ctrl+click or Shift+click to select the nets that you want to prioritize.

6. Drag the selected nets to the Route Priority preference sheet and release
the mouse button.

Each net is given the default priority of 3.

7. To change the net priority of a selected net, double-click the Prioritize cell,
and either type the desired value or select the value from the up and down
arrows.

8. To return any nets to the default value, right-click the Prioritize cells for the
selected nets and choose Clear or press the Delete key.

Click the “Integrate All Tools” button to integrate the detached Netlist View
with the main window.

Click the “Merge Tab Group” button EE to merge the split tab into the main tab
group.

To remove nets from the Route Priority sheet:

Select the entire rows of the nets you want to remove, right-click, and
choose Delete Selected Rows.

Specifying Registers for Flip-Flops

The USE DIN CELL and USE DOUT CELL preferences enable you to specify
registers in your design that are to be used as input or output flip-flops. For
each of these preferences, the True setting moves registers into the 1/0Os, and
the False setting moves registers out of the 1/Os.

To specify registers for flip-flops:
1. In Spreadsheet View, select the Cell Mapping tab.

2. Choose Tools > Netlist View and click the instances button =7 from the
Netlist View toolbar.

3. Do one the following:
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Click the Detach Tool button = at the top right to open Netlist View in
a separate window, and then position Netlist View alongside
Spreadsheet View.

Click the Split Tab Group button [f§ on the toolbar to separate Netlist

View into a tab group, and then select Spreadsheet View in the main
tab group. Both views now appear side-by-side.

To add registers to the Cell Mapping sheet, expand the Registers folder in
the design tree of Netlist View, and then select the registers that you want
to specify as flip-flops.

Drag the selected registers to the Cell Mapping preference sheet and
release the mouse button.

In the Din/Dout column for the selected flip-flop, choose DIN or DOUT and
press Enter.

The PIO Register cell is automatically changed to TRUE.

To change the PIO Register value, double-click the PIO Register cell and
choose FALSE.

To undo the any of the values you have assigned, right-click the selected
Prioritize cells and choose Clear or press the Delete key.

Click the “Integrate All Tools” button to integrate the detached Netlist View
with the main window.

Click the “Merge Tab Group” button EE to merge the split tab into the main tab
group.

To remove registers from the Cell Mapping sheet:

Select the entire rows of the registers you want to remove, right-click, and
choose Delete Selected Rows.

Specifying Voltage and Temperature

The Global preference sheet enables you to define the device core voltage
and core temperature for any Lattice device. For LatticeSC/M devices, it also
allows you to set other voltages for derating.

To specify voltage and temperature settings:

1.
2.

In Spreadsheet View, select the Global Preferences tab.

In the Preference Value column, double-click the cell for Junction
Temperature and type a new value. Do the same for Voltage.

For LatticeSC/M devices, double-click the Preference Value cell for
Derating and choose the desired value from the drop-down list.
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Migrating Pin Assignments

Diamond provides pin compatibility information that helps you migrate pin
assignments to a different device of the same family and package as the
currently targeted device. This information enables you to save your current
pinout while you explore other devices. It shows you which pins in your
current device will be unavailable or have different functions when you switch
devices, and it allows you to export the pin migration information to a pin
layout file.

You use the “Incompatible Pins” dialog box to select one or more devices that
are of the same family and package as your current device. Afterwards, you
can view all incompatible pins in Spreadsheet View and Package View. The
rows for incompatible pins are dimmed on the Pin Assignments sheet of
Spreadsheet View. In Package View, a dark gray circle appears behind each
incompatible pin square.

Pin compatibility information is available after the Translate Design process. It
is available for all device families except Platform Manager.

Note

Pin migration is not available for LatticeSC/M devices.

See Also »“Selecting a Device for Possible Pin Migration” on page 468
“Viewing Incompatible Pins” on page 470
“Exporting Pin Migration Information” on page 471
“Exporting a Pin Layout File” on page 548
“Color Coding of Cell Values” on page 396

Selecting a Device for Possible Pin Migration

The Incompatible Pins dialog box allows you to select one or more devices for
possible pin migration. Afterwards you can view the incompatible pins—those
that would not be available or that would have a different function if you were
to switch from the current device.

To select one or more devices for pin migration:
1. Open Spreadsheet View or Package View.

2. Choose View > Show Incompatible Pin or click the 4 button on the
toolbar.

The Incompatible Pins dialog box lists all the devices that are of the same
device family and package as the current device.

3. Select one or more of the devices from the Compatible Devices list, or
select All Devices.

If you select one device from the list, the incompatible pins will include
those between the current device and the selected device.
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If you select more than one device or All Devices, the incompatible pins
will include those between the current device and the combination of all
selected devices.

Note

The LFE3-17EA, in a 484 package, may have a DQS grouping migration issue
that requires design changes if DQS-DQ associations are used in the design.
Refer to the ECP3 Data Sheet and the ECP3 pinout files for the specific devices to
check for DQS grouping mismatches.

In the Check Areas section, select the types of incompatibility that you
want included for the selected devices: pins whose type, configuration,
LVDS/high