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Release Notes for 
Lattice Diamond 2.0.1

Welcome to Lattice Diamond®, the complete design environment for Lattice 
Semiconductor FPGAs. Lattice Diamond design software offers leading-edge 
design and implementation tools optimized for cost-sensitive, low-power 
Lattice FPGA architectures. Diamond is the next generation replacement for 
ispLEVER®, featuring design exploration, ease of use, improved design flow, 
and numerous other enhancements. Diamond is available for both the 
Windows and Linux operating systems. For details, see “Windows System 
Requirements” on page 10 or “Linux System Requirements” on page 12.

This version of Diamond adds a variety of enhancements to make designing 
for Lattice Semiconductor programmable devices easier than ever. The 
design tools also include support for the latest Lattice Semiconductor devices. 
See “What’s New” on page 2.

Known issues and workarounds are described in the Lattice Forums on the 
Lattice Semiconductor Web site: www.latticesemi.com/latticeforums. Under 
“Questions & Answers,” find “Lattice Diamond Known Issues” and click on the 
version number.

Under Design Tools and IP, click Lattice Diamond for the latest questions 
and answers. You can also ask questions in the Lattice Forums.

Lattice Semiconductor offers a rich variety of information sources, including 
the Help system, PDF manuals, tutorials, and online discussions. The easiest 
way to reach them all is through the online Help. The first topic in the Help 
provides links to all the other sources of information.

You can also find extensive information about Diamond, it’s capabilities, tools, 
and workflow on the Lattice Semiconductor Web site under:

www.latticesemi.com/latticediamond

../webhelp/eng/index.htm?context=Getting_Started&topic=Getting_Started
http://www.latticesemi.com/latticediamond
http://www.latticesemi.com/latticeforums
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What’s New
This release of Diamond provides a variety of new features in the following 
areas. See the online Help for details.

What’s New in Diamond 2.0.1

New Device Support The iCE40™ devices can be simulated with Aldec® 
Active-HDL™ Lattice Edition and can be programmed with Programmer.

Devices supported by the ispLEVER Classic design tools can also be 
simulated with the Active-HDL simulator found in Diamond.

LatticeECP4™ is no longer supported.

Timing Simulation Diamond supports the timing simulation flow when a 
design includes DDR2 or DDR3 memory interfaces.

Schematic Editor Schematic Editor has a variety of enhancements.

What’s New in Diamond 2.0

64-Bit Windows 7 The following software is now available in 64-bit versions 
that run on 64-bit Windows 7:

 Lattice Diamond with the full Diamond tool set

 Power Estimator

 Programmer

 Reveal™ Analyzer

The 64-bit version of IPexpress requires modules and IP that have been 
modified for the 64-bit environment. Modules are included with the software 
and can be configured and used with the 64-bit version. Previously 
downloaded and installed 32-bit IP cannot be configured with 64-bit 
IPexpress. However, 32-bit IP that have already been configured and 
generated will continue to work in your designs but cannot be modified.

Use IPexpress to download updated IP. If you are using 64-bit Diamond, IP 
that have not yet been updated are grayed out and cannot be downloaded. If 
the IP you need is not yet available, check again later or contact Lattice 
Applications. For instructions for downloading and installing IP, open the 
online Help and go to Entering the Design > Designing with Modules > 
Creating IPexpress Modules and IP > Downloading IPexpress IP.

../webhelp/eng/index.htm?context=Design_Entry&topic=downloading_IP
../webhelp/eng/index.htm?context=Design_Entry&topic=downloading_IP
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Red Hat Linux The following software are now available on Red Hat 
Enterprise Linux 6:

 Lattice Diamond with the full Diamond tool set

 LatticeMico System

 Power Estimator

 Programmer

 Reveal Analyzer

For Red Hat Enterprise Linux (all supported versions), there is now parallel 
port support for Programmer, Reveal, and LatticeMico System. A special 
installer is required to enable this feature. See the “Lattice Diamond 2.0 
Installation Notice for Linux.”

Deployment Tool Deployment Tool has been updated with such new 
features as file conversion capability, including the ability to convert bitstream, 
JEDEC, IEEE 1532 ISC data, and application-specific BSDL files from one 
format to another; external memory capability, including advanced SPI flash 
and sysCONFIG™ daisy chain; the ability to edit the USERCODE; and the 
ability to edit security fuse settings.

Deployment Tool enhancements include embedded system ability to copy the 
embedded source code to the output file directory; enhanced I2C embedded 
features including JEDEC file input support, the ability to specify the I2C slave 
address, the ability to include comments, and the ability to specify fixed pulse 
width. Also, embedded slave SPI now supports JEDEC file input.

For more information, open the online Help and go to: Programming the 
FPGA > Deploying the Design with the Deployment Tool.

Documentation With this release, Lattice introduces an online FPGA 
Design Guide including in depth discussion of “Design Planning” and “Timing 
Closure” with Lattice FPGAs. For easy access, see the Start Page in 
Diamond.

IPexpress Module Reference Guide is now called Lattice Module Reference 
Guide because it now includes the similar System Planner modules. See 
“System Planner” on page 6.

The “Designing with Modules” section of Entering the Design has been re-
organized by module type. The section has all the same topics with the same 
information, but you may find this organization easier to understand.

ECO Editor The new Signal Probes sheet enables you to assign signals to 
external pins as test probes for debugging. For more information, open the 
online Help and go to Applying Engineering Change Orders > Adding Signal 
Probes.

Floorplan View and Physical View The new Find dialog box enables you 
to search for a component, net, or site. For more information, open the online 
Help and go to Applying Design Constraints > Using Diamond's Preference 
Views > Searching for Design Elements.

../webhelp/eng/index.htm?context=Device_Programming&topic=Deployment_Tool
../webhelp/eng/index.htm?context=Device_Programming&topic=Deployment_Tool
../webhelp/eng/index.htm?context=Constraints&topic=searching_for_design_elements
../webhelp/eng/index.htm?context=Constraints&topic=searching_for_design_elements
../webhelp/eng/index.htm?context=Design_ECOs&topic=adding_signal_probes
../webhelp/eng/index.htm?context=Design_ECOs&topic=adding_signal_probes
http://www.latticesemi.com/dynamic/view_document.cfm?document_id=45589
http://www.latticesemi.com/dynamic/view_document.cfm?document_id=45588
http://www.latticesemi.com/dynamic/view_document.cfm?document_id=45588
../webhelp/eng/index.htm?context=IPexpress&topic=intro
../webhelp/eng/index.htm?context=IPexpress&topic=intro
../webhelp/eng/index.htm?context=Design_Entry&topic=designing_with_modules
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Hierarchy The Hierarchy view now shows the full path name of the files that 
define each module. For more information, open the online Help and go to: 
Managing Projects > Analyzing a Design> Working with the HDL Diagram 
Interface > Hierarchy View.

Incremental Design Flow This release of Diamond supports the 
Incremental Design flow feature for LatticeECP2M and LatticeECP3 devices. 
Incremental Design is a design methodology that preserves certain process 
results and performance on portions of a design while reducing re-processing 
time by focusing on other parts of the design during multiple design 
processing iterations. It accomplishes this by using design partitions you 
define in synthesis through Compile Points. Partitions allow you to lock down 
and preserve timing stability by preventing specified modules from being 
changed in the next design iteration. For more information, open the online 
Help and go to Using Incremental Design Flow.

IPexpress IPexpress™ contains numerous improvements to existing 
modules.

ispLeverDSP The ispLeverDSP software, blocks, and reference designs 
are no longer included with Diamond.

LatticeMico System LatticeMico™ System has been upgraded to the 
Eclipse 3.6.2 Platform. For more information, refer to the “LatticeMico System 
Software Release Notes for Diamond.” To access the release notes:

 If LatticeMico System is installed with Diamond, go to the Windows Start 
menu and choose Programs > Lattice Diamond > Accessories > 
LatticeMico System Release Notes.

 If LatticeMico System is installed as a stand-alone tool, go to the Windows 
Start menu and choose Programs > Lattice Diamond > LatticeMico 
System Release Notes.

Pin Migration The new “Check Areas” section of the Incompatible Pins 
dialog box allows you to narrow the list of incompatible pins to those whose 
type, configuration, LVDS/high speed, and bank numbers differ between the 
current device and the selected devices. For more information, open the 
online Help and go to Applying Design Constraints > Setting Preferences > 
Migrating Pin Assignments.

Place & Route The negotiation-based router (NBR), which helps reduce 
runtime on designs that are highly congested or difficult to route, is set as the 
default router. For more information, open the online Help and go to 
Implementing the Design > Place and Route > Improving PAR Results for 
Highly Congested Routing.

Preferences A new preference allows you to block a path going to a 
specific pin of a specific physical component:

BLOCK COMP <comp_name> PIN <pin_name> ;

COMP is a COMPONENT like SLICE_4. For more information, open the 
online Help and go to Constraints Reference Guide > Preferences > BLOCK.

../webhelp/eng/index.htm?context=Constraints_Ref&topic=block
../webhelp/eng/index.htm?context=Incremental_Design&topic=intro
../webhelp/eng/index.htm?context=Design_Implementation&topic=improve_par_congested_routing
../webhelp/eng/index.htm?context=Design_Implementation&topic=improve_par_congested_routing
../webhelp/eng/index.htm?context=Managing_Projects&topic=hierarchy_view
../webhelp/eng/index.htm?context=Managing_Projects&topic=hierarchy_view
../webhelp/eng/index.htm?context=Constraints&topic=migrating_pin_assignments
../webhelp/eng/index.htm?context=Constraints&topic=migrating_pin_assignments
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Programmer Programmer has been updated with such new features as 
support for MachXO2 I2C programming, custom I/O state, capture I/O state, 
dynamic I/O state, dual boot secure sector support, and custom SPI flash.

Programmer enhancements include support for custom SPI flash, a new 
device ID column in the spreadsheet, a new device package column in the 
spreadsheet, and a new display register dialog box.

For more information, open the online Help and go to Programming the 
FPGA.

Power Calculator The enhanced Startup Wizard for the stand-alone Power 
Calculator enables you to open a Power Calculator project file, calculate the 
power usage of an existing .ncd file, or estimate power usage based on a 
selected device. For more information, open the online Help and go to 
Analyzing Power Consumption > Starting Power Calculator as a Stand-Alone 
Tool.

Power Estimator The new Lattice Power Estimator is a stand-alone tool 
that does not require the installation of Diamond. Power Estimator gives you 
the option of estimating power consumption based on a selected device, 
performance grade, and operating conditions; or of extracting the settings 
from a saved Power Calculator project file (.pcf).

Reveal Analyzer Reveal Analyzer supports easily changing the cable 
connection to the board after the Reveal Analyzer project has been created. 
Previously you had to recreate the project if you had to change port or the 
cable type used. For more information, open the online Help and go to Testing 
and Debugging On-Chip > Performing Logic Analysis > Starting Reveal 
Analyzer > Changing the Cable Connection.

Run Manager Run Manager can also be controlled by the Process menu 
commands, but they only affect the active implementation. You can choose 
commands from the Process menu in the menu bar or the right-click menu in 
the Process view. The Process view also shows the status of the active 
implementation. For more information, open the online Help and go to: 
Managing Projects > Working with Run Manager.

Spreadsheet View The new “File > Export All SSV Preferences to LPF” 
command enables you to export all Spreadsheet View preferences, including 
default preferences, to a single logical preference file. For more information, 
open the online Help and go to Applying Design Constraints > Exporting/
Importing Pin Files and Preference Sheets.

Strategy Options In previous versions, Diamond only saved strategy 
settings that were changed from the defaults. If nothing was saved for an 
option, the default would be used. However, sometimes a default value is 
changed in later versions of the software. So in a previous version the default 
was True, but in the new version of Diamond the default is False. New design 
projects might work better, but someone upgrading Diamond during a project 
might see an unexpected change in their implementation.

With the 2.0 release, Diamond saves all strategy values whether they are 
default values or not. If a strategy is migrated to a future version of Diamond, 

../webhelp/eng/index.htm?context=On-Chip_Debugging&topic=change_cable_connection
../webhelp/eng/index.htm?context=On-Chip_Debugging&topic=change_cable_connection
../webhelp/eng/index.htm?context=On-Chip_Debugging&topic=change_cable_connection
../webhelp/eng/index.htm?context=Device_Programming&topic=FPGA_Configuration
../webhelp/eng/index.htm?context=Device_Programming&topic=FPGA_Configuration
../webhelp/eng/index.htm?context=Power_Analysis&topic=starting_powercalc_stand_alone
../webhelp/eng/index.htm?context=Power_Analysis&topic=starting_powercalc_stand_alone
../webhelp/eng/index.htm?context=Constraints&topic=exporting_importing_reports
../webhelp/eng/index.htm?context=Constraints&topic=exporting_importing_reports
../webhelp/eng/index.htm?context=Managing_Projects&topic=working_with_multiple_place_and_route_runs


Supported Third-Party Tools

6 Release Notes for Lattice Diamond 2.0.1

the saved values will be used regardless of any future changes to the 
defaults, providing more consistent results from one release to another.

Synthesis Tools The Synopsys® Synplify Pro® for Lattice and Lattice 
Synthesis Engine (LSE) synthesis tools have been updated.

TRACE A cross-probing feature has been added that enables you to cross-
probe a path from the TRACE report to the HDL Analyst view in Synplify Pro. 
For more information, open the online Help and go to Analyzing Static Timing 
> Running TRACE > Cross-Probing to Synplify Pro HDL Analyst.

The “Check Unconstrained Paths” option has been enhanced to report the 
start point and end point of each path that is unconstrained. For more 
information, open the online Help and go to Analyzing Static Timing > 
Running TRACE > Setting TRACE Options.

The Map and Place & Route Trace Reports have the option to report 
connections and paths that are not covered by timing preferences. You can 
control these reports with the new strategy options Check Unconstrained 
Connections and Number of Unconstrained Paths. These options are 
available under both Map Trace and Place & Route Trace in the Strategies 
dialog box. To see the dialog box, go to the File List view and double-click a 
strategy.

Supported Third-Party Tools
This version of Diamond has been tested with the following third-party tools:

 Active-HDL™ 9.1

 Modelsim® (SE) for 32-bit Windows 10.0b

 Modelsim® (SE) for 64-bit Linux 10.0d

 NC-Sim 10.20-P008

 Questa for Windows 10.1a

 Riviera 2010.10

 Synplify Pro F-2012.03L

 Precision 2010a Update 2

 VCS 2010.06-SP1

../webhelp/eng/index.htm?context=Static_Timing_Analysis&topic=cross-probe_hdl-analyst
../webhelp/eng/index.htm?context=Static_Timing_Analysis&topic=cross-probe_hdl-analyst
../webhelp/eng/index.htm?context=Static_Timing_Analysis&topic=trace_timing_analysis_options
../webhelp/eng/index.htm?context=Static_Timing_Analysis&topic=trace_timing_analysis_options
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Supported Devices
Lattice Diamond can be used with either a free license or a subscription 
license. The two licenses provide access to different device families.

Updating Projects from an Earlier Version
If you want to work on a design project created with an earlier version of 
Diamond, start with the following procedures. These procedures adapt the 
project for the following changes in Diamond.

Find out which version of Diamond your project was created with. Then work 
through the changes for that and every later version, starting with the earliest 
and going to the most recent. For example, if your project was created with 
Diamond 1.1, you would start with the changes for 1.1. After completing those 
changes you would work on the changes for each later version (1.2).

When you open a project from Diamond 1.2 or earlier, Diamond opens a 
dialog box warning that Diamond will automatically move all SDC files to the 
Synthesis Constraint Files folder in File List view and remove the “Input SDC 
Constraint File” options from the strategies. If the project is using LSE, the 
filenames will be changed to use an .ldc extension.

Once saved, the project will not be compatible with earlier versions of 
Diamond.

Device Family Free License Subscription License

LatticeEC™  

LatticeECP™  

LatticeECP2™  

LatticeECP2M™ 

LatticeECP2S 

LatticeECP2MS 

LatticeECP3™ 

LatticeSC™ 

LatticeSCM™ 

LatticeXP™  

LatticeXP2™  

MachXO™  

MachXO2™  

Platform Manager™  



Updating Projects from an Earlier Version

8 Release Notes for Lattice Diamond 2.0.1

1.4 Projects
For Diamond 1.4 and earlier, there might be some constraints that are not 
honored because of the Synplify Pro cross-probing feature. This EDIF 
renaming is usually related to bus names.

If such a problem occurs, you can turn off the renaming feature by placing the 
following line in the “Command line Options” text box of the Synplify Pro 
section of the active strategy:

set_option -syn_edif_array_rename 0

1.2 Projects
There were several enhancements for IP and MachXO2.

IP Incompatibilities
SPI4.2 2.7 is not compatible with Diamond 1.3 or later. If you are using this IP, 
check the Lattice Semiconductor Web site for a more recent version.

MachXO2 Changes
See if your design involves any of the following features:

 For EFB modules with user flash memory (UFM), regenerate the module.

 For IO_TYPE=PCI33 on a MachXO2-1200 or larger device, check if the 
CLAMP is using the default setting. With Diamond 1.3 the CLAMP default 
changes from ON to PCI and the I/O will be placed in bank 2. If you were 
using the default and still want the setting to be ON, you need to set it 
explicitly.

 For PCI33 MT 6.5 and PCI33 T 6.4 IP, either set the CLAMP to ON 
explicitly or choose a bigger package (256 or more).
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1.1 or 1.0 Projects
There were several enhancements for IP and MachXO2.

IP Incompatibilities
The following IP versions are not compatible with Diamond 1.2 or later. If you 
are using any of these IP, check the Lattice Semiconductor Web site for a 
more recent version.

MachXO2 Support
Some aspects of the software support for MachXO2 designs have been 
improved. See if your design involves any of the following features:

 The 4K/7K design with PLL has a CIB-to-PLL jump change. If you are 
using this design, recompile it.

 The EFB simulation model has changed. If you are using the EFB module, 
rerun your simulation tests to see more accurate results.

 In the DDR_GENERIC module of IPexpress, the GDDRX1_RX.Aligned 
with PLL interface is no longer supported. If you are using such a module, 
use IPexpress to regenerate it without the PLL option.

Also, MachXO2 has IP evaluation capability and TransFR mode for all I/Os.

Migrating ispLEVER Projects
Diamond uses a different project structure than ispLEVER and cannot directly 
open an ispLEVER project. However, design projects created in ispLEVER 
can easily be imported into Diamond. The process is automatic except for the 
ispLEVER process properties, which are similar to the Diamond strategy 
settings, and some modules and IPs. All of your ispLEVER project source will 
be automatically handled.

Projects created using ispLEVER can be imported into Lattice Diamond 
through two different paths:

 On the Start Page, click Import ispLEVER Project (in the upper-left 
corner).

 From the File menu, choose Open > Import ispLEVER Project.

 Convolution Block Encoder 3.6

 DDR1 6.9

 DDR2 7.1

 DDR3 1.2.1

 DDR1_CP 1.1 with MachXO2

 DDR2_CP 1.1 with MachXO2

 Interleaver Deinterleaver 3.5

 PCI_MT_33 6.4

 PCIe RC Lite 1.2

 Tri-Speed MAC 3.4

 Viterbi Block Decoder 4.6
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Follow the directions in the dialog box that opens to convert your ispLEVER 
project into a Lattice Diamond project.

Limitations to the import/conversion process include:

 NGO files in ispLEVER projects need to be manually copied into the 
Lattice Diamond project if the NGO files were originally copied into the 
ispLEVER project. For example, NGO files that were copied from Lattice 
IP generation.

 The .lpc files are replaced with .ipx files in Lattice Diamond. You need to 
regenerate your IP by double-clicking on the .lpc file. The resultant wizard 
will help you generate the new .ipx file, replacing the old .lpc file.

More information on importing ispLEVER projects can be found in the Lattice 
Diamond User Guide, online Help (see Managing Projects > Importing 
ispLEVER Projects), and training videos on the Lattice Web site.

Other Information Resources
Other available information resources for the Diamond software include the 
following.

 General Information: General information on Lattice Diamond can be 
found on the Lattice Web site at:

www.latticesemi.com/latticediamond

 Online Help: Start Lattice Diamond and choose Help > Lattice Diamond 
Help.

 Lattice Diamond User Guide: This document can be found from a link on 
the Start Page view or downloaded from:

www.latticesemi.com/latticediamond/downloads

 Training Videos: Several short videos are available on different aspects of 
the Lattice Diamond software. These can be viewed online at:

www.latticesemi.com/latticediamond/videos

Windows System Requirements
The basic system requirements for Lattice Diamond on Windows are:

 Intel Pentium or Pentium-compatible PC

 Windows XP, Windows Vista (32-bit), or Windows 7 (32-bit or 64-bit)

 Approximately 5.75 GB free disk space

Note

If your operating system is Windows Vista, make sure you have installed all the 
latest patches from Microsoft.

http://www.latticesemi.com/latticediamond
http://www.latticesemi.com/latticediamond/downloads
../webhelp/eng/index.htm?context=Managing_Projects&topic=importing_isplever_project
../webhelp/eng/index.htm?context=Managing_Projects&topic=importing_isplever_project
http://www.latticesemi.com/latticediamond/videos
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 1024 X 768 graphics display

 Microsoft-compatible mouse and mouse driver

 Network adapter 

 JScript-capable Web browser

 Acrobat Reader 5.0 or later

Memory Requirements
Table 1 lists the minimum memory requirements and the recommended 
memory for all the Lattice Semiconductor FPGA families. Designing for the 
largest FPGAs may require more than the usual 2 GB of memory. For help in 
extending your memory to 3 GB, see “Extending Memory” on page 12. 
Designing for LatticeECP3 with more than 95K LUT requires a 64-bit 
operating system.

Note

A node-locked license is based on the physical (hard-coded) address provided by 
the network adapter. Network connectivity is not required for a node-locked 
license. In the absence of a network connection, you can install the NWLink IPX/
SPX protocol to force recognition of your NIC card ID (see the installation notice).

A floating license requires access to the license server, so both a network adapter 
and connectivity are required.

Table 1:  Recommended Memory for Windows

Device Size Minimum Recommended

LatticeEC, 
LatticeECP

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

LatticeECP2/M Up to 20K LUT 768 MB 1 GB

Up to 50K LUT 1 GB 1.5 GB

Up to 100K LUT 1 GB 2 GB

LatticeECP3 Up to 95K LUT 2 GB 3 GB

Up to 150K LUT 3 GB 4 GB

LatticeSC/M Up to 40K LUT 768 MB 1 GB

Up to 115K LUT 1 GB 2.5 GB

LatticeXP, 
LatticeXP2

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

MachXO, 
MachXO2

All 256 MB 512 MB

Platform Manager All 256 MB 512 MB
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Extending Memory
Designing for LatticeECP3 may require more than the 2 GB normally 
available with 32-bit Windows systems. But you can configure Windows to 
use up to 3 GB of memory.

Note that increasing the amount of memory available to applications, 
decreases the amount available for the file cache, paged pool, and nonpaged 
pool, which can affect applications with heavy networking or I/O.

In Windows XP
In Windows XP Professional, add the /3GB switch to the end of the startup 
line in the boot.ini file. For details, see the following Microsoft articles:

 “Windows XP SP1 May Not Start with the /3GB or /USERVA Switch”:
support.microsoft.com/?kbid=328269

 “How to edit the Boot.ini file in Windows XP”:
support.microsoft.com/default.aspx?scid=kb;en-us;q289022

 “Memory Support and Windows Operating System” shows an example of 
the boot.ini with the /3GB switch:
msdn.microsoft.com/en-us/windows/hardware/gg487508.aspx

In All Other Versions of Windows
Use the BCDEdit /set increaseuserva 3072 command to set the boot entry 
option to 3 GB. For details, see Microsoft article “BCDEdit /set”:
msdn.microsoft.com/en-us/library/ff542202.aspx

Linux System Requirements
The basic system requirements for Lattice Diamond on Linux are:

 Intel Pentium or Pentium-compatible PC, or AMD Opteron system support

The ispVM System contains a 32-bit driver to support the 32-bit system 
only.

 Red Hat Enterprise Linux 4.X, 5.3, or 6; or Novell SUSE Linux Enterprise 
10 SP1 or 11 operating system

The host operating system can be either 32-bit or 64-bit. Diamond is a 32-
bit application requiring 32-bit support libraries to run on a 64-bit host 
operating system.

Version 5.3 of Red Hat Enterprise Linux has some extra installation 
requirements. See “Configuring Red Hat 5.3” on page 13.

 Approximately 5.75 GB free disk space

 1024 x 768 graphics display

 JScript-capable Web browser

http://support.microsoft.com/?kbid=328269
http://msdn.microsoft.com/en-us/windows/hardware/gg487508.aspx
http://support.microsoft.com/default.aspx?scid=kb;en-us;q289022
http://msdn.microsoft.com/en-us/library/ff542202.aspx


Linux System Requirements

Release Notes for Lattice Diamond 2.0.1 13

 Adobe Acrobat Reader, or equivalent PDF reader

 Network adapter and network connectivity

A floating license requires access to the license server, so both a network 
adapter and connectivity are required.

Memory Requirements
Table 2 lists the minimum memory requirements and recommended memory 
for all the Lattice Semiconductor FPGA families.

Configuring Red Hat 5.3
Red Hat Enterprise Linux 5.3 has some extra requirements for Diamond:

 In addition to the basic installation of Red Hat 5.3, under Development/ 
Legacy Software Development, select:

1:gtk+-1.2.10-56.el5.i386 - GIMP Toolkit (GTK+) sb:(9 of 9)

Under Base System/Legacy Software Support, add the following to the 
default items:

Openmotif22-2.2.3-18.i386 - Open Motif runtime

Proper Diamond operation depends upon these libraries being installed.

Table 2:  Recommended Memory for Linux

Device Size Minimum Recommended

LatticeEC, 
LatticeECP

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

LatticeECP2/M Up to 20K LUT 768 MB 1 GB

Up to 50K LUT 1 GB 1.5 GB

Up to 100K LUT 1 GB 2 GB

LatticeECP3 Up to 95K LUT 2 GB 3 GB

Up to 150K LUT 3 GB 4 GB

LatticeSC/M Up to 40K LUT 768 MB 1 GB

Up to 115K LUT 1 GB 2.5 GB

LatticeXP, 
LatticeXP2

Up to 20K LUT 512 MB 768 MB

Up to 50K LUT 768 MB 1 GB

MachXO, 
MachXO2

All 256 MB 512 MB

Platform Manager All 256 MB 512 MB
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 When installing the Red Hat Enterprise Linux version, be sure to install the 
PERL modules XML::Parser, XML::DOM, and XML::RegExp. These 
PERL modules are available at www.cpan.org.

Contacting Technical Support

FAQs The first place to look. The Lattice FAQs (frequently asked questions) 
provide solutions to questions that many of our customers have already 
asked. Lattice Applications Engineers are continuously adding to the FAQs.

Online Forums Lattice Forums contain a wealth of knowledge and are 
actively monitored by Lattice Applications Engineers.

Telephone Support Hotline Receive direct technical support for all Lattice 
products by calling Lattice Applications from 5:30 a.m. to 6 p.m. Pacific Time.

 For USA & Canada: 1-800-LATTICE (528-8423)

 For other locations: +1 503 268 8001

In Asia, call Lattice Applications from 8:30 a.m. to 5:30 p.m. Beijing Time 
(CST), +0800 UTC. Chinese and English language only.

 For Asia: +86 21 52989090

E-mail Support

 techsupport@latticesemi.com

 techsupport-asia@latticesemi.com

For Local Support Contact your nearest Lattice Sales Office.

Trademarks
Lattice Semiconductor Corporation, L Lattice Semiconductor Corporation (logo), L (stylized), L (design), Lattice 
(design), LSC, CleanClock, Custom Movile Device, DiePlus, E2CMOS, Extreme Performance, FlashBAK, FlexiClock, 
flexiFLASH, flexiMAC, flexiPCS, FreedomChip, GAL, GDX, Generic Array Logic, HDL Explorer, iCE Dice, iCE40, 
iCE65, iCEblink, iCEcable, iCEchip, iCEcube, iCEcube2, iCEman, iCEprog, iCEsab, iCEsocket, IPexpress, ISP, 
ispATE, ispClock, ispDOWNLOAD, ispGAL, ispGDS, ispGDX, ispGDX2, ispGDXV, ispGENERATOR, ispJTAG, 
ispLEVER, ispLeverCORE, ispLSI, ispMACH, ispPAC, ispTRACY, ispTURBO, ispVIRTUAL MACHINE, ispVM, ispXP, 
ispXPGA, ispXPLD, Lattice Diamond, LatticeCORE, LatticeEC, LatticeECP, LatticeECP-DSP, LatticeECP2, 
LatticeECP2M, LatticeECP3, LatticeECP4, LatticeMico, LatticeMico8, LatticeMico32, LatticeSC, LatticeSCM, 
LatticeXP, LatticeXP2, MACH, MachXO, MachXO2, MACO, mobileFPGA, ORCA, PAC, PAC-Designer, PAL, 
Performance Analyst, Platform Manager, ProcessorPM, PURESPEED, Reveal, SensorExtender, SiliconBlue, Silicon 
Forest, Speedlocked, Speed Locking, SuperBIG, SuperCOOL, SuperFAST, SuperWIDE, sysCLOCK, sysCONFIG, 
sysDSP, sysHSI, sysI/O, sysMEM, The Simple Machine for Complex Design, TraceID, TransFR, UltraMOS, and 
specific product designations are either registered trademarks or trademarks of Lattice Semiconductor Corporation or 
its subsidiaries in the United States and/or other countries. ISP, Bringing the Best Together, and More of the Best are 
service marks of Lattice Semiconductor Corporation.

Other product names used in this publication are for identification purposes only and may be trademarks of their 
respective companies.

http://www.cpan.org
http://www.latticesemi.com/support/faqs/index.cfm
http://www.latticesemi.com/support/forums.cfm
mailto:techsupport@latticesemi.com
mailto:techsupport-asia@latticesemi.com
http://www.latticesemi.com/sales/index.cfm
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