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1
HDL Design with 
Precision RTL Synthesis: 
CPLD Flow Tutorial

This tutorial shows you how to use Mentor Graphics® Precision® RTL 
Synthesis from within ispLEVER® to synthesize a Verilog design and 
generate an EDIF file for a Lattice CPLD device. 

Learning Objectives
When you have completed this tutorial, you should be able to do the following:

Create a new EDIF project in ispLEVER and target a device.

Start Precision RTL Synthesis from within ispLEVER, synthesize your 
Verilog HDL design, and generate an EDIF netlist file.

Import the EDIF file into the ispLEVER system, fit the design, generate a 
JEDEC file, and view the Fitter report.

Perform static timing analysis using the Performance Analyst and view the 
results.

Note

If you want to learn how to use Precision RTL Synthesis in standalone mode or 
understand more about its advanced features, see the Precision RTL Synthesis Users 
Manual, Precision RTL Synthesis Style Guide, and Precision Synthesis Reference 
Manual in the online help.
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Time to Complete This Tutorial
The time to complete this tutorial is about 20 minutes.

System Requirements
One of the following software configurations is required to complete the 
tutorial:

IspLEVER Starter

ispLEVER

Accessing Online Help
You can find online help information on any tool included in the tutorial at any 
time by pressing the F1 key.

About the Tutorial Design
The tutorial design consists of a simple 4 to 1 multiplexer, as shown in 
Figure 1:

Figure 1: Tutorial Design

This tutorial first directs you to create an EDIF project in the Project Navigator, 
then select the target device in which the design will be implemented. It 
assumes that functional simulation has already been performed. Next, you 
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start Precision RTL Synthesis and open a new Precision project. After you 
import the Verilog source files and set the implementation options, the tool 
synthesizes the design into the target device and generates an EDIF netlist. 
You then import the EDIF netlist into the Project Navigator project and fit the 
design. Finally, you perform a static timing analysis and examine the results.

About the Tutorial Data Flow
Figure 2 illustrates the design flow that the tutorial takes.You may find it 
helpful to refer to this diagram as you move through the tutorial tasks.

Figure 2: Tutorial Design Flow

Task 1: Create a New Project
To begin a new project in the Project Navigator, you must create a project 
directory. Then give the project file a name (.syn) and declare the project 
type (EDIF). 

The ispLEVER software saves an initial design file with the .syn file 
extension in the directory that you specify. All project files are copied to or 
created in this directory. The project type specifies that all design sources will 
be of this type.

To create a new project:

1. Start the ispLEVER system, if it is not already running.

2. In the Project Navigator, choose File > New Project to open the Project 
Wizard dialog box.

*.v

Precision RTL 
Synthesis

top.edf

Fit Design

Performance 
Analyst

JEDEC file
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3. In the dialog box, do the following:

a. In the Project Name box, type mux4to1. 

b. In the Location box, change to the following directory: 
<install_path>\examples\tutorial\
precision_cpld_tutor.

c. In the Design Entry Type box, select EDIF.

d. In the Synthesis Tools box, select Precision, shown in Figure 3.

e. Click Next to open the Project Wizard – Select Device dialog box.

Figure 3: Project Wizard Dialog Box

Note

If you want to preserve the original tutorial design files, save the 
precision_cpld_tutor directory to another location on your computer before 
proceeding.
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Task 2: Target a Device
The Project Wizard enables you to target a design to a specific Lattice device.

In the Project Navigator Sources in Project window, the device icon  
appears next to the target device for the project. You can double-click the icon 
to change the target device at any time during the design process.

To view the list of available devices and select the target device:

1. In the Project Wizard – Select Device dialog box, do the following:

a. In the Family box, select ispMACH 4000.

b. In the Device box, select LC4256V.

c. Accept the default settings for the rest of the boxes, as shown in 
Figure 4.

Figure 4: Project Wizard - Select Device Dialog Box

d. Click Next to open the Project Wizard – Add Source dialog box.

2. In the Project Wizard – Add Source dialog box, click Next, then click 
Finish.
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Your Project Navigator should look like Figure 5.

Figure 5: Project Navigator Window Showing New Project

Task 3: Create a Precision RTL Synthesis Project
For HDL designs, the ispLEVER software provides two synthesis tools that 
are integrated into the Project Navigator environment: Synplicity’s Synplify 
and Mentor Graphics’ Precision RTL Synthesis. You can synthesize your 
Verilog or VHDL design as a standalone process by choosing the synthesis 
tool from the Project Navigator or Lattice Semiconductor program group in 
your Start menu, or you can synthesize automatically and seamlessly within 
the Project Navigator.

Precision RTL Synthesis is a logic synthesis tool that starts with a high-level 
design written in the Verilog or VHDL hardware description language (HDLs). 

Note

Click on the part name to see the contents of the Processes for Current Source 
window.
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Then it converts the HDL description into small, high-performance design 
netlists that are optimized for Lattice devices.

To start Precision RTL Synthesis:

1. In the Project Navigator, choose Tools > Precision Synthesis to open 
the Precision RTL Synthesis tool.

2. Click OK to close the Tip of the Day.

3. Choose File > New Project, or click on the New Project icon in the 
Project pane to open the New Project dialog box, shown in Figure 6.

4. In the dialog box, do the following:

a. In the Project Name box, type syn_mux4to1.

b. In the Project Folder box, make sure the following directory is shown:

<install_path>\examples\Tutorial\
precision_cpld_tutor

c. Click OK.

Figure 6: New Project Dialog Box

The Precision RTL Synthesis window looks like that shown in Figure 7.
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Figure 7: Precision RTL Synthesis Window Showing syn_mux4to1 
Project

Task 4: Add the Verilog HDL Source File
Next, you will add a Verilog HDL source file to the project.

To add a source file to the project:

1. Click the Add Input Files icon in the Design pane.

You should see one Verilog HDL (.v) file called mux4to1.v listed in the 
Open dialog box, as shown in Figure 8.

2. Select the mux4to1.v file, then click Open.
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Figure 8: Open Dialog Box

Task 5: Set Implementation Options
Now you will set the target device and implementation options for logic 
synthesis.

To set the implementation options:

1. In the Design pane, click the Setup Design icon.

2. In the Project Settings dialog box, shown in Figure 9, click the plus sign 
(+) next to Lattice, and select ispMACH 4000. 

3. In the Device box, select LC4256V-10T100I.

4. Click OK.
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Figure 9: Project Settings Dialog Box

Task 6: Compile the Design
In this task, you will compile the Verilog HDL design.

To compile the design:

1. In the Design pane, click Compile.

The Precision RTL Synthesis software reads the input file and compiles 
the design using the source file, targeted device, and other settings.

The Precision RTL Synthesis window now lists the clocks, ports, nets, and 
instances in the design, as shown in Figure 10.
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Figure 10: Precision RTL Synthesis Window After Compilation

Select the Design Analysis pane to examine key reports and graphical views 
of the design, including the RTL Schematic (View RTL Schematic).

Task 7: Synthesize the Design
Now you will synthesize the Verilog HDL design.

To synthesize the design:

1. Click the Synthesize icon.

Precision RTL Synthesis synthesizes the Verilog HDL design and creates 
an EDIF file, as well as several other files, and displays them in the 
window, as shown in Figure 11. If you like, you can double-click the 
different files and view them. When you finish, close the files.

Select the Design Analysis pane to examine key reports for area (Report 
Area) and timing (Report Timing) and graphical views of the design, 
including the post-synthesis schematic (View Schematic) and critical path 
(View Critical Path).
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Figure 11: Precision RTL Synthesis Window After Synthesis

2. Select File > Save Project.

3. Choose File > Exit to close Precision RTL Synthesis. At the Are you 
sure you want to exit? prompt, click Yes.

Task 8: Import the EDIF File into Your Project
Now you are ready to import the EDIF file into ispLEVER project. You can 
import EDIF 2 0 0 netlists from third-party synthesis tools, such as Synplify or 
Precision RTL Synthesis, into ispLEVER.

To import an EDIF netlist into your project:

1. In the ispLEVER Project Navigator, choose Source > Import.

2. Go to syn_mux4to1_impl_1 folder within your project, select 
multiplexer4to1.edf, and click Open.

The software adds the selected EDIF file (multiplexer4to1.edf) to 
the project sources, as shown in Figure 12.
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Figure 12: Project Navigator Showing Added EDIF File

Task 9: Fit the Design and View the Report
The ispLEVER software has a single user interface with all options preset to 
deliver the highest possible push-button performance for most devices. When 
you double-click a process, all the processes prior to that process run 
automatically. Therefore, all you have to do is double-click the final process. 
However, here you will run one process at a time and view the results as you 
go.

At the end of a successful fitter run, the ispLEVER software generates a 
JEDEC file, as well as a fitter report so that you can see how the ispLEVER 
software has utilized and routed the part.

Note

After you import an EDIF file into the ispLEVER project, it is always linked to the 
Project Navigator. Therefore, if you make changes and recompile your HDL file to 
create a new EDIF file, your project is automatically updated as well.
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To fit the design and view the report:

1. With the target device selected in the Sources in Project window, double-
click Fit Design in the Processes for Current Source window to run the Fit 
Design process. 

The ispLEVER software successfully fits the design in the specified device 
and generates a JEDEC file. The results are shown in Figure 13.

Optional: If you like, you can right-click on the JEDEC File process and 
select View to create and look at the contents of the JEDEC file. Close the 
file when you are through.

Figure 13: Project Navigator Showing Fitted Design

2. Double-click on the HTML Fitter Report process to open the report in 
your browser, as shown in Figure 14. View the contents and then close 
the report.
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Figure 14: HTML Fitter Report

Task 10: Perform Static Timing Analysis
Static timing analysis is the process of verifying circuit timing by totaling the 
propagation delays along paths between clocked or combinational elements 
in a circuit. The analysis can determine and report timing data such as the 
critical path, setup and hold-time requirements, and the maximum frequency.

The Performance Analyst traces each logical path in the design and 
calculates the path delays using the device’s timing model and worst-case AC 
specifications supplied in the device data sheet.

The timing analysis results are displayed in a graphical spreadsheet with 
source signals displayed on the vertical axis and destination signals displayed 
on the horizontal axis. The worst-case delay value is displayed in a 
spreadsheet cell if there is at least one delay path between the source and 
destination. To more easily identify performance bottlenecks, you can double-
click a cell to view the path delay details.
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To perform timing analysis:

1. In the Project Navigator Sources in Project window, select the target 
device. 

2. In the Processes for Current Source window, double-click the Timing 
Analysis process to run the timing analysis and open the Performance 
Analyst, shown in Figure 15.

Figure 15: Performance Analyst Window

The Performance Analyst performs seven distinct analysis types: fMAX, 
tSU/tH, tPD, tCO, tOE, tCOE, and tP2P. The first type, fMAX, is an internal 
register-to-register delay analysis. fMAX measures the maximum clock 
operating frequency, limited by worst-case register-to-register delay. The 
tP2P type is the path between any two user-specified pins. The remaining 
five types are external pin-to-pin delay analysis. Timing threshold filters, 
source and destination filters, and path filters can be used to 
independently fine-tune each analysis.

3. Under Analysis, select tCO and then click Run.

The tCO path trace analysis reports clock-to-out delay starting from the 
primary input, going through the clock of flip-flops or gate of latches, and 
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ending at the primary output. In this case it is 12.95 ns. Figure 16 shows 
the results of the analysis.

Figure 16: Performance Analyst Window Showing Clock-to-Out Delay

4. Click the highlighted cell (12.95) in the spreadsheet window to open the 
Expanded Path dialog box, shown in Figure 17.

This dialog box enables you to analyze the individual timing components 
used to calculate the timing path. It shows a source pin (From) and a 
destination pin (To). It also shows the delay type, the delay of that path 
(value ns), and the cumulative delay of all the signals.

Note

Your timing numbers may differ slightly.
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Figure 17: Expanded Path Dialog Box.

5. Click Equations to open the Equations dialog box, shown in Figure 18, 
which shows the functional relationship between the selected source and 
the destination.

Figure 18: Equations Dialog Box

6. Close the Performance Analyst without saving.

7. Close ispLEVER without saving.

Summary
You have completed the HDL Design with Precision RTL Synthesis: CPLD 
Flow tutorial. In this tutorial you have learned how to do the following:

Create a new EDIF project in the ispLEVER system and target a device.

Start Precision RTL Synthesis from within ispLEVER, synthesize your 
Verilog HDL design, and generate an EDIF netlist file.

Import the EDIF file into ispLEVER.
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Fit the design, generate a JEDEC file, and view the Fitter report.

Run static timing analysis using the Performance Analyst and view the 
results.

Glossary
Following are the terms and concepts that you should understand to use this 
tutorial effectively.

EDIF. EDIF (Electronic Design Interchange Format) is a format used to 
exchange design data between different electronic computer-aided design 
systems. It is designed to be written and read by computer programs that are 
constituent parts of EDA systems or tools. Its syntax has been designed for 
easy machine parsing and is similar to LISP. The ispLEVER software supports 
EDIF Version 2 0 0.

HDL. An HDL is a hardware description language, which describes the 
structure and function of integrated circuits.

static timing analysis. Static timing analysis is the process of verifying circuit 
timing by totaling the propagation delays along paths between clocked or 
combinational elements in a circuit. The analysis can determine and report 
timing data such as the critical path, setup and hold-time requirements, and 
the maximum frequency.

synthesis. Synthesis is the process of translating a high-level design (RTL) 
description consisting of state machines, truth tables, and/or Boolean 
equations into a process-specific gate-level logic implementation.

Verilog. Verilog is a language for describing the structure and function of 
integrated circuits.

VHDL. VHDL (or VHSIC (Very High-Speed Integrated Circuits) Hardware 
Description Language) is a language for describing the structure and function 
of integrated circuits. 

Recommended Reference Materials
You can find additional information on the subjects covered by this tutorial 
from the following recommended sources:

Precision RTL Synthesis Users Manual

Precision RTL Synthesis Style Guide

Precision Synthesis Reference Manual

Lattice Semiconductor ispLEVER online help

Data sheets, technical notes, and other information on CPLDs on the 
Lattice Web site at http://www.latticesemi.com
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