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HDL Synthesis Design with Synplify: ORCA Flow

This tutorial shows you how to use Synplify from within ispLEVER® to synthesize a
Verilog design and generate an EDIF netlist file. You will implement the design in a
Lattice ORCA FPGA device and prepare the design for ModelSim timing simulation.

Note: If you want to learn how to use Synplify in standalone mode, or understand more about its
advanced features, please download or view the ORCA Synplicity Interface Manual online in PDF format
by selecting Help > ispLEVER Documentation Library in the ispLEVER Project Navigator.

Learning Objectives
When you have completed this tutorial, you should be able to:
e Use ispLEVER to create a new EDIF project and target a device.

e Launch Synplify from within ispLEVER, synthesize your Verilog design, and
generate an EDIF netlist file.

e Import the EDIF file into the ispLEVER.

o Implement the design using the Map, Place, and Route processes and view the
reports.

e Prepare the design for timing simulation using ModelSim.

Time to Complete This Tutorial

The time to complete this tutorial is about 20 minutes.
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Task 1: Create a New Project

To begin a new project, you must create a project directory. Then you must give the
project file (. syn) a name and declare the project type (EDIF).

The ispLEVER software saves an initial design file with the .syn file extension in the
directory you specity. All project files are copied to or created in this directory. The
project type specifies that all design sources will be of this type.

To create a new project:
1. Start the ispLEVER system, if it is not already running.

2. In the Project Navigator, choose File > New Project to open the Create New Project
dialog box.

3. In the dialog box,

o Change to the directory:
<install paths>\ispcpld\examples\tutorial\tutors.

e In the Project name box, type df _aligner.
e In the Project type box, select EDIF.
e Click Save.

2| x|
Save in: Ia butard j i e -

Froject name: |df_aligner.syn Save I

Save as lype: | Project File [* syn) | Cancel
Project type:  |[2a]]3 - Y
24

© 2004 Lattice Semiconductor 3



ispLEVER Tutorials HDL Synthesis Design with Synplify: ORCA Flow

In the Sources window, the project title defaults to untitled. You will change the

project title in the next step.

[ ispLEVER Project Navigator - [C:hispTOOLS),...  kutorial’ 10| =l

File View Source Process Options Tools wWindow Help

D= Al =R AL
|46 = M EB

Sources in Project: Processes for current source: |
Untitled

ispLSISZ5EVE- 165LF256

Starting: 'C:~ispTO0LS-ispcpld-bins~checkini exe -srr=au

Done: completed successfully.

= i=pLEVER Auto-Make Log File ;l
Ll

-
[+ Automake Log / IERN 3
Initializing new project LM o

4. In the Sources window, double-click the project title (untitled) to open the Project

Properties dialog box.

The default title for a new project is "Untitled." You can create a title for the project
with as many characters as you want. The title can contain spaces and any other

keyboard character except tabs and returns.

5. In the Title text box, type Data Frame Aligner and click OK.

Project Properties El

Title:

IData Frame &ligner

k. I Eanu:ell Help |
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Task 2: Target a Device

In the Project Navigator Sources window, there is a device icon % next to the target
device for the project. The Project Navigator lets you target a design to a specific
Lattice device at any time during the design process. A default device for the project is
already selected, but you will target an ORCA FPGA device for this tutorial.

To view the list of available devices and to change the target device:

1. In the Sources window, double-click the target device name to open the Device
Selector dialog box. The Device Selector dialog box shows the default device as
well as all available devices and their options.

x

— Select Device: — Device Information:
F arnily: Device: ;
ardell I Status: Production
MACH 4 Low Yalkage ;I ordell Denzity:
MACH & hﬂ_
MaACH 5 A ordels Logic cells: 10368
PACH 5 Low Yalkage
or2cl0a [0 cells: BEE
or2t00a )
artinG [0 pinz: 264
E:gi:ﬂ%[l; Dedicated input; -
o300 COutput enable:

loe:
Speed grade: [_] Fackage twpe:

[3 RAREEE |
Cperating conditions:
I Cormmercial j

Part M arne:
| or4e04-3B4352C =
Cancel Help
In the dialog box:

e Under Family, select or4e00 from the drop-down list.
e Under Device, select orde04.

e Click OK.

2. In the message box, click Yes to change device Kkits.
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Confirmn Change

3

f'ou are about to change Device kitz. Thiz
will rezult in changes in the Project Mavigatar
deszign efwiranment, Do you wizh o continue
with this operation’?

o |

HDL Synthesis Design with Synplify: ORCA Flow

X

3. Your Project Navigator should look like this:

@ ispLEYER Project Mavigator - [C:hispTOOLS",..., Euko
File Wiew Source Process

Options

Tools  Window  Help

IDs®E =G
|46 = F4 3 38 f
Snources in Projeck: | Processes For current source:
Data Frame Aligner 73 Build Database
‘ Docurments & Pre-Map Logical Design Floorplan

or4e04-36A4352

73 Map Design

=] Map Report

=} Map TRACE Report

Post-Map Physical Design Floorplan

X, Constraint Editar

X, Edit Constraints {ASCII)
G Map Timing Checkpoink
3 Place & Rouke Design
=} Place & Route Repart
=} PAD Specification File
=} FPlace & Route TRACE Repart
=] HTML Flace & Route Report
G Cycle Skealing
K Post-PAR Design Floorplan
*,, EPIC Device Editor
Flace & Route Timing Checkpoint
Generate Timing Simulation Files
Generate Gitstream Daka
@ Bitstream Report
73 Generate PROM Data

[E] PROM Report

[ "
=
b
(&

:’:IH% Revision Contrals {OFF)

la

i=plEVER Auto—-Malke Log File

Starting: 'C:ispTO0LS~i=pcpld

Done: completed successfullwy.

=10 x|

A+ Automake Log / 4| 3

Ready

[ o[ 4
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Task 3: Create a Synplify Project

For HDL designs, the ispLEVER software provides two synthesis tools that are
integrated into the Project Navigator environment: Synplify for Lattice (Synplify) and
LeonardoSpectrum. You can synthesize your Verilog or VHDL design as a standalone
process by choosing the synthesis tool from the Lattice Semiconductor program group
in your Start menu, or you can synthesize automatically and seamlessly within the
Project Navigator.

About Synplify

Synplify is a logic synthesis tool that starts with a high-level design written in Verilog
or VHDL hardware description languages (HDLs). Then Synplify converts the HDL
description into small, high-performance, design netlists that are optimized for Lattice
devices.

To start Synplify:

1. In the Project Navigator, choose Tools > Synplify Synthesis to open the Synplify
synthesis tool in the Project view.

! <no projects loaded= =10 =

Synplify” <> I

Synplicity

Simply Beoter Results

Sournce Files

Add | <load project

I:hungel Freguency (MHz) |EI 3
Edit I

Fesult File
Dhangal

Target
Ehangﬂl <click (o open projects
Wiew Log

Fun == Ready ...

Cancel

e

| v -

2. Choose File > New to open the dialog box. In the dialog box, do the following:
e Under File Type, select Project File
o Under File Name, type syn_aligner
e Under File Location, make sure you are in the tutor8 folder
e Click OK

© 2004 Lattice Semiconductor
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File Type:

Tewt File
@ Tcl Script
WHOL File Cancel
Yerilog File

[ Constraint File [Scope)
...... Praject File [Project]

Ui

Help

File: Mame:
Isyn_aligneri

File: Location:
IEI: WzpTOOLS ispopldhexamplesitutorialtutard J

Full Path:
IC: 4igpTOOLS vigpopldhexamplestutorialyutor3hayn_aligner. pri

3. The Synplify screen should look like this:

EaiE:"-.,ispTDEIL5"-.,ispcpld"-.,l:ul:urial"-.,l:ul:uriaI_B"-.,syn_aligner.prj - | I:Ilil
Sy Ilpllf e
Source Files Synphcgty
Al | C:‘\ispTEII:ILS"?is|:|cplI:I"\tHtmial\tutarial_ﬁ"ﬂexf_1 I Simply Better Results
El@ syr_aligner [project]
LW rev 1 [syn_aligner)
Changel Frequency (MHz) |1 3:
Edit |
FesultFile
Changel syh_aligner.edn
Target
ChangE!| Lattice ORCA Series 4 ; 4E0Z . BA3ISZ -3, maxfan: 100, forcegsr auto
Wiew Log R d
BEun —— Ea y Ty
Cancel
/| | v
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Task 4: Add the Verilog Source Files

In this task you will add Verilog source files to the project.

To add source files to the project:

1. On the Synplify main window, click Add to open the dialog box. You should see
one Verilog file named aligner.v.

2. Select the file and click Add to add the Verilog file to the project (shown in the
Files To Add To Project field).

Select Files to Add to Projeck 7] x|

Look in: |ﬁ butard j - £ E2-
Drev_l

aligner.w

File name: Ialigner.'-.f

Files of type:  |HDL Files [ vhd:v] |

Filez To&dd Ta Project;
C:hiepTO0OLS igpopldhexamplestutonalstutar8haligrer. « <= ddd All

<- tdd
Remowve All -
Remove -»

ok

4] | ﬂ Cancel

i e

3. Click OK to close the dialog box.
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4. In Synplify, expand the verilog folder. The Synplify screen should look like this:

Synplify - [C:\ispTOOLS ispcpld\examples’ tutorial' tutord' syn_aligner.prj *] - | Ellil
H@ File Edit Wiew Project Run HOL Analyst Options  Window Help _|ﬁ||5|‘
E=C o = o=
[PEOSHGE| a8 a [0 F2 |82
Sy Ilpllf ® —»
Source Files Synphczty
Add | C:hispTOOLSNispopldhexampleshtutar. . I rev_1 Tupe Simply Better Results
=62 spn_gligner [project]; o
-3 verilog
Changel P dlignerv Freguency (MHz) ID 3
rev_1 [aligrer)
. Symbolic FSM Compiler @
Edit |
Fesource Sharing v
K I 2
Result File
Changel syn_aligner.edf
Target
Change | Lattice ispXPGA : LFX1200B : 680feBGA : -5
Wiew Log R d
Eun —— Ea y ra
Cancel
@ syn_aligner.pril
[ [

10
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Task 5: Set Implementation Options

Synplify has probably set your implementation options correctly. However, it is good
practice to check them.

To set the implementation options:

1. Below the Source Files project window, click the Change (Results File) button to
open the dialog box.

Edif Result File 2=l
Lok in: |@ rew_1 = = cF EF-

File narne: Ialigner.edn oK. I
Files of type:  [EDIF (~.edn) =l Cancel |

.

This dialog box allows you to change the file name or destination of the output
EDIF file. In this tutorial, we will not change anything so all our project files remain
in our current project directory. Notice that Synplify automatically creates revision
folders inside your project folder. You should be in the rev_1 folder, inside your
project folder.

2. Click Cancel to close the dialog box.

3. Below the Change (Results File) button, click the Change (Target) button to open
the dialog box.

Dptions for innplementation: syn_aligner : rev_1 x|
Devce | Dutn&funshaﬂzl Implerneralion Hesuhl Timig F!ennltl 'v"eringl
Implemertatione:
Technology Fait: Speed: Fackage h
[Lakce ORCA Serec 4 =] | OB ) [2 =] [s222 =]
Device Mapoing O plions
Ipgion E Walup -
Fanout Cuids Com
Dizabale 00 Inserion I
o e
hd
Optan Desenphon
Clck on an oplion for & desciiplion {'_j
Synplicily
Ok | Cancz Aoy Help |
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4. Under Technology, select Lattice ORCA Series 4. Under Part, select 4EO4. Click
OK to close the dialog box.

5. Click the large Run button to start the synthesis process. Synplify synthesizes the
Verilog design and creates an EDIF file, as well as several other files, and displays
them in the window. If you like, you can double-click the different file names and
view them. When you are finished, close the files.

synplify - [ChispTOOLS ispcpldiexamples’tutorial'tutor8'syn_aligner.prj *] =100 x|

[ Ele Edt Yiew Project Run HOL Analyst Options Window Help -Iﬂlﬁl‘

PECSFHOE BB s OG0T 2 |82

Synplify’ >

Synplicity

Source Files
Add | C:'\|spTDDLS'~.«|spcpld\?xamples\tutorl... I IB'\-'_.'I . Tupe Simply Better Results
EI@ zyr_aligner [project] o @ aligner.edn  file
Ch =23 verilag : aligner.prf  Constraints
angel aligner.y ->MOTES: & L alignersm  Gate Metlist Fraguency (tMHz) m

! rev_1 [aligrer) ; @ aligner.zm  logfile ] ]
@aligner.srs RTL Wetlist Symbolic FSM Compiler ¥

Edit
—l o alignertly  file

FResource Sharing rd
KN I 1
ResultFile
Change | aligner.edn
Target
Changel Lattice ORCA Series 4 : 4E04 : BAZ52 © -2, maxfan: 100, forcegsr auto
Wiew Log D
Pun =21 Done!
Cancel
-@ syn_aligner.prj
[ [ [

6. Choose File > Save to save the Synplify project.

7. Choose File > Exit to exit Synplify. The Project Navigator Main window will be
activated again for the next task.
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Task 6: Import the EDIF File into Your Project

Using the Project Navigator, you can import EDIF 2.0.0 netlists from third-party
synthesis tools, such as Synplicity Synplify, into ispLEVER. In this task, you will
import the EDIF netlist you synthesized in the previous task into your project.

To import the EDIF netlist you synthesized into your project:

1. In the ispLEVER Project Navigator, choose Source > Import to open the dialog
box.

2. Go to the rev_1 folder, select aligner.edn, and then click Open.

Lok, in; |@ rev_1 j - £ B~

aligrer . edn

File name: Ialigner.edn Open I
Files of twpe: ISources [tk ed™ vhd;...] j Cancel |

.

3. In the Import EDIF dialog box under CAE Vendors, select Synplicity and click
OK.

ImporteDIF x|
EDIF File: Mrev_1%aligner.edn
— Impart ag:
Ok
" Custom |—I
£ Sumbal £ Met Cancel |
\-’EEI
ENDI Help |
" CAE Wendors
E wemplar
SEHDESES
Yiewlogic

[T Setfor all the following imported EDIF sounces

© 2004 Lattice Semiconductor 13
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The software adds the selected EDIF file (aligner.edn) to the project sources.

=101 %]

E ispLEYER Project Mavigator - [C:\ispTOOLS".. .\ Euko
Tools  Window  Help

File Miew Source Process

Options

HDL Synthesis Design with Synplify: ORCA Flow

R ael=ET .

|D= |
|46 = ™ 22 [

Processes For current source;

Sources in Project:
Data Frame Aligner
‘ Docurments

ordeld-364352
(. @ aligner (aligner.edn)

2 Build Database

K Pre-Map Logical Design Floorplan
3 Map Design

2] Map Report

=) Map TRACE Report

Post-Map Pheysical Design Floarplan

&, Constraint Editor

&, Edit Constraints (ASCII)
2 Map Tiring Checkpoink
3 Place & Route Design

2] Place & Route Repart

=) PAD Specification File

=] Place & Route TRACE Report

=] HTML Place & Route Report

3 Cycle Stealing

K Post-PAR. Design Floorplan

&, EPIC Device Editor
G Plare & Route Timing Checkpoink
3 Generate Timing Sirulation Files
G Gaenerate Bitstream Data

@ Bitstream Repork

¥} Generate PROM Data

() PROM Report

ﬁ'% Revision Conkrols (OFF)

Feading 'aligner . edn' file

Writing out design hierarchy o

EDIF Compiler finished success

Done: completed successfully.

[>T+ Automake Log / 1] ¥

2

Ready

[ o[

Note: After you import an EDIF file into the ispLEVER project, it is always linked to the Project
Navigator. Therefore, if you make changes and recompile your HDL file to create a new EDIF file,

your project is automatically updated as well.

© 2004 Lattice Semiconductor
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Task 7: Map the Design

In this task you will review Map options, run the Map program, and view the Map
report. Using the EDIF netlist file you synthesized and imported into Project Navigator
as input, you will actually run two processes, Build and Map. Before mapping can
occur, the Build process automatically translates and builds your netlist into an ORCA-
based database file. The ispLEVER software automatically does this netlist conversion
when you start the Map process.

About the Map Process

Mapping is the process of converting a design represented as a logical network of
device-independent components (e.g., gates and flip-flops) in the input logical design
file into a network of device-specific components, e.g., programmable functional units
(PFU) to be placed on the physical device represented in the post-map physical design
(.nca) file. Before mapping occurs, the EDIF netlist input is automatically converted
into a logical generic database file (.ngd) in terms of ORCA FPGA primitives during
the Build operation. After mapping, the resulting physical description is output to a
Physical Design file (.ncd), in terms of the components in the target architecture. This
physical design can then be placed and routed.

Also note that the resulting mapped .ncd files may include information based on user-
defined attributes (ORCA properties) specified in the input netlist. For example, a
property may specify where a component in the logical design must be placed in the
physical device, or what nets should be given the highest priority when the design is
routed. You can also use the ORCA Floorplanner to define component and regional
grouping in the pre-map .ngd file in the logical domain and/or in the post-map .ncd in
the physical domain.

To learn more about the Map process, refer to the "Mapping A Design" topic in the
ispLEVER Help system. To learn more about using attributes (properties) in your
netlist, download or view the ORCA Properties for Design Entry Desk Reference guide
in PDF format using the Project Navigator: Help > ispLEVER User Documents
command. See appropriate topics on floorplanning in ispLEVER for more on that
subject.

To review Map properties, run the Map process, and view the Map report:

1. Before you run the Map program, you can set Map properties. Many ispLEVER
processes have associated properties, which are displayed in the Properties dialog
box.

With the target device selected in the Sources window, right-click Map Design in
the Processes window and choose Properties from the popup menu to open the
dialog box.

© 2004 Lattice Semiconductor 15
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roperties- (Normal : Design}

Properties

9]

Hierarchical b apping

Guide Filename

Fack Logic Block Ll [0-100]
Softwire Lookup UL [0-10]

Overmap device if design does nat fit

Mum

Mum 8

T/F False
Advanced Oplions

Teuxt

T/F Falze

Select the edit region and type in a numenc value, Press the OF/Cancel
buttons left of the text when vou are done

Cloze
e

Defaults

Help

E LR |

Properties can be True/False, List, or Text/Number. Accept the default properties
and click Close to close the dialog box. Now you are ready to map the design.

In the Processes window, double-click the Map Design process. When the process
is completed, a green check mark appears next to the Build Database processes.
(Don’t worry about the warning for Map Design.)

[ ispLEYER Project Navigator - [C:hispTOOLSY..." Euta

File ‘iew Source Process Options Tools Window  Help

=10 ]

D= M|

e a2

=
|4 = = 22 Bt

Sources in Project:

| | Processes For current source: |

ata Frame Aligner

B Documents
orde04-36A352
[ @ aligner {aligner.edn)

VG Build Database
& Pre-Map Logical Design Floorplan
¥ "3 Map Design
4 [E) Map Report
[2) Map TRACE Report
Post-Map Physical Design Floorplan
& Constraint Editor
&, Edit Constraints (ASCI)
0 IMap Timing Checkpoint
73 Place & Route Design
[Z) Place & Route Report
2] PAD Specification File
2] Place & Route TRACE Report
[Z) HTML Place & Route Report
O Cycle Stealing
& Post-PAR Design Floorplan
&, EPIC Device Editor
0 Place & Route Timing Checkpaint
¥y Generate Timing Simulation Files
0 Generate Bitstream Data
@ Eitstreamn Repark
O Generate PROM Data
(2 PrOM Report

| % Revision Contrals (OFF) | j
Al 4
Done: completed successfully.
=
-
[T Automake Log / Bl E
Ready MLIM 5
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3. Double-click the Map Report process to open in the map report in the Report

Viewer.
¥ Report Yiewer - [df_aligner.mrp] - |E||i|
File Edit “Wiew Options window Help 18| x|

Lattice Mapping Feport File for Design 'aligner' -

Copyright (=) 1991-1994 by NeoCAD Inc. All rights reserved. =
Copyright (o) 1995 e

ATE&T Corp. All rights reserved.
Copyright (c) 1995-2001 Lucent

Technologies Inc. All right=s reserved.
Copyright {c) 2001 Agere Systemns

A]1]1 right=s reserved.
Copyright (c) 2002 Lattice Semiconductor Corporation,
All rights reserved.

De=sign Information

Command line: o ispTOOLS~1i=spf pga~bin~nt~mnap —a ord4ell -p ordeld -t BAILZ
df_aligner ngd —o df_aligner.ncd —f di_aligner.mZt

Target Vendor: LATTICE

Target Dewvice: ordeld4BA3GZ

Target Speed: 3

Happer: ordell, wersion: i1splever wi_Beta Test_Build (53c)

Happed on:

< | _lJ
[Cn 1 Cald [zo4g [ [RO Rec Off [Nowiap [DOS NS [NUM

The Map Report (.mrp) file is an ASCII file containing information about the MAP
command run. The .mrp file lists any DRC errors found in the design, details how
the design was mapped (e.g., the schematic constraints specified, the logic that was
removed or added, and how signals and symbols in the logical design were mapped
into signals and components in the physical design). It also supplies statistics about
component usage in the mapped design and contains information about the Map
Design process run.

4. View the report and then choose File > Exit to exit the Report Viewer.

© 2004 Lattice Semiconductor 17
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Task 8: Place & Route the Design

After a design has undergone the necessary translation to bring it into the physical
design format, you can run the Place & Route Design process (PAR). This process takes
a mapped physical design file (.ncd), places and routes the design, and outputs another
-ncd file.

About the Place & Route Process

PAR works in timing-driven mode. The timing-driven approach uses the constraint file
and various cost tables that assign weighted values to relevant factors such as
constraints, length of connection, and available routing resources.

The PAR process places the mapped physical design file (.ncd) in two stages: a
constructive placement and an optimizing placement. PAR writes the physical design
after each of these two stages completes.

Routing is done in two stages: iterative routing and delay reduction routing (also called
cleanup). PAR writes the physical design file (.ncd) only after iterations where the
routing score has improved. During iterative routing, the router performs an iterative
procedure to converge on a solution that routes the design to completion or minimizes
the number of unrouted nets. During reduction routing, the router takes the result of
iterative routing and re-routes some connections to minimize the signal delays within
the device.

To run Place & Route and view the reports:

1. In the Processes window, double-click the Place & Route Design process. The
1spLEVER software places and routes the design in the specified device and
generates the Place & Route Report. When the process is completed, a green check
mark appears next to the Place & Route process. (Don’t worry about the warnings.)

18 © 2004 Lattice Semiconductor
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@ ispLEYER Project Mavigator - [C:ispTOOLS",...  Eukol

File Miew Source Process

Cipkions

Tools window  Help

=101 x|

EEX] ACEFIEE TR
|46 = 1 22 B
Sources in Projeck: | Processes For current source: |
[Data Frame Aligner &” '3 Build Database
‘ Documents & Pre-Map Logical Design Floorplan

ar4e04-3BA4352
s @ aligner {aligner.edn)

&”'3 Map Design
@# =] Map Report
=} Map TRACE Report
X, Constraint Editor
@”' % Map Timing Checkpaint
i

{73 Place & Route Design
v

G Cycle Stealing

¥, EPIC Device Editor
73 Generate Timing Simulat

@ Bitstream Repork

[5) PROM Report

Post-Map Physical Design Floorplan
X, Edit Constraints {ASCI)
=} Place & Route Report
=} PAD Specification File
=} Flace & Route TRACE Report
[Z} HTML Place & Route Report

& Post-PaR Design Floorplan

G Place & Route Timing Checkpoint

ion Files

G Gaenerate Bitstream Data

G Generate PROM Data

j"% Revision Controls (OFF)

PNES

[

A4l]l =i1gnals are completely rou

par donel

Done :

conpleted successfully.

—
[, Automake Log / 1] ¥

Ready

[ 4

2. Double-click the Place & Route Report process to open the PAR report file (.par)
in the Report Viewer. The .par file contains execution information about the Place

& Route command run. The report also shows the steps taken as the program

converges on a placement and routing solution.

© 2004 Lattice Semiconductor
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¥ Report Yiewer - [df_aligner.par] 10| =]

File Edit Yiew Options Window Help 18| x|

———— Multipar Tool Eeport File ———

_Test_Build (53c).

Copyright {c) 1991-1994 by NeoCAD Inc. All rights reserved.

Copyright (o) 1995 ATAT Corp. All rights reserwved.

Copyright (c) 1995-2001 Lucent Technologies Inc. All rights reserwved.
Copyright {c) 2001 Agere Systemns All rights reserved.

Copyright (c) 2002 Lattice Semiconductor Corporation, All rights reserved.
Wed Dec 11 15:11:05 2002

-

C o igpTO0LS~i=pFPGA~bin~nt~par —-f df_aligner . pit di_aligner map.ncd
di_aligner.dir df_aligner. pri

Freference file: df aligner prf.

Levels Humber Timing RFun HCD
Cost [ned] Unrouted Score Time Status
51 * 1] 1] 40 Complete

* : De=zign saved.

par done!

FAR: Place And Route isplever w3 Beta Test Build (&53c).

Copyright (c) 1991-1994 by HeoCAD Inc. All rights reserwed.

Copyright {c) 1995 ATAT Corp. All rights reserwved.

Copyright (o) 1995-2001 Lucent Technologies Inc. All rights reserwved.
Copyright (c) 2001 Agere Sy=temns A]1]1 right=s reserved.

Copyright {c) 2002 Lattice Semiconductor Corporation. All rights reserved.
Wed Dec 11 15:11:05 2002

c:nispTOOLS~ispFPGASNbBin~nt~par —-f df_aligner pZt df_aligner map.ncd
di_ aligner.dir df aligner . pri

Freference file: di_aligner.pri.

Flacement lewvel-co=t: 5-1. =
< | _I'I
[Cn T Cald [157 [ [ROD Rec Off [Mo'wrap [DOS [NS [NOM [

3. View the report and then choose File > Exit to exit the Report Viewer.
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Task 9: Prepare for Simulation

The ispLEVER software supports third-party timing simulation with ModelSim™ from
Mentor Graphics®. Using this integrated package, you can simulate a single Verilog
design within one environment.

About Timing Simulation

Where as timing analysis returns partial timing information, dynamic timing simulation
will give you detailed information about gate delays and minimum and worst-case
circuit conditions. Because total delay of a complete circuit will depend on the number
of gates the signal sees and on the way the gates have been placed in the device, timing
simulation can only be run after the design has been implemented.

Timing simulation also requires several input files to run a Verilog netlist, a delay file,
and a test fixture. The netlist and delay files are automatically generated from within
ispLEVER. The test fixture must be written before hand.

To create the timing simulation files and start ModelSim:

1. In the Processes window, double-click the Generate Timing Simulation Files
process. The software writes two files to the project directory: df aligner.v (the
Verilog netlist) and df _aligner.sdf (the standard delay file). (Ignore the

warnings.)
[ ispLEYER Project Navigator - [C:ispTOOLS'...\b - | Ellll
File View Source Process Options Tools Window Help
(== lEXE|mE 2R
|4 = W = @ of|
Sources in Project: | Processes for current source: |
ata Frame Aligner @#'33 Build Database

ocuments & Pre-Map Logical Design Floorplan

) or4e04-3BA352 @?' 3 Map Design
i @ aligner {aligner.edn) (f Map Repart
[2] Map TRACE Repart
Past-Map Physical Design Floorplan

& Constraint Editor
& Edit Constraints (ASCIT)
@#'3 Map Timing Checkpoint
@?'3 Place & Route Design
M [E] Flace & Route Report
@# =] PAD Specification File
2] Place & Route TRACE Report
[E] HTML Place & Rouke Repart
O Cycle Stealing
K Past-PAR Design Floorplan
& EPIC Device Editor
O Place & Route Timing Checkpaoint
3 Generate Timing Simulation Files
O Generate Bitstream Data
@ Bitstream Report
O Generate PROM Data
[2) PROM Report

El Revision Controls (OFF) H[environnent c:~1=pTO0LS i=pFPG |
Al Package: Version 1.14. Status:
Converting design "df_aligner.:
Loading preferences from "df_a
Writing Verilog netli=t to fils
Writing SDF timing to file df_.

le

Done: completed successfully.

—
[T+ Automake Log / Eill IO
Ready [ [mom y
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2. To run ModelSim for timing simulation, in the Project Navigator choose Tools >

3.

22

ModelSim Simulator.

[7]ModelSim LATTICE 5.6e - Custom Lattice ¥ersion =0 =]
File Edit WYiew Compile Simulate Tools Window Help
S BR B R

‘El # Reading c: AzpTO0OLS /modelzimydtelAesimApref. el =
Hame ModelSim>

[Ilwnrk [Lnavailable
[l HEOPRIMS
=+l NEOPRIMS_vig
=l ORCaz
m- il ORCa2e_vig
m-Jlll ORCA2_vig
m- il ORCA3
m-Jlll ORCA3 vig

=l ORCas T
D

Library |

|-:iN|:| Design Loaded=

o

Note: To complete this task, you would need a Verilog test fixture file, which is not
included as part of this tutorial.

Close ModelSim.
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Congratulations

You have completed the HDL Synthesis Design with Synplify tutorial. In this tutorial
you have learned how to:

Use ispLEVER to create a new EDIF project and target a device.

Launch Synplify from within ispLEVER, synthesize your Verilog design, and
generate an EDIF netlist file.

Import the EDIF file into the ispLEVER.

Implement the design using the Map, Place, and Route processes and view the
reports.

Prepare the design for timing simulation using ModelSim.
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